Обзор

COM-объект iiko1CInterface

Обмен данными между системами iikoRMS/iikoChain и внешними системами возможен с использованием библиотеки iiko1CInterface. Эта библиотека написана на C# и является COM-объектом. Далее в документе рассматривается применение этой библиотеки для интеграции систем iiko с системой 1С.

  • Структура
  • Установка
Структура

На рисунке ниже приведена структурная схема интеграции 2-х систем, состоящая их следующих блоков:

  • 1С Бухгалтерия – ПО фирмы 1С (http://v8.1c.ru/)

  • Внешний обработчик – Разрабатывается в компании Айко, поставляется вместе в iikoRMS/iikoChain. Реализует основную функциональность интеграции, такую как, загрузка данных из iiko в 1С Бухгалтерия: Приходная накладная, Акт реализации, и т.д. Более подробно о возможностях внешнего обработчика можно прочитать в документации «iiikoOffice Руководство пользователя»

  • COM-объект – Разрабатывается в компании Айко. Выполняет основную работу по установке соединения и обмена данными с сервером iiko. Предоставляет сторонним разработчикам API, приведенный в этой документации, взаимодействия с сервером iiko.

  • Сервер – сервер iikoRMS или iikoChain

  • БД – база данных системы iiko

Установка

COM-компонент, которым является библиотека iiko1CInterface, для работы в ОС Windows предварительно должен быть установлен в системе. Установку можно выполнить в автоматическом и ручном режиме.

  1. Автоматический - iiko1CInterface устанавливается (обновляется) с помощью инсталлятора iikoRMS. Чтобы установить, нужно в списке устанавливаемых компонент указать для установки: "Интеграция с 1С". Данный режим является рекомендуемым режимом установки.

  2. Ручной – iiko1CInterface устанавливается с помощью приложения iiko1CManager, входящего в поставку iikoRMS/iikoChain. Ручной режим может потребоваться для установки библиотеки на компьютер, где не установлен iikoRMS/iikoChain (например, на сервере 1С, при использовании 1С в серверном, а не файловом режиме).

Библиотека iiko1CInterface.dll (со всеми необходимыми зависимостями), документация, утилита iiko1CManager после установки iikoRMS/iikoChain располагаются в директории: "C:\Program Files (x86)\iikoRMS\Выгрузка в 1С\Bin"

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


Примеры кода

Процесс загрузки документов с сервера iiko можно разделить на 4 этапа

  1. Создать класс загрузчика

  2. Создать фильтр загрузки документов

  3. Подключиться к серверу

  4. Выполнить последовательное чтение документов

Базовый класс загрузчика: DocumentLoader

Примечание Примечание

В предыдущих версиях библиотеки использовался класс загрузчика: InvoiceDataLoader. Он считается устаревшим и не рекомендуется к использованию).

Загрузка приходных накладных
Копировать
loader = Новый COMОбъект("iiko1CInterface.DocumentLoader");                                       // Создание COM-объекта "загрузчик"
filter = Новый COMОбъект("iiko1CInterface.DocumentFilter");                                       // Создание COM-объекта "фильтр загрузки"
filter.DateFrom=НачПериода;                                                                       // Настройка фильтра загруки
filter.DateTo=КонПериода;                                                                         // (указание периода)
invoces = loader.LoadInvoiceData("http://localhost:8080/resto/", "admin", "resto#test", filter);  // Подключение к серверу
invoce = invoces.GetFirstInvoiceData();                                                           // Чтение первого документа
Пока истина Цикл                                                                                  //
  Попытка                                                                                         // Чтение следующего документа
    invoce = invoces.GetNextInvoiceData();                                                        // (если он существует)
  Исключение                                                                                      //
    Прервать;
  КонецПопытки;
КонецЦикла;


История версий

  • 1.0.0.0 (11 сентября 2011)
  • 4.0.0.0 (1 октября 2014)
  • 5.0.0.0 (1 мая 2019)
  • 5.1.0.0 (1 сентября 2020)
  • 5.2.0.0 (1 июня 2021)
  • 5.2.1.0 (1 ноября 2021)
1.0.0.0 (11 сентября 2011)

  • Основная функциональность

4.0.0.0 (1 октября 2014)

  • Добавлены интерфейсы для классов

  • Создан проект документации

  • Созданы тестовые проекты

  • Добавлены модули тестирования

5.0.0.0 (1 мая 2019)

  • Добавлена поддержка Возвратов от покупателя (IIncomingReturnedInvoice)

5.1.0.0 (1 сентября 2020)

  • Метод IDocumentLoader.LoadIncomingServiceData(String, String, String, IDocumentFilter) теперь возвращает объект типа IIncomingServices, предоставляющий доступ к объектам типа IIncomingServiceData

  • Метод IDocumentLoader.LoadOutgoingServiceData(String, String, String, IDocumentFilter) теперь возвращает объект типа IOutgoingServices, предоставляющий доступ к объектам типа IOutgoingServiceData

  • IIncomingServiceData теперь предоставляет доступ ко всем полям документа, а не только к AccountName и AccountCode

  • IOutgoingServiceData теперь предоставляет доступ ко всем полям документа, а не только к RegisterNumber, SessionNumber, AccountName и AccountCode

  • Из Менеджера регистрации убрана проверка устаревших библиотек

5.2.0.0 (1 июня 2021)

В следующие интерфейсы добавлены поля для получения кода ТН ВЭД ЕАЭС элемента номенклатуры:

  • IDisassembleItem
  • IIncomingReturnedInvoiceItem
  • IInternalTransferItem
  • IInventoryItem
  • IInvoiceItem
  • IOrderDocumentItem
  • IOrderSaleItem
  • IOutgoingInvoiceItem
  • IProductionItem
  • IReturnedInvoiceItem
  • ISaleDataItem
  • ISaleItem
  • IWriteoffDocItem
5.2.1.0 (1 ноября 2021)

Минимальная версия iiko: 7.9.1

  • В IMenuItem добавлено свойство OuterEanCode


Классы

Пространства имён
Пространство имён | Описание
iiko1CInterface.Interfaces | Интерфейсы взаимодействия в библиотекой


iiko1CInterface.Interfaces - пространство имён

Интерфейсы взаимодействия в библиотекой
Интерфейсы
 | Интерфейс | Описание
Открытый интерфейс | IAssemblyChart | Интерфейс технологической карты
Открытый интерфейс | IAssemblyChartItem | Интерфейс элемента технологической карты
Открытый интерфейс | IAssemblyChartList | Интерфейс списка технологических карт
Открытый интерфейс | ICashFlow | Интерфейс движения денежных средств
Открытый интерфейс | ICashFlows | Интерфейс загрузки движения денежных средств
Открытый интерфейс | IChoiceBinding | Интерфейс модификатора
Открытый интерфейс | IChoiceBindingInfo | Интерфейс информации о модификторах блюда
Открытый интерфейс | IChoiceBindingInfoList | Интерфейс списка информаций о модификаторах
Открытый интерфейс | IDisassemble | Интерфейс акта разбора
Открытый интерфейс | IDisassembleItem | Интерфейс вложенной товарнной позиции акта рабора
Открытый интерфейс | IDisassembles | Интерфейс загрузки актов рабора
Открытый интерфейс | IDocumentFilter | Интерфейс загрузки документов
Открытый интерфейс | IDocumentLoader | Интерфейс загрузки документов
Открытый интерфейс | IEmloyeeTimeSheet | Интерфейс описания учета рабочего времени
Открытый интерфейс | IEmloyeeTimeSheetCut | Интерфейс описания учета рабочего времени
Открытый интерфейс | IEmloyeeTimeSheetCuts | Интерфейс загрузки учета рабочего времени
Открытый интерфейс | IEmloyeeTimeSheetItem | Интерфейс вложенного элемента учета рабочего времени
Открытый интерфейс | IEmloyeeTimeSheets | Интерфейс загрузки учета рабочего времени
Открытый интерфейс | IIncomingReturnedInvoice | Интерфейс вложенных возвратов от покупателя.
Открытый интерфейс | IIncomingReturnedInvoiceItem | Интерфейс товарных единиц по возврату от покупателя.
Открытый интерфейс | IIncomingReturnedInvoices | Интерфейс загрузки возвратов от покупателя.
Открытый интерфейс | IIncomingServiceData | Интерфейс актов приема услуг
Открытый интерфейс | IIncomingServices | Интерфейс загрузки актов приема услуг
Открытый интерфейс | IIntegration | Интерфейс загрузки справочников
Открытый интерфейс | IInternalTransfer | Интерфейс вложенных внутренних перемещений
Открытый интерфейс | IInternalTransferItem | Интерфейс товарных единиц внутренних перемещений
Открытый интерфейс | IInternalTransfers | Интерфейс загрузки внутренних перемещений
Открытый интерфейс | IInventories | Интерфейс загрузки инвентаризаций
Открытый интерфейс | IInventory | Интерфейс вложеных инвентаризаций
Открытый интерфейс | IInventoryItem | Интерфейс товарных единиц инвентаризции
Открытый интерфейс | IInvoiceData | Интерфейс вложенных приходных накладных
Открытый интерфейс | IInvoiceDataLoader | Класс загрузки приходных накладных
Открытый интерфейс | IInvoiceItem | Интерфейс товарных единиц по накладной
Открытый интерфейс | IInvoices | Интерфейс загрузки приходных накладных
Открытый интерфейс | IMenuGroup | Интерфейс номенклатурной группы
Открытый интерфейс | IMenuItem | Интерфейс номенклатурного элемента
Открытый интерфейс | INomenclature | Интерфейс номенклатуры
Открытый интерфейс | IOrder | Интерфейс заказа
Открытый интерфейс | IOrderDiscountItem | Интерфейс позиции скидки в заказе
Открытый интерфейс | IOrderDocumentItem | Интерфейс вложенного элементы заказа (линейное представление)
Открытый интерфейс | IOrderPaymentItem | Интерфейс позиции оплаты в заказе
Открытый интерфейс | IOrderSaleItem | Интерфейс позиция продажи в заказе
Открытый интерфейс | IOrdersDocument | Интерфейс документа заказов (счетов)
Открытый интерфейс | IOrdersDocuments | Интерфейс загрузки заказов (счетов)
Открытый интерфейс | IOrderWriteoffItem | Интерфейс позиции удаления со списанием в заказе
Открытый интерфейс | IOutgoingInvoice | Интерфейс описания вложенных расходных накладных
Открытый интерфейс | IOutgoingInvoiceItem | Интерфейс товарных единиц по расходной накладной
Открытый интерфейс | IOutgoingInvoices | Интерфейс описания вложенных расходных накладных
Открытый интерфейс | IOutgoingServiceData | Интерфейс актов оказания услуг
Открытый интерфейс | IOutgoingServices | Интерфейс загрузки актов оказания услуг
Открытый интерфейс | IProduction | Интерфейс вложений акта приготовления
Открытый интерфейс | IProductionItem | Интерфейс расходных товарных единиц по актам приготовления
Открытый интерфейс | IProductions | Интерфейс загрузки актов приготовления
Открытый интерфейс | IProfitTaking | Интерфейс описания вложенных актов реализации
Открытый интерфейс | IProfitTakingItem | Интерфейс товарных единиц по накладной
Открытый интерфейс | IProfitTakings | Интерфейс загрузки приема кассовой выручки
Открытый интерфейс | IReturnedInvoice | Интерфейс вложенных возвратных накладных
Открытый интерфейс | IReturnedInvoiceItem | Интерфейс товарных единиц по возвратной накладной
Открытый интерфейс | IReturnedInvoices | Интерфейс загрузки возвратных накладных
Открытый интерфейс | ISaleData | Интерфейс вложенных актов реализации
Открытый интерфейс | ISaleDataItem | Интерфейс товарных единиц по акту реализации
Открытый интерфейс | ISaleItem | Устарело. Интерфейс товарных единиц по акту реализации
Открытый интерфейс | ISales | Интерфейс загрузки актов реализации и списаний инградиентов
Открытый интерфейс | ITransformation | Интерфейс вложений актов переработки
Открытый интерфейс | ITransformations | Интерфейс загрузки актов переработки
Открытый интерфейс | ITreeMenuChangeDocument | Интерфейс приказа об изменении меню
Открытый интерфейс | ITreeMenuChangeDocumentItem | Интерфейс элемента приказа об изменении меню
Открытый интерфейс | IVersion | Версия протокола выгрузки
Открытый интерфейс | IWriteoff | Интерфейс описания актов списания
Открытый интерфейс | IWriteoffDocItem | Интерфейс описания товарных единиц по акту списания
Открытый интерфейс | IWriteoffItem | Устарело. Интерфейс массива товарных единиц по списанию инградиентов
Открытый интерфейс | IWriteoffs | Интерфейс описания актов списания


IAssemblyChart - интерфейс

Интерфейс технологической карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IAssemblyChart

Тип IAssemblyChart предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Amount | В основной единице измерения элемента номенклатуры
Открытое свойство | Appearance | Описание
Открытое свойство | DateFrom | Дата начала действия ТТК
Открытое свойство | DateTo | Дата окончания действия ТТК. Если не задано, то неограничено.
Открытое свойство | DateToHasValue | DateTo имеет значение
Открытое свойство | Description | Описание
Открытое свойство | Items | Список элементов технологической карты
Открытое свойство | Organoleptic | Описание
Открытое свойство | OutputComment | Описание
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
Открытое свойство | Technology | Описание технологии приготовления.
Открытое свойство | WriteoffStrategy | Способ списания продукта: 0 - Списывать ингредиенты, 1 - Списывать сам продукт.
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён


IAssemblyChart - свойства

Тип IAssemblyChart предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Amount | В основной единице измерения элемента номенклатуры
Открытое свойство | Appearance | Описание
Открытое свойство | DateFrom | Дата начала действия ТТК
Открытое свойство | DateTo | Дата окончания действия ТТК. Если не задано, то неограничено.
Открытое свойство | DateToHasValue | DateTo имеет значение
Открытое свойство | Description | Описание
Открытое свойство | Items | Список элементов технологической карты
Открытое свойство | Organoleptic | Описание
Открытое свойство | OutputComment | Описание
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
Открытое свойство | Technology | Описание технологии приготовления.
Открытое свойство | WriteoffStrategy | Способ списания продукта: 0 - Списывать ингредиенты, 1 - Списывать сам продукт.
В начало страницы
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Amount - свойство

В основной единице измерения элемента номенклатуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Appearance - свойство

Описание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Appearance { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.DateFrom - свойство

Дата начала действия ТТК

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime DateFrom { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.DateTo - свойство

Дата окончания действия ТТК. Если не задано, то неограничено.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime DateTo { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.DateToHasValue - свойство

DateTo имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool DateToHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Description - свойство

Описание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Description { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Items - свойство

Список элементов технологической карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChartItem[] Items { get; set; }

Значение свойства

Тип: IAssemblyChartItem
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Organoleptic - свойство

Описание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Organoleptic { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.OutputComment - свойство

Описание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OutputComment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ProductArticle - свойство

Артикул продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ProductId - свойство

Guid продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.Technology - свойство

Описание технологии приготовления.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Technology { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.WriteoffStrategy - свойство

Способ списания продукта: 0 - Списывать ингредиенты, 1 - Списывать сам продукт.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int WriteoffStrategy { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart - методы

Тип IAssemblyChart предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IAssemblyChartItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIAssemblyChartItem
Технологическая карта
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChartItem ItemsGetFirstElement()

Возвращаемое значение

Тип: IAssemblyChartItem
Технологическая карта
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChart.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChartItem ItemsGetNextElement()

Возвращаемое значение

Тип: IAssemblyChartItem
Технологическая карта
См. также

Ссылки

IAssemblyChart - интерфейс


IAssemblyChartItem - интерфейс

Интерфейс элемента технологической карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IAssemblyChartItem

Тип IAssemblyChartItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Departments | подразделения
Открытое свойство | GrossWeight | Количество ингредиента, брутто, в основных единицах ингредиента
Открытое свойство | NetWeight | Вес нетто ингредиента (после холодной обработки), кг
Открытое свойство | OutWeight | Выход ингредиента (после горячей обработки), кг. Если не задано, будет использован вес нетто.
Открытое свойство | OutWeightHasValue | OutWeight имеет значение
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
Открытое свойство | StoreSpecification | Позволяет задать подразделения, склады которых будут удовлетворять (или наоборот, не удовлетворять) данной спецификации. 0 - исплючить, 1 - включать
В начало страницы
Методы
 | Имя | Описание
Открытый метод | DepartmentsAddItem | Добавление элемента
Открытый метод | DepartmentsClearArray | "Очистка массива
Открытый метод | DepartmentsGetFirstElement | Получение первого элемента
Открытый метод | DepartmentsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IAssemblyChartItem - свойства

Тип IAssemblyChartItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Departments | подразделения
Открытое свойство | GrossWeight | Количество ингредиента, брутто, в основных единицах ингредиента
Открытое свойство | NetWeight | Вес нетто ингредиента (после холодной обработки), кг
Открытое свойство | OutWeight | Выход ингредиента (после горячей обработки), кг. Если не задано, будет использован вес нетто.
Открытое свойство | OutWeightHasValue | OutWeight имеет значение
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
Открытое свойство | StoreSpecification | Позволяет задать подразделения, склады которых будут удовлетворять (или наоборот, не удовлетворять) данной спецификации. 0 - исплючить, 1 - включать
В начало страницы
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.Departments - свойство

подразделения

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string[] Departments { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.GrossWeight - свойство

Количество ингредиента, брутто, в основных единицах ингредиента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double GrossWeight { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.NetWeight - свойство

Вес нетто ингредиента (после холодной обработки), кг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NetWeight { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.OutWeight - свойство

Выход ингредиента (после горячей обработки), кг. Если не задано, будет использован вес нетто.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double OutWeight { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.OutWeightHasValue - свойство

OutWeight имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool OutWeightHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.ProductArticle - свойство

Артикул продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.ProductId - свойство

Guid продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.StoreSpecification - свойство

Позволяет задать подразделения, склады которых будут удовлетворять (или наоборот, не удовлетворять) данной спецификации. 0 - исплючить, 1 - включать

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int StoreSpecification { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem - методы

Тип IAssemblyChartItem предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | DepartmentsAddItem | Добавление элемента
Открытый метод | DepartmentsClearArray | "Очистка массива
Открытый метод | DepartmentsGetFirstElement | Получение первого элемента
Открытый метод | DepartmentsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.DepartmentsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void DepartmentsAddItem(
    string item
)

Параметры

item
Тип: SystemString
Подразделение
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.DepartmentsClearArray - метод

"Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void DepartmentsClearArray()
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.DepartmentsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentsGetFirstElement()

Возвращаемое значение

Тип: String
Подразделение
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartItem.DepartmentsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentsGetNextElement()

Возвращаемое значение

Тип: String
Подразделение
См. также

Ссылки

IAssemblyChartItem - интерфейс


IAssemblyChartList - интерфейс

Интерфейс списка технологических карт

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IAssemblyChartList

Тип IAssemblyChartList предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | Список технологических карт
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IAssemblyChartList - свойства

Тип IAssemblyChartList предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | Список технологических карт
В начало страницы
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList.Items - свойство

Список технологических карт

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChart[] Items { get; set; }

Значение свойства

Тип: IAssemblyChart
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList - методы

Тип IAssemblyChartList предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IAssemblyChart item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIAssemblyChart
Технологическая карта
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChart ItemsGetFirstElement()

Возвращаемое значение

Тип: IAssemblyChart
Технологическая карта
См. также

Ссылки

IAssemblyChartList - интерфейс


IAssemblyChartList.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChart ItemsGetNextElement()

Возвращаемое значение

Тип: IAssemblyChart
Технологическая карта
См. также

Ссылки

IAssemblyChartList - интерфейс


ICashFlow - интерфейс

Интерфейс движения денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ICashFlow

Тип ICashFlow предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CounteragentFromCode | Организация, кредит (код)
Открытое свойство | CounteragentFromINN | Организация, кредит (ИНН)
Открытое свойство | CounteragentFromName | Организация, кредит (наименование)
Открытое свойство | CounteragentToCode | Организация, дебет (код)
Открытое свойство | CounteragentToINN | Организация, дебет (ИНН)
Открытое свойство | CounteragentToName | Организация, дебет (наименование)
Открытое свойство | CreditAccountCode | Кредит (код)
Открытое свойство | CreditAccountName | Кредит (наименование)
Открытое свойство | CreditAccountType | Кредит (тип)
Открытое свойство | CreditSubAccountCode | Кредит, подсчет (код)
Открытое свойство | CreditSubAccountName | Кредит, подсчет (наименование)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DebitAccountCode | Дебет (код)
Открытое свойство | DebitAccountName | Дебет (наименование)
Открытое свойство | DebitAccountType | Дебет (тип)
Открытое свойство | DebitSubAccountCode | Дебет, подсчет (код)
Открытое свойство | DebitSubAccountName | Дебет, подсчет (наименование)
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | Sum | Сумма проводки
Открытое свойство | Sum_DecimalAsString | Сумма проводки. Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ICashFlow - свойства

Тип ICashFlow предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CounteragentFromCode | Организация, кредит (код)
Открытое свойство | CounteragentFromINN | Организация, кредит (ИНН)
Открытое свойство | CounteragentFromName | Организация, кредит (наименование)
Открытое свойство | CounteragentToCode | Организация, дебет (код)
Открытое свойство | CounteragentToINN | Организация, дебет (ИНН)
Открытое свойство | CounteragentToName | Организация, дебет (наименование)
Открытое свойство | CreditAccountCode | Кредит (код)
Открытое свойство | CreditAccountName | Кредит (наименование)
Открытое свойство | CreditAccountType | Кредит (тип)
Открытое свойство | CreditSubAccountCode | Кредит, подсчет (код)
Открытое свойство | CreditSubAccountName | Кредит, подсчет (наименование)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DebitAccountCode | Дебет (код)
Открытое свойство | DebitAccountName | Дебет (наименование)
Открытое свойство | DebitAccountType | Дебет (тип)
Открытое свойство | DebitSubAccountCode | Дебет, подсчет (код)
Открытое свойство | DebitSubAccountName | Дебет, подсчет (наименование)
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | Sum | Сумма проводки
Открытое свойство | Sum_DecimalAsString | Сумма проводки. Представление в виде строки
В начало страницы
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentFromCode - свойство

Организация, кредит (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentFromCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentFromINN - свойство

Организация, кредит (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentFromINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentFromName - свойство

Организация, кредит (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentFromName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentToCode - свойство

Организация, дебет (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentToCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentToINN - свойство

Организация, дебет (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentToINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CounteragentToName - свойство

Организация, дебет (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentToName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CreditAccountCode - свойство

Кредит (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CreditAccountCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CreditAccountName - свойство

Кредит (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CreditAccountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CreditAccountType - свойство

Кредит (тип)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CreditAccountType { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CreditSubAccountCode - свойство

Кредит, подсчет (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CreditSubAccountCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.CreditSubAccountName - свойство

Кредит, подсчет (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CreditSubAccountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DebitAccountCode - свойство

Дебет (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DebitAccountCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DebitAccountName - свойство

Дебет (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DebitAccountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DebitAccountType - свойство

Дебет (тип)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DebitAccountType { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DebitSubAccountCode - свойство

Дебет, подсчет (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DebitSubAccountCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DebitSubAccountName - свойство

Дебет, подсчет (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DebitSubAccountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DepartmentCode - свойство

Торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.DepartmentName - свойство

Торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.JuristicPersonINN - свойство

ЮЛ (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.JuristicPersonName - свойство

ЮЛ (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Sum - свойство

Сумма проводки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Sum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

ICashFlow - интерфейс


ICashFlow.Sum_DecimalAsString - свойство

Сумма проводки. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Sum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ICashFlow - интерфейс


ICashFlows - интерфейс

Интерфейс загрузки движения денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ICashFlows

Тип ICashFlows предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashFlowArray | вложенные документы Движения денежных средств
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddCashFlowArray | Добавление элемента к массиву
Открытый метод | ClearCashFlowArray | Очистка массива CashFlowArray
Открытый метод | GetFirstCashFlow | Получение первого элемента массива
Открытый метод | GetNextCashFlow | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ICashFlows - свойства

Тип ICashFlows предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashFlowArray | вложенные документы Движения денежных средств
В начало страницы
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows.CashFlowArray - свойство

вложенные документы Движения денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ICashFlow[] CashFlowArray { get; set; }

Значение свойства

Тип: ICashFlow
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows - методы

Тип ICashFlows предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddCashFlowArray | Добавление элемента к массиву
Открытый метод | ClearCashFlowArray | Очистка массива CashFlowArray
Открытый метод | GetFirstCashFlow | Получение первого элемента массива
Открытый метод | GetNextCashFlow | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows.AddCashFlowArray - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddCashFlowArray(
    ICashFlow item
)

Параметры

item
Тип: iiko1CInterface.InterfacesICashFlow
Движение денежных средств
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows.ClearCashFlowArray - метод

Очистка массива CashFlowArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearCashFlowArray()
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows.GetFirstCashFlow - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ICashFlow GetFirstCashFlow()

Возвращаемое значение

Тип: ICashFlow
Движение денежных средств
См. также

Ссылки

ICashFlows - интерфейс


ICashFlows.GetNextCashFlow - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ICashFlow GetNextCashFlow()

Возвращаемое значение

Тип: ICashFlow
Движение денежных средств
См. также

Ссылки

ICashFlows - интерфейс


IChoiceBinding - интерфейс

Интерфейс модификатора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IChoiceBinding

Тип IChoiceBinding предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Article | Артикул элемента
Открытое свойство | Id | Guid элемента
Открытое свойство | IsGroupModifier | Является ли модификатор груповым
Открытое свойство | IsGroupModifierHasValue | IsGroupModifier имеет значение
Открытое свойство | MaxAmount | максимальное количество модификатора, которое можно добавить в блюдо
Открытое свойство | MinAmount | минимальное количество модификатора, которое можно добавить в блюдо
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IChoiceBinding - свойства

Тип IChoiceBinding предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Article | Артикул элемента
Открытое свойство | Id | Guid элемента
Открытое свойство | IsGroupModifier | Является ли модификатор груповым
Открытое свойство | IsGroupModifierHasValue | IsGroupModifier имеет значение
Открытое свойство | MaxAmount | максимальное количество модификатора, которое можно добавить в блюдо
Открытое свойство | MinAmount | минимальное количество модификатора, которое можно добавить в блюдо
В начало страницы
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.Article - свойство

Артикул элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.Id - свойство

Guid элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Id { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.IsGroupModifier - свойство

Является ли модификатор груповым

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IsGroupModifier { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.IsGroupModifierHasValue - свойство

IsGroupModifier имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IsGroupModifierHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.MaxAmount - свойство

максимальное количество модификатора, которое можно добавить в блюдо

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double MaxAmount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBinding.MinAmount - свойство

минимальное количество модификатора, которое можно добавить в блюдо

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double MinAmount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IChoiceBinding - интерфейс


IChoiceBindingInfo - интерфейс

Интерфейс информации о модификторах блюда

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IChoiceBindingInfo

Тип IChoiceBindingInfo предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | список модификаторов
Открытое свойство | ProductArticle | Номенклатурный код элемента меню (артикул)
Открытое свойство | ProductId | Guid элемента
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IChoiceBindingInfo - свойства

Тип IChoiceBindingInfo предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | список модификаторов
Открытое свойство | ProductArticle | Номенклатурный код элемента меню (артикул)
Открытое свойство | ProductId | Guid элемента
В начало страницы
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.Items - свойство

список модификаторов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding[] Items { get; set; }

Значение свойства

Тип: IChoiceBinding
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ProductArticle - свойство

Номенклатурный код элемента меню (артикул)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ProductId - свойство

Guid элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo - методы

Тип IChoiceBindingInfo предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IChoiceBinding item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIChoiceBinding
Информация о модификаторе
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding ItemsGetFirstElement()

Возвращаемое значение

Тип: IChoiceBinding
Информация о модификаторе
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfo.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding ItemsGetNextElement()

Возвращаемое значение

Тип: IChoiceBinding
Информация о модификаторе
См. также

Ссылки

IChoiceBindingInfo - интерфейс


IChoiceBindingInfoList - интерфейс

Интерфейс списка информаций о модификаторах

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IChoiceBindingInfoList

Тип IChoiceBindingInfoList предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | список модификаторов
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IChoiceBindingInfoList - свойства

Тип IChoiceBindingInfoList предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Items | список модификаторов
В начало страницы
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList.Items - свойство

список модификаторов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBindingInfo[] Items { get; set; }

Значение свойства

Тип: IChoiceBindingInfo
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList - методы

Тип IChoiceBindingInfoList предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IChoiceBindingInfo item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIChoiceBindingInfo
Информация о модификаторах
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBindingInfo ItemsGetFirstElement()

Возвращаемое значение

Тип: IChoiceBindingInfo
Информация о модификаторах
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IChoiceBindingInfoList.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBindingInfo ItemsGetNextElement()

Возвращаемое значение

Тип: IChoiceBindingInfo
Информация о модификаторах
См. также

Ссылки

IChoiceBindingInfoList - интерфейс


IDisassemble - интерфейс

Интерфейс акта разбора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IDisassemble

Тип IDisassemble предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | Items | Массив товарнных позиций акта рабора
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IDisassemble - свойства

Тип IDisassemble предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | Items | Массив товарнных позиций акта рабора
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
В начало страницы
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.Items - свойство

Массив товарнных позиций акта рабора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassembleItem[] Items { get; set; }

Значение свойства

Тип: IDisassembleItem
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble - методы

Тип IDisassemble предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IDisassembleItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIDisassembleItem
Акт разбора
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassembleItem ItemsGetFirstElement()

Возвращаемое значение

Тип: IDisassembleItem
Акт разбора
См. также

Ссылки

IDisassemble - интерфейс


IDisassemble.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassembleItem ItemsGetNextElement()

Возвращаемое значение

Тип: IDisassembleItem
Акт разбора
См. также

Ссылки

IDisassemble - интерфейс


IDisassembleItem - интерфейс

Интерфейс вложенной товарнной позиции акта рабора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IDisassembleItem

Тип IDisassembleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | AmountInContainer | Количество в таре
Открытое свойство | AmountInContainerHasValue | AmountInContainer имеет значение
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | ContainerCode | Тара (код)
Открытое свойство | ContainerName | Тара (название)
Открытое свойство | CostPrice | Себестоимость без НДС
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС
Открытое свойство | MainProductAmountPercent | Процент себестоимости, %
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продукт, 2=ингредиент
Открытое свойство | OperationName | тип строки: продукт/ингредиент
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IDisassembleItem - свойства

Тип IDisassembleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | AmountInContainer | Количество в таре
Открытое свойство | AmountInContainerHasValue | AmountInContainer имеет значение
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | ContainerCode | Тара (код)
Открытое свойство | ContainerName | Тара (название)
Открытое свойство | CostPrice | Себестоимость без НДС
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС
Открытое свойство | MainProductAmountPercent | Процент себестоимости, %
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продукт, 2=ингредиент
Открытое свойство | OperationName | тип строки: продукт/ингредиент
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
В начало страницы
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.AmountInContainer - свойство

Количество в таре

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double AmountInContainer { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.AmountInContainerHasValue - свойство

AmountInContainer имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool AmountInContainerHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.ContainerCode - свойство

Тара (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ContainerCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.ContainerName - свойство

Тара (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ContainerName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.CostPrice - свойство

Себестоимость без НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.MainProductAmountPercent - свойство

Процент себестоимости, %

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double MainProductAmountPercent { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.NdsProductPercent - свойство

Ставка НДС из справочника

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.Operation - свойство

тип строки: 1=продукт, 2=ингредиент

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.OperationName - свойство

тип строки: продукт/ингредиент

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembleItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IDisassembleItem - интерфейс


IDisassembles - интерфейс

Интерфейс загрузки актов рабора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IDisassembles

Тип IDisassembles предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Documents | список документов
В начало страницы
Методы
 | Имя | Описание
Открытый метод | DocumentsAddItem | Добавление элемента
Открытый метод | DocumentsClearArray | Очистка массива
Открытый метод | DocumentsGetFirstElement | Получение первого элемента
Открытый метод | DocumentsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IDisassembles - свойства

Тип IDisassembles предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Documents | список документов
В начало страницы
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles.Documents - свойство

список документов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassemble[] Documents { get; set; }

Значение свойства

Тип: IDisassemble
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles - методы

Тип IDisassembles предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | DocumentsAddItem | Добавление элемента
Открытый метод | DocumentsClearArray | Очистка массива
Открытый метод | DocumentsGetFirstElement | Получение первого элемента
Открытый метод | DocumentsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles.DocumentsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void DocumentsAddItem(
    IDisassemble item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIDisassemble
Акт разбора
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles.DocumentsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void DocumentsClearArray()
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles.DocumentsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassemble DocumentsGetFirstElement()

Возвращаемое значение

Тип: IDisassemble
Акт разбора
См. также

Ссылки

IDisassembles - интерфейс


IDisassembles.DocumentsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassemble DocumentsGetNextElement()

Возвращаемое значение

Тип: IDisassemble
Акт разбора
См. также

Ссылки

IDisassembles - интерфейс


IDocumentFilter - интерфейс

Интерфейс загрузки документов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IDocumentFilter

Тип IDocumentFilter предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AnalyticsByDate | Аналитика по дате: 0 - по документам, 1 - свернуть за день, 2 - свернуть за месяц
Открытое свойство | CutDownDishes | Сворачивать номенклатурные позиции: 0 - не сворачивать, 1 - сворачивать по НДС, 2 - сворачивать по категориям+НДС
Открытое свойство | DateFrom | Дата и время, с которой необходимо загрузить документы. Некоторые документы выгружаются только по календарным датам
Открытое свойство | DateTo | Дата и время, по которое загруются документы. Не включительно
Открытое свойство | DepartmentsFilter | Список кодов подразделений, участвующих в фильтре
Открытое свойство | IncludeUnprocessed | Включать в выгрузку непроверенные документы. По умолчанию, не включаются
Открытое свойство | StoresFilter | Фильтр складов. Если не задан, то включаются все документы
Открытое свойство | UseBusinessSettings | Использовать при выгрузке, понятие операционных дней. По умолчанию, не используется
Открытое свойство | UseOnlyDate | Прозводить выборку по дате (с DateFrom 00:00 по DateTo 23:59)
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddDepartmentId | Добавление в фильтр подразделение с заданным кодом
Открытый метод | AddStoreCode | Добавление в фильтр складов склада с заданным кодом
Открытый метод | SetAllDepartment | Отключение фильтра по подразделениям
Открытый метод | SetAllStores | Отключение фильтра по складам
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IDocumentFilter - свойства

Тип IDocumentFilter предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AnalyticsByDate | Аналитика по дате: 0 - по документам, 1 - свернуть за день, 2 - свернуть за месяц
Открытое свойство | CutDownDishes | Сворачивать номенклатурные позиции: 0 - не сворачивать, 1 - сворачивать по НДС, 2 - сворачивать по категориям+НДС
Открытое свойство | DateFrom | Дата и время, с которой необходимо загрузить документы. Некоторые документы выгружаются только по календарным датам
Открытое свойство | DateTo | Дата и время, по которое загруются документы. Не включительно
Открытое свойство | DepartmentsFilter | Список кодов подразделений, участвующих в фильтре
Открытое свойство | IncludeUnprocessed | Включать в выгрузку непроверенные документы. По умолчанию, не включаются
Открытое свойство | StoresFilter | Фильтр складов. Если не задан, то включаются все документы
Открытое свойство | UseBusinessSettings | Использовать при выгрузке, понятие операционных дней. По умолчанию, не используется
Открытое свойство | UseOnlyDate | Прозводить выборку по дате (с DateFrom 00:00 по DateTo 23:59)
В начало страницы
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.AnalyticsByDate - свойство

Аналитика по дате: 0 - по документам, 1 - свернуть за день, 2 - свернуть за месяц

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int AnalyticsByDate { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.CutDownDishes - свойство

Сворачивать номенклатурные позиции: 0 - не сворачивать, 1 - сворачивать по НДС, 2 - сворачивать по категориям+НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int CutDownDishes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.DateFrom - свойство

Дата и время, с которой необходимо загрузить документы. Некоторые документы выгружаются только по календарным датам

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime DateFrom { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.DateTo - свойство

Дата и время, по которое загруются документы. Не включительно

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime DateTo { get; set; }

Значение свойства

Тип: DateTime
Заметки
Чтобы получить документы за 1 день, нужно выгружать, например, с 01.01.2010 00:00 по 02.01.2010 00:00 Некоторые документы выгружаются только по календарным датам
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.DepartmentsFilter - свойство

Список кодов подразделений, участвующих в фильтре

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string[] DepartmentsFilter { get; }

Значение свойства

Тип: String
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.IncludeUnprocessed - свойство

Включать в выгрузку непроверенные документы. По умолчанию, не включаются

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IncludeUnprocessed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.StoresFilter - свойство

Фильтр складов. Если не задан, то включаются все документы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string[] StoresFilter { get; }

Значение свойства

Тип: String
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.UseBusinessSettings - свойство

Использовать при выгрузке, понятие операционных дней. По умолчанию, не используется

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool UseBusinessSettings { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.UseOnlyDate - свойство

Прозводить выборку по дате (с DateFrom 00:00 по DateTo 23:59)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool UseOnlyDate { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter - методы

Тип IDocumentFilter предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddDepartmentId | Добавление в фильтр подразделение с заданным кодом
Открытый метод | AddStoreCode | Добавление в фильтр складов склада с заданным кодом
Открытый метод | SetAllDepartment | Отключение фильтра по подразделениям
Открытый метод | SetAllStores | Отключение фильтра по складам
В начало страницы
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.AddDepartmentId - метод

Добавление в фильтр подразделение с заданным кодом

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddDepartmentId(
    string departmentId
)

Параметры

departmentId
Тип: SystemString
Код подразделения
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.AddStoreCode - метод

Добавление в фильтр складов склада с заданным кодом

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddStoreCode(
    string storeCode
)

Параметры

storeCode
Тип: SystemString
Код склада
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.SetAllDepartment - метод

Отключение фильтра по подразделениям

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void SetAllDepartment()
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentFilter.SetAllStores - метод

Отключение фильтра по складам

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void SetAllStores()
См. также

Ссылки

IDocumentFilter - интерфейс


IDocumentLoader - интерфейс

Интерфейс загрузки документов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IDocumentLoader

Тип IDocumentLoader предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | LoadCashFlowData | Загрузка движения денежных средств
Открытый метод | LoadDisassembleData | Загрузка актов разбора
Открытый метод | LoadEmloyeeTimeSheet | Загрузка учета рабочего времени
Открытый метод | LoadEmloyeeTimeSheetWithDaysNightsAndSchedulers | Загрузка учета рабочего времени с разбитием на смены и дневные/ночные периоды
Открытый метод | LoadIncomingReturnedInvoicesData | Загрузка возвратов от покупателя.
Открытый метод | LoadIncomingServiceData | Загрузка актов приема услуг
Открытый метод | LoadInternalTransfersData | Загрузка Загрузка внутренних перемещений
Открытый метод | LoadInventoriesData | Загрузка инвентаризаций
Открытый метод | LoadInvoiceData | Загрузка приходных накладных
Открытый метод | LoadOrders | Загрузка заказов (счетов)
Открытый метод | LoadOutgoingInvoicesData | Загрузка расходных накладных
Открытый метод | LoadOutgoingServiceData | Загрузка актов оказания услуг
Открытый метод | LoadProductionsData | Загрузка актов приготовления
Открытый метод | LoadProfitTakingData | Загрузка приема кассовой выручки
Открытый метод | LoadReturnedInvoicesData | Загрузка возвратных накладных
Открытый метод | LoadSalesData | Загрузка актов реализации
Открытый метод | LoadTransformationsData | Загрузка актов переработки
Открытый метод | LoadWriteoffsData | Загрузка актов списания
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IDocumentLoader - методы

Тип IDocumentLoader предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | LoadCashFlowData | Загрузка движения денежных средств
Открытый метод | LoadDisassembleData | Загрузка актов разбора
Открытый метод | LoadEmloyeeTimeSheet | Загрузка учета рабочего времени
Открытый метод | LoadEmloyeeTimeSheetWithDaysNightsAndSchedulers | Загрузка учета рабочего времени с разбитием на смены и дневные/ночные периоды
Открытый метод | LoadIncomingReturnedInvoicesData | Загрузка возвратов от покупателя.
Открытый метод | LoadIncomingServiceData | Загрузка актов приема услуг
Открытый метод | LoadInternalTransfersData | Загрузка Загрузка внутренних перемещений
Открытый метод | LoadInventoriesData | Загрузка инвентаризаций
Открытый метод | LoadInvoiceData | Загрузка приходных накладных
Открытый метод | LoadOrders | Загрузка заказов (счетов)
Открытый метод | LoadOutgoingInvoicesData | Загрузка расходных накладных
Открытый метод | LoadOutgoingServiceData | Загрузка актов оказания услуг
Открытый метод | LoadProductionsData | Загрузка актов приготовления
Открытый метод | LoadProfitTakingData | Загрузка приема кассовой выручки
Открытый метод | LoadReturnedInvoicesData | Загрузка возвратных накладных
Открытый метод | LoadSalesData | Загрузка актов реализации
Открытый метод | LoadTransformationsData | Загрузка актов переработки
Открытый метод | LoadWriteoffsData | Загрузка актов списания
В начало страницы
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadCashFlowData - метод

Загрузка движения денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ICashFlows LoadCashFlowData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: ICashFlows
Движение денежных средств
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadDisassembleData - метод

Загрузка актов разбора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IDisassembles LoadDisassembleData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IDisassembles
Акты разбора
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadEmloyeeTimeSheet - метод

Загрузка учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheets LoadEmloyeeTimeSheet(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IEmloyeeTimeSheets
Учет рабочего времени
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadEmloyeeTimeSheetWithDaysNightsAndSchedulers - метод

Загрузка учета рабочего времени с разбитием на смены и дневные/ночные периоды

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetCuts LoadEmloyeeTimeSheetWithDaysNightsAndSchedulers(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IEmloyeeTimeSheetCuts
Учет рабочего времени с разбитием на смены и дневные/ночные периоды
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadIncomingReturnedInvoicesData - метод

Загрузка возвратов от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoices LoadIncomingReturnedInvoicesData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IIncomingReturnedInvoices
Возвраты от покупателя
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadIncomingServiceData - метод

Загрузка актов приема услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingServices LoadIncomingServiceData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IIncomingServices
Акты приема услуг
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadInternalTransfersData - метод

Загрузка Загрузка внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransfers LoadInternalTransfersData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IInternalTransfers
Акты внутренние перемещения
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadInventoriesData - метод

Загрузка инвентаризаций

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventories LoadInventoriesData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IInventories
Инвентаризации
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadInvoiceData - метод

Загрузка приходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoices LoadInvoiceData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IInvoices
Приходные накладные
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadOrders - метод

Загрузка заказов (счетов)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrdersDocuments LoadOrders(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IOrdersDocuments
Движение денежных средств
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadOutgoingInvoicesData - метод

Загрузка расходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoices LoadOutgoingInvoicesData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IOutgoingInvoices
Расходные накладные
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadOutgoingServiceData - метод

Загрузка актов оказания услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingServices LoadOutgoingServiceData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IOutgoingServices
Акты оказания услуг
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadProductionsData - метод

Загрузка актов приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductions LoadProductionsData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IProductions
Акты приготовления
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadProfitTakingData - метод

Загрузка приема кассовой выручки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTakings LoadProfitTakingData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IProfitTakings
Кассовая выручка
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadReturnedInvoicesData - метод

Загрузка возвратных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoices LoadReturnedInvoicesData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IReturnedInvoices
Возвратные накладные
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadSalesData - метод

Загрузка актов реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISales LoadSalesData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: ISales
Приходные накладные
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadTransformationsData - метод

Загрузка актов переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITransformations LoadTransformationsData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: ITransformations
Акты переработки
См. также

Ссылки

IDocumentLoader - интерфейс


IDocumentLoader.LoadWriteoffsData - метод

Загрузка актов списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoffs LoadWriteoffsData(
    string server,
    string login,
    string password,
    IDocumentFilter filter
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
filter
Тип: iiko1CInterface.InterfacesIDocumentFilter
Фильтр выбора документов

Возвращаемое значение

Тип: IWriteoffs
Акты списания
См. также

Ссылки

IDocumentLoader - интерфейс


IEmloyeeTimeSheet - интерфейс

Интерфейс описания учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IEmloyeeTimeSheet

Тип IEmloyeeTimeSheet предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | EmloyeeTimeSheetItems | вложенные элементы списка учета рабочего времени
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetItems | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetItems | Очистка массива
Открытый метод | GetFirstEmloyeeTimeSheetItem | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheetItem | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IEmloyeeTimeSheet - свойства

Тип IEmloyeeTimeSheet предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | EmloyeeTimeSheetItems | вложенные элементы списка учета рабочего времени
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.DepartmentCode - свойство

Торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.DepartmentName - свойство

Торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.EmloyeeTimeSheetItems - свойство

вложенные элементы списка учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetItem[] EmloyeeTimeSheetItems { get; set; }

Значение свойства

Тип: IEmloyeeTimeSheetItem
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.JuristicPersonINN - свойство

ЮЛ (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.JuristicPersonName - свойство

ЮЛ (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet - методы

Тип IEmloyeeTimeSheet предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetItems | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetItems | Очистка массива
Открытый метод | GetFirstEmloyeeTimeSheetItem | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheetItem | Получение следующего элемента
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.AddEmloyeeTimeSheetItems - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddEmloyeeTimeSheetItems(
    IEmloyeeTimeSheetItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIEmloyeeTimeSheetItem
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.ClearEmloyeeTimeSheetItems - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearEmloyeeTimeSheetItems()
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.GetFirstEmloyeeTimeSheetItem - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetItem GetFirstEmloyeeTimeSheetItem()

Возвращаемое значение

Тип: IEmloyeeTimeSheetItem
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheet.GetNextEmloyeeTimeSheetItem - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetItem GetNextEmloyeeTimeSheetItem()

Возвращаемое значение

Тип: IEmloyeeTimeSheetItem
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheet - интерфейс


IEmloyeeTimeSheetCut - интерфейс

Интерфейс описания учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IEmloyeeTimeSheetCut

Тип IEmloyeeTimeSheetCut предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AttendanceDate | Дата явки
Открытое свойство | AttendanceType | Тип явки
Открытое свойство | DayNightType | Ночная/Дневная смена
Открытое свойство | Department | Департамент
Открытое свойство | DinnerTime | Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)
Открытое свойство | DinnerTimeString | Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)
Открытое свойство | Duration | Длительность явки
Открытое свойство | DurationOfDinnerString | Длительность неоплачиваемого времени (т.е. обеда)
Открытое свойство | DurationString | Длительность явки
Открытое свойство | Employee | Пользователь
Открытое свойство | EmployeeCode | Табельный номер
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IEmloyeeTimeSheetCut - свойства

Тип IEmloyeeTimeSheetCut предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AttendanceDate | Дата явки
Открытое свойство | AttendanceType | Тип явки
Открытое свойство | DayNightType | Ночная/Дневная смена
Открытое свойство | Department | Департамент
Открытое свойство | DinnerTime | Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)
Открытое свойство | DinnerTimeString | Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)
Открытое свойство | Duration | Длительность явки
Открытое свойство | DurationOfDinnerString | Длительность неоплачиваемого времени (т.е. обеда)
Открытое свойство | DurationString | Длительность явки
Открытое свойство | Employee | Пользователь
Открытое свойство | EmployeeCode | Табельный номер
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.AttendanceDate - свойство

Дата явки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AttendanceDate { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.AttendanceType - свойство

Тип явки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AttendanceType { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.DayNightType - свойство

Ночная/Дневная смена

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DayNightType { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.Department - свойство

Департамент

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Department { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.DinnerTime - свойство

Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double DinnerTime { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.DinnerTimeString - свойство

Длительность явки за вычетом неоплачиваемого времени (т.е. обеда)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DinnerTimeString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.Duration - свойство

Длительность явки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
long Duration { get; set; }

Значение свойства

Тип: Int64
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.DurationOfDinnerString - свойство

Длительность неоплачиваемого времени (т.е. обеда)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DurationOfDinnerString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.DurationString - свойство

Длительность явки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DurationString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.Employee - свойство

Пользователь

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Employee { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCut.EmployeeCode - свойство

Табельный номер

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string EmployeeCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetCut - интерфейс


IEmloyeeTimeSheetCuts - интерфейс

Интерфейс загрузки учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IEmloyeeTimeSheetCuts

Тип IEmloyeeTimeSheetCuts предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | EmloyeeTimeSheetArray | вложенные списки учета рабочего времени
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetArray | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetArray | Очистка массива EmloyeeTimeSheetArray
Открытый метод | GetFirstEmloyeeTimeSheet | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheet | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IEmloyeeTimeSheetCuts - свойства

Тип IEmloyeeTimeSheetCuts предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | EmloyeeTimeSheetArray | вложенные списки учета рабочего времени
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts.EmloyeeTimeSheetArray - свойство

вложенные списки учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetCut[] EmloyeeTimeSheetArray { get; set; }

Значение свойства

Тип: IEmloyeeTimeSheetCut
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts - методы

Тип IEmloyeeTimeSheetCuts предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetArray | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetArray | Очистка массива EmloyeeTimeSheetArray
Открытый метод | GetFirstEmloyeeTimeSheet | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheet | Получение следующего элемента
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts.AddEmloyeeTimeSheetArray - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddEmloyeeTimeSheetArray(
    IEmloyeeTimeSheetCut item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIEmloyeeTimeSheetCut
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts.ClearEmloyeeTimeSheetArray - метод

Очистка массива EmloyeeTimeSheetArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearEmloyeeTimeSheetArray()
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts.GetFirstEmloyeeTimeSheet - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetCut GetFirstEmloyeeTimeSheet()

Возвращаемое значение

Тип: IEmloyeeTimeSheetCut
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetCuts.GetNextEmloyeeTimeSheet - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheetCut GetNextEmloyeeTimeSheet()

Возвращаемое значение

Тип: IEmloyeeTimeSheetCut
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheetCuts - интерфейс


IEmloyeeTimeSheetItem - интерфейс

Интерфейс вложенного элемента учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IEmloyeeTimeSheetItem

Тип IEmloyeeTimeSheetItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingDate | Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | AccountingDate_DateTimeAsString | Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | AttendancePayRatePercent | Тип явки (коэффициент расчета, %)
Открытое свойство | AttendancePayRatePercent_Int32AsString | Тип явки (коэффициент расчета, %). Представление в виде строки
Открытое свойство | AttendanceTypeCode | Тип явки (код)
Открытое свойство | AttendanceTypeName | Тип явки (наименование)
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | Duration | Длительность, в формате HH:MM
Открытое свойство | DurationMinutes | Длительность, минут
Открытое свойство | DurationMinutes_Int32AsString | Длительность, минут. Представление в виде строки
Открытое свойство | EmployeeCode | Код сотрудника (строковое значение)
Открытое свойство | EmployeeName | Имя сотрудника (строковое значение)
Открытое свойство | EndDate | Фактическое окончание
Открытое свойство | EndDate_DateTimeAsString | Фактическое окончание. Представление в виде строки
Открытое свойство | IsAttendance | Тип явки (явка/неявка)
Открытое свойство | IsAttendance_BooleanAsString | Тип явки (явка/неявка). Представление в виде строки
Открытое свойство | NonPaid | Неоплачиваемое время, в формате HH:MM
Открытое свойство | NonPaidMinutes | Неоплачиваемое время, минут
Открытое свойство | NonPaidMinutes_Int32AsString | Неоплачиваемое время, минут. Представление в виде строки
Открытое свойство | ScheduleCode | Тип смены (код)
Открытое свойство | ScheduleDuration | Тип смены (длительность), в формате HH:MM
Открытое свойство | ScheduleDurationMinutes | Тип смены (длительность), минут
Открытое свойство | ScheduleDurationMinutes_Int32AsString | Тип смены (длительность), минут. Представление в виде строки
Открытое свойство | ScheduleEnd | Тип смены (время окончания), в формате HH:MM
Открытое свойство | ScheduleEndMinutes | Тип смены (время окончания), в минутах от начала дня
Открытое свойство | ScheduleEndMinutes_Int32AsString | Тип смены (время окончания), в минутах от начала дня. Представление в виде строки
Открытое свойство | ScheduleName | Тип смены (наименование)
Открытое свойство | ScheduleNonPaid | Тип смены (неоплачиваемое время), в формате HH:MM
Открытое свойство | ScheduleNonPaidMinutes | Тип смены (неоплачиваемое время), минут
Открытое свойство | ScheduleNonPaidMinutes_Int32AsString | Тип смены (неоплачиваемое время), минут. Представление в виде строки
Открытое свойство | ScheduleStart | Тип смены (время начала), в формате HH:MM
Открытое свойство | ScheduleStartMinutes | Тип смены (время начала), в минутах от начала дня
Открытое свойство | ScheduleStartMinutes_Int32AsString | Тип смены (время начала), в минутах от начала дня. Представление в виде строки
Открытое свойство | StartDate | фактическое начало
Открытое свойство | StartDate_DateTimeAsString | фактическое начало. Представление в виде строки
Открытое свойство | TypeCode | Тип строки (код)
Открытое свойство | TypeName | Тип строки (наименование)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IEmloyeeTimeSheetItem - свойства

Тип IEmloyeeTimeSheetItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingDate | Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | AccountingDate_DateTimeAsString | Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | AttendancePayRatePercent | Тип явки (коэффициент расчета, %)
Открытое свойство | AttendancePayRatePercent_Int32AsString | Тип явки (коэффициент расчета, %). Представление в виде строки
Открытое свойство | AttendanceTypeCode | Тип явки (код)
Открытое свойство | AttendanceTypeName | Тип явки (наименование)
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | Duration | Длительность, в формате HH:MM
Открытое свойство | DurationMinutes | Длительность, минут
Открытое свойство | DurationMinutes_Int32AsString | Длительность, минут. Представление в виде строки
Открытое свойство | EmployeeCode | Код сотрудника (строковое значение)
Открытое свойство | EmployeeName | Имя сотрудника (строковое значение)
Открытое свойство | EndDate | Фактическое окончание
Открытое свойство | EndDate_DateTimeAsString | Фактическое окончание. Представление в виде строки
Открытое свойство | IsAttendance | Тип явки (явка/неявка)
Открытое свойство | IsAttendance_BooleanAsString | Тип явки (явка/неявка). Представление в виде строки
Открытое свойство | NonPaid | Неоплачиваемое время, в формате HH:MM
Открытое свойство | NonPaidMinutes | Неоплачиваемое время, минут
Открытое свойство | NonPaidMinutes_Int32AsString | Неоплачиваемое время, минут. Представление в виде строки
Открытое свойство | ScheduleCode | Тип смены (код)
Открытое свойство | ScheduleDuration | Тип смены (длительность), в формате HH:MM
Открытое свойство | ScheduleDurationMinutes | Тип смены (длительность), минут
Открытое свойство | ScheduleDurationMinutes_Int32AsString | Тип смены (длительность), минут. Представление в виде строки
Открытое свойство | ScheduleEnd | Тип смены (время окончания), в формате HH:MM
Открытое свойство | ScheduleEndMinutes | Тип смены (время окончания), в минутах от начала дня
Открытое свойство | ScheduleEndMinutes_Int32AsString | Тип смены (время окончания), в минутах от начала дня. Представление в виде строки
Открытое свойство | ScheduleName | Тип смены (наименование)
Открытое свойство | ScheduleNonPaid | Тип смены (неоплачиваемое время), в формате HH:MM
Открытое свойство | ScheduleNonPaidMinutes | Тип смены (неоплачиваемое время), минут
Открытое свойство | ScheduleNonPaidMinutes_Int32AsString | Тип смены (неоплачиваемое время), минут. Представление в виде строки
Открытое свойство | ScheduleStart | Тип смены (время начала), в формате HH:MM
Открытое свойство | ScheduleStartMinutes | Тип смены (время начала), в минутах от начала дня
Открытое свойство | ScheduleStartMinutes_Int32AsString | Тип смены (время начала), в минутах от начала дня. Представление в виде строки
Открытое свойство | StartDate | фактическое начало
Открытое свойство | StartDate_DateTimeAsString | фактическое начало. Представление в виде строки
Открытое свойство | TypeCode | Тип строки (код)
Открытое свойство | TypeName | Тип строки (наименование)
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AccountingDate - свойство

Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime AccountingDate { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AccountingDate_DateTimeAsString - свойство

Дата учета (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingDate_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AttendancePayRatePercent - свойство

Тип явки (коэффициент расчета, %)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int AttendancePayRatePercent { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AttendancePayRatePercent_Int32AsString - свойство

Тип явки (коэффициент расчета, %). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AttendancePayRatePercent_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AttendanceTypeCode - свойство

Тип явки (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AttendanceTypeCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.AttendanceTypeName - свойство

Тип явки (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AttendanceTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.Date - свойство

Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.Date_DateTimeAsString - свойство

Дата регистрации записи в журнале (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.Duration - свойство

Длительность, в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Duration { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.DurationMinutes - свойство

Длительность, минут

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int DurationMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.DurationMinutes_Int32AsString - свойство

Длительность, минут. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DurationMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.EmployeeCode - свойство

Код сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string EmployeeCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.EmployeeName - свойство

Имя сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string EmployeeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.EndDate - свойство

Фактическое окончание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime EndDate { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.EndDate_DateTimeAsString - свойство

Фактическое окончание. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string EndDate_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.IsAttendance - свойство

Тип явки (явка/неявка)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IsAttendance { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.IsAttendance_BooleanAsString - свойство

Тип явки (явка/неявка). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IsAttendance_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.NonPaid - свойство

Неоплачиваемое время, в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NonPaid { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.NonPaidMinutes - свойство

Неоплачиваемое время, минут

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NonPaidMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.NonPaidMinutes_Int32AsString - свойство

Неоплачиваемое время, минут. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NonPaidMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleCode - свойство

Тип смены (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleDuration - свойство

Тип смены (длительность), в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleDuration { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleDurationMinutes - свойство

Тип смены (длительность), минут

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int ScheduleDurationMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleDurationMinutes_Int32AsString - свойство

Тип смены (длительность), минут. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleDurationMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleEnd - свойство

Тип смены (время окончания), в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleEnd { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleEndMinutes - свойство

Тип смены (время окончания), в минутах от начала дня

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int ScheduleEndMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleEndMinutes_Int32AsString - свойство

Тип смены (время окончания), в минутах от начала дня. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleEndMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleName - свойство

Тип смены (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleNonPaid - свойство

Тип смены (неоплачиваемое время), в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleNonPaid { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleNonPaidMinutes - свойство

Тип смены (неоплачиваемое время), минут

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int ScheduleNonPaidMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleNonPaidMinutes_Int32AsString - свойство

Тип смены (неоплачиваемое время), минут. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleNonPaidMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleStart - свойство

Тип смены (время начала), в формате HH:MM

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleStart { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleStartMinutes - свойство

Тип смены (время начала), в минутах от начала дня

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int ScheduleStartMinutes { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.ScheduleStartMinutes_Int32AsString - свойство

Тип смены (время начала), в минутах от начала дня. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ScheduleStartMinutes_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.StartDate - свойство

фактическое начало

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime StartDate { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.StartDate_DateTimeAsString - свойство

фактическое начало. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StartDate_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.TypeCode - свойство

Тип строки (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheetItem.TypeName - свойство

Тип строки (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IEmloyeeTimeSheetItem - интерфейс


IEmloyeeTimeSheets - интерфейс

Интерфейс загрузки учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IEmloyeeTimeSheets

Тип IEmloyeeTimeSheets предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | EmloyeeTimeSheetArray | вложенные списки учета рабочего времени
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetArray | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetArray | Очистка массива
Открытый метод | GetFirstEmloyeeTimeSheet | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheet | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IEmloyeeTimeSheets - свойства

Тип IEmloyeeTimeSheets предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | EmloyeeTimeSheetArray | вложенные списки учета рабочего времени
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets.EmloyeeTimeSheetArray - свойство

вложенные списки учета рабочего времени

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheet[] EmloyeeTimeSheetArray { get; set; }

Значение свойства

Тип: IEmloyeeTimeSheet
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets - методы

Тип IEmloyeeTimeSheets предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddEmloyeeTimeSheetArray | Добавление элемента
Открытый метод | ClearEmloyeeTimeSheetArray | Очистка массива
Открытый метод | GetFirstEmloyeeTimeSheet | Получение первого элемента
Открытый метод | GetNextEmloyeeTimeSheet | Получение следующего элемента
В начало страницы
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets.AddEmloyeeTimeSheetArray - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddEmloyeeTimeSheetArray(
    IEmloyeeTimeSheet item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIEmloyeeTimeSheet
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets.ClearEmloyeeTimeSheetArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearEmloyeeTimeSheetArray()
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets.GetFirstEmloyeeTimeSheet - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheet GetFirstEmloyeeTimeSheet()

Возвращаемое значение

Тип: IEmloyeeTimeSheet
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IEmloyeeTimeSheets.GetNextEmloyeeTimeSheet - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IEmloyeeTimeSheet GetNextEmloyeeTimeSheet()

Возвращаемое значение

Тип: IEmloyeeTimeSheet
Элемент учета рабочего времени
См. также

Ссылки

IEmloyeeTimeSheets - интерфейс


IIncomingReturnedInvoice - интерфейс

Интерфейс вложенных возвратов от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIncomingReturnedInvoice

Тип IIncomingReturnedInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий.
Открытое свойство | ConceptionCode | Концепция (код).
Открытое свойство | ConceptionName | Концепция (название).
Открытое свойство | CustomerCode | Код покупателя.
Открытое свойство | CustomerINN | ИНН покупателя.
Открытое свойство | CustomerName | Наименование покупателя.
Открытое свойство | Date | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС).
Открытое свойство | Date_DateTimeAsString | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки.
Открытое свойство | DepartmentCode | Торговое предприятие (код).
Открытое свойство | DepartmentName | торговое предприятие (наименование).
Открытое свойство | IncomingReturnedInvoiceItems | Вложенные товарные позиции по возврату от покупателя.
Открытое свойство | Invoice | Строка поля счет-фактуры
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН).
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование).
Открытое свойство | Number | Номер документа.
Открытое свойство | OutgoingInvoiceDate_DateTimeAsString | Дата расходной накладной. Представление в виде строки.
Открытое свойство | OutgoingInvoiceNumber | Номер расходной накладной.
Открытое свойство | Processed | Проведен ли документ.
Открытое свойство | Processed_BooleanAsString | Проведен ли документ. Представление в виде строки.
Открытое свойство | RevenueAccountCode | Движение денежных средств (код).
Открытое свойство | RevenueAccountName | Движение денежных средств.
Открытое свойство | WriteoffAccountCode | Статья расходов (код).
Открытое свойство | WriteoffAccountName | Статья расходов.
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstIncomingReturnedInvoiceItem | Получение первого элемента массива.
Открытый метод | GetNextIncomingReturnedInvoiceItem | Получение следующего элемента массива.
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIncomingReturnedInvoice - свойства

Тип IIncomingReturnedInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий.
Открытое свойство | ConceptionCode | Концепция (код).
Открытое свойство | ConceptionName | Концепция (название).
Открытое свойство | CustomerCode | Код покупателя.
Открытое свойство | CustomerINN | ИНН покупателя.
Открытое свойство | CustomerName | Наименование покупателя.
Открытое свойство | Date | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС).
Открытое свойство | Date_DateTimeAsString | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки.
Открытое свойство | DepartmentCode | Торговое предприятие (код).
Открытое свойство | DepartmentName | торговое предприятие (наименование).
Открытое свойство | IncomingReturnedInvoiceItems | Вложенные товарные позиции по возврату от покупателя.
Открытое свойство | Invoice | Строка поля счет-фактуры
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН).
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование).
Открытое свойство | Number | Номер документа.
Открытое свойство | OutgoingInvoiceDate_DateTimeAsString | Дата расходной накладной. Представление в виде строки.
Открытое свойство | OutgoingInvoiceNumber | Номер расходной накладной.
Открытое свойство | Processed | Проведен ли документ.
Открытое свойство | Processed_BooleanAsString | Проведен ли документ. Представление в виде строки.
Открытое свойство | RevenueAccountCode | Движение денежных средств (код).
Открытое свойство | RevenueAccountName | Движение денежных средств.
Открытое свойство | WriteoffAccountCode | Статья расходов (код).
Открытое свойство | WriteoffAccountName | Статья расходов.
В начало страницы
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Comment - свойство

Комментарий.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.ConceptionCode - свойство

Концепция (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.ConceptionName - свойство

Концепция (название).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.CustomerCode - свойство

Код покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.CustomerINN - свойство

ИНН покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.CustomerName - свойство

Наименование покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Date - свойство

Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Date_DateTimeAsString - свойство

Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.DepartmentCode - свойство

Торговое предприятие (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.DepartmentName - свойство

торговое предприятие (наименование).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.IncomingReturnedInvoiceItems - свойство

Вложенные товарные позиции по возврату от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoiceItem[] IncomingReturnedInvoiceItems { get; }

Значение свойства

Тип: IIncomingReturnedInvoiceItem
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Invoice - свойство

Строка поля счет-фактуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Invoice { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.JuristicPersonINN - свойство

Юридическое лицо (ИНН).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.JuristicPersonName - свойство

Юридическое лицо (наименование).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Number - свойство

Номер документа.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.OutgoingInvoiceDate_DateTimeAsString - свойство

Дата расходной накладной. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OutgoingInvoiceDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.OutgoingInvoiceNumber - свойство

Номер расходной накладной.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OutgoingInvoiceNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Processed - свойство

Проведен ли документ.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.Processed_BooleanAsString - свойство

Проведен ли документ. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.RevenueAccountCode - свойство

Движение денежных средств (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.RevenueAccountName - свойство

Движение денежных средств.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.WriteoffAccountCode - свойство

Статья расходов (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.WriteoffAccountName - свойство

Статья расходов.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice - методы

Тип IIncomingReturnedInvoice предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstIncomingReturnedInvoiceItem | Получение первого элемента массива.
Открытый метод | GetNextIncomingReturnedInvoiceItem | Получение следующего элемента массива.
В начало страницы
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.GetFirstIncomingReturnedInvoiceItem - метод

Получение первого элемента массива.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoiceItem GetFirstIncomingReturnedInvoiceItem()

Возвращаемое значение

Тип: IIncomingReturnedInvoiceItem
Товарная единица по возврату от покупателя.
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoice.GetNextIncomingReturnedInvoiceItem - метод

Получение следующего элемента массива.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoiceItem GetNextIncomingReturnedInvoiceItem()

Возвращаемое значение

Тип: IIncomingReturnedInvoiceItem
Товарная единица по возврату от покупателя.
См. также

Ссылки

IIncomingReturnedInvoice - интерфейс


IIncomingReturnedInvoiceItem - интерфейс

Интерфейс товарных единиц по возврату от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIncomingReturnedInvoiceItem

Тип IIncomingReturnedInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | Группа учета (название).
Открытое свойство | AccountingCategoryCode | Группа учета (код).
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности).
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки.
Открытое свойство | Article | Номенклатурный код.
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности).
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности).
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | IncomePrice | Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности).
Открытое свойство | IncomePrice_DecimalAsString | Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | IncomeSum | Сумма, которая будет зачислена на склад (IEEE-число 2ой точности).
Открытое свойство | IncomeSum_DecimalAsString | Сумма, которая будет зачислена на склад (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование).
Открытое свойство | MeasureUnitName | Единица измерения (код).
Открытое свойство | Nds | Сумма НДС (IEEE-число 2ой точности).
Открытое свойство | Nds_DecimalAsString | Сумма НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | NdsPercent | Ставка НДС (IEEE-число 2ой точности).
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры.
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС).
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)).
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)). Представление в виде строки.
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название).
Открытое свойство | PriceWithNds | Цена с НДС (IEEE-число 2ой точности).
Открытое свойство | PriceWithNds_DecimalAsString | Цена с НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада.
Открытое свойство | StoreName | Название склада.
Открытое свойство | SumWithNds | Сумма с НДС (IEEE-число 2ой точности).
Открытое свойство | SumWithNds_DecimalAsString | Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIncomingReturnedInvoiceItem - свойства

Тип IIncomingReturnedInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | Группа учета (название).
Открытое свойство | AccountingCategoryCode | Группа учета (код).
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности).
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки.
Открытое свойство | Article | Номенклатурный код.
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности).
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности).
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | IncomePrice | Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности).
Открытое свойство | IncomePrice_DecimalAsString | Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | IncomeSum | Сумма, которая будет зачислена на склад (IEEE-число 2ой точности).
Открытое свойство | IncomeSum_DecimalAsString | Сумма, которая будет зачислена на склад (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование).
Открытое свойство | MeasureUnitName | Единица измерения (код).
Открытое свойство | Nds | Сумма НДС (IEEE-число 2ой точности).
Открытое свойство | Nds_DecimalAsString | Сумма НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | NdsPercent | Ставка НДС (IEEE-число 2ой точности).
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры.
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС).
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)).
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)). Представление в виде строки.
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название).
Открытое свойство | PriceWithNds | Цена с НДС (IEEE-число 2ой точности).
Открытое свойство | PriceWithNds_DecimalAsString | Цена с НДС (IEEE-число 2ой точности). Представление в виде строки.
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада.
Открытое свойство | StoreName | Название склада.
Открытое свойство | SumWithNds | Сумма с НДС (IEEE-число 2ой точности).
Открытое свойство | SumWithNds_DecimalAsString | Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.AccountingCategory - свойство

Группа учета (название).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.AccountingCategoryCode - свойство

Группа учета (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.AlcoCategoryCode - свойство

Код классификатора алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AlcoCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Amount - свойство

Количество (IEEE-число 4ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Article - свойство

Номенклатурный код.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.IncomePrice - свойство

Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double IncomePrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.IncomePrice_DecimalAsString - свойство

Цена единицы товара, по которой будет сделан приход на склад (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomePrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.IncomeSum - свойство

Сумма, которая будет зачислена на склад (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double IncomeSum { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.IncomeSum_DecimalAsString - свойство

Сумма, которая будет зачислена на склад (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomeSum_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.MeasureUnitCode - свойство

Единица измерения (наименование).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.MeasureUnitName - свойство

Единица измерения (код).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Nds - свойство

Сумма НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Nds_DecimalAsString - свойство

Сумма НДС (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NdsPercent - свойство

Ставка НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NdsPercent_DecimalAsString - свойство

Ставка НДС (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.Nomenclature - свойство

Наименование номенклатуры.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис(услуга)). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.PriceWithNds - свойство

Цена с НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.PriceWithNds_DecimalAsString - свойство

Цена с НДС (IEEE-число 2ой точности). Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.ProducerJurPersonInn - свойство

ИНН для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonInn { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.ProducerJurPersonKpp - свойство

КПП для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonKpp { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.ProducerJurPersonName - свойство

Имя ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.StoreCode - свойство

Код склада.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.StoreName - свойство

Название склада.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.SumWithNds - свойство

Сумма с НДС (IEEE-число 2ой точности).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoiceItem.SumWithNds_DecimalAsString - свойство

Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingReturnedInvoiceItem - интерфейс


IIncomingReturnedInvoices - интерфейс

Интерфейс загрузки возвратов от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIncomingReturnedInvoices

Тип IIncomingReturnedInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | IncomingReturnedInvoiceArray | Вложенные возвраты от покупателя.
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstIncomingReturnedInvoice | Получение первого элемента массива.
Открытый метод | GetNextIncomingReturnedInvoice | Получение следующего элемента массива.
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIncomingReturnedInvoices - свойства

Тип IIncomingReturnedInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | IncomingReturnedInvoiceArray | Вложенные возвраты от покупателя.
В начало страницы
См. также

Ссылки

IIncomingReturnedInvoices - интерфейс


IIncomingReturnedInvoices.IncomingReturnedInvoiceArray - свойство

Вложенные возвраты от покупателя.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoice[] IncomingReturnedInvoiceArray { get; }

Значение свойства

Тип: IIncomingReturnedInvoice
См. также

Ссылки

IIncomingReturnedInvoices - интерфейс


IIncomingReturnedInvoices - методы

Тип IIncomingReturnedInvoices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstIncomingReturnedInvoice | Получение первого элемента массива.
Открытый метод | GetNextIncomingReturnedInvoice | Получение следующего элемента массива.
В начало страницы
См. также

Ссылки

IIncomingReturnedInvoices - интерфейс


IIncomingReturnedInvoices.GetFirstIncomingReturnedInvoice - метод

Получение первого элемента массива.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoice GetFirstIncomingReturnedInvoice()

Возвращаемое значение

Тип: IIncomingReturnedInvoice
Возврат от покупателя.
См. также

Ссылки

IIncomingReturnedInvoices - интерфейс


IIncomingReturnedInvoices.GetNextIncomingReturnedInvoice - метод

Получение следующего элемента массива.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingReturnedInvoice GetNextIncomingReturnedInvoice()

Возвращаемое значение

Тип: IIncomingReturnedInvoice
Возврат от покупателя.
См. также

Ссылки

IIncomingReturnedInvoices - интерфейс


IIncomingServiceData - интерфейс

Интерфейс актов приема услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIncomingServiceData

Тип IIncomingServiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountCode | Код счета
Открытое свойство | AccountName | Название счета
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIncomingServiceData - свойства

Тип IIncomingServiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountCode | Код счета
Открытое свойство | AccountName | Название счета
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.AccountCode - свойство

Код счета

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.AccountName - свойство

Название счета

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Correspond_BooleanAsString - свойство

Соответствует заказу. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Correspond_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.DueDate_DateTimeAsString - свойство

Срок оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DueDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.IncomingDate_DateTimeAsString - свойство

входящая дата. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.IncomingNumber - свойство

входящий номер

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Invoice - свойство

Счет-фактура (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Invoice { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.InvoiceItems - свойство

Вложенные товарные позиции по накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem[] InvoiceItems { get; }

Значение свойства

Тип: IInvoiceItem
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Number - свойство

номер накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.PaymentDate_DateTimeAsString - свойство

Дата оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.StaffCode - свойство

Код сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.StaffName - свойство

Имя сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.SupplierCode - свойство

Код поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.SupplierINN - свойство

ИНН поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.SupplierName - свойство

Наименование поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.SupplierStoreCode - свойство

Склад поставщик (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.SupplierStoreName - свойство

Склад поставщик (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.Timely_BooleanAsString - свойство

Доставка в срок. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Timely_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.TransportInvoiceNumber - свойство

Номер товарно-транспортной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TransportInvoiceNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData - методы

Тип IIncomingServiceData предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.GetFirstInvoiceItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetFirstInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServiceData.GetNextInvoiceItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetNextInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IIncomingServiceData - интерфейс


IIncomingServices - интерфейс

Интерфейс загрузки актов приема услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIncomingServices

Тип IIncomingServices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | Вложенные акты приема услуг
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIncomingServices - свойства

Тип IIncomingServices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | Вложенные акты приема услуг
В начало страницы
См. также

Ссылки

IIncomingServices - интерфейс


IIncomingServices.InvoiceData - свойство

Вложенные акты приема услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingServiceData[] InvoiceData { get; }

Значение свойства

Тип: IIncomingServiceData
См. также

Ссылки

IIncomingServices - интерфейс


IIncomingServices - методы

Тип IIncomingServices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IIncomingServices - интерфейс


IIncomingServices.GetFirstInvoiceData - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingServiceData GetFirstInvoiceData()

Возвращаемое значение

Тип: IIncomingServiceData
Акт приема услуг
См. также

Ссылки

IIncomingServices - интерфейс


IIncomingServices.GetNextInvoiceData - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IIncomingServiceData GetNextInvoiceData()

Возвращаемое значение

Тип: IIncomingServiceData
Акт приема услуг
См. также

Ссылки

IIncomingServices - интерфейс


IIntegration - интерфейс

Интерфейс загрузки справочников

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IIntegration

Тип IIntegration предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | Connect | Соединение с сервером
Открытый метод | ExportAssemblyCharts | Выгрузить технологические карты
Открытый метод | ExportNomenclature | Выгрузка номенклатуры
Открытый метод | ExportPriceList | Выгрузить прайс-лист
Открытый метод | ImportAssemblyCharts | Загрузить технологические карты
Открытый метод | ImportChoiceBindings | Выгрузка номенклатуры
Открытый метод | ImportGroups | Загрузка номенклатурных групп
Открытый метод | ImportNomenclature | Загрузка номенклатуры
Открытый метод | ImportPriceList | Загрузка приказа об изменении меню
Открытый метод | ImportProducts | Загрузка номенклатурных позиций
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IIntegration - методы

Тип IIntegration предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | Connect | Соединение с сервером
Открытый метод | ExportAssemblyCharts | Выгрузить технологические карты
Открытый метод | ExportNomenclature | Выгрузка номенклатуры
Открытый метод | ExportPriceList | Выгрузить прайс-лист
Открытый метод | ImportAssemblyCharts | Загрузить технологические карты
Открытый метод | ImportChoiceBindings | Выгрузка номенклатуры
Открытый метод | ImportGroups | Загрузка номенклатурных групп
Открытый метод | ImportNomenclature | Загрузка номенклатуры
Открытый метод | ImportPriceList | Загрузка приказа об изменении меню
Открытый метод | ImportProducts | Загрузка номенклатурных позиций
В начало страницы
См. также

Ссылки

IIntegration - интерфейс


IIntegration.Connect - метод

Соединение с сервером

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void Connect(
    string server,
    string login,
    string password
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ExportAssemblyCharts - метод

Выгрузить технологические карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IAssemblyChartList ExportAssemblyCharts(
    bool allHistory
)

Параметры

allHistory
Тип: SystemBoolean
true - вся история

Возвращаемое значение

Тип: IAssemblyChartList
Технологические карты
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ExportNomenclature - метод

Выгрузка номенклатуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
INomenclature ExportNomenclature(
    bool includeDeleted
)

Параметры

includeDeleted
Тип: SystemBoolean
true - включать удаленные

Возвращаемое значение

Тип: INomenclature
Номенклатура
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ExportPriceList - метод

Выгрузить прайс-лист

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITreeMenuChangeDocument ExportPriceList(
    string number
)

Параметры

number
Тип: SystemString
Номер прайс-листа

Возвращаемое значение

Тип: ITreeMenuChangeDocument
Прайс-лист
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportAssemblyCharts - метод

Загрузить технологические карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportAssemblyCharts(
    IAssemblyChartList assemblyCharts
)

Параметры

assemblyCharts
Тип: iiko1CInterface.InterfacesIAssemblyChartList
Технологические карты
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportChoiceBindings - метод

Выгрузка номенклатуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportChoiceBindings(
    IChoiceBindingInfoList сhoiceBindingList
)

Параметры

сhoiceBindingList
Тип: iiko1CInterface.InterfacesIChoiceBindingInfoList
Список номенклатуры
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportGroups - метод

Загрузка номенклатурных групп

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportGroups(
    INomenclature nomenclature,
    int importType
)

Параметры

nomenclature
Тип: iiko1CInterface.InterfacesINomenclature
Номенклатуры
importType
Тип: SystemInt32
Тип импорта 0 - позиции в загрузке добавляются/замещаются 1 - загрузка содержит полный набор объектов, все остальные позиции удаляются
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportNomenclature - метод

Загрузка номенклатуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportNomenclature(
    INomenclature nomenclature,
    int importType
)

Параметры

nomenclature
Тип: iiko1CInterface.InterfacesINomenclature
Номенклатура
importType
Тип: SystemInt32
Тип импорта 0 - позиции в загрузке добавляются/замещаются 1 - загрузка содержит полный набор объектов, все остальные позиции удаляются
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportPriceList - метод

Загрузка приказа об изменении меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportPriceList(
    ITreeMenuChangeDocument document
)

Параметры

document
Тип: iiko1CInterface.InterfacesITreeMenuChangeDocument
Приказ
См. также

Ссылки

IIntegration - интерфейс


IIntegration.ImportProducts - метод

Загрузка номенклатурных позиций

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ImportProducts(
    INomenclature nomenclature,
    bool importChoiceBindigs,
    int importType
)

Параметры

nomenclature
Тип: iiko1CInterface.InterfacesINomenclature
Номенклатуры
importChoiceBindigs
Тип: SystemBoolean
true - импортировать список номенклатуры
importType
Тип: SystemInt32
Тип импорта 0 - позиции в загрузке добавляются/замещаются 1 - загрузка содержит полный набор объектов, все остальные позиции удаляются
См. также

Ссылки

IIntegration - интерфейс


IInternalTransfer - интерфейс

Интерфейс вложенных внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInternalTransfer

Тип IInternalTransfer предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentIncomeCode | торговое предприятие, получатель (код)
Открытое свойство | DepartmentIncomeName | торговое предприятие, получатель (наименование)
Открытое свойство | DepartmentOutcomeCode | торговое предприятие, отправитель (код)
Открытое свойство | DepartmentOutcomeName | торговое предприятие, отправитель (наименование)
Открытое свойство | InternalTransferItems | Вложенные товарные позиции внутренних перемещений
Открытое свойство | JuristicPersonIncomeINN | Юридическое лицо, получатель (ИНН)
Открытое свойство | JuristicPersonIncomeName | Юридическое лицо, получатель (наименование)
Открытое свойство | JuristicPersonOutcomeINN | Юридическое лицо, отправитель (ИНН)
Открытое свойство | JuristicPersonOutcomeName | Юридическое лицо, отправитель (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StoreIncomeCode | Код склада получатель (строковое значение)
Открытое свойство | StoreIncomeName | Название склада получатель (строковое значение)
Открытое свойство | StoreOutcomeCode | Код склада отправитель (строковое значение)
Открытое свойство | StoreOutcomeName | Название склада отправитель (строковое значение)
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInternalTransferItem | Получение первого элемента массива
Открытый метод | GetNextInternalTransferItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInternalTransfer - свойства

Тип IInternalTransfer предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentIncomeCode | торговое предприятие, получатель (код)
Открытое свойство | DepartmentIncomeName | торговое предприятие, получатель (наименование)
Открытое свойство | DepartmentOutcomeCode | торговое предприятие, отправитель (код)
Открытое свойство | DepartmentOutcomeName | торговое предприятие, отправитель (наименование)
Открытое свойство | InternalTransferItems | Вложенные товарные позиции внутренних перемещений
Открытое свойство | JuristicPersonIncomeINN | Юридическое лицо, получатель (ИНН)
Открытое свойство | JuristicPersonIncomeName | Юридическое лицо, получатель (наименование)
Открытое свойство | JuristicPersonOutcomeINN | Юридическое лицо, отправитель (ИНН)
Открытое свойство | JuristicPersonOutcomeName | Юридическое лицо, отправитель (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StoreIncomeCode | Код склада получатель (строковое значение)
Открытое свойство | StoreIncomeName | Название склада получатель (строковое значение)
Открытое свойство | StoreOutcomeCode | Код склада отправитель (строковое значение)
Открытое свойство | StoreOutcomeName | Название склада отправитель (строковое значение)
В начало страницы
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.DepartmentIncomeCode - свойство

торговое предприятие, получатель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentIncomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.DepartmentIncomeName - свойство

торговое предприятие, получатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.DepartmentOutcomeCode - свойство

торговое предприятие, отправитель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentOutcomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.DepartmentOutcomeName - свойство

торговое предприятие, отправитель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.InternalTransferItems - свойство

Вложенные товарные позиции внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransferItem[] InternalTransferItems { get; }

Значение свойства

Тип: IInternalTransferItem
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.JuristicPersonIncomeINN - свойство

Юридическое лицо, получатель (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonIncomeINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.JuristicPersonIncomeName - свойство

Юридическое лицо, получатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.JuristicPersonOutcomeINN - свойство

Юридическое лицо, отправитель (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonOutcomeINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.JuristicPersonOutcomeName - свойство

Юридическое лицо, отправитель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.StoreIncomeCode - свойство

Код склада получатель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreIncomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.StoreIncomeName - свойство

Название склада получатель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.StoreOutcomeCode - свойство

Код склада отправитель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreOutcomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.StoreOutcomeName - свойство

Название склада отправитель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer - методы

Тип IInternalTransfer предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInternalTransferItem | Получение первого элемента массива
Открытый метод | GetNextInternalTransferItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.GetFirstInternalTransferItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransferItem GetFirstInternalTransferItem()

Возвращаемое значение

Тип: IInternalTransferItem
Внутреннее перемещение
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransfer.GetNextInternalTransferItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransferItem GetNextInternalTransferItem()

Возвращаемое значение

Тип: IInternalTransferItem
Внутреннее перемещение
См. также

Ссылки

IInternalTransfer - интерфейс


IInternalTransferItem - интерфейс

Интерфейс товарных единиц внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInternalTransferItem

Тип IInternalTransferItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentIncomeCode | Устарело. торговое предприятие, получатель (код)
Открытое свойство | DepartmentIncomeName | Устарело. торговое предприятие, получатель (наименование)
Открытое свойство | DepartmentOutcomeCode | Устарело. торговое предприятие, отправитель (код)
Открытое свойство | DepartmentOutcomeName | Устарело. торговое предприятие, отправитель (наименование)
Открытое свойство | JuristicPersonIncomeINN | Устарело. Юридическое лицо, получатель (ИНН)
Открытое свойство | JuristicPersonIncomeName | Устарело. Юридическое лицо, получатель (наименование)
Открытое свойство | JuristicPersonOutcomeINN | Устарело. Юридическое лицо, отправитель (ИНН)
Открытое свойство | JuristicPersonOutcomeName | Устарело. Юридическое лицо, отправитель (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | StoreIncomeCode | Устарело. Код склада получатель (строковое значение)
Открытое свойство | StoreIncomeName | Устарело. Название склада получатель (строковое значение)
Открытое свойство | StoreOutcomeCode | Устарело. Код склада отправитель (строковое значение)
Открытое свойство | StoreOutcomeName | Устарело. Название склада отправитель (строковое значение)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInternalTransferItem - свойства

Тип IInternalTransferItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentIncomeCode | Устарело. торговое предприятие, получатель (код)
Открытое свойство | DepartmentIncomeName | Устарело. торговое предприятие, получатель (наименование)
Открытое свойство | DepartmentOutcomeCode | Устарело. торговое предприятие, отправитель (код)
Открытое свойство | DepartmentOutcomeName | Устарело. торговое предприятие, отправитель (наименование)
Открытое свойство | JuristicPersonIncomeINN | Устарело. Юридическое лицо, получатель (ИНН)
Открытое свойство | JuristicPersonIncomeName | Устарело. Юридическое лицо, получатель (наименование)
Открытое свойство | JuristicPersonOutcomeINN | Устарело. Юридическое лицо, отправитель (ИНН)
Открытое свойство | JuristicPersonOutcomeName | Устарело. Юридическое лицо, отправитель (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | StoreIncomeCode | Устарело. Код склада получатель (строковое значение)
Открытое свойство | StoreIncomeName | Устарело. Название склада получатель (строковое значение)
Открытое свойство | StoreOutcomeCode | Устарело. Код склада отправитель (строковое значение)
Открытое свойство | StoreOutcomeName | Устарело. Название склада отправитель (строковое значение)
В начало страницы
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.DepartmentIncomeCode - свойство

Примечание: Данный API устарел.

торговое предприятие, получатель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentIncomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.DepartmentIncomeName - свойство

Примечание: Данный API устарел.

торговое предприятие, получатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.DepartmentOutcomeCode - свойство

Примечание: Данный API устарел.

торговое предприятие, отправитель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentOutcomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.DepartmentOutcomeName - свойство

Примечание: Данный API устарел.

торговое предприятие, отправитель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.JuristicPersonIncomeINN - свойство

Примечание: Данный API устарел.

Юридическое лицо, получатель (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonIncomeINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.JuristicPersonIncomeName - свойство

Примечание: Данный API устарел.

Юридическое лицо, получатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.JuristicPersonOutcomeINN - свойство

Примечание: Данный API устарел.

Юридическое лицо, отправитель (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonOutcomeINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.JuristicPersonOutcomeName - свойство

Примечание: Данный API устарел.

Юридическое лицо, отправитель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.StoreIncomeCode - свойство

Примечание: Данный API устарел.

Код склада получатель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string StoreIncomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.StoreIncomeName - свойство

Примечание: Данный API устарел.

Название склада получатель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string StoreIncomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.StoreOutcomeCode - свойство

Примечание: Данный API устарел.

Код склада отправитель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string StoreOutcomeCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransferItem.StoreOutcomeName - свойство

Примечание: Данный API устарел.

Название склада отправитель (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string StoreOutcomeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInternalTransferItem - интерфейс


IInternalTransfers - интерфейс

Интерфейс загрузки внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInternalTransfers

Тип IInternalTransfers предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InternalTransferArray | вложенные внутреннее перемещения
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInternalTransfer | Получение первого элемента массива
Открытый метод | GetNextInternalTransfer | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInternalTransfers - свойства

Тип IInternalTransfers предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InternalTransferArray | вложенные внутреннее перемещения
В начало страницы
См. также

Ссылки

IInternalTransfers - интерфейс


IInternalTransfers.InternalTransferArray - свойство

вложенные внутреннее перемещения

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransfer[] InternalTransferArray { get; }

Значение свойства

Тип: IInternalTransfer
См. также

Ссылки

IInternalTransfers - интерфейс


IInternalTransfers - методы

Тип IInternalTransfers предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInternalTransfer | Получение первого элемента массива
Открытый метод | GetNextInternalTransfer | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInternalTransfers - интерфейс


IInternalTransfers.GetFirstInternalTransfer - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransfer GetFirstInternalTransfer()

Возвращаемое значение

Тип: IInternalTransfer
Внутренее перемещение
См. также

Ссылки

IInternalTransfers - интерфейс


IInternalTransfers.GetNextInternalTransfer - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransfer GetNextInternalTransfer()

Возвращаемое значение

Тип: IInternalTransfer
Внутренее перемещение
См. также

Ссылки

IInternalTransfers - интерфейс


IInventories - интерфейс

Интерфейс загрузки инвентаризаций

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInventories

Тип IInventories предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InventoryArray | вложенные инвентаризации
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddInventoryArray | Добавление элемента к массиву
Открытый метод | ClearInventoryArray | Очистка массива
Открытый метод | GetFirstInventory | Получение первого элемента массива
Открытый метод | GetNextInventory | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInventories - свойства

Тип IInventories предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InventoryArray | вложенные инвентаризации
В начало страницы
См. также

Ссылки

IInventories - интерфейс


IInventories.InventoryArray - свойство

вложенные инвентаризации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventory[] InventoryArray { get; set; }

Значение свойства

Тип: IInventory
См. также

Ссылки

IInventories - интерфейс


IInventories - методы

Тип IInventories предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddInventoryArray | Добавление элемента к массиву
Открытый метод | ClearInventoryArray | Очистка массива
Открытый метод | GetFirstInventory | Получение первого элемента массива
Открытый метод | GetNextInventory | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInventories - интерфейс


IInventories.AddInventoryArray - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddInventoryArray(
    IInventory item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIInventory
Инвентаризация
См. также

Ссылки

IInventories - интерфейс


IInventories.ClearInventoryArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearInventoryArray()
См. также

Ссылки

IInventories - интерфейс


IInventories.GetFirstInventory - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventory GetFirstInventory()

Возвращаемое значение

Тип: IInventory
Инвентаризация
См. также

Ссылки

IInventories - интерфейс


IInventories.GetNextInventory - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventory GetNextInventory()

Возвращаемое значение

Тип: IInventory
Инвентаризация
См. также

Ссылки

IInventories - интерфейс


IInventory - интерфейс

Интерфейс вложеных инвентаризаций

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInventory

Тип IInventory предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountShortageCode | Счет недостачи (код)
Открытое свойство | AccountShortageName | Счет недостачи (наименование)
Открытое свойство | AccountSurplusCode | Счет излишков (код)
Открытое свойство | AccountSurplusName | Счет излишков (наименование)
Открытое свойство | Comment | Комментарий
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | InventoryItem | Вложенные товарные позиции инвентаризации
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddInventoryItem | Добавление элемента к массиву
Открытый метод | ClearInventoryItem | Очистка массива
Открытый метод | GetFirstInventoryItem | Получение первого элемента массива
Открытый метод | GetNextInventoryItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInventory - свойства

Тип IInventory предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountShortageCode | Счет недостачи (код)
Открытое свойство | AccountShortageName | Счет недостачи (наименование)
Открытое свойство | AccountSurplusCode | Счет излишков (код)
Открытое свойство | AccountSurplusName | Счет излишков (наименование)
Открытое свойство | Comment | Комментарий
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | InventoryItem | Вложенные товарные позиции инвентаризации
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
См. также

Ссылки

IInventory - интерфейс


IInventory.AccountShortageCode - свойство

Счет недостачи (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountShortageCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.AccountShortageName - свойство

Счет недостачи (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountShortageName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.AccountSurplusCode - свойство

Счет излишков (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountSurplusCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.AccountSurplusName - свойство

Счет излишков (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountSurplusName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IInventory - интерфейс


IInventory.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.InventoryItem - свойство

Вложенные товарные позиции инвентаризации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventoryItem[] InventoryItem { get; }

Значение свойства

Тип: IInventoryItem
См. также

Ссылки

IInventory - интерфейс


IInventory.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IInventory - интерфейс


IInventory.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventory - интерфейс


IInventory - методы

Тип IInventory предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddInventoryItem | Добавление элемента к массиву
Открытый метод | ClearInventoryItem | Очистка массива
Открытый метод | GetFirstInventoryItem | Получение первого элемента массива
Открытый метод | GetNextInventoryItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInventory - интерфейс


IInventory.AddInventoryItem - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddInventoryItem(
    IInventoryItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIInventoryItem
Инвентаризация
См. также

Ссылки

IInventory - интерфейс


IInventory.ClearInventoryItem - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearInventoryItem()
См. также

Ссылки

IInventory - интерфейс


IInventory.GetFirstInventoryItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventoryItem GetFirstInventoryItem()

Возвращаемое значение

Тип: IInventoryItem
Инвентаризация
См. также

Ссылки

IInventory - интерфейс


IInventory.GetNextInventoryItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventoryItem GetNextInventoryItem()

Возвращаемое значение

Тип: IInventoryItem
Инвентаризация
См. также

Ссылки

IInventory - интерфейс


IInventoryItem - интерфейс

Интерфейс товарных единиц инвентаризции

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInventoryItem

Тип IInventoryItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | DiffAmount | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения
Открытое свойство | DiffAmount_DecimalAsString | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения.. Представление в виде строки
Открытое свойство | DiffCost | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС
Открытое свойство | DiffCost_DecimalAsString | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС.. Представление в виде строки
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInventoryItem - свойства

Тип IInventoryItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | DiffAmount | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения
Открытое свойство | DiffAmount_DecimalAsString | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения.. Представление в виде строки
Открытое свойство | DiffCost | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС
Открытое свойство | DiffCost_DecimalAsString | разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС.. Представление в виде строки
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
В начало страницы
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.CostPrice - свойство

Себестоимость (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.CostPrice_DecimalAsString - свойство

Себестоимость (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.CostPriceByUnit - свойство

Себестоимость за ед. (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DiffAmount - свойство

разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double DiffAmount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DiffAmount_DecimalAsString - свойство

разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В основной единице измерения.. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiffAmount_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DiffCost - свойство

разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double DiffCost { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.DiffCost_DecimalAsString - свойство

разница между книжными остатками и результатми инвентаризации (положительная для излишков, отрицательная для недостач). В рублях без НДС.. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiffCost_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInventoryItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IInventoryItem - интерфейс


IInvoiceData - интерфейс

Интерфейс вложенных приходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInvoiceData

Тип IInvoiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInvoiceData - свойства

Тип IInvoiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Correspond_BooleanAsString - свойство

Соответствует заказу. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Correspond_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.DueDate_DateTimeAsString - свойство

Срок оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DueDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.IncomingDate_DateTimeAsString - свойство

входящая дата. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.IncomingNumber - свойство

входящий номер

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Invoice - свойство

Счет-фактура (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Invoice { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.InvoiceItems - свойство

Вложенные товарные позиции по накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem[] InvoiceItems { get; }

Значение свойства

Тип: IInvoiceItem
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Number - свойство

номер накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.PaymentDate_DateTimeAsString - свойство

Дата оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.StaffCode - свойство

Код сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.StaffName - свойство

Имя сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.SupplierCode - свойство

Код поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.SupplierINN - свойство

ИНН поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.SupplierName - свойство

Наименование поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.SupplierStoreCode - свойство

Склад поставщик (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.SupplierStoreName - свойство

Склад поставщик (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.Timely_BooleanAsString - свойство

Доставка в срок. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Timely_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.TransportInvoiceNumber - свойство

Номер товарно-транспортной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TransportInvoiceNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData - методы

Тип IInvoiceData предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.GetFirstInvoiceItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetFirstInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceData.GetNextInvoiceItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetNextInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IInvoiceData - интерфейс


IInvoiceDataLoader - интерфейс

Класс загрузки приходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInvoiceDataLoader

Тип IInvoiceDataLoader предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | IncludeUnprocessed | true: загружать непроведенные документы
В начало страницы
Методы
 | Имя | Описание
Открытый метод | LoadCashFlowData | Загрузка движений денежных средств
Открытый метод | LoadInternalTransfersData | Загрузка внутренних перемещений
Открытый метод | LoadInventoriesData | Загрузка инвентаризаций
Открытый метод | LoadInvoiceData | Загрузка приходных накладных
Открытый метод | LoadInvoiceDataFromFile | Загрузка приходных накладных за период из файла
Открытый метод | LoadOutgoingInvoicesData | Загрузка расходных накладных
Открытый метод | LoadProductionsData | Загрузка актов приготовления
Открытый метод | LoadProfitTakingData | Загрузка приема кассовой выручки
Открытый метод | LoadReturnedInvoicesData | Загрузка возвратных накладных
Открытый метод | LoadSalesData | Загрузка актов реализации
Открытый метод | LoadTransformationsData | Загрузка актов переработки
Открытый метод | LoadWriteoffsData | Загрузка актов списания
Открытый метод | SaveInvoiceData | Сохранение приходных накладных в файл
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInvoiceDataLoader - свойства

Тип IInvoiceDataLoader предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | IncludeUnprocessed | true: загружать непроведенные документы
В начало страницы
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.IncludeUnprocessed - свойство

true: загружать непроведенные документы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IncludeUnprocessed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader - методы

Тип IInvoiceDataLoader предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | LoadCashFlowData | Загрузка движений денежных средств
Открытый метод | LoadInternalTransfersData | Загрузка внутренних перемещений
Открытый метод | LoadInventoriesData | Загрузка инвентаризаций
Открытый метод | LoadInvoiceData | Загрузка приходных накладных
Открытый метод | LoadInvoiceDataFromFile | Загрузка приходных накладных за период из файла
Открытый метод | LoadOutgoingInvoicesData | Загрузка расходных накладных
Открытый метод | LoadProductionsData | Загрузка актов приготовления
Открытый метод | LoadProfitTakingData | Загрузка приема кассовой выручки
Открытый метод | LoadReturnedInvoicesData | Загрузка возвратных накладных
Открытый метод | LoadSalesData | Загрузка актов реализации
Открытый метод | LoadTransformationsData | Загрузка актов переработки
Открытый метод | LoadWriteoffsData | Загрузка актов списания
Открытый метод | SaveInvoiceData | Сохранение приходных накладных в файл
В начало страницы
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadCashFlowData - метод

Загрузка движений денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ICashFlows LoadCashFlowData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: ICashFlows
Движения денежных средств
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadInternalTransfersData - метод

Загрузка внутренних перемещений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInternalTransfers LoadInternalTransfersData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IInternalTransfers
Внутренние перемещения
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadInventoriesData - метод

Загрузка инвентаризаций

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInventories LoadInventoriesData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IInventories
Инвентаризации
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadInvoiceData - метод

Загрузка приходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoices LoadInvoiceData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IInvoices
Приходный накладные
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadInvoiceDataFromFile - метод

Загрузка приходных накладных за период из файла

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceData[] LoadInvoiceDataFromFile(
    string fileName,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

fileName
Тип: SystemString
Имя файла
dateFrom
Тип: SystemDateTime
Начало периода
dateTo
Тип: SystemDateTime
Окончания периода

Возвращаемое значение

Тип: IInvoiceData
Списко приходных накладных
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadOutgoingInvoicesData - метод

Загрузка расходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoices LoadOutgoingInvoicesData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IOutgoingInvoices
Расходные накладные
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadProductionsData - метод

Загрузка актов приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductions LoadProductionsData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IProductions
Акты приготовления
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadProfitTakingData - метод

Загрузка приема кассовой выручки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTakings LoadProfitTakingData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IProfitTakings
Кассовая выручка
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadReturnedInvoicesData - метод

Загрузка возвратных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoices LoadReturnedInvoicesData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IReturnedInvoices
Возвратные накладные
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadSalesData - метод

Загрузка актов реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISales LoadSalesData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: ISales
Акты реализации
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadTransformationsData - метод

Загрузка актов переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITransformations LoadTransformationsData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: ITransformations
Акты приготовления
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.LoadWriteoffsData - метод

Загрузка актов списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoffs LoadWriteoffsData(
    string server,
    string login,
    string password,
    DateTime dateFrom,
    DateTime dateTo
)

Параметры

server
Тип: SystemString
Uri сервера
login
Тип: SystemString
Логин
password
Тип: SystemString
Пароль
dateFrom
Тип: SystemDateTime
Дата начала
dateTo
Тип: SystemDateTime
Дата окончания

Возвращаемое значение

Тип: IWriteoffs
Акты списания
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceDataLoader.SaveInvoiceData - метод

Сохранение приходных накладных в файл

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void SaveInvoiceData(
    string fileName,
    IInvoiceData[] invoiceData
)

Параметры

fileName
Тип: SystemString
Имя файла
invoiceData
Тип: iiko1CInterface.InterfacesIInvoiceData
Массив приходных накладных
См. также

Ссылки

IInvoiceDataLoader - интерфейс


IInvoiceItem - интерфейс

Интерфейс товарных единиц по накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInvoiceItem

Тип IInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | AmountInContainer | Количество в таре
Открытое свойство | AmountInContainer_DecimalAsString | Количество в таре. Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | ContainerCode | Тара (код)
Открытое свойство | ContainerName | Тара (название)
Открытое свойство | CustomsDeclarationNumber | Номер государственной таможенной декларации
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | OuterProductCode | Номенклатура поставщика (код)
Открытое свойство | OuterProductName | Номенклатура поставщика (название)
Открытое свойство | PriceWithNds | Цена с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInvoiceItem - свойства

Тип IInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | AmountInContainer | Количество в таре
Открытое свойство | AmountInContainer_DecimalAsString | Количество в таре. Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | ContainerCode | Тара (код)
Открытое свойство | ContainerName | Тара (название)
Открытое свойство | CustomsDeclarationNumber | Номер государственной таможенной декларации
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | OuterProductCode | Номенклатура поставщика (код)
Открытое свойство | OuterProductName | Номенклатура поставщика (название)
Открытое свойство | PriceWithNds | Цена с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.AlcoCategoryCode - свойство

Код классификатора алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AlcoCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.AmountInContainer - свойство

Количество в таре

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double AmountInContainer { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.AmountInContainer_DecimalAsString - свойство

Количество в таре. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AmountInContainer_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.ContainerCode - свойство

Тара (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ContainerCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.ContainerName - свойство

Тара (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ContainerName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.CustomsDeclarationNumber - свойство

Номер государственной таможенной декларации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomsDeclarationNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Nds - свойство

Сумма НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Nds_DecimalAsString - свойство

Сумма НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NdsPercent - свойство

Ставка НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NdsPercent_DecimalAsString - свойство

Ставка НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.OuterProductCode - свойство

Номенклатура поставщика (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OuterProductCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.OuterProductName - свойство

Номенклатура поставщика (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OuterProductName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.PriceWithNds - свойство

Цена с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.PriceWithNds_DecimalAsString - свойство

Цена с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.ProducerJurPersonInn - свойство

ИНН для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonInn { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.ProducerJurPersonKpp - свойство

КПП для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonKpp { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.ProducerJurPersonName - свойство

Имя ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.SumWithNds - свойство

Сумма с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoiceItem.SumWithNds_DecimalAsString - свойство

Сумма с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IInvoiceItem - интерфейс


IInvoices - интерфейс

Интерфейс загрузки приходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IInvoices

Тип IInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | вложенные приходные накладные
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IInvoices - свойства

Тип IInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | вложенные приходные накладные
В начало страницы
См. также

Ссылки

IInvoices - интерфейс


IInvoices.InvoiceData - свойство

вложенные приходные накладные

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceData[] InvoiceData { get; }

Значение свойства

Тип: IInvoiceData
См. также

Ссылки

IInvoices - интерфейс


IInvoices - методы

Тип IInvoices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IInvoices - интерфейс


IInvoices.GetFirstInvoiceData - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceData GetFirstInvoiceData()

Возвращаемое значение

Тип: IInvoiceData
Приходная накладная
См. также

Ссылки

IInvoices - интерфейс


IInvoices.GetNextInvoiceData - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceData GetNextInvoiceData()

Возвращаемое значение

Тип: IInvoiceData
Приходная накладная
См. также

Ссылки

IInvoices - интерфейс


IMenuGroup - интерфейс

Интерфейс номенклатурной группы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IMenuGroup

Тип IMenuGroup предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Article | Номенклатурный код группы меню (артикул)
Открытое свойство | Deleted | Удалена ли группа
Открытое свойство | FastCode | Код быстрого набора
Открытое свойство | Id | Guid элемента
Открытое свойство | Name | Название группы меню
Открытое свойство | ParentArticle | Артикул родительской группы
Открытое свойство | ParentId | Guid родительской группы
Открытое свойство | Position | Позиция
Открытое свойство | PositionHasValue | Position имеет значение
Открытое свойство | Type | Тип группы меню (0 - не задана, 1 - продукты, 2 - модификаторы)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IMenuGroup - свойства

Тип IMenuGroup предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Article | Номенклатурный код группы меню (артикул)
Открытое свойство | Deleted | Удалена ли группа
Открытое свойство | FastCode | Код быстрого набора
Открытое свойство | Id | Guid элемента
Открытое свойство | Name | Название группы меню
Открытое свойство | ParentArticle | Артикул родительской группы
Открытое свойство | ParentId | Guid родительской группы
Открытое свойство | Position | Позиция
Открытое свойство | PositionHasValue | Position имеет значение
Открытое свойство | Type | Тип группы меню (0 - не задана, 1 - продукты, 2 - модификаторы)
В начало страницы
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Article - свойство

Номенклатурный код группы меню (артикул)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Deleted - свойство

Удалена ли группа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Deleted { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.FastCode - свойство

Код быстрого набора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string FastCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Id - свойство

Guid элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Id { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Name - свойство

Название группы меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Name { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.ParentArticle - свойство

Артикул родительской группы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ParentArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.ParentId - свойство

Guid родительской группы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ParentId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Position - свойство

Позиция

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Position { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.PositionHasValue - свойство

Position имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PositionHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuGroup - интерфейс


IMenuGroup.Type - свойство

Тип группы меню (0 - не задана, 1 - продукты, 2 - модификаторы)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Type { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IMenuGroup - интерфейс


IMenuItem - интерфейс

Интерфейс номенклатурного элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IMenuItem

Тип IMenuItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategoryCode | Бухгалтерская категория (код)
Открытое свойство | Article | Номенклатурный код элемента меню (артикул)
Открытое свойство | Barcodes | список штрихкодов продукта
Открытое свойство | ChoiceBindings | список модификаторов
Открытое свойство | CookingPlaceType | тип места приготовления
Открытое свойство | CookWithMainDish | Готовить вместе с основным блюдом
Открытое свойство | CookWithMainDishHasValue | CookWithMainDish имеет значение
Открытое свойство | Deleted | Удалено ли блюдо
Открытое свойство | FastCode | Код быстрого набора
Открытое свойство | Id | Guid элемента
Открытое свойство | IncludedInMenu | переменная, показывающая включено ли блюдо в меню. Если true – блюдо включено в меню, если false блюдо не включено в меню
Открытое свойство | IncludedInMenuHasValue | IncludedInMenu имеет значение
Открытое свойство | MeasureUnit | единица измерения (название)
Открытое свойство | Name | Название
Открытое свойство | OuterEanCode | Код ТН ВЭД ЕАЭС
Открытое свойство | ParentArticle | Артикул родительской группы
Открытое свойство | ParentId | Guid родительской группы
Открытое свойство | Position | Позиция
Открытое свойство | PositionHasValue | Position имеет значение
Открытое свойство | Price | цена элемента меню
Открытое свойство | PriceHasValue | Price имеет значение
Открытое свойство | PrintInCheque | переменная, определяющая печатать ли модификатор на чеке
Открытое свойство | PrintInChequeHasValue | PrintInCheque имеет значение
Открытое свойство | PrintInPrecheque | переменная, определяющая печатать ли модификатор на пречеке
Открытое свойство | PrintInPrechequeHasValue | PrintInPrecheque имеет значение
Открытое свойство | Type | тип элемента меню (1 - блюдо, 2 - модификатор, 3 – товар, 4 – заготовка, 5 – сервис)
Открытое свойство | UseBalanceForSell | переменная, указывающая использовать ли весы при продаже
Открытое свойство | UseBalanceForSellHasValue | UseBalanceForSell имеет значение
Открытое свойство | ValueAddedTax | налог на добавленную стоимость
Открытое свойство | ValueAddedTaxHasValue | ValueAddedTax имеет значение
В начало страницы
Методы
 | Имя | Описание
Открытый метод | BarcodesAddItem | Добавление элемента к массиву
Открытый метод | BarcodesClearArray | Очистка массива
Открытый метод | BarcodesGetFirstElement | Получение первого элемента
Открытый метод | BarcodesGetNextElement | Получение следующего элемента
Открытый метод | ChoiceBindingsAddItem | Добавление элемента к массиву
Открытый метод | ChoiceBindingsClearArray | Очистка массива
Открытый метод | ChoiceBindingsGetFirstElement | Получение первого элемента
Открытый метод | ChoiceBindingsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IMenuItem - свойства

Тип IMenuItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategoryCode | Бухгалтерская категория (код)
Открытое свойство | Article | Номенклатурный код элемента меню (артикул)
Открытое свойство | Barcodes | список штрихкодов продукта
Открытое свойство | ChoiceBindings | список модификаторов
Открытое свойство | CookingPlaceType | тип места приготовления
Открытое свойство | CookWithMainDish | Готовить вместе с основным блюдом
Открытое свойство | CookWithMainDishHasValue | CookWithMainDish имеет значение
Открытое свойство | Deleted | Удалено ли блюдо
Открытое свойство | FastCode | Код быстрого набора
Открытое свойство | Id | Guid элемента
Открытое свойство | IncludedInMenu | переменная, показывающая включено ли блюдо в меню. Если true – блюдо включено в меню, если false блюдо не включено в меню
Открытое свойство | IncludedInMenuHasValue | IncludedInMenu имеет значение
Открытое свойство | MeasureUnit | единица измерения (название)
Открытое свойство | Name | Название
Открытое свойство | OuterEanCode | Код ТН ВЭД ЕАЭС
Открытое свойство | ParentArticle | Артикул родительской группы
Открытое свойство | ParentId | Guid родительской группы
Открытое свойство | Position | Позиция
Открытое свойство | PositionHasValue | Position имеет значение
Открытое свойство | Price | цена элемента меню
Открытое свойство | PriceHasValue | Price имеет значение
Открытое свойство | PrintInCheque | переменная, определяющая печатать ли модификатор на чеке
Открытое свойство | PrintInChequeHasValue | PrintInCheque имеет значение
Открытое свойство | PrintInPrecheque | переменная, определяющая печатать ли модификатор на пречеке
Открытое свойство | PrintInPrechequeHasValue | PrintInPrecheque имеет значение
Открытое свойство | Type | тип элемента меню (1 - блюдо, 2 - модификатор, 3 – товар, 4 – заготовка, 5 – сервис)
Открытое свойство | UseBalanceForSell | переменная, указывающая использовать ли весы при продаже
Открытое свойство | UseBalanceForSellHasValue | UseBalanceForSell имеет значение
Открытое свойство | ValueAddedTax | налог на добавленную стоимость
Открытое свойство | ValueAddedTaxHasValue | ValueAddedTax имеет значение
В начало страницы
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.AccountingCategoryCode - свойство

Бухгалтерская категория (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Article - свойство

Номенклатурный код элемента меню (артикул)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Barcodes - свойство

список штрихкодов продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string[] Barcodes { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ChoiceBindings - свойство

список модификаторов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding[] ChoiceBindings { get; set; }

Значение свойства

Тип: IChoiceBinding
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.CookingPlaceType - свойство

тип места приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CookingPlaceType { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.CookWithMainDish - свойство

Готовить вместе с основным блюдом

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool CookWithMainDish { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.CookWithMainDishHasValue - свойство

CookWithMainDish имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool CookWithMainDishHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Deleted - свойство

Удалено ли блюдо

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Deleted { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.FastCode - свойство

Код быстрого набора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string FastCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Id - свойство

Guid элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Id { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.IncludedInMenu - свойство

переменная, показывающая включено ли блюдо в меню. Если true – блюдо включено в меню, если false блюдо не включено в меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IncludedInMenu { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.IncludedInMenuHasValue - свойство

IncludedInMenu имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IncludedInMenuHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.MeasureUnit - свойство

единица измерения (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnit { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Name - свойство

Название

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Name { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.OuterEanCode - свойство

Код ТН ВЭД ЕАЭС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ParentArticle - свойство

Артикул родительской группы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ParentArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ParentId - свойство

Guid родительской группы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ParentId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Position - свойство

Позиция

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Position { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PositionHasValue - свойство

Position имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PositionHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Price - свойство

цена элемента меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Price { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PriceHasValue - свойство

Price имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PriceHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PrintInCheque - свойство

переменная, определяющая печатать ли модификатор на чеке

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PrintInCheque { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PrintInChequeHasValue - свойство

PrintInCheque имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PrintInChequeHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PrintInPrecheque - свойство

переменная, определяющая печатать ли модификатор на пречеке

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PrintInPrecheque { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.PrintInPrechequeHasValue - свойство

PrintInPrecheque имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool PrintInPrechequeHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.Type - свойство

тип элемента меню (1 - блюдо, 2 - модификатор, 3 – товар, 4 – заготовка, 5 – сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Type { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.UseBalanceForSell - свойство

переменная, указывающая использовать ли весы при продаже

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool UseBalanceForSell { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.UseBalanceForSellHasValue - свойство

UseBalanceForSell имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool UseBalanceForSellHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ValueAddedTax - свойство

налог на добавленную стоимость

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double ValueAddedTax { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ValueAddedTaxHasValue - свойство

ValueAddedTax имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool ValueAddedTaxHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem - методы

Тип IMenuItem предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | BarcodesAddItem | Добавление элемента к массиву
Открытый метод | BarcodesClearArray | Очистка массива
Открытый метод | BarcodesGetFirstElement | Получение первого элемента
Открытый метод | BarcodesGetNextElement | Получение следующего элемента
Открытый метод | ChoiceBindingsAddItem | Добавление элемента к массиву
Открытый метод | ChoiceBindingsClearArray | Очистка массива
Открытый метод | ChoiceBindingsGetFirstElement | Получение первого элемента
Открытый метод | ChoiceBindingsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.BarcodesAddItem - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void BarcodesAddItem(
    string item
)

Параметры

item
Тип: SystemString
Штирхкод
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.BarcodesClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void BarcodesClearArray()
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.BarcodesGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string BarcodesGetFirstElement()

Возвращаемое значение

Тип: String
Штирхкод
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.BarcodesGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string BarcodesGetNextElement()

Возвращаемое значение

Тип: String
Штирхкод
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ChoiceBindingsAddItem - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ChoiceBindingsAddItem(
    IChoiceBinding item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIChoiceBinding
Модификатор
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ChoiceBindingsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ChoiceBindingsClearArray()
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ChoiceBindingsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding ChoiceBindingsGetFirstElement()

Возвращаемое значение

Тип: IChoiceBinding
Модификатор
См. также

Ссылки

IMenuItem - интерфейс


IMenuItem.ChoiceBindingsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IChoiceBinding ChoiceBindingsGetNextElement()

Возвращаемое значение

Тип: IChoiceBinding
Модификатор
См. также

Ссылки

IMenuItem - интерфейс


INomenclature - интерфейс

Интерфейс номенклатуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface INomenclature

Тип INomenclature предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Groups | список групп
Открытое свойство | Items | список блюд
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GroupsAddItem | Добавление элемента
Открытый метод | GroupsClearArray | Очистка массива
Открытый метод | GroupsGetFirstElement | Получение первого элемента
Открытый метод | GroupsGetNextElement | Получение следующего элемента
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


INomenclature - свойства

Тип INomenclature предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Groups | список групп
Открытое свойство | Items | список блюд
В начало страницы
См. также

Ссылки

INomenclature - интерфейс


INomenclature.Groups - свойство

список групп

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuGroup[] Groups { get; set; }

Значение свойства

Тип: IMenuGroup
См. также

Ссылки

INomenclature - интерфейс


INomenclature.Items - свойство

список блюд

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuItem[] Items { get; set; }

Значение свойства

Тип: IMenuItem
См. также

Ссылки

INomenclature - интерфейс


INomenclature - методы

Тип INomenclature предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GroupsAddItem | Добавление элемента
Открытый метод | GroupsClearArray | Очистка массива
Открытый метод | GroupsGetFirstElement | Получение первого элемента
Открытый метод | GroupsGetNextElement | Получение следующего элемента
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

INomenclature - интерфейс


INomenclature.GroupsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void GroupsAddItem(
    IMenuGroup item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIMenuGroup
Группа
См. также

Ссылки

INomenclature - интерфейс


INomenclature.GroupsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void GroupsClearArray()
См. также

Ссылки

INomenclature - интерфейс


INomenclature.GroupsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuGroup GroupsGetFirstElement()

Возвращаемое значение

Тип: IMenuGroup
Группа
См. также

Ссылки

INomenclature - интерфейс


INomenclature.GroupsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuGroup GroupsGetNextElement()

Возвращаемое значение

Тип: IMenuGroup
Группа
См. также

Ссылки

INomenclature - интерфейс


INomenclature.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    IMenuItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIMenuItem
Блюдо
См. также

Ссылки

INomenclature - интерфейс


INomenclature.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

INomenclature - интерфейс


INomenclature.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuItem ItemsGetFirstElement()

Возвращаемое значение

Тип: IMenuItem
Блюдо
См. также

Ссылки

INomenclature - интерфейс


INomenclature.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IMenuItem ItemsGetNextElement()

Возвращаемое значение

Тип: IMenuItem
Блюдо
См. также

Ссылки

INomenclature - интерфейс


IOrder - интерфейс

Интерфейс заказа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrder

Тип IOrder предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CheckNum | Номер чека
Открытое свойство | OrderClosed | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | OrderClosed_DateTimeAsString | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | OrderDiscounts | вложенные позиции скидок
Открытое свойство | OrderId | Guid заказа
Открытое свойство | OrderNumber | Номер заказа
Открытое свойство | OrderNumber_Int32AsString | Номер заказа. Представление в виде строки
Открытое свойство | OrderPayments | вложенные позиции оплат
Открытое свойство | OrderSales | вложенные позиции продаж
Открытое свойство | OrderWriteoffs | вложенные позиции удалений
Открытое свойство | TypeOfActivity | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivity_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddOrderDiscounts | Добавление элемента к массиву
Открытый метод | AddOrderPayments | Добавление элемента к массиву
Открытый метод | AddOrderSales | Добавление элемента к массиву
Открытый метод | AddOrderWriteoffs | Очистка массива
Открытый метод | ClearOrderDiscounts | Очистка массива
Открытый метод | ClearOrderPayments | Очистка массива
Открытый метод | ClearOrderSales | Очистка массива
Открытый метод | ClearOrderWriteoffs | Очистка массива
Открытый метод | GetFirstOrderDiscountItem | Получение первого элемента массива
Открытый метод | GetFirstOrderPaymentItem | Получение первого элемента массива
Открытый метод | GetFirstOrderSaleItem | Получение первого элемента массива
Открытый метод | GetFirstOrderWriteoffItem | Получение первого элемента массива
Открытый метод | GetNextOrderDiscountItem | Получение следующего элемента массива
Открытый метод | GetNextOrderPaymentItem | Получение следующего элемента массива
Открытый метод | GetNextOrderSaleItem | Получение следующего элемента массива
Открытый метод | GetNextOrderWriteoffItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrder - свойства

Тип IOrder предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CheckNum | Номер чека
Открытое свойство | OrderClosed | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | OrderClosed_DateTimeAsString | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | OrderDiscounts | вложенные позиции скидок
Открытое свойство | OrderId | Guid заказа
Открытое свойство | OrderNumber | Номер заказа
Открытое свойство | OrderNumber_Int32AsString | Номер заказа. Представление в виде строки
Открытое свойство | OrderPayments | вложенные позиции оплат
Открытое свойство | OrderSales | вложенные позиции продаж
Открытое свойство | OrderWriteoffs | вложенные позиции удалений
Открытое свойство | TypeOfActivity | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivity_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
В начало страницы
См. также

Ссылки

IOrder - интерфейс


IOrder.CheckNum - свойство

Номер чека

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CheckNum { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderClosed - свойство

Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime OrderClosed { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderClosed_DateTimeAsString - свойство

Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderClosed_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderDiscounts - свойство

вложенные позиции скидок

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDiscountItem[] OrderDiscounts { get; set; }

Значение свойства

Тип: IOrderDiscountItem
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderId - свойство

Guid заказа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderNumber - свойство

Номер заказа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int OrderNumber { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderNumber_Int32AsString - свойство

Номер заказа. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderNumber_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderPayments - свойство

вложенные позиции оплат

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderPaymentItem[] OrderPayments { get; set; }

Значение свойства

Тип: IOrderPaymentItem
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderSales - свойство

вложенные позиции продаж

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderSaleItem[] OrderSales { get; set; }

Значение свойства

Тип: IOrderSaleItem
См. также

Ссылки

IOrder - интерфейс


IOrder.OrderWriteoffs - свойство

вложенные позиции удалений

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderWriteoffItem[] OrderWriteoffs { get; set; }

Значение свойства

Тип: IOrderWriteoffItem
См. также

Ссылки

IOrder - интерфейс


IOrder.TypeOfActivity - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int TypeOfActivity { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrder - интерфейс


IOrder.TypeOfActivity_Int32AsString - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeOfActivity_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrder - интерфейс


IOrder - методы

Тип IOrder предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddOrderDiscounts | Добавление элемента к массиву
Открытый метод | AddOrderPayments | Добавление элемента к массиву
Открытый метод | AddOrderSales | Добавление элемента к массиву
Открытый метод | AddOrderWriteoffs | Очистка массива
Открытый метод | ClearOrderDiscounts | Очистка массива
Открытый метод | ClearOrderPayments | Очистка массива
Открытый метод | ClearOrderSales | Очистка массива
Открытый метод | ClearOrderWriteoffs | Очистка массива
Открытый метод | GetFirstOrderDiscountItem | Получение первого элемента массива
Открытый метод | GetFirstOrderPaymentItem | Получение первого элемента массива
Открытый метод | GetFirstOrderSaleItem | Получение первого элемента массива
Открытый метод | GetFirstOrderWriteoffItem | Получение первого элемента массива
Открытый метод | GetNextOrderDiscountItem | Получение следующего элемента массива
Открытый метод | GetNextOrderPaymentItem | Получение следующего элемента массива
Открытый метод | GetNextOrderSaleItem | Получение следующего элемента массива
Открытый метод | GetNextOrderWriteoffItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IOrder - интерфейс


IOrder.AddOrderDiscounts - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrderDiscounts(
    IOrderDiscountItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrderDiscountItem
Позиция скидки
См. также

Ссылки

IOrder - интерфейс


IOrder.AddOrderPayments - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrderPayments(
    IOrderPaymentItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrderPaymentItem
Позиция оплат
См. также

Ссылки

IOrder - интерфейс


IOrder.AddOrderSales - метод

Добавление элемента к массиву

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrderSales(
    IOrderSaleItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrderSaleItem
Позиция продаж
См. также

Ссылки

IOrder - интерфейс


IOrder.AddOrderWriteoffs - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrderWriteoffs(
    IOrderWriteoffItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrderWriteoffItem
Позиция удаления со списанием
См. также

Ссылки

IOrder - интерфейс


IOrder.ClearOrderDiscounts - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrderDiscounts()
См. также

Ссылки

IOrder - интерфейс


IOrder.ClearOrderPayments - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrderPayments()
См. также

Ссылки

IOrder - интерфейс


IOrder.ClearOrderSales - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrderSales()
См. также

Ссылки

IOrder - интерфейс


IOrder.ClearOrderWriteoffs - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrderWriteoffs()
См. также

Ссылки

IOrder - интерфейс


IOrder.GetFirstOrderDiscountItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDiscountItem GetFirstOrderDiscountItem()

Возвращаемое значение

Тип: IOrderDiscountItem
Позиция скидки
См. также

Ссылки

IOrder - интерфейс


IOrder.GetFirstOrderPaymentItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderPaymentItem GetFirstOrderPaymentItem()

Возвращаемое значение

Тип: IOrderPaymentItem
Позиция оплат
См. также

Ссылки

IOrder - интерфейс


IOrder.GetFirstOrderSaleItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderSaleItem GetFirstOrderSaleItem()

Возвращаемое значение

Тип: IOrderSaleItem
Позиция продаж
См. также

Ссылки

IOrder - интерфейс


IOrder.GetFirstOrderWriteoffItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderWriteoffItem GetFirstOrderWriteoffItem()

Возвращаемое значение

Тип: IOrderWriteoffItem
Позиция удаления со списанием
См. также

Ссылки

IOrder - интерфейс


IOrder.GetNextOrderDiscountItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDiscountItem GetNextOrderDiscountItem()

Возвращаемое значение

Тип: IOrderDiscountItem
Позиция скидки
См. также

Ссылки

IOrder - интерфейс


IOrder.GetNextOrderPaymentItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderPaymentItem GetNextOrderPaymentItem()

Возвращаемое значение

Тип: IOrderPaymentItem
Позиция оплат
См. также

Ссылки

IOrder - интерфейс


IOrder.GetNextOrderSaleItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderSaleItem GetNextOrderSaleItem()

Возвращаемое значение

Тип: IOrderSaleItem
Позиция продаж
См. также

Ссылки

IOrder - интерфейс


IOrder.GetNextOrderWriteoffItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderWriteoffItem GetNextOrderWriteoffItem()

Возвращаемое значение

Тип: IOrderWriteoffItem
Позиция удаления со списанием
См. также

Ссылки

IOrder - интерфейс


IOrderDiscountItem - интерфейс

Интерфейс позиции скидки в заказе

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrderDiscountItem

Тип IOrderDiscountItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | DiscountId | Тип скидки (код)
Открытое свойство | DiscountName | Тип скидки (название)
Открытое свойство | DiscountSum | Сумма скидки (IEEE-число 2ой точности)
Открытое свойство | DiscountSum_DecimalAsString | Сумма скидки (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrderDiscountItem - свойства

Тип IOrderDiscountItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | DiscountId | Тип скидки (код)
Открытое свойство | DiscountName | Тип скидки (название)
Открытое свойство | DiscountSum | Сумма скидки (IEEE-число 2ой точности)
Открытое свойство | DiscountSum_DecimalAsString | Сумма скидки (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

IOrderDiscountItem - интерфейс


IOrderDiscountItem.DiscountId - свойство

Тип скидки (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDiscountItem - интерфейс


IOrderDiscountItem.DiscountName - свойство

Тип скидки (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDiscountItem - интерфейс


IOrderDiscountItem.DiscountSum - свойство

Сумма скидки (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double DiscountSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDiscountItem - интерфейс


IOrderDiscountItem.DiscountSum_DecimalAsString - свойство

Сумма скидки (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDiscountItem - интерфейс


IOrderDocumentItem - интерфейс

Интерфейс вложенного элементы заказа (линейное представление)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrderDocumentItem

Тип IOrderDocumentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CardTypeName | Банковская карта (тип)
Открытое свойство | CheckNumber | Номер чека
Открытое свойство | CounteragentCode | Контрагент (код)
Открытое свойство | CounteragentName | Контрагент (наименование)
Открытое свойство | DiscountId | Тип скидки (код)
Открытое свойство | DiscountName | Тип скидки (название)
Открытое свойство | DiscountSum | Сумма скидки (IEEE-число 2ой точности)
Открытое свойство | DiscountSum_DecimalAsString | Сумма скидки (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | IsPaymentFiscal | Является ли оплата фискальной
Открытое свойство | IsPaymentFiscal_BooleanAsString | Является ли оплата фискальной. Представление в виде строки
Открытое свойство | ItemTypeCode | Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание)
Открытое свойство | ItemTypeCode_Int32AsString | Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание). Представление в виде строки
Открытое свойство | ItemTypeName | Тип строки (название)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureAmount | Количество номенклатуры (IEEE-число 3ой точности)
Открытое свойство | NomenclatureAmount_DecimalAsString | Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки
Открытое свойство | NomenclatureDiscountSum | Сумма скидки по позиции (IEEE-число 2ой точности)
Открытое свойство | NomenclatureDiscountSum_DecimalAsString | Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (Код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclaturePrice | Цена номенклатуры (IEEE-число 2ой точности)
Открытое свойство | NomenclaturePrice_DecimalAsString | Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | OrderClosed | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | OrderClosed_DateTimeAsString | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | OrderId | Guid заказа
Открытое свойство | OrderNumber | Номер заказа
Открытое свойство | OrderNumber_Int32AsString | Номер заказа. Представление в виде строки
Открытое свойство | OrderServiceType | Режим обслуживания (0 - обычный, 1 - доставка, 2 - самовывоз).
Открытое свойство | OrderServiceType_Int32AsString | Режим обслуживания (0, 1, 2) - представление в виде строки.
Открытое свойство | PaymentSum | Сумма оплаты (IEEE-число 2ой точности)
Открытое свойство | PaymentSum_DecimalAsString | Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | PaymentTypeId | Тип оплаты (код)
Открытое свойство | PaymentTypeName | Тип оплаты (название)
Открытое свойство | RemovalTypeId | Причина удаления (код)
Открытое свойство | RemovalTypeName | Причина удаления (название)
Открытое свойство | SoldWithDishCode | Целевое блюдо (с каким блюдом продан модификатор), код
Открытое свойство | SoldWithDishName | Целевое блюдо (с каким блюдом продан модификатор), наименование
Открытое свойство | SoldWithDishOuterEanCode | Целевое блюдо, код ТН ВЭД ЕАЭС
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TypeOfActivity | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivity_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrderDocumentItem - свойства

Тип IOrderDocumentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CardTypeName | Банковская карта (тип)
Открытое свойство | CheckNumber | Номер чека
Открытое свойство | CounteragentCode | Контрагент (код)
Открытое свойство | CounteragentName | Контрагент (наименование)
Открытое свойство | DiscountId | Тип скидки (код)
Открытое свойство | DiscountName | Тип скидки (название)
Открытое свойство | DiscountSum | Сумма скидки (IEEE-число 2ой точности)
Открытое свойство | DiscountSum_DecimalAsString | Сумма скидки (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | IsPaymentFiscal | Является ли оплата фискальной
Открытое свойство | IsPaymentFiscal_BooleanAsString | Является ли оплата фискальной. Представление в виде строки
Открытое свойство | ItemTypeCode | Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание)
Открытое свойство | ItemTypeCode_Int32AsString | Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание). Представление в виде строки
Открытое свойство | ItemTypeName | Тип строки (название)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureAmount | Количество номенклатуры (IEEE-число 3ой точности)
Открытое свойство | NomenclatureAmount_DecimalAsString | Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки
Открытое свойство | NomenclatureDiscountSum | Сумма скидки по позиции (IEEE-число 2ой точности)
Открытое свойство | NomenclatureDiscountSum_DecimalAsString | Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (Код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclaturePrice | Цена номенклатуры (IEEE-число 2ой точности)
Открытое свойство | NomenclaturePrice_DecimalAsString | Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | OrderClosed | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | OrderClosed_DateTimeAsString | Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | OrderId | Guid заказа
Открытое свойство | OrderNumber | Номер заказа
Открытое свойство | OrderNumber_Int32AsString | Номер заказа. Представление в виде строки
Открытое свойство | OrderServiceType | Режим обслуживания (0 - обычный, 1 - доставка, 2 - самовывоз).
Открытое свойство | OrderServiceType_Int32AsString | Режим обслуживания (0, 1, 2) - представление в виде строки.
Открытое свойство | PaymentSum | Сумма оплаты (IEEE-число 2ой точности)
Открытое свойство | PaymentSum_DecimalAsString | Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | PaymentTypeId | Тип оплаты (код)
Открытое свойство | PaymentTypeName | Тип оплаты (название)
Открытое свойство | RemovalTypeId | Причина удаления (код)
Открытое свойство | RemovalTypeName | Причина удаления (название)
Открытое свойство | SoldWithDishCode | Целевое блюдо (с каким блюдом продан модификатор), код
Открытое свойство | SoldWithDishName | Целевое блюдо (с каким блюдом продан модификатор), наименование
Открытое свойство | SoldWithDishOuterEanCode | Целевое блюдо, код ТН ВЭД ЕАЭС
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TypeOfActivity | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivity_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
В начало страницы
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.CardTypeName - свойство

Банковская карта (тип)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.CheckNumber - свойство

Номер чека

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CheckNumber { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.CounteragentCode - свойство

Контрагент (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.CounteragentName - свойство

Контрагент (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.DiscountId - свойство

Тип скидки (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.DiscountName - свойство

Тип скидки (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.DiscountSum - свойство

Сумма скидки (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double DiscountSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.DiscountSum_DecimalAsString - свойство

Сумма скидки (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DiscountSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.IsPaymentFiscal - свойство

Является ли оплата фискальной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IsPaymentFiscal { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.IsPaymentFiscal_BooleanAsString - свойство

Является ли оплата фискальной. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IsPaymentFiscal_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.ItemTypeCode - свойство

Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int ItemTypeCode { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.ItemTypeCode_Int32AsString - свойство

Тип строки (код: 1 - продажа, 2 - оплата, 3 - скидка, 4 - списание). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ItemTypeCode_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.ItemTypeName - свойство

Тип строки (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ItemTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.Nds - свойство

Сумма НДС по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.Nds_DecimalAsString - свойство

Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NdsPercent - свойство

Ставка НДС по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NdsPercent_DecimalAsString - свойство

Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureAmount - свойство

Количество номенклатуры (IEEE-число 3ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclatureAmount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureAmount_DecimalAsString - свойство

Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureAmount_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureDiscountSum - свойство

Сумма скидки по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclatureDiscountSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureDiscountSum_DecimalAsString - свойство

Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureDiscountSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureOuterEanCode - свойство

Номенклатура (Код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclaturePrice - свойство

Цена номенклатуры (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclaturePrice { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclaturePrice_DecimalAsString - свойство

Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclaturePrice_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderClosed - свойство

Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime OrderClosed { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderClosed_DateTimeAsString - свойство

Дата и время регистрации (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderClosed_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderId - свойство

Guid заказа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderNumber - свойство

Номер заказа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int OrderNumber { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderNumber_Int32AsString - свойство

Номер заказа. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderNumber_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderServiceType - свойство

Режим обслуживания (0 - обычный, 1 - доставка, 2 - самовывоз).

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int OrderServiceType { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.OrderServiceType_Int32AsString - свойство

Режим обслуживания (0, 1, 2) - представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OrderServiceType_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.PaymentSum - свойство

Сумма оплаты (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PaymentSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.PaymentSum_DecimalAsString - свойство

Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.PaymentTypeId - свойство

Тип оплаты (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.PaymentTypeName - свойство

Тип оплаты (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.RemovalTypeId - свойство

Причина удаления (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RemovalTypeId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.RemovalTypeName - свойство

Причина удаления (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RemovalTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.SoldWithDishCode - свойство

Целевое блюдо (с каким блюдом продан модификатор), код

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.SoldWithDishName - свойство

Целевое блюдо (с каким блюдом продан модификатор), наименование

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.SoldWithDishOuterEanCode - свойство

Целевое блюдо, код ТН ВЭД ЕАЭС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.TypeOfActivity - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int TypeOfActivity { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderDocumentItem.TypeOfActivity_Int32AsString - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeOfActivity_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderDocumentItem - интерфейс


IOrderPaymentItem - интерфейс

Интерфейс позиции оплаты в заказе

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrderPaymentItem

Тип IOrderPaymentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CardTypeName | Банковская карта (тип)
Открытое свойство | CounteragentCode | Контрагент (код)
Открытое свойство | CounteragentName | Контрагент (наиемнование)
Открытое свойство | IsPaymentFiscal | Является ли оплата фискальной
Открытое свойство | IsPaymentFiscal_BooleanAsString | Является ли оплата фискальной. Представление в виде строки
Открытое свойство | PaymentSum | Сумма оплаты (IEEE-число 2ой точности)
Открытое свойство | PaymentSum_DecimalAsString | Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | PaymentTypeId | Тип оплаты (код)
Открытое свойство | PaymentTypeName | Тип оплаты (название)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrderPaymentItem - свойства

Тип IOrderPaymentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CardTypeName | Банковская карта (тип)
Открытое свойство | CounteragentCode | Контрагент (код)
Открытое свойство | CounteragentName | Контрагент (наиемнование)
Открытое свойство | IsPaymentFiscal | Является ли оплата фискальной
Открытое свойство | IsPaymentFiscal_BooleanAsString | Является ли оплата фискальной. Представление в виде строки
Открытое свойство | PaymentSum | Сумма оплаты (IEEE-число 2ой точности)
Открытое свойство | PaymentSum_DecimalAsString | Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | PaymentTypeId | Тип оплаты (код)
Открытое свойство | PaymentTypeName | Тип оплаты (название)
В начало страницы
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.CardTypeName - свойство

Банковская карта (тип)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.CounteragentCode - свойство

Контрагент (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.CounteragentName - свойство

Контрагент (наиемнование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CounteragentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.IsPaymentFiscal - свойство

Является ли оплата фискальной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IsPaymentFiscal { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.IsPaymentFiscal_BooleanAsString - свойство

Является ли оплата фискальной. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IsPaymentFiscal_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.PaymentSum - свойство

Сумма оплаты (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PaymentSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.PaymentSum_DecimalAsString - свойство

Сумма оплаты (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.PaymentTypeId - свойство

Тип оплаты (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderPaymentItem.PaymentTypeName - свойство

Тип оплаты (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderPaymentItem - интерфейс


IOrderSaleItem - интерфейс

Интерфейс позиция продажи в заказе

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrderSaleItem

Тип IOrderSaleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureAmount | Количество номенклатуры (IEEE-число 3ой точности)
Открытое свойство | NomenclatureAmount_DecimalAsString | Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки
Открытое свойство | NomenclatureDiscountSum | Сумма скидки по позиции (IEEE-число 2ой точности)
Открытое свойство | NomenclatureDiscountSum_DecimalAsString | Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (Код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclaturePrice | Цена номенклатуры (IEEE-число 2ой точности)
Открытое свойство | NomenclaturePrice_DecimalAsString | Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | SoldWithDishCode | Целевое блюдо (с каким блюдом продан модификатор), код
Открытое свойство | SoldWithDishName | Целевое блюдо (с каким блюдом продан модификатор), наименование
Открытое свойство | SoldWithDishOuterEanCode | Целевое блюдо, код ТН ВЭД ЕАЭС
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrderSaleItem - свойства

Тип IOrderSaleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС по позиции (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureAmount | Количество номенклатуры (IEEE-число 3ой точности)
Открытое свойство | NomenclatureAmount_DecimalAsString | Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки
Открытое свойство | NomenclatureDiscountSum | Сумма скидки по позиции (IEEE-число 2ой точности)
Открытое свойство | NomenclatureDiscountSum_DecimalAsString | Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (Код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclaturePrice | Цена номенклатуры (IEEE-число 2ой точности)
Открытое свойство | NomenclaturePrice_DecimalAsString | Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | SoldWithDishCode | Целевое блюдо (с каким блюдом продан модификатор), код
Открытое свойство | SoldWithDishName | Целевое блюдо (с каким блюдом продан модификатор), наименование
Открытое свойство | SoldWithDishOuterEanCode | Целевое блюдо, код ТН ВЭД ЕАЭС
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.Nds - свойство

Сумма НДС по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.Nds_DecimalAsString - свойство

Сумма НДС по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NdsPercent - свойство

Ставка НДС по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NdsPercent_DecimalAsString - свойство

Ставка НДС по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureAmount - свойство

Количество номенклатуры (IEEE-число 3ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclatureAmount { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureAmount_DecimalAsString - свойство

Количество номенклатуры (IEEE-число 3ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureAmount_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureDiscountSum - свойство

Сумма скидки по позиции (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclatureDiscountSum { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureDiscountSum_DecimalAsString - свойство

Сумма скидки по позиции (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureDiscountSum_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureOuterEanCode - свойство

Номенклатура (Код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclaturePrice - свойство

Цена номенклатуры (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NomenclaturePrice { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclaturePrice_DecimalAsString - свойство

Цена номенклатуры (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclaturePrice_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.SoldWithDishCode - свойство

Целевое блюдо (с каким блюдом продан модификатор), код

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.SoldWithDishName - свойство

Целевое блюдо (с каким блюдом продан модификатор), наименование

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.SoldWithDishOuterEanCode - свойство

Целевое блюдо, код ТН ВЭД ЕАЭС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishOuterEanCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrderSaleItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderSaleItem - интерфейс


IOrdersDocument - интерфейс

Интерфейс документа заказов (счетов)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrdersDocument

Тип IOrdersDocument предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegisterNumber | Номер кассы в iiko
Открытое свойство | CashRegisterNumber_Int32AsString | Номер кассы в iiko. Представление в виде строки
Открытое свойство | CashRegisterSerialNumber | Серийный номер ККМ
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата учета (ГГГГ-ММ-ДД)
Открытое свойство | Date_DateTimeAsString | Дата учета (ГГГГ-ММ-ДД). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OrderDocumentItems | вложенные элементы заказов (линейное представление)
Открытое свойство | Orders | вложенные заказы
Открытое свойство | Processed | Закрыта ли кассовая смена
Открытое свойство | Processed_BooleanAsString | Закрыта ли кассовая смена. Представление в виде строки
Открытое свойство | SessionFiscalNumber | Фискальный номер смены (номер Z-отчета)
Открытое свойство | SessionNumber | Номер смены в iiko
Открытое свойство | SessionNumber_Int32AsString | Номер смены в iiko. Представление в виде строки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddOrderDocumentItems | Добавление элемента
Открытый метод | AddOrders | Добавление элемента
Открытый метод | ClearOrderDocumentItems | Очистка массива
Открытый метод | ClearOrders | Очистка массива
Открытый метод | GetFirstOrder | Получение первого элемента
Открытый метод | GetFirstOrderDocumentItem | Получение первого элемента
Открытый метод | GetNextOrder | Получение следующего элемента
Открытый метод | GetNextOrderDocumentItem | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrdersDocument - свойства

Тип IOrdersDocument предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegisterNumber | Номер кассы в iiko
Открытое свойство | CashRegisterNumber_Int32AsString | Номер кассы в iiko. Представление в виде строки
Открытое свойство | CashRegisterSerialNumber | Серийный номер ККМ
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата учета (ГГГГ-ММ-ДД)
Открытое свойство | Date_DateTimeAsString | Дата учета (ГГГГ-ММ-ДД). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | ЮЛ (ИНН)
Открытое свойство | JuristicPersonName | ЮЛ (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OrderDocumentItems | вложенные элементы заказов (линейное представление)
Открытое свойство | Orders | вложенные заказы
Открытое свойство | Processed | Закрыта ли кассовая смена
Открытое свойство | Processed_BooleanAsString | Закрыта ли кассовая смена. Представление в виде строки
Открытое свойство | SessionFiscalNumber | Фискальный номер смены (номер Z-отчета)
Открытое свойство | SessionNumber | Номер смены в iiko
Открытое свойство | SessionNumber_Int32AsString | Номер смены в iiko. Представление в виде строки
В начало страницы
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.CashRegisterNumber - свойство

Номер кассы в iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int CashRegisterNumber { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.CashRegisterNumber_Int32AsString - свойство

Номер кассы в iiko. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegisterNumber_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.CashRegisterSerialNumber - свойство

Серийный номер ККМ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegisterSerialNumber { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Date - свойство

Дата учета (ГГГГ-ММ-ДД)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Date_DateTimeAsString - свойство

Дата учета (ГГГГ-ММ-ДД). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.DepartmentCode - свойство

Торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.DepartmentName - свойство

Торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.JuristicPersonINN - свойство

ЮЛ (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.JuristicPersonName - свойство

ЮЛ (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.OrderDocumentItems - свойство

вложенные элементы заказов (линейное представление)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDocumentItem[] OrderDocumentItems { get; set; }

Значение свойства

Тип: IOrderDocumentItem
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Orders - свойство

вложенные заказы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrder[] Orders { get; set; }

Значение свойства

Тип: IOrder
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Processed - свойство

Закрыта ли кассовая смена

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.Processed_BooleanAsString - свойство

Закрыта ли кассовая смена. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.SessionFiscalNumber - свойство

Фискальный номер смены (номер Z-отчета)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SessionFiscalNumber { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.SessionNumber - свойство

Номер смены в iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int SessionNumber { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.SessionNumber_Int32AsString - свойство

Номер смены в iiko. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SessionNumber_Int32AsString { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument - методы

Тип IOrdersDocument предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddOrderDocumentItems | Добавление элемента
Открытый метод | AddOrders | Добавление элемента
Открытый метод | ClearOrderDocumentItems | Очистка массива
Открытый метод | ClearOrders | Очистка массива
Открытый метод | GetFirstOrder | Получение первого элемента
Открытый метод | GetFirstOrderDocumentItem | Получение первого элемента
Открытый метод | GetNextOrder | Получение следующего элемента
Открытый метод | GetNextOrderDocumentItem | Получение следующего элемента
В начало страницы
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.AddOrderDocumentItems - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrderDocumentItems(
    IOrderDocumentItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrderDocumentItem
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.AddOrders - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrders(
    IOrder item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrder
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.ClearOrderDocumentItems - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrderDocumentItems()
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.ClearOrders - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrders()
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.GetFirstOrder - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrder GetFirstOrder()

Возвращаемое значение

Тип: IOrder
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.GetFirstOrderDocumentItem - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDocumentItem GetFirstOrderDocumentItem()

Возвращаемое значение

Тип: IOrderDocumentItem
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.GetNextOrder - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrder GetNextOrder()

Возвращаемое значение

Тип: IOrder
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocument.GetNextOrderDocumentItem - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrderDocumentItem GetNextOrderDocumentItem()

Возвращаемое значение

Тип: IOrderDocumentItem
Заказ
См. также

Ссылки

IOrdersDocument - интерфейс


IOrdersDocuments - интерфейс

Интерфейс загрузки заказов (счетов)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrdersDocuments

Тип IOrdersDocuments предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | OrdersDocumentArray | вложенные документы заказов (счетов)
В начало страницы
Методы
 | Имя | Описание
Открытый метод | AddOrdersDocumentArray | Добавление элемента
Открытый метод | ClearOrdersDocumentArray | Очистка массива OrdersDocumentArray
Открытый метод | GetFirstOrdersDocument | Получение первого элемента
Открытый метод | GetNextOrdersDocument | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrdersDocuments - свойства

Тип IOrdersDocuments предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | OrdersDocumentArray | вложенные документы заказов (счетов)
В начало страницы
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments.OrdersDocumentArray - свойство

вложенные документы заказов (счетов)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrdersDocument[] OrdersDocumentArray { get; set; }

Значение свойства

Тип: IOrdersDocument
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments - методы

Тип IOrdersDocuments предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | AddOrdersDocumentArray | Добавление элемента
Открытый метод | ClearOrdersDocumentArray | Очистка массива OrdersDocumentArray
Открытый метод | GetFirstOrdersDocument | Получение первого элемента
Открытый метод | GetNextOrdersDocument | Получение следующего элемента
В начало страницы
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments.AddOrdersDocumentArray - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void AddOrdersDocumentArray(
    IOrdersDocument item
)

Параметры

item
Тип: iiko1CInterface.InterfacesIOrdersDocument
Зазаз
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments.ClearOrdersDocumentArray - метод

Очистка массива OrdersDocumentArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ClearOrdersDocumentArray()
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments.GetFirstOrdersDocument - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrdersDocument GetFirstOrdersDocument()

Возвращаемое значение

Тип: IOrdersDocument
Зазаз
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrdersDocuments.GetNextOrdersDocument - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOrdersDocument GetNextOrdersDocument()

Возвращаемое значение

Тип: IOrdersDocument
Зазаз
См. также

Ссылки

IOrdersDocuments - интерфейс


IOrderWriteoffItem - интерфейс

Интерфейс позиции удаления со списанием в заказе

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOrderWriteoffItem

Тип IOrderWriteoffItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | RemovalTypeId | Причина удаления (код)
Открытое свойство | RemovalTypeName | Причина удаления (название)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOrderWriteoffItem - свойства

Тип IOrderWriteoffItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | RemovalTypeId | Причина удаления (код)
Открытое свойство | RemovalTypeName | Причина удаления (название)
В начало страницы
См. также

Ссылки

IOrderWriteoffItem - интерфейс


IOrderWriteoffItem.RemovalTypeId - свойство

Причина удаления (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RemovalTypeId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderWriteoffItem - интерфейс


IOrderWriteoffItem.RemovalTypeName - свойство

Причина удаления (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RemovalTypeName { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

IOrderWriteoffItem - интерфейс


IOutgoingInvoice - интерфейс

Интерфейс описания вложенных расходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOutgoingInvoice

Тип IOutgoingInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CustomerCode | Код покупателя (строковое значение)
Открытое свойство | CustomerINN | ИНН покупателя (строковое значение)
Открытое свойство | CustomerName | Наименование покупателя (строковое значение)
Открытое свойство | CustomerStoreCode | Склад покупатель (код)
Открытое свойство | CustomerStoreName | Склад покупатель (наименование)
Открытое свойство | Date | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | Номер документа
Открытое свойство | OutgoingInvoiceItems | Вложенные товарные позиции по расхожной накладной
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | UserCode | Сотрудник (код)
Открытое свойство | UserName | Сотрудник (наименование)
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstOutgoingInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextOutgoingInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOutgoingInvoice - свойства

Тип IOutgoingInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CustomerCode | Код покупателя (строковое значение)
Открытое свойство | CustomerINN | ИНН покупателя (строковое значение)
Открытое свойство | CustomerName | Наименование покупателя (строковое значение)
Открытое свойство | CustomerStoreCode | Склад покупатель (код)
Открытое свойство | CustomerStoreName | Склад покупатель (наименование)
Открытое свойство | Date | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | Номер документа
Открытое свойство | OutgoingInvoiceItems | Вложенные товарные позиции по расхожной накладной
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | UserCode | Сотрудник (код)
Открытое свойство | UserName | Сотрудник (наименование)
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
В начало страницы
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.CustomerCode - свойство

Код покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.CustomerINN - свойство

ИНН покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.CustomerName - свойство

Наименование покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.CustomerStoreCode - свойство

Склад покупатель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerStoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.CustomerStoreName - свойство

Склад покупатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerStoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Date - свойство

Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Date_DateTimeAsString - свойство

Дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.DepartmentCode - свойство

Торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.DepartmentName - свойство

Торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Number - свойство

Номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.OutgoingInvoiceItems - свойство

Вложенные товарные позиции по расхожной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoiceItem[] OutgoingInvoiceItems { get; }

Значение свойства

Тип: IOutgoingInvoiceItem
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.RevenueAccountCode - свойство

Движение денежных средств (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.RevenueAccountName - свойство

Движение денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.UserCode - свойство

Сотрудник (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string UserCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.UserName - свойство

Сотрудник (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string UserName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.WriteoffAccountCode - свойство

Статья расходов(код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.WriteoffAccountName - свойство

Статья расходов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice - методы

Тип IOutgoingInvoice предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstOutgoingInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextOutgoingInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.GetFirstOutgoingInvoiceItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoiceItem GetFirstOutgoingInvoiceItem()

Возвращаемое значение

Тип: IOutgoingInvoiceItem
Расходная накладная
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoice.GetNextOutgoingInvoiceItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoiceItem GetNextOutgoingInvoiceItem()

Возвращаемое значение

Тип: IOutgoingInvoiceItem
Расходная накладная
См. также

Ссылки

IOutgoingInvoice - интерфейс


IOutgoingInvoiceItem - интерфейс

Интерфейс товарных единиц по расходной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOutgoingInvoiceItem

Тип IOutgoingInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsProductPercent | Ставка НДС из справочника
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=cписание, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=cписание, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: cписание/списание ингредиентов
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | "Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOutgoingInvoiceItem - свойства

Тип IOutgoingInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsProductPercent | Ставка НДС из справочника
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=cписание, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=cписание, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: cписание/списание ингредиентов
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | "Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.CostPrice - свойство

Себестоимость без НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Nds - свойство

Сумма НДС с продаж

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Nds_DecimalAsString - свойство

Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NdsPercent - свойство

Ставка НДС с продаж

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NdsPercent_DecimalAsString - свойство

Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NdsProductPercent - свойство

Ставка НДС из справочника

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Operation - свойство

тип строки: 1=cписание, 2=списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.Operation_Int32AsString - свойство

тип строки: 1=cписание, 2=списание ингредиентов. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.OperationName - свойство

тип строки: cписание/списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.PriceWithNds - свойство

Цена продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.PriceWithNds_DecimalAsString - свойство

Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.StoreName - свойство

"Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.TargetDishAccountingCategoryCode - свойство

Группа учета целевого блюда (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.TargetDishAccountingCategoryName - свойство

Группа учета целевого блюда (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.TargetDishCode - свойство

Целевое блюдо (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.TargetDishName - свойство

Целевое блюдо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.TargetDishOuterEanCode - свойство

Целевое блюдо (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.WriteoffType - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int WriteoffType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.WriteoffType_Int32AsString - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoiceItem.WriteoffTypeName - свойство

тип списания (название): Списывать со склада/Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingInvoiceItem - интерфейс


IOutgoingInvoices - интерфейс

Интерфейс описания вложенных расходных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOutgoingInvoices

Тип IOutgoingInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | OutgoingInvoiceArray | Вложенные расходные накладные
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstOutgoingInvoice | Получение первого элемента массива
Открытый метод | GetNextOutgoingInvoice | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOutgoingInvoices - свойства

Тип IOutgoingInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | OutgoingInvoiceArray | Вложенные расходные накладные
В начало страницы
См. также

Ссылки

IOutgoingInvoices - интерфейс


IOutgoingInvoices.OutgoingInvoiceArray - свойство

Вложенные расходные накладные

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoice[] OutgoingInvoiceArray { get; }

Значение свойства

Тип: IOutgoingInvoice
См. также

Ссылки

IOutgoingInvoices - интерфейс


IOutgoingInvoices - методы

Тип IOutgoingInvoices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstOutgoingInvoice | Получение первого элемента массива
Открытый метод | GetNextOutgoingInvoice | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IOutgoingInvoices - интерфейс


IOutgoingInvoices.GetFirstOutgoingInvoice - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoice GetFirstOutgoingInvoice()

Возвращаемое значение

Тип: IOutgoingInvoice
Расходная накладная
См. также

Ссылки

IOutgoingInvoices - интерфейс


IOutgoingInvoices.GetNextOutgoingInvoice - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingInvoice GetNextOutgoingInvoice()

Возвращаемое значение

Тип: IOutgoingInvoice
Расходная накладная
См. также

Ссылки

IOutgoingInvoices - интерфейс


IOutgoingServiceData - интерфейс

Интерфейс актов оказания услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOutgoingServiceData

Тип IOutgoingServiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountCode | Код счета
Открытое свойство | AccountName | Название счета
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RegisterNumber | Номер кассы
Открытое свойство | SessionNumber | Номер смены
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOutgoingServiceData - свойства

Тип IOutgoingServiceData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountCode | Код счета
Открытое свойство | AccountName | Название счета
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Correspond_BooleanAsString | Соответствует заказу. Представление в виде строки.
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | DueDate_DateTimeAsString | Срок оплаты. Представление в виде строки.
Открытое свойство | IncomingDate_DateTimeAsString | входящая дата. Представление в виде строки
Открытое свойство | IncomingNumber | входящий номер
Открытое свойство | Invoice | Счет-фактура (строковое значение)
Открытое свойство | InvoiceItems | Вложенные товарные позиции по накладной
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер накладной
Открытое свойство | PaymentDate_DateTimeAsString | Дата оплаты. Представление в виде строки.
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RegisterNumber | Номер кассы
Открытое свойство | SessionNumber | Номер смены
Открытое свойство | StaffCode | Код сотрудника (строковое значение)
Открытое свойство | StaffName | Имя сотрудника (строковое значение)
Открытое свойство | SupplierCode | Код поставщика (строковое значение)
Открытое свойство | SupplierINN | ИНН поставщика (строковое значение)
Открытое свойство | SupplierName | Наименование поставщика (строковое значение)
Открытое свойство | SupplierStoreCode | Склад поставщик (код)
Открытое свойство | SupplierStoreName | Склад поставщик (наименование)
Открытое свойство | Timely_BooleanAsString | Доставка в срок. Представление в виде строки.
Открытое свойство | TransportInvoiceNumber | Номер товарно-транспортной накладной
В начало страницы
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.AccountCode - свойство

Код счета

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.AccountName - свойство

Название счета

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Correspond_BooleanAsString - свойство

Соответствует заказу. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Correspond_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.DueDate_DateTimeAsString - свойство

Срок оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DueDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.IncomingDate_DateTimeAsString - свойство

входящая дата. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.IncomingNumber - свойство

входящий номер

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Invoice - свойство

Счет-фактура (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Invoice { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.InvoiceItems - свойство

Вложенные товарные позиции по накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem[] InvoiceItems { get; }

Значение свойства

Тип: IInvoiceItem
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Number - свойство

номер накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.PaymentDate_DateTimeAsString - свойство

Дата оплаты. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.RegisterNumber - свойство

Номер кассы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int RegisterNumber { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SessionNumber - свойство

Номер смены

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int SessionNumber { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.StaffCode - свойство

Код сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.StaffName - свойство

Имя сотрудника (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StaffName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SupplierCode - свойство

Код поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SupplierINN - свойство

ИНН поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SupplierName - свойство

Наименование поставщика (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SupplierStoreCode - свойство

Склад поставщик (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.SupplierStoreName - свойство

Склад поставщик (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SupplierStoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.Timely_BooleanAsString - свойство

Доставка в срок. Представление в виде строки.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Timely_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.TransportInvoiceNumber - свойство

Номер товарно-транспортной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TransportInvoiceNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData - методы

Тип IOutgoingServiceData предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.GetFirstInvoiceItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetFirstInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServiceData.GetNextInvoiceItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IInvoiceItem GetNextInvoiceItem()

Возвращаемое значение

Тип: IInvoiceItem
Приходная накладная
См. также

Ссылки

IOutgoingServiceData - интерфейс


IOutgoingServices - интерфейс

Интерфейс загрузки актов оказания услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IOutgoingServices

Тип IOutgoingServices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | Вложенные акты оказания услуг
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IOutgoingServices - свойства

Тип IOutgoingServices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | InvoiceData | Вложенные акты оказания услуг
В начало страницы
См. также

Ссылки

IOutgoingServices - интерфейс


IOutgoingServices.InvoiceData - свойство

Вложенные акты оказания услуг

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingServiceData[] InvoiceData { get; }

Значение свойства

Тип: IOutgoingServiceData
См. также

Ссылки

IOutgoingServices - интерфейс


IOutgoingServices - методы

Тип IOutgoingServices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstInvoiceData | Получение первого элемента массива
Открытый метод | GetNextInvoiceData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IOutgoingServices - интерфейс


IOutgoingServices.GetFirstInvoiceData - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingServiceData GetFirstInvoiceData()

Возвращаемое значение

Тип: IOutgoingServiceData
Акт оказания услуг
См. также

Ссылки

IOutgoingServices - интерфейс


IOutgoingServices.GetNextInvoiceData - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IOutgoingServiceData GetNextInvoiceData()

Возвращаемое значение

Тип: IOutgoingServiceData
Акт оказания услуг
См. также

Ссылки

IOutgoingServices - интерфейс


IProduction - интерфейс

Интерфейс вложений акта приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProduction

Тип IProduction предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomeItems | Вложенные товарные позиции приходов по актам приготовления
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OutcomeItems | Вложенные товарные позиции расходов по актам приготовления
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstIncomeItems | Получение первого элемента массива "Входящие"
Открытый метод | GetFirstOutcomeItems | Получение первого элемента массива "Исходящие"
Открытый метод | GetNextIncomeItems | Получение следующего элемента массива "Входящие"
Открытый метод | GetNextOutcomeItems | Получение следующего элемента массива "Исходящие"
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProduction - свойства

Тип IProduction предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomeItems | Вложенные товарные позиции приходов по актам приготовления
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OutcomeItems | Вложенные товарные позиции расходов по актам приготовления
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
См. также

Ссылки

IProduction - интерфейс


IProduction.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IProduction - интерфейс


IProduction.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.IncomeItems - свойство

Вложенные товарные позиции приходов по актам приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem[] IncomeItems { get; }

Значение свойства

Тип: IProductionItem
См. также

Ссылки

IProduction - интерфейс


IProduction.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction.OutcomeItems - свойство

Вложенные товарные позиции расходов по актам приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem[] OutcomeItems { get; }

Значение свойства

Тип: IProductionItem
См. также

Ссылки

IProduction - интерфейс


IProduction.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IProduction - интерфейс


IProduction.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProduction - интерфейс


IProduction - методы

Тип IProduction предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstIncomeItems | Получение первого элемента массива "Входящие"
Открытый метод | GetFirstOutcomeItems | Получение первого элемента массива "Исходящие"
Открытый метод | GetNextIncomeItems | Получение следующего элемента массива "Входящие"
Открытый метод | GetNextOutcomeItems | Получение следующего элемента массива "Исходящие"
В начало страницы
См. также

Ссылки

IProduction - интерфейс


IProduction.GetFirstIncomeItems - метод

Получение первого элемента массива "Входящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetFirstIncomeItems()

Возвращаемое значение

Тип: IProductionItem
Расходная товарная единица
См. также

Ссылки

IProduction - интерфейс


IProduction.GetFirstOutcomeItems - метод

Получение первого элемента массива "Исходящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetFirstOutcomeItems()

Возвращаемое значение

Тип: IProductionItem
Расходная товарная единица
См. также

Ссылки

IProduction - интерфейс


IProduction.GetNextIncomeItems - метод

Получение следующего элемента массива "Входящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetNextIncomeItems()

Возвращаемое значение

Тип: IProductionItem
Расходная товарная единица
См. также

Ссылки

IProduction - интерфейс


IProduction.GetNextOutcomeItems - метод

Получение следующего элемента массива "Исходящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetNextOutcomeItems()

Возвращаемое значение

Тип: IProductionItem
Расходная товарная единица
См. также

Ссылки

IProduction - интерфейс


IProductionItem - интерфейс

Интерфейс расходных товарных единиц по актам приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProductionItem

Тип IProductionItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=Приход, 2=Расход
Открытое свойство | Operation_Int32AsString | тип строки: 1=Приход, 2=Расход. Представление в виде строки
Открытое свойство | OperationName | тип строки: Приход/Расход
Открытое свойство | StoreCode | Код склада списания (строковое значение)
Открытое свойство | StoreName | Название склада списания (строковое значение)
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProductionItem - свойства

Тип IProductionItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=Приход, 2=Расход
Открытое свойство | Operation_Int32AsString | тип строки: 1=Приход, 2=Расход. Представление в виде строки
Открытое свойство | OperationName | тип строки: Приход/Расход
Открытое свойство | StoreCode | Код склада списания (строковое значение)
Открытое свойство | StoreName | Название склада списания (строковое значение)
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
В начало страницы
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - мидификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Operation - свойство

тип строки: 1=Приход, 2=Расход

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.Operation_Int32AsString - свойство

тип строки: 1=Приход, 2=Расход. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.OperationName - свойство

тип строки: Приход/Расход

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.StoreCode - свойство

Код склада списания (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.StoreName - свойство

Название склада списания (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.TargetDishAccountingCategoryCode - свойство

Группа учета целевого блюда (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.TargetDishAccountingCategoryName - свойство

Группа учета целевого блюда (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.TargetDishCode - свойство

Целевое блюдо (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.TargetDishName - свойство

Целевое блюдо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductionItem.TargetDishOuterEanCode - свойство

Целевое блюдо (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProductionItem - интерфейс


IProductions - интерфейс

Интерфейс загрузки актов приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProductions

Тип IProductions предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProductionArray | вложенные акты приготовления
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstProduction | Получение первого элемента массива
Открытый метод | GetNextProduction | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProductions - свойства

Тип IProductions предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProductionArray | вложенные акты приготовления
В начало страницы
См. также

Ссылки

IProductions - интерфейс


IProductions.ProductionArray - свойство

вложенные акты приготовления

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProduction[] ProductionArray { get; }

Значение свойства

Тип: IProduction
См. также

Ссылки

IProductions - интерфейс


IProductions - методы

Тип IProductions предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstProduction | Получение первого элемента массива
Открытый метод | GetNextProduction | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IProductions - интерфейс


IProductions.GetFirstProduction - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProduction GetFirstProduction()

Возвращаемое значение

Тип: IProduction
Акт приготовления
См. также

Ссылки

IProductions - интерфейс


IProductions.GetNextProduction - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProduction GetNextProduction()

Возвращаемое значение

Тип: IProduction
Акт приготовления
См. также

Ссылки

IProductions - интерфейс


IProfitTaking - интерфейс

Интерфейс описания вложенных актов реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProfitTaking

Тип IProfitTaking предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegisterNumber | Номер кассы Iiko
Открытое свойство | CashRegisterNumber_Int32AsString | Номер кассы Iiko. Представление в виде строки
Открытое свойство | CashRegisterSerial | Серийный номер фискального регистратора
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | Номер документа
Открытое свойство | Processed | Проведен ли документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | ProfitTakingItems | Вложенный элемент приема кассовой выручки
Открытое свойство | SessionNumber | Номер смены Iiko
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstProfitTakingItem | Получение первого элемента массива ProfitTakingItems
Открытый метод | GetNextProfitTakingItem | Получение следующего элемента массива ProfitTakingItems
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProfitTaking - свойства

Тип IProfitTaking предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegisterNumber | Номер кассы Iiko
Открытое свойство | CashRegisterNumber_Int32AsString | Номер кассы Iiko. Представление в виде строки
Открытое свойство | CashRegisterSerial | Серийный номер фискального регистратора
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | Торговое предприятие (код)
Открытое свойство | DepartmentName | Торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | Номер документа
Открытое свойство | Processed | Проведен ли документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | ProfitTakingItems | Вложенный элемент приема кассовой выручки
Открытое свойство | SessionNumber | Номер смены Iiko
В начало страницы
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.CashRegisterNumber - свойство

Номер кассы Iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int CashRegisterNumber { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.CashRegisterNumber_Int32AsString - свойство

Номер кассы Iiko. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegisterNumber_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.CashRegisterSerial - свойство

Серийный номер фискального регистратора

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegisterSerial { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.CashRegNumber - свойство

Номер кассы iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Date - свойство

Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Date_DateTimeAsString - свойство

Дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.DepartmentCode - свойство

Торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.DepartmentName - свойство

Торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Number - свойство

Номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Processed - свойство

Проведен ли документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.ProfitTakingItems - свойство

Вложенный элемент приема кассовой выручки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTakingItem[] ProfitTakingItems { get; }

Значение свойства

Тип: IProfitTakingItem
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.SessionNumber - свойство

Номер смены Iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SessionNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking - методы

Тип IProfitTaking предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstProfitTakingItem | Получение первого элемента массива ProfitTakingItems
Открытый метод | GetNextProfitTakingItem | Получение следующего элемента массива ProfitTakingItems
В начало страницы
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.GetFirstProfitTakingItem - метод

Получение первого элемента массива ProfitTakingItems

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTakingItem GetFirstProfitTakingItem()

Возвращаемое значение

Тип: IProfitTakingItem
Товарная единица
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTaking.GetNextProfitTakingItem - метод

Получение следующего элемента массива ProfitTakingItems

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTakingItem GetNextProfitTakingItem()

Возвращаемое значение

Тип: IProfitTakingItem
Товарная единица
См. также

Ссылки

IProfitTaking - интерфейс


IProfitTakingItem - интерфейс

Интерфейс товарных единиц по накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProfitTakingItem

Тип IProfitTakingItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AdvanceProductCode | Авансовый платеж (код)
Открытое свойство | AdvanceProductName | Авансовый платеж (название)
Открытое свойство | Card | Номер карты
Открытое свойство | CardHolderBirthday_DateTimeAsString | Покупатель (дата рождения). Представление в виде строки
Открытое свойство | CardHolderCode | Покупатель (код)
Открытое свойство | CardHolderCompanyINN | Покупатель (ИНН)
Открытое свойство | CardHolderCompanyName | Покупатель (наименование)
Открытое свойство | CardHolderFirstName | Покупатель (имя)
Открытое свойство | CardHolderLastName | Покупатель (фамилия)
Открытое свойство | CardHolderMiddleName | Покупатель (отчество)
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | PaymentTypeId | Вид оплаты (код)
Открытое свойство | PaymentTypeName | Вид оплаты (наименование)
Открытое свойство | Sum | Сумма
Открытое свойство | Sum_DecimalAsString | Сумма. Представление в виде строки
Открытое свойство | TypeOfActivityCode | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivityCode_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
Открытое свойство | TypeOfActivityName | Вид деятельности (название)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProfitTakingItem - свойства

Тип IProfitTakingItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AdvanceProductCode | Авансовый платеж (код)
Открытое свойство | AdvanceProductName | Авансовый платеж (название)
Открытое свойство | Card | Номер карты
Открытое свойство | CardHolderBirthday_DateTimeAsString | Покупатель (дата рождения). Представление в виде строки
Открытое свойство | CardHolderCode | Покупатель (код)
Открытое свойство | CardHolderCompanyINN | Покупатель (ИНН)
Открытое свойство | CardHolderCompanyName | Покупатель (наименование)
Открытое свойство | CardHolderFirstName | Покупатель (имя)
Открытое свойство | CardHolderLastName | Покупатель (фамилия)
Открытое свойство | CardHolderMiddleName | Покупатель (отчество)
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | PaymentTypeId | Вид оплаты (код)
Открытое свойство | PaymentTypeName | Вид оплаты (наименование)
Открытое свойство | Sum | Сумма
Открытое свойство | Sum_DecimalAsString | Сумма. Представление в виде строки
Открытое свойство | TypeOfActivityCode | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)
Открытое свойство | TypeOfActivityCode_Int32AsString | Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки
Открытое свойство | TypeOfActivityName | Вид деятельности (название)
В начало страницы
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.AdvanceProductCode - свойство

Авансовый платеж (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AdvanceProductCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.AdvanceProductName - свойство

Авансовый платеж (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AdvanceProductName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.Card - свойство

Номер карты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Card { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderBirthday_DateTimeAsString - свойство

Покупатель (дата рождения). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderBirthday_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderCode - свойство

Покупатель (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderCompanyINN - свойство

Покупатель (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderCompanyINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderCompanyName - свойство

Покупатель (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderCompanyName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderFirstName - свойство

Покупатель (имя)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderFirstName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderLastName - свойство

Покупатель (фамилия)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderLastName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.CardHolderMiddleName - свойство

Покупатель (отчество)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CardHolderMiddleName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.PaymentTypeId - свойство

Вид оплаты (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeId { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.PaymentTypeName - свойство

Вид оплаты (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PaymentTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.Sum - свойство

Сумма

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Sum { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.Sum_DecimalAsString - свойство

Сумма. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Sum_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.TypeOfActivityCode - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int TypeOfActivityCode { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.TypeOfActivityCode_Int32AsString - свойство

Вид деятельности (0 ресторан, 1 доставка, 2 takeaway). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeOfActivityCode_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakingItem.TypeOfActivityName - свойство

Вид деятельности (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TypeOfActivityName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IProfitTakingItem - интерфейс


IProfitTakings - интерфейс

Интерфейс загрузки приема кассовой выручки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IProfitTakings

Тип IProfitTakings предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProfitTakingArray | Вложенные приемы кассовой выручки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstProfitTaking | Получение первого элемента массива ProfitTakingArray
Открытый метод | GetNextProfitTaking | Получение следующего элемента массива ProfitTakingArray
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IProfitTakings - свойства

Тип IProfitTakings предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProfitTakingArray | Вложенные приемы кассовой выручки
В начало страницы
См. также

Ссылки

IProfitTakings - интерфейс


IProfitTakings.ProfitTakingArray - свойство

Вложенные приемы кассовой выручки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTaking[] ProfitTakingArray { get; }

Значение свойства

Тип: IProfitTaking
См. также

Ссылки

IProfitTakings - интерфейс


IProfitTakings - методы

Тип IProfitTakings предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstProfitTaking | Получение первого элемента массива ProfitTakingArray
Открытый метод | GetNextProfitTaking | Получение следующего элемента массива ProfitTakingArray
В начало страницы
См. также

Ссылки

IProfitTakings - интерфейс


IProfitTakings.GetFirstProfitTaking - метод

Получение первого элемента массива ProfitTakingArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTaking GetFirstProfitTaking()

Возвращаемое значение

Тип: IProfitTaking
Кассовая выручка
См. также

Ссылки

IProfitTakings - интерфейс


IProfitTakings.GetNextProfitTaking - метод

Получение следующего элемента массива ProfitTakingArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProfitTaking GetNextProfitTaking()

Возвращаемое значение

Тип: IProfitTaking
Кассовая выручка
См. также

Ссылки

IProfitTakings - интерфейс


IReturnedInvoice - интерфейс

Интерфейс вложенных возвратных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IReturnedInvoice

Тип IReturnedInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CustomerCode | Код покупателя (строковое значение)
Открытое свойство | CustomerINN | ИНН покупателя (строковое значение)
Открытое свойство | CustomerName | Наименование покупателя (строковое значение)
Открытое свойство | Date | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomingInvoiceDate_DateTimeAsString | Ссылка на Приходную накладную. Поле Номер документа.. Представление в виде строки
Открытое свойство | IncomingInvoiceNumber | Ссылка на Приходную накладную. Поле Дата документа
Открытое свойство | Invoice | Строка поля счет-фактуры
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ли документ
Открытое свойство | Processed_BooleanAsString | Проведен ли документ. Представление в виде строки
Открытое свойство | ReturnedInvoiceItems | Вложенные товарные позиции по расходной накладной"
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstReturnedInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextReturnedInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IReturnedInvoice - свойства

Тип IReturnedInvoice предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | CustomerCode | Код покупателя (строковое значение)
Открытое свойство | CustomerINN | ИНН покупателя (строковое значение)
Открытое свойство | CustomerName | Наименование покупателя (строковое значение)
Открытое свойство | Date | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomingInvoiceDate_DateTimeAsString | Ссылка на Приходную накладную. Поле Номер документа.. Представление в виде строки
Открытое свойство | IncomingInvoiceNumber | Ссылка на Приходную накладную. Поле Дата документа
Открытое свойство | Invoice | Строка поля счет-фактуры
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ли документ
Открытое свойство | Processed_BooleanAsString | Проведен ли документ. Представление в виде строки
Открытое свойство | ReturnedInvoiceItems | Вложенные товарные позиции по расходной накладной"
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
В начало страницы
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.CustomerCode - свойство

Код покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.CustomerINN - свойство

ИНН покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.CustomerName - свойство

Наименование покупателя (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CustomerName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Date - свойство

дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Date_DateTimeAsString - свойство

дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.IncomingInvoiceDate_DateTimeAsString - свойство

Ссылка на Приходную накладную. Поле Номер документа.. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingInvoiceDate_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.IncomingInvoiceNumber - свойство

Ссылка на Приходную накладную. Поле Дата документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string IncomingInvoiceNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Invoice - свойство

Строка поля счет-фактуры

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Invoice { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Processed - свойство

Проведен ли документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.Processed_BooleanAsString - свойство

Проведен ли документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.ReturnedInvoiceItems - свойство

Вложенные товарные позиции по расходной накладной"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoiceItem[] ReturnedInvoiceItems { get; }

Значение свойства

Тип: IReturnedInvoiceItem
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.RevenueAccountCode - свойство

Движение денежных средств (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.RevenueAccountName - свойство

Движение денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.WriteoffAccountCode - свойство

Статья расходов(код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.WriteoffAccountName - свойство

Статья расходов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice - методы

Тип IReturnedInvoice предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstReturnedInvoiceItem | Получение первого элемента массива
Открытый метод | GetNextReturnedInvoiceItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.GetFirstReturnedInvoiceItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoiceItem GetFirstReturnedInvoiceItem()

Возвращаемое значение

Тип: IReturnedInvoiceItem
Товарная единица по возвратной накладной
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoice.GetNextReturnedInvoiceItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoiceItem GetNextReturnedInvoiceItem()

Возвращаемое значение

Тип: IReturnedInvoiceItem
Товарная единица по возвратной накладной
См. также

Ссылки

IReturnedInvoice - интерфейс


IReturnedInvoiceItem - интерфейс

Интерфейс товарных единиц по возвратной накладной

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IReturnedInvoiceItem

Тип IReturnedInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IReturnedInvoiceItem - свойства

Тип IReturnedInvoiceItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | AlcoCategoryCode | Код классификатора алкогольной продукции.
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | ProducerJurPersonInn | ИНН для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonKpp | КПП для ЮЛ поставщика алкогольной продукции.
Открытое свойство | ProducerJurPersonName | Имя ЮЛ поставщика алкогольной продукции.
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
В начало страницы
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.AlcoCategoryCode - свойство

Код классификатора алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AlcoCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Nds - свойство

Сумма НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Nds_DecimalAsString - свойство

Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NdsPercent - свойство

Ставка НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NdsPercent_DecimalAsString - свойство

Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.PriceWithNds - свойство

Цена продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.PriceWithNds_DecimalAsString - свойство

Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.ProducerJurPersonInn - свойство

ИНН для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonInn { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.ProducerJurPersonKpp - свойство

КПП для ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonKpp { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.ProducerJurPersonName - свойство

Имя ЮЛ поставщика алкогольной продукции.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProducerJurPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoiceItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IReturnedInvoiceItem - интерфейс


IReturnedInvoices - интерфейс

Интерфейс загрузки возвратных накладных

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IReturnedInvoices

Тип IReturnedInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ReturnedInvoiceArray | вложенные расходные накладные
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstReturnedInvoice | Получение первого элемента массива ReturnedInvoiceArray
Открытый метод | GetNextReturnedInvoice | Получение следующего элемента массива ReturnedInvoiceArray
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IReturnedInvoices - свойства

Тип IReturnedInvoices предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ReturnedInvoiceArray | вложенные расходные накладные
В начало страницы
См. также

Ссылки

IReturnedInvoices - интерфейс


IReturnedInvoices.ReturnedInvoiceArray - свойство

вложенные расходные накладные

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoice[] ReturnedInvoiceArray { get; }

Значение свойства

Тип: IReturnedInvoice
См. также

Ссылки

IReturnedInvoices - интерфейс


IReturnedInvoices - методы

Тип IReturnedInvoices предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstReturnedInvoice | Получение первого элемента массива ReturnedInvoiceArray
Открытый метод | GetNextReturnedInvoice | Получение следующего элемента массива ReturnedInvoiceArray
В начало страницы
См. также

Ссылки

IReturnedInvoices - интерфейс


IReturnedInvoices.GetFirstReturnedInvoice - метод

Получение первого элемента массива ReturnedInvoiceArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoice GetFirstReturnedInvoice()

Возвращаемое значение

Тип: IReturnedInvoice
Возвратная накладаная
См. также

Ссылки

IReturnedInvoices - интерфейс


IReturnedInvoices.GetNextReturnedInvoice - метод

Получение следующего элемента массива ReturnedInvoiceArray

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IReturnedInvoice GetNextReturnedInvoice()

Возвращаемое значение

Тип: IReturnedInvoice
Возвратная накладаная
См. также

Ссылки

IReturnedInvoices - интерфейс


ISaleData - интерфейс

Интерфейс вложенных актов реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ISaleData

Тип ISaleData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | SaleItems | Вложенные товарные позиции акта реализации
Открытое свойство | SalesItems | Устарело. Вложенные товарные позиции акта реализации
Открытое свойство | SessionNumber | Номер смены iiko
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
Открытое свойство | WriteoffItems | Устарело. Вложенные товарные позиции списаний инградиентов
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstSaleDataItem | "Получение первого элемента массива
Открытый метод | GetFirstSaleItem | Устарело. Получение первого элемента массива SalesItems
Открытый метод | GetFirstWriteoffItem | Устарело. Получение первого элемента массива
Открытый метод | GetNextSaleDataItem | Получение следующего элемента массива
Открытый метод | GetNextSaleItem | Устарело. Получение следующего элемента массива
Открытый метод | GetNextWriteoffItem | Устарело. Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ISaleData - свойства

Тип ISaleData предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | RevenueAccountCode | Движение денежных средств (код)
Открытое свойство | RevenueAccountName | Движение денежных средств
Открытое свойство | SaleItems | Вложенные товарные позиции акта реализации
Открытое свойство | SalesItems | Устарело. Вложенные товарные позиции акта реализации
Открытое свойство | SessionNumber | Номер смены iiko
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | WriteoffAccountCode | Статья расходов(код)
Открытое свойство | WriteoffAccountName | Статья расходов
Открытое свойство | WriteoffItems | Устарело. Вложенные товарные позиции списаний инградиентов
В начало страницы
См. также

Ссылки

ISaleData - интерфейс


ISaleData.CashRegNumber - свойство

Номер кассы iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.JuristicPersonINN - свойство

Юридическое лицо, продавец (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.JuristicPersonName - свойство

Юридическое лицо, продавец (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ISaleData - интерфейс


ISaleData.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.RevenueAccountCode - свойство

Движение денежных средств (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.RevenueAccountName - свойство

Движение денежных средств

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string RevenueAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.SaleItems - свойство

Вложенные товарные позиции акта реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleDataItem[] SaleItems { get; }

Значение свойства

Тип: ISaleDataItem
См. также

Ссылки

ISaleData - интерфейс


ISaleData.SalesItems - свойство

Примечание: Данный API устарел.

Вложенные товарные позиции акта реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
ISaleItem[] SalesItems { get; }

Значение свойства

Тип: ISaleItem
См. также

Ссылки

ISaleData - интерфейс


ISaleData.SessionNumber - свойство

Номер смены iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SessionNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.WriteoffAccountCode - свойство

Статья расходов(код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.WriteoffAccountName - свойство

Статья расходов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleData - интерфейс


ISaleData.WriteoffItems - свойство

Примечание: Данный API устарел.

Вложенные товарные позиции списаний инградиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
IWriteoffItem[] WriteoffItems { get; }

Значение свойства

Тип: IWriteoffItem
См. также

Ссылки

ISaleData - интерфейс


ISaleData - методы

Тип ISaleData предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstSaleDataItem | "Получение первого элемента массива
Открытый метод | GetFirstSaleItem | Устарело. Получение первого элемента массива SalesItems
Открытый метод | GetFirstWriteoffItem | Устарело. Получение первого элемента массива
Открытый метод | GetNextSaleDataItem | Получение следующего элемента массива
Открытый метод | GetNextSaleItem | Устарело. Получение следующего элемента массива
Открытый метод | GetNextWriteoffItem | Устарело. Получение следующего элемента массива
В начало страницы
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetFirstSaleDataItem - метод

"Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleDataItem GetFirstSaleDataItem()

Возвращаемое значение

Тип: ISaleDataItem
Акт реализации
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetFirstSaleItem - метод

Примечание: Данный API устарел.

Получение первого элемента массива SalesItems

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
ISaleItem GetFirstSaleItem()

Возвращаемое значение

Тип: ISaleItem
Акт реализации
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetFirstWriteoffItem - метод

Примечание: Данный API устарел.

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
IWriteoffItem GetFirstWriteoffItem()

Возвращаемое значение

Тип: IWriteoffItem
Акт списания
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetNextSaleDataItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleDataItem GetNextSaleDataItem()

Возвращаемое значение

Тип: ISaleDataItem
Акт реализации
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetNextSaleItem - метод

Примечание: Данный API устарел.

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
ISaleItem GetNextSaleItem()

Возвращаемое значение

Тип: ISaleItem
Акт реализации
См. также

Ссылки

ISaleData - интерфейс


ISaleData.GetNextWriteoffItem - метод

Примечание: Данный API устарел.

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
IWriteoffItem GetNextWriteoffItem()

Возвращаемое значение

Тип: IWriteoffItem
Акт списания
См. также

Ссылки

ISaleData - интерфейс


ISaleDataItem - интерфейс

Интерфейс товарных единиц по акту реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ISaleDataItem

Тип ISaleDataItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsNomenclaturePercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsNomenclaturePercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ISaleDataItem - свойства

Тип ISaleDataItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsNomenclaturePercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsNomenclaturePercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | TargetDishAccountingCategoryCode | Группа учета целевого блюда (код)
Открытое свойство | TargetDishAccountingCategoryName | Группа учета целевого блюда (название)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Amount - свойство

Количество

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Nds - свойство

Сумма НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Nds_DecimalAsString - свойство

Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NdsNomenclaturePercent - свойство

Ставка НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsNomenclaturePercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NdsNomenclaturePercent_DecimalAsString - свойство

Ставка НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsNomenclaturePercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NdsPercent - свойство

Ставка НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NdsPercent_DecimalAsString - свойство

Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Operation - свойство

тип строки: 1=продажа, 2=списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.Operation_Int32AsString - свойство

тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.OperationName - свойство

тип строки: продажа/списание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.PriceWithNds - свойство

Цена продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.PriceWithNds_DecimalAsString - свойство

Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.SoldWithDishCode - свойство

Продано с блюдом (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.SoldWithDishName - свойство

Продано с блюдом (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.SoldWithDishOuterEanCode - свойство

Продано с блюдом (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.TargetDishAccountingCategoryCode - свойство

Группа учета целевого блюда (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.TargetDishAccountingCategoryName - свойство

Группа учета целевого блюда (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishAccountingCategoryName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.TargetDishCode - свойство

Целевое блюдо (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.TargetDishName - свойство

Целевое блюдо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.TargetDishOuterEanCode - свойство

Целевое блюдо (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.WriteoffType - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int WriteoffType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.WriteoffType_Int32AsString - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleDataItem.WriteoffTypeName - свойство

тип списания (название): Списывать со склада/Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleDataItem - интерфейс


ISaleItem - интерфейс

Примечание: Данный API устарел.

Интерфейс товарных единиц по акту реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute("Используйте ISaleDataItem")]
public interface ISaleItem

Тип ISaleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ISaleItem - свойства

Тип ISaleItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | Nds | Сумма НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | Nds_DecimalAsString | Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | NdsPercent | Ставка НДС с продаж (IEEE-число 2ой точности)
Открытое свойство | NdsPercent_DecimalAsString | Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | PriceWithNds | Цена продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | PriceWithNds_DecimalAsString | Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | SumWithNds | Сумма продажи с НДС (IEEE-число 2ой точности)
Открытое свойство | SumWithNds_DecimalAsString | Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.JuristicPersonINN - свойство

Юридическое лицо, продавец (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.JuristicPersonName - свойство

Юридическое лицо, продавец (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Nds - свойство

Сумма НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Nds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Nds_DecimalAsString - свойство

Сумма НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NdsPercent - свойство

Ставка НДС с продаж (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NdsPercent_DecimalAsString - свойство

Ставка НДС с продаж (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Operation - свойство

тип строки: 1=продажа, 2=списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.Operation_Int32AsString - свойство

тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.OperationName - свойство

тип строки: продажа/списание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.PriceWithNds - свойство

Цена продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double PriceWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.PriceWithNds_DecimalAsString - свойство

Цена продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string PriceWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.SoldWithDishCode - свойство

Продано с блюдом (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.SoldWithDishName - свойство

Продано с блюдом (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.SoldWithDishOuterEanCode - свойство

Продано с блюдом (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.SumWithNds - свойство

Сумма продажи с НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double SumWithNds { get; }

Значение свойства

Тип: Double
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.SumWithNds_DecimalAsString - свойство

Сумма продажи с НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SumWithNds_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.WriteoffType - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int WriteoffType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.WriteoffType_Int32AsString - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISaleItem.WriteoffTypeName - свойство

тип списания (название): Списывать со склада/Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ISaleItem - интерфейс


ISales - интерфейс

Интерфейс загрузки актов реализации и списаний инградиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ISales

Тип ISales предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | SalesData | вложенные акты реализации
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstSaleData | Получение первого элемента массива
Открытый метод | GetNextSaleData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ISales - свойства

Тип ISales предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | SalesData | вложенные акты реализации
В начало страницы
См. также

Ссылки

ISales - интерфейс


ISales.SalesData - свойство

вложенные акты реализации

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleData[] SalesData { get; }

Значение свойства

Тип: ISaleData
См. также

Ссылки

ISales - интерфейс


ISales - методы

Тип ISales предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstSaleData | Получение первого элемента массива
Открытый метод | GetNextSaleData | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

ISales - интерфейс


ISales.GetFirstSaleData - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleData GetFirstSaleData()

Возвращаемое значение

Тип: ISaleData
Акт списания
См. также

Ссылки

ISales - интерфейс


ISales.GetNextSaleData - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ISaleData GetNextSaleData()

Возвращаемое значение

Тип: ISaleData
Акт реализации
См. также

Ссылки

ISales - интерфейс


ITransformation - интерфейс

Интерфейс вложений актов переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ITransformation

Тип ITransformation предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomeItems | Вложенные товарные позиции приходов по актам переработки
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OutcomeItems | Вложенные товарные позиции расходов по актам переработки
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstIncomeItems | Получение первого элемента массива "Входящие"
Открытый метод | GetFirstOutcomeItems | Получение первого элемента массива "Исходящие"
Открытый метод | GetNextIncomeItems | Получение следующего элемента массива "Входящие"
Открытый метод | GetNextOutcomeItems | Получение следующего элемента массива "Исходящие"
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ITransformation - свойства

Тип ITransformation предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | IncomeItems | Вложенные товарные позиции приходов по актам переработки
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | OutcomeItems | Вложенные товарные позиции расходов по актам переработки
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
В начало страницы
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Date - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Date_DateTimeAsString - свойство

дата документа (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.IncomeItems - свойство

Вложенные товарные позиции приходов по актам переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem[] IncomeItems { get; }

Значение свойства

Тип: IProductionItem
См. также

Ссылки

ITransformation - интерфейс


ITransformation.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation.OutcomeItems - свойство

Вложенные товарные позиции расходов по актам переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem[] OutcomeItems { get; }

Значение свойства

Тип: IProductionItem
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITransformation - интерфейс


ITransformation.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

ITransformation - интерфейс


ITransformation - методы

Тип ITransformation предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstIncomeItems | Получение первого элемента массива "Входящие"
Открытый метод | GetFirstOutcomeItems | Получение первого элемента массива "Исходящие"
Открытый метод | GetNextIncomeItems | Получение следующего элемента массива "Входящие"
Открытый метод | GetNextOutcomeItems | Получение следующего элемента массива "Исходящие"
В начало страницы
См. также

Ссылки

ITransformation - интерфейс


ITransformation.GetFirstIncomeItems - метод

Получение первого элемента массива "Входящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetFirstIncomeItems()

Возвращаемое значение

Тип: IProductionItem
Акт переработки
См. также

Ссылки

ITransformation - интерфейс


ITransformation.GetFirstOutcomeItems - метод

Получение первого элемента массива "Исходящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetFirstOutcomeItems()

Возвращаемое значение

Тип: IProductionItem
Акт переработки
См. также

Ссылки

ITransformation - интерфейс


ITransformation.GetNextIncomeItems - метод

Получение следующего элемента массива "Входящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetNextIncomeItems()

Возвращаемое значение

Тип: IProductionItem
Акт переработки
См. также

Ссылки

ITransformation - интерфейс


ITransformation.GetNextOutcomeItems - метод

Получение следующего элемента массива "Исходящие"

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IProductionItem GetNextOutcomeItems()

Возвращаемое значение

Тип: IProductionItem
Акт переработки
См. также

Ссылки

ITransformation - интерфейс


ITransformations - интерфейс

Интерфейс загрузки актов переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ITransformations

Тип ITransformations предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | TransformationArray | вложенные акты переработки
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstTransformation | Получение первого элемента массива
Открытый метод | GetNextTransformation | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ITransformations - свойства

Тип ITransformations предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | TransformationArray | вложенные акты переработки
В начало страницы
См. также

Ссылки

ITransformations - интерфейс


ITransformations.TransformationArray - свойство

вложенные акты переработки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITransformation[] TransformationArray { get; }

Значение свойства

Тип: ITransformation
См. также

Ссылки

ITransformations - интерфейс


ITransformations - методы

Тип ITransformations предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstTransformation | Получение первого элемента массива
Открытый метод | GetNextTransformation | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

ITransformations - интерфейс


ITransformations.GetFirstTransformation - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITransformation GetFirstTransformation()

Возвращаемое значение

Тип: ITransformation
Акт переработки
См. также

Ссылки

ITransformations - интерфейс


ITransformations.GetNextTransformation - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITransformation GetNextTransformation()

Возвращаемое значение

Тип: ITransformation
Акт переработки
См. также

Ссылки

ITransformations - интерфейс


ITreeMenuChangeDocument - интерфейс

Интерфейс приказа об изменении меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ITreeMenuChangeDocument

Тип ITreeMenuChangeDocument предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | коментарий.
Открытое свойство | ConceptionCode | Концепция, которой принадлежит данный документ.
Открытое свойство | Date | дата документа
Открытое свойство | Deleted | документ удален
Открытое свойство | DeletePreviousMenu | удалять предыдущее меню
Открытое свойство | IncludeAllModifiers | автоматически добавлять модификаторы
Открытое свойство | Items | список элементов меню
Открытое свойство | Number | номер документа
Открытое свойство | Processed | документ проведен
В начало страницы
Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ITreeMenuChangeDocument - свойства

Тип ITreeMenuChangeDocument предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Comment | коментарий.
Открытое свойство | ConceptionCode | Концепция, которой принадлежит данный документ.
Открытое свойство | Date | дата документа
Открытое свойство | Deleted | документ удален
Открытое свойство | DeletePreviousMenu | удалять предыдущее меню
Открытое свойство | IncludeAllModifiers | автоматически добавлять модификаторы
Открытое свойство | Items | список элементов меню
Открытое свойство | Number | номер документа
Открытое свойство | Processed | документ проведен
В начало страницы
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Comment - свойство

коментарий.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.ConceptionCode - свойство

Концепция, которой принадлежит данный документ.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Date - свойство

дата документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; set; }

Значение свойства

Тип: DateTime
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Deleted - свойство

документ удален

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Deleted { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.DeletePreviousMenu - свойство

удалять предыдущее меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool DeletePreviousMenu { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.IncludeAllModifiers - свойство

автоматически добавлять модификаторы

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool IncludeAllModifiers { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Items - свойство

список элементов меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITreeMenuChangeDocumentItem[] Items { get; set; }

Значение свойства

Тип: ITreeMenuChangeDocumentItem
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.Processed - свойство

документ проведен

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument - методы

Тип ITreeMenuChangeDocument предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | ItemsAddItem | Добавление элемента
Открытый метод | ItemsClearArray | Очистка массива
Открытый метод | ItemsGetFirstElement | Получение первого элемента
Открытый метод | ItemsGetNextElement | Получение следующего элемента
В начало страницы
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.ItemsAddItem - метод

Добавление элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsAddItem(
    ITreeMenuChangeDocumentItem item
)

Параметры

item
Тип: iiko1CInterface.InterfacesITreeMenuChangeDocumentItem
Приказ об изменении меню
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.ItemsClearArray - метод

Очистка массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
void ItemsClearArray()
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.ItemsGetFirstElement - метод

Получение первого элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITreeMenuChangeDocumentItem ItemsGetFirstElement()

Возвращаемое значение

Тип: ITreeMenuChangeDocumentItem
Приказ об изменении меню
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocument.ItemsGetNextElement - метод

Получение следующего элемента

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
ITreeMenuChangeDocumentItem ItemsGetNextElement()

Возвращаемое значение

Тип: ITreeMenuChangeDocumentItem
Приказ об изменении меню
См. также

Ссылки

ITreeMenuChangeDocument - интерфейс


ITreeMenuChangeDocumentItem - интерфейс

Интерфейс элемента приказа об изменении меню

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface ITreeMenuChangeDocumentItem

Тип ITreeMenuChangeDocumentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Category | код ценовой категории
Открытое свойство | DepartmentId | код ресторана
Открытое свойство | Including | Включить или исключить из меню.
Открытое свойство | NewPrice | Новая цена. Если null, то цена не меняется.
Открытое свойство | NewPriceHasValue | NewPrice имеет значение
Открытое свойство | Num | Позиция строки в документе.
Открытое свойство | NumHasValue | Num имеет значение
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


ITreeMenuChangeDocumentItem - свойства

Тип ITreeMenuChangeDocumentItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | Category | код ценовой категории
Открытое свойство | DepartmentId | код ресторана
Открытое свойство | Including | Включить или исключить из меню.
Открытое свойство | NewPrice | Новая цена. Если null, то цена не меняется.
Открытое свойство | NewPriceHasValue | NewPrice имеет значение
Открытое свойство | Num | Позиция строки в документе.
Открытое свойство | NumHasValue | Num имеет значение
Открытое свойство | ProductArticle | Артикул продукта
Открытое свойство | ProductId | Guid продукта
В начало страницы
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.Category - свойство

код ценовой категории

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Category { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.DepartmentId - свойство

код ресторана

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.Including - свойство

Включить или исключить из меню.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Including { get; set; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.NewPrice - свойство

Новая цена. Если null, то цена не меняется.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NewPrice { get; set; }

Значение свойства

Тип: Double
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.NewPriceHasValue - свойство

NewPrice имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool NewPriceHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.Num - свойство

Позиция строки в документе.

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Num { get; set; }

Значение свойства

Тип: Int32
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.NumHasValue - свойство

Num имеет значение

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool NumHasValue { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.ProductArticle - свойство

Артикул продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductArticle { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


ITreeMenuChangeDocumentItem.ProductId - свойство

Guid продукта

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProductId { get; set; }

Значение свойства

Тип: String
См. также

Ссылки

ITreeMenuChangeDocumentItem - интерфейс


IVersion - интерфейс

Версия протокола выгрузки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IVersion

Тип IVersion предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProtocolVersion | Версия протокола выгрузки документов
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IVersion - свойства

Тип IVersion предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | ProtocolVersion | Версия протокола выгрузки документов
В начало страницы
См. также

Ссылки

IVersion - интерфейс


IVersion.ProtocolVersion - свойство

Версия протокола выгрузки документов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ProtocolVersion { get; }

Значение свойства

Тип: String
См. также

Ссылки

IVersion - интерфейс


IWriteoff - интерфейс

Интерфейс описания актов списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IWriteoff

Тип IWriteoff предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | SessionNumber | Номер смены iiko
Открытое свойство | WriteoffAccountCode | Статья расходов (код)
Открытое свойство | WriteoffAccountName | Статья расходов (наименование)
Открытое свойство | WriteoffItems | Вложенные товарные позиции по актам списания
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstWriteoffDocItem | Получение первого элемента массива
Открытый метод | GetNextWriteoffDocItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IWriteoff - свойства

Тип IWriteoff предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | CashRegNumber | Номер кассы iiko
Открытое свойство | Comment | Комментарий
Открытое свойство | ConceptionCode | Концепция (код)
Открытое свойство | ConceptionName | Концепция (название)
Открытое свойство | Date | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)
Открытое свойство | Date_DateTimeAsString | дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо (наименование)
Открытое свойство | Number | номер документа
Открытое свойство | Processed | Проведен ди документ
Открытое свойство | Processed_BooleanAsString | Проведен ди документ. Представление в виде строки
Открытое свойство | SessionNumber | Номер смены iiko
Открытое свойство | WriteoffAccountCode | Статья расходов (код)
Открытое свойство | WriteoffAccountName | Статья расходов (наименование)
Открытое свойство | WriteoffItems | Вложенные товарные позиции по актам списания
В начало страницы
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.CashRegNumber - свойство

Номер кассы iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CashRegNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Comment - свойство

Комментарий

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Comment { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.ConceptionCode - свойство

Концепция (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.ConceptionName - свойство

Концепция (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string ConceptionName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Date - свойство

дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
DateTime Date { get; }

Значение свойства

Тип: DateTime
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Date_DateTimeAsString - свойство

дата оприходования (ДД.ММ.ГГГГ ЧЧ.ММ.СС). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Date_DateTimeAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.JuristicPersonINN - свойство

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.JuristicPersonName - свойство

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Number - свойство

номер документа

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Number { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Processed - свойство

Проведен ди документ

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
bool Processed { get; }

Значение свойства

Тип: Boolean
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.Processed_BooleanAsString - свойство

Проведен ди документ. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Processed_BooleanAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.SessionNumber - свойство

Номер смены iiko

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SessionNumber { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.WriteoffAccountCode - свойство

Статья расходов (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.WriteoffAccountName - свойство

Статья расходов (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffAccountName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.WriteoffItems - свойство

Вложенные товарные позиции по актам списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoffDocItem[] WriteoffItems { get; }

Значение свойства

Тип: IWriteoffDocItem
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff - методы

Тип IWriteoff предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstWriteoffDocItem | Получение первого элемента массива
Открытый метод | GetNextWriteoffDocItem | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.GetFirstWriteoffDocItem - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoffDocItem GetFirstWriteoffDocItem()

Возвращаемое значение

Тип: IWriteoffDocItem
Акт списания
См. также

Ссылки

IWriteoff - интерфейс


IWriteoff.GetNextWriteoffDocItem - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoffDocItem GetNextWriteoffDocItem()

Возвращаемое значение

Тип: IWriteoffDocItem
Акт списания
См. также

Ссылки

IWriteoff - интерфейс


IWriteoffDocItem - интерфейс

Интерфейс описания товарных единиц по акту списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IWriteoffDocItem

Тип IWriteoffDocItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип операции: 1=списание, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип операции: 1=списание, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип операции: списание/списание ингредиентов
Открытое свойство | SoldWithDishAccountingCategoryCode | Группа учета проданного блюда (код)
Открытое свойство | SoldWithDishAccountingCategoryName | Группа учета проданного блюда (название)
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IWriteoffDocItem - свойства

Тип IWriteoffDocItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | Устарело. торговое предприятие (код)
Открытое свойство | DepartmentName | Устарело. торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Устарело. Юридическое лицо (ИНН)
Открытое свойство | JuristicPersonName | Устарело. Юридическое лицо (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsProductPercent | Ставка НДС из справочника (IEEE-число 2ой точности)
Открытое свойство | NdsProductPercent_DecimalAsString | Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureOuterEanCode | Номенклатура (код ТН ВЭД ЕАЭС)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип операции: 1=списание, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип операции: 1=списание, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип операции: списание/списание ингредиентов
Открытое свойство | SoldWithDishAccountingCategoryCode | Группа учета проданного блюда (код)
Открытое свойство | SoldWithDishAccountingCategoryName | Группа учета проданного блюда (название)
Открытое свойство | SoldWithDishCode | Продано с блюдом (код)
Открытое свойство | SoldWithDishName | Продано с блюдом (название)
Открытое свойство | SoldWithDishOuterEanCode | Продано с блюдом (код ТН ВЭД ЕАЭС)
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
Открытое свойство | TargetDishOuterEanCode | Целевое блюдо (код ТН ВЭД ЕАЭС)
Открытое свойство | WriteoffType | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты
Открытое свойство | WriteoffType_Int32AsString | тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки
Открытое свойство | WriteoffTypeName | тип списания (название): Списывать со склада/Списывать ингредиенты
В начало страницы
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.DepartmentCode - свойство

Примечание: Данный API устарел.

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.DepartmentName - свойство

Примечание: Данный API устарел.

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.JuristicPersonINN - свойство

Примечание: Данный API устарел.

Юридическое лицо (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.JuristicPersonName - свойство

Примечание: Данный API устарел.

Юридическое лицо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute]
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NdsProductPercent - свойство

Ставка НДС из справочника (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsProductPercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NdsProductPercent_DecimalAsString - свойство

Ставка НДС из справочника (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsProductPercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NomenclatureOuterEanCode - свойство

Номенклатура (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Operation - свойство

тип операции: 1=списание, 2=списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.Operation_Int32AsString - свойство

тип операции: 1=списание, 2=списание ингредиентов. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.OperationName - свойство

тип операции: списание/списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.SoldWithDishAccountingCategoryCode - свойство

Группа учета проданного блюда (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishAccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.SoldWithDishAccountingCategoryName - свойство

Группа учета проданного блюда (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishAccountingCategoryName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.SoldWithDishCode - свойство

Продано с блюдом (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.SoldWithDishName - свойство

Продано с блюдом (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.SoldWithDishOuterEanCode - свойство

Продано с блюдом (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string SoldWithDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.TargetDishCode - свойство

Целевое блюдо (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.TargetDishName - свойство

Целевое блюдо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.TargetDishOuterEanCode - свойство

Целевое блюдо (код ТН ВЭД ЕАЭС)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishOuterEanCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.WriteoffType - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int WriteoffType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.WriteoffType_Int32AsString - свойство

тип списания: 1=Списывать со склада, 2=Списывать ингредиенты. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffDocItem.WriteoffTypeName - свойство

тип списания (название): Списывать со склада/Списывать ингредиенты

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string WriteoffTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffDocItem - интерфейс


IWriteoffItem - интерфейс

Примечание: Данный API устарел.

Интерфейс массива товарных единиц по списанию инградиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
[ObsoleteAttribute("Используйте IWriteoffDocItem")]
public interface IWriteoffItem

Тип IWriteoffItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsNomenclaturePercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsNomenclaturePercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IWriteoffItem - свойства

Тип IWriteoffItem предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | AccountingCategory | группа учета (название)
Открытое свойство | AccountingCategoryCode | группа учета (код)
Открытое свойство | Amount | Количество (IEEE-число 4ой точности)
Открытое свойство | Amount_DecimalAsString | Количество (IEEE-число 4ой точности). Представление в виде строки
Открытое свойство | Article | Номенклатурный код (строковое значение)
Открытое свойство | CostPrice | Себестоимость без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPrice_DecimalAsString | Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | CostPriceByUnit | Себестоимость за ед. без НДС (IEEE-число 2ой точности)
Открытое свойство | CostPriceByUnit_DecimalAsString | Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | DepartmentCode | торговое предприятие (код)
Открытое свойство | DepartmentName | торговое предприятие (наименование)
Открытое свойство | JuristicPersonINN | Юридическое лицо, продавец (ИНН)
Открытое свойство | JuristicPersonName | Юридическое лицо, продавец (наименование)
Открытое свойство | MeasureUnitCode | Единица измерения (наименование)
Открытое свойство | MeasureUnitName | Единица измерения (код)
Открытое свойство | NdsNomenclaturePercent | Ставка НДС (IEEE-число 2ой точности)
Открытое свойство | NdsNomenclaturePercent_DecimalAsString | Ставка НДС (IEEE-число 2ой точности). Представление в виде строки
Открытое свойство | Nomenclature | Наименование номенклатуры (строковое значение)
Открытое свойство | NomenclatureType | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)
Открытое свойство | NomenclatureType_Int32AsString | Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки
Открытое свойство | NomenclatureTypeName | Тип номенклатурной позиции (название)
Открытое свойство | Operation | тип строки: 1=продажа, 2=списание ингредиентов
Открытое свойство | Operation_Int32AsString | тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки
Открытое свойство | OperationName | тип строки: продажа/списание
Открытое свойство | StoreCode | Код склада (строковое значение)
Открытое свойство | StoreName | Название склада (строковое значение)
Открытое свойство | TargetDishCode | Целевое блюдо (код)
Открытое свойство | TargetDishName | Целевое блюдо (наименование)
В начало страницы
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.AccountingCategory - свойство

группа учета (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategory { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.AccountingCategoryCode - свойство

группа учета (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string AccountingCategoryCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Amount - свойство

Количество (IEEE-число 4ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double Amount { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Amount_DecimalAsString - свойство

Количество (IEEE-число 4ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Amount_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Article - свойство

Номенклатурный код (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Article { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.CostPrice - свойство

Себестоимость без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPrice { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.CostPrice_DecimalAsString - свойство

Себестоимость без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPrice_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.CostPriceByUnit - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double CostPriceByUnit { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.CostPriceByUnit_DecimalAsString - свойство

Себестоимость за ед. без НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string CostPriceByUnit_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.DepartmentCode - свойство

торговое предприятие (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.DepartmentName - свойство

торговое предприятие (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string DepartmentName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.JuristicPersonINN - свойство

Юридическое лицо, продавец (ИНН)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonINN { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.JuristicPersonName - свойство

Юридическое лицо, продавец (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string JuristicPersonName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.MeasureUnitCode - свойство

Единица измерения (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.MeasureUnitName - свойство

Единица измерения (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string MeasureUnitName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.NdsNomenclaturePercent - свойство

Ставка НДС (IEEE-число 2ой точности)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
double NdsNomenclaturePercent { get; }

Значение свойства

Тип: Double
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.NdsNomenclaturePercent_DecimalAsString - свойство

Ставка НДС (IEEE-число 2ой точности). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NdsNomenclaturePercent_DecimalAsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Nomenclature - свойство

Наименование номенклатуры (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Nomenclature { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.NomenclatureType - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int NomenclatureType { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.NomenclatureType_Int32AsString - свойство

Тип номенклатурной позиции (код: 1 - блюдо, 2 - модификатор, 3 - товар, 4 - заготовка, 5 - сервис). Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureType_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.NomenclatureTypeName - свойство

Тип номенклатурной позиции (название)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string NomenclatureTypeName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Operation - свойство

тип строки: 1=продажа, 2=списание ингредиентов

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
int Operation { get; }

Значение свойства

Тип: Int32
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.Operation_Int32AsString - свойство

тип строки: 1=продажа, 2=списание ингредиентов. Представление в виде строки

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string Operation_Int32AsString { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.OperationName - свойство

тип строки: продажа/списание

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string OperationName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.StoreCode - свойство

Код склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.StoreName - свойство

Название склада (строковое значение)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string StoreName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.TargetDishCode - свойство

Целевое блюдо (код)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishCode { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffItem.TargetDishName - свойство

Целевое блюдо (наименование)

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
string TargetDishName { get; }

Значение свойства

Тип: String
См. также

Ссылки

IWriteoffItem - интерфейс


IWriteoffs - интерфейс

Интерфейс описания актов списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
public interface IWriteoffs

Тип IWriteoffs предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | WriteoffArray | вложенные акты списания
В начало страницы
Методы
 | Имя | Описание
Открытый метод | GetFirstWriteoff | Получение первого элемента массива
Открытый метод | GetNextWriteoff | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

iiko1CInterface.Interfaces - пространство имён

ЗАО "Айко" 2021 [Версия 5.2.1.0]

Отправить комментарий по этой теме в support@iiko.ru


IWriteoffs - свойства

Тип IWriteoffs предоставляет следующие члены.

Свойства
 | Имя | Описание
Открытое свойство | WriteoffArray | вложенные акты списания
В начало страницы
См. также

Ссылки

IWriteoffs - интерфейс


IWriteoffs.WriteoffArray - свойство

вложенные акты списания

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoff[] WriteoffArray { get; }

Значение свойства

Тип: IWriteoff
См. также

Ссылки

IWriteoffs - интерфейс


IWriteoffs - методы

Тип IWriteoffs предоставляет следующие члены.

Методы
 | Имя | Описание
Открытый метод | GetFirstWriteoff | Получение первого элемента массива
Открытый метод | GetNextWriteoff | Получение следующего элемента массива
В начало страницы
См. также

Ссылки

IWriteoffs - интерфейс


IWriteoffs.GetFirstWriteoff - метод

Получение первого элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoff GetFirstWriteoff()

Возвращаемое значение

Тип: IWriteoff
Акт списания
См. также

Ссылки

IWriteoffs - интерфейс


IWriteoffs.GetNextWriteoff - метод

Получение следующего элемента массива

Пространство имён: iiko1CInterface.Interfaces
Сборка: iiko1CInterface (в iiko1CInterface.dll) Версия: 1ca4876affdd3bc5359a98b321fc115a647d2251
Синтаксис
C#
Копировать
IWriteoff GetNextWriteoff()

Возвращаемое значение

Тип: IWriteoff
Акт списания
См. также

Ссылки

IWriteoffs - интерфейс