Resto.Front.Api Namespace

Classes
 | Class | Description
Public class | OperationArgumentExtensions |
Public class | PluginContext | Provides access to api services.
Structures
 | Structure | Description
Public structure | VoidValue | Represents dummy value for IObservableT where notification itself is the only purpose to have such sequence and notification argument doesn't have any meaning. It's something like Void-method in the Rx-world.
Interfaces
 | Interface | Description
Public interface | IFrontPlugin | Common interface for every front plugin. Implement this interface to make front treat your class as plugin.
Public interface | ILicensingService | Service provides access to plugin licensing.
Public interface | ILog | Provides a set of methods to log messages.
Public interface | INotificationT | Defines a provider for push-based notification.
Public interface | INotificationT, TResult | Defines a provider for push-based notification.
Public interface | INotificationService |
Public interface | IOperationService | Provides a set of operations.
Public interface | IPaymentDataContext | Helper to work with plugin saved data in iiko storage.
Public interface | IPaymentProcessor | Common interface for payment front plugin.
Public interface | IPluginIntegrationService | Service provides integration features.
Public interface | IReceiptPrinter | Instance to perform print actions. Should be used only when it comes like function parameter.


IFrontPlugin Interface

Common interface for every front plugin. Implement this interface to make front treat your class as plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IFrontPlugin : IDisposable

The IFrontPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

Resto.Front.Api Namespace


IFrontPlugin Methods

The IFrontPlugin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Top
See Also

Reference

IFrontPlugin Interface
Resto.Front.Api Namespace


ILicensingService Interface

Service provides access to plugin licensing.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ILicensingService

The ILicensingService type exposes the following members.

Methods
 | Name | Description
Public method | AcquireSlot | Acquires one slot from the specified module for client with specified identifier. This method will temporarily bind slot to the client, repeated acquisitions from the same module for the same client will return the same slot.
Public method | IsEnabled | Checks whether the specified module is enabled in the license.
Top
See Also

Reference

Resto.Front.Api Namespace


ILicensingService Methods

The ILicensingService type exposes the following members.

Methods
 | Name | Description
Public method | AcquireSlot | Acquires one slot from the specified module for client with specified identifier. This method will temporarily bind slot to the client, repeated acquisitions from the same module for the same client will return the same slot.
Public method | IsEnabled | Checks whether the specified module is enabled in the license.
Top
See Also

Reference

ILicensingService Interface
Resto.Front.Api Namespace


ILicensingService.AcquireSlot Method

iikoFront Api V7Preview7 Code Reference

ILicensingServiceAcquireSlot Method

Acquires one slot from the specified module for client with specified identifier. This method will temporarily bind slot to the client, repeated acquisitions from the same module for the same client will return the same slot.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AcquireSlot(
    int moduleId,
    Guid clientId
)

Parameters

moduleId
Type: SystemInt32
The licensable module identifier.
clientId
Type: SystemGuid
The calling client identifier.

Return Value

Type: IDisposable
A token for single licensing unit (plugin instance or external connection), disposing it releases slot and unbinds the slot from the client.
Exceptions
Exception | Condition
InsufficientLicenseException | License slot could not be acquired.
See Also

Reference

ILicensingService Interface
Resto.Front.Api Namespace


ILicensingService.IsEnabled Method

ILicensingServiceIsEnabled Method

Checks whether the specified module is enabled in the license.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsEnabled(
    int moduleId
)

Parameters

moduleId
Type: SystemInt32
The licensable module identifier.

Return Value

Type: Boolean
true if the specified module is enabled.
Remarks
Module is enabled when there is an active (not expired) license for this module. This method just checks if the module itself is enabled, it doesn't check whether the module contains any available slots.
See Also

Reference

ILicensingService Interface
Resto.Front.Api Namespace


ILog Interface

Provides a set of methods to log messages.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ILog

The ILog type exposes the following members.

Methods
 | Name | Description
Public method | Error(String) | Logs a message with the Error level.
Public method | Error(String, Exception) | Logs a message with the Error level including the stack trace of the exception passed as a parameter.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Public method | Info | Logs a message with the Info level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Public method | Warn | Logs a message with the Warn level.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Top
See Also

Reference

Resto.Front.Api Namespace


ILog Methods

The ILog type exposes the following members.

Methods
 | Name | Description
Public method | Error(String) | Logs a message with the Error level.
Public method | Error(String, Exception) | Logs a message with the Error level including the stack trace of the exception passed as a parameter.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Public method | Info | Logs a message with the Info level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Public method | Warn | Logs a message with the Warn level.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Top
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.Error Method

ILogError Method

Overload List
 | Name | Description
Public method | Error(String) | Logs a message with the Error level.
Public method | Error(String, Exception) | Logs a message with the Error level including the stack trace of the exception passed as a parameter.
Top
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.Error Method (String)

ILogError Method (String)

Logs a message with the Error level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Error(
    string message
)

Parameters

message
Type: SystemString
The message to log.
See Also

Reference

ILog Interface
Error Overload
Resto.Front.Api Namespace


ILog.Error Method (String, Exception)

ILogError Method (String, Exception)

Logs a message with the Error level including the stack trace of the exception passed as a parameter.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Error(
    string message,
    Exception exception
)

Parameters

message
Type: SystemString
The message to log.
exception
Type: SystemException
The exception to log, including its stack trace.
See Also

Reference

ILog Interface
Error Overload
Resto.Front.Api Namespace


ILog.ErrorFormat Method

ILogErrorFormat Method

Overload List
 | Name | Description
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object) | Logs a formatted message string with the Error level.
Public method | ErrorFormat(String, Object, Object, Object) | Logs a formatted message string with the Error level.
Top
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.ErrorFormat Method (String, Object)

ILogErrorFormat Method (String, Object)

Logs a formatted message string with the Error level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ErrorFormat(
    string format,
    Object arg
)

Parameters

format
Type: SystemString
A composite format string.
arg
Type: SystemObject
The object to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
ErrorFormat Overload
Resto.Front.Api Namespace


ILog.ErrorFormat Method (String, Object[])

ILogErrorFormat Method (String, Object)

Logs a formatted message string with the Error level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ErrorFormat(
    string format,
    params Object[] args
)

Parameters

format
Type: SystemString
A composite format string.
args
Type: SystemObject
An object array that contains zero or more objects to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
ErrorFormat Overload
Resto.Front.Api Namespace


ILog.ErrorFormat Method (String, Object, Object)

ILogErrorFormat Method (String, Object, Object)

Logs a formatted message string with the Error level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
Remarks
The message is formatted using the Format(String, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
ErrorFormat Overload
Resto.Front.Api Namespace


ILog.ErrorFormat Method (String, Object, Object, Object)

ILogErrorFormat Method (String, Object, Object, Object)

Logs a formatted message string with the Error level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ErrorFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
arg2
Type: SystemObject
The third object to format.
Remarks
The message is formatted using the Format(String, Object, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
ErrorFormat Overload
Resto.Front.Api Namespace


ILog.Info Method

ILogInfo Method

Logs a message with the Info level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Info(
    string message
)

Parameters

message
Type: SystemString
The message to log.
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.InfoFormat Method

ILogInfoFormat Method

Overload List
 | Name | Description
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object) | Logs a formatted message string with the Info level.
Public method | InfoFormat(String, Object, Object, Object) | Logs a formatted message string with the Info level.
Top
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.InfoFormat Method (String, Object)

ILogInfoFormat Method (String, Object)

Logs a formatted message string with the Info level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void InfoFormat(
    string format,
    Object arg
)

Parameters

format
Type: SystemString
A composite format string.
arg
Type: SystemObject
The object to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
InfoFormat Overload
Resto.Front.Api Namespace


ILog.InfoFormat Method (String, Object[])

ILogInfoFormat Method (String, Object)

Logs a formatted message string with the Info level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void InfoFormat(
    string format,
    params Object[] args
)

Parameters

format
Type: SystemString
A composite format string.
args
Type: SystemObject
An object array that contains zero or more objects to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
InfoFormat Overload
Resto.Front.Api Namespace


ILog.InfoFormat Method (String, Object, Object)

ILogInfoFormat Method (String, Object, Object)

Logs a formatted message string with the Info level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void InfoFormat(
    string format,
    Object arg0,
    Object arg1
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
Remarks
The message is formatted using the Format(String, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
InfoFormat Overload
Resto.Front.Api Namespace


ILog.InfoFormat Method (String, Object, Object, Object)

ILogInfoFormat Method (String, Object, Object, Object)

Logs a formatted message string with the Info level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void InfoFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
arg2
Type: SystemObject
The third object to format.
Remarks
The message is formatted using the Format(String, Object, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
InfoFormat Overload
Resto.Front.Api Namespace


ILog.Warn Method

ILogWarn Method

Logs a message with the Warn level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Warn(
    string message
)

Parameters

message
Type: SystemString
The message to log.
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.WarnFormat Method

ILogWarnFormat Method

Overload List
 | Name | Description
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object) | Logs a formatted message string with the Warn level.
Public method | WarnFormat(String, Object, Object, Object) | Logs a formatted message string with the Warn level.
Top
See Also

Reference

ILog Interface
Resto.Front.Api Namespace


ILog.WarnFormat Method (String, Object)

ILogWarnFormat Method (String, Object)

Logs a formatted message string with the Warn level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void WarnFormat(
    string format,
    Object arg
)

Parameters

format
Type: SystemString
A composite format string.
arg
Type: SystemObject
The object to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
WarnFormat Overload
Resto.Front.Api Namespace


ILog.WarnFormat Method (String, Object[])

ILogWarnFormat Method (String, Object)

Logs a formatted message string with the Warn level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void WarnFormat(
    string format,
    params Object[] args
)

Parameters

format
Type: SystemString
A composite format string.
args
Type: SystemObject
An object array that contains zero or more objects to format.
Remarks
The message is formatted using the Format(String, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
WarnFormat Overload
Resto.Front.Api Namespace


ILog.WarnFormat Method (String, Object, Object)

ILogWarnFormat Method (String, Object, Object)

Logs a formatted message string with the Warn level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void WarnFormat(
    string format,
    Object arg0,
    Object arg1
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
Remarks
The message is formatted using the Format(String, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
WarnFormat Overload
Resto.Front.Api Namespace


ILog.WarnFormat Method (String, Object, Object, Object)

ILogWarnFormat Method (String, Object, Object, Object)

Logs a formatted message string with the Warn level.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void WarnFormat(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)

Parameters

format
Type: SystemString
A composite format string.
arg0
Type: SystemObject
The first object to format.
arg1
Type: SystemObject
The second object to format.
arg2
Type: SystemObject
The third object to format.
Remarks
The message is formatted using the Format(String, Object, Object, Object) method. See string.Format for details of the syntax of the format string and the behavior of the formatting.
See Also

Reference

ILog Interface
WarnFormat Overload
Resto.Front.Api Namespace


INotification(T) Interface

INotificationT Interface

Defines a provider for push-based notification.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INotification<out T>

Type Parameters

T

The INotificationT type exposes the following members.

Methods
 | Name | Description
Public method | Subscribe |
Top
See Also

Reference

Resto.Front.Api Namespace


INotification(T) Methods

INotificationT Methods

The INotificationT generic type exposes the following members.

Methods
 | Name | Description
Public method | Subscribe |
Top
See Also

Reference

INotificationT Interface
Resto.Front.Api Namespace


INotification(T).Subscribe Method

INotificationTSubscribe Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable Subscribe(
    Action<T> handler
)

Parameters

handler
Type: SystemAction T

Return Value

Type: IDisposable
See Also

Reference

INotificationT Interface
Resto.Front.Api Namespace


INotification(T, TResult) Interface

INotificationT, TResult Interface

Defines a provider for push-based notification.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INotification<out T, in TResult>

Type Parameters

T
TResult

The INotificationT, TResult type exposes the following members.

Methods
 | Name | Description
Public method | Subscribe |
Top
See Also

Reference

Resto.Front.Api Namespace


INotification(T, TResult) Methods

INotificationT, TResult Methods

The INotificationT, TResult generic type exposes the following members.

Methods
 | Name | Description
Public method | Subscribe |
Top
See Also

Reference

INotificationT, TResult Interface
Resto.Front.Api Namespace


INotification(T, TResult).Subscribe Method

INotificationT, TResultSubscribe Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable Subscribe(
    Func<T, TResult> handler
)

Parameters

handler
Type: SystemFunc T, TResult

Return Value

Type: IDisposable
See Also

Reference

INotificationT, TResult Interface
Resto.Front.Api Namespace


INotificationService Interface

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INotificationService

The INotificationService type exposes the following members.

Properties
 | Name | Description
Public property | BeforeDeleteOrder | Order deletion. Throwing OperationCanceledException will abort the operation.
Public property | BeforeDeletePrintedItem | Printed order item deletion. Throwing OperationCanceledException will abort the operation.
Public property | BeforeDoCheque | After payment before cheque printing.
Public property | BeforeOrderBill | Order billing. Throwing OperationCanceledException will abort the operation.
Public property | BeforeServiceCheque | Order items service printing. Throwing OperationCanceledException will abort the operation.
Public property | BillChequePosResolving | Bill cheque printing, allows to send bill cheque task to custom point of sale.
Public property | BillChequePrinting | Bill cheque printing, allows to extend the cheque with custom header or footer sections.
Public property | CafeSessionChanged |
Public property | CafeSessionClosing | Cafe session closing, allows to print custom reports.
Public property | CafeSessionOpening | Cafe session opening, allows to print custom reports.
Public property | CashChequePrinting | Cash cheque printing, allows to extend the cheque with custom header or footer sections.
Public property | ChangeSumChanged |
Public property | CityChanged |
Public property | ClientChanged |
Public property | CompoundItemTemplateChanged |
Public property | CurrentUserChanged |
Public property | DeliveryCancelCauseChanged |
Public property | DeliveryOrderChanged |
Public property | DeliverySettingsChanged |
Public property | DiscountCardChanged |
Public property | DiscountTypeChanged |
Public property | DonationTypeChanged |
Public property | ExternalOperationChanged |
Public property | KitchenOrderChanged |
Public property | MarketingSourceChanged |
Public property | NavigatingToPaymentScreen | Navigating to the payment screen. Throwing OperationCanceledException will abort the operation.
Public property | OrderBillCancelled |
Public property | OrderChanged |
Public property | OrderEditBarcodeScanned | Barcode scanning on the order edit screen. Handler should return true if the event is to be marked handled.
Public property | OrderEditCardSlided | Card slided on the order edit screen. Handler should return true if the event is to be marked handled.
Public property | OrderSplittedByCashRegisters | Order splitted by cash registers, allows to track relationship between deleted source order and created new orders.
Public property | OrderStorned | Order storned, allows to track relationship between deleted source and created new order.
Public property | PaymentTypeChanged |
Public property | PreliminaryOrderChanged |
Public property | PriceCategoryChanged |
Public property | ProductCategoryChanged |
Public property | ProductChanged |
Public property | ProductGroupChanged |
Public property | ProductScaleChanged |
Public property | ProductSizeChanged |
Public property | ProductsRemainingAmountsChanged |
Public property | ProductStocksListChanged |
Public property | QuickMenuUpdated |
Public property | RegionChanged |
Public property | RemovalTypeChanged |
Public property | ReserveChanged |
Public property | RestaurantChanged |
Public property | RestaurantSectionChanged |
Public property | RoleChanged |
Public property | ScreenChanged |
Public property | ServiceChequePrinted | Service cheque printed.
Public property | StreetChanged |
Public property | TableChanged |
Public property | TaxCategoryChanged |
Public property | TerminalChanged |
Public property | TerminalsGroupChanged |
Public property | UserChanged |
Public property | UserSessionChanged |
Top
See Also

Reference

Resto.Front.Api Namespace


INotificationService Properties

The INotificationService type exposes the following members.

Properties
 | Name | Description
Public property | BeforeDeleteOrder | Order deletion. Throwing OperationCanceledException will abort the operation.
Public property | BeforeDeletePrintedItem | Printed order item deletion. Throwing OperationCanceledException will abort the operation.
Public property | BeforeDoCheque | After payment before cheque printing.
Public property | BeforeOrderBill | Order billing. Throwing OperationCanceledException will abort the operation.
Public property | BeforeServiceCheque | Order items service printing. Throwing OperationCanceledException will abort the operation.
Public property | BillChequePosResolving | Bill cheque printing, allows to send bill cheque task to custom point of sale.
Public property | BillChequePrinting | Bill cheque printing, allows to extend the cheque with custom header or footer sections.
Public property | CafeSessionChanged |
Public property | CafeSessionClosing | Cafe session closing, allows to print custom reports.
Public property | CafeSessionOpening | Cafe session opening, allows to print custom reports.
Public property | CashChequePrinting | Cash cheque printing, allows to extend the cheque with custom header or footer sections.
Public property | ChangeSumChanged |
Public property | CityChanged |
Public property | ClientChanged |
Public property | CompoundItemTemplateChanged |
Public property | CurrentUserChanged |
Public property | DeliveryCancelCauseChanged |
Public property | DeliveryOrderChanged |
Public property | DeliverySettingsChanged |
Public property | DiscountCardChanged |
Public property | DiscountTypeChanged |
Public property | DonationTypeChanged |
Public property | ExternalOperationChanged |
Public property | KitchenOrderChanged |
Public property | MarketingSourceChanged |
Public property | NavigatingToPaymentScreen | Navigating to the payment screen. Throwing OperationCanceledException will abort the operation.
Public property | OrderBillCancelled |
Public property | OrderChanged |
Public property | OrderEditBarcodeScanned | Barcode scanning on the order edit screen. Handler should return true if the event is to be marked handled.
Public property | OrderEditCardSlided | Card slided on the order edit screen. Handler should return true if the event is to be marked handled.
Public property | OrderSplittedByCashRegisters | Order splitted by cash registers, allows to track relationship between deleted source order and created new orders.
Public property | OrderStorned | Order storned, allows to track relationship between deleted source and created new order.
Public property | PaymentTypeChanged |
Public property | PreliminaryOrderChanged |
Public property | PriceCategoryChanged |
Public property | ProductCategoryChanged |
Public property | ProductChanged |
Public property | ProductGroupChanged |
Public property | ProductScaleChanged |
Public property | ProductSizeChanged |
Public property | ProductsRemainingAmountsChanged |
Public property | ProductStocksListChanged |
Public property | QuickMenuUpdated |
Public property | RegionChanged |
Public property | RemovalTypeChanged |
Public property | ReserveChanged |
Public property | RestaurantChanged |
Public property | RestaurantSectionChanged |
Public property | RoleChanged |
Public property | ScreenChanged |
Public property | ServiceChequePrinted | Service cheque printed.
Public property | StreetChanged |
Public property | TableChanged |
Public property | TaxCategoryChanged |
Public property | TerminalChanged |
Public property | TerminalsGroupChanged |
Public property | UserChanged |
Public property | UserSessionChanged |
Top
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BeforeDeleteOrder Property

INotificationServiceBeforeDeleteOrder Property

Order deletion. Throwing OperationCanceledException will abort the operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IViewManager vm)> BeforeDeleteOrder { get; }

Property Value

Type: INotification ValueTuple IOrder, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BeforeDeletePrintedItem Property

INotificationServiceBeforeDeletePrintedItem Property

Printed order item deletion. Throwing OperationCanceledException will abort the operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IReadOnlyCollection<IOrderRootItem> deletingItems, IReadOnlyCollection<IOrderModifierItem> deletingModifiers, IDeletionMethod dm, IViewManager vm)> BeforeDeletePrintedItem { get; }

Property Value

Type: INotification ValueTuple IOrder, IReadOnlyCollection IOrderRootItem , IReadOnlyCollection IOrderModifierItem , IDeletionMethod, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BeforeDoCheque Property

INotificationServiceBeforeDoCheque Property

After payment before cheque printing.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IOperationService os, IViewManager vm)> BeforeDoCheque { get; }

Property Value

Type: INotification ValueTuple IOrder, IOperationService, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BeforeOrderBill Property

INotificationServiceBeforeOrderBill Property

Order billing. Throwing OperationCanceledException will abort the operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IOperationService os, IViewManager vm)> BeforeOrderBill { get; }

Property Value

Type: INotification ValueTuple IOrder, IOperationService, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BeforeServiceCheque Property

INotificationServiceBeforeServiceCheque Property

Order items service printing. Throwing OperationCanceledException will abort the operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IReadOnlyCollection<IOrderCookingItem> printingItems, IViewManager vm)> BeforeServiceCheque { get; }

Property Value

Type: INotification ValueTuple IOrder, IReadOnlyCollection IOrderCookingItem , IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.BillChequePosResolving Property

INotificationServiceBillChequePosResolving Property

Bill cheque printing, allows to send bill cheque task to custom point of sale.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, bool isStorno), IPointOfSale> BillChequePosResolving { get; }

Property Value

Type: INotification ValueTuple IOrder, Boolean , IPointOfSale
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace
CashRegisterDriverParametersIsBillTaskSupported


INotificationService.BillChequePrinting Property

INotificationServiceBillChequePrinting Property

Bill cheque printing, allows to extend the cheque with custom header or footer sections.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<Guid, BillCheque> BillChequePrinting { get; }

Property Value

Type: INotification Guid, BillCheque
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CafeSessionChanged Property

INotificationServiceCafeSessionChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ICafeSession>> CafeSessionChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ICafeSession
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CafeSessionClosing Property

INotificationServiceCafeSessionClosing Property

Cafe session closing, allows to print custom reports.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IReceiptPrinter printer, IViewManager vm)> CafeSessionClosing { get; }

Property Value

Type: INotification ValueTuple IReceiptPrinter, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CafeSessionOpening Property

INotificationServiceCafeSessionOpening Property

Cafe session opening, allows to print custom reports.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IReceiptPrinter printer, IViewManager vm)> CafeSessionOpening { get; }

Property Value

Type: INotification ValueTuple IReceiptPrinter, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CashChequePrinting Property

INotificationServiceCashChequePrinting Property

Cash cheque printing, allows to extend the cheque with custom header or footer sections.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<Guid, CashCheque> CashChequePrinting { get; }

Property Value

Type: INotification Guid, CashCheque
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ChangeSumChanged Property

INotificationServiceChangeSumChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<decimal> ChangeSumChanged { get; }

Property Value

Type: IObservable Decimal
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CityChanged Property

INotificationServiceCityChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ICity>> CityChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ICity
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ClientChanged Property

INotificationServiceClientChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IClient> ClientChanged { get; }

Property Value

Type: IObservable IClient
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CompoundItemTemplateChanged Property

INotificationServiceCompoundItemTemplateChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ICompoundItemTemplate>> CompoundItemTemplateChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ICompoundItemTemplate
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.CurrentUserChanged Property

INotificationServiceCurrentUserChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IUser> CurrentUserChanged { get; }

Property Value

Type: IObservable IUser
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DeliveryCancelCauseChanged Property

INotificationServiceDeliveryCancelCauseChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IDeliveryCancelCause>> DeliveryCancelCauseChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IDeliveryCancelCause
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DeliveryOrderChanged Property

INotificationServiceDeliveryOrderChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IDeliveryOrder>> DeliveryOrderChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IDeliveryOrder
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DeliverySettingsChanged Property

INotificationServiceDeliverySettingsChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IDeliverySettings> DeliverySettingsChanged { get; }

Property Value

Type: IObservable IDeliverySettings
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DiscountCardChanged Property

INotificationServiceDiscountCardChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IDiscountCard>> DiscountCardChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IDiscountCard
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DiscountTypeChanged Property

INotificationServiceDiscountTypeChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IDiscountType>> DiscountTypeChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IDiscountType
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.DonationTypeChanged Property

INotificationServiceDonationTypeChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IDonationType>> DonationTypeChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IDonationType
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ExternalOperationChanged Property

INotificationServiceExternalOperationChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<ExternalOperationChangedEventArgs> ExternalOperationChanged { get; }

Property Value

Type: IObservable ExternalOperationChangedEventArgs
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.KitchenOrderChanged Property

INotificationServiceKitchenOrderChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IKitchenOrder>> KitchenOrderChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IKitchenOrder
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.MarketingSourceChanged Property

INotificationServiceMarketingSourceChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IMarketingSource>> MarketingSourceChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IMarketingSource
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.NavigatingToPaymentScreen Property

INotificationServiceNavigatingToPaymentScreen Property

Navigating to the payment screen. Throwing OperationCanceledException will abort the operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IPointOfSale pos, IOperationService os, IViewManager vm, INavigatingToPaymentScreenOperationContext context)> NavigatingToPaymentScreen { get; }

Property Value

Type: INotification ValueTuple IOrder, IPointOfSale, IOperationService, IViewManager, INavigatingToPaymentScreenOperationContext
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderBillCancelled Property

INotificationServiceOrderBillCancelled Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IOrder> OrderBillCancelled { get; }

Property Value

Type: IObservable IOrder
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderChanged Property

INotificationServiceOrderChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IOrder>> OrderChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IOrder
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderEditBarcodeScanned Property

INotificationServiceOrderEditBarcodeScanned Property

Barcode scanning on the order edit screen. Handler should return true if the event is to be marked handled.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(string barcode, IOrder order, IOperationService os, IViewManager vm), bool> OrderEditBarcodeScanned { get; }

Property Value

Type: INotification ValueTuple String, IOrder, IOperationService, IViewManager , Boolean
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderEditCardSlided Property

INotificationServiceOrderEditCardSlided Property

Card slided on the order edit screen. Handler should return true if the event is to be marked handled.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(CardInputDialogResult card, IOrder order, IOperationService os, IViewManager vm), bool> OrderEditCardSlided { get; }

Property Value

Type: INotification ValueTuple CardInputDialogResult, IOrder, IOperationService, IViewManager , Boolean
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderSplittedByCashRegisters Property

INotificationServiceOrderSplittedByCashRegisters Property

Order splitted by cash registers, allows to track relationship between deleted source order and created new orders.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(Guid orderId, Guid[] )> OrderSplittedByCashRegisters { get; }

Property Value

Type: INotification ValueTuple Guid, Guid
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.OrderStorned Property

INotificationServiceOrderStorned Property

Order storned, allows to track relationship between deleted source and created new order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, Guid newOrderId)> OrderStorned { get; }

Property Value

Type: INotification ValueTuple IOrder, Guid
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.PaymentTypeChanged Property

INotificationServicePaymentTypeChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IPaymentType>> PaymentTypeChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IPaymentType
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.PreliminaryOrderChanged Property

INotificationServicePreliminaryOrderChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IPreliminaryOrder>> PreliminaryOrderChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IPreliminaryOrder
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.PriceCategoryChanged Property

INotificationServicePriceCategoryChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IPriceCategory>> PriceCategoryChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IPriceCategory
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductCategoryChanged Property

INotificationServiceProductCategoryChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IProductCategory>> ProductCategoryChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IProductCategory
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductChanged Property

INotificationServiceProductChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IProduct> ProductChanged { get; }

Property Value

Type: IObservable IProduct
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductGroupChanged Property

INotificationServiceProductGroupChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IProductGroup>> ProductGroupChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IProductGroup
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductScaleChanged Property

INotificationServiceProductScaleChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IProductScale>> ProductScaleChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IProductScale
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductSizeChanged Property

INotificationServiceProductSizeChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IProductSize>> ProductSizeChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IProductSize
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductsRemainingAmountsChanged Property

INotificationServiceProductsRemainingAmountsChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<VoidValue> ProductsRemainingAmountsChanged { get; }

Property Value

Type: IObservable VoidValue
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ProductStocksListChanged Property

INotificationServiceProductStocksListChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IProductStocksList>> ProductStocksListChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IProductStocksList
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.QuickMenuUpdated Property

INotificationServiceQuickMenuUpdated Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<VoidValue> QuickMenuUpdated { get; }

Property Value

Type: IObservable VoidValue
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.RegionChanged Property

INotificationServiceRegionChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IRegion>> RegionChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IRegion
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.RemovalTypeChanged Property

INotificationServiceRemovalTypeChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IRemovalType>> RemovalTypeChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IRemovalType
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ReserveChanged Property

INotificationServiceReserveChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IReserve>> ReserveChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IReserve
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.RestaurantChanged Property

INotificationServiceRestaurantChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IRestaurant> RestaurantChanged { get; }

Property Value

Type: IObservable IRestaurant
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.RestaurantSectionChanged Property

INotificationServiceRestaurantSectionChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IRestaurantSection>> RestaurantSectionChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IRestaurantSection
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.RoleChanged Property

INotificationServiceRoleChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IRole>> RoleChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IRole
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ScreenChanged Property

INotificationServiceScreenChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IScreen> ScreenChanged { get; }

Property Value

Type: IObservable IScreen
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.ServiceChequePrinted Property

INotificationServiceServiceChequePrinted Property

Service cheque printed.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INotification<(IOrder order, IOperationService os, IViewManager vm)> ServiceChequePrinted { get; }

Property Value

Type: INotification ValueTuple IOrder, IOperationService, IViewManager
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.StreetChanged Property

INotificationServiceStreetChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IStreet> StreetChanged { get; }

Property Value

Type: IObservable IStreet
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.TableChanged Property

INotificationServiceTableChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ITable>> TableChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ITable
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.TaxCategoryChanged Property

INotificationServiceTaxCategoryChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ITaxCategory>> TaxCategoryChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ITaxCategory
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.TerminalChanged Property

INotificationServiceTerminalChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<ITerminal>> TerminalChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs ITerminal
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.TerminalsGroupChanged Property

INotificationServiceTerminalsGroupChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<ITerminalsGroup> TerminalsGroupChanged { get; }

Property Value

Type: IObservable ITerminalsGroup
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.UserChanged Property

INotificationServiceUserChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<EntityChangedEventArgs<IUser>> UserChanged { get; }

Property Value

Type: IObservable EntityChangedEventArgs IUser
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


INotificationService.UserSessionChanged Property

INotificationServiceUserSessionChanged Property

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IObservable<IReadOnlyList<IUser>> UserSessionChanged { get; }

Property Value

Type: IObservable IReadOnlyList IUser
See Also

Reference

INotificationService Interface
Resto.Front.Api Namespace


IOperationService Interface

Provides a set of operations.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOperationService

The IOperationService type exposes the following members.

Methods
 | Name | Description
Public method | AddButtonToClosedOrderScreen | Adds a button to the closed order screen.
Public method | AddButtonToOrderEditScreen | Adds a button to plugins menu on the order edit screen.
Public method | AddButtonToPaymentScreen | Adds a button to the payment screen.
Public method | AddButtonToPluginsMenu | Adds a button to plugins menu on the additional operations screen.
Public method | AddButtonToProductsReturnScreen | Adds a button to “Other” menu on the products return screen. Button is shown only when returning products of a past order (Additional Operations -> Past Receipts -> Find past order by number -> Order Return -> Other).
Public method | AddClientToOrder | Returns true if client is bound to the order.
Public method | AddDonation | Adds new donation to order.
Public method | AddErrorMessage | Shows non-modal error message in the left top corner of the screen.
Public method | AddIikoCardReferrerToOrder | Bounds to the order iikoCard5 referrer by id.
Public method | AddNotificationMessage | Shows non-modal notification message in the left top corner of the screen.
Public method | AddStatusBarInfo | Shows text in iikoFront status bar.
Public method | AddToggleButtonToPaymentScreen | Adds a toggle button to the payment screen.
Public method | AddWarningMessage | Shows non-modal warning message in the left top corner of the screen.
Public method | AuthenticateByPin |
Public method | BillOrder | Changes the order to Bill status and returns text of bill cheque.
Public method | CalculateDeliveryTerminalWorkload | Returns terminal workload.
Public method | CallExternalOperation(Int32, String, String, Byte, ITerminal) | Calls an operation which is implemented in another plugin.
Public method | CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector) | Calls an operation which is implemented in another plugin.
Public method | CancelBill | Сhanges the order to the New status and prints the bill cancellation cheque.
Public method | CancelNewDelivery | Cancels new delivery.
Public method | CancelNewDeliveryAndHideItemsFromOlap | Cancels new delivery and hides delivery order items from OLAP reports.
Public method | CancelReserve | Cancels reservation due to some reason
Public method | CanProductBePaidWithPaymentType | Function describes if the product is compatible with payment type, i.e. payment type can be used to pay for the product.
Public method | ChangeDeliveryOpinion | Changes client's opinion on closed delivery.
Public method | ChangeKitchenOrderItemsProcessingStatus | Changes cooking status of the specified cooking items and modifiers.
Public method | ChangePreliminaryOrder | Changes preliminary order.
Public method | CheckCanEditOrder | If current user has permissions to view order.
Public method | CheckProductsSellingRestrictions | If current user can add these products with such amounts.
Public method | CloseCafeSession | Closes cafe session.
Public method | ClosePersonalSession | Closes personal session for the specified user or user defined by the credentials.
Public method | CreateDiscountCard | Creates a new discount card.
Public method | CreateEditSession | Creates an edit session. All changes made with this session will be accumulated without affecting entities. Use SubmitChanges(ICredentials, IEditSession) method to apply all changes or do nothing to discard them.
Public method | CreatePreliminaryOrder | Create new preliminary order.
Public method | DeleteDonation | Deletes existing donation from the order.
Public method | DeleteOrder | Deletes order. Order must have no printed items. User must have rights to edit orders.
Public method | DeleteOrderAndHideItemsFromOlap | Deletes order and hides order items from OLAP reports. Order must have no printed items, no payment items and no removed with writeoff items. User must have rights to edit orders.
Public method | DeletePreliminaryOrder | Deletes preliminary order
Public method | EnablePreliminaryOrdersScreen | Enable preliminary orders screen for iikoFront user.
Public method | ExecuteContinuousOperation(ActionIOperationService) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Public method | ExecuteContinuousOperationT(FuncIOperationService, T) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Public method | GetActivePaymentTypes | Returns active payment types bound to the specified processor.
Public method | GetActiveProducts |
Public method | GetActiveRemovalTypes | Gets removal types which are allowed to use.
Public method | GetActiveStreets | Obsolete. Gets active streets.
Public method | GetAllergenGroupsByOrderRootItem | Get list of allergen groups for OrderRootItem.
Public method | GetAllergenGroupsByProductIds | Get list of allergen groups for products.
Public method | GetAllProducts | Gets all products (both active and inactive).
Public method | GetAllStreets | Obsolete. Gets all streets (both active and inactive).
Public method | GetCafeSessionById | Returns cafeSession by id.
Public method | GetCafeSessions |
Public method | GetCashRegisterInfoById | Returns cashRegisterInfo by id.
Public method | GetCashRegisterInfos |
Public method | GetChangedDeliveryOrders |
Public method | GetChangedOrders |
Public method | GetChangedReserves |
Public method | GetChildGroupsByProductGroup | Returns childGroups of the specified productGroup.
Public method | GetChildProductsByProductGroup | Returns childProducts of the specified productGroup.
Public method | GetCities |
Public method | GetCityById | Returns city by id.
Public method | GetClientById | Returns client by id.
Public method | GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetCompoundItemTemplateById | Returns compoundItemTemplate by id.
Public method | GetCompoundItemTemplates |
Public method | GetConceptionById | Returns conception by id.
Public method | GetDeletedOrderTypes |
Public method | GetDeliveryCancelCauseById | Returns deliveryCancelCause by id.
Public method | GetDeliveryCancelCauses |
Public method | GetDeliveryOrderById | Returns deliveryOrder by id.
Public method | GetDeliveryOrders | Returns delivery orders.
Public method | GetDeliverySection | Returns section of current group where delivery orders are created. Is determined by default table of group.
Public method | GetDisabledSizesByProduct | Returns disabledSizes of the specified product.
Public method | GetDiscountCardById | Returns discountCard by id.
Public method | GetDiscountCards |
Public method | GetDiscountTypeById | Returns discountType by id.
Public method | GetDiscountTypes |
Public method | GetDonationTypesCompatibleWith | Gets donation types which are allowed to use with the order.
Public method | GetExternalOperations | Returns the list of all currently registered external operations with their service names and owner plugins' licensable module identifiers.
Public method | GetFrontDeliverySettings | Returns courier and self-service delivery duration time set on a delivery terminal.
Public method | GetGroupModifiers | Returns group modifiers of the specified product.
Public method | GetHierarchicalMenu |
Public method | GetHostAgentId |
Public method | GetHostDeliverySettings | Returns delivery settings of restaurant.
Public method | GetHostRestaurant |
Public method | GetHostTerminal | Returns local terminal, where the plugin is currently being executed.
Public method | GetHostTerminalPointsOfSale | Returns list of points of sale attached to local terminal. Empty list means that local terminal is not cash terminal.
Public method | GetHostTerminalSettings | Returns settings of the local terminal.
Public method | GetHostTerminalsGroup |
Public method | GetIncludedInMenuSectionsByProduct | Returns includedInMenuSections of the specified product.
Public method | GetKitchenOrderById | Returns kitchenOrder by id.
Public method | GetKitchenOrders |
Public method | GetMarketingSourceById | Returns marketingSource by id.
Public method | GetMarketingSources |
Public method | GetOrderAppliedDiscounts |
Public method | GetOrderById | Returns order by id.
Public method | GetOrderItemProductGroups | Returns product groups from the specified order. Products in each group are intended to be cooked together.
Public method | GetOrders | Returns orders list.
Public method | GetOrderTypeById | Returns orderType by id.
Public method | GetOrderTypes |
Public method | GetOrganizationFingerprint | Returns a fingerprint which can be used to identify an iikoRMS server instance.
Public method | GetPastOrder | Get closed order data from server, and returns it.
Public method | GetPaymentSystemName | Tries to return a string for matching the payment type to the payment system if it exists, elseway returns empty string.
Public method | GetPaymentTypeById | Returns paymentType by id.
Public method | GetPaymentTypes |
Public method | GetPaymentTypesToPayOutOnUser | Returns payment types that can be processed “silently”, without user interface.
Public method | GetPointOfSaleById | Returns pointOfSale by id.
Public method | GetPreliminaryOrderById | Returns preliminaryOrder by id or null if preliminaryOrder with specified id doesn't exist.
Public method | GetPreliminaryOrders | Get all preliminary orders.
Public method | GetPrice | Returns price for the product according to the given client price category.
Public method | GetPriceCategories |
Public method | GetPriceCategoryById | Returns priceCategory by id.
Public method | GetProductById | Returns product by id.
Public method | GetProductCategories |
Public method | GetProductCategoryById | Returns productCategory by id.
Public method | GetProductGroupById | Returns productGroup by id.
Public method | GetProductGroups |
Public method | GetProductScaleById | Returns productScale by id.
Public method | GetProductScales |
Public method | GetProductScaleSizes |
Public method | GetProductSizeById | Returns productSize by id.
Public method | GetProductSizes |
Public method | GetProductsRemainingAmounts | Gets remaining amounts of products in stop list.
Public method | GetProductStocksListById | Returns productStocksList by id.
Public method | GetProductStocksLists |
Public method | GetQuickMenu | Returns quick menu for specified restaurant section and day.
Public method | GetReceiptMarkup | Get reciept markup of the payment.
Public method | GetRegionById | Returns region by id.
Public method | GetRegions |
Public method | GetRelatedDeliveryOrders | Gets all deliveries that are related with argument through splitting between cash registers. Delivery itself is also returned. If delivery was not split, returns delivery passed as argument.
Public method | GetRemovalTypeById | Returns removalType by id.
Public method | GetReportMarkupById | Get report markup by id.
Public method | GetReportPrinter | Get instance of report printer
Public method | GetReserveById | Returns reserve by id.
Public method | GetReserves | Returns reserves or banquets in any ReserveStatus.
Public method | GetRoleById | Returns role by id.
Public method | GetRoles |
Public method | GetSimpleModifiers | Returns simple modifiers of the specified product.
Public method | GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetStreetById | Returns street by id.
Public method | GetSurveyItemById | Returns surveyItem by id.
Public method | GetSurveyItems |
Public method | GetTableById | Returns table by id.
Public method | GetTables |
Public method | GetTaxCategories |
Public method | GetTaxCategoryById | Returns taxCategory by id.
Public method | GetTemplatedModifiersParamsByProduct | Returns templatedModifiersParams of the specified product.
Public method | GetTerminalById | Returns terminal by id.
Public method | GetTerminals | Returns list of terminals in the restaurant.
Public method | GetTerminalsGroupPointsOfSale | Returns list of points of sale of the specified terminals group.
Public method | GetTerminalsGroupRestaurantSections | Returns list of restaurant sections of the specified terminals group.
Public method | GetTerminalsGroups | Returns list of terminals groups.
Public method | GetTerminalsGroupTerminals | Returns list of terminals attached to the specified terminals group.
Public method | GetTransportSettings | Returns iikoTransport settings.
Public method | GetUser | Get user corresponding to specified credentials.
Public method | GetUserById | Returns user by id.
Public method | GetUserRoles | Returns roles available for the user.
Public method | GetUsers |
Public method | IsActiveForDeliveries |
Public method | IsAllCafeSessionsClosed | Returns true if all cafe sessions of the local terminal are closed.
Public method | IsAllCafeSessionsOpen | Returns true if all cafe sessions of the local terminal are open.
Public method | IsDeliveryActive | Returns whether delivery is active.
Public method | IsDeliveryConfirmationActive | Returns whether delivery confirmation is active.
Public method | IsMultiCashRegisterConfiguration | Returns true if multi cash register configuration allowed.
Public method | IsOrderHasEInvoice | Returns whether eInvoice is active for order.
Public method | IsProductSellingRestricted | Checks remaining amount of the product and determines whether selling of that product is restricted.
Public method | NeedToSplitOrderBeforePayment | Checks if order should be splitted between cash registers before payment. Method also returns estimated point of sale for order if it can be determinated at the moment.
Public method | OpenCafeSession | Opens cafe session.
Public method | OpenPersonalSession | Opens personal session for the specified or defined by the credentials user using the specified role.
Public method | PayOrder | Pay order with included processed or “silent” payment items.
Public method | PayOrderAndPayOutOnUser | Pay order and pay out on user.
Public method | PrepareDeliveryForSending | Prepares delivery for sending by courier, switches DeliveryStatus from New to Waiting.
Public method | Print | Print document on specified printer.
Public method | PrintBanquet | Prints preliminary document with estimated event date and time, planned menu, guests count, client contacts, prepay info, etc.
Public method | PrintBillCheque | Changes the order to Bill status if it is not Bill and prints bill cheque.
Public method | PrintDeliveryBill | Prints delivery bill.
Public method | PrintOrderItems | Prints service cheque for defined order item products.
Public method | PrintReceiptCheque | Printing receipts to a printer.
Public method | PrintTableReservedCheque | Prints short “Table reserved” document with estimated event date and time, guests count and client contacts. Can be used to place onto reserved table as a hint not to occupy it.
Public method | ProcessPrepay | Processes existing payment item. Payment item should be processed externally or supports silent processing.
Public method | RegisterCashRegisterFactory | Registers cash register factory.
Public method | RegisterChequeTaskProcessor | Registers chequeTaskProcessor for extension the functionality of the cash register.
Public method | RegisterCustomRoundingHandler | Allows to provide custom order sum rounding implementation.
Public method | RegisterExternalCourierServicesProvider | Registers ecs provider.
Public method | RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Public method | RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Public method | RegisterPaymentSystem | Registers payment system.
Public method | RegisterScaleFactory | Registers scale factory.
Public method | RemoveOrderClient | Returns true if client is unbound of the order.
Public method | SearchClients | Search clients. The number of results is limited.
Public method | SearchDiscountCardByNumber | Searches a discount card by given card number.
Public method | SearchStreets | Searches streets and returns limited number of results.
Public method | SendDelivery | Sends the delivery.
Public method | SendHrsCardTransactionToServer | Sends guest data to the server.
Public method | SplitOrderBetweenCashRegisters | Split order between cash registers according to the current point of sale mapping.
Public method | StartCourseCooking | Starts cooking for all order item products of the specified course.
Public method | StartProductsCooking | Starts cooking for the specified order item products.
Public method | StartService | Starts the specified service.
Public method | StopService | Stops the specified service.
Public method | SubmitChanges | Applies all changes made with specified edit session.
Public method | TryEditCurrentOrder | Allows to show messages and make changes to the order that is currently opened on the order edit screen.
Public method | TryGetBillPrinter | Try get bill printer for specified restaurant section.
Public method | TryGetCafeSessionByCashRegister | Returns current open cafe session on cash register.
Public method | TryGetCafeSessionById | Returns cafeSession by id or null if cafeSession with specified id doesn't exist.
Public method | TryGetCashRegisterInfoById | Returns cashRegisterInfo by id or null if cashRegisterInfo with specified id doesn't exist.
Public method | TryGetChildGroupsByProductGroup | Returns childGroups of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetChildProductsByProductGroup | Returns childProducts of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetCityById | Returns city by id or null if city with specified id doesn't exist.
Public method | TryGetClientById | Returns client by id or null if client with specified id doesn't exist.
Public method | TryGetClientByPhone | Returns client by phone.
Public method | TryGetCompoundItemTemplateById | Returns compoundItemTemplate by id or null if compoundItemTemplate with specified id doesn't exist.
Public method | TryGetConceptionById | Returns conception by id or null if conception with specified id doesn't exist.
Public method | TryGetDeliveryCancelCauseById | Returns deliveryCancelCause by id or null if deliveryCancelCause with specified id doesn't exist.
Public method | TryGetDeliveryOrderById | Returns deliveryOrder by id or null if deliveryOrder with specified id doesn't exist.
Public method | TryGetDisabledSizesByProduct | Returns disabledSizes of the specified product or null if product doesn't exist.
Public method | TryGetDiscountCardById | Returns discountCard by id or null if discountCard with specified id doesn't exist.
Public method | TryGetDiscountTypeById | Returns discountType by id or null if discountType with specified id doesn't exist.
Public method | TryGetDocumentPrinter | Try get document printer for specified restaurant section.
Public method | TryGetIncludedInMenuSectionsByProduct | Returns includedInMenuSections of the specified product or null if product doesn't exist.
Public method | TryGetKitchenOrderById | Returns kitchenOrder by id or null if kitchenOrder with specified id doesn't exist.
Public method | TryGetLastChangedOrderTerminal | Returns termnal that changed order last time.
Public method | TryGetMarketingSourceById | Returns marketingSource by id or null if marketingSource with specified id doesn't exist.
Public method | TryGetOrderById | Returns order by id or null if order with specified id doesn't exist.
Public method | TryGetOrderExternalDataByKey |
Public method | TryGetOrderTypeById | Returns orderType by id or null if orderType with specified id doesn't exist.
Public method | TryGetParentByProduct | Returns parent of the specified product or null if product doesn't exist.
Public method | TryGetParentByProductGroup | Returns parent of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetPaymentTypeById | Returns paymentType by id or null if paymentType with specified id doesn't exist.
Public method | TryGetPointOfSaleById | Returns pointOfSale by id or null if pointOfSale with specified id doesn't exist.
Public method | TryGetPreliminaryOrderById | Returns preliminaryOrder by id.
Public method | TryGetPriceCategoryById | Returns priceCategory by id or null if priceCategory with specified id doesn't exist.
Public method | TryGetProductById | Returns product by id or null if product with specified id doesn't exist.
Public method | TryGetProductCategoryById | Returns productCategory by id or null if productCategory with specified id doesn't exist.
Public method | TryGetProductGroupById | Returns productGroup by id or null if productGroup with specified id doesn't exist.
Public method | TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
Public method | TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
Public method | TryGetProductScaleById | Returns productScale by id or null if productScale with specified id doesn't exist.
Public method | TryGetProductSizeById | Returns productSize by id or null if productSize with specified id doesn't exist.
Public method | TryGetProductStocksListById | Returns productStocksList by id or null if productStocksList with specified id doesn't exist.
Public method | TryGetReceiptChequePrinter | Try get receipt cheque printer for default cash register.
Public method | TryGetRegionById | Returns region by id or null if region with specified id doesn't exist.
Public method | TryGetRemovalTypeById | Returns removalType by id or null if removalType with specified id doesn't exist.
Public method | TryGetReserveByExternalId | Returns reserve by its external id or null if reserve with specified external id doesn't exist.
Public method | TryGetReserveById | Returns reserve by id or null if reserve with specified id doesn't exist.
Public method | TryGetRoleById | Returns role by id or null if role with specified id doesn't exist.
Public method | TryGetSectionSchemaByRestaurantSection | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.
Public method | TryGetSelectiveDiscountItemSettings | Returns order items to which the specified selective discount item is applied or null if the discount item is applied to the whole order.
Public method | TryGetStickerPrinter | Try get sticker printer for specified restaurant section.
Public method | TryGetStreetById | Returns street by id or null if street with specified id doesn't exist.
Public method | TryGetSurveyItemById | Returns surveyItem by id or null if surveyItem with specified id doesn't exist.
Public method | TryGetTableById | Returns table by id or null if table with specified id doesn't exist.
Public method | TryGetTaxCategoryById | Returns taxCategory by id or null if taxCategory with specified id doesn't exist.
Public method | TryGetTemplatedModifiersParamsByProduct | Returns templatedModifiersParams of the specified product or null if product doesn't exist.
Public method | TryGetTerminalById | Returns terminal by id or null if terminal with specified id doesn't exist.
Public method | TryGetUserById | Returns user by id or null if user with specified id doesn't exist.
Public method | UpdateDiscountCard | Updates an existing discount card.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | AddDiscountByCardNumber | Add discount by card number. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalFiscalizedPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new externally fiscalized payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalFiscalizedPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external fiscalized payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalPaymentItem(Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | AddFlexibleSumDiscountByCardNumber | Add discount by card number. (Defined by OperationServiceExtensions.)
Public Extension Method | AddIikoCardDiscounts | Adds discounts grouped by order items. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderCombo | Create order combo item. Order must contain new combo items. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(IOperationService, String, IOrder, ICredentials) to delete the data when it's no longer needed. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderGuest(String, IOrder, ICredentials) | Overloaded. Adds new guest to existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderGuest(Guid, String, IOrder, ICredentials) | Overloaded. Adds new guest with the given ID to existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the order item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item component in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the order item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item component in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderProductItem(Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Overloaded. Adds assortment position to the guest in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderProductItem(Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Overloaded. Adds assortment position to the guest in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPreliminaryPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Overloaded. Add new preliminary payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPreliminaryPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Overloaded. Add new preliminary payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientAddresses | Changes client addresses. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientBirthDate | Changes client's birth date. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientBlacklistInfo | Changes client blacklist info. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientCardNumber | Changes client card number. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientComment | Changes client comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientConsentDates | Changes client's dates of consent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientEmails | Changes client emails list. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientGender | Change client's gender. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientIikoBizId | Changes client's account in iiko.biz. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientLastOrderDate | Changes client's last order date. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientLinkedCounteragent | Changes client linked counter agent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientMainAddressIndex | Changes client main address index. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientMarketingSource | Changes client marketing source. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientName | Changes client name. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientNick | Changes client nickname. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientOrganizationDetailsInfo | Changes organization details information of client. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPhones | Changes client phones list. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientSurname | Changes client surname. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeComboAmount | Change combo amount. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeComboPrice | Change combo price. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeCookingPriority | Changes custom cooking priority and top priority flag. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryAddress | Changes address of delivery (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryClientName | Change name of delivery client. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryComment | Change the order comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryConfirmTime | Changes delivery confirmation state and time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryCustomApiData | Change the delivery custom data from api. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryDuration | Change duration of delivery processing. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryEmail | Change the order e-mail. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExternalCourier | Changes external courier for delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExternalCourierService | Changes external courier service for delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryLocation | Changes delivery address location. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryMarketingSource | Assign/change order marketing source. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryOperator | Assign/change the order operator. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryPhone | Changes the order phone. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryProblemComment | Change the order problem comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryProblemStatus | Change the order problem status. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemCourse | Changes the course of the order item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemSize | Changes the product size of the order item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderItemComment | Changes product order item's comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderItemWaiter | Changes product order item's waiter. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the product item modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the compound item common modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the compound component modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderTables | Changes tables of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderWaiter | Changes order's waiter. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePaymentItemCustomData | Changes custom data of existing payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePaymentItemSum | Changes sum of existing payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePriceCategory | Changes price category of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveComment | Changes reserve comment. Use empty string to clear comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveEstimatedStartTime | Changes estimated reserve start time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveReminder | Changes reserve reminder flag. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveTables | Changes reserving tables. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeStreetName | Changes street's name. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateBanquet(DateTime, IClient, IReadOnlyListITable, ICredentials, Guid) | Overloaded. Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateBanquet(DateTime, IClient, IOrder, ICredentials, Guid) | Overloaded. Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateClient | Creates new client. The client must have a card number or at least one phone number. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateStreet(String, ICredentials) | Overloaded. Creates new street. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateStreet(Guid, String, ICity, ICredentials) | Overloaded. Creates new street. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteExternalPaymentItem | Delete existing external payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderCombo | Delete order combo item. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderExternalData | Deletes external data from the order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderGuest | Deletes guest without any products from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderItemComment | Deletes product order item's comment. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrRestoreStreet | Deletes street. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePaymentItem | Delete existing payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group. (Defined by OperationServiceExtensions.)
Public Extension Method | MarkOrderAsTab | Marks the order as tab and assignes tab name. (Defined by OperationServiceExtensions.)
Public Extension Method | MoveOrderItemToAnotherGuest | Moves product item between guests of the same order. (Defined by OperationServiceExtensions.)
Public Extension Method | MoveOrderItemToAnotherOrder | Moves product item between orders. (Defined by OperationServiceExtensions.)
Public Extension Method | OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order. (Defined by OperationServiceExtensions.)
Public Extension Method | RenameOrderGuest | Renames order's guest. (Defined by OperationServiceExtensions.)
Public Extension Method | ReopenReserve | Reopens previously closed or canceled reserve. (Defined by OperationServiceExtensions.)
Public Extension Method | ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action. (Defined by OperationServiceExtensions.)
Public Extension Method | ResetPriceCategory | Resets price category of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ServeOrderCookingItem | Mark order item product as served. (Defined by OperationServiceExtensions.)
Public Extension Method | SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryDelivered | Change delivery status to delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryUndelivered | Change delivery status to OnWay from status delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOpenPrice | Changes order item open price. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the product item modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the compound item common modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the compound component modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderType | Sets order type for order. (Defined by OperationServiceExtensions.)
Public Extension Method | SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SplitOrderCookingItem | Cut off specified amount from product to new one. (Defined by OperationServiceExtensions.)
Public Extension Method | StartBanquet | Transits banquet to the started status. (Defined by OperationServiceExtensions.)
Public Extension Method | UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently. (Defined by OperationServiceExtensions.)
Public Extension Method | UnserveOrderCookingItem | Mark order item product as unserved. (Defined by OperationServiceExtensions.)
Public Extension Method | UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items. (Defined by OperationServiceExtensions.)
Top
Remarks
There is a global instance of the service which is available
See Also

Reference

Resto.Front.Api Namespace
PluginContextOperations


IOperationService Methods

The IOperationService type exposes the following members.

Methods
 | Name | Description
Public method | AddButtonToClosedOrderScreen | Adds a button to the closed order screen.
Public method | AddButtonToOrderEditScreen | Adds a button to plugins menu on the order edit screen.
Public method | AddButtonToPaymentScreen | Adds a button to the payment screen.
Public method | AddButtonToPluginsMenu | Adds a button to plugins menu on the additional operations screen.
Public method | AddButtonToProductsReturnScreen | Adds a button to “Other” menu on the products return screen. Button is shown only when returning products of a past order (Additional Operations -> Past Receipts -> Find past order by number -> Order Return -> Other).
Public method | AddClientToOrder | Returns true if client is bound to the order.
Public method | AddDonation | Adds new donation to order.
Public method | AddErrorMessage | Shows non-modal error message in the left top corner of the screen.
Public method | AddIikoCardReferrerToOrder | Bounds to the order iikoCard5 referrer by id.
Public method | AddNotificationMessage | Shows non-modal notification message in the left top corner of the screen.
Public method | AddStatusBarInfo | Shows text in iikoFront status bar.
Public method | AddToggleButtonToPaymentScreen | Adds a toggle button to the payment screen.
Public method | AddWarningMessage | Shows non-modal warning message in the left top corner of the screen.
Public method | AuthenticateByPin |
Public method | BillOrder | Changes the order to Bill status and returns text of bill cheque.
Public method | CalculateDeliveryTerminalWorkload | Returns terminal workload.
Public method | CallExternalOperation(Int32, String, String, Byte, ITerminal) | Calls an operation which is implemented in another plugin.
Public method | CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector) | Calls an operation which is implemented in another plugin.
Public method | CancelBill | Сhanges the order to the New status and prints the bill cancellation cheque.
Public method | CancelNewDelivery | Cancels new delivery.
Public method | CancelNewDeliveryAndHideItemsFromOlap | Cancels new delivery and hides delivery order items from OLAP reports.
Public method | CancelReserve | Cancels reservation due to some reason
Public method | CanProductBePaidWithPaymentType | Function describes if the product is compatible with payment type, i.e. payment type can be used to pay for the product.
Public method | ChangeDeliveryOpinion | Changes client's opinion on closed delivery.
Public method | ChangeKitchenOrderItemsProcessingStatus | Changes cooking status of the specified cooking items and modifiers.
Public method | ChangePreliminaryOrder | Changes preliminary order.
Public method | CheckCanEditOrder | If current user has permissions to view order.
Public method | CheckProductsSellingRestrictions | If current user can add these products with such amounts.
Public method | CloseCafeSession | Closes cafe session.
Public method | ClosePersonalSession | Closes personal session for the specified user or user defined by the credentials.
Public method | CreateDiscountCard | Creates a new discount card.
Public method | CreateEditSession | Creates an edit session. All changes made with this session will be accumulated without affecting entities. Use SubmitChanges(ICredentials, IEditSession) method to apply all changes or do nothing to discard them.
Public method | CreatePreliminaryOrder | Create new preliminary order.
Public method | DeleteDonation | Deletes existing donation from the order.
Public method | DeleteOrder | Deletes order. Order must have no printed items. User must have rights to edit orders.
Public method | DeleteOrderAndHideItemsFromOlap | Deletes order and hides order items from OLAP reports. Order must have no printed items, no payment items and no removed with writeoff items. User must have rights to edit orders.
Public method | DeletePreliminaryOrder | Deletes preliminary order
Public method | EnablePreliminaryOrdersScreen | Enable preliminary orders screen for iikoFront user.
Public method | ExecuteContinuousOperation(ActionIOperationService) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Public method | ExecuteContinuousOperationT(FuncIOperationService, T) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Public method | GetActivePaymentTypes | Returns active payment types bound to the specified processor.
Public method | GetActiveProducts |
Public method | GetActiveRemovalTypes | Gets removal types which are allowed to use.
Public method | GetActiveStreets | Obsolete. Gets active streets.
Public method | GetAllergenGroupsByOrderRootItem | Get list of allergen groups for OrderRootItem.
Public method | GetAllergenGroupsByProductIds | Get list of allergen groups for products.
Public method | GetAllProducts | Gets all products (both active and inactive).
Public method | GetAllStreets | Obsolete. Gets all streets (both active and inactive).
Public method | GetCafeSessionById | Returns cafeSession by id.
Public method | GetCafeSessions |
Public method | GetCashRegisterInfoById | Returns cashRegisterInfo by id.
Public method | GetCashRegisterInfos |
Public method | GetChangedDeliveryOrders |
Public method | GetChangedOrders |
Public method | GetChangedReserves |
Public method | GetChildGroupsByProductGroup | Returns childGroups of the specified productGroup.
Public method | GetChildProductsByProductGroup | Returns childProducts of the specified productGroup.
Public method | GetCities |
Public method | GetCityById | Returns city by id.
Public method | GetClientById | Returns client by id.
Public method | GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetCompoundItemTemplateById | Returns compoundItemTemplate by id.
Public method | GetCompoundItemTemplates |
Public method | GetConceptionById | Returns conception by id.
Public method | GetDeletedOrderTypes |
Public method | GetDeliveryCancelCauseById | Returns deliveryCancelCause by id.
Public method | GetDeliveryCancelCauses |
Public method | GetDeliveryOrderById | Returns deliveryOrder by id.
Public method | GetDeliveryOrders | Returns delivery orders.
Public method | GetDeliverySection | Returns section of current group where delivery orders are created. Is determined by default table of group.
Public method | GetDisabledSizesByProduct | Returns disabledSizes of the specified product.
Public method | GetDiscountCardById | Returns discountCard by id.
Public method | GetDiscountCards |
Public method | GetDiscountTypeById | Returns discountType by id.
Public method | GetDiscountTypes |
Public method | GetDonationTypesCompatibleWith | Gets donation types which are allowed to use with the order.
Public method | GetExternalOperations | Returns the list of all currently registered external operations with their service names and owner plugins' licensable module identifiers.
Public method | GetFrontDeliverySettings | Returns courier and self-service delivery duration time set on a delivery terminal.
Public method | GetGroupModifiers | Returns group modifiers of the specified product.
Public method | GetHierarchicalMenu |
Public method | GetHostAgentId |
Public method | GetHostDeliverySettings | Returns delivery settings of restaurant.
Public method | GetHostRestaurant |
Public method | GetHostTerminal | Returns local terminal, where the plugin is currently being executed.
Public method | GetHostTerminalPointsOfSale | Returns list of points of sale attached to local terminal. Empty list means that local terminal is not cash terminal.
Public method | GetHostTerminalSettings | Returns settings of the local terminal.
Public method | GetHostTerminalsGroup |
Public method | GetIncludedInMenuSectionsByProduct | Returns includedInMenuSections of the specified product.
Public method | GetKitchenOrderById | Returns kitchenOrder by id.
Public method | GetKitchenOrders |
Public method | GetMarketingSourceById | Returns marketingSource by id.
Public method | GetMarketingSources |
Public method | GetOrderAppliedDiscounts |
Public method | GetOrderById | Returns order by id.
Public method | GetOrderItemProductGroups | Returns product groups from the specified order. Products in each group are intended to be cooked together.
Public method | GetOrders | Returns orders list.
Public method | GetOrderTypeById | Returns orderType by id.
Public method | GetOrderTypes |
Public method | GetOrganizationFingerprint | Returns a fingerprint which can be used to identify an iikoRMS server instance.
Public method | GetPastOrder | Get closed order data from server, and returns it.
Public method | GetPaymentSystemName | Tries to return a string for matching the payment type to the payment system if it exists, elseway returns empty string.
Public method | GetPaymentTypeById | Returns paymentType by id.
Public method | GetPaymentTypes |
Public method | GetPaymentTypesToPayOutOnUser | Returns payment types that can be processed “silently”, without user interface.
Public method | GetPointOfSaleById | Returns pointOfSale by id.
Public method | GetPreliminaryOrderById | Returns preliminaryOrder by id or null if preliminaryOrder with specified id doesn't exist.
Public method | GetPreliminaryOrders | Get all preliminary orders.
Public method | GetPrice | Returns price for the product according to the given client price category.
Public method | GetPriceCategories |
Public method | GetPriceCategoryById | Returns priceCategory by id.
Public method | GetProductById | Returns product by id.
Public method | GetProductCategories |
Public method | GetProductCategoryById | Returns productCategory by id.
Public method | GetProductGroupById | Returns productGroup by id.
Public method | GetProductGroups |
Public method | GetProductScaleById | Returns productScale by id.
Public method | GetProductScales |
Public method | GetProductScaleSizes |
Public method | GetProductSizeById | Returns productSize by id.
Public method | GetProductSizes |
Public method | GetProductsRemainingAmounts | Gets remaining amounts of products in stop list.
Public method | GetProductStocksListById | Returns productStocksList by id.
Public method | GetProductStocksLists |
Public method | GetQuickMenu | Returns quick menu for specified restaurant section and day.
Public method | GetReceiptMarkup | Get reciept markup of the payment.
Public method | GetRegionById | Returns region by id.
Public method | GetRegions |
Public method | GetRelatedDeliveryOrders | Gets all deliveries that are related with argument through splitting between cash registers. Delivery itself is also returned. If delivery was not split, returns delivery passed as argument.
Public method | GetRemovalTypeById | Returns removalType by id.
Public method | GetReportMarkupById | Get report markup by id.
Public method | GetReportPrinter | Get instance of report printer
Public method | GetReserveById | Returns reserve by id.
Public method | GetReserves | Returns reserves or banquets in any ReserveStatus.
Public method | GetRoleById | Returns role by id.
Public method | GetRoles |
Public method | GetSimpleModifiers | Returns simple modifiers of the specified product.
Public method | GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
Public method | GetStreetById | Returns street by id.
Public method | GetSurveyItemById | Returns surveyItem by id.
Public method | GetSurveyItems |
Public method | GetTableById | Returns table by id.
Public method | GetTables |
Public method | GetTaxCategories |
Public method | GetTaxCategoryById | Returns taxCategory by id.
Public method | GetTemplatedModifiersParamsByProduct | Returns templatedModifiersParams of the specified product.
Public method | GetTerminalById | Returns terminal by id.
Public method | GetTerminals | Returns list of terminals in the restaurant.
Public method | GetTerminalsGroupPointsOfSale | Returns list of points of sale of the specified terminals group.
Public method | GetTerminalsGroupRestaurantSections | Returns list of restaurant sections of the specified terminals group.
Public method | GetTerminalsGroups | Returns list of terminals groups.
Public method | GetTerminalsGroupTerminals | Returns list of terminals attached to the specified terminals group.
Public method | GetTransportSettings | Returns iikoTransport settings.
Public method | GetUser | Get user corresponding to specified credentials.
Public method | GetUserById | Returns user by id.
Public method | GetUserRoles | Returns roles available for the user.
Public method | GetUsers |
Public method | IsActiveForDeliveries |
Public method | IsAllCafeSessionsClosed | Returns true if all cafe sessions of the local terminal are closed.
Public method | IsAllCafeSessionsOpen | Returns true if all cafe sessions of the local terminal are open.
Public method | IsDeliveryActive | Returns whether delivery is active.
Public method | IsDeliveryConfirmationActive | Returns whether delivery confirmation is active.
Public method | IsMultiCashRegisterConfiguration | Returns true if multi cash register configuration allowed.
Public method | IsOrderHasEInvoice | Returns whether eInvoice is active for order.
Public method | IsProductSellingRestricted | Checks remaining amount of the product and determines whether selling of that product is restricted.
Public method | NeedToSplitOrderBeforePayment | Checks if order should be splitted between cash registers before payment. Method also returns estimated point of sale for order if it can be determinated at the moment.
Public method | OpenCafeSession | Opens cafe session.
Public method | OpenPersonalSession | Opens personal session for the specified or defined by the credentials user using the specified role.
Public method | PayOrder | Pay order with included processed or “silent” payment items.
Public method | PayOrderAndPayOutOnUser | Pay order and pay out on user.
Public method | PrepareDeliveryForSending | Prepares delivery for sending by courier, switches DeliveryStatus from New to Waiting.
Public method | Print | Print document on specified printer.
Public method | PrintBanquet | Prints preliminary document with estimated event date and time, planned menu, guests count, client contacts, prepay info, etc.
Public method | PrintBillCheque | Changes the order to Bill status if it is not Bill and prints bill cheque.
Public method | PrintDeliveryBill | Prints delivery bill.
Public method | PrintOrderItems | Prints service cheque for defined order item products.
Public method | PrintReceiptCheque | Printing receipts to a printer.
Public method | PrintTableReservedCheque | Prints short “Table reserved” document with estimated event date and time, guests count and client contacts. Can be used to place onto reserved table as a hint not to occupy it.
Public method | ProcessPrepay | Processes existing payment item. Payment item should be processed externally or supports silent processing.
Public method | RegisterCashRegisterFactory | Registers cash register factory.
Public method | RegisterChequeTaskProcessor | Registers chequeTaskProcessor for extension the functionality of the cash register.
Public method | RegisterCustomRoundingHandler | Allows to provide custom order sum rounding implementation.
Public method | RegisterExternalCourierServicesProvider | Registers ecs provider.
Public method | RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Public method | RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Public method | RegisterPaymentSystem | Registers payment system.
Public method | RegisterScaleFactory | Registers scale factory.
Public method | RemoveOrderClient | Returns true if client is unbound of the order.
Public method | SearchClients | Search clients. The number of results is limited.
Public method | SearchDiscountCardByNumber | Searches a discount card by given card number.
Public method | SearchStreets | Searches streets and returns limited number of results.
Public method | SendDelivery | Sends the delivery.
Public method | SendHrsCardTransactionToServer | Sends guest data to the server.
Public method | SplitOrderBetweenCashRegisters | Split order between cash registers according to the current point of sale mapping.
Public method | StartCourseCooking | Starts cooking for all order item products of the specified course.
Public method | StartProductsCooking | Starts cooking for the specified order item products.
Public method | StartService | Starts the specified service.
Public method | StopService | Stops the specified service.
Public method | SubmitChanges | Applies all changes made with specified edit session.
Public method | TryEditCurrentOrder | Allows to show messages and make changes to the order that is currently opened on the order edit screen.
Public method | TryGetBillPrinter | Try get bill printer for specified restaurant section.
Public method | TryGetCafeSessionByCashRegister | Returns current open cafe session on cash register.
Public method | TryGetCafeSessionById | Returns cafeSession by id or null if cafeSession with specified id doesn't exist.
Public method | TryGetCashRegisterInfoById | Returns cashRegisterInfo by id or null if cashRegisterInfo with specified id doesn't exist.
Public method | TryGetChildGroupsByProductGroup | Returns childGroups of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetChildProductsByProductGroup | Returns childProducts of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetCityById | Returns city by id or null if city with specified id doesn't exist.
Public method | TryGetClientById | Returns client by id or null if client with specified id doesn't exist.
Public method | TryGetClientByPhone | Returns client by phone.
Public method | TryGetCompoundItemTemplateById | Returns compoundItemTemplate by id or null if compoundItemTemplate with specified id doesn't exist.
Public method | TryGetConceptionById | Returns conception by id or null if conception with specified id doesn't exist.
Public method | TryGetDeliveryCancelCauseById | Returns deliveryCancelCause by id or null if deliveryCancelCause with specified id doesn't exist.
Public method | TryGetDeliveryOrderById | Returns deliveryOrder by id or null if deliveryOrder with specified id doesn't exist.
Public method | TryGetDisabledSizesByProduct | Returns disabledSizes of the specified product or null if product doesn't exist.
Public method | TryGetDiscountCardById | Returns discountCard by id or null if discountCard with specified id doesn't exist.
Public method | TryGetDiscountTypeById | Returns discountType by id or null if discountType with specified id doesn't exist.
Public method | TryGetDocumentPrinter | Try get document printer for specified restaurant section.
Public method | TryGetIncludedInMenuSectionsByProduct | Returns includedInMenuSections of the specified product or null if product doesn't exist.
Public method | TryGetKitchenOrderById | Returns kitchenOrder by id or null if kitchenOrder with specified id doesn't exist.
Public method | TryGetLastChangedOrderTerminal | Returns termnal that changed order last time.
Public method | TryGetMarketingSourceById | Returns marketingSource by id or null if marketingSource with specified id doesn't exist.
Public method | TryGetOrderById | Returns order by id or null if order with specified id doesn't exist.
Public method | TryGetOrderExternalDataByKey |
Public method | TryGetOrderTypeById | Returns orderType by id or null if orderType with specified id doesn't exist.
Public method | TryGetParentByProduct | Returns parent of the specified product or null if product doesn't exist.
Public method | TryGetParentByProductGroup | Returns parent of the specified productGroup or null if productGroup doesn't exist.
Public method | TryGetPaymentTypeById | Returns paymentType by id or null if paymentType with specified id doesn't exist.
Public method | TryGetPointOfSaleById | Returns pointOfSale by id or null if pointOfSale with specified id doesn't exist.
Public method | TryGetPreliminaryOrderById | Returns preliminaryOrder by id.
Public method | TryGetPriceCategoryById | Returns priceCategory by id or null if priceCategory with specified id doesn't exist.
Public method | TryGetProductById | Returns product by id or null if product with specified id doesn't exist.
Public method | TryGetProductCategoryById | Returns productCategory by id or null if productCategory with specified id doesn't exist.
Public method | TryGetProductGroupById | Returns productGroup by id or null if productGroup with specified id doesn't exist.
Public method | TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
Public method | TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
Public method | TryGetProductScaleById | Returns productScale by id or null if productScale with specified id doesn't exist.
Public method | TryGetProductSizeById | Returns productSize by id or null if productSize with specified id doesn't exist.
Public method | TryGetProductStocksListById | Returns productStocksList by id or null if productStocksList with specified id doesn't exist.
Public method | TryGetReceiptChequePrinter | Try get receipt cheque printer for default cash register.
Public method | TryGetRegionById | Returns region by id or null if region with specified id doesn't exist.
Public method | TryGetRemovalTypeById | Returns removalType by id or null if removalType with specified id doesn't exist.
Public method | TryGetReserveByExternalId | Returns reserve by its external id or null if reserve with specified external id doesn't exist.
Public method | TryGetReserveById | Returns reserve by id or null if reserve with specified id doesn't exist.
Public method | TryGetRoleById | Returns role by id or null if role with specified id doesn't exist.
Public method | TryGetSectionSchemaByRestaurantSection | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.
Public method | TryGetSelectiveDiscountItemSettings | Returns order items to which the specified selective discount item is applied or null if the discount item is applied to the whole order.
Public method | TryGetStickerPrinter | Try get sticker printer for specified restaurant section.
Public method | TryGetStreetById | Returns street by id or null if street with specified id doesn't exist.
Public method | TryGetSurveyItemById | Returns surveyItem by id or null if surveyItem with specified id doesn't exist.
Public method | TryGetTableById | Returns table by id or null if table with specified id doesn't exist.
Public method | TryGetTaxCategoryById | Returns taxCategory by id or null if taxCategory with specified id doesn't exist.
Public method | TryGetTemplatedModifiersParamsByProduct | Returns templatedModifiersParams of the specified product or null if product doesn't exist.
Public method | TryGetTerminalById | Returns terminal by id or null if terminal with specified id doesn't exist.
Public method | TryGetUserById | Returns user by id or null if user with specified id doesn't exist.
Public method | UpdateDiscountCard | Updates an existing discount card.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | AddDiscountByCardNumber | Add discount by card number. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalFiscalizedPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new externally fiscalized payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalFiscalizedPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external fiscalized payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddExternalPaymentItem(Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Overloaded. Add new external payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | AddFlexibleSumDiscountByCardNumber | Add discount by card number. (Defined by OperationServiceExtensions.)
Public Extension Method | AddIikoCardDiscounts | Adds discounts grouped by order items. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderCombo | Create order combo item. Order must contain new combo items. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(IOperationService, String, IOrder, ICredentials) to delete the data when it's no longer needed. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderGuest(String, IOrder, ICredentials) | Overloaded. Adds new guest to existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderGuest(Guid, String, IOrder, ICredentials) | Overloaded. Adds new guest with the given ID to existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the order item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item component in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the order item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Overloaded. Adds order item modifier to the compound item component in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderProductItem(Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Overloaded. Adds assortment position to the guest in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderProductItem(Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Overloaded. Adds assortment position to the guest in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Overloaded. Add new payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPreliminaryPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Overloaded. Add new preliminary payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | AddPreliminaryPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Overloaded. Add new preliminary payment item to order. (Defined by OperationServiceExtensions.)
Public Extension Method | BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientAddresses | Changes client addresses. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientBirthDate | Changes client's birth date. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientBlacklistInfo | Changes client blacklist info. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientCardNumber | Changes client card number. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientComment | Changes client comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientConsentDates | Changes client's dates of consent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientEmails | Changes client emails list. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientGender | Change client's gender. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientIikoBizId | Changes client's account in iiko.biz. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientLastOrderDate | Changes client's last order date. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientLinkedCounteragent | Changes client linked counter agent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientMainAddressIndex | Changes client main address index. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientMarketingSource | Changes client marketing source. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientName | Changes client name. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientNick | Changes client nickname. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientOrganizationDetailsInfo | Changes organization details information of client. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientPhones | Changes client phones list. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeClientSurname | Changes client surname. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeComboAmount | Change combo amount. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeComboPrice | Change combo price. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeCookingPriority | Changes custom cooking priority and top priority flag. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryAddress | Changes address of delivery (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryClientName | Change name of delivery client. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryComment | Change the order comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryConfirmTime | Changes delivery confirmation state and time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryCustomApiData | Change the delivery custom data from api. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryDuration | Change duration of delivery processing. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryEmail | Change the order e-mail. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExternalCourier | Changes external courier for delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryExternalCourierService | Changes external courier service for delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryLocation | Changes delivery address location. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryMarketingSource | Assign/change order marketing source. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryOperator | Assign/change the order operator. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryPhone | Changes the order phone. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryProblemComment | Change the order problem comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliveryProblemStatus | Change the order problem status. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemCourse | Changes the course of the order item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderCookingItemSize | Changes the product size of the order item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderItemComment | Changes product order item's comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderItemWaiter | Changes product order item's waiter. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the product item modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the compound item common modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderModifierItemAmount(Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32) | Overloaded. Changes the amount of the compound component modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderTables | Changes tables of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeOrderWaiter | Changes order's waiter. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePaymentItemCustomData | Changes custom data of existing payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePaymentItemSum | Changes sum of existing payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangePriceCategory | Changes price category of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveComment | Changes reserve comment. Use empty string to clear comment. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveEstimatedStartTime | Changes estimated reserve start time. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveReminder | Changes reserve reminder flag. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeReserveTables | Changes reserving tables. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application. (Defined by OperationServiceExtensions.)
Public Extension Method | ChangeStreetName | Changes street's name. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateBanquet(DateTime, IClient, IReadOnlyListITable, ICredentials, Guid) | Overloaded. Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateBanquet(DateTime, IClient, IOrder, ICredentials, Guid) | Overloaded. Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateClient | Creates new client. The client must have a card number or at least one phone number. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateStreet(String, ICredentials) | Overloaded. Creates new street. (Defined by OperationServiceExtensions.)
Public Extension Method | CreateStreet(Guid, String, ICity, ICredentials) | Overloaded. Creates new street. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteExternalPaymentItem | Delete existing external payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderCombo | Delete order combo item. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderExternalData | Deletes external data from the order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderGuest | Deletes guest without any products from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderItemComment | Deletes product order item's comment. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrderModifierItem(IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Overloaded. Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeleteOrRestoreStreet | Deletes street. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePaymentItem | Delete existing payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group. (Defined by OperationServiceExtensions.)
Public Extension Method | MarkOrderAsTab | Marks the order as tab and assignes tab name. (Defined by OperationServiceExtensions.)
Public Extension Method | MoveOrderItemToAnotherGuest | Moves product item between guests of the same order. (Defined by OperationServiceExtensions.)
Public Extension Method | MoveOrderItemToAnotherOrder | Moves product item between orders. (Defined by OperationServiceExtensions.)
Public Extension Method | OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order. (Defined by OperationServiceExtensions.)
Public Extension Method | RenameOrderGuest | Renames order's guest. (Defined by OperationServiceExtensions.)
Public Extension Method | ReopenReserve | Reopens previously closed or canceled reserve. (Defined by OperationServiceExtensions.)
Public Extension Method | ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action. (Defined by OperationServiceExtensions.)
Public Extension Method | ResetPriceCategory | Resets price category of the order. (Defined by OperationServiceExtensions.)
Public Extension Method | ServeOrderCookingItem | Mark order item product as served. (Defined by OperationServiceExtensions.)
Public Extension Method | SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryDelivered | Change delivery status to delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | SetDeliveryUndelivered | Change delivery status to OnWay from status delivered. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOpenPrice | Changes order item open price. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the product item modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the compound item common modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderModifierItemCustomName(String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Overloaded. Sets the custom name of the compound component modifier. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetOrderType | Sets order type for order. (Defined by OperationServiceExtensions.)
Public Extension Method | SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders. (Defined by OperationServiceExtensions.)
Public Extension Method | SplitOrderCookingItem | Cut off specified amount from product to new one. (Defined by OperationServiceExtensions.)
Public Extension Method | StartBanquet | Transits banquet to the started status. (Defined by OperationServiceExtensions.)
Public Extension Method | UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently. (Defined by OperationServiceExtensions.)
Public Extension Method | UnserveOrderCookingItem | Mark order item product as unserved. (Defined by OperationServiceExtensions.)
Public Extension Method | UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items. (Defined by OperationServiceExtensions.)
Top
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddButtonToClosedOrderScreen Method

IOperationServiceAddButtonToClosedOrderScreen Method

Adds a button to the closed order screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddButtonToClosedOrderScreen(
    string caption,
    Action<(IViewManager vm, IOrder closedOrder, ICashRegisterInfo cashRegister)> callback,
    string iconGeometry = null
)

Parameters

caption
Type: SystemString
Text to display on the button
callback
Type: SystemAction ValueTuple IViewManager, IOrder, ICashRegisterInfo
Button click event handler.
iconGeometry (Optional)
Type: SystemString
Path geometry to show icon on the button. Path markup syntax is described here: https://docs.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/path-markup-syntax?view=netframeworkdesktop-4.8

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddButtonToOrderEditScreen Method

IOperationServiceAddButtonToOrderEditScreen Method

Adds a button to plugins menu on the order edit screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddButtonToOrderEditScreen(
    string caption,
    Action<(IOrder order, IOperationService os, IViewManager vm)> callback,
    string iconGeometry = null
)

Parameters

caption
Type: SystemString
Text to display on the button
callback
Type: SystemAction ValueTuple IOrder, IOperationService, IViewManager
Button click event handler.
iconGeometry (Optional)
Type: SystemString
Path geometry to show icon on the button. Path markup syntax is described here: https://docs.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/path-markup-syntax?view=netframeworkdesktop-4.8

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddButtonToPaymentScreen Method

IOperationServiceAddButtonToPaymentScreen Method

Adds a button to the payment screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddButtonToPaymentScreen(
    string caption,
    Action<(IOrder order, IOperationService os, IViewManager vm)> callback,
    string iconGeometry = null
)

Parameters

caption
Type: SystemString
Text to display on the button
callback
Type: SystemAction ValueTuple IOrder, IOperationService, IViewManager
Button click event handler.
iconGeometry (Optional)
Type: SystemString
Path geometry to show icon on the button. Path markup syntax is described here: https://docs.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/path-markup-syntax?view=netframeworkdesktop-4.8

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddButtonToPluginsMenu Method

IOperationServiceAddButtonToPluginsMenu Method

Adds a button to plugins menu on the additional operations screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddButtonToPluginsMenu(
    string caption,
    Action<(IViewManager vm, IReceiptPrinter printer)> callback
)

Parameters

caption
Type: SystemString
Text to display on the button
callback
Type: SystemAction ValueTuple IViewManager, IReceiptPrinter
Button click event handler.

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddButtonToProductsReturnScreen Method

IOperationServiceAddButtonToProductsReturnScreen Method

Adds a button to “Other” menu on the products return screen. Button is shown only when returning products of a past order (Additional Operations -> Past Receipts -> Find past order by number -> Order Return -> Other).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddButtonToProductsReturnScreen(
    string caption,
    Action<(IViewManager vm, Guid pastOrderId, ICashRegisterInfo cashRegister)> callback
)

Parameters

caption
Type: SystemString
Text to display on the button
callback
Type: SystemAction ValueTuple IViewManager, Guid, ICashRegisterInfo
Button click event handler.

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddClientToOrder Method

IOperationServiceAddClientToOrder Method

Returns true if client is bound to the order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AddClientToOrder(
    ICredentials credentials,
    IOrder order,
    IClient client
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to bind the client.
client
Type: Resto.Front.Api.Data.BrdIClient
The client will be bound to the order.

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddDonation Method

IOperationServiceAddDonation Method

Adds new donation to order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentItem AddDonation(
    ICredentials credentials,
    IOrder order,
    IDonationType donationType,
    IPaymentType paymentType,
    IPaymentItemAdditionalData additionalData,
    bool isProcessed,
    decimal donationSum
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order whose donation will be added.
donationType
Type: Resto.Front.Api.Data.PaymentsIDonationType
Type of donation that will be added.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Underlying payment type of the donation to be added. paymentType must be one of PaymentTypes.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a donation, or null if payment type doesn't require additional data for donation initialization.
isProcessed
Type: SystemBoolean
Whether donation was already processed by some external system.
donationSum
Type: SystemDecimal
Sum of donation that will be added.

Return Value

Type: IPaymentItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddErrorMessage Method

IOperationServiceAddErrorMessage Method

Shows non-modal error message in the left top corner of the screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddErrorMessage(
    string message,
    string sender,
    TimeSpan? timeout = null
)

Parameters

message
Type: SystemString
The message text.
sender
Type: SystemString
The message sender.
timeout (Optional)
Type: SystemNullable TimeSpan
The message display timeout. If null, message will be shown until user manually closes it, else message will be automatically closed after the specified amount of time.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddIikoCardReferrerToOrder Method

IOperationServiceAddIikoCardReferrerToOrder Method

Bounds to the order iikoCard5 referrer by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddIikoCardReferrerToOrder(
    IOrder order,
    Guid referrerId
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to bind the iikoCard referrer.
referrerId
Type: SystemGuid
The referrer Id will be bound to the order.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddNotificationMessage Method

IOperationServiceAddNotificationMessage Method

Shows non-modal notification message in the left top corner of the screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddNotificationMessage(
    string message,
    string sender,
    TimeSpan? timeout = null
)

Parameters

message
Type: SystemString
The message text.
sender
Type: SystemString
The message sender.
timeout (Optional)
Type: SystemNullable TimeSpan
The message display timeout. If null, message will be shown until user manually closes it, else message will be automatically closed after the specified amount of time.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddStatusBarInfo Method

IOperationServiceAddStatusBarInfo Method

Shows text in iikoFront status bar.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddStatusBarInfo(
    string text,
    bool isError = false,
    byte rank = 255,
    double widthRate = 1
)

Parameters

text
Type: SystemString
Text to be shown in iikoFront status bar. Text is limited to 255 symbols, everything over the limit will be cut.
isError (Optional)
Type: SystemBoolean
Whether the status bar item describes an error. Error message will be shown in red with an error icon.
rank (Optional)
Type: SystemByte
Higher rank means created status bar item is to be placed on right side of lesser ranked items, items on right side may be shortened if lack of free space.
widthRate (Optional)
Type: SystemDouble
Means the size in relation to other status bar items.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddToggleButtonToPaymentScreen Method

IOperationServiceAddToggleButtonToPaymentScreen Method

Adds a toggle button to the payment screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable AddToggleButtonToPaymentScreen(
    Func<IOrder, ToggleButtonState> getStateCallback,
    Func<(IOrder order, IOperationService os, IViewManager vm, ToggleButtonState state), ToggleButtonState> callback
)

Parameters

getStateCallback
Type: SystemFunc IOrder, ToggleButtonState
Toggle button get current state event handler.
callback
Type: SystemFunc ValueTuple IOrder, IOperationService, IViewManager, ToggleButtonState , ToggleButtonState
Toggle button change state event handler. Use method's return value to update the button's state

Return Value

Type: IDisposable
Remarks
Use method's return value to remove the button or it will be automatically removed when plugin is unloaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AddWarningMessage Method

IOperationServiceAddWarningMessage Method

Shows non-modal warning message in the left top corner of the screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddWarningMessage(
    string message,
    string sender,
    TimeSpan? timeout = null
)

Parameters

message
Type: SystemString
The message text.
sender
Type: SystemString
The message sender.
timeout (Optional)
Type: SystemNullable TimeSpan
The message display timeout. If null, message will be shown until user manually closes it, else message will be automatically closed after the specified amount of time.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.AuthenticateByPin Method

IOperationServiceAuthenticateByPin Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICredentials AuthenticateByPin(
    string pin
)

Parameters

pin
Type: SystemString

Return Value

Type: ICredentials
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.BillOrder Method

IOperationServiceBillOrder Method

Changes the order to Bill status and returns text of bill cheque.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string BillOrder(
    ICredentials credentials,
    IOrder order,
    int tapeWidth
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to bill.
tapeWidth
Type: SystemInt32
Result text tape width.

Return Value

Type: String
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CalculateDeliveryTerminalWorkload Method

IOperationServiceCalculateDeliveryTerminalWorkload Method

Returns terminal workload.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryTerminalWorkload CalculateDeliveryTerminalWorkload()

Return Value

Type: IDeliveryTerminalWorkload
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CallExternalOperation Method

IOperationServiceCallExternalOperation Method

Overload List
 | Name | Description
Public method | CallExternalOperation(Int32, String, String, Byte, ITerminal) | Calls an operation which is implemented in another plugin.
Public method | CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector) | Calls an operation which is implemented in another plugin.
Top
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CallExternalOperation Method (Int32, String, String, Byte[], ITerminal)

IOperationServiceCallExternalOperation Method (Int32, String, String, Byte, ITerminal)

Calls an operation which is implemented in another plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
byte[] CallExternalOperation(
    int pluginModuleId,
    string serviceName,
    string operationName,
    byte[] request,
    ITerminal terminal = null
)

Parameters

pluginModuleId
Type: SystemInt32
Licensable module identifier of the plugin to be called. That module id have to be pre-shared with consumer plugins.
serviceName
Type: SystemString
Name of the external service which is implemented in another plugin. That name have to be pre-shared with consumer plugins.
operationName
Type: SystemString
Name of the external operation which is implemented in another plugin and have been registered using RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte). That name have to be pre-shared between producer and consumer plugins.
request
Type: SystemByte
The data which will be transferred as an incoming argument into the external operation.
terminal (Optional)
Type: Resto.Front.Api.Data.OrganizationITerminal
Terminal for executing the external operation remotely. Leave it null to execute the operation on the local terminal.

Return Value

Type: Byte
Response returned by the producer plugin.
Exceptions
Exception | Condition
ExternalOperationCallingException | When an external operation calling or execution throws any kind of exception, caller receives the ExternalOperationCallingException with original message and reason. Orignal stacktrace can be found in api.log.
Remarks
Different plugins running under the same iikoFront application instance can communicate via external operations. iikoFront just transfers requests and responses between plugins without knowing any details. Both producer and consumer plugins should understand the data structure, developers should negotiate a protocol specification, pre-share operation names, handle versioning and so on. Producer plugin registers an operation using RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte) and consumer plugin call it using CallExternalOperation(Int32, String, String, Byte, ITerminal).
See Also

Reference

IOperationService Interface
CallExternalOperation Overload
Resto.Front.Api Namespace
IOperationServiceRegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte)


IOperationService.CallExternalOperation(TRequest, TResponse) Method (Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector)

IOperationServiceCallExternalOperationTRequest, TResponse Method (Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector)

Calls an operation which is implemented in another plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TResponse CallExternalOperation<TRequest, TResponse>(
    int pluginModuleId,
    string serviceName,
    string operationName,
    TRequest request,
    ITerminal terminal = null,
    SerializationBinder binder = null,
    ISurrogateSelector surrogateSelector = null
)

Parameters

pluginModuleId
Type: SystemInt32
Licensable module identifier of the plugin to be called. That module id have to be pre-shared with consumer plugins.
serviceName
Type: SystemString
Name of the external service which is implemented in another plugin. That name have to be pre-shared with consumer plugins.
operationName
Type: SystemString
Name of the external operation which is implemented in another plugin and have been registered using RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector). That name have to be pre-shared between producer and consumer plugins.
request
Type: TRequest
The data which will be transferred as an incoming argument into the external operation.
terminal (Optional)
Type: Resto.Front.Api.Data.OrganizationITerminal
Terminal for executing the external operation remotely. Leave it null to execute the operation on the local terminal.
binder (Optional)
Type: System.Runtime.SerializationSerializationBinder
A serialization binder for custom mapping between types and names. Default is null.
surrogateSelector (Optional)
Type: System.Runtime.SerializationISurrogateSelector
The ISurrogateSelector to use for serialization. Default is null.

Type Parameters

TRequest
TResponse

Return Value

Type: TResponse
Response returned by the producer plugin.
Exceptions
Exception | Condition
ExternalOperationCallingException | When an external operation calling or execution throws any kind of exception, caller receives the ExternalOperationCallingException with original message and reason. Orignal stacktrace can be found in api.log.
Remarks
Different plugins running under the same iikoFront application instance can communicate via external operations. iikoFront just transfers requests and responses between plugins without knowing any details. Both producer and consumer plugins should understand the data structure, developers should negotiate a protocol specification, pre-share operation names, handle versioning and so on. Producer plugin registers an operation using RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector) and consumer plugin call it using CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector).
See Also

Reference

IOperationService Interface
CallExternalOperation Overload
Resto.Front.Api Namespace
IOperationServiceRegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector)


IOperationService.CancelBill Method

IOperationServiceCancelBill Method

Сhanges the order to the New status and prints the bill cancellation cheque.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CancelBill(
    ICredentials credentials,
    IOrder order
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to cancel bill.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CancelNewDelivery Method

IOperationServiceCancelNewDelivery Method

Cancels new delivery.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CancelNewDelivery(
    ICredentials credentials,
    IDeliveryOrder delivery,
    IDeliveryCancelCause cancelCause,
    string cancelComment
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery to cancel
cancelCause
Type: Resto.Front.Api.Data.BrdIDeliveryCancelCause
Cause of cancelling delivery
cancelComment
Type: SystemString
Comment to the delivery cancellation.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CancelNewDeliveryAndHideItemsFromOlap Method

IOperationServiceCancelNewDeliveryAndHideItemsFromOlap Method

Cancels new delivery and hides delivery order items from OLAP reports.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CancelNewDeliveryAndHideItemsFromOlap(
    ICredentials credentials,
    IDeliveryOrder delivery,
    IDeliveryCancelCause cancelCause
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery to remove.
cancelCause
Type: Resto.Front.Api.Data.BrdIDeliveryCancelCause
Cause of cancelling delivery
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CancelReserve Method

IOperationServiceCancelReserve Method

Cancels reservation due to some reason

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CancelReserve(
    ICredentials credentials,
    IReserve reserve,
    ReserveCancelReason reason
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to cancel.
reason
Type: Resto.Front.Api.Data.BrdReserveCancelReason
Reason to cancel planned event.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CanProductBePaidWithPaymentType Method

IOperationServiceCanProductBePaidWithPaymentType Method

Function describes if the product is compatible with payment type, i.e. payment type can be used to pay for the product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanProductBePaidWithPaymentType(
    IProduct product,
    IPaymentType paymentType
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Payment type.

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ChangeDeliveryOpinion Method

IOperationServiceChangeDeliveryOpinion Method

Changes client's opinion on closed delivery.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryOpinion(
    Guid DeliveryId,
    string OpinionComment,
    IDictionary<Guid, int> Marks
)

Parameters

DeliveryId
Type: SystemGuid
Id of the delivery to change opinion for.
OpinionComment
Type: SystemString
Client's textual opinion.
Marks
Type: System.Collections.GenericIDictionary Guid, Int32
Client's marks for survey items. Mark should be equal to either 0 or 100.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ChangeKitchenOrderItemsProcessingStatus Method

IOperationServiceChangeKitchenOrderItemsProcessingStatus Method

Changes cooking status of the specified cooking items and modifiers.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ChangeKitchenOrderItemsProcessingStatus(
    IKitchenOrder order,
    IReadOnlyList<IKitchenOrderCookingItem> cookingItems,
    IReadOnlyList<IKitchenOrderModifierItem> separateModifiers,
    KitchenOrderItemProcessingStatus newStatus
)

Parameters

order
Type: Resto.Front.Api.Data.KitchenIKitchenOrder
Order which contains the specified cooking items and modifiers.
cookingItems
Type: System.Collections.GenericIReadOnlyList IKitchenOrderCookingItem
Cooking items.
separateModifiers
Type: System.Collections.GenericIReadOnlyList IKitchenOrderModifierItem
Modifiers which are cooked separately from their products. Use IsSeparate to check whether the modifier is cooked separately.
newStatus
Type: Resto.Front.Api.Data.KitchenKitchenOrderItemProcessingStatus
New processing status to be set for all specified cooking items and modifiers.

Return Value

Type: Boolean
Whether the operation was successful. Kitchen orders use optimistic locking model, so someone could apply conflicting changes to the same cooking items and modifiers just before this method call, in that case plugin should re-read the kitchen order, re-check conditions and call this method again if it still makes sense.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ChangePreliminaryOrder Method

IOperationServiceChangePreliminaryOrder Method

Changes preliminary order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePreliminaryOrder(
    IPreliminaryOrder order,
    string newNumber,
    string newOriginName,
    IReadOnlyList<PreliminaryOrderItemProduct> newProducts
)

Parameters

order
Type: Resto.Front.Api.Data.PreliminaryOrdersIPreliminaryOrder
newNumber
Type: SystemString
newOriginName
Type: SystemString
newProducts
Type: System.Collections.GenericIReadOnlyList PreliminaryOrderItemProduct
Remarks
Changing preliminary orders, which were created on another terminal, may take a long time due to network latency.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CheckCanEditOrder Method

IOperationServiceCheckCanEditOrder Method

If current user has permissions to view order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CheckCanEditOrder(
    ICredentials credentials,
    IOrder order
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to check.

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CheckProductsSellingRestrictions Method

IOperationServiceCheckProductsSellingRestrictions Method

If current user can add these products with such amounts.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ProductsSellingRestrictions CheckProductsSellingRestrictions(
    ICredentials credentials,
    Dictionary<IProduct, decimal> productsAndAmount
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
productsAndAmount
Type: System.Collections.GenericDictionary IProduct, Decimal
Products and amount to check. Amount should be between MinimumItemAmount and MaximumItemAmount

Return Value

Type: ProductsSellingRestrictions
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetProductsRemainingAmounts


IOperationService.CloseCafeSession Method

IOperationServiceCloseCafeSession Method

Closes cafe session.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CloseCafeSession(
    ICredentials credentials
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ClosePersonalSession Method

IOperationServiceClosePersonalSession Method

Closes personal session for the specified user or user defined by the credentials.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ClosePersonalSession(
    ICredentials credentials,
    IUser user = null
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
user (Optional)
Type: Resto.Front.Api.Data.SecurityIUser
The user to close personal session for. Leave it null to close personal session for the user defined by the credentials.

Return Value

Type: Boolean
Whether the operation was successful. Note that the method returns true even if personal session had already been closed.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IRestaurantUsePersonalRoles
IOperationServiceOpenPersonalSession(ICredentials, IRole, IUser)


IOperationService.CreateDiscountCard Method

IOperationServiceCreateDiscountCard Method

Creates a new discount card.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountCard CreateDiscountCard(
    string cardNumber,
    string ownerName,
    IPriceCategory priceCategory,
    IDiscountType discountType
)

Parameters

cardNumber
Type: SystemString
Number of discount card.
ownerName
Type: SystemString
Owner name of discount card.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category. Cannot be combined with discountType.
discountType
Type: Resto.Front.Api.Data.OrdersIDiscountType
Discount type. Cannot be combined with priceCategory.

Return Value

Type: IDiscountCard
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CreateEditSession Method

IOperationServiceCreateEditSession Method

Creates an edit session. All changes made with this session will be accumulated without affecting entities. Use SubmitChanges(ICredentials, IEditSession) method to apply all changes or do nothing to discard them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IEditSession CreateEditSession()

Return Value

Type: IEditSession
A new edit session.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.CreatePreliminaryOrder Method

IOperationServiceCreatePreliminaryOrder Method

Create new preliminary order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPreliminaryOrder CreatePreliminaryOrder(
    string number,
    string originName,
    IReadOnlyList<PreliminaryOrderItemProduct> products
)

Parameters

number
Type: SystemString
originName
Type: SystemString
products
Type: System.Collections.GenericIReadOnlyList PreliminaryOrderItemProduct

Return Value

Type: IPreliminaryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.DeleteDonation Method

IOperationServiceDeleteDonation Method

Deletes existing donation from the order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteDonation(
    ICredentials credentials,
    IOrder order,
    IPaymentItem paymentItem
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order whose donation will be deleted.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Donation to be deleted from the order.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.DeleteOrder Method

IOperationServiceDeleteOrder Method

Deletes order. Order must have no printed items. User must have rights to edit orders.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrder(
    ICredentials credentials,
    IOrder order
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that must be deleted.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.DeleteOrderAndHideItemsFromOlap Method

IOperationServiceDeleteOrderAndHideItemsFromOlap Method

Deletes order and hides order items from OLAP reports. Order must have no printed items, no payment items and no removed with writeoff items. User must have rights to edit orders.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderAndHideItemsFromOlap(
    ICredentials credentials,
    IOrder order
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to remove.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.DeletePreliminaryOrder Method

IOperationServiceDeletePreliminaryOrder Method

Deletes preliminary order

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeletePreliminaryOrder(
    IPreliminaryOrder order
)

Parameters

order
Type: Resto.Front.Api.Data.PreliminaryOrdersIPreliminaryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.EnablePreliminaryOrdersScreen Method

IOperationServiceEnablePreliminaryOrdersScreen Method

Enable preliminary orders screen for iikoFront user.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void EnablePreliminaryOrdersScreen()
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ExecuteContinuousOperation Method

IOperationServiceExecuteContinuousOperation Method

Overload List
 | Name | Description
Public method | ExecuteContinuousOperation(ActionIOperationService) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Public method | ExecuteContinuousOperationT(FuncIOperationService, T) | Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.
Top
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ExecuteContinuousOperation Method (Action(IOperationService))

IOperationServiceExecuteContinuousOperation Method (ActionIOperationService)

Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ExecuteContinuousOperation(
    Action<IOperationService> continuousOperation
)

Parameters

continuousOperation
Type: SystemAction IOperationService
Callback to be executed continuously.
Remarks
It could be useful for calling several methods of the local IOperationService instance sequentially when it's important to call them one by one without outside changes. While all committed changes will immediately become visible for everyone, no one except of the provided callback will be allowed to alter entities which were touched via that short-living IOperationService (input argument of the callback). For example, you can create a new order and add there guests, products and external prepay using one edit session, but you cannot print order items or process external prepay in the same session, because these operations can't be rolled back and thus aren't available via IEditSession. Executing these operations separately on a global Operations isn't reliable because there is a chance to be interrupted by a user, other plugin or background entity change handlers, which may prevent further our edits by applying conflicting changes or by locking an entity for a long time.
See Also

Reference

IOperationService Interface
ExecuteContinuousOperation Overload
Resto.Front.Api Namespace


IOperationService.ExecuteContinuousOperation(T) Method (Func(IOperationService, T))

IOperationServiceExecuteContinuousOperationT Method (FuncIOperationService, T)

Executes the callback function as one continuous operation by providing temporary instance of IOperationService, which holds internal locks taken on lockable entities (such as order) until the operation ends. It's strongly recommended to avoid potentially obstructive calls in the callback, i.e network calls, heavy I/O or CPU-bound calls, thread blocking and so on, because touched entities will remain locked for a long time.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
T ExecuteContinuousOperation<T>(
    Func<IOperationService, T> continuousOperation
)

Parameters

continuousOperation
Type: SystemFunc IOperationService, T
Callback to be executed continuously.

Type Parameters

T

Return Value

Type: T
Remarks
It could be useful for calling several methods of the local IOperationService instance sequentially when it's important to call them one by one without outside changes. While all committed changes will immediately become visible for everyone, no one except of the provided callback will be allowed to alter entities which were touched via that short-living IOperationService (input argument of the callback). For example, you can create a new order and add there guests, products and external prepay using one edit session, but you cannot print order items or process external prepay in the same session, because these operations can't be rolled back and thus aren't available via IEditSession. Executing these operations separately on a global Operations isn't reliable because there is a chance to be interrupted by a user, other plugin or background entity change handlers, which may prevent further our edits by applying conflicting changes or by locking an entity for a long time.
See Also

Reference

IOperationService Interface
ExecuteContinuousOperation Overload
Resto.Front.Api Namespace


IOperationService.GetActivePaymentTypes Method

IOperationServiceGetActivePaymentTypes Method

Returns active payment types bound to the specified processor.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentType> GetActivePaymentTypes(
    IPaymentProcessor processor
)

Parameters

processor
Type: Resto.Front.ApiIPaymentProcessor
Hosting payment processor

Return Value

Type: IReadOnlyList IPaymentType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetActiveProducts Method

IOperationServiceGetActiveProducts Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProduct> GetActiveProducts()

Return Value

Type: IReadOnlyList IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetActiveRemovalTypes Method

IOperationServiceGetActiveRemovalTypes Method

Gets removal types which are allowed to use.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRemovalType> GetActiveRemovalTypes()

Return Value

Type: IReadOnlyList IRemovalType
Remarks
Deleting printed product is unwanted operation usually, so it requires providing reason and removal type. If product was marred, it could be written off from some account depending on removal type.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IEditSessionDeletePrintedOrderItems(String, WriteoffOptions, IOrderStub, IReadOnlyListIOrderRootItemStub)


IOperationService.GetActiveStreets Method

IOperationServiceGetActiveStreets Method

Note: This API is now obsolete.

Gets active streets.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[ObsoleteAttribute("Use SearchStreets method for effective application-side search. Transferring all streets for plugin-side filtering may nagatively affect performance.")]
IReadOnlyList<IStreet> GetActiveStreets()

Return Value

Type: IReadOnlyList IStreet
Remarks
Use GetAllStreets to get all streets (both active and inactive).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetAllStreets


IOperationService.GetAllergenGroupsByOrderRootItem Method

IOperationServiceGetAllergenGroupsByOrderRootItem Method

Get list of allergen groups for OrderRootItem.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IAllergenGroup> GetAllergenGroupsByOrderRootItem(
    IOrderRootItem orderRootItem
)

Parameters

orderRootItem
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Order root item.

Return Value

Type: IReadOnlyList IAllergenGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetAllergenGroupsByProductIds Method

IOperationServiceGetAllergenGroupsByProductIds Method

Get list of allergen groups for products.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IAllergenGroup> GetAllergenGroupsByProductIds(
    Guid[] productIds
)

Parameters

productIds
Type: SystemGuid
Product ids.

Return Value

Type: IReadOnlyList IAllergenGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetAllProducts Method

IOperationServiceGetAllProducts Method

Gets all products (both active and inactive).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProduct> GetAllProducts()

Return Value

Type: IReadOnlyList IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetAllStreets Method

IOperationServiceGetAllStreets Method

Note: This API is now obsolete.

Gets all streets (both active and inactive).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[ObsoleteAttribute("Use SearchStreets method for effective application-side search. Transferring all streets for plugin-side filtering may nagatively affect performance.")]
IReadOnlyList<IStreet> GetAllStreets()

Return Value

Type: IReadOnlyList IStreet
Remarks
Use GetActiveStreets to get active streets only.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetActiveStreets


IOperationService.GetCafeSessionById Method

IOperationServiceGetCafeSessionById Method

Returns cafeSession by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICafeSession GetCafeSessionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICafeSession
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCafeSessions Method

IOperationServiceGetCafeSessions Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ICafeSession> GetCafeSessions()

Return Value

Type: IReadOnlyList ICafeSession
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCashRegisterInfoById Method

IOperationServiceGetCashRegisterInfoById Method

Returns cashRegisterInfo by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo GetCashRegisterInfoById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICashRegisterInfo
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCashRegisterInfos Method

IOperationServiceGetCashRegisterInfos Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ICashRegisterInfo> GetCashRegisterInfos()

Return Value

Type: IReadOnlyList ICashRegisterInfo
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetChangedDeliveryOrders Method

IOperationServiceGetChangedDeliveryOrders Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ChangedEntities<IDeliveryOrder> GetChangedDeliveryOrders(
    int revisionFrom
)

Parameters

revisionFrom
Type: SystemInt32

Return Value

Type: ChangedEntities IDeliveryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetChangedOrders Method

IOperationServiceGetChangedOrders Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ChangedEntities<IOrder> GetChangedOrders(
    int revisionFrom,
    bool excludeDeliveryOrders = false
)

Parameters

revisionFrom
Type: SystemInt32
excludeDeliveryOrders (Optional)
Type: SystemBoolean

Return Value

Type: ChangedEntities IOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetChangedReserves Method

IOperationServiceGetChangedReserves Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ChangedEntities<IReserve> GetChangedReserves(
    int revisionFrom
)

Parameters

revisionFrom
Type: SystemInt32

Return Value

Type: ChangedEntities IReserve
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetChildGroupsByProductGroup Method

IOperationServiceGetChildGroupsByProductGroup Method

Returns childGroups of the specified productGroup.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductGroup> GetChildGroupsByProductGroup(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetChildProductsByProductGroup Method

IOperationServiceGetChildProductsByProductGroup Method

Returns childProducts of the specified productGroup.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProduct> GetChildProductsByProductGroup(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCities Method

IOperationServiceGetCities Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ICity> GetCities()

Return Value

Type: IReadOnlyList ICity
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCityById Method

IOperationServiceGetCityById Method

Returns city by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICity GetCityById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICity
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetClientById Method

IOperationServiceGetClientById Method

Returns client by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient GetClientById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IClient
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCommonGroupModifiers Method

IOperationServiceGetCommonGroupModifiers Method

Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IGroupModifier> GetCommonGroupModifiers(
    ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get common modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCommonSimpleModifiers Method

IOperationServiceGetCommonSimpleModifiers Method

Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ISimpleModifier> GetCommonSimpleModifiers(
    ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get common modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCompoundItemTemplateById Method

IOperationServiceGetCompoundItemTemplateById Method

Returns compoundItemTemplate by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICompoundItemTemplate GetCompoundItemTemplateById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICompoundItemTemplate
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetCompoundItemTemplates Method

IOperationServiceGetCompoundItemTemplates Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ICompoundItemTemplate> GetCompoundItemTemplates()

Return Value

Type: IReadOnlyList ICompoundItemTemplate
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetConceptionById Method

IOperationServiceGetConceptionById Method

Returns conception by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IConception GetConceptionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IConception
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeletedOrderTypes Method

IOperationServiceGetDeletedOrderTypes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderType> GetDeletedOrderTypes()

Return Value

Type: IReadOnlyList IOrderType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeliveryCancelCauseById Method

IOperationServiceGetDeliveryCancelCauseById Method

Returns deliveryCancelCause by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryCancelCause GetDeliveryCancelCauseById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDeliveryCancelCause
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeliveryCancelCauses Method

IOperationServiceGetDeliveryCancelCauses Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDeliveryCancelCause> GetDeliveryCancelCauses()

Return Value

Type: IReadOnlyList IDeliveryCancelCause
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeliveryOrderById Method

IOperationServiceGetDeliveryOrderById Method

Returns deliveryOrder by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryOrder GetDeliveryOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDeliveryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeliveryOrders Method

IOperationServiceGetDeliveryOrders Method

Returns delivery orders.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDeliveryOrder> GetDeliveryOrders(
    bool includeDeleted = false
)

Parameters

includeDeleted (Optional)
Type: SystemBoolean
Whether to include deleted delivery orders in the result. Deleted delivery order has the order status Deleted except for delivery status Cancelled. Default value is false.

Return Value

Type: IReadOnlyList IDeliveryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDeliverySection Method

IOperationServiceGetDeliverySection Method

Returns section of current group where delivery orders are created. Is determined by default table of group.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection GetDeliverySection()

Return Value

Type: IRestaurantSection
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDisabledSizesByProduct Method

IOperationServiceGetDisabledSizesByProduct Method

Returns disabledSizes of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductSize> GetDisabledSizesByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDiscountCardById Method

IOperationServiceGetDiscountCardById Method

Returns discountCard by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountCard GetDiscountCardById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDiscountCard
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDiscountCards Method

IOperationServiceGetDiscountCards Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDiscountCard> GetDiscountCards()

Return Value

Type: IReadOnlyList IDiscountCard
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDiscountTypeById Method

IOperationServiceGetDiscountTypeById Method

Returns discountType by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountType GetDiscountTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDiscountType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDiscountTypes Method

IOperationServiceGetDiscountTypes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDiscountType> GetDiscountTypes()

Return Value

Type: IReadOnlyList IDiscountType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetDonationTypesCompatibleWith Method

IOperationServiceGetDonationTypesCompatibleWith Method

Gets donation types which are allowed to use with the order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDonationType> GetDonationTypesCompatibleWith(
    IOrder order
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order.

Return Value

Type: IReadOnlyList IDonationType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetExternalOperations Method

IOperationServiceGetExternalOperations Method

Returns the list of all currently registered external operations with their service names and owner plugins' licensable module identifiers.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<(int pluginModuleId, string serviceName, string operationName)> GetExternalOperations()

Return Value

Type: IReadOnlyList ValueTuple Int32, String, String
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceRegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte)
IOperationServiceCallExternalOperation(Int32, String, String, Byte, ITerminal)


IOperationService.GetFrontDeliverySettings Method

IOperationServiceGetFrontDeliverySettings Method

Returns courier and self-service delivery duration time set on a delivery terminal.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IFrontDeliverySettings GetFrontDeliverySettings()

Return Value

Type: IFrontDeliverySettings
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetGroupModifiers Method

IOperationServiceGetGroupModifiers Method

Returns group modifiers of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IGroupModifier> GetGroupModifiers(
    IProduct product,
    IPriceCategory priceCategory
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHierarchicalMenu Method

IOperationServiceGetHierarchicalMenu Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
HierarchicalMenu GetHierarchicalMenu()

Return Value

Type: HierarchicalMenu
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHostAgentId Method

IOperationServiceGetHostAgentId Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid GetHostAgentId()

Return Value

Type: Guid
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHostDeliverySettings Method

IOperationServiceGetHostDeliverySettings Method

Returns delivery settings of restaurant.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliverySettings GetHostDeliverySettings()

Return Value

Type: IDeliverySettings
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHostRestaurant Method

IOperationServiceGetHostRestaurant Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurant GetHostRestaurant()

Return Value

Type: IRestaurant
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHostTerminal Method

IOperationServiceGetHostTerminal Method

Returns local terminal, where the plugin is currently being executed.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminal GetHostTerminal()

Return Value

Type: ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetHostTerminalSettings
IOperationServiceGetTerminals


IOperationService.GetHostTerminalPointsOfSale Method

IOperationServiceGetHostTerminalPointsOfSale Method

Returns list of points of sale attached to local terminal. Empty list means that local terminal is not cash terminal.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPointOfSale> GetHostTerminalPointsOfSale()

Return Value

Type: IReadOnlyList IPointOfSale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetHostTerminalSettings Method

IOperationServiceGetHostTerminalSettings Method

Returns settings of the local terminal.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IHostTerminalSettings GetHostTerminalSettings()

Return Value

Type: IHostTerminalSettings
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetHostTerminal


IOperationService.GetHostTerminalsGroup Method

IOperationServiceGetHostTerminalsGroup Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminalsGroup GetHostTerminalsGroup()

Return Value

Type: ITerminalsGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetTerminalsGroups


IOperationService.GetIncludedInMenuSectionsByProduct Method

IOperationServiceGetIncludedInMenuSectionsByProduct Method

Returns includedInMenuSections of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRestaurantSection> GetIncludedInMenuSectionsByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IRestaurantSection
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetKitchenOrderById Method

IOperationServiceGetKitchenOrderById Method

Returns kitchenOrder by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IKitchenOrder GetKitchenOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IKitchenOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetKitchenOrders Method

IOperationServiceGetKitchenOrders Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenOrder> GetKitchenOrders()

Return Value

Type: IReadOnlyList IKitchenOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetMarketingSourceById Method

IOperationServiceGetMarketingSourceById Method

Returns marketingSource by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IMarketingSource GetMarketingSourceById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IMarketingSource
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetMarketingSources Method

IOperationServiceGetMarketingSources Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IMarketingSource> GetMarketingSources()

Return Value

Type: IReadOnlyList IMarketingSource
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrderAppliedDiscounts Method

IOperationServiceGetOrderAppliedDiscounts Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IAppliedDiscountItem> GetOrderAppliedDiscounts(
    IOrder Order
)

Parameters

Order
Type: Resto.Front.Api.Data.OrdersIOrder

Return Value

Type: IReadOnlyList IAppliedDiscountItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrderById Method

IOperationServiceGetOrderById Method

Returns order by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrder GetOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrderItemProductGroups Method

IOperationServiceGetOrderItemProductGroups Method

Returns product groups from the specified order. Products in each group are intended to be cooked together.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IReadOnlyList<IOrderCookingItem>> GetOrderItemProductGroups(
    IOrder order
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder

Return Value

Type: IReadOnlyList IReadOnlyList IOrderCookingItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IEditSessionGroupOrderCookingItems(IReadOnlyListIOrderCookingItemStub, IOrderStub)
IEditSessionUngroupOrderCookingItems(IReadOnlyListIOrderCookingItemStub, IOrderStub)


IOperationService.GetOrders Method

IOperationServiceGetOrders Method

Returns orders list.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrder> GetOrders(
    bool includeDeleted = false,
    bool excludeDeliveryOrders = false
)

Parameters

includeDeleted (Optional)
Type: SystemBoolean
Whether to include deleted orders in the result. Deleted order has the order status Deleted. Default value is false.
excludeDeliveryOrders (Optional)
Type: SystemBoolean
Whether to exclude delivery orders from the result. The default is false.

Return Value

Type: IReadOnlyList IOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrderTypeById Method

IOperationServiceGetOrderTypeById Method

Returns orderType by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType GetOrderTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IOrderType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrderTypes Method

IOperationServiceGetOrderTypes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderType> GetOrderTypes()

Return Value

Type: IReadOnlyList IOrderType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetOrganizationFingerprint Method

IOperationServiceGetOrganizationFingerprint Method

Returns a fingerprint which can be used to identify an iikoRMS server instance.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
byte[] GetOrganizationFingerprint()

Return Value

Type: Byte
Exceptions
Exception | Condition
ExternalOperationFailedException | Underlying network request to the iikoRMS server has failed.
Remarks
Sometimes iikoRMS server instances are being cloned with entire database, so that all their key entities have duplicated ids. Fingerprints help to detect changes of some specific server instance properties, which are usually different for cloned instances, but sometimes also may change on the same instance without any cloning. It is assumed that the plugin compares the currently received fingerprint with previously remembered one to ensure that it communicates with the same iikoRMS server instance. Fingerprints equality means that there is the same server instance. When fingerprints are different, plugin should somehow check, whether it is another instance or the fingerprint of the original instance has been changed. The method requires a connection to the iikoRMS server, so calling this method in offline mode will end up with an exception.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPastOrder Method

IOperationServiceGetPastOrder Method

Get closed order data from server, and returns it.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPastOrder GetPastOrder(
    Guid orderId,
    int orderNumber
)

Parameters

orderId
Type: SystemGuid
Order Id
orderNumber
Type: SystemInt32
Order number

Return Value

Type: IPastOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPaymentSystemName Method

IOperationServiceGetPaymentSystemName Method

Tries to return a string for matching the payment type to the payment system if it exists, elseway returns empty string.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetPaymentSystemName(
    IPaymentType paymentType
)

Parameters

paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Payment type

Return Value

Type: String
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IPaymentProcessorPaymentSystemKey


IOperationService.GetPaymentTypeById Method

IOperationServiceGetPaymentTypeById Method

Returns paymentType by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentType GetPaymentTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPaymentType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPaymentTypes Method

IOperationServiceGetPaymentTypes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentType> GetPaymentTypes()

Return Value

Type: IReadOnlyList IPaymentType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPaymentTypesToPayOutOnUser Method

IOperationServiceGetPaymentTypesToPayOutOnUser Method

Returns payment types that can be processed “silently”, without user interface.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentType> GetPaymentTypesToPayOutOnUser()

Return Value

Type: IReadOnlyList IPaymentType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPointOfSaleById Method

IOperationServiceGetPointOfSaleById Method

Returns pointOfSale by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPointOfSale GetPointOfSaleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPointOfSale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPreliminaryOrderById Method

IOperationServiceGetPreliminaryOrderById Method

Returns preliminaryOrder by id or null if preliminaryOrder with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPreliminaryOrder GetPreliminaryOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPreliminaryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPreliminaryOrders Method

IOperationServiceGetPreliminaryOrders Method

Get all preliminary orders.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPreliminaryOrder> GetPreliminaryOrders()

Return Value

Type: IReadOnlyList IPreliminaryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPrice Method

IOperationServiceGetPrice Method

Returns price for the product according to the given client price category.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal GetPrice(
    IProduct product,
    IProductSize productSize,
    IPriceCategory priceCategory,
    DateTime pricingTime
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get price for.
productSize
Type: Resto.Front.Api.Data.AssortmentIProductSize
Product size to get price for or null if the product doesn't have a scale.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to get price according to.
pricingTime
Type: SystemDateTime
Time for which calculated price.

Return Value

Type: Decimal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPriceCategories Method

IOperationServiceGetPriceCategories Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPriceCategory> GetPriceCategories()

Return Value

Type: IReadOnlyList IPriceCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetPriceCategoryById Method

IOperationServiceGetPriceCategoryById Method

Returns priceCategory by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory GetPriceCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPriceCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductById Method

IOperationServiceGetProductById Method

Returns product by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct GetProductById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductCategories Method

IOperationServiceGetProductCategories Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductCategory> GetProductCategories()

Return Value

Type: IReadOnlyList IProductCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductCategoryById Method

IOperationServiceGetProductCategoryById Method

Returns productCategory by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductCategory GetProductCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductGroupById Method

IOperationServiceGetProductGroupById Method

Returns productGroup by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup GetProductGroupById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductGroups Method

IOperationServiceGetProductGroups Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductGroup> GetProductGroups()

Return Value

Type: IReadOnlyList IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductScaleById Method

IOperationServiceGetProductScaleById Method

Returns productScale by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductScale GetProductScaleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductScale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductScales Method

IOperationServiceGetProductScales Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductScale> GetProductScales()

Return Value

Type: IReadOnlyList IProductScale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductScaleSizes Method

IOperationServiceGetProductScaleSizes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductSize> GetProductScaleSizes(
    IProductScale productScale
)

Parameters

productScale
Type: Resto.Front.Api.Data.AssortmentIProductScale

Return Value

Type: IReadOnlyList IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductSizeById Method

IOperationServiceGetProductSizeById Method

Returns productSize by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize GetProductSizeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductSizes Method

IOperationServiceGetProductSizes Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductSize> GetProductSizes()

Return Value

Type: IReadOnlyList IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductsRemainingAmounts Method

IOperationServiceGetProductsRemainingAmounts Method

Gets remaining amounts of products in stop list.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Dictionary<IProduct, decimal> GetProductsRemainingAmounts()

Return Value

Type: Dictionary IProduct, Decimal
Dictionary of products and theirs remaining amounts.
Remarks
Products that has small remaining amount can be added to stop list to limit consumption. Selling of product with zero or negative remaining amount is restricted.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceIsProductSellingRestricted(IProduct)


IOperationService.GetProductStocksListById Method

IOperationServiceGetProductStocksListById Method

Returns productStocksList by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductStocksList GetProductStocksListById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductStocksList
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetProductStocksLists Method

IOperationServiceGetProductStocksLists Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductStocksList> GetProductStocksLists()

Return Value

Type: IReadOnlyList IProductStocksList
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetQuickMenu Method

IOperationServiceGetQuickMenu Method

Returns quick menu for specified restaurant section and day.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IQuickMenuPage> GetQuickMenu(
    IRestaurantSection restaurantSection,
    DayOfWeek dayOfWeek
)

Parameters

restaurantSection
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection
Restaurant section which contains order's table. Different sections may have different quick menu pages.
dayOfWeek
Type: SystemDayOfWeek
Specifies for which day menu will be returned. Sections may have different quick menu for different days of week.

Return Value

Type: IReadOnlyList IQuickMenuPage
Remarks
Quick menu is zero or more pages with links to products and product groups, can be used in order editor UI to allow adding items to order directly instead of searching them in hierarchical menu.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetHierarchicalMenu


IOperationService.GetReceiptMarkup Method

IOperationServiceGetReceiptMarkup Method

Get reciept markup of the payment.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Document GetReceiptMarkup(
    ChequeTask chequeTask,
    CashRegisterChequeExtensions chequeExtensions,
    ICashRegisterInfo cashRegister
)

Parameters

chequeTask
Type: Resto.Front.Api.Data.Device.TasksChequeTask
CashRegister do cheque task.
chequeExtensions
Type: Resto.Front.Api.Data.DeviceCashRegisterChequeExtensions
Additional info.
cashRegister
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.

Return Value

Type: Document
Markup of the reciept.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRegionById Method

IOperationServiceGetRegionById Method

Returns region by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRegion GetRegionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRegion
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRegions Method

IOperationServiceGetRegions Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRegion> GetRegions()

Return Value

Type: IReadOnlyList IRegion
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRelatedDeliveryOrders Method

IOperationServiceGetRelatedDeliveryOrders Method

Gets all deliveries that are related with argument through splitting between cash registers. Delivery itself is also returned. If delivery was not split, returns delivery passed as argument.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDeliveryOrder> GetRelatedDeliveryOrders(
    IDeliveryOrder delivery
)

Parameters

delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery order to get related deliveries.

Return Value

Type: IReadOnlyList IDeliveryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRemovalTypeById Method

IOperationServiceGetRemovalTypeById Method

Returns removalType by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRemovalType GetRemovalTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRemovalType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetReportMarkupById Method

IOperationServiceGetReportMarkupById Method

Get report markup by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Document GetReportMarkupById(
    string reportId,
    ICashRegisterInfo cashRegister
)

Parameters

reportId
Type: SystemString
Report identifier.
cashRegister
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
The cash register to be used by the report. Specify null if the report doesn't use a cash register. Note that some reports require a cash register to be local or have an open cafe session (cash shift).

Return Value

Type: Document
Markup of the report.
Exceptions
Exception | Condition
ArgumentNullException | Report requires cash register.
ArgumentOutOfRangeException | Invalid report identifier.
ServerConnectionException | Report requires server connection.
ReportBuildException | Report building failed.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetReportPrinter Method

IOperationServiceGetReportPrinter Method

Get instance of report printer

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPrinterRef GetReportPrinter()

Return Value

Type: IPrinterRef
Instance of report printer.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetReserveById Method

IOperationServiceGetReserveById Method

Returns reserve by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReserve GetReserveById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IReserve
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetReserves Method

IOperationServiceGetReserves Method

Returns reserves or banquets in any ReserveStatus.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IReserve> GetReserves()

Return Value

Type: IReadOnlyList IReserve
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRoleById Method

IOperationServiceGetRoleById Method

Returns role by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRole GetRoleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRole
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetRoles Method

IOperationServiceGetRoles Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRole> GetRoles()

Return Value

Type: IReadOnlyList IRole
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetSimpleModifiers Method

IOperationServiceGetSimpleModifiers Method

Returns simple modifiers of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ISimpleModifier> GetSimpleModifiers(
    IProduct product,
    IPriceCategory priceCategory
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetSplittableGroupModifiers Method

IOperationServiceGetSplittableGroupModifiers Method

Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IGroupModifier> GetSplittableGroupModifiers(
    ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get splittable modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetSplittableSimpleModifiers Method

IOperationServiceGetSplittableSimpleModifiers Method

Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ISimpleModifier> GetSplittableSimpleModifiers(
    ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get splittable modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetStreetById Method

IOperationServiceGetStreetById Method

Returns street by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IStreet GetStreetById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IStreet
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetSurveyItemById Method

IOperationServiceGetSurveyItemById Method

Returns surveyItem by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ISurveyItem GetSurveyItemById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ISurveyItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetSurveyItems Method

IOperationServiceGetSurveyItems Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ISurveyItem> GetSurveyItems()

Return Value

Type: IReadOnlyList ISurveyItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTableById Method

IOperationServiceGetTableById Method

Returns table by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITable GetTableById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTables Method

IOperationServiceGetTables Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITable> GetTables()

Return Value

Type: IReadOnlyList ITable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTaxCategories Method

IOperationServiceGetTaxCategories Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITaxCategory> GetTaxCategories()

Return Value

Type: IReadOnlyList ITaxCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTaxCategoryById Method

IOperationServiceGetTaxCategoryById Method

Returns taxCategory by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITaxCategory GetTaxCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITaxCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTemplatedModifiersParamsByProduct Method

IOperationServiceGetTemplatedModifiersParamsByProduct Method

Returns templatedModifiersParams of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITemplatedModifierParams> GetTemplatedModifiersParamsByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList ITemplatedModifierParams
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTerminalById Method

IOperationServiceGetTerminalById Method

Returns terminal by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminal GetTerminalById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTerminals Method

IOperationServiceGetTerminals Method

Returns list of terminals in the restaurant.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITerminal> GetTerminals()

Return Value

Type: IReadOnlyList ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceGetHostTerminal


IOperationService.GetTerminalsGroupPointsOfSale Method

IOperationServiceGetTerminalsGroupPointsOfSale Method

Returns list of points of sale of the specified terminals group.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPointOfSale> GetTerminalsGroupPointsOfSale(
    ITerminalsGroup terminalsGroup
)

Parameters

terminalsGroup
Type: Resto.Front.Api.Data.OrganizationITerminalsGroup
Terminals group whose points of sale are to be obtained.

Return Value

Type: IReadOnlyList IPointOfSale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTerminalsGroupRestaurantSections Method

IOperationServiceGetTerminalsGroupRestaurantSections Method

Returns list of restaurant sections of the specified terminals group.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRestaurantSection> GetTerminalsGroupRestaurantSections(
    ITerminalsGroup terminalsGroup
)

Parameters

terminalsGroup
Type: Resto.Front.Api.Data.OrganizationITerminalsGroup
Terminals group whose restaurant sections are to be obtained.

Return Value

Type: IReadOnlyList IRestaurantSection
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTerminalsGroups Method

IOperationServiceGetTerminalsGroups Method

Returns list of terminals groups.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITerminalsGroup> GetTerminalsGroups()

Return Value

Type: IReadOnlyList ITerminalsGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
[!:GetHostTerminalGroup]


IOperationService.GetTerminalsGroupTerminals Method

IOperationServiceGetTerminalsGroupTerminals Method

Returns list of terminals attached to the specified terminals group.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITerminal> GetTerminalsGroupTerminals(
    ITerminalsGroup terminalsGroup
)

Parameters

terminalsGroup
Type: Resto.Front.Api.Data.OrganizationITerminalsGroup
Terminals group to which the required terminals are attached.

Return Value

Type: IReadOnlyList ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetTransportSettings Method

IOperationServiceGetTransportSettings Method

Returns iikoTransport settings.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITransportSettings GetTransportSettings()

Return Value

Type: ITransportSettings
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetUser Method

IOperationServiceGetUser Method

Get user corresponding to specified credentials.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser GetUser(
    ICredentials credentials
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.

Return Value

Type: IUser
User whose pin have been used to authenticate current plugin.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetUserById Method

IOperationServiceGetUserById Method

Returns user by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser GetUserById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IUser
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetUserRoles Method

IOperationServiceGetUserRoles Method

Returns roles available for the user.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRole> GetUserRoles(
    IUser user
)

Parameters

user
Type: Resto.Front.Api.Data.SecurityIUser
User to get his roles.

Return Value

Type: IReadOnlyList IRole
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.GetUsers Method

IOperationServiceGetUsers Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IUser> GetUsers()

Return Value

Type: IReadOnlyList IUser
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsActiveForDeliveries Method

IOperationServiceIsActiveForDeliveries Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActiveForDeliveries(
    IDiscountType discountType
)

Parameters

discountType
Type: Resto.Front.Api.Data.OrdersIDiscountType

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsAllCafeSessionsClosed Method

IOperationServiceIsAllCafeSessionsClosed Method

Returns true if all cafe sessions of the local terminal are closed.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsAllCafeSessionsClosed()

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceIsAllCafeSessionsOpen


IOperationService.IsAllCafeSessionsOpen Method

IOperationServiceIsAllCafeSessionsOpen Method

Returns true if all cafe sessions of the local terminal are open.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsAllCafeSessionsOpen()

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceIsAllCafeSessionsClosed


IOperationService.IsDeliveryActive Method

IOperationServiceIsDeliveryActive Method

Returns whether delivery is active.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsDeliveryActive()

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsDeliveryConfirmationActive Method

IOperationServiceIsDeliveryConfirmationActive Method

Returns whether delivery confirmation is active.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsDeliveryConfirmationActive()

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsMultiCashRegisterConfiguration Method

IOperationServiceIsMultiCashRegisterConfiguration Method

Returns true if multi cash register configuration allowed.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsMultiCashRegisterConfiguration()

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsOrderHasEInvoice Method

IOperationServiceIsOrderHasEInvoice Method

Returns whether eInvoice is active for order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsOrderHasEInvoice(
    Guid orderId
)

Parameters

orderId
Type: SystemGuid
Order id.

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.IsProductSellingRestricted Method

IOperationServiceIsProductSellingRestricted Method

Checks remaining amount of the product and determines whether selling of that product is restricted.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsProductSellingRestricted(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to check remaining amount.

Return Value

Type: Boolean
true if the product has too low amount and selling is restricted, otherwise false.
Remarks
If product selling is restricted, it can be sold only by user with permission to edit menu.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.NeedToSplitOrderBeforePayment Method

IOperationServiceNeedToSplitOrderBeforePayment Method

Checks if order should be splitted between cash registers before payment. Method also returns estimated point of sale for order if it can be determinated at the moment.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CheckSplitResultDto NeedToSplitOrderBeforePayment(
    IOrder order
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to check.

Return Value

Type: CheckSplitResultDto
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.OpenCafeSession Method

IOperationServiceOpenCafeSession Method

Opens cafe session.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void OpenCafeSession(
    ICredentials credentials
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.OpenPersonalSession Method

IOperationServiceOpenPersonalSession Method

Opens personal session for the specified or defined by the credentials user using the specified role.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool OpenPersonalSession(
    ICredentials credentials,
    IRole role = null,
    IUser user = null
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
role (Optional)
Type: Resto.Front.Api.Data.SecurityIRole
User role for the opening session. Must be null if the restaurant doesn't use roles, otherwise not-null role must be specified. Check UsePersonalRoles to determine, whether the restaurant uses roles or not.
user (Optional)
Type: Resto.Front.Api.Data.SecurityIUser
The user to open personal session for. Leave it null to open personal session for the user defined by the credentials.

Return Value

Type: Boolean
Whether the operation was successful. Note that the method returns true even if personal session had already been opened, regardless of the role.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IRestaurantUsePersonalRoles
IOperationServiceClosePersonalSession(ICredentials, IUser)


IOperationService.PayOrder Method

IOperationServicePayOrder Method

Pay order with included processed or “silent” payment items.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PayOrder(
    ICredentials credentials,
    IOrder order,
    ChequeAdditionalInfo chequeAdditionalInfo = null
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to pay.
chequeAdditionalInfo (Optional)
Type: Resto.Front.Api.Data.PaymentsChequeAdditionalInfo
Cheque additional info for russian fiscal payments according to federal law #54.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PayOrderAndPayOutOnUser Method

IOperationServicePayOrderAndPayOutOnUser Method

Pay order and pay out on user.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PayOrderAndPayOutOnUser(
    ICredentials credentials,
    IOrder order,
    IPaymentType paymentType,
    decimal sum,
    ChequeAdditionalInfo chequeAdditionalInfo = null
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to pay.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Payment type to pay. Should be “silent” payment type from GetPaymentTypesToPayOutOnUser
sum
Type: SystemDecimal
Sum to pay.
chequeAdditionalInfo (Optional)
Type: Resto.Front.Api.Data.PaymentsChequeAdditionalInfo
Cheque additional info for russian fiscal payments according to federal law #54.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrepareDeliveryForSending Method

IOperationServicePrepareDeliveryForSending Method

Prepares delivery for sending by courier, switches DeliveryStatus from New to Waiting.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrepareDeliveryForSending(
    ICredentials credentials,
    IDeliveryOrder delivery,
    bool throwOnChanges = false
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery to prepare for sending.
throwOnChanges (Optional)
Type: SystemBoolean
Whether to stop method execution and throw EntityModifiedException if order changed according to the product auto-addition settings. Default is false, which means to proceed anyway. Set this flag to true if you have preconditions which should be checked again after adding new items to the delivery. Handle exceptions of type EntityModifiedException, check preconditions again and call this method again if you are ok with changes.
Remarks
This method may add some items according to the product auto-addition settings. Payment time should be set to on-delivery-closing in the settings, payment before sending is not supported yet.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceSendDelivery(ICredentials, IDeliveryOrder)


IOperationService.Print Method

IOperationServicePrint Method

Print document on specified printer.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Print(
    IPrinterRef printer,
    Document document,
    bool checkIsCompleted = false
)

Parameters

printer
Type: Resto.Front.Api.Data.PrintIPrinterRef
Instance of printer.
document
Type: Resto.Front.Api.Data.PrintDocument
Document to print.
checkIsCompleted (Optional)
Type: SystemBoolean
Wait for printing to complete and check it's success. Otherwise, only the success of sending the issue to the printer is checked. Relevant for the receipt printer.

Return Value

Type: Boolean
True for successfully printed document.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrintBanquet Method

IOperationServicePrintBanquet Method

Prints preliminary document with estimated event date and time, planned menu, guests count, client contacts, prepay info, etc.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintBanquet(
    ICredentials credentials,
    IReserve banquet
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
banquet
Type: Resto.Front.Api.Data.BrdIReserve
Banquet to print. Must be in New status and have an order (Order).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrintBillCheque Method

IOperationServicePrintBillCheque Method

Changes the order to Bill status if it is not Bill and prints bill cheque.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintBillCheque(
    ICredentials credentials,
    IOrder order,
    PrinterSelectionMode printerSelectionMode = PrinterSelectionMode.Default
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to bill.
printerSelectionMode (Optional)
Type: Resto.Front.Api.Data.PrintPrinterSelectionMode
Specifies how to select a printer to print bill cheque.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrintDeliveryBill Method

IOperationServicePrintDeliveryBill Method

Prints delivery bill.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintDeliveryBill(
    ICredentials credentials,
    IDeliveryOrder delivery
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery to printing the bill.
Remarks
Delivery stickers may also be printed according to the settings.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IDeliveryOrderIsPrintedBillActual
IEditSessionResetIsPrintedDeliveryBillActual(IDeliveryOrderStub)


IOperationService.PrintOrderItems Method

IOperationServicePrintOrderItems Method

Prints service cheque for defined order item products.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintOrderItems(
    ICredentials credentials,
    IOrder order,
    IReadOnlyList<IOrderCookingItem> orderItems
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which items will be printed.
orderItems
Type: System.Collections.GenericIReadOnlyList IOrderCookingItem
Order items to be printed.
Remarks
All order items must be either not printed (so they will be printed) or printed (so they will be reprinted), but not mixed.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrintReceiptCheque Method

IOperationServicePrintReceiptCheque Method

Printing receipts to a printer.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintReceiptCheque(
    Guid cashRegisterId,
    Document document
)

Parameters

cashRegisterId
Type: SystemGuid
Id of the cashRegister, the printer receipts which will be sent to print
document
Type: Resto.Front.Api.Data.PrintDocument
Print data.

Return Value

Type:
Markup of the reciept.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.PrintTableReservedCheque Method

IOperationServicePrintTableReservedCheque Method

Prints short “Table reserved” document with estimated event date and time, guests count and client contacts. Can be used to place onto reserved table as a hint not to occupy it.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintTableReservedCheque(
    ICredentials credentials,
    IReserve reserve
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to print “Table reserved” cheque for.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.ProcessPrepay Method

IOperationServiceProcessPrepay Method

Processes existing payment item. Payment item should be processed externally or supports silent processing.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ProcessPrepay(
    ICredentials credentials,
    IOrder order,
    IPaymentItem paymentItem,
    ChequeAdditionalInfo chequeAdditionalInfo = null,
    OrganizationDetailsInfo organizationDetailsInfo = null
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order whose payment item will be processed.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be processed in iiko.
chequeAdditionalInfo (Optional)
Type: Resto.Front.Api.Data.PaymentsChequeAdditionalInfo
Cheque additional info for russian fiscal payments according to federal law #54.
organizationDetailsInfo (Optional)
Type: Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo
Organization details informations.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterCashRegisterFactory Method

IOperationServiceRegisterCashRegisterFactory Method

Registers cash register factory.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterCashRegisterFactory(
    ICashRegisterFactory cashRegisterFactory
)

Parameters

cashRegisterFactory
Type: Resto.Front.Api.DevicesICashRegisterFactory
Cash register factory.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterChequeTaskProcessor Method

IOperationServiceRegisterChequeTaskProcessor Method

Registers chequeTaskProcessor for extension the functionality of the cash register.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterChequeTaskProcessor(
    IChequeTaskProcessor chequeTaskProcessor
)

Parameters

chequeTaskProcessor
Type: Resto.Front.Api.DevicesIChequeTaskProcessor
Processor to extend the functionality of the cash register.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterCustomRoundingHandler Method

IOperationServiceRegisterCustomRoundingHandler Method

Allows to provide custom order sum rounding implementation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterCustomRoundingHandler(
    Func<IOrder, decimal> callback
)

Parameters

callback
Type: SystemFunc IOrder, Decimal
The rounding logic implementation, which will be called to calculate order sum. Callback gets an order and returns a sum, by which the result sum of the order should be increased or decreased. In case of zero no rounding will be applied, in case of an exception default rounding will be applied.

Return Value

Type: IDisposable
Remarks
Usually order sum rounding is used to speed up the service and convenience of customers by discarding pennies, or as a legal requirement. For example, if ResultSum is 1320.74, the callback may return -0.74 to round the sum down to 1320, or return 0.01 to round the sum up to 1320.75 (to the nearest multiple of 0.05).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterExternalCourierServicesProvider Method

IOperationServiceRegisterExternalCourierServicesProvider Method

Registers ecs provider.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterExternalCourierServicesProvider(
    string providerId,
    Func<(Guid , string )[]> getServicesCallback
)

Parameters

providerId
Type: SystemString
Unique service provider id.
getServicesCallback
Type: SystemFunc ValueTuple Guid, String
External courier services provider.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterExternalOperation Method

IOperationServiceRegisterExternalOperation Method

Overload List
 | Name | Description
Public method | RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Public method | RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector) | Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.
Top
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterExternalOperation Method (String, String, Func(ValueTuple(Byte[], String, Int32, Guid), Byte[]))

IOperationServiceRegisterExternalOperation Method (String, String, FuncValueTupleByte, String, Int32, Guid, Byte)

Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterExternalOperation(
    string serviceName,
    string operationName,
    Func<(byte[] , string callerPluginName, int callerPluginModuleId, Guid callerTerminalId), byte[]> callback
)

Parameters

serviceName
Type: SystemString
Identifies the external service, just a namespace for a set of interrelated operations, which helps to group them logically. It's recommended to choose a unique name to avoid collisions with other plugins, i.e. include company's name or plugin's name into the service name. Min length is 1, max length is 50 chars.
operationName
Type: SystemString
In aggregate with [!:serviceName] identifies the operation. Both names have to be pre-shared with consumer plugins, so that they will be able to call the operation referring it by service and operation name. The combination of a service name and operation name must be unique at the same time. Min length is 1, max length is 50 chars.
callback
Type: SystemFunc ValueTuple Byte , String, Int32, Guid , Byte
The operation implementation, which will be called by other plugins via CallExternalOperation(Int32, String, String, Byte, ITerminal).

Return Value

Type: IDisposable
Remarks
Different plugins running under the same iikoFront application instance can communicate via external operations. iikoFront just transfers requests and responses between plugins without knowing any details. Both producer and consumer plugins should understand the data structure, developers should negotiate a protocol specification, pre-share operation names, handle versioning and so on. Producer plugin registers an operation using RegisterExternalOperation(String, String, FuncValueTupleByte, String, Int32, Guid, Byte) and consumer plugin call it using CallExternalOperation(Int32, String, String, Byte, ITerminal).
See Also

Reference

IOperationService Interface
RegisterExternalOperation Overload
Resto.Front.Api Namespace
IOperationServiceCallExternalOperation(Int32, String, String, Byte, ITerminal)


IOperationService.RegisterExternalOperation(TRequest, TResponse) Method (String, String, Func(ValueTuple(TRequest, String, Int32, Guid), TResponse), SerializationBinder, ISurrogateSelector)

IOperationServiceRegisterExternalOperationTRequest, TResponse Method (String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector)

Exposes a custom operation to be available for call by other plugins. The registration is not permanent, it holds true until disposing the return value, or plugin shutdown.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterExternalOperation<TRequest, TResponse>(
    string serviceName,
    string operationName,
    Func<(TRequest , string callerPluginName, int callerPluginModuleId, Guid callerTerminalId), TResponse> callback,
    SerializationBinder binder = null,
    ISurrogateSelector surrogateSelector = null
)

Parameters

serviceName
Type: SystemString
Identifies the external service, just a namespace for a set of interrelated operations, which helps to group them logically. It's recommended to choose a unique name to avoid collisions with other plugins, i.e. include company's name or plugin's name into the service name. Min length is 1, max length is 50 chars.
operationName
Type: SystemString
In aggregate with serviceName identifies the operation. Both names have to be pre-shared with consumer plugins, so that they will be able to call the operation referring it by service and operation name. The combination of a service name and operation name must be unique at the same time. Min length is 1, max length is 50 chars.
callback
Type: SystemFunc ValueTuple TRequest, String, Int32, Guid , TResponse
The operation implementation, which will be called by other plugins via CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector).
binder (Optional)
Type: System.Runtime.SerializationSerializationBinder
A serialization binder for custom mapping between types and names. Default is null.
surrogateSelector (Optional)
Type: System.Runtime.SerializationISurrogateSelector
The ISurrogateSelector to use for serialization. Default is null.

Type Parameters

TRequest
TResponse

Return Value

Type: IDisposable
Remarks
Different plugins running under the same iikoFront application instance can communicate via external operations. iikoFront just transfers requests and responses between plugins without knowing any details. Both producer and consumer plugins should understand the data structure, developers should negotiate a protocol specification, pre-share operation names, handle versioning and so on. Producer plugin registers an operation using RegisterExternalOperationTRequest, TResponse(String, String, FuncValueTupleTRequest, String, Int32, Guid, TResponse, SerializationBinder, ISurrogateSelector) and consumer plugin call it using CallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector).
See Also

Reference

IOperationService Interface
RegisterExternalOperation Overload
Resto.Front.Api Namespace
IOperationServiceCallExternalOperationTRequest, TResponse(Int32, String, String, TRequest, ITerminal, SerializationBinder, ISurrogateSelector)


IOperationService.RegisterPaymentSystem Method

IOperationServiceRegisterPaymentSystem Method

Registers payment system.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterPaymentSystem(
    IPaymentProcessor paymentProcessor,
    bool canProcessPaymentReturnWithoutOrder = false
)

Parameters

paymentProcessor
Type: Resto.Front.ApiIPaymentProcessor
Payment plugin paymentProcessor.
canProcessPaymentReturnWithoutOrder (Optional)
Type: SystemBoolean
Can process payment return without order.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RegisterScaleFactory Method

IOperationServiceRegisterScaleFactory Method

Registers scale factory.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDisposable RegisterScaleFactory(
    IScaleFactory scaleFactory
)

Parameters

scaleFactory
Type: Resto.Front.Api.DevicesIScaleFactory
Scale factory.

Return Value

Type: IDisposable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.RemoveOrderClient Method

IOperationServiceRemoveOrderClient Method

Returns true if client is unbound of the order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool RemoveOrderClient(
    ICredentials credentials,
    IOrder order,
    IClient client
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to unbind the client.
client
Type: Resto.Front.Api.Data.BrdIClient
The client will be unbound of the order.

Return Value

Type: Boolean
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.SearchClients Method

IOperationServiceSearchClients Method

Search clients. The number of results is limited.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IClient> SearchClients(
    ICredentials credentials,
    string query,
    SearchType searchType = SearchType.Prefix,
    ClientFields fields = ClientFields.All
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
query
Type: SystemString
Search query.
searchType (Optional)
Type: Resto.Front.Api.Data.SearchSearchType
Type of search. Default type: Prefix
fields (Optional)
Type: Resto.Front.Api.Data.SearchClientFields
Customer's fields for search. Default is All.

Return Value

Type: IReadOnlyList IClient
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.SearchDiscountCardByNumber Method

IOperationServiceSearchDiscountCardByNumber Method

Searches a discount card by given card number.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountCard SearchDiscountCardByNumber(
    string cardNumber
)

Parameters

cardNumber
Type: SystemString
Number to search.

Return Value

Type: IDiscountCard
Card with given number or null if card wasn't found.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.SearchStreets Method

IOperationServiceSearchStreets Method

Searches streets and returns limited number of results.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IStreet> SearchStreets(
    string query,
    SearchType searchType = SearchType.Prefix,
    StreetFields fields = StreetFields.Name,
    IReadOnlyList<ICity> cities = null
)

Parameters

query
Type: SystemString
Search query.
searchType (Optional)
Type: Resto.Front.Api.Data.SearchSearchType
Type of search. Default type: Prefix
fields (Optional)
Type: Resto.Front.Api.Data.SearchStreetFields
Street's fields for search. Default is Name.
cities (Optional)
Type: System.Collections.GenericIReadOnlyList ICity
Optional filter for searching streets only in certain cities. Default is null, which means searching without filtering by city (in all citities).

Return Value

Type: IReadOnlyList IStreet
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.SendDelivery Method

IOperationServiceSendDelivery Method

Sends the delivery.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SendDelivery(
    ICredentials credentials,
    IDeliveryOrder delivery
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
delivery
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery to send
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServicePrepareDeliveryForSending(ICredentials, IDeliveryOrder, Boolean)


IOperationService.SendHrsCardTransactionToServer Method

IOperationServiceSendHrsCardTransactionToServer Method

Sends guest data to the server.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SendHrsCardTransactionToServer(
    Guid orderId,
    string guestName,
    string guestId,
    string roomNumber
)

Parameters

orderId
Type: SystemGuid
Order Id
guestName
Type: SystemString
Guest name
guestId
Type: SystemString
Guest Id
roomNumber
Type: SystemString
Guest room number
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.SplitOrderBetweenCashRegisters Method

IOperationServiceSplitOrderBetweenCashRegisters Method

Split order between cash registers according to the current point of sale mapping.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrder> SplitOrderBetweenCashRegisters(
    ICredentials credentials,
    IOrder order
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to split.

Return Value

Type: IReadOnlyList IOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.StartCourseCooking Method

IOperationServiceStartCourseCooking Method

Starts cooking for all order item products of the specified course.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void StartCourseCooking(
    ICredentials credentials,
    IOrder order,
    OrderItemCourse course
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to start products cooking from.
course
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Which course products cooking should be started.
Remarks
Cooking of Vip and First course products start immediately after printing, so allowed course values are Second, Third or Fourth only.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.StartProductsCooking Method

IOperationServiceStartProductsCooking Method

Starts cooking for the specified order item products.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void StartProductsCooking(
    ICredentials credentials,
    IOrder order,
    IReadOnlyList<IOrderCookingItem> products
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to start products cooking from.
products
Type: System.Collections.GenericIReadOnlyList IOrderCookingItem
Order item products to start cooking.
Remarks
Products must be printed with one of the following cooking priorities: Second, Third or Fourth
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceStartCourseCooking(ICredentials, IOrder, OrderItemCourse)


IOperationService.StartService Method

IOperationServiceStartService Method

Starts the specified service.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void StartService(
    ICredentials credentials,
    IOrder order,
    IOrderServiceItem service
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to start service from.
service
Type: Resto.Front.Api.Data.OrdersIOrderServiceItem
Service to start.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceStopService(ICredentials, IOrder, IOrderServiceItem)


IOperationService.StopService Method

IOperationServiceStopService Method

Stops the specified service.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void StopService(
    ICredentials credentials,
    IOrder order,
    IOrderServiceItem service
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to stop service from.
service
Type: Resto.Front.Api.Data.OrdersIOrderServiceItem
Service to stop.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceStartService(ICredentials, IOrder, IOrderServiceItem)


IOperationService.SubmitChanges Method

IOperationServiceSubmitChanges Method

Applies all changes made with specified edit session.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ISubmittedEntities SubmitChanges(
    ICredentials credentials,
    IEditSession editSession
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
editSession
Type: Resto.Front.Api.EditorsIEditSession
Edit session with changes.

Return Value

Type: ISubmittedEntities
Created or changed entities. Use corresponding Get method to retrieve entities by their stubs.
Remarks
Do not use current edit session instance for another changes after submitting, create new edit session instead.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IOperationServiceCreateEditSession


IOperationService.TryEditCurrentOrder Method

IOperationServiceTryEditCurrentOrder Method

Allows to show messages and make changes to the order that is currently opened on the order edit screen.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void TryEditCurrentOrder(
    Action<(IOrder order, IOperationService os, IViewManager vm)> callback
)

Parameters

callback
Type: SystemAction ValueTuple IOrder, IOperationService, IViewManager
Callback that can show messages and make changes to the order using the view manager and special instance of operation service.
Exceptions
Exception | Condition
NotSupportedException | Current screen doesn't support this operation.
OperationCanceledException | Current screen has canceled the operation. It means that the current screen was unable to execute the operation immediately and therefore scheduled it for executing later, but then navigation to another screen has happened in a way that prevented calling delayed operations before changing the screen.
Exception | Any exception thrown by callback.
Remarks
The callback will be called immediately if the are no uninterruptable activity by user or another plugin, otherwise this method will wait until the screen becomes idle. Delivery order editor currently doesn't support changes from API.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetBillPrinter Method

IOperationServiceTryGetBillPrinter Method

Try get bill printer for specified restaurant section.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPrinterRef TryGetBillPrinter(
    IRestaurantSection section = null,
    bool checkIsConfigured = false
)

Parameters

section (Optional)
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection
Printer`s restaurant section. If section not specified uses default table`s section.
checkIsConfigured (Optional)
Type: SystemBoolean
If checkIsConfigured = true returns only configured printer.

Return Value

Type: IPrinterRef
Instance of printer or null if section does not contains bill printer or bill printer not configured (for checkIsConfigured = true).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetCafeSessionByCashRegister Method

IOperationServiceTryGetCafeSessionByCashRegister Method

Returns current open cafe session on cash register.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICafeSession TryGetCafeSessionByCashRegister(
    ICashRegisterInfo cashRegister
)

Parameters

cashRegister
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register

Return Value

Type: ICafeSession
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetCafeSessionById Method

IOperationServiceTryGetCafeSessionById Method

Returns cafeSession by id or null if cafeSession with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICafeSession TryGetCafeSessionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICafeSession
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetCashRegisterInfoById Method

IOperationServiceTryGetCashRegisterInfoById Method

Returns cashRegisterInfo by id or null if cashRegisterInfo with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo TryGetCashRegisterInfoById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICashRegisterInfo
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetChildGroupsByProductGroup Method

IOperationServiceTryGetChildGroupsByProductGroup Method

Returns childGroups of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductGroup> TryGetChildGroupsByProductGroup(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetChildProductsByProductGroup Method

IOperationServiceTryGetChildProductsByProductGroup Method

Returns childProducts of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProduct> TryGetChildProductsByProductGroup(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetCityById Method

IOperationServiceTryGetCityById Method

Returns city by id or null if city with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICity TryGetCityById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICity
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetClientById Method

IOperationServiceTryGetClientById Method

Returns client by id or null if client with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient TryGetClientById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IClient
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetClientByPhone Method

IOperationServiceTryGetClientByPhone Method

Returns client by phone.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient TryGetClientByPhone(
    ICredentials credentials,
    string phone
)

Parameters

credentials
Type: Resto.Front.Api.Data.SecurityICredentials
The credentials returned by AuthenticateByPin(String) method.
phone
Type: SystemString

Return Value

Type: IClient
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetCompoundItemTemplateById Method

IOperationServiceTryGetCompoundItemTemplateById Method

Returns compoundItemTemplate by id or null if compoundItemTemplate with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICompoundItemTemplate TryGetCompoundItemTemplateById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ICompoundItemTemplate
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetConceptionById Method

IOperationServiceTryGetConceptionById Method

Returns conception by id or null if conception with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IConception TryGetConceptionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IConception
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDeliveryCancelCauseById Method

IOperationServiceTryGetDeliveryCancelCauseById Method

Returns deliveryCancelCause by id or null if deliveryCancelCause with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryCancelCause TryGetDeliveryCancelCauseById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDeliveryCancelCause
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDeliveryOrderById Method

IOperationServiceTryGetDeliveryOrderById Method

Returns deliveryOrder by id or null if deliveryOrder with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryOrder TryGetDeliveryOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDeliveryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDisabledSizesByProduct Method

IOperationServiceTryGetDisabledSizesByProduct Method

Returns disabledSizes of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductSize> TryGetDisabledSizesByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDiscountCardById Method

IOperationServiceTryGetDiscountCardById Method

Returns discountCard by id or null if discountCard with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountCard TryGetDiscountCardById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDiscountCard
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDiscountTypeById Method

IOperationServiceTryGetDiscountTypeById Method

Returns discountType by id or null if discountType with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountType TryGetDiscountTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IDiscountType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetDocumentPrinter Method

IOperationServiceTryGetDocumentPrinter Method

Try get document printer for specified restaurant section.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPrinterRef TryGetDocumentPrinter(
    IRestaurantSection section = null,
    bool checkIsConfigured = false
)

Parameters

section (Optional)
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection
Printer`s restaurant section. If section not specified uses default table`s section.
checkIsConfigured (Optional)
Type: SystemBoolean
If checkIsConfigured = true returns only configured printer.

Return Value

Type: IPrinterRef
Instance of printer or null if section does not contains document printer or document printer not configured (for checkIsConfigured = true).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetIncludedInMenuSectionsByProduct Method

IOperationServiceTryGetIncludedInMenuSectionsByProduct Method

Returns includedInMenuSections of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IRestaurantSection> TryGetIncludedInMenuSectionsByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IRestaurantSection
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetKitchenOrderById Method

IOperationServiceTryGetKitchenOrderById Method

Returns kitchenOrder by id or null if kitchenOrder with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IKitchenOrder TryGetKitchenOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IKitchenOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetLastChangedOrderTerminal Method

IOperationServiceTryGetLastChangedOrderTerminal Method

Returns termnal that changed order last time.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminal TryGetLastChangedOrderTerminal(
    IOrder order
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to check

Return Value

Type: ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetMarketingSourceById Method

IOperationServiceTryGetMarketingSourceById Method

Returns marketingSource by id or null if marketingSource with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IMarketingSource TryGetMarketingSourceById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IMarketingSource
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetOrderById Method

IOperationServiceTryGetOrderById Method

Returns order by id or null if order with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrder TryGetOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetOrderExternalDataByKey Method

IOperationServiceTryGetOrderExternalDataByKey Method

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string TryGetOrderExternalDataByKey(
    Guid orderId,
    string key
)

Parameters

orderId
Type: SystemGuid
key
Type: SystemString

Return Value

Type: String
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetOrderTypeById Method

IOperationServiceTryGetOrderTypeById Method

Returns orderType by id or null if orderType with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType TryGetOrderTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IOrderType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetParentByProduct Method

IOperationServiceTryGetParentByProduct Method

Returns parent of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup TryGetParentByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetParentByProductGroup Method

IOperationServiceTryGetParentByProductGroup Method

Returns parent of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup TryGetParentByProductGroup(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetPaymentTypeById Method

IOperationServiceTryGetPaymentTypeById Method

Returns paymentType by id or null if paymentType with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentType TryGetPaymentTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPaymentType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetPointOfSaleById Method

IOperationServiceTryGetPointOfSaleById Method

Returns pointOfSale by id or null if pointOfSale with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPointOfSale TryGetPointOfSaleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPointOfSale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetPreliminaryOrderById Method

IOperationServiceTryGetPreliminaryOrderById Method

Returns preliminaryOrder by id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPreliminaryOrder TryGetPreliminaryOrderById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPreliminaryOrder
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetPriceCategoryById Method

IOperationServiceTryGetPriceCategoryById Method

Returns priceCategory by id or null if priceCategory with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory TryGetPriceCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IPriceCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductById Method

IOperationServiceTryGetProductById Method

Returns product by id or null if product with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct TryGetProductById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProduct
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductCategoryById Method

IOperationServiceTryGetProductCategoryById Method

Returns productCategory by id or null if productCategory with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductCategory TryGetProductCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductGroupById Method

IOperationServiceTryGetProductGroupById Method

Returns productGroup by id or null if productGroup with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup TryGetProductGroupById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductGroup
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductGroupMenuImage Method

IOperationServiceTryGetProductGroupMenuImage Method

Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
byte[] TryGetProductGroupMenuImage(
    IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Product group to get menu image for.

Return Value

Type: Byte
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IProductGroupHasMenuImage
IProductGroupBackgroundColor
IProductGroupFontColor
OperationArgumentExtensionsTryGetProductGroupMenuImage(IProductGroup)


IOperationService.TryGetProductMenuImage Method

IOperationServiceTryGetProductMenuImage Method

Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
byte[] TryGetProductMenuImage(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get menu image for.

Return Value

Type: Byte
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IProductHasMenuImage
IProductBackgroundColor
IProductFontColor
OperationArgumentExtensionsTryGetProductMenuImage(IProduct)


IOperationService.TryGetProductScaleById Method

IOperationServiceTryGetProductScaleById Method

Returns productScale by id or null if productScale with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductScale TryGetProductScaleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductScale
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductSizeById Method

IOperationServiceTryGetProductSizeById Method

Returns productSize by id or null if productSize with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize TryGetProductSizeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductSize
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetProductStocksListById Method

IOperationServiceTryGetProductStocksListById Method

Returns productStocksList by id or null if productStocksList with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductStocksList TryGetProductStocksListById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IProductStocksList
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetReceiptChequePrinter Method

IOperationServiceTryGetReceiptChequePrinter Method

Try get receipt cheque printer for default cash register.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPrinterRef TryGetReceiptChequePrinter(
    bool checkIsConfigured = false
)

Parameters

checkIsConfigured (Optional)
Type: SystemBoolean
If checkIsConfigured = true returns only configured printer.

Return Value

Type: IPrinterRef
Instance of printer or null if receipt cheque printer not configured (for checkIsConfigured = true).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetRegionById Method

IOperationServiceTryGetRegionById Method

Returns region by id or null if region with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRegion TryGetRegionById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRegion
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetRemovalTypeById Method

IOperationServiceTryGetRemovalTypeById Method

Returns removalType by id or null if removalType with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRemovalType TryGetRemovalTypeById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRemovalType
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetReserveByExternalId Method

IOperationServiceTryGetReserveByExternalId Method

Returns reserve by its external id or null if reserve with specified external id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReserve TryGetReserveByExternalId(
    Guid externalId
)

Parameters

externalId
Type: SystemGuid
Reserve identifier from the external system.

Return Value

Type: IReserve
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IReserveExternalId


IOperationService.TryGetReserveById Method

IOperationServiceTryGetReserveById Method

Returns reserve by id or null if reserve with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReserve TryGetReserveById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IReserve
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetRoleById Method

IOperationServiceTryGetRoleById Method

Returns role by id or null if role with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRole TryGetRoleById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IRole
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetSectionSchemaByRestaurantSection Method

IOperationServiceTryGetSectionSchemaByRestaurantSection Method

Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ISectionSchema TryGetSectionSchemaByRestaurantSection(
    IRestaurantSection restaurantSection
)

Parameters

restaurantSection
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection

Return Value

Type: ISectionSchema
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetSelectiveDiscountItemSettings Method

IOperationServiceTryGetSelectiveDiscountItemSettings Method

Returns order items to which the specified selective discount item is applied or null if the discount item is applied to the whole order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ISelectiveDiscountItemSettings TryGetSelectiveDiscountItemSettings(
    IOrder Order,
    IDiscountItem DiscountItem
)

Parameters

Order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to get selective discount item settings from.
DiscountItem
Type: Resto.Front.Api.Data.OrdersIDiscountItem
Selective discount item.

Return Value

Type: ISelectiveDiscountItemSettings
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace
IDiscountTypeCanApplySelectively
IDiscountItemIsSelectivelyApplied


IOperationService.TryGetStickerPrinter Method

IOperationServiceTryGetStickerPrinter Method

Try get sticker printer for specified restaurant section.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPrinterRef TryGetStickerPrinter(
    IRestaurantSection section = null,
    bool checkIsConfigured = false
)

Parameters

section (Optional)
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection
Printer`s restaurant section. If section not specified uses default table`s section.
checkIsConfigured (Optional)
Type: SystemBoolean
If checkIsConfigured = true returns only configured printer.

Return Value

Type: IPrinterRef
Instance of printer or null if section does not contains sticker printer or sticker printer not configured (for checkIsConfigured = true).
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetStreetById Method

IOperationServiceTryGetStreetById Method

Returns street by id or null if street with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IStreet TryGetStreetById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IStreet
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetSurveyItemById Method

IOperationServiceTryGetSurveyItemById Method

Returns surveyItem by id or null if surveyItem with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ISurveyItem TryGetSurveyItemById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ISurveyItem
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetTableById Method

IOperationServiceTryGetTableById Method

Returns table by id or null if table with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITable TryGetTableById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITable
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetTaxCategoryById Method

IOperationServiceTryGetTaxCategoryById Method

Returns taxCategory by id or null if taxCategory with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITaxCategory TryGetTaxCategoryById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITaxCategory
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetTemplatedModifiersParamsByProduct Method

IOperationServiceTryGetTemplatedModifiersParamsByProduct Method

Returns templatedModifiersParams of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITemplatedModifierParams> TryGetTemplatedModifiersParamsByProduct(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList ITemplatedModifierParams
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetTerminalById Method

IOperationServiceTryGetTerminalById Method

Returns terminal by id or null if terminal with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminal TryGetTerminalById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: ITerminal
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.TryGetUserById Method

IOperationServiceTryGetUserById Method

Returns user by id or null if user with specified id doesn't exist.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser TryGetUserById(
    Guid id
)

Parameters

id
Type: SystemGuid

Return Value

Type: IUser
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IOperationService.UpdateDiscountCard Method

IOperationServiceUpdateDiscountCard Method

Updates an existing discount card.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountCard UpdateDiscountCard(
    Guid id,
    string ownerName,
    IPriceCategory priceCategory,
    IDiscountType cardDiscountType
)

Parameters

id
Type: SystemGuid
Id of a discount card to update.
ownerName
Type: SystemString
New owner name for a discount card.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
New price category for a discount card. Cannot be combined with cardDiscountType.
cardDiscountType
Type: Resto.Front.Api.Data.OrdersIDiscountType
New discount type for a discount card. Cannot be combined with priceCategory.

Return Value

Type: IDiscountCard
See Also

Reference

IOperationService Interface
Resto.Front.Api Namespace


IPaymentDataContext Interface

Helper to work with plugin saved data in iiko storage.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentDataContext

The IPaymentDataContext type exposes the following members.

Methods
 | Name | Description
Public method | GetCustomData | Method to get your custom data from iiko storage.
Public method | GetRollbackData | Method to get your data from iiko storage.
Public method | SetCustomData | Method to set your custom data to store in iiko storage.
Public method | SetInfoForReports | Method to set card number and card type to display in iiko reports. Data will be saved on disk after successful payment.
Public method | SetRollbackData | Method to set your data to store in iiko storage. Data will be saved on disk after successful payment.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCustomDataT | Method to get your custom data from iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | GetRollbackDataT | Method to get your rollback data from iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | SetCustomDataT | Method to set your custom data to store in iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | SetRollbackDataT | Method to set your rollback data to store in iiko storage. Data will be saved on disk after successful payment. (Defined by PaymentDataContextExtensions.)
Top
See Also

Reference

Resto.Front.Api Namespace


IPaymentDataContext Methods

The IPaymentDataContext type exposes the following members.

Methods
 | Name | Description
Public method | GetCustomData | Method to get your custom data from iiko storage.
Public method | GetRollbackData | Method to get your data from iiko storage.
Public method | SetCustomData | Method to set your custom data to store in iiko storage.
Public method | SetInfoForReports | Method to set card number and card type to display in iiko reports. Data will be saved on disk after successful payment.
Public method | SetRollbackData | Method to set your data to store in iiko storage. Data will be saved on disk after successful payment.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCustomDataT | Method to get your custom data from iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | GetRollbackDataT | Method to get your rollback data from iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | SetCustomDataT | Method to set your custom data to store in iiko storage. (Defined by PaymentDataContextExtensions.)
Public Extension Method | SetRollbackDataT | Method to set your rollback data to store in iiko storage. Data will be saved on disk after successful payment. (Defined by PaymentDataContextExtensions.)
Top
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentDataContext.GetCustomData Method

IPaymentDataContextGetCustomData Method

Method to get your custom data from iiko storage.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetCustomData()

Return Value

Type: String
Data that you previosly stored.
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentDataContext.GetRollbackData Method

IPaymentDataContextGetRollbackData Method

Method to get your data from iiko storage.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetRollbackData()

Return Value

Type: String
Data that you previosly stored.
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentDataContext.SetCustomData Method

IPaymentDataContextSetCustomData Method

Method to set your custom data to store in iiko storage.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetCustomData(
    string serializedData
)

Parameters

serializedData
Type: SystemString
Your custom data. Store any additional data here. Max serialized to string data length is MaxExternalPaymentItemDataLength
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentDataContext.SetInfoForReports Method

IPaymentDataContextSetInfoForReports Method

Method to set card number and card type to display in iiko reports. Data will be saved on disk after successful payment.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetInfoForReports(
    string cardNumber,
    string cardType
)

Parameters

cardNumber
Type: SystemString
cardType
Type: SystemString
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentDataContext.SetRollbackData Method

IPaymentDataContextSetRollbackData Method

Method to set your data to store in iiko storage. Data will be saved on disk after successful payment.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetRollbackData(
    string serializedData
)

Parameters

serializedData
Type: SystemString
Your data. Please save only data that you may need on operation rollback. Max serialized to string data length is MaxExternalPaymentItemDataLength
See Also

Reference

IPaymentDataContext Interface
Resto.Front.Api Namespace


IPaymentProcessor Interface

Common interface for payment front plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentProcessor

The IPaymentProcessor type exposes the following members.

Properties
 | Name | Description
Public property | PaymentSystemKey | Key for matching the payment type to the payment system.
Public property | PaymentSystemName | Localized payment system's title that will be used in UI.
Top
Methods
 | Name | Description
Public method | CanPaySilently | Whether to perform payment operation silently.
Public method | CollectData | Perform data collect operation on payment item selected.
Public method | EmergencyCancelPayment | Perform emergency cancel payment operation.
Public method | EmergencyCancelPaymentSilently | Perform silent emergency cancel payment operation.
Public method | OnPaymentAdded | Perform order edit operation after payment is added to order (on preliminary payments page or on payment page).
Public method | OnPreliminaryPaymentEditing | Perform operations when preliminary payment is going to be edited. If method throws exception, payment is removed from order.
Public method | Pay | Perform payment operation.
Public method | PaySilently | Perform silent payment operation.
Public method | ReturnPayment | Perform return payment operation.
Public method | ReturnPaymentWithoutOrder | Perform return payment sum without iikoFront order.
Top
See Also

Reference

Resto.Front.Api Namespace
IOperationServiceRegisterPaymentSystem(IPaymentProcessor, Boolean)


IPaymentProcessor Properties

The IPaymentProcessor type exposes the following members.

Properties
 | Name | Description
Public property | PaymentSystemKey | Key for matching the payment type to the payment system.
Public property | PaymentSystemName | Localized payment system's title that will be used in UI.
Top
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.PaymentSystemKey Property

IPaymentProcessorPaymentSystemKey Property

Key for matching the payment type to the payment system.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string PaymentSystemKey { get; }

Property Value

Type: String
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace
IOperationServiceGetPaymentSystemName(IPaymentType)


IPaymentProcessor.PaymentSystemName Property

IPaymentProcessorPaymentSystemName Property

Localized payment system's title that will be used in UI.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string PaymentSystemName { get; }

Property Value

Type: String
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor Methods

The IPaymentProcessor type exposes the following members.

Methods
 | Name | Description
Public method | CanPaySilently | Whether to perform payment operation silently.
Public method | CollectData | Perform data collect operation on payment item selected.
Public method | EmergencyCancelPayment | Perform emergency cancel payment operation.
Public method | EmergencyCancelPaymentSilently | Perform silent emergency cancel payment operation.
Public method | OnPaymentAdded | Perform order edit operation after payment is added to order (on preliminary payments page or on payment page).
Public method | OnPreliminaryPaymentEditing | Perform operations when preliminary payment is going to be edited. If method throws exception, payment is removed from order.
Public method | Pay | Perform payment operation.
Public method | PaySilently | Perform silent payment operation.
Public method | ReturnPayment | Perform return payment operation.
Public method | ReturnPaymentWithoutOrder | Perform return payment sum without iikoFront order.
Top
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.CanPaySilently Method

IPaymentProcessorCanPaySilently Method

Whether to perform payment operation silently.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanPaySilently(
    decimal sum,
    Guid? orderId,
    Guid paymentTypeId,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to return.
orderId
Type: SystemNullable Guid
Order Id.
paymentTypeId
Type: SystemGuid
Payment type Id.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.

Return Value

Type: Boolean
If the payment operation must be processed silently then return true. Otherwise return false.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.CollectData Method

IPaymentProcessorCollectData Method

Perform data collect operation on payment item selected.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CollectData(
    Guid orderId,
    Guid paymentTypeId,
    IUser cashier,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

orderId
Type: SystemGuid
Order Id.
paymentTypeId
Type: SystemGuid
Payment type Id.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinterObject to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManagerObject to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContextObject to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions was not successful.
Remarks
Called when plug-in payment item is going to be added to the order.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.EmergencyCancelPayment Method

IPaymentProcessorEmergencyCancelPayment Method

Perform emergency cancel payment operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void EmergencyCancelPayment(
    decimal sum,
    Guid? orderId,
    Guid paymentTypeId,
    Guid transactionId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to return.
orderId
Type: SystemNullable Guid
Order Id.
paymentTypeId
Type: SystemGuid
Payment type Id.
transactionId
Type: SystemGuid
Transaction Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that cancel payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.EmergencyCancelPaymentSilently Method

IPaymentProcessorEmergencyCancelPaymentSilently Method

Perform silent emergency cancel payment operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void EmergencyCancelPaymentSilently(
    decimal sum,
    Guid? orderId,
    Guid paymentTypeId,
    Guid transactionId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IReceiptPrinter printer,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to return.
orderId
Type: SystemNullable Guid
Order Id.
paymentTypeId
Type: SystemGuid
Payment type Id.
transactionId
Type: SystemGuid
Transaction Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that cancel payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.OnPaymentAdded Method

IPaymentProcessorOnPaymentAdded Method

Perform order edit operation after payment is added to order (on preliminary payments page or on payment page).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void OnPaymentAdded(
    IOrder order,
    IPaymentItem paymentItem,
    IUser cashier,
    IOperationService operationService,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Added payment item.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
operationService
Type: Resto.Front.ApiIOperationService
Allows to edit entities within this method. Should not be used after method returns.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions were cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions were not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.OnPreliminaryPaymentEditing Method

IPaymentProcessorOnPreliminaryPaymentEditing Method

Perform operations when preliminary payment is going to be edited. If method throws exception, payment is removed from order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool OnPreliminaryPaymentEditing(
    IOrder order,
    IPaymentItem paymentItem,
    IUser cashier,
    IOperationService operationService,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

order
Type: Resto.Front.Api.Data.OrdersIOrder
Order.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
operationService
Type: Resto.Front.ApiIOperationService
Allows to edit entities within this method. Should not be used after method returns.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.

Return Value

Type: Boolean
Whether standard numpad is active after method ends. If new sum is set in action and no further edit is considered, return false. Otherwise return true to enable editing sum via numbad.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions were cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions were not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.Pay Method

IPaymentProcessorPay Method

Perform payment operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Pay(
    decimal sum,
    IOrder order,
    IPaymentItem paymentItem,
    Guid transactionId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IOperationService operationService,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to pay.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item.
transactionId
Type: SystemGuid
Transaction Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
operationService
Type: Resto.Front.ApiIOperationService
Allows to edit entities within this method. Should not be used after method returns.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.PaySilently Method

IPaymentProcessorPaySilently Method

Perform silent payment operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PaySilently(
    decimal sum,
    IOrder order,
    IPaymentItem paymentItem,
    Guid transactionId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IReceiptPrinter printer,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to pay.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item.
transactionId
Type: SystemGuid
Transaction Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.ReturnPayment Method

IPaymentProcessorReturnPayment Method

Perform return payment operation.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ReturnPayment(
    decimal sum,
    Guid? orderId,
    Guid paymentTypeId,
    Guid transactionId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IReceiptPrinter printer,
    IViewManager viewManager,
    IPaymentDataContext context
)

Parameters

sum
Type: SystemDecimal
Sum to return.
orderId
Type: SystemNullable Guid
Order Id.
paymentTypeId
Type: SystemGuid
Payment type Id.
transactionId
Type: SystemGuid
Transaction Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
context
Type: Resto.Front.ApiIPaymentDataContext
IPaymentDataContext object to work with plugin saved data in iiko storage.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that return payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPaymentProcessor.ReturnPaymentWithoutOrder Method

IPaymentProcessorReturnPaymentWithoutOrder Method

Perform return payment sum without iikoFront order.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ReturnPaymentWithoutOrder(
    decimal sum,
    Guid? orderId,
    Guid paymentTypeId,
    IPointOfSale pointOfSale,
    IUser cashier,
    IReceiptPrinter printer,
    IViewManager viewManager
)

Parameters

sum
Type: SystemDecimal
Sum to return.
orderId
Type: SystemNullable Guid
When returning products from a past order, this parameter contains id of that order. If returning products are not from a past order, but just arbitrary products selected by user, this parameter is null.
paymentTypeId
Type: SystemGuid
Payment type Id.
pointOfSale
Type: Resto.Front.Api.Data.OrganizationIPointOfSale
Point of sale.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
User handling payments and receipts.
printer
Type: Resto.Front.ApiIReceiptPrinter
IReceiptPrinter object to perform print actions. Should not be used after method returns.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
Exceptions
Exception | Condition
PaymentActionCancelledException | Exception to notify that payment actions was cancelled with no message shown.
PaymentActionFailedException | Exception to notify that cancel payment actions was not successful.
See Also

Reference

IPaymentProcessor Interface
Resto.Front.Api Namespace


IPluginIntegrationService Interface

Service provides integration features.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPluginIntegrationService

The IPluginIntegrationService type exposes the following members.

Methods
 | Name | Description
Public method | GetApplicationVersion | Gets version of the iikoFront application.
Public method | GetConfigsDirectoryPath | Gets path to the directory where plugin should store it's configuration files (not a data).
Public method | GetDataStorageDirectoryPath | Gets path to the directory where plugin should store it's data.
Public method | GetPaymentProcessorSettingsKey | Get PluginKey to use with settings of payment processor.
Public method | GetPluginSettings | Gets plugin settings by specified plugin key and bound entity id.
Public method | GetSupportedApiVersions | Get a list of API version names, which are supported by the iikoFront application.
Public method | UpdatePluginSettings | Updates plugin settings. Makes a call to iikoRMS Server, so it should be available.
Top
See Also

Reference

Resto.Front.Api Namespace


IPluginIntegrationService Methods

The IPluginIntegrationService type exposes the following members.

Methods
 | Name | Description
Public method | GetApplicationVersion | Gets version of the iikoFront application.
Public method | GetConfigsDirectoryPath | Gets path to the directory where plugin should store it's configuration files (not a data).
Public method | GetDataStorageDirectoryPath | Gets path to the directory where plugin should store it's data.
Public method | GetPaymentProcessorSettingsKey | Get PluginKey to use with settings of payment processor.
Public method | GetPluginSettings | Gets plugin settings by specified plugin key and bound entity id.
Public method | GetSupportedApiVersions | Get a list of API version names, which are supported by the iikoFront application.
Public method | UpdatePluginSettings | Updates plugin settings. Makes a call to iikoRMS Server, so it should be available.
Top
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.GetApplicationVersion Method

IPluginIntegrationServiceGetApplicationVersion Method

Gets version of the iikoFront application.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetApplicationVersion()

Return Value

Type: String
A string containing the application version.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.GetConfigsDirectoryPath Method

IPluginIntegrationServiceGetConfigsDirectoryPath Method

Gets path to the directory where plugin should store it's configuration files (not a data).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetConfigsDirectoryPath()

Return Value

Type: String
Remarks
Config files will not be deleted during iikoFront app data reset.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.GetDataStorageDirectoryPath Method

IPluginIntegrationServiceGetDataStorageDirectoryPath Method

Gets path to the directory where plugin should store it's data.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GetDataStorageDirectoryPath()

Return Value

Type: String
Remarks
Contents of that directory will automatically be zipped and deleted in case if iikoFront app has to reset all it's data and start with a clean state. Put here things that is related to iikoFront data.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.GetPaymentProcessorSettingsKey Method

IPluginIntegrationServiceGetPaymentProcessorSettingsKey Method

Get PluginKey to use with settings of payment processor.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid GetPaymentProcessorSettingsKey(
    IPaymentProcessor processor
)

Parameters

processor
Type: Resto.Front.ApiIPaymentProcessor
Payment processor.

Return Value

Type: Guid
Key.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace
Resto.Front.Api.Data.SettingsIPluginSettings
IPluginSettingsPluginKey


IPluginIntegrationService.GetPluginSettings Method

IPluginIntegrationServiceGetPluginSettings Method

Gets plugin settings by specified plugin key and bound entity id.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPluginSettings GetPluginSettings(
    Guid pluginKey,
    Guid? boundEntityId
)

Parameters

pluginKey
Type: SystemGuid
Plugin key, identifying owner of settings.
boundEntityId
Type: SystemNullable Guid
Identifier of iikoRMS entity that is bound to settings.

Return Value

Type: IPluginSettings
Plugin settings or null if there is no settings associated with plugin key and entity.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.GetSupportedApiVersions Method

IPluginIntegrationServiceGetSupportedApiVersions Method

Get a list of API version names, which are supported by the iikoFront application.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<string> GetSupportedApiVersions(
    bool includePrerelease
)

Parameters

includePrerelease
Type: SystemBoolean
Whether to include prerelease versions. true — all supported API versions will be returned, false — only released API versions will be returned. Released API version works identically on each iikoFront app version (GetApplicationVersion) which supports that API version, while prerelease versions are subject to change and may be incompatible between iikoFront app versions.

Return Value

Type: IReadOnlyList String
List of supported API versions.
Remarks
Can be used by meta-plugins which deal with other plugins.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IPluginIntegrationService.UpdatePluginSettings Method

IPluginIntegrationServiceUpdatePluginSettings Method

Updates plugin settings. Makes a call to iikoRMS Server, so it should be available.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void UpdatePluginSettings(
    List<IPluginSettings> updatedSettings
)

Parameters

updatedSettings
Type: System.Collections.GenericList IPluginSettings
New values of settings that should be stored.
See Also

Reference

IPluginIntegrationService Interface
Resto.Front.Api Namespace


IReceiptPrinter Interface

Instance to perform print actions. Should be used only when it comes like function parameter.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IReceiptPrinter

The IReceiptPrinter type exposes the following members.

Methods
 | Name | Description
Public method | Print | Printing ReceiptSlip object on receipt printer.
Top
See Also

Reference

Resto.Front.Api Namespace


IReceiptPrinter Methods

The IReceiptPrinter type exposes the following members.

Methods
 | Name | Description
Public method | Print | Printing ReceiptSlip object on receipt printer.
Top
See Also

Reference

IReceiptPrinter Interface
Resto.Front.Api Namespace


IReceiptPrinter.Print Method

IReceiptPrinterPrint Method

Printing ReceiptSlip object on receipt printer.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Print(
    ReceiptSlip slip
)

Parameters

slip
Type: Resto.Front.Api.Data.ChequesReceiptSlip
See Also

Reference

IReceiptPrinter Interface
Resto.Front.Api Namespace


OperationArgumentExtensions Class

Inheritance Hierarchy
SystemObject
Resto.Front.ApiOperationArgumentExtensions

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class OperationArgumentExtensions

The OperationArgumentExtensions type exposes the following members.

Methods
Name | Description
GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetGroupModifiers | Returns group modifiers of the specified product.
GetSimpleModifiers | Returns simple modifiers of the specified product.
GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetUserRoles | Returns roles available for the user.
TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
Top
See Also

Reference

Resto.Front.Api Namespace


OperationArgumentExtensions Methods

The OperationArgumentExtensions type exposes the following members.

Methods
Name | Description
GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetGroupModifiers | Returns group modifiers of the specified product.
GetSimpleModifiers | Returns simple modifiers of the specified product.
GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.
GetUserRoles | Returns roles available for the user.
TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
Top
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetCommonGroupModifiers Method

OperationArgumentExtensionsGetCommonGroupModifiers Method

Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IGroupModifier> GetCommonGroupModifiers(
    this ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get common modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICompoundItemTemplate. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetCommonSimpleModifiers Method

OperationArgumentExtensionsGetCommonSimpleModifiers Method

Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<ISimpleModifier> GetCommonSimpleModifiers(
    this ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get common modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICompoundItemTemplate. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetGroupModifiers Method

OperationArgumentExtensionsGetGroupModifiers Method

Returns group modifiers of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IGroupModifier> GetGroupModifiers(
    this IProduct product,
    IPriceCategory priceCategory
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetSimpleModifiers Method

OperationArgumentExtensionsGetSimpleModifiers Method

Returns simple modifiers of the specified product.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<ISimpleModifier> GetSimpleModifiers(
    this IProduct product,
    IPriceCategory priceCategory
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetSplittableGroupModifiers Method

OperationArgumentExtensionsGetSplittableGroupModifiers Method

Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IGroupModifier> GetSplittableGroupModifiers(
    this ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get splittable modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList IGroupModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICompoundItemTemplate. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetSplittableSimpleModifiers Method

OperationArgumentExtensionsGetSplittableSimpleModifiers Method

Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<ISimpleModifier> GetSplittableSimpleModifiers(
    this ICompoundItemTemplate compoundItemTemplate,
    IPriceCategory priceCategory
)

Parameters

compoundItemTemplate
Type: Resto.Front.Api.Data.AssortmentICompoundItemTemplate
Compound item template to get splittable modifiers for.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
Price category to check menu inclusion according to.

Return Value

Type: IReadOnlyList ISimpleModifier

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICompoundItemTemplate. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.GetUserRoles Method

OperationArgumentExtensionsGetUserRoles Method

Returns roles available for the user.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IRole> GetUserRoles(
    this IUser user
)

Parameters

user
Type: Resto.Front.Api.Data.SecurityIUser
User to get his roles.

Return Value

Type: IReadOnlyList IRole

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IUser. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.TryGetProductGroupMenuImage Method

OperationArgumentExtensionsTryGetProductGroupMenuImage Method

Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static byte[] TryGetProductGroupMenuImage(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Product group to get menu image for.

Return Value

Type: Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


OperationArgumentExtensions.TryGetProductMenuImage Method

OperationArgumentExtensionsTryGetProductMenuImage Method

Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static byte[] TryGetProductMenuImage(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get menu image for.

Return Value

Type: Byte

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

OperationArgumentExtensions Class
Resto.Front.Api Namespace


PluginContext Class

Provides access to api services.
Inheritance Hierarchy
SystemObject
Resto.Front.ApiPluginContext

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class PluginContext

The PluginContext type exposes the following members.

Properties
Name | Description
Integration | Provides integration features.
Licensing | Provides licensing service.
Log | Provides logger. Messages sent to the logger will be written to the log file and optionally to the console or other standard output (latter is available for debug mode).
Notifications | Provides notifications.
Operations | Provides operations.
Services | Provider of all services which are available for current plugin.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Fills the context with Api services on plugin startup. This method isn't intended to be called from plugin.
 | Shutdown | Gracefully terminates current host process. Plugin may call this method to stop working.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Uninitialize | Resets the context to uninitialized state. This method isn't intended to be called from plugin.
Top
See Also

Reference

Resto.Front.Api Namespace


PluginContext Properties

The PluginContext type exposes the following members.

Properties
Name | Description
Integration | Provides integration features.
Licensing | Provides licensing service.
Log | Provides logger. Messages sent to the logger will be written to the log file and optionally to the console or other standard output (latter is available for debug mode).
Notifications | Provides notifications.
Operations | Provides operations.
Services | Provider of all services which are available for current plugin.
Top
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Integration Property

PluginContextIntegration Property

Provides integration features.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPluginIntegrationService Integration { get; }

Property Value

Type: IPluginIntegrationService
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Licensing Property

PluginContextLicensing Property

Provides licensing service.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static ILicensingService Licensing { get; }

Property Value

Type: ILicensingService
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Log Property

PluginContextLog Property

Provides logger. Messages sent to the logger will be written to the log file and optionally to the console or other standard output (latter is available for debug mode).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static ILog Log { get; }

Property Value

Type: ILog
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Notifications Property

PluginContextNotifications Property

Provides notifications.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static INotificationService Notifications { get; }

Property Value

Type: INotificationService
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Operations Property

PluginContextOperations Property

Provides operations.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOperationService Operations { get; }

Property Value

Type: IOperationService
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Services Property

PluginContextServices Property

Provider of all services which are available for current plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IServiceProvider Services { get; }

Property Value

Type: IServiceProvider
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext Methods

The PluginContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize | Fills the context with Api services on plugin startup. This method isn't intended to be called from plugin.
 | Shutdown | Gracefully terminates current host process. Plugin may call this method to stop working.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Uninitialize | Resets the context to uninitialized state. This method isn't intended to be called from plugin.
Top
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Initialize Method

PluginContextInitialize Method

Fills the context with Api services on plugin startup. This method isn't intended to be called from plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void Initialize(
    IServiceProvider services,
    Action shutdownSignal,
    ILog log
)

Parameters

services
Type: SystemIServiceProvider
shutdownSignal
Type: SystemAction
log
Type: Resto.Front.ApiILog
Remarks
Primarily this method is used by Api infrastructure, but it also can be used in unit tests for checking plugin's code. When writing tests against code which is using static properties of PluginContext, you can initialize the context with dummy (mocked) services. Services are retrieved from the provider when corresponding static properties are called, so for testing purposes you may provide minimum set of services which are actually used in the code being tested.
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace
PluginContextUninitialize


PluginContext.Shutdown Method

PluginContextShutdown Method

Gracefully terminates current host process. Plugin may call this method to stop working.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void Shutdown(
    string reason = null
)

Parameters

reason (Optional)
Type: SystemString
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace


PluginContext.Uninitialize Method

PluginContextUninitialize Method

Resets the context to uninitialized state. This method isn't intended to be called from plugin.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void Uninitialize()
Remarks
Use this method in unit tests to reset the context and re-initialize with appropriate services for each test fixture.
See Also

Reference

PluginContext Class
Resto.Front.Api Namespace
PluginContextInitialize(IServiceProvider, Action, ILog)


VoidValue Structure

Represents dummy value for IObservableT where notification itself is the only purpose to have such sequence and notification argument doesn't have any meaning. It's something like Void-method in the Rx-world.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public struct VoidValue : IEquatable<VoidValue>

The VoidValue type exposes the following members.

Properties
Name | Description
Default | Just a syntactic replacement for default(VoidValue).
Top
Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VoidValue) | Always true.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
Equality | Always true.
Inequality | Always false.
Top
See Also

Reference

Resto.Front.Api Namespace


VoidValue Properties

The VoidValue type exposes the following members.

Properties
Name | Description
Default | Just a syntactic replacement for default(VoidValue).
Top
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue.Default Property

VoidValueDefault Property

Just a syntactic replacement for default(VoidValue).

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static VoidValue Default { get; }

Property Value

Type: VoidValue
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue Methods

The VoidValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VoidValue) | Always true.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue.Equals Method

VoidValueEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(VoidValue) | Always true.
Top
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue.Equals Method (Object)

VoidValueEquals Method (Object)

Indicates whether this instance and a specified object are equal.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current instance.

Return Value

Type: Boolean
if obj and this instance are the same type and represent the same value; otherwise, .
See Also

Reference

VoidValue Structure
Equals Overload
Resto.Front.Api Namespace


VoidValue.Equals Method (VoidValue)

VoidValueEquals Method (VoidValue)

Always true.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    VoidValue other
)

Parameters

other
Type: Resto.Front.ApiVoidValue

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

VoidValue Structure
Equals Overload
Resto.Front.Api Namespace


VoidValue.GetHashCode Method

VoidValueGetHashCode Method

Returns the hash code for this instance.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue Operators

The VoidValue type exposes the following members.

Operators
Name | Description
Equality | Always true.
Inequality | Always false.
Top
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue.Equality Operator

VoidValueEquality Operator

Always true.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static bool operator ==(
    VoidValue first,
    VoidValue second
)

Parameters

first
Type: Resto.Front.ApiVoidValue
second
Type: Resto.Front.ApiVoidValue

Return Value

Type: Boolean
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


VoidValue.Inequality Operator

VoidValueInequality Operator

Always false.

Namespace: Resto.Front.Api
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static bool operator !=(
    VoidValue first,
    VoidValue second
)

Parameters

first
Type: Resto.Front.ApiVoidValue
second
Type: Resto.Front.ApiVoidValue

Return Value

Type: Boolean
See Also

Reference

VoidValue Structure
Resto.Front.Api Namespace


Resto.Front.Api.Attributes Namespace

Classes
Class | Description
PluginLicenseModuleIdAttribute | Specifies plugin's licensable module identifier.


PluginLicenseModuleIdAttribute Class

Specifies plugin's licensable module identifier.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.AttributesPluginLicenseModuleIdAttribute

Namespace: Resto.Front.Api.Attributes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class PluginLicenseModuleIdAttribute : Attribute

The PluginLicenseModuleIdAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PluginLicenseModuleIdAttribute | Initializes a new instance of the PluginLicenseModuleIdAttribute class.
Top
Properties
 | Name | Description
Public property | ModuleId | Licensable module identifier.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
If plugin is intended to be distributed by “license per plugin” scheme, contact iiko to register licensable module for your plugin, then apply this attribute to plugin with received module identifier. Each plugin instance will require another one license slot, so total slots number for given license module should correspond to count of simultaneously running iikoFronts with your plugin installed to.
Examples
Copy
[PluginLicenseModuleId(42)]
public sealed class MyPlugin : IFrontPlugin
{ ... }
See Also

Reference

Resto.Front.Api.Attributes Namespace


PluginLicenseModuleIdAttribute Constructor

Initializes a new instance of the PluginLicenseModuleIdAttribute class.

Namespace: Resto.Front.Api.Attributes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PluginLicenseModuleIdAttribute(
    int moduleId
)

Parameters

moduleId
Type: SystemInt32
The licensable module identifier.
See Also

Reference

PluginLicenseModuleIdAttribute Class
Resto.Front.Api.Attributes Namespace


PluginLicenseModuleIdAttribute Properties

The PluginLicenseModuleIdAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ModuleId | Licensable module identifier.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PluginLicenseModuleIdAttribute Class
Resto.Front.Api.Attributes Namespace


PluginLicenseModuleIdAttribute.ModuleId Property

PluginLicenseModuleIdAttributeModuleId Property

Licensable module identifier.

Namespace: Resto.Front.Api.Attributes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int ModuleId { get; }

Property Value

Type: Int32
See Also

Reference

PluginLicenseModuleIdAttribute Class
Resto.Front.Api.Attributes Namespace


PluginLicenseModuleIdAttribute Methods

The PluginLicenseModuleIdAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PluginLicenseModuleIdAttribute Class
Resto.Front.Api.Attributes Namespace


Resto.Front.Api.Attributes.JetBrains Namespace

Classes
 | Class | Description
Public class | AspChildControlTypeAttribute |
Public class | AspDataFieldAttribute |
Public class | AspDataFieldsAttribute |
Public class | AspMethodPropertyAttribute |
Public class | AspMvcActionAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC action. If applied to a method, the MVC action name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String).
 | AspMvcActionSelectorAttribute | ASP.NET MVC attribute. When applied to a parameter of an attribute, indicates that this parameter is an MVC action name.
Public class | AspMvcAreaAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC area. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String).
Public class | AspMvcAreaMasterLocationFormatAttribute |
Public class | AspMvcAreaPartialViewLocationFormatAttribute |
Public class | AspMvcAreaViewLocationFormatAttribute |
Public class | AspMvcControllerAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC controller. If applied to a method, the MVC controller name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String, String).
Public class | AspMvcDisplayTemplateAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC display template. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.DisplayExtensions.DisplayForModel(HtmlHelper, String).
Public class | AspMvcEditorTemplateAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC editor template. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.EditorExtensions.EditorForModel(HtmlHelper, String).
Public class | AspMvcMasterAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC Master. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(String, String).
Public class | AspMvcMasterLocationFormatAttribute |
Public class | AspMvcModelTypeAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC model type. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(String, Object).
Public class | AspMvcPartialViewAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC partial view. If applied to a method, the MVC partial view name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.RenderPartialExtensions.RenderPartial(HtmlHelper, String).
Public class | AspMvcPartialViewLocationFormatAttribute |
Public class | AspMvcSuppressViewErrorAttribute | ASP.NET MVC attribute. Allows disabling inspections for MVC views within a class or a method.
Public class | AspMvcTemplateAttribute | ASP.NET MVC attribute. Indicates that a parameter is an MVC template. Use this attribute for custom wrappers similar to System.ComponentModel.DataAnnotations.UIHintAttribute(System.String).
Public class | AspMvcViewAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component. If applied to a method, the MVC view name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(Object).
Public class | AspMvcViewComponentAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component name.
Public class | AspMvcViewComponentViewAttribute | ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component view. If applied to a method, the MVC view component view name is default.
Public class | AspMvcViewLocationFormatAttribute |
Public class | AspRequiredAttributeAttribute |
Public class | AspTypePropertyAttribute |
Public class | AssertionConditionAttribute | Indicates the condition parameter of the assertion method. The method itself should be marked by AssertionMethodAttribute attribute. The mandatory argument of the attribute is the assertion type.
Public class | AssertionMethodAttribute | Indicates that the marked method is assertion method, i.e. it halts control flow if one of the conditions is satisfied. To set the condition, mark one of the parameters with AssertionConditionAttribute attribute.
 | BaseTypeRequiredAttribute | When applied to a target attribute, specifies a requirement for any type marked with the target attribute to implement or inherit specific type or types.
 | CanBeNullAttribute | Indicates that the value of the marked element could be null sometimes, so the check for null is necessary before its usage.
 | CannotApplyEqualityOperatorAttribute | Indicates that the value of the marked type (or its derivatives) cannot be compared using '==' or '!=' operators and Equals() should be used instead. However, using '==' or '!=' for comparison with null is always permitted.
Public class | CollectionAccessAttribute | Indicates how method, constructor invocation or property access over collection type affects content of the collection.
Public class | ContractAnnotationAttribute | Describes dependency between method input and output.
Public class | HtmlAttributeValueAttribute |
Public class | HtmlElementAttributesAttribute |
Public class | InstantHandleAttribute | Tells code analysis engine if the parameter is completely handled when the invoked method is on stack. If the parameter is a delegate, indicates that delegate is executed while the method is executed. If the parameter is an enumerable, indicates that it is enumerated while the method is executed.
 | InvokerParameterNameAttribute | Indicates that the function argument should be string literal and match one of the parameters of the caller function. For example, ReSharper annotates the parameter of ArgumentNullException.
Public class | ItemCanBeNullAttribute | Can be appplied to symbols of types derived from IEnumerable as well as to symbols of Task and Lazy classes to indicate that the value of a collection item, of the Task.Result property or of the Lazy.Value property can be null.
Public class | ItemNotNullAttribute | Can be appplied to symbols of types derived from IEnumerable as well as to symbols of Task and Lazy classes to indicate that the value of a collection item, of the Task.Result property or of the Lazy.Value property can never be null.
Public class | LinqTunnelAttribute | Indicates that method is pure LINQ method, with postponed enumeration (like Enumerable.Select, .Where). This annotation allows inference of [InstantHandle] annotation for parameters of delegate type by analyzing LINQ method chains.
 | LocalizationRequiredAttribute | Indicates that marked element should be localized or not.
 | MacroAttribute | Allows specifying a macro for a parameter of a source template.
Public class | MeansImplicitUseAttribute | Should be used on attributes and causes ReSharper to not mark symbols marked with such attributes as unused (as well as by other usage inspections)
Public class | MustUseReturnValueAttribute | Indicates that the return value of method invocation must be used.
Public class | NoEnumerationAttribute | Indicates that IEnumerable, passed as parameter, is not enumerated.
Public class | NoReorderAttribute | Prevents the Member Reordering feature from tossing members of the marked class.
 | NotifyPropertyChangedInvocatorAttribute | Indicates that the method is contained in a type that implements System.ComponentModel.INotifyPropertyChanged interface and this method is used to notify that some property value changed.
 | NotNullAttribute | Indicates that the value of the marked element could never be null.
Public class | PathReferenceAttribute | Indicates that a parameter is a path to a file or a folder within a web project. Path can be relative or absolute, starting from web root (~).
 | ProvidesContextAttribute | Indicates the type member or parameter of some type, that should be used instead of all other ways to get the value that type. This annotation is useful when you have some "context" value evaluated and stored somewhere, meaning that all other ways to get this value must be consolidated with existing one.
Public class | PublicAPIAttribute | This attribute is intended to mark publicly available API which should not be removed and so is treated as used.
 | PureAttribute | Indicates that a method does not make any observable state changes. The same as System.Diagnostics.Contracts.PureAttribute.
Public class | RazorDirectiveAttribute |
Public class | RazorHelperCommonAttribute |
Public class | RazorImportNamespaceAttribute |
Public class | RazorInjectionAttribute |
Public class | RazorLayoutAttribute |
Public class | RazorPageBaseTypeAttribute |
Public class | RazorSectionAttribute | Razor attribute. Indicates that a parameter or a method is a Razor section. Use this attribute for custom wrappers similar to System.Web.WebPages.WebPageBase.RenderSection(String).
Public class | RazorWriteLiteralMethodAttribute |
Public class | RazorWriteMethodAttribute |
Public class | RazorWriteMethodParameterAttribute |
Public class | RegexPatternAttribute | Indicates that parameter is regular expression pattern.
 | SourceTemplateAttribute | An extension method marked with this attribute is processed by ReSharper code completion as a 'Source Template'. When extension method is completed over some expression, it's source code is automatically expanded like a template at call site.
 | StringFormatMethodAttribute | Indicates that the marked method builds string by format pattern and (optional) arguments. Parameter, which contains format string, should be given in constructor. The format string should be in Format(IFormatProvider, String, Object)-like form.
Public class | TerminatesProgramAttribute | Obsolete. Indicates that the marked method unconditionally terminates control flow execution. For example, it could unconditionally throw exception.
Public class | UsedImplicitlyAttribute | Indicates that the marked symbol is used implicitly (e.g. via reflection, in external library), so this symbol will not be marked as unused (as well as by other usage inspections).
Public class | ValueProviderAttribute | For a parameter that is expected to be one of the limited set of values. Specify fields of which type should be used as values for this parameter.
Public class | XamlItemBindingOfItemsControlAttribute | XAML attribute. Indicates the property of some BindingBase-derived type, that is used to bind some item of ItemsControl-derived type. This annotation will enable the DataContext type resolve for XAML bindings for such properties.
Public class | XamlItemsControlAttribute | XAML attribute. Indicates the type that has ItemsSource property and should be treated as ItemsControl-derived type, to enable inner items DataContext type resolve.
Enumerations
 | Enumeration | Description
Public enumeration | AssertionConditionType | Specifies assertion type. If the assertion method argument satisfies the condition, then the execution continues. Otherwise, execution is assumed to be halted.
Public enumeration | CollectionAccessType |
Public enumeration | ImplicitUseKindFlags |
Public enumeration | ImplicitUseTargetFlags | Specify what is considered used implicitly when marked with MeansImplicitUseAttribute or UsedImplicitlyAttribute.


AspChildControlTypeAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspChildControlTypeAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspChildControlTypeAttribute : Attribute

The AspChildControlTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspChildControlTypeAttribute | Initializes a new instance of the AspChildControlTypeAttribute class
Top
Properties
 | Name | Description
Public property | ControlType |
Public property | TagName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspChildControlTypeAttribute Constructor

Initializes a new instance of the AspChildControlTypeAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspChildControlTypeAttribute(
    string tagName,
    Type controlType
)

Parameters

tagName
Type: SystemString
controlType
Type: SystemType
See Also

Reference

AspChildControlTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspChildControlTypeAttribute Properties

The AspChildControlTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ControlType |
Public property | TagName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspChildControlTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspChildControlTypeAttribute.ControlType Property

AspChildControlTypeAttributeControlType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Type ControlType { get; }

Property Value

Type: Type
See Also

Reference

AspChildControlTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspChildControlTypeAttribute.TagName Property

AspChildControlTypeAttributeTagName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TagName { get; }

Property Value

Type: String
See Also

Reference

AspChildControlTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspChildControlTypeAttribute Methods

The AspChildControlTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspChildControlTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspDataFieldAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspDataFieldAttribute : Attribute

The AspDataFieldAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspDataFieldAttribute | Initializes a new instance of the AspDataFieldAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldAttribute Constructor

Initializes a new instance of the AspDataFieldAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspDataFieldAttribute()
See Also

Reference

AspDataFieldAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldAttribute Properties

The AspDataFieldAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspDataFieldAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldAttribute Methods

The AspDataFieldAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspDataFieldAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldsAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspDataFieldsAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspDataFieldsAttribute : Attribute

The AspDataFieldsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspDataFieldsAttribute | Initializes a new instance of the AspDataFieldsAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldsAttribute Constructor

Initializes a new instance of the AspDataFieldsAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspDataFieldsAttribute()
See Also

Reference

AspDataFieldsAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldsAttribute Properties

The AspDataFieldsAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspDataFieldsAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspDataFieldsAttribute Methods

The AspDataFieldsAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspDataFieldsAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMethodPropertyAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMethodPropertyAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMethodPropertyAttribute : Attribute

The AspMethodPropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMethodPropertyAttribute | Initializes a new instance of the AspMethodPropertyAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMethodPropertyAttribute Constructor

Initializes a new instance of the AspMethodPropertyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMethodPropertyAttribute()
See Also

Reference

AspMethodPropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMethodPropertyAttribute Properties

The AspMethodPropertyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMethodPropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMethodPropertyAttribute Methods

The AspMethodPropertyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMethodPropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC action. If applied to a method, the MVC action name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcActionAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcActionAttribute : Attribute

The AspMvcActionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcActionAttribute | Initializes a new instance of the AspMvcActionAttribute class
Public method | AspMvcActionAttribute(String) | Initializes a new instance of the AspMvcActionAttribute class
Top
Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Constructor

Overload List
 | Name | Description
Public method | AspMvcActionAttribute | Initializes a new instance of the AspMvcActionAttribute class
Public method | AspMvcActionAttribute(String) | Initializes a new instance of the AspMvcActionAttribute class
Top
See Also

Reference

AspMvcActionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Constructor

Initializes a new instance of the AspMvcActionAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcActionAttribute()
See Also

Reference

AspMvcActionAttribute Class
AspMvcActionAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Constructor (String)

Initializes a new instance of the AspMvcActionAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcActionAttribute(
    string anonymousProperty
)

Parameters

anonymousProperty
Type: SystemString
See Also

Reference

AspMvcActionAttribute Class
AspMvcActionAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Properties

The AspMvcActionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcActionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute.AnonymousProperty Property

AspMvcActionAttributeAnonymousProperty Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string AnonymousProperty { get; }

Property Value

Type: String
See Also

Reference

AspMvcActionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionAttribute Methods

The AspMvcActionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcActionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionSelectorAttribute Class

ASP.NET MVC attribute. When applied to a parameter of an attribute, indicates that this parameter is an MVC action name.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcActionSelectorAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcActionSelectorAttribute : Attribute

The AspMvcActionSelectorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcActionSelectorAttribute | Initializes a new instance of the AspMvcActionSelectorAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[ActionName("Foo")]
public ActionResult Login(string returnUrl) {
  ViewBag.ReturnUrl = Url.Action("Foo"); // OK
  return RedirectToAction("Bar"); // Error: Cannot resolve action
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionSelectorAttribute Constructor

Initializes a new instance of the AspMvcActionSelectorAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcActionSelectorAttribute()
See Also

Reference

AspMvcActionSelectorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionSelectorAttribute Properties

The AspMvcActionSelectorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcActionSelectorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcActionSelectorAttribute Methods

The AspMvcActionSelectorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcActionSelectorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC area. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcAreaAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcAreaAttribute : Attribute

The AspMvcAreaAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcAreaAttribute | Initializes a new instance of the AspMvcAreaAttribute class
Public method | AspMvcAreaAttribute(String) | Initializes a new instance of the AspMvcAreaAttribute class
Top
Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Constructor

Overload List
 | Name | Description
Public method | AspMvcAreaAttribute | Initializes a new instance of the AspMvcAreaAttribute class
Public method | AspMvcAreaAttribute(String) | Initializes a new instance of the AspMvcAreaAttribute class
Top
See Also

Reference

AspMvcAreaAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Constructor

Initializes a new instance of the AspMvcAreaAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcAreaAttribute()
See Also

Reference

AspMvcAreaAttribute Class
AspMvcAreaAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Constructor (String)

Initializes a new instance of the AspMvcAreaAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcAreaAttribute(
    string anonymousProperty
)

Parameters

anonymousProperty
Type: SystemString
See Also

Reference

AspMvcAreaAttribute Class
AspMvcAreaAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Properties

The AspMvcAreaAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcAreaAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute.AnonymousProperty Property

AspMvcAreaAttributeAnonymousProperty Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string AnonymousProperty { get; }

Property Value

Type: String
See Also

Reference

AspMvcAreaAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaAttribute Methods

The AspMvcAreaAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcAreaAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaMasterLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcAreaMasterLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcAreaMasterLocationFormatAttribute : Attribute

The AspMvcAreaMasterLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcAreaMasterLocationFormatAttribute | Initializes a new instance of the AspMvcAreaMasterLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaMasterLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcAreaMasterLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcAreaMasterLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcAreaMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaMasterLocationFormatAttribute Properties

The AspMvcAreaMasterLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcAreaMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaMasterLocationFormatAttribute.Format Property

AspMvcAreaMasterLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcAreaMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaMasterLocationFormatAttribute Methods

The AspMvcAreaMasterLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcAreaMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaPartialViewLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcAreaPartialViewLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcAreaPartialViewLocationFormatAttribute : Attribute

The AspMvcAreaPartialViewLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcAreaPartialViewLocationFormatAttribute | Initializes a new instance of the AspMvcAreaPartialViewLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaPartialViewLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcAreaPartialViewLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcAreaPartialViewLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcAreaPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaPartialViewLocationFormatAttribute Properties

The AspMvcAreaPartialViewLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcAreaPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaPartialViewLocationFormatAttribute.Format Property

AspMvcAreaPartialViewLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcAreaPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaPartialViewLocationFormatAttribute Methods

The AspMvcAreaPartialViewLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcAreaPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaViewLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcAreaViewLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcAreaViewLocationFormatAttribute : Attribute

The AspMvcAreaViewLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcAreaViewLocationFormatAttribute | Initializes a new instance of the AspMvcAreaViewLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaViewLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcAreaViewLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcAreaViewLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcAreaViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaViewLocationFormatAttribute Properties

The AspMvcAreaViewLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcAreaViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaViewLocationFormatAttribute.Format Property

AspMvcAreaViewLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcAreaViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcAreaViewLocationFormatAttribute Methods

The AspMvcAreaViewLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcAreaViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC controller. If applied to a method, the MVC controller name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.ChildActionExtensions.RenderAction(HtmlHelper, String, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcControllerAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcControllerAttribute : Attribute

The AspMvcControllerAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcControllerAttribute | Initializes a new instance of the AspMvcControllerAttribute class
Public method | AspMvcControllerAttribute(String) | Initializes a new instance of the AspMvcControllerAttribute class
Top
Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Constructor

Overload List
 | Name | Description
Public method | AspMvcControllerAttribute | Initializes a new instance of the AspMvcControllerAttribute class
Public method | AspMvcControllerAttribute(String) | Initializes a new instance of the AspMvcControllerAttribute class
Top
See Also

Reference

AspMvcControllerAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Constructor

Initializes a new instance of the AspMvcControllerAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcControllerAttribute()
See Also

Reference

AspMvcControllerAttribute Class
AspMvcControllerAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Constructor (String)

Initializes a new instance of the AspMvcControllerAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcControllerAttribute(
    string anonymousProperty
)

Parameters

anonymousProperty
Type: SystemString
See Also

Reference

AspMvcControllerAttribute Class
AspMvcControllerAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Properties

The AspMvcControllerAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AnonymousProperty |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcControllerAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute.AnonymousProperty Property

AspMvcControllerAttributeAnonymousProperty Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string AnonymousProperty { get; }

Property Value

Type: String
See Also

Reference

AspMvcControllerAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcControllerAttribute Methods

The AspMvcControllerAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcControllerAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcDisplayTemplateAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC display template. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.DisplayExtensions.DisplayForModel(HtmlHelper, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcDisplayTemplateAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcDisplayTemplateAttribute : Attribute

The AspMvcDisplayTemplateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcDisplayTemplateAttribute | Initializes a new instance of the AspMvcDisplayTemplateAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcDisplayTemplateAttribute Constructor

Initializes a new instance of the AspMvcDisplayTemplateAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcDisplayTemplateAttribute()
See Also

Reference

AspMvcDisplayTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcDisplayTemplateAttribute Properties

The AspMvcDisplayTemplateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcDisplayTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcDisplayTemplateAttribute Methods

The AspMvcDisplayTemplateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcDisplayTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcEditorTemplateAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC editor template. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.EditorExtensions.EditorForModel(HtmlHelper, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcEditorTemplateAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcEditorTemplateAttribute : Attribute

The AspMvcEditorTemplateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcEditorTemplateAttribute | Initializes a new instance of the AspMvcEditorTemplateAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcEditorTemplateAttribute Constructor

Initializes a new instance of the AspMvcEditorTemplateAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcEditorTemplateAttribute()
See Also

Reference

AspMvcEditorTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcEditorTemplateAttribute Properties

The AspMvcEditorTemplateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcEditorTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcEditorTemplateAttribute Methods

The AspMvcEditorTemplateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcEditorTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC Master. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(String, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcMasterAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcMasterAttribute : Attribute

The AspMvcMasterAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcMasterAttribute | Initializes a new instance of the AspMvcMasterAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterAttribute Constructor

Initializes a new instance of the AspMvcMasterAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcMasterAttribute()
See Also

Reference

AspMvcMasterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterAttribute Properties

The AspMvcMasterAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcMasterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterAttribute Methods

The AspMvcMasterAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcMasterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcMasterLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcMasterLocationFormatAttribute : Attribute

The AspMvcMasterLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcMasterLocationFormatAttribute | Initializes a new instance of the AspMvcMasterLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcMasterLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcMasterLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterLocationFormatAttribute Properties

The AspMvcMasterLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterLocationFormatAttribute.Format Property

AspMvcMasterLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcMasterLocationFormatAttribute Methods

The AspMvcMasterLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcMasterLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcModelTypeAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC model type. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(String, Object).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcModelTypeAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcModelTypeAttribute : Attribute

The AspMvcModelTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcModelTypeAttribute | Initializes a new instance of the AspMvcModelTypeAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcModelTypeAttribute Constructor

Initializes a new instance of the AspMvcModelTypeAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcModelTypeAttribute()
See Also

Reference

AspMvcModelTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcModelTypeAttribute Properties

The AspMvcModelTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcModelTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcModelTypeAttribute Methods

The AspMvcModelTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcModelTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC partial view. If applied to a method, the MVC partial view name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Html.RenderPartialExtensions.RenderPartial(HtmlHelper, String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcPartialViewAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcPartialViewAttribute : Attribute

The AspMvcPartialViewAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcPartialViewAttribute | Initializes a new instance of the AspMvcPartialViewAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewAttribute Constructor

Initializes a new instance of the AspMvcPartialViewAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcPartialViewAttribute()
See Also

Reference

AspMvcPartialViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewAttribute Properties

The AspMvcPartialViewAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcPartialViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewAttribute Methods

The AspMvcPartialViewAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcPartialViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcPartialViewLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcPartialViewLocationFormatAttribute : Attribute

The AspMvcPartialViewLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcPartialViewLocationFormatAttribute | Initializes a new instance of the AspMvcPartialViewLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcPartialViewLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcPartialViewLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewLocationFormatAttribute Properties

The AspMvcPartialViewLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewLocationFormatAttribute.Format Property

AspMvcPartialViewLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcPartialViewLocationFormatAttribute Methods

The AspMvcPartialViewLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcPartialViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcSuppressViewErrorAttribute Class

ASP.NET MVC attribute. Allows disabling inspections for MVC views within a class or a method.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcSuppressViewErrorAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcSuppressViewErrorAttribute : Attribute

The AspMvcSuppressViewErrorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcSuppressViewErrorAttribute | Initializes a new instance of the AspMvcSuppressViewErrorAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcSuppressViewErrorAttribute Constructor

Initializes a new instance of the AspMvcSuppressViewErrorAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcSuppressViewErrorAttribute()
See Also

Reference

AspMvcSuppressViewErrorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcSuppressViewErrorAttribute Properties

The AspMvcSuppressViewErrorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcSuppressViewErrorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcSuppressViewErrorAttribute Methods

The AspMvcSuppressViewErrorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcSuppressViewErrorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcTemplateAttribute Class

ASP.NET MVC attribute. Indicates that a parameter is an MVC template. Use this attribute for custom wrappers similar to System.ComponentModel.DataAnnotations.UIHintAttribute(System.String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcTemplateAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcTemplateAttribute : Attribute

The AspMvcTemplateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcTemplateAttribute | Initializes a new instance of the AspMvcTemplateAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcTemplateAttribute Constructor

Initializes a new instance of the AspMvcTemplateAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcTemplateAttribute()
See Also

Reference

AspMvcTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcTemplateAttribute Properties

The AspMvcTemplateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcTemplateAttribute Methods

The AspMvcTemplateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component. If applied to a method, the MVC view name is calculated implicitly from the context. Use this attribute for custom wrappers similar to System.Web.Mvc.Controller.View(Object).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcViewAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcViewAttribute : Attribute

The AspMvcViewAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcViewAttribute | Initializes a new instance of the AspMvcViewAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewAttribute Constructor

Initializes a new instance of the AspMvcViewAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcViewAttribute()
See Also

Reference

AspMvcViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewAttribute Properties

The AspMvcViewAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewAttribute Methods

The AspMvcViewAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component name.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcViewComponentAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcViewComponentAttribute : Attribute

The AspMvcViewComponentAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcViewComponentAttribute | Initializes a new instance of the AspMvcViewComponentAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentAttribute Constructor

Initializes a new instance of the AspMvcViewComponentAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcViewComponentAttribute()
See Also

Reference

AspMvcViewComponentAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentAttribute Properties

The AspMvcViewComponentAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcViewComponentAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentAttribute Methods

The AspMvcViewComponentAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcViewComponentAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentViewAttribute Class

ASP.NET MVC attribute. If applied to a parameter, indicates that the parameter is an MVC view component view. If applied to a method, the MVC view component view name is default.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcViewComponentViewAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcViewComponentViewAttribute : Attribute

The AspMvcViewComponentViewAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcViewComponentViewAttribute | Initializes a new instance of the AspMvcViewComponentViewAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentViewAttribute Constructor

Initializes a new instance of the AspMvcViewComponentViewAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcViewComponentViewAttribute()
See Also

Reference

AspMvcViewComponentViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentViewAttribute Properties

The AspMvcViewComponentViewAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcViewComponentViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewComponentViewAttribute Methods

The AspMvcViewComponentViewAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcViewComponentViewAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewLocationFormatAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspMvcViewLocationFormatAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspMvcViewLocationFormatAttribute : Attribute

The AspMvcViewLocationFormatAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspMvcViewLocationFormatAttribute | Initializes a new instance of the AspMvcViewLocationFormatAttribute class
Top
Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewLocationFormatAttribute Constructor

Initializes a new instance of the AspMvcViewLocationFormatAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspMvcViewLocationFormatAttribute(
    string format
)

Parameters

format
Type: SystemString
See Also

Reference

AspMvcViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewLocationFormatAttribute Properties

The AspMvcViewLocationFormatAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Format |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspMvcViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewLocationFormatAttribute.Format Property

AspMvcViewLocationFormatAttributeFormat Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Format { get; }

Property Value

Type: String
See Also

Reference

AspMvcViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspMvcViewLocationFormatAttribute Methods

The AspMvcViewLocationFormatAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspMvcViewLocationFormatAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspRequiredAttributeAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspRequiredAttributeAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspRequiredAttributeAttribute : Attribute

The AspRequiredAttributeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspRequiredAttributeAttribute | Initializes a new instance of the AspRequiredAttributeAttribute class
Top
Properties
 | Name | Description
Public property | Attribute |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspRequiredAttributeAttribute Constructor

Initializes a new instance of the AspRequiredAttributeAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspRequiredAttributeAttribute(
    string attribute
)

Parameters

attribute
Type: SystemString
See Also

Reference

AspRequiredAttributeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspRequiredAttributeAttribute Properties

The AspRequiredAttributeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Attribute |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspRequiredAttributeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspRequiredAttributeAttribute.Attribute Property

AspRequiredAttributeAttributeAttribute Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Attribute { get; }

Property Value

Type: String
See Also

Reference

AspRequiredAttributeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspRequiredAttributeAttribute Methods

The AspRequiredAttributeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspRequiredAttributeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspTypePropertyAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAspTypePropertyAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AspTypePropertyAttribute : Attribute

The AspTypePropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AspTypePropertyAttribute | Initializes a new instance of the AspTypePropertyAttribute class
Top
Properties
 | Name | Description
Public property | CreateConstructorReferences |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AspTypePropertyAttribute Constructor

Initializes a new instance of the AspTypePropertyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AspTypePropertyAttribute(
    bool createConstructorReferences
)

Parameters

createConstructorReferences
Type: SystemBoolean
See Also

Reference

AspTypePropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspTypePropertyAttribute Properties

The AspTypePropertyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | CreateConstructorReferences |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AspTypePropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspTypePropertyAttribute.CreateConstructorReferences Property

AspTypePropertyAttributeCreateConstructorReferences Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CreateConstructorReferences { get; }

Property Value

Type: Boolean
See Also

Reference

AspTypePropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AspTypePropertyAttribute Methods

The AspTypePropertyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AspTypePropertyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionAttribute Class

Indicates the condition parameter of the assertion method. The method itself should be marked by AssertionMethodAttribute attribute. The mandatory argument of the attribute is the assertion type.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAssertionConditionAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AssertionConditionAttribute : Attribute

The AssertionConditionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssertionConditionAttribute | Initializes a new instance of the AssertionConditionAttribute class
Top
Properties
 | Name | Description
Public property | ConditionType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionAttribute Constructor

Initializes a new instance of the AssertionConditionAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AssertionConditionAttribute(
    AssertionConditionType conditionType
)

Parameters

conditionType
Type: Resto.Front.Api.Attributes.JetBrainsAssertionConditionType
See Also

Reference

AssertionConditionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionAttribute Properties

The AssertionConditionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ConditionType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AssertionConditionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionAttribute.ConditionType Property

AssertionConditionAttributeConditionType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AssertionConditionType ConditionType { get; }

Property Value

Type: AssertionConditionType
See Also

Reference

AssertionConditionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionAttribute Methods

The AssertionConditionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssertionConditionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionConditionType Enumeration

Specifies assertion type. If the assertion method argument satisfies the condition, then the execution continues. Otherwise, execution is assumed to be halted.

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum AssertionConditionType
Members
Member name | Value | Description
IS_TRUE | 0 | Marked parameter should be evaluated to true.
IS_FALSE | 1 | Marked parameter should be evaluated to false.
IS_NULL | 2 | Marked parameter should be evaluated to null value.
IS_NOT_NULL | 3 | Marked parameter should be evaluated to not null value.
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AssertionMethodAttribute Class

Indicates that the marked method is assertion method, i.e. it halts control flow if one of the conditions is satisfied. To set the condition, mark one of the parameters with AssertionConditionAttribute attribute.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsAssertionMethodAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class AssertionMethodAttribute : Attribute

The AssertionMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AssertionMethodAttribute | Initializes a new instance of the AssertionMethodAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


AssertionMethodAttribute Constructor

Initializes a new instance of the AssertionMethodAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AssertionMethodAttribute()
See Also

Reference

AssertionMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionMethodAttribute Properties

The AssertionMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AssertionMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


AssertionMethodAttribute Methods

The AssertionMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssertionMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


BaseTypeRequiredAttribute Class

When applied to a target attribute, specifies a requirement for any type marked with the target attribute to implement or inherit specific type or types.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsBaseTypeRequiredAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class BaseTypeRequiredAttribute : Attribute

The BaseTypeRequiredAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | BaseTypeRequiredAttribute | Initializes a new instance of the BaseTypeRequiredAttribute class
Top
Properties
 | Name | Description
Public property | BaseType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[BaseTypeRequired(typeof(IComponent)] // Specify requirement
class ComponentAttribute : Attribute { }

[Component] // ComponentAttribute requires implementing IComponent interface
class MyComponent : IComponent { }
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


BaseTypeRequiredAttribute Constructor

Initializes a new instance of the BaseTypeRequiredAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public BaseTypeRequiredAttribute(
    Type baseType
)

Parameters

baseType
Type: SystemType
See Also

Reference

BaseTypeRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


BaseTypeRequiredAttribute Properties

The BaseTypeRequiredAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BaseType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

BaseTypeRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


BaseTypeRequiredAttribute.BaseType Property

BaseTypeRequiredAttributeBaseType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Type BaseType { get; }

Property Value

Type: Type
See Also

Reference

BaseTypeRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


BaseTypeRequiredAttribute Methods

The BaseTypeRequiredAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseTypeRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CanBeNullAttribute Class

Indicates that the value of the marked element could be null sometimes, so the check for null is necessary before its usage.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsCanBeNullAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class CanBeNullAttribute : Attribute

The CanBeNullAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CanBeNullAttribute | Initializes a new instance of the CanBeNullAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[CanBeNull] object Test() => null;

void UseTest() {
  var p = Test();
  var s = p.ToString(); // Warning: Possible 'System.NullReferenceException'
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


CanBeNullAttribute Constructor

Initializes a new instance of the CanBeNullAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CanBeNullAttribute()
See Also

Reference

CanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CanBeNullAttribute Properties

The CanBeNullAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

CanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CanBeNullAttribute Methods

The CanBeNullAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CannotApplyEqualityOperatorAttribute Class

Indicates that the value of the marked type (or its derivatives) cannot be compared using '==' or '!=' operators and Equals() should be used instead. However, using '==' or '!=' for comparison with null is always permitted.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsCannotApplyEqualityOperatorAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class CannotApplyEqualityOperatorAttribute : Attribute

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CannotApplyEqualityOperatorAttribute | Initializes a new instance of the CannotApplyEqualityOperatorAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[CannotApplyEqualityOperator]
class NoEquality { }

class UsesNoEquality {
  void Test() {
    var ca1 = new NoEquality();
    var ca2 = new NoEquality();
    if (ca1 != null) { // OK
      bool condition = ca1 == ca2; // Warning
    }
  }
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


CannotApplyEqualityOperatorAttribute Constructor

Initializes a new instance of the CannotApplyEqualityOperatorAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotApplyEqualityOperatorAttribute()
See Also

Reference

CannotApplyEqualityOperatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CannotApplyEqualityOperatorAttribute Properties

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

CannotApplyEqualityOperatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CannotApplyEqualityOperatorAttribute Methods

The CannotApplyEqualityOperatorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CannotApplyEqualityOperatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessAttribute Class

Indicates how method, constructor invocation or property access over collection type affects content of the collection.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsCollectionAccessAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class CollectionAccessAttribute : Attribute

The CollectionAccessAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionAccessAttribute | Initializes a new instance of the CollectionAccessAttribute class
Top
Properties
 | Name | Description
Public property | CollectionAccessType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessAttribute Constructor

Initializes a new instance of the CollectionAccessAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CollectionAccessAttribute(
    CollectionAccessType collectionAccessType
)

Parameters

collectionAccessType
Type: Resto.Front.Api.Attributes.JetBrainsCollectionAccessType
See Also

Reference

CollectionAccessAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessAttribute Properties

The CollectionAccessAttribute type exposes the following members.

Properties
 | Name | Description
Public property | CollectionAccessType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

CollectionAccessAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessAttribute.CollectionAccessType Property

CollectionAccessAttributeCollectionAccessType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CollectionAccessType CollectionAccessType { get; }

Property Value

Type: CollectionAccessType
See Also

Reference

CollectionAccessAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessAttribute Methods

The CollectionAccessAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CollectionAccessAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


CollectionAccessType Enumeration

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum CollectionAccessType
Members
Member name | Value | Description
None | 0 | Method does not use or modify content of the collection.
Read | 1 | Method only reads content of the collection but does not modify it.
ModifyExistingContent | 2 | Method can change content of the collection but does not add new elements.
UpdatedContent | 6 | Method can add new elements to the collection.
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Class

Describes dependency between method input and output.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsContractAnnotationAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ContractAnnotationAttribute : Attribute

The ContractAnnotationAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ContractAnnotationAttribute(String) | Initializes a new instance of the ContractAnnotationAttribute class
Public method | ContractAnnotationAttribute(String, Boolean) | Initializes a new instance of the ContractAnnotationAttribute class
Top
Properties
 | Name | Description
Public property | Contract |
Public property | ForceFullStates |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Constructor

Overload List
 | Name | Description
Public method | ContractAnnotationAttribute(String) | Initializes a new instance of the ContractAnnotationAttribute class
Public method | ContractAnnotationAttribute(String, Boolean) | Initializes a new instance of the ContractAnnotationAttribute class
Top
See Also

Reference

ContractAnnotationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Constructor (String)

Initializes a new instance of the ContractAnnotationAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ContractAnnotationAttribute(
    string contract
)

Parameters

contract
Type: SystemString
See Also

Reference

ContractAnnotationAttribute Class
ContractAnnotationAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Constructor (String, Boolean)

Initializes a new instance of the ContractAnnotationAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ContractAnnotationAttribute(
    string contract,
    bool forceFullStates
)

Parameters

contract
Type: SystemString
forceFullStates
Type: SystemBoolean
See Also

Reference

ContractAnnotationAttribute Class
ContractAnnotationAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Properties

The ContractAnnotationAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Contract |
Public property | ForceFullStates |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ContractAnnotationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute.Contract Property

ContractAnnotationAttributeContract Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Contract { get; }

Property Value

Type: String
See Also

Reference

ContractAnnotationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute.ForceFullStates Property

ContractAnnotationAttributeForceFullStates Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool ForceFullStates { get; }

Property Value

Type: Boolean
See Also

Reference

ContractAnnotationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ContractAnnotationAttribute Methods

The ContractAnnotationAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContractAnnotationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlAttributeValueAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsHtmlAttributeValueAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class HtmlAttributeValueAttribute : Attribute

The HtmlAttributeValueAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlAttributeValueAttribute | Initializes a new instance of the HtmlAttributeValueAttribute class
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


HtmlAttributeValueAttribute Constructor

Initializes a new instance of the HtmlAttributeValueAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public HtmlAttributeValueAttribute(
    string name
)

Parameters

name
Type: SystemString
See Also

Reference

HtmlAttributeValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlAttributeValueAttribute Properties

The HtmlAttributeValueAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

HtmlAttributeValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlAttributeValueAttribute.Name Property

HtmlAttributeValueAttributeName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

HtmlAttributeValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlAttributeValueAttribute Methods

The HtmlAttributeValueAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlAttributeValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsHtmlElementAttributesAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class HtmlElementAttributesAttribute : Attribute

The HtmlElementAttributesAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlElementAttributesAttribute | Initializes a new instance of the HtmlElementAttributesAttribute class
Public method | HtmlElementAttributesAttribute(String) | Initializes a new instance of the HtmlElementAttributesAttribute class
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Constructor

Overload List
 | Name | Description
Public method | HtmlElementAttributesAttribute | Initializes a new instance of the HtmlElementAttributesAttribute class
Public method | HtmlElementAttributesAttribute(String) | Initializes a new instance of the HtmlElementAttributesAttribute class
Top
See Also

Reference

HtmlElementAttributesAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Constructor

Initializes a new instance of the HtmlElementAttributesAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public HtmlElementAttributesAttribute()
See Also

Reference

HtmlElementAttributesAttribute Class
HtmlElementAttributesAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Constructor (String)

Initializes a new instance of the HtmlElementAttributesAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public HtmlElementAttributesAttribute(
    string name
)

Parameters

name
Type: SystemString
See Also

Reference

HtmlElementAttributesAttribute Class
HtmlElementAttributesAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Properties

The HtmlElementAttributesAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

HtmlElementAttributesAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute.Name Property

HtmlElementAttributesAttributeName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

HtmlElementAttributesAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


HtmlElementAttributesAttribute Methods

The HtmlElementAttributesAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HtmlElementAttributesAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ImplicitUseKindFlags Enumeration

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum ImplicitUseKindFlags
Members
Member name | Value | Description
Default | 7 |
Access | 1 | Only entity marked with attribute considered used.
Assign | 2 | Indicates implicit assignment to a member.
InstantiatedWithFixedConstructorSignature | 4 | Indicates implicit instantiation of a type with fixed constructor signature. That means any unused constructor parameters won't be reported as such.
InstantiatedNoFixedConstructorSignature | 8 | Indicates implicit instantiation of a type.
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ImplicitUseTargetFlags Enumeration

Specify what is considered used implicitly when marked with MeansImplicitUseAttribute or UsedImplicitlyAttribute.

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum ImplicitUseTargetFlags
Members
Member name | Value | Description
Default | 1 |
Itself | 1 |
Members | 2 | Members of entity marked with attribute are considered used.
WithMembers | 3 | Entity marked with attribute and all its members considered used.
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


InstantHandleAttribute Class

Tells code analysis engine if the parameter is completely handled when the invoked method is on stack. If the parameter is a delegate, indicates that delegate is executed while the method is executed. If the parameter is an enumerable, indicates that it is enumerated while the method is executed.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsInstantHandleAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class InstantHandleAttribute : Attribute

The InstantHandleAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | InstantHandleAttribute | Initializes a new instance of the InstantHandleAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


InstantHandleAttribute Constructor

Initializes a new instance of the InstantHandleAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InstantHandleAttribute()
See Also

Reference

InstantHandleAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


InstantHandleAttribute Properties

The InstantHandleAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

InstantHandleAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


InstantHandleAttribute Methods

The InstantHandleAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InstantHandleAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


InvokerParameterNameAttribute Class

Indicates that the function argument should be string literal and match one of the parameters of the caller function. For example, ReSharper annotates the parameter of ArgumentNullException.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsInvokerParameterNameAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class InvokerParameterNameAttribute : Attribute

The InvokerParameterNameAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | InvokerParameterNameAttribute | Initializes a new instance of the InvokerParameterNameAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
void Foo(string param) {
  if (param == null)
    throw new ArgumentNullException("par"); // Warning: Cannot resolve symbol
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


InvokerParameterNameAttribute Constructor

Initializes a new instance of the InvokerParameterNameAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InvokerParameterNameAttribute()
See Also

Reference

InvokerParameterNameAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


InvokerParameterNameAttribute Properties

The InvokerParameterNameAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

InvokerParameterNameAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


InvokerParameterNameAttribute Methods

The InvokerParameterNameAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InvokerParameterNameAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemCanBeNullAttribute Class

Can be appplied to symbols of types derived from IEnumerable as well as to symbols of Task and Lazy classes to indicate that the value of a collection item, of the Task.Result property or of the Lazy.Value property can be null.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsItemCanBeNullAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ItemCanBeNullAttribute : Attribute

The ItemCanBeNullAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ItemCanBeNullAttribute | Initializes a new instance of the ItemCanBeNullAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ItemCanBeNullAttribute Constructor

Initializes a new instance of the ItemCanBeNullAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ItemCanBeNullAttribute()
See Also

Reference

ItemCanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemCanBeNullAttribute Properties

The ItemCanBeNullAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ItemCanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemCanBeNullAttribute Methods

The ItemCanBeNullAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ItemCanBeNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemNotNullAttribute Class

Can be appplied to symbols of types derived from IEnumerable as well as to symbols of Task and Lazy classes to indicate that the value of a collection item, of the Task.Result property or of the Lazy.Value property can never be null.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsItemNotNullAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ItemNotNullAttribute : Attribute

The ItemNotNullAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ItemNotNullAttribute | Initializes a new instance of the ItemNotNullAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ItemNotNullAttribute Constructor

Initializes a new instance of the ItemNotNullAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ItemNotNullAttribute()
See Also

Reference

ItemNotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemNotNullAttribute Properties

The ItemNotNullAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ItemNotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ItemNotNullAttribute Methods

The ItemNotNullAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ItemNotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LinqTunnelAttribute Class

Indicates that method is pure LINQ method, with postponed enumeration (like Enumerable.Select, .Where). This annotation allows inference of [InstantHandle] annotation for parameters of delegate type by analyzing LINQ method chains.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsLinqTunnelAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class LinqTunnelAttribute : Attribute

The LinqTunnelAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LinqTunnelAttribute | Initializes a new instance of the LinqTunnelAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


LinqTunnelAttribute Constructor

Initializes a new instance of the LinqTunnelAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LinqTunnelAttribute()
See Also

Reference

LinqTunnelAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LinqTunnelAttribute Properties

The LinqTunnelAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LinqTunnelAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LinqTunnelAttribute Methods

The LinqTunnelAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinqTunnelAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Class

Indicates that marked element should be localized or not.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsLocalizationRequiredAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class LocalizationRequiredAttribute : Attribute

The LocalizationRequiredAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LocalizationRequiredAttribute | Initializes a new instance of the LocalizationRequiredAttribute class
Public method | LocalizationRequiredAttribute(Boolean) | Initializes a new instance of the LocalizationRequiredAttribute class
Top
Properties
 | Name | Description
Public property | Required |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[LocalizationRequiredAttribute(true)]
class Foo {
  string str = "my string"; // Warning: Localizable string
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Constructor

Overload List
 | Name | Description
Public method | LocalizationRequiredAttribute | Initializes a new instance of the LocalizationRequiredAttribute class
Public method | LocalizationRequiredAttribute(Boolean) | Initializes a new instance of the LocalizationRequiredAttribute class
Top
See Also

Reference

LocalizationRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Constructor

Initializes a new instance of the LocalizationRequiredAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LocalizationRequiredAttribute()
See Also

Reference

LocalizationRequiredAttribute Class
LocalizationRequiredAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Constructor (Boolean)

Initializes a new instance of the LocalizationRequiredAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LocalizationRequiredAttribute(
    bool required
)

Parameters

required
Type: SystemBoolean
See Also

Reference

LocalizationRequiredAttribute Class
LocalizationRequiredAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Properties

The LocalizationRequiredAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Required |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

LocalizationRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute.Required Property

LocalizationRequiredAttributeRequired Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Required { get; }

Property Value

Type: Boolean
See Also

Reference

LocalizationRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


LocalizationRequiredAttribute Methods

The LocalizationRequiredAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LocalizationRequiredAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute Class

Allows specifying a macro for a parameter of a source template.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsMacroAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class MacroAttribute : Attribute

The MacroAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MacroAttribute | Initializes a new instance of the MacroAttribute class
Top
Properties
 | Name | Description
Public property | Editable | Allows specifying which occurrence of the target parameter becomes editable when the template is deployed.
Public property | Expression | Allows specifying a macro that will be executed for a source template parameter when the template is expanded.
Public property | Target | Identifies the target parameter of a source template if the MacroAttribute is applied on a template method.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
You can apply the attribute on the whole method or on any of its additional parameters. The macro expression is defined in the Expression property. When applied on a method, the target template parameter is defined in the Target property. To apply the macro silently for the parameter, set the Editable property value = -1.
Examples
Applying the attribute on a source template method:
Copy
[SourceTemplate, Macro(Target = "item", Expression = "suggestVariableName()")]
public static void forEach<T>(this IEnumerable<T> collection) {
  foreach (var item in collection) {
    //$ $END$
  }
}
Applying the attribute on a template method parameter:
Copy
[SourceTemplate]
public static void something(this Entity x, [Macro(Expression = "guid()", Editable = -1)] string newguid) {
  /*$ var $x$Id = "$newguid$" + x.ToString();
  x.DoSomething($x$Id); */
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute Constructor

Initializes a new instance of the MacroAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MacroAttribute()
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute Properties

The MacroAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Editable | Allows specifying which occurrence of the target parameter becomes editable when the template is deployed.
Public property | Expression | Allows specifying a macro that will be executed for a source template parameter when the template is expanded.
Public property | Target | Identifies the target parameter of a source template if the MacroAttribute is applied on a template method.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute.Editable Property

MacroAttributeEditable Property

Allows specifying which occurrence of the target parameter becomes editable when the template is deployed.

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Editable { get; set; }

Property Value

Type: Int32
Remarks
If the target parameter is used several times in the template, only one occurrence becomes editable; other occurrences are changed synchronously. To specify the zero-based index of the editable occurrence, use values >= 0. To make the parameter non-editable when the template is expanded, use -1.
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute.Expression Property

MacroAttributeExpression Property

Allows specifying a macro that will be executed for a source template parameter when the template is expanded.

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Expression { get; set; }

Property Value

Type: String
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute.Target Property

MacroAttributeTarget Property

Identifies the target parameter of a source template if the MacroAttribute is applied on a template method.

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Target { get; set; }

Property Value

Type: String
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MacroAttribute Methods

The MacroAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MacroAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Class

Should be used on attributes and causes ReSharper to not mark symbols marked with such attributes as unused (as well as by other usage inspections)
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsMeansImplicitUseAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class MeansImplicitUseAttribute : Attribute

The MeansImplicitUseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MeansImplicitUseAttribute | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseKindFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseTargetFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseKindFlags, ImplicitUseTargetFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Top
Properties
 | Name | Description
Public property | TargetFlags |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UseKindFlags |
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Constructor

Overload List
 | Name | Description
Public method | MeansImplicitUseAttribute | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseKindFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseTargetFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Public method | MeansImplicitUseAttribute(ImplicitUseKindFlags, ImplicitUseTargetFlags) | Initializes a new instance of the MeansImplicitUseAttribute class
Top
See Also

Reference

MeansImplicitUseAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Constructor

Initializes a new instance of the MeansImplicitUseAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MeansImplicitUseAttribute()
See Also

Reference

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Constructor (ImplicitUseKindFlags)

Initializes a new instance of the MeansImplicitUseAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MeansImplicitUseAttribute(
    ImplicitUseKindFlags useKindFlags
)

Parameters

useKindFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseKindFlags
See Also

Reference

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Constructor (ImplicitUseTargetFlags)

Initializes a new instance of the MeansImplicitUseAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MeansImplicitUseAttribute(
    ImplicitUseTargetFlags targetFlags
)

Parameters

targetFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseTargetFlags
See Also

Reference

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Constructor (ImplicitUseKindFlags, ImplicitUseTargetFlags)

Initializes a new instance of the MeansImplicitUseAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MeansImplicitUseAttribute(
    ImplicitUseKindFlags useKindFlags,
    ImplicitUseTargetFlags targetFlags
)

Parameters

useKindFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseKindFlags
targetFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseTargetFlags
See Also

Reference

MeansImplicitUseAttribute Class
MeansImplicitUseAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Properties

The MeansImplicitUseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TargetFlags |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UseKindFlags |
Top
See Also

Reference

MeansImplicitUseAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute.TargetFlags Property

MeansImplicitUseAttributeTargetFlags Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ImplicitUseTargetFlags TargetFlags { get; }

Property Value

Type: ImplicitUseTargetFlags
See Also

Reference

MeansImplicitUseAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute.UseKindFlags Property

MeansImplicitUseAttributeUseKindFlags Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ImplicitUseKindFlags UseKindFlags { get; }

Property Value

Type: ImplicitUseKindFlags
See Also

Reference

MeansImplicitUseAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MeansImplicitUseAttribute Methods

The MeansImplicitUseAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MeansImplicitUseAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Class

Indicates that the return value of method invocation must be used.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsMustUseReturnValueAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class MustUseReturnValueAttribute : Attribute

The MustUseReturnValueAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MustUseReturnValueAttribute | Initializes a new instance of the MustUseReturnValueAttribute class
Public method | MustUseReturnValueAttribute(String) | Initializes a new instance of the MustUseReturnValueAttribute class
Top
Properties
 | Name | Description
Public property | Justification |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Constructor

Overload List
 | Name | Description
Public method | MustUseReturnValueAttribute | Initializes a new instance of the MustUseReturnValueAttribute class
Public method | MustUseReturnValueAttribute(String) | Initializes a new instance of the MustUseReturnValueAttribute class
Top
See Also

Reference

MustUseReturnValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Constructor

Initializes a new instance of the MustUseReturnValueAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MustUseReturnValueAttribute()
See Also

Reference

MustUseReturnValueAttribute Class
MustUseReturnValueAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Constructor (String)

Initializes a new instance of the MustUseReturnValueAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public MustUseReturnValueAttribute(
    string justification
)

Parameters

justification
Type: SystemString
See Also

Reference

MustUseReturnValueAttribute Class
MustUseReturnValueAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Properties

The MustUseReturnValueAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Justification |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MustUseReturnValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute.Justification Property

MustUseReturnValueAttributeJustification Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Justification { get; }

Property Value

Type: String
See Also

Reference

MustUseReturnValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


MustUseReturnValueAttribute Methods

The MustUseReturnValueAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MustUseReturnValueAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoEnumerationAttribute Class

Indicates that IEnumerable, passed as parameter, is not enumerated.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsNoEnumerationAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class NoEnumerationAttribute : Attribute

The NoEnumerationAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NoEnumerationAttribute | Initializes a new instance of the NoEnumerationAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


NoEnumerationAttribute Constructor

Initializes a new instance of the NoEnumerationAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NoEnumerationAttribute()
See Also

Reference

NoEnumerationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoEnumerationAttribute Properties

The NoEnumerationAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NoEnumerationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoEnumerationAttribute Methods

The NoEnumerationAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NoEnumerationAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoReorderAttribute Class

Prevents the Member Reordering feature from tossing members of the marked class.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsNoReorderAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class NoReorderAttribute : Attribute

The NoReorderAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NoReorderAttribute | Initializes a new instance of the NoReorderAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The attribute must be mentioned in your member reordering patterns
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


NoReorderAttribute Constructor

Initializes a new instance of the NoReorderAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NoReorderAttribute()
See Also

Reference

NoReorderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoReorderAttribute Properties

The NoReorderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NoReorderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NoReorderAttribute Methods

The NoReorderAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NoReorderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Class

Indicates that the method is contained in a type that implements System.ComponentModel.INotifyPropertyChanged interface and this method is used to notify that some property value changed.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsNotifyPropertyChangedInvocatorAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class NotifyPropertyChangedInvocatorAttribute : Attribute

The NotifyPropertyChangedInvocatorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NotifyPropertyChangedInvocatorAttribute | Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class
Public method | NotifyPropertyChangedInvocatorAttribute(String) | Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class
Top
Properties
 | Name | Description
Public property | ParameterName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
The method should be non-static and conform to one of the supported signatures: NotifyChanged(string)NotifyChanged(params string[])NotifyChanged{T}(Expression{Func{T}})NotifyChanged{T,U}(Expression{Func{T,U}})SetProperty{T}(ref T, T, string)
Examples
Copy
public class Foo : INotifyPropertyChanged {
  public event PropertyChangedEventHandler PropertyChanged;

  [NotifyPropertyChangedInvocator]
  protected virtual void NotifyChanged(string propertyName) { ... }

  string _name;

  public string Name {
    get { return _name; }
    set { _name = value; NotifyChanged("LastName"); /* Warning */ }
  }
}
Examples of generated notifications: NotifyChanged("Property")NotifyChanged(() => Property)NotifyChanged((VM x) => x.Property)SetProperty(ref myField, value, "Property")
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Constructor

Overload List
 | Name | Description
Public method | NotifyPropertyChangedInvocatorAttribute | Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class
Public method | NotifyPropertyChangedInvocatorAttribute(String) | Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class
Top
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Constructor

Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NotifyPropertyChangedInvocatorAttribute()
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
NotifyPropertyChangedInvocatorAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Constructor (String)

Initializes a new instance of the NotifyPropertyChangedInvocatorAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NotifyPropertyChangedInvocatorAttribute(
    string parameterName
)

Parameters

parameterName
Type: SystemString
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
NotifyPropertyChangedInvocatorAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Properties

The NotifyPropertyChangedInvocatorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ParameterName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute.ParameterName Property

NotifyPropertyChangedInvocatorAttributeParameterName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ParameterName { get; }

Property Value

Type: String
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotifyPropertyChangedInvocatorAttribute Methods

The NotifyPropertyChangedInvocatorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NotifyPropertyChangedInvocatorAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotNullAttribute Class

Indicates that the value of the marked element could never be null.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsNotNullAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class NotNullAttribute : Attribute

The NotNullAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NotNullAttribute | Initializes a new instance of the NotNullAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[NotNull] object Foo() {
  return null; // Warning: Possible 'null' assignment
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


NotNullAttribute Constructor

Initializes a new instance of the NotNullAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NotNullAttribute()
See Also

Reference

NotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotNullAttribute Properties

The NotNullAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


NotNullAttribute Methods

The NotNullAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NotNullAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Class

Indicates that a parameter is a path to a file or a folder within a web project. Path can be relative or absolute, starting from web root (~).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsPathReferenceAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class PathReferenceAttribute : Attribute

The PathReferenceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PathReferenceAttribute | Initializes a new instance of the PathReferenceAttribute class
Public method | PathReferenceAttribute(String) | Initializes a new instance of the PathReferenceAttribute class
Top
Properties
 | Name | Description
Public property | BasePath |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Constructor

Overload List
 | Name | Description
Public method | PathReferenceAttribute | Initializes a new instance of the PathReferenceAttribute class
Public method | PathReferenceAttribute(String) | Initializes a new instance of the PathReferenceAttribute class
Top
See Also

Reference

PathReferenceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Constructor

Initializes a new instance of the PathReferenceAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PathReferenceAttribute()
See Also

Reference

PathReferenceAttribute Class
PathReferenceAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Constructor (String)

Initializes a new instance of the PathReferenceAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PathReferenceAttribute(
    string basePath
)

Parameters

basePath
Type: SystemString
See Also

Reference

PathReferenceAttribute Class
PathReferenceAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Properties

The PathReferenceAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BasePath |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PathReferenceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute.BasePath Property

PathReferenceAttributeBasePath Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string BasePath { get; }

Property Value

Type: String
See Also

Reference

PathReferenceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PathReferenceAttribute Methods

The PathReferenceAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathReferenceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ProvidesContextAttribute Class

Indicates the type member or parameter of some type, that should be used instead of all other ways to get the value that type. This annotation is useful when you have some "context" value evaluated and stored somewhere, meaning that all other ways to get this value must be consolidated with existing one.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsProvidesContextAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ProvidesContextAttribute : Attribute

The ProvidesContextAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ProvidesContextAttribute | Initializes a new instance of the ProvidesContextAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
class Foo {
  [ProvidesContext] IBarService _barService = ...;

  void ProcessNode(INode node) {
    DoSomething(node, node.GetGlobalServices().Bar);
    //              ^ Warning: use value of '_barService' field
  }
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ProvidesContextAttribute Constructor

Initializes a new instance of the ProvidesContextAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ProvidesContextAttribute()
See Also

Reference

ProvidesContextAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ProvidesContextAttribute Properties

The ProvidesContextAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ProvidesContextAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ProvidesContextAttribute Methods

The ProvidesContextAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProvidesContextAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Class

This attribute is intended to mark publicly available API which should not be removed and so is treated as used.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsPublicAPIAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class PublicAPIAttribute : Attribute

The PublicAPIAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PublicAPIAttribute | Initializes a new instance of the PublicAPIAttribute class
Public method | PublicAPIAttribute(String) | Initializes a new instance of the PublicAPIAttribute class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Constructor

Overload List
 | Name | Description
Public method | PublicAPIAttribute | Initializes a new instance of the PublicAPIAttribute class
Public method | PublicAPIAttribute(String) | Initializes a new instance of the PublicAPIAttribute class
Top
See Also

Reference

PublicAPIAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Constructor

Initializes a new instance of the PublicAPIAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PublicAPIAttribute()
See Also

Reference

PublicAPIAttribute Class
PublicAPIAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Constructor (String)

Initializes a new instance of the PublicAPIAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PublicAPIAttribute(
    string comment
)

Parameters

comment
Type: SystemString
See Also

Reference

PublicAPIAttribute Class
PublicAPIAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Properties

The PublicAPIAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PublicAPIAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute.Comment Property

PublicAPIAttributeComment Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; }

Property Value

Type: String
See Also

Reference

PublicAPIAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PublicAPIAttribute Methods

The PublicAPIAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PublicAPIAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PureAttribute Class

Indicates that a method does not make any observable state changes. The same as System.Diagnostics.Contracts.PureAttribute.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsPureAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class PureAttribute : Attribute

The PureAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PureAttribute | Initializes a new instance of the PureAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[Pure] int Multiply(int x, int y) => x * y;

void M() {
  Multiply(123, 42); // Waring: Return value of pure method is not used
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


PureAttribute Constructor

Initializes a new instance of the PureAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PureAttribute()
See Also

Reference

PureAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PureAttribute Properties

The PureAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PureAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


PureAttribute Methods

The PureAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PureAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorDirectiveAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorDirectiveAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorDirectiveAttribute : Attribute

The RazorDirectiveAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorDirectiveAttribute | Initializes a new instance of the RazorDirectiveAttribute class
Top
Properties
 | Name | Description
Public property | Directive |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorDirectiveAttribute Constructor

Initializes a new instance of the RazorDirectiveAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorDirectiveAttribute(
    string directive
)

Parameters

directive
Type: SystemString
See Also

Reference

RazorDirectiveAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorDirectiveAttribute Properties

The RazorDirectiveAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Directive |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorDirectiveAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorDirectiveAttribute.Directive Property

RazorDirectiveAttributeDirective Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Directive { get; }

Property Value

Type: String
See Also

Reference

RazorDirectiveAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorDirectiveAttribute Methods

The RazorDirectiveAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorDirectiveAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorHelperCommonAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorHelperCommonAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorHelperCommonAttribute : Attribute

The RazorHelperCommonAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorHelperCommonAttribute | Initializes a new instance of the RazorHelperCommonAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorHelperCommonAttribute Constructor

Initializes a new instance of the RazorHelperCommonAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorHelperCommonAttribute()
See Also

Reference

RazorHelperCommonAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorHelperCommonAttribute Properties

The RazorHelperCommonAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorHelperCommonAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorHelperCommonAttribute Methods

The RazorHelperCommonAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorHelperCommonAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorImportNamespaceAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorImportNamespaceAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorImportNamespaceAttribute : Attribute

The RazorImportNamespaceAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorImportNamespaceAttribute | Initializes a new instance of the RazorImportNamespaceAttribute class
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorImportNamespaceAttribute Constructor

Initializes a new instance of the RazorImportNamespaceAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorImportNamespaceAttribute(
    string name
)

Parameters

name
Type: SystemString
See Also

Reference

RazorImportNamespaceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorImportNamespaceAttribute Properties

The RazorImportNamespaceAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorImportNamespaceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorImportNamespaceAttribute.Name Property

RazorImportNamespaceAttributeName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

RazorImportNamespaceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorImportNamespaceAttribute Methods

The RazorImportNamespaceAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorImportNamespaceAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorInjectionAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorInjectionAttribute : Attribute

The RazorInjectionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorInjectionAttribute | Initializes a new instance of the RazorInjectionAttribute class
Top
Properties
 | Name | Description
Public property | FieldName |
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute Constructor

Initializes a new instance of the RazorInjectionAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorInjectionAttribute(
    string type,
    string fieldName
)

Parameters

type
Type: SystemString
fieldName
Type: SystemString
See Also

Reference

RazorInjectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute Properties

The RazorInjectionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FieldName |
Public property | Type |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorInjectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute.FieldName Property

RazorInjectionAttributeFieldName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string FieldName { get; }

Property Value

Type: String
See Also

Reference

RazorInjectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute.Type Property

RazorInjectionAttributeType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Type { get; }

Property Value

Type: String
See Also

Reference

RazorInjectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorInjectionAttribute Methods

The RazorInjectionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorInjectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorLayoutAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorLayoutAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorLayoutAttribute : Attribute

The RazorLayoutAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorLayoutAttribute | Initializes a new instance of the RazorLayoutAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorLayoutAttribute Constructor

Initializes a new instance of the RazorLayoutAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorLayoutAttribute()
See Also

Reference

RazorLayoutAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorLayoutAttribute Properties

The RazorLayoutAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorLayoutAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorLayoutAttribute Methods

The RazorLayoutAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorLayoutAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorPageBaseTypeAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorPageBaseTypeAttribute : Attribute

The RazorPageBaseTypeAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorPageBaseTypeAttribute(String) | Initializes a new instance of the RazorPageBaseTypeAttribute class
Public method | RazorPageBaseTypeAttribute(String, String) | Initializes a new instance of the RazorPageBaseTypeAttribute class
Top
Properties
 | Name | Description
Public property | BaseType |
Public property | PageName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Constructor

Overload List
 | Name | Description
Public method | RazorPageBaseTypeAttribute(String) | Initializes a new instance of the RazorPageBaseTypeAttribute class
Public method | RazorPageBaseTypeAttribute(String, String) | Initializes a new instance of the RazorPageBaseTypeAttribute class
Top
See Also

Reference

RazorPageBaseTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Constructor (String)

Initializes a new instance of the RazorPageBaseTypeAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorPageBaseTypeAttribute(
    string baseType
)

Parameters

baseType
Type: SystemString
See Also

Reference

RazorPageBaseTypeAttribute Class
RazorPageBaseTypeAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Constructor (String, String)

Initializes a new instance of the RazorPageBaseTypeAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorPageBaseTypeAttribute(
    string baseType,
    string pageName
)

Parameters

baseType
Type: SystemString
pageName
Type: SystemString
See Also

Reference

RazorPageBaseTypeAttribute Class
RazorPageBaseTypeAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Properties

The RazorPageBaseTypeAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BaseType |
Public property | PageName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorPageBaseTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute.BaseType Property

RazorPageBaseTypeAttributeBaseType Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string BaseType { get; }

Property Value

Type: String
See Also

Reference

RazorPageBaseTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute.PageName Property

RazorPageBaseTypeAttributePageName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PageName { get; }

Property Value

Type: String
See Also

Reference

RazorPageBaseTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorPageBaseTypeAttribute Methods

The RazorPageBaseTypeAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorPageBaseTypeAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorSectionAttribute Class

Razor attribute. Indicates that a parameter or a method is a Razor section. Use this attribute for custom wrappers similar to System.Web.WebPages.WebPageBase.RenderSection(String).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorSectionAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorSectionAttribute : Attribute

The RazorSectionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorSectionAttribute | Initializes a new instance of the RazorSectionAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorSectionAttribute Constructor

Initializes a new instance of the RazorSectionAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorSectionAttribute()
See Also

Reference

RazorSectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorSectionAttribute Properties

The RazorSectionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorSectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorSectionAttribute Methods

The RazorSectionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorSectionAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteLiteralMethodAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorWriteLiteralMethodAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorWriteLiteralMethodAttribute : Attribute

The RazorWriteLiteralMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorWriteLiteralMethodAttribute | Initializes a new instance of the RazorWriteLiteralMethodAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteLiteralMethodAttribute Constructor

Initializes a new instance of the RazorWriteLiteralMethodAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorWriteLiteralMethodAttribute()
See Also

Reference

RazorWriteLiteralMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteLiteralMethodAttribute Properties

The RazorWriteLiteralMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorWriteLiteralMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteLiteralMethodAttribute Methods

The RazorWriteLiteralMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorWriteLiteralMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorWriteMethodAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorWriteMethodAttribute : Attribute

The RazorWriteMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorWriteMethodAttribute | Initializes a new instance of the RazorWriteMethodAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodAttribute Constructor

Initializes a new instance of the RazorWriteMethodAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorWriteMethodAttribute()
See Also

Reference

RazorWriteMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodAttribute Properties

The RazorWriteMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorWriteMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodAttribute Methods

The RazorWriteMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorWriteMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodParameterAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRazorWriteMethodParameterAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RazorWriteMethodParameterAttribute : Attribute

The RazorWriteMethodParameterAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RazorWriteMethodParameterAttribute | Initializes a new instance of the RazorWriteMethodParameterAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodParameterAttribute Constructor

Initializes a new instance of the RazorWriteMethodParameterAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RazorWriteMethodParameterAttribute()
See Also

Reference

RazorWriteMethodParameterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodParameterAttribute Properties

The RazorWriteMethodParameterAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RazorWriteMethodParameterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RazorWriteMethodParameterAttribute Methods

The RazorWriteMethodParameterAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RazorWriteMethodParameterAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RegexPatternAttribute Class

Indicates that parameter is regular expression pattern.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsRegexPatternAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class RegexPatternAttribute : Attribute

The RegexPatternAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RegexPatternAttribute | Initializes a new instance of the RegexPatternAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


RegexPatternAttribute Constructor

Initializes a new instance of the RegexPatternAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RegexPatternAttribute()
See Also

Reference

RegexPatternAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RegexPatternAttribute Properties

The RegexPatternAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RegexPatternAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


RegexPatternAttribute Methods

The RegexPatternAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RegexPatternAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


SourceTemplateAttribute Class

An extension method marked with this attribute is processed by ReSharper code completion as a 'Source Template'. When extension method is completed over some expression, it's source code is automatically expanded like a template at call site.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsSourceTemplateAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class SourceTemplateAttribute : Attribute

The SourceTemplateAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SourceTemplateAttribute | Initializes a new instance of the SourceTemplateAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Template method body can contain valid source code and/or special comments starting with '$'. Text inside these comments is added as source code when the template is applied. Template parameters can be used either as additional method parameters or as identifiers wrapped in two '$' signs. Use the MacroAttribute attribute to specify macros for parameters.
Examples
In this example, the 'forEach' method is a source template available over all values of enumerable types, producing ordinary C# 'foreach' statement and placing caret inside block:
Copy
[SourceTemplate]
public static void forEach<T>(this IEnumerable<T> xs) {
  foreach (var x in xs) {
     //$ $END$
  }
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


SourceTemplateAttribute Constructor

Initializes a new instance of the SourceTemplateAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public SourceTemplateAttribute()
See Also

Reference

SourceTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


SourceTemplateAttribute Properties

The SourceTemplateAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

SourceTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


SourceTemplateAttribute Methods

The SourceTemplateAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SourceTemplateAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


StringFormatMethodAttribute Class

Indicates that the marked method builds string by format pattern and (optional) arguments. Parameter, which contains format string, should be given in constructor. The format string should be in Format(IFormatProvider, String, Object)-like form.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsStringFormatMethodAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class StringFormatMethodAttribute : Attribute

The StringFormatMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | StringFormatMethodAttribute | Initializes a new instance of the StringFormatMethodAttribute class
Top
Properties
 | Name | Description
Public property | FormatParameterName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Examples
Copy
[StringFormatMethod("message")]
void ShowError(string message, params object[] args) { /* do something */ }

void Foo() {
  ShowError("Failed: {0}"); // Warning: Non-existing argument in format string
}
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


StringFormatMethodAttribute Constructor

Initializes a new instance of the StringFormatMethodAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public StringFormatMethodAttribute(
    string formatParameterName
)

Parameters

formatParameterName
Type: SystemString
Specifies which parameter of an annotated method should be treated as format-string
See Also

Reference

StringFormatMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


StringFormatMethodAttribute Properties

The StringFormatMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | FormatParameterName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

StringFormatMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


StringFormatMethodAttribute.FormatParameterName Property

StringFormatMethodAttributeFormatParameterName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string FormatParameterName { get; }

Property Value

Type: String
See Also

Reference

StringFormatMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


StringFormatMethodAttribute Methods

The StringFormatMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringFormatMethodAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


TerminatesProgramAttribute Class

Note: This API is now obsolete.

Indicates that the marked method unconditionally terminates control flow execution. For example, it could unconditionally throw exception.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsTerminatesProgramAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[ObsoleteAttribute("Use [ContractAnnotation('=> halt')] instead")]
public sealed class TerminatesProgramAttribute : Attribute

The TerminatesProgramAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | TerminatesProgramAttribute | Initializes a new instance of the TerminatesProgramAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


TerminatesProgramAttribute Constructor

Initializes a new instance of the TerminatesProgramAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TerminatesProgramAttribute()
See Also

Reference

TerminatesProgramAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


TerminatesProgramAttribute Properties

The TerminatesProgramAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

TerminatesProgramAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


TerminatesProgramAttribute Methods

The TerminatesProgramAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TerminatesProgramAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Class

Indicates that the marked symbol is used implicitly (e.g. via reflection, in external library), so this symbol will not be marked as unused (as well as by other usage inspections).
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsUsedImplicitlyAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class UsedImplicitlyAttribute : Attribute

The UsedImplicitlyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | UsedImplicitlyAttribute | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseKindFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseTargetFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseKindFlags, ImplicitUseTargetFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Top
Properties
 | Name | Description
Public property | TargetFlags |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UseKindFlags |
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Constructor

Overload List
 | Name | Description
Public method | UsedImplicitlyAttribute | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseKindFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseTargetFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Public method | UsedImplicitlyAttribute(ImplicitUseKindFlags, ImplicitUseTargetFlags) | Initializes a new instance of the UsedImplicitlyAttribute class
Top
See Also

Reference

UsedImplicitlyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Constructor

Initializes a new instance of the UsedImplicitlyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UsedImplicitlyAttribute()
See Also

Reference

UsedImplicitlyAttribute Class
UsedImplicitlyAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Constructor (ImplicitUseKindFlags)

Initializes a new instance of the UsedImplicitlyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UsedImplicitlyAttribute(
    ImplicitUseKindFlags useKindFlags
)

Parameters

useKindFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseKindFlags
See Also

Reference

UsedImplicitlyAttribute Class
UsedImplicitlyAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Constructor (ImplicitUseTargetFlags)

Initializes a new instance of the UsedImplicitlyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UsedImplicitlyAttribute(
    ImplicitUseTargetFlags targetFlags
)

Parameters

targetFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseTargetFlags
See Also

Reference

UsedImplicitlyAttribute Class
UsedImplicitlyAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Constructor (ImplicitUseKindFlags, ImplicitUseTargetFlags)

Initializes a new instance of the UsedImplicitlyAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UsedImplicitlyAttribute(
    ImplicitUseKindFlags useKindFlags,
    ImplicitUseTargetFlags targetFlags
)

Parameters

useKindFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseKindFlags
targetFlags
Type: Resto.Front.Api.Attributes.JetBrainsImplicitUseTargetFlags
See Also

Reference

UsedImplicitlyAttribute Class
UsedImplicitlyAttribute Overload
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Properties

The UsedImplicitlyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TargetFlags |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | UseKindFlags |
Top
See Also

Reference

UsedImplicitlyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute.TargetFlags Property

UsedImplicitlyAttributeTargetFlags Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ImplicitUseTargetFlags TargetFlags { get; }

Property Value

Type: ImplicitUseTargetFlags
See Also

Reference

UsedImplicitlyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute.UseKindFlags Property

UsedImplicitlyAttributeUseKindFlags Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ImplicitUseKindFlags UseKindFlags { get; }

Property Value

Type: ImplicitUseKindFlags
See Also

Reference

UsedImplicitlyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


UsedImplicitlyAttribute Methods

The UsedImplicitlyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UsedImplicitlyAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ValueProviderAttribute Class

For a parameter that is expected to be one of the limited set of values. Specify fields of which type should be used as values for this parameter.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsValueProviderAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ValueProviderAttribute : Attribute

The ValueProviderAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ValueProviderAttribute | Initializes a new instance of the ValueProviderAttribute class
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


ValueProviderAttribute Constructor

Initializes a new instance of the ValueProviderAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ValueProviderAttribute(
    string name
)

Parameters

name
Type: SystemString
See Also

Reference

ValueProviderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ValueProviderAttribute Properties

The ValueProviderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ValueProviderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ValueProviderAttribute.Name Property

ValueProviderAttributeName Property

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

ValueProviderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


ValueProviderAttribute Methods

The ValueProviderAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValueProviderAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemBindingOfItemsControlAttribute Class

XAML attribute. Indicates the property of some BindingBase-derived type, that is used to bind some item of ItemsControl-derived type. This annotation will enable the DataContext type resolve for XAML bindings for such properties.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsXamlItemBindingOfItemsControlAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class XamlItemBindingOfItemsControlAttribute : Attribute

The XamlItemBindingOfItemsControlAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | XamlItemBindingOfItemsControlAttribute | Initializes a new instance of the XamlItemBindingOfItemsControlAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Property should have the tree ancestor of the ItemsControl type or marked with the XamlItemsControlAttribute attribute.
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemBindingOfItemsControlAttribute Constructor

Initializes a new instance of the XamlItemBindingOfItemsControlAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XamlItemBindingOfItemsControlAttribute()
See Also

Reference

XamlItemBindingOfItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemBindingOfItemsControlAttribute Properties

The XamlItemBindingOfItemsControlAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

XamlItemBindingOfItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemBindingOfItemsControlAttribute Methods

The XamlItemBindingOfItemsControlAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XamlItemBindingOfItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemsControlAttribute Class

XAML attribute. Indicates the type that has ItemsSource property and should be treated as ItemsControl-derived type, to enable inner items DataContext type resolve.
Inheritance Hierarchy
SystemObject
SystemAttribute
Resto.Front.Api.Attributes.JetBrainsXamlItemsControlAttribute

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class XamlItemsControlAttribute : Attribute

The XamlItemsControlAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | XamlItemsControlAttribute | Initializes a new instance of the XamlItemsControlAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemsControlAttribute Constructor

Initializes a new instance of the XamlItemsControlAttribute class

Namespace: Resto.Front.Api.Attributes.JetBrains
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XamlItemsControlAttribute()
See Also

Reference

XamlItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemsControlAttribute Properties

The XamlItemsControlAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

XamlItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


XamlItemsControlAttribute Methods

The XamlItemsControlAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XamlItemsControlAttribute Class
Resto.Front.Api.Attributes.JetBrains Namespace


Resto.Front.Api.Data.Assortment Namespace

Classes
 | Class | Description
Public class | ProductExtensions | Provides a set of static methods to access referenced entities.
Public class | ProductGroupExtensions | Provides a set of static methods to access referenced entities.
Interfaces
 | Interface | Description
Public interface | IChildModifier |
Public interface | IChildModifierBase |
Public interface | ICompoundItemTemplate | Template describing a family of customizable, interchangeable and combinable products.
Public interface | IGroupModifier |
Public interface | IProduct |
Public interface | IProductCategory |
Public interface | IProductGroup |
Public interface | IProductScale | Scale of the product sizes.
Public interface | IProductSize | Size of the product, affects ingredient consumption and price.
Public interface | IQuickMenuItem | Presents cell of quick menu page grid.
Public interface | IQuickMenuPage | Presents page of quick menu.
Public interface | IQuickMenuProductGroupItem | Presents product group cell of quick menu page grid.
Public interface | IQuickMenuProductItem | Presents product cell of quick menu page grid.
Public interface | ISimpleModifier |
Public interface | ISimpleModifierBase |
Public interface | ITemplatedModifierParams | Product-specific settings of the compound item template modifier. ICompoundItemTemplate describes general modifier settings for all products of that template, different products may specify different default amount and free of charge amount for each group modifier, child modifier or simple modifier. If ProductGroup is null, this instance is about simple modifier, otherwise this instance describes params for group modifier, then Product says whether it's about group itself or about child of that group.
Enumerations
 | Enumeration | Description
Public enumeration | ProductType |


IChildModifier Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IChildModifier : ISerializable,
    IChildModifierBase

The IChildModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from IChildModifierBase.)
Public property | DefaultAmount | (Inherited from IChildModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from IChildModifierBase.)
Public property | HideIfDefaultAmount | (Inherited from IChildModifierBase.)
Public property | MaximumAmount | (Inherited from IChildModifierBase.)
Public property | MinimumAmount | (Inherited from IChildModifierBase.)
Public property | Product | (Inherited from IChildModifierBase.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IChildModifier Properties

The IChildModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from IChildModifierBase.)
Public property | DefaultAmount | (Inherited from IChildModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from IChildModifierBase.)
Public property | HideIfDefaultAmount | (Inherited from IChildModifierBase.)
Public property | MaximumAmount | (Inherited from IChildModifierBase.)
Public property | MinimumAmount | (Inherited from IChildModifierBase.)
Public property | Product | (Inherited from IChildModifierBase.)
Top
See Also

Reference

IChildModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifier Methods

The IChildModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IChildModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IChildModifierBase : ISerializable

The IChildModifierBase type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | DefaultAmount |
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | HideIfDefaultAmount |
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | Product |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase Properties

The IChildModifierBase type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | DefaultAmount |
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | HideIfDefaultAmount |
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | Product |
Top
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.AmountIndependentOfParentAmount Property

IChildModifierBaseAmountIndependentOfParentAmount Property

Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AmountIndependentOfParentAmount { get; }

Property Value

Type: Boolean
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.DefaultAmount Property

IChildModifierBaseDefaultAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int DefaultAmount { get; }

Property Value

Type: Int32
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.FreeOfChargeAmount Property

IChildModifierBaseFreeOfChargeAmount Property

Maximum amount that will be free, additional amount will be paid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int FreeOfChargeAmount { get; }

Property Value

Type: Int32
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.HideIfDefaultAmount Property

IChildModifierBaseHideIfDefaultAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HideIfDefaultAmount { get; }

Property Value

Type: Boolean
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.MaximumAmount Property

IChildModifierBaseMaximumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MaximumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.MinimumAmount Property

IChildModifierBaseMinimumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MinimumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase.Product Property

IChildModifierBaseProduct Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


IChildModifierBase Methods

The IChildModifierBase type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IChildModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate Interface

Template describing a family of customizable, interchangeable and combinable products.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICompoundItemTemplate : ISerializable,
    IEntity

The ICompoundItemTemplate type exposes the following members.

Properties
 | Name | Description
Public property | AllowProductsCombining | Whether compound items created using this template may be splitted into two components, each of which with own product and individual set of modifiers.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Template name.
Public property | Scale | Scale of the current template sizes or null for template without sizes.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate Properties

The ICompoundItemTemplate type exposes the following members.

Properties
 | Name | Description
Public property | AllowProductsCombining | Whether compound items created using this template may be splitted into two components, each of which with own product and individual set of modifiers.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Template name.
Public property | Scale | Scale of the current template sizes or null for template without sizes.
Top
See Also

Reference

ICompoundItemTemplate Interface
Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate.AllowProductsCombining Property

ICompoundItemTemplateAllowProductsCombining Property

Whether compound items created using this template may be splitted into two components, each of which with own product and individual set of modifiers.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AllowProductsCombining { get; }

Property Value

Type: Boolean
See Also

Reference

ICompoundItemTemplate Interface
Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate.Name Property

ICompoundItemTemplateName Property

Template name.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ICompoundItemTemplate Interface
Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate.Scale Property

ICompoundItemTemplateScale Property

Scale of the current template sizes or null for template without sizes.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductScale Scale { get; }

Property Value

Type: IProductScale
See Also

Reference

ICompoundItemTemplate Interface
Resto.Front.Api.Data.Assortment Namespace


ICompoundItemTemplate Methods

The ICompoundItemTemplate type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetCommonGroupModifiers | Group modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetCommonSimpleModifiers | Simple modifiers that are available for the whole compound item. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetSplittableGroupModifiers | Group modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetSplittableSimpleModifiers | Simple modifiers that are available for compound item component. See GetTemplatedModifiersParams(IProduct) of the templated products to get default amount settings for them. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

ICompoundItemTemplate Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IGroupModifier : ISerializable

The IGroupModifier type exposes the following members.

Properties
 | Name | Description
Public property | FreeOfChargeAmount | Maximum amount of child modifiers that will be free, additional amount will be paid.
Public property | Items |
Public property | MaximumAmount |
Public property | MenuIndex | Gets an index of modifier group in hierarchical menu, can be used to sort modifier groups of product.
Public property | MinimumAmount |
Public property | ProductGroup |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IGroupModifier Properties

The IGroupModifier type exposes the following members.

Properties
 | Name | Description
Public property | FreeOfChargeAmount | Maximum amount of child modifiers that will be free, additional amount will be paid.
Public property | Items |
Public property | MaximumAmount |
Public property | MenuIndex | Gets an index of modifier group in hierarchical menu, can be used to sort modifier groups of product.
Public property | MinimumAmount |
Public property | ProductGroup |
Top
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.FreeOfChargeAmount Property

IGroupModifierFreeOfChargeAmount Property

Maximum amount of child modifiers that will be free, additional amount will be paid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int FreeOfChargeAmount { get; }

Property Value

Type: Int32
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.Items Property

IGroupModifierItems Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IChildModifier> Items { get; }

Property Value

Type: IReadOnlyList IChildModifier
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.MaximumAmount Property

IGroupModifierMaximumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MaximumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.MenuIndex Property

IGroupModifierMenuIndex Property

Gets an index of modifier group in hierarchical menu, can be used to sort modifier groups of product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MenuIndex { get; }

Property Value

Type: Int32
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.MinimumAmount Property

IGroupModifierMinimumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MinimumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier.ProductGroup Property

IGroupModifierProductGroup Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup ProductGroup { get; }

Property Value

Type: IProductGroup
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IGroupModifier Methods

The IGroupModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IGroupModifier Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProduct : ISerializable,
    IEntity

The IProduct type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Background color of a menu button for the product. If the product has a menu image (HasMenuImage, TryGetProductMenuImage(IProduct)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor
Public property | CanSetOpenPrice | Gets a value that indicates whether the product possible to set an open price.
Public property | Category |
Public property | DefaultCourse | Default course of the product.
Public property | Description |
Public property | DescriptionForeign |
Public property | ExpirationTime |
Public property | FastCode | Quick type product code
Public property | FontColor | Font color of a menu button for the product's name.
Public property | FoodValueCaloricity |
Public property | FoodValueCarbohydrate |
Public property | FoodValueFat |
Public property | FoodValueProtein |
Public property | ForeignName |
Public property | FullName |
Public property | HasMenuImage | Whether the product has an image to be used as a background in menu. If true, call TryGetProductMenuImage(IProduct) to get an image. If the product doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.
Public property | Id | (Inherited from IEntity.)
Public property | ImmediateCookingStart | Indicates whether the product cooking or time pay service execution should be started immediately after adding into the order. It is expected that plugin will check this flag and apply appropriate action.
Public property | IsActive | Gets a value that indicates whether this product is active in assortment base. Product can be activated or deactivated via iikoOffice.
Public property | KitchenName |
Public property | MeasuringUnitName | Measurement unit of product to be displayed
Public property | MenuIndex | Gets an index of product in hierarchical menu, can be used to sort products inside the same product group.
Public property | Name |
Public property | Number | Nomenclature article of product.
Public property | Price |
Public property | RateSchedule | For products of type Service is a schedule of a service rates. null for other product types.
Public property | Scale | Scale of the current product sizes or null for product without sizes.
Public property | TaxPercent | Tax percent or null for not taxed products.
Public property | Template | Template of the current product or null for product without template.
Public property | Type |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetDisabledSizes | Returns disabledSizes of the specified product. (Defined by ProductExtensions.)
Public Extension Method | GetGroupModifiers | Returns group modifiers of the specified product. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetIncludedInMenuSections | Returns includedInMenuSections of the specified product. (Defined by ProductExtensions.)
Public Extension Method | GetSimpleModifiers | Returns simple modifiers of the specified product. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product. (Defined by ProductExtensions.)
Public Extension Method | TryGetDisabledSizes | Returns disabledSizes of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetIncludedInMenuSections | Returns includedInMenuSections of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetParent | Returns parent of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned. (Defined by OperationArgumentExtensions.)
Public Extension Method | TryGetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IProduct Properties

The IProduct type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Background color of a menu button for the product. If the product has a menu image (HasMenuImage, TryGetProductMenuImage(IProduct)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor
Public property | CanSetOpenPrice | Gets a value that indicates whether the product possible to set an open price.
Public property | Category |
Public property | DefaultCourse | Default course of the product.
Public property | Description |
Public property | DescriptionForeign |
Public property | ExpirationTime |
Public property | FastCode | Quick type product code
Public property | FontColor | Font color of a menu button for the product's name.
Public property | FoodValueCaloricity |
Public property | FoodValueCarbohydrate |
Public property | FoodValueFat |
Public property | FoodValueProtein |
Public property | ForeignName |
Public property | FullName |
Public property | HasMenuImage | Whether the product has an image to be used as a background in menu. If true, call TryGetProductMenuImage(IProduct) to get an image. If the product doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.
Public property | Id | (Inherited from IEntity.)
Public property | ImmediateCookingStart | Indicates whether the product cooking or time pay service execution should be started immediately after adding into the order. It is expected that plugin will check this flag and apply appropriate action.
Public property | IsActive | Gets a value that indicates whether this product is active in assortment base. Product can be activated or deactivated via iikoOffice.
Public property | KitchenName |
Public property | MeasuringUnitName | Measurement unit of product to be displayed
Public property | MenuIndex | Gets an index of product in hierarchical menu, can be used to sort products inside the same product group.
Public property | Name |
Public property | Number | Nomenclature article of product.
Public property | Price |
Public property | RateSchedule | For products of type Service is a schedule of a service rates. null for other product types.
Public property | Scale | Scale of the current product sizes or null for product without sizes.
Public property | TaxPercent | Tax percent or null for not taxed products.
Public property | Template | Template of the current product or null for product without template.
Public property | Type |
Top
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.BackgroundColor Property

IProductBackgroundColor Property

Background color of a menu button for the product. If the product has a menu image (HasMenuImage, TryGetProductMenuImage(IProduct)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Color? BackgroundColor { get; }

Property Value

Type: Nullable Color
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.CanSetOpenPrice Property

IProductCanSetOpenPrice Property

Gets a value that indicates whether the product possible to set an open price.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanSetOpenPrice { get; }

Property Value

Type: Boolean
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Category Property

IProductCategory Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductCategory Category { get; }

Property Value

Type: IProductCategory
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.DefaultCourse Property

IProductDefaultCourse Property

Default course of the product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderItemCourse DefaultCourse { get; }

Property Value

Type: OrderItemCourse
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Description Property

IProductDescription Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Description { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.DescriptionForeign Property

IProductDescriptionForeign Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string DescriptionForeign { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.ExpirationTime Property

IProductExpirationTime Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? ExpirationTime { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FastCode Property

IProductFastCode Property

Quick type product code

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FastCode { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FontColor Property

IProductFontColor Property

Font color of a menu button for the product's name.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Color? FontColor { get; }

Property Value

Type: Nullable Color
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FoodValueCaloricity Property

IProductFoodValueCaloricity Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal FoodValueCaloricity { get; }

Property Value

Type: Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FoodValueCarbohydrate Property

IProductFoodValueCarbohydrate Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal FoodValueCarbohydrate { get; }

Property Value

Type: Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FoodValueFat Property

IProductFoodValueFat Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal FoodValueFat { get; }

Property Value

Type: Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FoodValueProtein Property

IProductFoodValueProtein Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal FoodValueProtein { get; }

Property Value

Type: Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.ForeignName Property

IProductForeignName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ForeignName { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.FullName Property

IProductFullName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullName { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.HasMenuImage Property

IProductHasMenuImage Property

Whether the product has an image to be used as a background in menu. If true, call TryGetProductMenuImage(IProduct) to get an image. If the product doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasMenuImage { get; }

Property Value

Type: Boolean
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.ImmediateCookingStart Property

IProductImmediateCookingStart Property

Indicates whether the product cooking or time pay service execution should be started immediately after adding into the order. It is expected that plugin will check this flag and apply appropriate action.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ImmediateCookingStart { get; }

Property Value

Type: Boolean
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.IsActive Property

IProductIsActive Property

Gets a value that indicates whether this product is active in assortment base. Product can be activated or deactivated via iikoOffice.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.KitchenName Property

IProductKitchenName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string KitchenName { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.MeasuringUnitName Property

IProductMeasuringUnitName Property

Measurement unit of product to be displayed

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string MeasuringUnitName { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.MenuIndex Property

IProductMenuIndex Property

Gets an index of product in hierarchical menu, can be used to sort products inside the same product group.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MenuIndex { get; }

Property Value

Type: Int32
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Name Property

IProductName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Number Property

IProductNumber Property

Nomenclature article of product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Number { get; }

Property Value

Type: String
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Price Property

IProductPrice Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.RateSchedule Property

IProductRateSchedule Property

For products of type Service is a schedule of a service rates. null for other product types.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
RateSchedule RateSchedule { get; }

Property Value

Type: RateSchedule
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Scale Property

IProductScale Property

Scale of the current product sizes or null for product without sizes.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductScale Scale { get; }

Property Value

Type: IProductScale
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.TaxPercent Property

IProductTaxPercent Property

Tax percent or null for not taxed products.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? TaxPercent { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Template Property

IProductTemplate Property

Template of the current product or null for product without template.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICompoundItemTemplate Template { get; }

Property Value

Type: ICompoundItemTemplate
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct.Type Property

IProductType Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ProductType Type { get; }

Property Value

Type: ProductType
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProduct Methods

The IProduct type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetDisabledSizes | Returns disabledSizes of the specified product. (Defined by ProductExtensions.)
Public Extension Method | GetGroupModifiers | Returns group modifiers of the specified product. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetIncludedInMenuSections | Returns includedInMenuSections of the specified product. (Defined by ProductExtensions.)
Public Extension Method | GetSimpleModifiers | Returns simple modifiers of the specified product. (Defined by OperationArgumentExtensions.)
Public Extension Method | GetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product. (Defined by ProductExtensions.)
Public Extension Method | TryGetDisabledSizes | Returns disabledSizes of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetIncludedInMenuSections | Returns includedInMenuSections of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetParent | Returns parent of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned. (Defined by OperationArgumentExtensions.)
Public Extension Method | TryGetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product or null if product doesn't exist. (Defined by ProductExtensions.)
Top
See Also

Reference

IProduct Interface
Resto.Front.Api.Data.Assortment Namespace


IProductCategory Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductCategory : ISerializable,
    IEntity

The IProductCategory type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IProductCategory Properties

The IProductCategory type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
See Also

Reference

IProductCategory Interface
Resto.Front.Api.Data.Assortment Namespace


IProductCategory.Name Property

IProductCategoryName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IProductCategory Interface
Resto.Front.Api.Data.Assortment Namespace


IProductCategory Methods

The IProductCategory type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductCategory Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductGroup : ISerializable,
    IEntity

The IProductGroup type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Background color of a menu button for the product group. If the product group has a menu image (HasMenuImage, TryGetProductGroupMenuImage(IProductGroup)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor
Public property | FontColor | Font color of a menu button for the product group's name.
Public property | HasMenuImage | Whether the product group has an image to be used as a background in menu. If true, call TryGetProductGroupMenuImage(IProductGroup) to get an image. If the product group doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.
Public property | Id | (Inherited from IEntity.)
Public property | MenuIndex | Gets an index of product group in hierarchical menu, can be used to sort product groups inside the same parent product group.
Public property | Name |
Public property | Number | Nomenclature article of product group.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetChildGroups | Returns childGroups of the specified productGroup. (Defined by ProductGroupExtensions.)
Public Extension Method | GetChildProducts | Returns childProducts of the specified productGroup. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetChildGroups | Returns childGroups of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetChildProducts | Returns childProducts of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetParent | Returns parent of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetProductGroupMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IProductGroup Properties

The IProductGroup type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Background color of a menu button for the product group. If the product group has a menu image (HasMenuImage, TryGetProductGroupMenuImage(IProductGroup)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor
Public property | FontColor | Font color of a menu button for the product group's name.
Public property | HasMenuImage | Whether the product group has an image to be used as a background in menu. If true, call TryGetProductGroupMenuImage(IProductGroup) to get an image. If the product group doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.
Public property | Id | (Inherited from IEntity.)
Public property | MenuIndex | Gets an index of product group in hierarchical menu, can be used to sort product groups inside the same parent product group.
Public property | Name |
Public property | Number | Nomenclature article of product group.
Top
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.BackgroundColor Property

IProductGroupBackgroundColor Property

Background color of a menu button for the product group. If the product group has a menu image (HasMenuImage, TryGetProductGroupMenuImage(IProductGroup)) and UI supports images in menu, image should be used as a background instead of solid BackgroundColor

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Color? BackgroundColor { get; }

Property Value

Type: Nullable Color
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.FontColor Property

IProductGroupFontColor Property

Font color of a menu button for the product group's name.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Color? FontColor { get; }

Property Value

Type: Nullable Color
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.HasMenuImage Property

IProductGroupHasMenuImage Property

Whether the product group has an image to be used as a background in menu. If true, call TryGetProductGroupMenuImage(IProductGroup) to get an image. If the product group doesn't have an image or UI doesn't support images in menu, use BackgroundColor as a menu button background.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasMenuImage { get; }

Property Value

Type: Boolean
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.MenuIndex Property

IProductGroupMenuIndex Property

Gets an index of product group in hierarchical menu, can be used to sort product groups inside the same parent product group.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MenuIndex { get; }

Property Value

Type: Int32
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.Name Property

IProductGroupName Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup.Number Property

IProductGroupNumber Property

Nomenclature article of product group.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Number { get; }

Property Value

Type: String
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductGroup Methods

The IProductGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetChildGroups | Returns childGroups of the specified productGroup. (Defined by ProductGroupExtensions.)
Public Extension Method | GetChildProducts | Returns childProducts of the specified productGroup. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetChildGroups | Returns childGroups of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetChildProducts | Returns childProducts of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetParent | Returns parent of the specified productGroup or null if productGroup doesn't exist. (Defined by ProductGroupExtensions.)
Public Extension Method | TryGetProductGroupMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned. (Defined by ProductExtensions.)
Public Extension Method | TryGetProductGroupMenuImage | Returns a byte sequence presenting an image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

IProductGroup Interface
Resto.Front.Api.Data.Assortment Namespace


IProductScale Interface

Scale of the product sizes.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductScale : ISerializable,
    IEntity

The IProductScale type exposes the following members.

Properties
 | Name | Description
Public property | DefaultSize | Size to use by default when using products with this scale.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of the product scale.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IProductScale Properties

The IProductScale type exposes the following members.

Properties
 | Name | Description
Public property | DefaultSize | Size to use by default when using products with this scale.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of the product scale.
Top
See Also

Reference

IProductScale Interface
Resto.Front.Api.Data.Assortment Namespace


IProductScale.DefaultSize Property

IProductScaleDefaultSize Property

Size to use by default when using products with this scale.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize DefaultSize { get; }

Property Value

Type: IProductSize
See Also

Reference

IProductScale Interface
Resto.Front.Api.Data.Assortment Namespace


IProductScale.Name Property

IProductScaleName Property

Name of the product scale.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IProductScale Interface
Resto.Front.Api.Data.Assortment Namespace


IProductScale Methods

The IProductScale type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductScale Interface
Resto.Front.Api.Data.Assortment Namespace


IProductSize Interface

Size of the product, affects ingredient consumption and price.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductSize : ISerializable,
    IEntity

The IProductSize type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | KitchenName | Name of the product size adapted for kitchen displays (usually as short as possible).
Public property | MenuIndex | Gets an index of the current size in the list of the product scale sizes, can be used to sort product sizes in menu.
Public property | Name | Name of the product size.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IProductSize Properties

The IProductSize type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | KitchenName | Name of the product size adapted for kitchen displays (usually as short as possible).
Public property | MenuIndex | Gets an index of the current size in the list of the product scale sizes, can be used to sort product sizes in menu.
Public property | Name | Name of the product size.
Top
See Also

Reference

IProductSize Interface
Resto.Front.Api.Data.Assortment Namespace


IProductSize.KitchenName Property

IProductSizeKitchenName Property

Name of the product size adapted for kitchen displays (usually as short as possible).

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string KitchenName { get; }

Property Value

Type: String
See Also

Reference

IProductSize Interface
Resto.Front.Api.Data.Assortment Namespace


IProductSize.MenuIndex Property

IProductSizeMenuIndex Property

Gets an index of the current size in the list of the product scale sizes, can be used to sort product sizes in menu.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MenuIndex { get; }

Property Value

Type: Int32
See Also

Reference

IProductSize Interface
Resto.Front.Api.Data.Assortment Namespace


IProductSize.Name Property

IProductSizeName Property

Name of the product size.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IProductSize Interface
Resto.Front.Api.Data.Assortment Namespace


IProductSize Methods

The IProductSize type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductSize Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuItem Interface

Presents cell of quick menu page grid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IQuickMenuItem : ISerializable

The IQuickMenuItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IQuickMenuItem Methods

The IQuickMenuItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IQuickMenuItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuPage Interface

Presents page of quick menu.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IQuickMenuPage : ISerializable

The IQuickMenuPage type exposes the following members.

Properties
 | Name | Description
Public property | Items | Quick menu items grid. Empty cells are null, others are either product or product group.
Public property | Name | Quick menu page name.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IQuickMenuPage Properties

The IQuickMenuPage type exposes the following members.

Properties
 | Name | Description
Public property | Items | Quick menu items grid. Empty cells are null, others are either product or product group.
Public property | Name | Quick menu page name.
Top
See Also

Reference

IQuickMenuPage Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuPage.Items Property

IQuickMenuPageItems Property

Quick menu items grid. Empty cells are null, others are either product or product group.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IQuickMenuItem[,] Items { get; }

Property Value

Type: IQuickMenuItem
See Also

Reference

IQuickMenuPage Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuPage.Name Property

IQuickMenuPageName Property

Quick menu page name.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IQuickMenuPage Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuPage Methods

The IQuickMenuPage type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IQuickMenuPage Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductGroupItem Interface

Presents product group cell of quick menu page grid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IQuickMenuProductGroupItem : ISerializable,
    IQuickMenuItem

The IQuickMenuProductGroupItem type exposes the following members.

Properties
 | Name | Description
Public property | ProductGroup |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductGroupItem Properties

The IQuickMenuProductGroupItem type exposes the following members.

Properties
 | Name | Description
Public property | ProductGroup |
Top
See Also

Reference

IQuickMenuProductGroupItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductGroupItem.ProductGroup Property

IQuickMenuProductGroupItemProductGroup Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup ProductGroup { get; }

Property Value

Type: IProductGroup
See Also

Reference

IQuickMenuProductGroupItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductGroupItem Methods

The IQuickMenuProductGroupItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IQuickMenuProductGroupItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductItem Interface

Presents product cell of quick menu page grid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IQuickMenuProductItem : ISerializable,
    IQuickMenuItem

The IQuickMenuProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Product |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductItem Properties

The IQuickMenuProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Product |
Top
See Also

Reference

IQuickMenuProductItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductItem.Product Property

IQuickMenuProductItemProduct Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IQuickMenuProductItem Interface
Resto.Front.Api.Data.Assortment Namespace


IQuickMenuProductItem Methods

The IQuickMenuProductItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IQuickMenuProductItem Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifier Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISimpleModifier : ISerializable,
    ISimpleModifierBase

The ISimpleModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from ISimpleModifierBase.)
Public property | DefaultAmount | (Inherited from ISimpleModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from ISimpleModifierBase.)
Public property | MaximumAmount | (Inherited from ISimpleModifierBase.)
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product. (Inherited from ISimpleModifierBase.)
Public property | MinimumAmount | (Inherited from ISimpleModifierBase.)
Public property | Product | (Inherited from ISimpleModifierBase.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ISimpleModifier Properties

The ISimpleModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from ISimpleModifierBase.)
Public property | DefaultAmount | (Inherited from ISimpleModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from ISimpleModifierBase.)
Public property | MaximumAmount | (Inherited from ISimpleModifierBase.)
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product. (Inherited from ISimpleModifierBase.)
Public property | MinimumAmount | (Inherited from ISimpleModifierBase.)
Public property | Product | (Inherited from ISimpleModifierBase.)
Top
See Also

Reference

ISimpleModifier Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifier Methods

The ISimpleModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ISimpleModifier Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase Interface

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISimpleModifierBase : ISerializable

The ISimpleModifierBase type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | DefaultAmount |
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | MaximumAmount |
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product.
Public property | MinimumAmount |
Public property | Product |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase Properties

The ISimpleModifierBase type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | DefaultAmount |
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | MaximumAmount |
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product.
Public property | MinimumAmount |
Public property | Product |
Top
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.AmountIndependentOfParentAmount Property

ISimpleModifierBaseAmountIndependentOfParentAmount Property

Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AmountIndependentOfParentAmount { get; }

Property Value

Type: Boolean
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.DefaultAmount Property

ISimpleModifierBaseDefaultAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int DefaultAmount { get; }

Property Value

Type: Int32
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.FreeOfChargeAmount Property

ISimpleModifierBaseFreeOfChargeAmount Property

Maximum amount that will be free, additional amount will be paid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int FreeOfChargeAmount { get; }

Property Value

Type: Int32
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.MaximumAmount Property

ISimpleModifierBaseMaximumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MaximumAmount { get; }

Property Value

Type: Int32
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.MenuIndex Property

ISimpleModifierBaseMenuIndex Property

Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MenuIndex { get; }

Property Value

Type: Int32
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.MinimumAmount Property

ISimpleModifierBaseMinimumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MinimumAmount { get; }

Property Value

Type: Int32
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase.Product Property

ISimpleModifierBaseProduct Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ISimpleModifierBase Methods

The ISimpleModifierBase type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ISimpleModifierBase Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams Interface

Product-specific settings of the compound item template modifier. ICompoundItemTemplate describes general modifier settings for all products of that template, different products may specify different default amount and free of charge amount for each group modifier, child modifier or simple modifier. If ProductGroup is null, this instance is about simple modifier, otherwise this instance describes params for group modifier, then Product says whether it's about group itself or about child of that group.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITemplatedModifierParams : ISerializable

The ITemplatedModifierParams type exposes the following members.

Properties
 | Name | Description
Public property | DefaultAmount | Default amount of the modifier for this object's owner product within compound item template. If the compound item is splitted, default amount of the common modifier is determined by the primary component's product.
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | Product | Product of the modifier, depending on ProductGroup it is a simple or a child modifier.
Public property | ProductGroup | Group of the child modifier or null for simple modifier.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams Properties

The ITemplatedModifierParams type exposes the following members.

Properties
 | Name | Description
Public property | DefaultAmount | Default amount of the modifier for this object's owner product within compound item template. If the compound item is splitted, default amount of the common modifier is determined by the primary component's product.
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid.
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | Product | Product of the modifier, depending on ProductGroup it is a simple or a child modifier.
Public property | ProductGroup | Group of the child modifier or null for simple modifier.
Top
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.DefaultAmount Property

ITemplatedModifierParamsDefaultAmount Property

Default amount of the modifier for this object's owner product within compound item template. If the compound item is splitted, default amount of the common modifier is determined by the primary component's product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int DefaultAmount { get; }

Property Value

Type: Int32
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.FreeOfChargeAmount Property

ITemplatedModifierParamsFreeOfChargeAmount Property

Maximum amount that will be free, additional amount will be paid.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int FreeOfChargeAmount { get; }

Property Value

Type: Int32
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.MaximumAmount Property

ITemplatedModifierParamsMaximumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? MaximumAmount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.MinimumAmount Property

ITemplatedModifierParamsMinimumAmount Property

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? MinimumAmount { get; }

Property Value

Type: Nullable Int32
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.Product Property

ITemplatedModifierParamsProduct Property

Product of the modifier, depending on ProductGroup it is a simple or a child modifier.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams.ProductGroup Property

ITemplatedModifierParamsProductGroup Property

Group of the child modifier or null for simple modifier.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup ProductGroup { get; }

Property Value

Type: IProductGroup
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ITemplatedModifierParams Methods

The ITemplatedModifierParams type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITemplatedModifierParams Interface
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions Class

Provides a set of static methods to access referenced entities.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.AssortmentProductExtensions

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class ProductExtensions

The ProductExtensions type exposes the following members.

Methods
Name | Description
GetDisabledSizes | Returns disabledSizes of the specified product.
GetIncludedInMenuSections | Returns includedInMenuSections of the specified product.
GetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product.
TryGetDisabledSizes | Returns disabledSizes of the specified product or null if product doesn't exist.
TryGetIncludedInMenuSections | Returns includedInMenuSections of the specified product or null if product doesn't exist.
TryGetParent | Returns parent of the specified product or null if product doesn't exist.
TryGetProductGroupMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
TryGetProductMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
TryGetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product or null if product doesn't exist.
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ProductExtensions Methods

The ProductExtensions type exposes the following members.

Methods
Name | Description
GetDisabledSizes | Returns disabledSizes of the specified product.
GetIncludedInMenuSections | Returns includedInMenuSections of the specified product.
GetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product.
TryGetDisabledSizes | Returns disabledSizes of the specified product or null if product doesn't exist.
TryGetIncludedInMenuSections | Returns includedInMenuSections of the specified product or null if product doesn't exist.
TryGetParent | Returns parent of the specified product or null if product doesn't exist.
TryGetProductGroupMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.
TryGetProductMenuBitmap | Returns a bitmap image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.
TryGetTemplatedModifiersParams | Returns templatedModifiersParams of the specified product or null if product doesn't exist.
Top
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.GetDisabledSizes Method

ProductExtensionsGetDisabledSizes Method

Returns disabledSizes of the specified product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProductSize> GetDisabledSizes(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IProductSize

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.GetIncludedInMenuSections Method

ProductExtensionsGetIncludedInMenuSections Method

Returns includedInMenuSections of the specified product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IRestaurantSection> GetIncludedInMenuSections(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IRestaurantSection

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.GetTemplatedModifiersParams Method

ProductExtensionsGetTemplatedModifiersParams Method

Returns templatedModifiersParams of the specified product.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<ITemplatedModifierParams> GetTemplatedModifiersParams(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList ITemplatedModifierParams

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.TryGetDisabledSizes Method

ProductExtensionsTryGetDisabledSizes Method

Returns disabledSizes of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProductSize> TryGetDisabledSizes(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IProductSize

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.TryGetIncludedInMenuSections Method

ProductExtensionsTryGetIncludedInMenuSections Method

Returns includedInMenuSections of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IRestaurantSection> TryGetIncludedInMenuSections(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList IRestaurantSection

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.TryGetParent Method

ProductExtensionsTryGetParent Method

Returns parent of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IProductGroup TryGetParent(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IProductGroup

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductExtensions.TryGetProductGroupMenuBitmap Method

ProductExtensionsTryGetProductGroupMenuBitmap Method

Returns a bitmap image to be shown as a background on a menu button for the specified product group. If the product group doesn't have an image, null will be returned.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static Bitmap TryGetProductGroupMenuBitmap(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Product group to get menu image for.

Return Value

Type: Bitmap

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace
IProductGroupHasMenuImage
IProductGroupBackgroundColor
IProductGroupFontColor
IOperationServiceTryGetProductGroupMenuImage(IProductGroup)


ProductExtensions.TryGetProductMenuBitmap Method

ProductExtensionsTryGetProductMenuBitmap Method

Returns a bitmap image to be shown as a background on a menu button for the specified product. If the product doesn't have an image, null will be returned.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static Bitmap TryGetProductMenuBitmap(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Product to get menu image for.

Return Value

Type: Bitmap

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
The image may be of any format, depending on what the user has uploaded.
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace
IProductHasMenuImage
IProductBackgroundColor
IProductFontColor
IOperationServiceTryGetProductMenuImage(IProduct)


ProductExtensions.TryGetTemplatedModifiersParams Method

ProductExtensionsTryGetTemplatedModifiersParams Method

Returns templatedModifiersParams of the specified product or null if product doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<ITemplatedModifierParams> TryGetTemplatedModifiersParams(
    this IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct

Return Value

Type: IReadOnlyList ITemplatedModifierParams

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProduct. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions Class

Provides a set of static methods to access referenced entities.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.AssortmentProductGroupExtensions

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class ProductGroupExtensions

The ProductGroupExtensions type exposes the following members.

Methods
Name | Description
GetChildGroups | Returns childGroups of the specified productGroup.
GetChildProducts | Returns childProducts of the specified productGroup.
TryGetChildGroups | Returns childGroups of the specified productGroup or null if productGroup doesn't exist.
TryGetChildProducts | Returns childProducts of the specified productGroup or null if productGroup doesn't exist.
TryGetParent | Returns parent of the specified productGroup or null if productGroup doesn't exist.
Top
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions Methods

The ProductGroupExtensions type exposes the following members.

Methods
Name | Description
GetChildGroups | Returns childGroups of the specified productGroup.
GetChildProducts | Returns childProducts of the specified productGroup.
TryGetChildGroups | Returns childGroups of the specified productGroup or null if productGroup doesn't exist.
TryGetChildProducts | Returns childProducts of the specified productGroup or null if productGroup doesn't exist.
TryGetParent | Returns parent of the specified productGroup or null if productGroup doesn't exist.
Top
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions.GetChildGroups Method

ProductGroupExtensionsGetChildGroups Method

Returns childGroups of the specified productGroup.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProductGroup> GetChildGroups(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProductGroup

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions.GetChildProducts Method

ProductGroupExtensionsGetChildProducts Method

Returns childProducts of the specified productGroup.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProduct> GetChildProducts(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProduct

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions.TryGetChildGroups Method

ProductGroupExtensionsTryGetChildGroups Method

Returns childGroups of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProductGroup> TryGetChildGroups(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProductGroup

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions.TryGetChildProducts Method

ProductGroupExtensionsTryGetChildProducts Method

Returns childProducts of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReadOnlyList<IProduct> TryGetChildProducts(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IReadOnlyList IProduct

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductGroupExtensions.TryGetParent Method

ProductGroupExtensionsTryGetParent Method

Returns parent of the specified productGroup or null if productGroup doesn't exist.

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IProductGroup TryGetParent(
    this IProductGroup productGroup
)

Parameters

productGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup

Return Value

Type: IProductGroup

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IProductGroup. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProductGroupExtensions Class
Resto.Front.Api.Data.Assortment Namespace


ProductType Enumeration

Namespace: Resto.Front.Api.Data.Assortment
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ProductType
Members
Member name | Value | Description
Goods | 0 | Goods
Dish | 1 | Dish
Modifier | 2 | Modifier
Service | 3 | Service
Rate | 4 | Rate
Petrol | 5 | Petrol
HalfFinishedGoods | 6 | Half finished goods
ExternalGoods | 7 | External goods
ForPurchase | 8 | Product for purchase, has a negative price
See Also

Reference

Resto.Front.Api.Data.Assortment Namespace


Resto.Front.Api.Data.Brd Namespace

Classes
 | Class | Description
Public class | AddressDto |
Public class | DeliverySmsNotificationTemplates |
Public class | EmailDto |
Public class | ExternalCourierServiceDataDto |
Public class | PhoneDto |
Interfaces
 | Interface | Description
Public interface | IAddress |
Public interface | ICity |
Public interface | IClient |
Public interface | ICounteragent |
Public interface | IDeliveryCancelCause |
Public interface | IEmail |
Public interface | IExternalCourier |
Public interface | IExternalCourierService |
Public interface | IExternalCourierServiceData |
Public interface | IMarketingSource |
Public interface | IPhone |
Public interface | IRegion |
Public interface | IReserve |
Public interface | IStreet |
Public interface | ISurveyItem | Item of client's survey.
Enumerations
 | Enumeration | Description
Public enumeration | DeliveryBillPrintTimeOption | Delivery bill may be printed either automatically or manually. This option specifies how and when to print delivery bill.
Public enumeration | DeliveryPaymentTimeOption | Order may be paid either before sending a courier to way or after successful delivery before closing. This option specifies when to pay courier deliveries.
Public enumeration | DeliverySmsSendingEventType | Дубликат одноименного серверного перечисления для нужд api.
Public enumeration | DeliveryStatus |
Public enumeration | Gender | Gender of a client.
Public enumeration | ReserveCancelReason | Reason why planned event failed.
Public enumeration | ReserveStatus | Describes the status of a reserve or a banquet.
Public enumeration | SurveyType | Describes the type of the survey item.


AddressDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.BrdAddressDto

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class AddressDto : ISerializable

The AddressDto type exposes the following members.

Constructors
 | Name | Description
Public method | AddressDto | Initializes a new instance of the AddressDto class
Protected method | AddressDto(SerializationInfo, StreamingContext) | Initializes a new instance of the AddressDto class
Top
Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | Building |
Public property | Doorphone |
Public property | Entrance |
Public property | ExternalCartographyId |
Public property | Flat |
Public property | Floor |
Public property | House |
Public property | Index |
Public property | RegionId |
Public property | StreetId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


AddressDto Constructor

Overload List
 | Name | Description
Public method | AddressDto | Initializes a new instance of the AddressDto class
Protected method | AddressDto(SerializationInfo, StreamingContext) | Initializes a new instance of the AddressDto class
Top
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto Constructor

Initializes a new instance of the AddressDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AddressDto()
See Also

Reference

AddressDto Class
AddressDto Overload
Resto.Front.Api.Data.Brd Namespace


AddressDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AddressDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected AddressDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

AddressDto Class
AddressDto Overload
Resto.Front.Api.Data.Brd Namespace


AddressDto Properties

The AddressDto type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | Building |
Public property | Doorphone |
Public property | Entrance |
Public property | ExternalCartographyId |
Public property | Flat |
Public property | Floor |
Public property | House |
Public property | Index |
Public property | RegionId |
Public property | StreetId |
Top
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.AdditionalInfo Property

AddressDtoAdditionalInfo Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string AdditionalInfo { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Building Property

AddressDtoBuilding Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Building { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Doorphone Property

AddressDtoDoorphone Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Doorphone { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Entrance Property

AddressDtoEntrance Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Entrance { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.ExternalCartographyId Property

AddressDtoExternalCartographyId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ExternalCartographyId { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Flat Property

AddressDtoFlat Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Flat { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Floor Property

AddressDtoFloor Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Floor { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.House Property

AddressDtoHouse Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string House { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.Index Property

AddressDtoIndex Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Index { get; set; }

Property Value

Type: String
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.RegionId Property

AddressDtoRegionId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid RegionId { get; set; }

Property Value

Type: Guid
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.StreetId Property

AddressDtoStreetId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid StreetId { get; set; }

Property Value

Type: Guid
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto Methods

The AddressDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


AddressDto.GetObjectData Method

AddressDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AddressDto Class
Resto.Front.Api.Data.Brd Namespace


DeliveryBillPrintTimeOption Enumeration

Delivery bill may be printed either automatically or manually. This option specifies how and when to print delivery bill.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeliveryBillPrintTimeOption
Members
Member name | Value | Description
Manually | 0 | Delivery bill may be printed manually at user's or plugin's discretion. Use PrintDeliveryBill(ICredentials, IDeliveryOrder) method to print delivery bill. If delivery bill hasn't been printed manually before sending the delivery, it will be printed automatically on send.
AutomaticallyOnCookingStarted | 1 | Delivery bill will be printed automatically on cooking start. Cooking may start automatically or manually (use PrintOrderItems(ICredentials, IOrder, IReadOnlyListIOrderCookingItem) method to manually start cooking).
AutomaticallyOnCookingCompleted | 2 | Delivery bill will be printed automatically on cooking complete.
AutomaticallyOnSending | 3 | Delivery bill will be printed automatically on sending delivery.
AutomaticallyOnPayment | 4 | Delivery bill will be printed automatically on payment.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


DeliveryPaymentTimeOption Enumeration

Order may be paid either before sending a courier to way or after successful delivery before closing. This option specifies when to pay courier deliveries.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeliveryPaymentTimeOption
Members
Member name | Value | Description
BeforeSending | 0 | Delivery must be paid before sending courier to way.
BeforeClosing | 1 | Delivery must be paid before closing.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.BrdDeliverySmsNotificationTemplates

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeliverySmsNotificationTemplates : ISerializable

The DeliverySmsNotificationTemplates type exposes the following members.

Constructors
 | Name | Description
Public method | DeliverySmsNotificationTemplates | Initializes a new instance of the DeliverySmsNotificationTemplates class
Protected method | DeliverySmsNotificationTemplates(SerializationInfo, StreamingContext) | Initializes a new instance of the DeliverySmsNotificationTemplates class
Top
Properties
 | Name | Description
Public property | ChangeToCancelledStatus | Sms template for delivery change to Cancelled status.
Public property | ChangeToClosedStatus | Sms template for delivery change to Closed status.
Public property | ChangeToCookingCompletedStatus | Sms template for delivery change to cooking completed status.
Public property | ChangeToCookingStartedStatus | Sms template for delivery change to cooking started status.
Public property | ChangeToDeliveredStatus | Sms template for delivery change to Delivered status.
Public property | ChangeToNewStatus | Sms template for delivery change to New status.
Public property | ChangeToOnWayStatus | Sms template for delivery change to OnWay status.
Public property | ChangeToUnconfirmedStatus | Sms template for delivery change to Unconfirmed status.
Public property | ChangeToWaitingStatus | Sms template for delivery change to New status.
Public property | SumChange | Sms template for delivery order sum change notification.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Constructor

Overload List
 | Name | Description
Public method | DeliverySmsNotificationTemplates | Initializes a new instance of the DeliverySmsNotificationTemplates class
Protected method | DeliverySmsNotificationTemplates(SerializationInfo, StreamingContext) | Initializes a new instance of the DeliverySmsNotificationTemplates class
Top
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Constructor

Initializes a new instance of the DeliverySmsNotificationTemplates class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeliverySmsNotificationTemplates()
See Also

Reference

DeliverySmsNotificationTemplates Class
DeliverySmsNotificationTemplates Overload
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the DeliverySmsNotificationTemplates class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected DeliverySmsNotificationTemplates(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

DeliverySmsNotificationTemplates Class
DeliverySmsNotificationTemplates Overload
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Properties

The DeliverySmsNotificationTemplates type exposes the following members.

Properties
 | Name | Description
Public property | ChangeToCancelledStatus | Sms template for delivery change to Cancelled status.
Public property | ChangeToClosedStatus | Sms template for delivery change to Closed status.
Public property | ChangeToCookingCompletedStatus | Sms template for delivery change to cooking completed status.
Public property | ChangeToCookingStartedStatus | Sms template for delivery change to cooking started status.
Public property | ChangeToDeliveredStatus | Sms template for delivery change to Delivered status.
Public property | ChangeToNewStatus | Sms template for delivery change to New status.
Public property | ChangeToOnWayStatus | Sms template for delivery change to OnWay status.
Public property | ChangeToUnconfirmedStatus | Sms template for delivery change to Unconfirmed status.
Public property | ChangeToWaitingStatus | Sms template for delivery change to New status.
Public property | SumChange | Sms template for delivery order sum change notification.
Top
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToCancelledStatus Property

DeliverySmsNotificationTemplatesChangeToCancelledStatus Property

Sms template for delivery change to Cancelled status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToCancelledStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToClosedStatus Property

DeliverySmsNotificationTemplatesChangeToClosedStatus Property

Sms template for delivery change to Closed status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToClosedStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToCookingCompletedStatus Property

DeliverySmsNotificationTemplatesChangeToCookingCompletedStatus Property

Sms template for delivery change to cooking completed status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToCookingCompletedStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToCookingStartedStatus Property

DeliverySmsNotificationTemplatesChangeToCookingStartedStatus Property

Sms template for delivery change to cooking started status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToCookingStartedStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToDeliveredStatus Property

DeliverySmsNotificationTemplatesChangeToDeliveredStatus Property

Sms template for delivery change to Delivered status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToDeliveredStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToNewStatus Property

DeliverySmsNotificationTemplatesChangeToNewStatus Property

Sms template for delivery change to New status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToNewStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToOnWayStatus Property

DeliverySmsNotificationTemplatesChangeToOnWayStatus Property

Sms template for delivery change to OnWay status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToOnWayStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToUnconfirmedStatus Property

DeliverySmsNotificationTemplatesChangeToUnconfirmedStatus Property

Sms template for delivery change to Unconfirmed status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToUnconfirmedStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.ChangeToWaitingStatus Property

DeliverySmsNotificationTemplatesChangeToWaitingStatus Property

Sms template for delivery change to New status.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ChangeToWaitingStatus { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.SumChange Property

DeliverySmsNotificationTemplatesSumChange Property

Sms template for delivery order sum change notification.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string SumChange { get; set; }

Property Value

Type: String
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates Methods

The DeliverySmsNotificationTemplates type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsNotificationTemplates.GetObjectData Method

DeliverySmsNotificationTemplatesGetObjectData Method

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DeliverySmsNotificationTemplates Class
Resto.Front.Api.Data.Brd Namespace


DeliverySmsSendingEventType Enumeration

Дубликат одноименного серверного перечисления для нужд api.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeliverySmsSendingEventType
Members
Member name | Value | Description
OnDeliveryStatusSetUnconfirmed | 0 |
OnDeliveryStatusSetNew | 1 |
OnDeliveryItemsCookingStarted | 2 |
OnDeliveryItemsCookingCompleted | 3 |
OnDeliveryStatusSetWaiting | 4 |
OnDeliveryStatusSetOnWay | 5 |
OnDeliveryStatusSetDelivered | 6 |
OnDeliveryStatusSetClosed | 7 |
OnDeliveryStatusSetCanceled | 8 |
OnDeliverySumChanged | 9 |
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


DeliveryStatus Enumeration

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeliveryStatus
Members
Member name | Value | Description
Unconfirmed | 0 |
New | 1 |
Waiting | 2 |
OnWay | 3 |
Delivered | 4 |
Closed | 5 |
Cancelled | 6 |
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


EmailDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.BrdEmailDto

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class EmailDto : ISerializable

The EmailDto type exposes the following members.

Constructors
 | Name | Description
Public method | EmailDto | Initializes a new instance of the EmailDto class
Protected method | EmailDto(SerializationInfo, StreamingContext) | Initializes a new instance of the EmailDto class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | EmailValue |
Public property | IsMain |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


EmailDto Constructor

Overload List
 | Name | Description
Public method | EmailDto | Initializes a new instance of the EmailDto class
Protected method | EmailDto(SerializationInfo, StreamingContext) | Initializes a new instance of the EmailDto class
Top
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto Constructor

Initializes a new instance of the EmailDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EmailDto()
See Also

Reference

EmailDto Class
EmailDto Overload
Resto.Front.Api.Data.Brd Namespace


EmailDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the EmailDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected EmailDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

EmailDto Class
EmailDto Overload
Resto.Front.Api.Data.Brd Namespace


EmailDto Properties

The EmailDto type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | EmailValue |
Public property | IsMain |
Top
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto.Comment Property

EmailDtoComment Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

Type: String
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto.EmailValue Property

EmailDtoEmailValue Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string EmailValue { get; set; }

Property Value

Type: String
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto.IsMain Property

EmailDtoIsMain Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsMain { get; set; }

Property Value

Type: Boolean
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto Methods

The EmailDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


EmailDto.GetObjectData Method

EmailDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

EmailDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.BrdExternalCourierServiceDataDto

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ExternalCourierServiceDataDto : ISerializable

The ExternalCourierServiceDataDto type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalCourierServiceDataDto | Initializes a new instance of the ExternalCourierServiceDataDto class
Protected method | ExternalCourierServiceDataDto(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternalCourierServiceDataDto class
Top
Properties
 | Name | Description
Public property | CourierComment |
Public property | CourierName |
Public property | CourierPhone |
Public property | ServiceId |
Public property | ServiceName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Constructor

Overload List
 | Name | Description
Public method | ExternalCourierServiceDataDto | Initializes a new instance of the ExternalCourierServiceDataDto class
Protected method | ExternalCourierServiceDataDto(SerializationInfo, StreamingContext) | Initializes a new instance of the ExternalCourierServiceDataDto class
Top
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Constructor

Initializes a new instance of the ExternalCourierServiceDataDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalCourierServiceDataDto()
See Also

Reference

ExternalCourierServiceDataDto Class
ExternalCourierServiceDataDto Overload
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ExternalCourierServiceDataDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected ExternalCourierServiceDataDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ExternalCourierServiceDataDto Class
ExternalCourierServiceDataDto Overload
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Properties

The ExternalCourierServiceDataDto type exposes the following members.

Properties
 | Name | Description
Public property | CourierComment |
Public property | CourierName |
Public property | CourierPhone |
Public property | ServiceId |
Public property | ServiceName |
Top
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.CourierComment Property

ExternalCourierServiceDataDtoCourierComment Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CourierComment { get; set; }

Property Value

Type: String
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.CourierName Property

ExternalCourierServiceDataDtoCourierName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CourierName { get; set; }

Property Value

Type: String
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.CourierPhone Property

ExternalCourierServiceDataDtoCourierPhone Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CourierPhone { get; set; }

Property Value

Type: String
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.ServiceId Property

ExternalCourierServiceDataDtoServiceId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ServiceId { get; set; }

Property Value

Type: String
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.ServiceName Property

ExternalCourierServiceDataDtoServiceName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ServiceName { get; set; }

Property Value

Type: String
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto Methods

The ExternalCourierServiceDataDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


ExternalCourierServiceDataDto.GetObjectData Method

ExternalCourierServiceDataDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ExternalCourierServiceDataDto Class
Resto.Front.Api.Data.Brd Namespace


Gender Enumeration

Gender of a client.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum Gender
Members
Member name | Value | Description
NotSpecified | 0 | Unknown.
Male | 1 | Male.
Female | 2 | Female.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IAddress Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IAddress : ISerializable

The IAddress type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | Building |
Public property | Doorphone |
Public property | Entrance |
Public property | ExternalCartographyId |
Public property | Flat |
Public property | Floor |
Public property | House |
Public property | Index |
Public property | Region |
Public property | Street |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IAddress Properties

The IAddress type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInfo |
Public property | Building |
Public property | Doorphone |
Public property | Entrance |
Public property | ExternalCartographyId |
Public property | Flat |
Public property | Floor |
Public property | House |
Public property | Index |
Public property | Region |
Public property | Street |
Top
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.AdditionalInfo Property

IAddressAdditionalInfo Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string AdditionalInfo { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Building Property

IAddressBuilding Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Building { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Doorphone Property

IAddressDoorphone Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Doorphone { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Entrance Property

IAddressEntrance Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Entrance { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.ExternalCartographyId Property

IAddressExternalCartographyId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ExternalCartographyId { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Flat Property

IAddressFlat Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Flat { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Floor Property

IAddressFloor Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Floor { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.House Property

IAddressHouse Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string House { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Index Property

IAddressIndex Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Index { get; }

Property Value

Type: String
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Region Property

IAddressRegion Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRegion Region { get; }

Property Value

Type: IRegion
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress.Street Property

IAddressStreet Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IStreet Street { get; }

Property Value

Type: IStreet
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


IAddress Methods

The IAddress type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IAddress Interface
Resto.Front.Api.Data.Brd Namespace


ICity Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICity : ISerializable, IEntity

The ICity type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive |
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


ICity Properties

The ICity type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive |
Public property | Name |
Top
See Also

Reference

ICity Interface
Resto.Front.Api.Data.Brd Namespace


ICity.IsActive Property

ICityIsActive Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

ICity Interface
Resto.Front.Api.Data.Brd Namespace


ICity.Name Property

ICityName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ICity Interface
Resto.Front.Api.Data.Brd Namespace


ICity Methods

The ICity type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICity Interface
Resto.Front.Api.Data.Brd Namespace


IClient Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IClient : ISerializable,
    IEntity, IVersionedEntity, IClientStub

The IClient type exposes the following members.

Properties
 | Name | Description
Public property | Addresses |
Public property | BirthDate | Date the client was born.
Public property | BlacklistReason | Reason why client was added to blacklist.
Public property | CardNumber |
Public property | Comment |
Public property | ConsentDateFrom | Expiration date of the client's explicit consent to the processing of personal data.
Public property | ConsentDateTo | Date of the client's explicit consent to the processing of personal data.
Public property | Counteragent | Client's organization
Public property | DateCreated | Date of client's creation.
Public property | Emails |
Public property | Gender | Gender.
Public property | Id | (Inherited from IEntity.)
Public property | IikoBizId | Id of client's account in iiko.biz.
Public property | InBlacklist | Is client in blacklist.
Public property | LastOrderDate | Date of last order client done.
Public property | LinkedCounteragent | Linked counteragent. Used for specific payment logic in delivery.
Public property | MainAddressIndex |
Public property | MarketingSource | Advertising Source of customer (for example, some web site, call center)
Public property | Name |
Public property | Nick |
Public property | PersonalDataConsent | Has the client given a consent for personal data processing.
Public property | Phones |
Public property | ProcessingDateFrom | The date, when the illegal usage of personal data was registered, or when then ligitimate interest to store data has emerged.
Public property | ProcessingDateTo | Expiration date of rectifying violations of personal data processing or legitimate interest in data retention.
Public property | ReceivesLoyaltySystemNotifications | Does the client receive notifications from the loyalty system.
Public property | ReceivesOrderStatusNotifications | Does the client receive order status notifications, or not.
Public property | ReceivesPromotionalNotifications | Does the client receive promotional notifications.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | Surname |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IClient Properties

The IClient type exposes the following members.

Properties
 | Name | Description
Public property | Addresses |
Public property | BirthDate | Date the client was born.
Public property | BlacklistReason | Reason why client was added to blacklist.
Public property | CardNumber |
Public property | Comment |
Public property | ConsentDateFrom | Expiration date of the client's explicit consent to the processing of personal data.
Public property | ConsentDateTo | Date of the client's explicit consent to the processing of personal data.
Public property | Counteragent | Client's organization
Public property | DateCreated | Date of client's creation.
Public property | Emails |
Public property | Gender | Gender.
Public property | Id | (Inherited from IEntity.)
Public property | IikoBizId | Id of client's account in iiko.biz.
Public property | InBlacklist | Is client in blacklist.
Public property | LastOrderDate | Date of last order client done.
Public property | LinkedCounteragent | Linked counteragent. Used for specific payment logic in delivery.
Public property | MainAddressIndex |
Public property | MarketingSource | Advertising Source of customer (for example, some web site, call center)
Public property | Name |
Public property | Nick |
Public property | PersonalDataConsent | Has the client given a consent for personal data processing.
Public property | Phones |
Public property | ProcessingDateFrom | The date, when the illegal usage of personal data was registered, or when then ligitimate interest to store data has emerged.
Public property | ProcessingDateTo | Expiration date of rectifying violations of personal data processing or legitimate interest in data retention.
Public property | ReceivesLoyaltySystemNotifications | Does the client receive notifications from the loyalty system.
Public property | ReceivesOrderStatusNotifications | Does the client receive order status notifications, or not.
Public property | ReceivesPromotionalNotifications | Does the client receive promotional notifications.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | Surname |
Top
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Addresses Property

IClientAddresses Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IAddress> Addresses { get; }

Property Value

Type: IReadOnlyList IAddress
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.BirthDate Property

IClientBirthDate Property

Date the client was born.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? BirthDate { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.BlacklistReason Property

IClientBlacklistReason Property

Reason why client was added to blacklist.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string BlacklistReason { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.CardNumber Property

IClientCardNumber Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CardNumber { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Comment Property

IClientComment Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ConsentDateFrom Property

IClientConsentDateFrom Property

Expiration date of the client's explicit consent to the processing of personal data.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ConsentDateFrom { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ConsentDateTo Property

IClientConsentDateTo Property

Date of the client's explicit consent to the processing of personal data.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ConsentDateTo { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Counteragent Property

IClientCounteragent Property

Client's organization

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICounteragent Counteragent { get; }

Property Value

Type: ICounteragent
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.DateCreated Property

IClientDateCreated Property

Date of client's creation.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? DateCreated { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Emails Property

IClientEmails Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IEmail> Emails { get; }

Property Value

Type: IReadOnlyList IEmail
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Gender Property

IClientGender Property

Gender.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Gender Gender { get; }

Property Value

Type: Gender
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.IikoBizId Property

IClientIikoBizId Property

Id of client's account in iiko.biz.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid IikoBizId { get; }

Property Value

Type: Guid
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.InBlacklist Property

IClientInBlacklist Property

Is client in blacklist.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool InBlacklist { get; }

Property Value

Type: Boolean
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.LastOrderDate Property

IClientLastOrderDate Property

Date of last order client done.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? LastOrderDate { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.LinkedCounteragent Property

IClientLinkedCounteragent Property

Linked counteragent. Used for specific payment logic in delivery.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser LinkedCounteragent { get; }

Property Value

Type: IUser
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.MainAddressIndex Property

IClientMainAddressIndex Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? MainAddressIndex { get; }

Property Value

Type: Nullable Int32
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.MarketingSource Property

IClientMarketingSource Property

Advertising Source of customer (for example, some web site, call center)

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IMarketingSource MarketingSource { get; }

Property Value

Type: IMarketingSource
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Name Property

IClientName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Nick Property

IClientNick Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Nick { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.PersonalDataConsent Property

IClientPersonalDataConsent Property

Has the client given a consent for personal data processing.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool? PersonalDataConsent { get; }

Property Value

Type: Nullable Boolean
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Phones Property

IClientPhones Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPhone> Phones { get; }

Property Value

Type: IReadOnlyList IPhone
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ProcessingDateFrom Property

IClientProcessingDateFrom Property

The date, when the illegal usage of personal data was registered, or when then ligitimate interest to store data has emerged.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ProcessingDateFrom { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ProcessingDateTo Property

IClientProcessingDateTo Property

Expiration date of rectifying violations of personal data processing or legitimate interest in data retention.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ProcessingDateTo { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ReceivesLoyaltySystemNotifications Property

IClientReceivesLoyaltySystemNotifications Property

Does the client receive notifications from the loyalty system.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ReceivesLoyaltySystemNotifications { get; }

Property Value

Type: Boolean
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ReceivesOrderStatusNotifications Property

IClientReceivesOrderStatusNotifications Property

Does the client receive order status notifications, or not.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ReceivesOrderStatusNotifications { get; }

Property Value

Type: Boolean
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.ReceivesPromotionalNotifications Property

IClientReceivesPromotionalNotifications Property

Does the client receive promotional notifications.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ReceivesPromotionalNotifications { get; }

Property Value

Type: Boolean
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient.Surname Property

IClientSurname Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Surname { get; }

Property Value

Type: String
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


IClient Methods

The IClient type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IClient Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICounteragent : ISerializable

The ICounteragent type exposes the following members.

Properties
 | Name | Description
Public property | AccountingReasonCode |
Public property | Address |
Public property | Code |
Public property | FullAddressCity |
Public property | FullAddressCountry |
Public property | FullAddressHouse |
Public property | FullAddressPostCode |
Public property | FullAddressRegion |
Public property | FullAddressStreet |
Public property | Name |
Public property | RecipientCode |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


ICounteragent Properties

The ICounteragent type exposes the following members.

Properties
 | Name | Description
Public property | AccountingReasonCode |
Public property | Address |
Public property | Code |
Public property | FullAddressCity |
Public property | FullAddressCountry |
Public property | FullAddressHouse |
Public property | FullAddressPostCode |
Public property | FullAddressRegion |
Public property | FullAddressStreet |
Public property | Name |
Public property | RecipientCode |
Top
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.AccountingReasonCode Property

ICounteragentAccountingReasonCode Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string AccountingReasonCode { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.Address Property

ICounteragentAddress Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Address { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.Code Property

ICounteragentCode Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Code { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressCity Property

ICounteragentFullAddressCity Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressCity { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressCountry Property

ICounteragentFullAddressCountry Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressCountry { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressHouse Property

ICounteragentFullAddressHouse Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressHouse { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressPostCode Property

ICounteragentFullAddressPostCode Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressPostCode { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressRegion Property

ICounteragentFullAddressRegion Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressRegion { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.FullAddressStreet Property

ICounteragentFullAddressStreet Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FullAddressStreet { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.Name Property

ICounteragentName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent.RecipientCode Property

ICounteragentRecipientCode Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string RecipientCode { get; }

Property Value

Type: String
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


ICounteragent Methods

The ICounteragent type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICounteragent Interface
Resto.Front.Api.Data.Brd Namespace


IDeliveryCancelCause Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliveryCancelCause : ISerializable,
    IEntity

The IDeliveryCancelCause type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IDeliveryCancelCause Properties

The IDeliveryCancelCause type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
See Also

Reference

IDeliveryCancelCause Interface
Resto.Front.Api.Data.Brd Namespace


IDeliveryCancelCause.Name Property

IDeliveryCancelCauseName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IDeliveryCancelCause Interface
Resto.Front.Api.Data.Brd Namespace


IDeliveryCancelCause Methods

The IDeliveryCancelCause type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeliveryCancelCause Interface
Resto.Front.Api.Data.Brd Namespace


IEmail Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IEmail : ISerializable

The IEmail type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | IsMain |
Public property | Value |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IEmail Properties

The IEmail type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | IsMain |
Public property | Value |
Top
See Also

Reference

IEmail Interface
Resto.Front.Api.Data.Brd Namespace


IEmail.Comment Property

IEmailComment Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IEmail Interface
Resto.Front.Api.Data.Brd Namespace


IEmail.IsMain Property

IEmailIsMain Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsMain { get; }

Property Value

Type: Boolean
See Also

Reference

IEmail Interface
Resto.Front.Api.Data.Brd Namespace


IEmail.Value Property

IEmailValue Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Value { get; }

Property Value

Type: String
See Also

Reference

IEmail Interface
Resto.Front.Api.Data.Brd Namespace


IEmail Methods

The IEmail type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IEmail Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourier Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IExternalCourier : ISerializable

The IExternalCourier type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Name |
Public property | Phone |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IExternalCourier Properties

The IExternalCourier type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Name |
Public property | Phone |
Top
See Also

Reference

IExternalCourier Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourier.Comment Property

IExternalCourierComment Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IExternalCourier Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourier.Name Property

IExternalCourierName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IExternalCourier Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourier.Phone Property

IExternalCourierPhone Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Phone { get; }

Property Value

Type: String
See Also

Reference

IExternalCourier Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourier Methods

The IExternalCourier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IExternalCourier Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierService Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IExternalCourierService : ISerializable

The IExternalCourierService type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IExternalCourierService Properties

The IExternalCourierService type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name |
Top
See Also

Reference

IExternalCourierService Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierService.Id Property

IExternalCourierServiceId Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

IExternalCourierService Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierService.Name Property

IExternalCourierServiceName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IExternalCourierService Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierService Methods

The IExternalCourierService type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IExternalCourierService Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierServiceData Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IExternalCourierServiceData : ISerializable

The IExternalCourierServiceData type exposes the following members.

Properties
 | Name | Description
Public property | Courier |
Public property | Service |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IExternalCourierServiceData Properties

The IExternalCourierServiceData type exposes the following members.

Properties
 | Name | Description
Public property | Courier |
Public property | Service |
Top
See Also

Reference

IExternalCourierServiceData Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierServiceData.Courier Property

IExternalCourierServiceDataCourier Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IExternalCourier Courier { get; }

Property Value

Type: IExternalCourier
See Also

Reference

IExternalCourierServiceData Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierServiceData.Service Property

IExternalCourierServiceDataService Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IExternalCourierService Service { get; }

Property Value

Type: IExternalCourierService
See Also

Reference

IExternalCourierServiceData Interface
Resto.Front.Api.Data.Brd Namespace


IExternalCourierServiceData Methods

The IExternalCourierServiceData type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IExternalCourierServiceData Interface
Resto.Front.Api.Data.Brd Namespace


IMarketingSource Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IMarketingSource : ISerializable,
    IEntity

The IMarketingSource type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IMarketingSource Properties

The IMarketingSource type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
See Also

Reference

IMarketingSource Interface
Resto.Front.Api.Data.Brd Namespace


IMarketingSource.Name Property

IMarketingSourceName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IMarketingSource Interface
Resto.Front.Api.Data.Brd Namespace


IMarketingSource Methods

The IMarketingSource type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IMarketingSource Interface
Resto.Front.Api.Data.Brd Namespace


IPhone Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPhone : ISerializable

The IPhone type exposes the following members.

Properties
 | Name | Description
Public property | IsMain |
Public property | Value |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IPhone Properties

The IPhone type exposes the following members.

Properties
 | Name | Description
Public property | IsMain |
Public property | Value |
Top
See Also

Reference

IPhone Interface
Resto.Front.Api.Data.Brd Namespace


IPhone.IsMain Property

IPhoneIsMain Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsMain { get; }

Property Value

Type: Boolean
See Also

Reference

IPhone Interface
Resto.Front.Api.Data.Brd Namespace


IPhone.Value Property

IPhoneValue Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Value { get; }

Property Value

Type: String
See Also

Reference

IPhone Interface
Resto.Front.Api.Data.Brd Namespace


IPhone Methods

The IPhone type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPhone Interface
Resto.Front.Api.Data.Brd Namespace


IRegion Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IRegion : ISerializable,
    IEntity

The IRegion type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IRegion Properties

The IRegion type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Top
See Also

Reference

IRegion Interface
Resto.Front.Api.Data.Brd Namespace


IRegion.Name Property

IRegionName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IRegion Interface
Resto.Front.Api.Data.Brd Namespace


IRegion Methods

The IRegion type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IRegion Interface
Resto.Front.Api.Data.Brd Namespace


IReserve Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IReserve : ISerializable,
    IEntity, IVersionedEntity, IReserveStub

The IReserve type exposes the following members.

Properties
 | Name | Description
Public property | CancelReason | The reserve cancellation reason or null if the reserve hasn't been canceled.
Public property | Client | Client that placed the reserve.
Public property | Comment | Gets the optional comment for reserve or banquet.
Public property | Duration | Gets estimated banquet duration.
Public property | EstimatedStartTime | Gets the estimated time when reserve will be closed or banquet will be started.
Public property | ExternalId | Identifier in the external system where the reserve came from.
Public property | GuestsComingTime | Gets the time when guests came and reserve was closed or banquet was started.
Public property | GuestsCount | Gets estimated guests count.
Public property | Id | (Inherited from IEntity.)
Public property | Order | Order used to form menu for banquet, specify serve sequence (via courses), prepay.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | ShouldRemind | Whether to remind staff to prepare table beforehand. Table preparation time can be changed via iikoOffice (1 hour by default).
Public property | Status | Gets the status of the reserve or banquet.
Public property | Tables | Gets the reserved tables.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IReserve Properties

The IReserve type exposes the following members.

Properties
 | Name | Description
Public property | CancelReason | The reserve cancellation reason or null if the reserve hasn't been canceled.
Public property | Client | Client that placed the reserve.
Public property | Comment | Gets the optional comment for reserve or banquet.
Public property | Duration | Gets estimated banquet duration.
Public property | EstimatedStartTime | Gets the estimated time when reserve will be closed or banquet will be started.
Public property | ExternalId | Identifier in the external system where the reserve came from.
Public property | GuestsComingTime | Gets the time when guests came and reserve was closed or banquet was started.
Public property | GuestsCount | Gets estimated guests count.
Public property | Id | (Inherited from IEntity.)
Public property | Order | Order used to form menu for banquet, specify serve sequence (via courses), prepay.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | ShouldRemind | Whether to remind staff to prepare table beforehand. Table preparation time can be changed via iikoOffice (1 hour by default).
Public property | Status | Gets the status of the reserve or banquet.
Public property | Tables | Gets the reserved tables.
Top
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.CancelReason Property

IReserveCancelReason Property

The reserve cancellation reason or null if the reserve hasn't been canceled.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ReserveCancelReason? CancelReason { get; }

Property Value

Type: Nullable ReserveCancelReason
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Client Property

IReserveClient Property

Client that placed the reserve.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient Client { get; }

Property Value

Type: IClient
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Comment Property

IReserveComment Property

Gets the optional comment for reserve or banquet.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Duration Property

IReserveDuration Property

Gets estimated banquet duration.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan Duration { get; }

Property Value

Type: TimeSpan
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.EstimatedStartTime Property

IReserveEstimatedStartTime Property

Gets the estimated time when reserve will be closed or banquet will be started.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime EstimatedStartTime { get; }

Property Value

Type: DateTime
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.ExternalId Property

IReserveExternalId Property

Identifier in the external system where the reserve came from.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid ExternalId { get; }

Property Value

Type: Guid
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.GuestsComingTime Property

IReserveGuestsComingTime Property

Gets the time when guests came and reserve was closed or banquet was started.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? GuestsComingTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.GuestsCount Property

IReserveGuestsCount Property

Gets estimated guests count.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int GuestsCount { get; }

Property Value

Type: Int32
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Order Property

IReserveOrder Property

Order used to form menu for banquet, specify serve sequence (via courses), prepay.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrder Order { get; }

Property Value

Type: IOrder
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.ShouldRemind Property

IReserveShouldRemind Property

Whether to remind staff to prepare table beforehand. Table preparation time can be changed via iikoOffice (1 hour by default).

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ShouldRemind { get; }

Property Value

Type: Boolean
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Status Property

IReserveStatus Property

Gets the status of the reserve or banquet.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ReserveStatus Status { get; }

Property Value

Type: ReserveStatus
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve.Tables Property

IReserveTables Property

Gets the reserved tables.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITable> Tables { get; }

Property Value

Type: IReadOnlyList ITable
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IReserve Methods

The IReserve type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IReserve Interface
Resto.Front.Api.Data.Brd Namespace


IStreet Interface

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IStreet : ISerializable,
    IEntity, IVersionedEntity, IStreetStub

The IStreet type exposes the following members.

Properties
 | Name | Description
Public property | City |
Public property | ExternalId | Identifier in external street database (for example, KLADR).
Public property | Id | (Inherited from IEntity.)
Public property | IsActive |
Public property | Name |
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


IStreet Properties

The IStreet type exposes the following members.

Properties
 | Name | Description
Public property | City |
Public property | ExternalId | Identifier in external street database (for example, KLADR).
Public property | Id | (Inherited from IEntity.)
Public property | IsActive |
Public property | Name |
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Top
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


IStreet.City Property

IStreetCity Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICity City { get; }

Property Value

Type: ICity
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


IStreet.ExternalId Property

IStreetExternalId Property

Identifier in external street database (for example, KLADR).

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ExternalId { get; }

Property Value

Type: String
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


IStreet.IsActive Property

IStreetIsActive Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


IStreet.Name Property

IStreetName Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


IStreet Methods

The IStreet type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IStreet Interface
Resto.Front.Api.Data.Brd Namespace


ISurveyItem Interface

Item of client's survey.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISurveyItem : ISerializable,
    IEntity

The ISurveyItem type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Question | Question itself.
Public property | Type | Type of survey item.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


ISurveyItem Properties

The ISurveyItem type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Question | Question itself.
Public property | Type | Type of survey item.
Top
See Also

Reference

ISurveyItem Interface
Resto.Front.Api.Data.Brd Namespace


ISurveyItem.Question Property

ISurveyItemQuestion Property

Question itself.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Question { get; }

Property Value

Type: String
See Also

Reference

ISurveyItem Interface
Resto.Front.Api.Data.Brd Namespace


ISurveyItem.Type Property

ISurveyItemType Property

Type of survey item.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
SurveyType Type { get; }

Property Value

Type: SurveyType
See Also

Reference

ISurveyItem Interface
Resto.Front.Api.Data.Brd Namespace


ISurveyItem Methods

The ISurveyItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ISurveyItem Interface
Resto.Front.Api.Data.Brd Namespace


PhoneDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.BrdPhoneDto

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PhoneDto : ISerializable

The PhoneDto type exposes the following members.

Constructors
 | Name | Description
Public method | PhoneDto | Initializes a new instance of the PhoneDto class
Protected method | PhoneDto(SerializationInfo, StreamingContext) | Initializes a new instance of the PhoneDto class
Top
Properties
 | Name | Description
Public property | IsMain |
Public property | PhoneValue |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


PhoneDto Constructor

Overload List
 | Name | Description
Public method | PhoneDto | Initializes a new instance of the PhoneDto class
Protected method | PhoneDto(SerializationInfo, StreamingContext) | Initializes a new instance of the PhoneDto class
Top
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


PhoneDto Constructor

Initializes a new instance of the PhoneDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PhoneDto()
See Also

Reference

PhoneDto Class
PhoneDto Overload
Resto.Front.Api.Data.Brd Namespace


PhoneDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PhoneDto class

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected PhoneDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PhoneDto Class
PhoneDto Overload
Resto.Front.Api.Data.Brd Namespace


PhoneDto Properties

The PhoneDto type exposes the following members.

Properties
 | Name | Description
Public property | IsMain |
Public property | PhoneValue |
Top
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


PhoneDto.IsMain Property

PhoneDtoIsMain Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsMain { get; set; }

Property Value

Type: Boolean
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


PhoneDto.PhoneValue Property

PhoneDtoPhoneValue Property

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PhoneValue { get; set; }

Property Value

Type: String
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


PhoneDto Methods

The PhoneDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


PhoneDto.GetObjectData Method

PhoneDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PhoneDto Class
Resto.Front.Api.Data.Brd Namespace


ReserveCancelReason Enumeration

Reason why planned event failed.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ReserveCancelReason
Members
Member name | Value | Description
ClientNotAppeared | 0 | Client didn't come timely.
ClientRefused | 1 | Client changed his mind.
Other | 2 | Any reason other than ClientNotAppeared and ClientRefused.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


ReserveStatus Enumeration

Describes the status of a reserve or a banquet.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ReserveStatus
Members
Member name | Value | Description
New | 0 | The reserve or banquet has been created. This means that corresponding tables are reserved for specified date in future.
Started | 1 | The banquet has been started. This means that event is active, so corresponding tables are occupied by guests.
Closed | 2 | The reserve or banquet has been closed. For reserve this means closing the reservation due to customer coming or customer cancellation. For banquet this means that event was either cancelled or successfully ended.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


SurveyType Enumeration

Describes the type of the survey item.

Namespace: Resto.Front.Api.Data.Brd
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum SurveyType
Members
Member name | Value | Description
Common | 0 | Common question.
Courier | 1 | Courier.
DeliveryOperator | 2 | Delivery operator.
DeliveryFood | 3 | Food quality in delivery.
See Also

Reference

Resto.Front.Api.Data.Brd Namespace


Resto.Front.Api.Data.Cheques Namespace

Classes
 | Class | Description
Public class | Attributes | Names of the xml tag attributes used for cheques printing (CashCheque, BillCheque, ReceiptSlip).
Public class | AttributeValues | Values of the xml tag attributes used for cheques printing (CashCheque, BillCheque, ReceiptSlip).
Public class | BillCheque |
Public class | CashCheque |
Public class | ReceiptSlip | Slip to print on receipt-cheque printer.
Public class | Tags | Names of the xml tags used for cheques printing (CashCheque, BillCheque, ReceiptSlip).


Attributes Class

Names of the xml tag attributes used for cheques printing (CashCheque, BillCheque, ReceiptSlip).
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesAttributes

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class Attributes

The Attributes type exposes the following members.

Fields
Name | Description
Align | Horizontal alignment of the content.
AutoWidth | Column width will be adjusted by the content.
Bell | Turns on the a kitchen bell or opens cash drawer before printing a document. Works only for printers.
CellSpacing | Width of the space between table columns (in chars). Default is 1.
ColumnSpan | Stretches the cell into specified number of columns. Default is 1.
Fit | Specifies which value (Left or Right) will be adjusted by the content. Default is Right.
Font | Specifies the font size for the table row (should be set for the first cell of the row, will be ignored for the subsequent cells). Inner elements inherit this setting.
Formatter | Text wrapping mode.
Left | Specifies the left part of the Pair element.
MaxWidth | Maximum column width (in chars). Default is unspecified.
MinWidth | Minimum column width (in chars). Default is 1.
Right | Specifies the right part of the Pair element.
Symbols | Sets a new character (or character set) used to fill in the white space.
VerticalAlign | Vertical alignment of the content.
Width | Fixed column width (in chars). Default is unspecified. Cannot be used with AutoWidth.
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace
Resto.Front.Api.Data.ChequesAttributeValues
Resto.Front.Api.Data.ChequesTags


Attributes Fields

The Attributes type exposes the following members.

Fields
Name | Description
Align | Horizontal alignment of the content.
AutoWidth | Column width will be adjusted by the content.
Bell | Turns on the a kitchen bell or opens cash drawer before printing a document. Works only for printers.
CellSpacing | Width of the space between table columns (in chars). Default is 1.
ColumnSpan | Stretches the cell into specified number of columns. Default is 1.
Fit | Specifies which value (Left or Right) will be adjusted by the content. Default is Right.
Font | Specifies the font size for the table row (should be set for the first cell of the row, will be ignored for the subsequent cells). Inner elements inherit this setting.
Formatter | Text wrapping mode.
Left | Specifies the left part of the Pair element.
MaxWidth | Maximum column width (in chars). Default is unspecified.
MinWidth | Minimum column width (in chars). Default is 1.
Right | Specifies the right part of the Pair element.
Symbols | Sets a new character (or character set) used to fill in the white space.
VerticalAlign | Vertical alignment of the content.
Width | Fixed column width (in chars). Default is unspecified. Cannot be used with AutoWidth.
Top
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Align Field

AttributesAlign Field

Horizontal alignment of the content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Align = "align"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.AutoWidth Field

AttributesAutoWidth Field

Column width will be adjusted by the content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string AutoWidth = "autowidth"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Bell Field

AttributesBell Field

Turns on the a kitchen bell or opens cash drawer before printing a document. Works only for printers.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Bell = "bell"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace
TagsDoc


Attributes.CellSpacing Field

AttributesCellSpacing Field

Width of the space between table columns (in chars). Default is 1.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string CellSpacing = "cellspacing"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace
TagsTable


Attributes.ColumnSpan Field

AttributesColumnSpan Field

Stretches the cell into specified number of columns. Default is 1.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string ColumnSpan = "colspan"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Fit Field

AttributesFit Field

Specifies which value (Left or Right) will be adjusted by the content. Default is Right.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Fit = "fit"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace
TagsPair


Attributes.Font Field

AttributesFont Field

Specifies the font size for the table row (should be set for the first cell of the row, will be ignored for the subsequent cells). Inner elements inherit this setting.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Font = "font"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Formatter Field

AttributesFormatter Field

Text wrapping mode.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Formatter = "formatter"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Left Field

AttributesLeft Field

Specifies the left part of the Pair element.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Left = "left"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.MaxWidth Field

AttributesMaxWidth Field

Maximum column width (in chars). Default is unspecified.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string MaxWidth = "maxwidth"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.MinWidth Field

AttributesMinWidth Field

Minimum column width (in chars). Default is 1.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string MinWidth = "minwidth"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Right Field

AttributesRight Field

Specifies the right part of the Pair element.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Right = "right"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Symbols Field

AttributesSymbols Field

Sets a new character (or character set) used to fill in the white space.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Symbols = "symbols"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace
TagsFill
TagsLineCell
TagsLine


Attributes.VerticalAlign Field

AttributesVerticalAlign Field

Vertical alignment of the content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string VerticalAlign = "valign"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


Attributes.Width Field

AttributesWidth Field

Fixed column width (in chars). Default is unspecified. Cannot be used with AutoWidth.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Width = "width"

Field Value

Type: String
See Also

Reference

Attributes Class
Resto.Front.Api.Data.Cheques Namespace


AttributeValues Class

Values of the xml tag attributes used for cheques printing (CashCheque, BillCheque, ReceiptSlip).
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesAttributeValues

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class AttributeValues

The AttributeValues type exposes the following members.

Fields
Name | Description
Bottom | Align a content to the bottom.
Center | Align a content by the center.
CutText | Excess text will be trimmed out.
Empty | Empty value applicable to attributes for which only their presence is important.
Justify | Justify a content.
LargeFont | The largest possible font size.
Left | Align a content to the left.
MediumFont | Medium font size.
Right | Align a content to the right.
SmallFont | The smallest possible font size, used by default.
SplitText | Split text into lines on whitespaces.
Top | Align a content to the top.
WrapText | Split text into lines on any chars.
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace
Resto.Front.Api.Data.ChequesAttributes
Resto.Front.Api.Data.ChequesTags


AttributeValues Fields

The AttributeValues type exposes the following members.

Fields
Name | Description
Bottom | Align a content to the bottom.
Center | Align a content by the center.
CutText | Excess text will be trimmed out.
Empty | Empty value applicable to attributes for which only their presence is important.
Justify | Justify a content.
LargeFont | The largest possible font size.
Left | Align a content to the left.
MediumFont | Medium font size.
Right | Align a content to the right.
SmallFont | The smallest possible font size, used by default.
SplitText | Split text into lines on whitespaces.
Top | Align a content to the top.
WrapText | Split text into lines on any chars.
Top
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace


AttributeValues.Bottom Field

AttributeValuesBottom Field

Align a content to the bottom.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Bottom = "bottom"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesVerticalAlign


AttributeValues.Center Field

AttributeValuesCenter Field

Align a content by the center.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Center = "center"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesAlign
AttributesVerticalAlign


AttributeValues.CutText Field

AttributeValuesCutText Field

Excess text will be trimmed out.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string CutText = "cut"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFormatter


AttributeValues.Empty Field

AttributeValuesEmpty Field

Empty value applicable to attributes for which only their presence is important.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Empty = ""

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace


AttributeValues.Justify Field

AttributeValuesJustify Field

Justify a content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Justify = "justify"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesAlign


AttributeValues.LargeFont Field

AttributeValuesLargeFont Field

The largest possible font size.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string LargeFont = "f2"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFont


AttributeValues.Left Field

AttributeValuesLeft Field

Align a content to the left.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Left = "left"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesAlign


AttributeValues.MediumFont Field

AttributeValuesMediumFont Field

Medium font size.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string MediumFont = "f1"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFont


AttributeValues.Right Field

AttributeValuesRight Field

Align a content to the right.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Right = "right"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesAlign


AttributeValues.SmallFont Field

AttributeValuesSmallFont Field

The smallest possible font size, used by default.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string SmallFont = "f0"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFont


AttributeValues.SplitText Field

AttributeValuesSplitText Field

Split text into lines on whitespaces.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string SplitText = "split"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFormatter


AttributeValues.Top Field

AttributeValuesTop Field

Align a content to the top.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Top = "top"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesVerticalAlign


AttributeValues.WrapText Field

AttributeValuesWrapText Field

Split text into lines on any chars.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string WrapText = "wrap"

Field Value

Type: String
See Also

Reference

AttributeValues Class
Resto.Front.Api.Data.Cheques Namespace
AttributesFormatter


BillCheque Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesBillCheque

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class BillCheque : ISerializable

The BillCheque type exposes the following members.

Constructors
 | Name | Description
Public method | BillCheque | Initializes a new instance of the BillCheque class
Protected method | BillCheque(SerializationInfo, StreamingContext) | Initializes a new instance of the BillCheque class
Top
Properties
 | Name | Description
Public property | AfterFooter | Markup to add at the end of the cheque.
Public property | AfterHeader | Markup to add after header (including date, a name of the waiter and other) and before cheque data.
Public property | BeforeFooter | Markup to add after cheque data (after result sums).
Public property | BeforeHeader | Markup to add before header (at the very beginning of the cheque).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace


BillCheque Constructor

Overload List
 | Name | Description
Public method | BillCheque | Initializes a new instance of the BillCheque class
Protected method | BillCheque(SerializationInfo, StreamingContext) | Initializes a new instance of the BillCheque class
Top
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque Constructor

Initializes a new instance of the BillCheque class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public BillCheque()
See Also

Reference

BillCheque Class
BillCheque Overload
Resto.Front.Api.Data.Cheques Namespace


BillCheque Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the BillCheque class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected BillCheque(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

BillCheque Class
BillCheque Overload
Resto.Front.Api.Data.Cheques Namespace


BillCheque Properties

The BillCheque type exposes the following members.

Properties
 | Name | Description
Public property | AfterFooter | Markup to add at the end of the cheque.
Public property | AfterHeader | Markup to add after header (including date, a name of the waiter and other) and before cheque data.
Public property | BeforeFooter | Markup to add after cheque data (after result sums).
Public property | BeforeHeader | Markup to add before header (at the very beginning of the cheque).
Top
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque.AfterFooter Property

BillChequeAfterFooter Property

Markup to add at the end of the cheque.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement AfterFooter { get; set; }

Property Value

Type: XElement
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque.AfterHeader Property

BillChequeAfterHeader Property

Markup to add after header (including date, a name of the waiter and other) and before cheque data.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement AfterHeader { get; set; }

Property Value

Type: XElement
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque.BeforeFooter Property

BillChequeBeforeFooter Property

Markup to add after cheque data (after result sums).

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement BeforeFooter { get; set; }

Property Value

Type: XElement
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque.BeforeHeader Property

BillChequeBeforeHeader Property

Markup to add before header (at the very beginning of the cheque).

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement BeforeHeader { get; set; }

Property Value

Type: XElement
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque Methods

The BillCheque type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


BillCheque.GetObjectData Method

BillChequeGetObjectData Method

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

BillCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesCashCheque

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashCheque : ISerializable

The CashCheque type exposes the following members.

Constructors
 | Name | Description
Public method | CashCheque | Initializes a new instance of the CashCheque class
Protected method | CashCheque(SerializationInfo, StreamingContext) | Initializes a new instance of the CashCheque class
Top
Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace


CashCheque Constructor

Overload List
 | Name | Description
Public method | CashCheque | Initializes a new instance of the CashCheque class
Protected method | CashCheque(SerializationInfo, StreamingContext) | Initializes a new instance of the CashCheque class
Top
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque Constructor

Initializes a new instance of the CashCheque class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashCheque()
See Also

Reference

CashCheque Class
CashCheque Overload
Resto.Front.Api.Data.Cheques Namespace


CashCheque Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the CashCheque class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected CashCheque(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

CashCheque Class
CashCheque Overload
Resto.Front.Api.Data.Cheques Namespace


CashCheque Properties

The CashCheque type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Top
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque.AfterCheque Property

CashChequeAfterCheque Property

Markup to add at the end of the cheque.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement AfterCheque { get; set; }

Property Value

Type: XElement
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque.BeforeCheque Property

CashChequeBeforeCheque Property

Markup to add to the header (at the very beginning of the cheque).

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement BeforeCheque { get; set; }

Property Value

Type: XElement
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque Methods

The CashCheque type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


CashCheque.GetObjectData Method

CashChequeGetObjectData Method

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CashCheque Class
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Class

Slip to print on receipt-cheque printer.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesReceiptSlip

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ReceiptSlip : ISerializable

The ReceiptSlip type exposes the following members.

Constructors
 | Name | Description
Public method | ReceiptSlip | Initializes a new instance of the ReceiptSlip class
Protected method | ReceiptSlip(SerializationInfo, StreamingContext) | Initializes a new instance of the ReceiptSlip class
Top
Properties
 | Name | Description
Public property | Doc | Markup.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Constructor

Overload List
 | Name | Description
Public method | ReceiptSlip | Initializes a new instance of the ReceiptSlip class
Protected method | ReceiptSlip(SerializationInfo, StreamingContext) | Initializes a new instance of the ReceiptSlip class
Top
See Also

Reference

ReceiptSlip Class
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Constructor

Initializes a new instance of the ReceiptSlip class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ReceiptSlip()
See Also

Reference

ReceiptSlip Class
ReceiptSlip Overload
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ReceiptSlip class

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected ReceiptSlip(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ReceiptSlip Class
ReceiptSlip Overload
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Properties

The ReceiptSlip type exposes the following members.

Properties
 | Name | Description
Public property | Doc | Markup.
Top
See Also

Reference

ReceiptSlip Class
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip.Doc Property

ReceiptSlipDoc Property

Markup.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement Doc { get; set; }

Property Value

Type: XElement
See Also

Reference

ReceiptSlip Class
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip Methods

The ReceiptSlip type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReceiptSlip Class
Resto.Front.Api.Data.Cheques Namespace


ReceiptSlip.GetObjectData Method

ReceiptSlipGetObjectData Method

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ReceiptSlip Class
Resto.Front.Api.Data.Cheques Namespace


Tags Class

Names of the xml tags used for cheques printing (CashCheque, BillCheque, ReceiptSlip).
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ChequesTags

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class Tags

The Tags type exposes the following members.

Fields
Name | Description
Cell | Single cell of the table with arbitrary content including other tags.
Cells | Table cells, serialized line by line (LTR).
Center | Align a content by the center.
Column | Declares single column inside Columns collection.
Columns | Declares a set of columns (Column).
CutText | Excess text will be trimmed out.
Doc | Root of the document.
Fill | Overrides the character used to fill in the whitespace. A new character (or character set) is specified by the Symbols attribute.
Justify | Justify a content.
LargeFont | Sets the largest possible font size of the content.
Left | Align a content to the left.
Line | Prints a line filled by specified Symbols attribute. Default symbol is "-".
LineCell | Cell will be stretched into all columns of a parent table filled by specified Symbols attribute. Default symbol is "-".
MediumFont | Sets medium font size of the content.
NewParagraph | Begins new paragraph. Text after this element will start on a new line.
Pagecut | Page cut.
Pair | Prints two values, first part is assigned to Left attribute and will be aligned to the left, second one is assigned to Right attribute and will be aligned to the right.
QRCode | Formatting embedded text as QR code.
Right | Align a content to the right.
SmallFont | Sets the smallest possible font size of the content, used by default.
SplitText | Split text into lines on whitespaces.
Table | Prints the table using two inner tags — Columns and Cells, first declares the layout of the table, latter provides cell values.
TextCell | Single cell of the table with text content.
WrapText | Split text into lines on any chars.
Top
See Also

Reference

Resto.Front.Api.Data.Cheques Namespace
Resto.Front.Api.Data.ChequesAttributes
Resto.Front.Api.Data.ChequesAttributeValues


Tags Fields

The Tags type exposes the following members.

Fields
Name | Description
Cell | Single cell of the table with arbitrary content including other tags.
Cells | Table cells, serialized line by line (LTR).
Center | Align a content by the center.
Column | Declares single column inside Columns collection.
Columns | Declares a set of columns (Column).
CutText | Excess text will be trimmed out.
Doc | Root of the document.
Fill | Overrides the character used to fill in the whitespace. A new character (or character set) is specified by the Symbols attribute.
Justify | Justify a content.
LargeFont | Sets the largest possible font size of the content.
Left | Align a content to the left.
Line | Prints a line filled by specified Symbols attribute. Default symbol is "-".
LineCell | Cell will be stretched into all columns of a parent table filled by specified Symbols attribute. Default symbol is "-".
MediumFont | Sets medium font size of the content.
NewParagraph | Begins new paragraph. Text after this element will start on a new line.
Pagecut | Page cut.
Pair | Prints two values, first part is assigned to Left attribute and will be aligned to the left, second one is assigned to Right attribute and will be aligned to the right.
QRCode | Formatting embedded text as QR code.
Right | Align a content to the right.
SmallFont | Sets the smallest possible font size of the content, used by default.
SplitText | Split text into lines on whitespaces.
Table | Prints the table using two inner tags — Columns and Cells, first declares the layout of the table, latter provides cell values.
TextCell | Single cell of the table with text content.
WrapText | Split text into lines on any chars.
Top
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Cell Field

TagsCell Field

Single cell of the table with arbitrary content including other tags.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Cell = "c"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Cells Field

TagsCells Field

Table cells, serialized line by line (LTR).

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Cells = "cells"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Center Field

TagsCenter Field

Align a content by the center.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Center = "center"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Column Field

TagsColumn Field

Declares single column inside Columns collection.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Column = "column"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Columns Field

TagsColumns Field

Declares a set of columns (Column).

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Columns = "columns"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.CutText Field

TagsCutText Field

Excess text will be trimmed out.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string CutText = "cut"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Doc Field

TagsDoc Field

Root of the document.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Doc = "doc"

Field Value

Type: String
Remarks
Do not use this tag when embedding something into existing document. For example, BillCheque template already has the root tag, so your BeforeFooter shouldn't contain another one.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Fill Field

TagsFill Field

Overrides the character used to fill in the whitespace. A new character (or character set) is specified by the Symbols attribute.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Fill = "fill"

Field Value

Type: String
Remarks
  1. Not inherited by a table if it is wrapped with the Fill tag.
  2. Tag does not override the whitespace characters of custom text.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Justify Field

TagsJustify Field

Justify a content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Justify = "justify"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.LargeFont Field

TagsLargeFont Field

Sets the largest possible font size of the content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string LargeFont = "f2"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Left Field

TagsLeft Field

Align a content to the left.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Left = "left"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Line Field

TagsLine Field

Prints a line filled by specified Symbols attribute. Default symbol is "-".

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Line = "line"

Field Value

Type: String
Remarks
Should be used as an empty element.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.LineCell Field

TagsLineCell Field

Cell will be stretched into all columns of a parent table filled by specified Symbols attribute. Default symbol is "-".

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string LineCell = "linecell"

Field Value

Type: String
Remarks
Should be used as an empty element.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.MediumFont Field

TagsMediumFont Field

Sets medium font size of the content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string MediumFont = "f1"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.NewParagraph Field

TagsNewParagraph Field

Begins new paragraph. Text after this element will start on a new line.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string NewParagraph = "np"

Field Value

Type: String
Remarks
Should be used as an empty element.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Pagecut Field

TagsPagecut Field

Page cut.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Pagecut = "pagecut"

Field Value

Type: String
Remarks
Should be used as an empty element.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Pair Field

TagsPair Field

Prints two values, first part is assigned to Left attribute and will be aligned to the left, second one is assigned to Right attribute and will be aligned to the right.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Pair = "pair"

Field Value

Type: String
Remarks
Should be used as an empty element.
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.QRCode Field

TagsQRCode Field

Formatting embedded text as QR code.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string QRCode = "qrcode"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Right Field

TagsRight Field

Align a content to the right.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Right = "right"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.SmallFont Field

TagsSmallFont Field

Sets the smallest possible font size of the content, used by default.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string SmallFont = "f0"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.SplitText Field

TagsSplitText Field

Split text into lines on whitespaces.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string SplitText = "split"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.Table Field

TagsTable Field

Prints the table using two inner tags — Columns and Cells, first declares the layout of the table, latter provides cell values.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string Table = "table"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.TextCell Field

TagsTextCell Field

Single cell of the table with text content.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string TextCell = "ct"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Tags.WrapText Field

TagsWrapText Field

Split text into lines on any chars.

Namespace: Resto.Front.Api.Data.Cheques
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const string WrapText = "wrap"

Field Value

Type: String
See Also

Reference

Tags Class
Resto.Front.Api.Data.Cheques Namespace


Resto.Front.Api.Data.Common Namespace

Classes
 | Class | Description
Public class | ChangedEntitiesT | Information about changed entities.
Public class | ExternalOperationChangedEventArgs | Arguments for external operation changed notification event.
Structures
 | Structure | Description
Public structure | ChangedEntityT | Information about changed entity.
Public structure | EntityChangedEventArgsT | Arguments for entity changed notification event.
Interfaces
 | Interface | Description
Public interface | IEntity | Represents an object which have an identifier.
Public interface | IVersionedEntity | Represents an entity which have a revision.
Enumerations
 | Enumeration | Description
Public enumeration | EntityEventType | Type of entity changed event.


ChangedEntities(T) Class

ChangedEntitiesT Class

Information about changed entities.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.CommonChangedEntitiesT

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ChangedEntities<T>
where T : class, IVersionedEntity

Type Parameters

T

The ChangedEntitiesT type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedEntitiesT | Ctor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Entities | Collection of changed entities.
Public field | RevisionTo | Max known Revision of changed Entities collection.
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


ChangedEntities(T) Constructor

ChangedEntitiesT Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChangedEntities(
    IReadOnlyCollection<ChangedEntity<T>> entities,
    int revisionTo
)

Parameters

entities
Type: System.Collections.GenericIReadOnlyCollection ChangedEntity T
revisionTo
Type: SystemInt32
See Also

Reference

ChangedEntitiesT Class
Resto.Front.Api.Data.Common Namespace


ChangedEntities(T) Methods

ChangedEntitiesT Methods

The ChangedEntitiesT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangedEntitiesT Class
Resto.Front.Api.Data.Common Namespace


ChangedEntities(T) Fields

ChangedEntitiesT Fields

The ChangedEntitiesT generic type exposes the following members.

Fields
 | Name | Description
Public field | Entities | Collection of changed entities.
Public field | RevisionTo | Max known Revision of changed Entities collection.
Top
See Also

Reference

ChangedEntitiesT Class
Resto.Front.Api.Data.Common Namespace


ChangedEntities(T).Entities Field

ChangedEntitiesTEntities Field

Collection of changed entities.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<ChangedEntity<T>> Entities

Field Value

Type: IReadOnlyCollection ChangedEntity T
See Also

Reference

ChangedEntitiesT Class
Resto.Front.Api.Data.Common Namespace


ChangedEntities(T).RevisionTo Field

ChangedEntitiesTRevisionTo Field

Max known Revision of changed Entities collection.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int RevisionTo

Field Value

Type: Int32
See Also

Reference

ChangedEntitiesT Class
Resto.Front.Api.Data.Common Namespace


ChangedEntity(T) Structure

ChangedEntityT Structure

Information about changed entity.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public struct ChangedEntity<T>
where T : class, IVersionedEntity

Type Parameters

T

The ChangedEntityT type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedEntityT | Ctor.
Top
Properties
 | Name | Description
Public property | Entity | Changed entity. null if the entity has been permanently removed.
Public property | Id | Changed entity identifier.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


ChangedEntity(T) Constructor

ChangedEntityT Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChangedEntity(
    Guid id,
    T entity
)

Parameters

id
Type: SystemGuid
entity
Type: T
See Also

Reference

ChangedEntityT Structure
Resto.Front.Api.Data.Common Namespace


ChangedEntity(T) Properties

ChangedEntityT Properties

The ChangedEntityT generic type exposes the following members.

Properties
 | Name | Description
Public property | Entity | Changed entity. null if the entity has been permanently removed.
Public property | Id | Changed entity identifier.
Top
See Also

Reference

ChangedEntityT Structure
Resto.Front.Api.Data.Common Namespace


ChangedEntity(T).Entity Property

ChangedEntityTEntity Property

Changed entity. null if the entity has been permanently removed.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public T Entity { get; }

Property Value

Type: T
See Also

Reference

ChangedEntityT Structure
Resto.Front.Api.Data.Common Namespace


ChangedEntity(T).Id Property

ChangedEntityTId Property

Changed entity identifier.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

ChangedEntityT Structure
Resto.Front.Api.Data.Common Namespace


ChangedEntity(T) Methods

ChangedEntityT Methods

The ChangedEntityT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ChangedEntityT Structure
Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T) Structure

EntityChangedEventArgsT Structure

Arguments for entity changed notification event.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public struct EntityChangedEventArgs<T>
where T : class, IEntity

Type Parameters

T

The EntityChangedEventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | EntityChangedEventArgsT | Ctor.
Top
Properties
 | Name | Description
Public property | Entity | Changed entity.
Public property | EventType | Entity changed event type.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T) Constructor

EntityChangedEventArgsT Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityChangedEventArgs(
    T entity,
    EntityEventType eventType
)

Parameters

entity
Type: T
eventType
Type: Resto.Front.Api.Data.CommonEntityEventType
See Also

Reference

EntityChangedEventArgsT Structure
Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T) Properties

EntityChangedEventArgsT Properties

The EntityChangedEventArgsT generic type exposes the following members.

Properties
 | Name | Description
Public property | Entity | Changed entity.
Public property | EventType | Entity changed event type.
Top
See Also

Reference

EntityChangedEventArgsT Structure
Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T).Entity Property

EntityChangedEventArgsTEntity Property

Changed entity.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public T Entity { get; }

Property Value

Type: T
See Also

Reference

EntityChangedEventArgsT Structure
Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T).EventType Property

EntityChangedEventArgsTEventType Property

Entity changed event type.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityEventType EventType { get; }

Property Value

Type: EntityEventType
See Also

Reference

EntityChangedEventArgsT Structure
Resto.Front.Api.Data.Common Namespace


EntityChangedEventArgs(T) Methods

EntityChangedEventArgsT Methods

The EntityChangedEventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

EntityChangedEventArgsT Structure
Resto.Front.Api.Data.Common Namespace


EntityEventType Enumeration

Type of entity changed event.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum EntityEventType
Members
Member name | Value | Description
Created | 0 | Entity was created.
Updated | 1 | Entity was updated.
Removed | 2 | Entity was removed.
See Also

Reference

Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs Class

Arguments for external operation changed notification event.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.CommonExternalOperationChangedEventArgs

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public sealed class ExternalOperationChangedEventArgs

The ExternalOperationChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalOperationChangedEventArgs | Initializes a new instance of the ExternalOperationChangedEventArgs class
Top
Properties
 | Name | Description
Public property | OperationName | Name of the operation.
Public property | PluginModuleId | Licensable module identifier of the plugin.
Public property | Registered | Whether the operation was registered or unregistered.
Public property | ServiceName | Name of the service.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs Constructor

Initializes a new instance of the ExternalOperationChangedEventArgs class

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalOperationChangedEventArgs(
    int pluginModuleId,
    string serviceName,
    string operationName,
    bool registered
)

Parameters

pluginModuleId
Type: SystemInt32
serviceName
Type: SystemString
operationName
Type: SystemString
registered
Type: SystemBoolean
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs Properties

The ExternalOperationChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OperationName | Name of the operation.
Public property | PluginModuleId | Licensable module identifier of the plugin.
Public property | Registered | Whether the operation was registered or unregistered.
Public property | ServiceName | Name of the service.
Top
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs.OperationName Property

ExternalOperationChangedEventArgsOperationName Property

Name of the operation.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OperationName { get; }

Property Value

Type: String
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs.PluginModuleId Property

ExternalOperationChangedEventArgsPluginModuleId Property

Licensable module identifier of the plugin.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int PluginModuleId { get; }

Property Value

Type: Int32
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs.Registered Property

ExternalOperationChangedEventArgsRegistered Property

Whether the operation was registered or unregistered.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Registered { get; }

Property Value

Type: Boolean
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs.ServiceName Property

ExternalOperationChangedEventArgsServiceName Property

Name of the service.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ServiceName { get; }

Property Value

Type: String
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


ExternalOperationChangedEventArgs Methods

The ExternalOperationChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExternalOperationChangedEventArgs Class
Resto.Front.Api.Data.Common Namespace


IEntity Interface

Represents an object which have an identifier.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IEntity : ISerializable

The IEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


IEntity Properties

The IEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Top
See Also

Reference

IEntity Interface
Resto.Front.Api.Data.Common Namespace


IEntity.Id Property

IEntityId Property

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

IEntity Interface
Resto.Front.Api.Data.Common Namespace


IEntity Methods

The IEntity type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IEntity Interface
Resto.Front.Api.Data.Common Namespace


IVersionedEntity Interface

Represents an entity which have a revision.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IVersionedEntity : ISerializable,
    IEntity

The IVersionedEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Revision | Incremental version of the entity.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Common Namespace


IVersionedEntity Properties

The IVersionedEntity type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Revision | Incremental version of the entity.
Top
See Also

Reference

IVersionedEntity Interface
Resto.Front.Api.Data.Common Namespace


IVersionedEntity.Revision Property

IVersionedEntityRevision Property

Incremental version of the entity.

Namespace: Resto.Front.Api.Data.Common
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Revision { get; }

Property Value

Type: Int32
See Also

Reference

IVersionedEntity Interface
Resto.Front.Api.Data.Common Namespace


IVersionedEntity Methods

The IVersionedEntity type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IVersionedEntity Interface
Resto.Front.Api.Data.Common Namespace


Resto.Front.Api.Data.DataTransferObjects Namespace

Classes
 | Class | Description
Public class | CheckSplitResultDto |
Public class | HierarchicalMenu |
Public class | LegalAddress |
Public class | PreliminaryOrderItemModifier |
Public class | PreliminaryOrderItemProduct |
Public class | SmsSendingResultDto |


CheckSplitResultDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsCheckSplitResultDto

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CheckSplitResultDto : ISerializable

The CheckSplitResultDto type exposes the following members.

Constructors
 | Name | Description
Public method | CheckSplitResultDto | Initializes a new instance of the CheckSplitResultDto class
Protected method | CheckSplitResultDto(SerializationInfo, StreamingContext) | Initializes a new instance of the CheckSplitResultDto class
Top
Properties
 | Name | Description
Public property | CheckSplitRequiredResult | Whether order should be splitted between cash registers before payment.
Public property | PointOfSale | Estimated point of sale for order payment if it can be determinated at the moment.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto Constructor

Overload List
 | Name | Description
Public method | CheckSplitResultDto | Initializes a new instance of the CheckSplitResultDto class
Protected method | CheckSplitResultDto(SerializationInfo, StreamingContext) | Initializes a new instance of the CheckSplitResultDto class
Top
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto Constructor

Initializes a new instance of the CheckSplitResultDto class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CheckSplitResultDto()
See Also

Reference

CheckSplitResultDto Class
CheckSplitResultDto Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the CheckSplitResultDto class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected CheckSplitResultDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

CheckSplitResultDto Class
CheckSplitResultDto Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto Properties

The CheckSplitResultDto type exposes the following members.

Properties
 | Name | Description
Public property | CheckSplitRequiredResult | Whether order should be splitted between cash registers before payment.
Public property | PointOfSale | Estimated point of sale for order payment if it can be determinated at the moment.
Top
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto.CheckSplitRequiredResult Property

CheckSplitResultDtoCheckSplitRequiredResult Property

Whether order should be splitted between cash registers before payment.

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CheckSplitRequiredResult CheckSplitRequiredResult { get; set; }

Property Value

Type: CheckSplitRequiredResult
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto.PointOfSale Property

CheckSplitResultDtoPointOfSale Property

Estimated point of sale for order payment if it can be determinated at the moment.

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IPointOfSale PointOfSale { get; set; }

Property Value

Type: IPointOfSale
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto Methods

The CheckSplitResultDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


CheckSplitResultDto.GetObjectData Method

CheckSplitResultDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CheckSplitResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsHierarchicalMenu

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class HierarchicalMenu : ISerializable

The HierarchicalMenu type exposes the following members.

Constructors
 | Name | Description
Public method | HierarchicalMenu | Initializes a new instance of the HierarchicalMenu class
Protected method | HierarchicalMenu(SerializationInfo, StreamingContext) | Initializes a new instance of the HierarchicalMenu class
Top
Properties
 | Name | Description
Public property | ProductGroups |
Public property | Products |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Constructor

Overload List
 | Name | Description
Public method | HierarchicalMenu | Initializes a new instance of the HierarchicalMenu class
Protected method | HierarchicalMenu(SerializationInfo, StreamingContext) | Initializes a new instance of the HierarchicalMenu class
Top
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Constructor

Initializes a new instance of the HierarchicalMenu class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public HierarchicalMenu()
See Also

Reference

HierarchicalMenu Class
HierarchicalMenu Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the HierarchicalMenu class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected HierarchicalMenu(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

HierarchicalMenu Class
HierarchicalMenu Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Properties

The HierarchicalMenu type exposes the following members.

Properties
 | Name | Description
Public property | ProductGroups |
Public property | Products |
Top
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu.ProductGroups Property

HierarchicalMenuProductGroups Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyList<IProductGroup> ProductGroups { get; set; }

Property Value

Type: IReadOnlyList IProductGroup
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu.Products Property

HierarchicalMenuProducts Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyList<IProduct> Products { get; set; }

Property Value

Type: IReadOnlyList IProduct
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu Methods

The HierarchicalMenu type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


HierarchicalMenu.GetObjectData Method

HierarchicalMenuGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HierarchicalMenu Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsLegalAddress

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class LegalAddress : ISerializable

The LegalAddress type exposes the following members.

Constructors
 | Name | Description
Public method | LegalAddress | Initializes a new instance of the LegalAddress class
Protected method | LegalAddress(SerializationInfo, StreamingContext) | Initializes a new instance of the LegalAddress class
Top
Properties
 | Name | Description
Public property | Building |
Public property | City |
Public property | Country |
Public property | House |
Public property | Street |
Public property | ZipCode |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Constructor

Overload List
 | Name | Description
Public method | LegalAddress | Initializes a new instance of the LegalAddress class
Protected method | LegalAddress(SerializationInfo, StreamingContext) | Initializes a new instance of the LegalAddress class
Top
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Constructor

Initializes a new instance of the LegalAddress class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LegalAddress()
See Also

Reference

LegalAddress Class
LegalAddress Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LegalAddress class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected LegalAddress(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

LegalAddress Class
LegalAddress Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Properties

The LegalAddress type exposes the following members.

Properties
 | Name | Description
Public property | Building |
Public property | City |
Public property | Country |
Public property | House |
Public property | Street |
Public property | ZipCode |
Top
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.Building Property

LegalAddressBuilding Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Building { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.City Property

LegalAddressCity Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string City { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.Country Property

LegalAddressCountry Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Country { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.House Property

LegalAddressHouse Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string House { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.Street Property

LegalAddressStreet Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Street { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.ZipCode Property

LegalAddressZipCode Property

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ZipCode { get; set; }

Property Value

Type: String
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress Methods

The LegalAddress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


LegalAddress.GetObjectData Method

LegalAddressGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

LegalAddress Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsPreliminaryOrderItemModifier

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PreliminaryOrderItemModifier : ISerializable

The PreliminaryOrderItemModifier type exposes the following members.

Constructors
 | Name | Description
Public method | PreliminaryOrderItemModifier | Initializes a new instance of the PreliminaryOrderItemModifier class
Protected method | PreliminaryOrderItemModifier(SerializationInfo, StreamingContext) | Initializes a new instance of the PreliminaryOrderItemModifier class
Top
Properties
 | Name | Description
Public property | Amount | Modifier amount
Public property | Dish | Modifier dish
Public property | IsChildModifier | Is modifier child of group modifier
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Constructor

Overload List
 | Name | Description
Public method | PreliminaryOrderItemModifier | Initializes a new instance of the PreliminaryOrderItemModifier class
Protected method | PreliminaryOrderItemModifier(SerializationInfo, StreamingContext) | Initializes a new instance of the PreliminaryOrderItemModifier class
Top
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Constructor

Initializes a new instance of the PreliminaryOrderItemModifier class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PreliminaryOrderItemModifier()
See Also

Reference

PreliminaryOrderItemModifier Class
PreliminaryOrderItemModifier Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PreliminaryOrderItemModifier class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected PreliminaryOrderItemModifier(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PreliminaryOrderItemModifier Class
PreliminaryOrderItemModifier Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Properties

The PreliminaryOrderItemModifier type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Modifier amount
Public property | Dish | Modifier dish
Public property | IsChildModifier | Is modifier child of group modifier
Top
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier.Amount Property

PreliminaryOrderItemModifierAmount Property

Modifier amount

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Amount { get; set; }

Property Value

Type: Int32
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier.Dish Property

PreliminaryOrderItemModifierDish Property

Modifier dish

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IProduct Dish { get; set; }

Property Value

Type: IProduct
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier.IsChildModifier Property

PreliminaryOrderItemModifierIsChildModifier Property

Is modifier child of group modifier

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsChildModifier { get; set; }

Property Value

Type: Boolean
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier Methods

The PreliminaryOrderItemModifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemModifier.GetObjectData Method

PreliminaryOrderItemModifierGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PreliminaryOrderItemModifier Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsPreliminaryOrderItemProduct

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PreliminaryOrderItemProduct : ISerializable

The PreliminaryOrderItemProduct type exposes the following members.

Constructors
 | Name | Description
Public method | PreliminaryOrderItemProduct | Initializes a new instance of the PreliminaryOrderItemProduct class
Protected method | PreliminaryOrderItemProduct(SerializationInfo, StreamingContext) | Initializes a new instance of the PreliminaryOrderItemProduct class
Top
Properties
 | Name | Description
Public property | Amount | Product amount
Public property | Dish | Product dish
Public property | Modifiers | Product modifiers
Public property | ProductSize | Size of the product.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Constructor

Overload List
 | Name | Description
Public method | PreliminaryOrderItemProduct | Initializes a new instance of the PreliminaryOrderItemProduct class
Protected method | PreliminaryOrderItemProduct(SerializationInfo, StreamingContext) | Initializes a new instance of the PreliminaryOrderItemProduct class
Top
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Constructor

Initializes a new instance of the PreliminaryOrderItemProduct class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PreliminaryOrderItemProduct()
See Also

Reference

PreliminaryOrderItemProduct Class
PreliminaryOrderItemProduct Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the PreliminaryOrderItemProduct class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected PreliminaryOrderItemProduct(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

PreliminaryOrderItemProduct Class
PreliminaryOrderItemProduct Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Properties

The PreliminaryOrderItemProduct type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Product amount
Public property | Dish | Product dish
Public property | Modifiers | Product modifiers
Public property | ProductSize | Size of the product.
Top
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct.Amount Property

PreliminaryOrderItemProductAmount Property

Product amount

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Amount { get; set; }

Property Value

Type: Decimal
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct.Dish Property

PreliminaryOrderItemProductDish Property

Product dish

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IProduct Dish { get; set; }

Property Value

Type: IProduct
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct.Modifiers Property

PreliminaryOrderItemProductModifiers Property

Product modifiers

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyList<PreliminaryOrderItemModifier> Modifiers { get; set; }

Property Value

Type: IReadOnlyList PreliminaryOrderItemModifier
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct.ProductSize Property

PreliminaryOrderItemProductProductSize Property

Size of the product.

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IProductSize ProductSize { get; set; }

Property Value

Type: IProductSize
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct Methods

The PreliminaryOrderItemProduct type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


PreliminaryOrderItemProduct.GetObjectData Method

PreliminaryOrderItemProductGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PreliminaryOrderItemProduct Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DataTransferObjectsSmsSendingResultDto

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class SmsSendingResultDto : ISerializable

The SmsSendingResultDto type exposes the following members.

Constructors
 | Name | Description
Public method | SmsSendingResultDto | Initializes a new instance of the SmsSendingResultDto class
Protected method | SmsSendingResultDto(SerializationInfo, StreamingContext) | Initializes a new instance of the SmsSendingResultDto class
Top
Properties
 | Name | Description
Public property | ErrorText | Error text in case of unsuccessfully sending.
Public property | IsError | Indicates if sms was sent successfully or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Constructor

Overload List
 | Name | Description
Public method | SmsSendingResultDto | Initializes a new instance of the SmsSendingResultDto class
Protected method | SmsSendingResultDto(SerializationInfo, StreamingContext) | Initializes a new instance of the SmsSendingResultDto class
Top
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Constructor

Initializes a new instance of the SmsSendingResultDto class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public SmsSendingResultDto()
See Also

Reference

SmsSendingResultDto Class
SmsSendingResultDto Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SmsSendingResultDto class

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected SmsSendingResultDto(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

SmsSendingResultDto Class
SmsSendingResultDto Overload
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Properties

The SmsSendingResultDto type exposes the following members.

Properties
 | Name | Description
Public property | ErrorText | Error text in case of unsuccessfully sending.
Public property | IsError | Indicates if sms was sent successfully or not.
Top
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto.ErrorText Property

SmsSendingResultDtoErrorText Property

Error text in case of unsuccessfully sending.

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ErrorText { get; set; }

Property Value

Type: String
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto.IsError Property

SmsSendingResultDtoIsError Property

Indicates if sms was sent successfully or not.

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsError { get; set; }

Property Value

Type: Boolean
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto Methods

The SmsSendingResultDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


SmsSendingResultDto.GetObjectData Method

SmsSendingResultDtoGetObjectData Method

Namespace: Resto.Front.Api.Data.DataTransferObjects
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

SmsSendingResultDto Class
Resto.Front.Api.Data.DataTransferObjects Namespace


Resto.Front.Api.Data.Device Namespace

Classes
 | Class | Description
Public class | BeforeDoCheckActionResult | BeforeDoCheckAction will be passed to the front app for changing certain values. Set null for any field for default value.
Public class | CashRegisterChequeExtensions | More information about do cheque
Interfaces
 | Interface | Description
Public interface | ICafeSession | Current open cafe session. TryGetCafeSessionByCashRegister(ICashRegisterInfo)
Public interface | ICashRegisterInfo |
Enumerations
 | Enumeration | Description
Public enumeration | CashRegisterCloseEncashmentSetup | Cash register close encashment setup.
Public enumeration | DeviceType | Type of a device.
Public enumeration | State | Device state.


BeforeDoCheckActionResult Class

BeforeDoCheckAction will be passed to the front app for changing certain values. Set null for any field for default value.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DeviceBeforeDoCheckActionResult

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class BeforeDoCheckActionResult

The BeforeDoCheckActionResult type exposes the following members.

Constructors
 | Name | Description
Public method | BeforeDoCheckActionResult | Main constructor
Top
Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Public property | CashierName | Cashier name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public BeforeDoCheckActionResult()
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult Properties

The BeforeDoCheckActionResult type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Public property | CashierName | Cashier name.
Top
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult.AfterCheque Property

BeforeDoCheckActionResultAfterCheque Property

Markup to add at the end of the cheque.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<Document> AfterCheque { get; set; }

Property Value

Type: List Document
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult.BeforeCheque Property

BeforeDoCheckActionResultBeforeCheque Property

Markup to add to the header (at the very beginning of the cheque).

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<Document> BeforeCheque { get; set; }

Property Value

Type: List Document
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult.CashierName Property

BeforeDoCheckActionResultCashierName Property

Cashier name.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CashierName { get; set; }

Property Value

Type: String
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


BeforeDoCheckActionResult Methods

The BeforeDoCheckActionResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BeforeDoCheckActionResult Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions Class

More information about do cheque
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.DeviceCashRegisterChequeExtensions

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CashRegisterChequeExtensions

The CashRegisterChequeExtensions type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterChequeExtensions | Initializes a new instance of the CashRegisterChequeExtensions class
Top
Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Public property | PastOrderId | Closed order id other cafe session.
Public property | PastOrderNumber | Closed order number other cafe session.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions Constructor

Initializes a new instance of the CashRegisterChequeExtensions class

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterChequeExtensions(
    IEnumerable<XElement> beforeCheque,
    IEnumerable<XElement> afterCheque,
    Guid? pastOrderId,
    int? pastOrderNumber
)

Parameters

beforeCheque
Type: System.Collections.GenericIEnumerable XElement
Markup to add to the header (at the very beginning of the cheque).
afterCheque
Type: System.Collections.GenericIEnumerable XElement
Markup to add at the end of the cheque.
pastOrderId
Type: SystemNullable Guid
Closed order id other cafe session.
pastOrderNumber
Type: SystemNullable Int32
Closed order number other cafe session.
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions Properties

The CashRegisterChequeExtensions type exposes the following members.

Properties
 | Name | Description
Public property | AfterCheque | Markup to add at the end of the cheque.
Public property | BeforeCheque | Markup to add to the header (at the very beginning of the cheque).
Public property | PastOrderId | Closed order id other cafe session.
Public property | PastOrderNumber | Closed order number other cafe session.
Top
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions.AfterCheque Property

CashRegisterChequeExtensionsAfterCheque Property

Markup to add at the end of the cheque.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<Document> AfterCheque { get; }

Property Value

Type: List Document
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions.BeforeCheque Property

CashRegisterChequeExtensionsBeforeCheque Property

Markup to add to the header (at the very beginning of the cheque).

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<Document> BeforeCheque { get; }

Property Value

Type: List Document
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions.PastOrderId Property

CashRegisterChequeExtensionsPastOrderId Property

Closed order id other cafe session.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? PastOrderId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions.PastOrderNumber Property

CashRegisterChequeExtensionsPastOrderNumber Property

Closed order number other cafe session.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? PastOrderNumber { get; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterChequeExtensions Methods

The CashRegisterChequeExtensions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterChequeExtensions Class
Resto.Front.Api.Data.Device Namespace


CashRegisterCloseEncashmentSetup Enumeration

Cash register close encashment setup.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum CashRegisterCloseEncashmentSetup
Members
Member name | Value | Description
Partial | 0 | Partial incassation.
FullAndPayIn | 1 | Full incassation and pay in.
AutoAndPayIn | 2 | Autoincassation and pay in.
See Also

Reference

Resto.Front.Api.Data.Device Namespace


DeviceType Enumeration

Type of a device.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeviceType
Members
Member name | Value | Description
CashRegister | 0 |
PrinterDevice | 1 |
CameraDevice | 2 |
CustomerDisplay | 3 |
CardProcessing | 4 |
ScaleDevice | 5 |
CashDrawerDevice | 6 |
PowerDevice | 7 |
See Also

Reference

Resto.Front.Api.Data.Device Namespace


ICafeSession Interface

Current open cafe session. TryGetCafeSessionByCashRegister(ICashRegisterInfo)

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICafeSession : ISerializable,
    IEntity

The ICafeSession type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | The cash register device on which this cafe session is open.
Public property | Id | (Inherited from IEntity.)
Public property | Number | The number of the cafe session.
Public property | OpenTime | When the cafe session was opened.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Device Namespace


ICafeSession Properties

The ICafeSession type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | The cash register device on which this cafe session is open.
Public property | Id | (Inherited from IEntity.)
Public property | Number | The number of the cafe session.
Public property | OpenTime | When the cafe session was opened.
Top
See Also

Reference

ICafeSession Interface
Resto.Front.Api.Data.Device Namespace


ICafeSession.CashRegister Property

ICafeSessionCashRegister Property

The cash register device on which this cafe session is open.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo CashRegister { get; }

Property Value

Type: ICashRegisterInfo
See Also

Reference

ICafeSession Interface
Resto.Front.Api.Data.Device Namespace


ICafeSession.Number Property

ICafeSessionNumber Property

The number of the cafe session.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

ICafeSession Interface
Resto.Front.Api.Data.Device Namespace


ICafeSession.OpenTime Property

ICafeSessionOpenTime Property

When the cafe session was opened.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime OpenTime { get; }

Property Value

Type: DateTime
See Also

Reference

ICafeSession Interface
Resto.Front.Api.Data.Device Namespace


ICafeSession Methods

The ICafeSession type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICafeSession Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo Interface

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICashRegisterInfo : ISerializable,
    IEntity

The ICashRegisterInfo type exposes the following members.

Properties
 | Name | Description
Public property | CheckCashDrawer |
Public property | CloseEncashmentSetup |
Public property | EmulateDayShift |
Public property | EmulateFiscalCheques |
Public property | EmulateFiscalReports |
Public property | FriendlyName |
Public property | FullCheque |
Public property | HasDriver |
Public property | Id | (Inherited from IEntity.)
Public property | IsOfdSupported |
Public property | IsOfdVersionHigher10 |
Public property | IsVirtual |
Public property | Name |
Public property | Number |
Public property | PrintChange |
Public property | PrintNds |
Public property | PrintOrderNumber |
Public property | SerialNumber |
Public property | VirtualChequePrinterId |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo Properties

The ICashRegisterInfo type exposes the following members.

Properties
 | Name | Description
Public property | CheckCashDrawer |
Public property | CloseEncashmentSetup |
Public property | EmulateDayShift |
Public property | EmulateFiscalCheques |
Public property | EmulateFiscalReports |
Public property | FriendlyName |
Public property | FullCheque |
Public property | HasDriver |
Public property | Id | (Inherited from IEntity.)
Public property | IsOfdSupported |
Public property | IsOfdVersionHigher10 |
Public property | IsVirtual |
Public property | Name |
Public property | Number |
Public property | PrintChange |
Public property | PrintNds |
Public property | PrintOrderNumber |
Public property | SerialNumber |
Public property | VirtualChequePrinterId |
Top
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.CheckCashDrawer Property

ICashRegisterInfoCheckCashDrawer Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CheckCashDrawer { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.CloseEncashmentSetup Property

ICashRegisterInfoCloseEncashmentSetup Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterCloseEncashmentSetup CloseEncashmentSetup { get; }

Property Value

Type: CashRegisterCloseEncashmentSetup
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.EmulateDayShift Property

ICashRegisterInfoEmulateDayShift Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool EmulateDayShift { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.EmulateFiscalCheques Property

ICashRegisterInfoEmulateFiscalCheques Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool EmulateFiscalCheques { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.EmulateFiscalReports Property

ICashRegisterInfoEmulateFiscalReports Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool EmulateFiscalReports { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.FriendlyName Property

ICashRegisterInfoFriendlyName Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string FriendlyName { get; }

Property Value

Type: String
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.FullCheque Property

ICashRegisterInfoFullCheque Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool FullCheque { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.HasDriver Property

ICashRegisterInfoHasDriver Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasDriver { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.IsOfdSupported Property

ICashRegisterInfoIsOfdSupported Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsOfdSupported { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.IsOfdVersionHigher10 Property

ICashRegisterInfoIsOfdVersionHigher10 Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsOfdVersionHigher10 { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.IsVirtual Property

ICashRegisterInfoIsVirtual Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsVirtual { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.Name Property

ICashRegisterInfoName Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.Number Property

ICashRegisterInfoNumber Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.PrintChange Property

ICashRegisterInfoPrintChange Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PrintChange { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.PrintNds Property

ICashRegisterInfoPrintNds Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PrintNds { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.PrintOrderNumber Property

ICashRegisterInfoPrintOrderNumber Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PrintOrderNumber { get; }

Property Value

Type: Boolean
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.SerialNumber Property

ICashRegisterInfoSerialNumber Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string SerialNumber { get; }

Property Value

Type: String
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo.VirtualChequePrinterId Property

ICashRegisterInfoVirtualChequePrinterId Property

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? VirtualChequePrinterId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


ICashRegisterInfo Methods

The ICashRegisterInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICashRegisterInfo Interface
Resto.Front.Api.Data.Device Namespace


State Enumeration

Device state.

Namespace: Resto.Front.Api.Data.Device
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum State
Members
Member name | Value | Description
Unknown | 0 | Unknown.
New | 1 | New.
Stopped | 2 | Stopped.
Starting | 3 | Starting.
Running | 4 | Running.
Paused | 5 | Paused.
Stopping | 6 | Stopping.
Shutdown | 7 | Shutdown.
RuntimeSetup | 8 | Runtime setup.
See Also

Reference

Resto.Front.Api.Data.Device Namespace


Resto.Front.Api.Data.Device.Results Namespace

Classes
 | Class | Description
Public class | CashRegisterResult | Cash register result.
Public class | CashRegisterStatus | Cash register status.
Public class | CashRegisterVatData | Cash register VAT data.
Public class | DeviceInfo | Device status information.
Public class | DirectIoResult | The result of the operation.
Public class | Document | Document for printing.
Public class | ErrorResult | The successful result of the executed command.
Public class | FiscalRegisterTaxItem | Fiscal register tax item
Public class | OkResult | The successful result of the executed command.
Public class | PostResult | Device post result.
Public class | QueryInfoResult | Class that contains list of additional supported commands.
Public class | ScaleWeightResult | Scale weight result.


CashRegisterResult Class

Cash register result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsPostResult
Resto.Front.Api.Data.Device.ResultsCashRegisterResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterResult : PostResult

The CashRegisterResult type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterResult | Main constructor
Top
Properties
 | Name | Description
Public property | BillNumber | Bill number.
Public property | CashSum | Cash sum.
Public property | ChequeVatTotalizers | VAT totalizers for the last cheque.
Public property | DailyVatTotalizers | Daily VAT totalizers.
Public property | DocumentNumber | Document number.
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | RtcDateTime | Rtc date time.
Public property | SaleNumber | Sale number.
Public property | SerialNumber | Serial number.
Public property | Session | Session.
Public property | Success | Is it successful? (Inherited from PostResult.)
Public property | TotalIncomeSum | Total income sum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterResult(
    decimal? cashSum,
    decimal? totalIncomeSum,
    int? session,
    string serialNumber,
    int? documentNumber,
    int? saleNumber,
    int? billNumber,
    string rtcDateTime
)

Parameters

cashSum
Type: SystemNullable Decimal
totalIncomeSum
Type: SystemNullable Decimal
session
Type: SystemNullable Int32
serialNumber
Type: SystemString
documentNumber
Type: SystemNullable Int32
saleNumber
Type: SystemNullable Int32
billNumber
Type: SystemNullable Int32
rtcDateTime
Type: SystemString
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult Properties

The CashRegisterResult type exposes the following members.

Properties
 | Name | Description
Public property | BillNumber | Bill number.
Public property | CashSum | Cash sum.
Public property | ChequeVatTotalizers | VAT totalizers for the last cheque.
Public property | DailyVatTotalizers | Daily VAT totalizers.
Public property | DocumentNumber | Document number.
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | RtcDateTime | Rtc date time.
Public property | SaleNumber | Sale number.
Public property | SerialNumber | Serial number.
Public property | Session | Session.
Public property | Success | Is it successful? (Inherited from PostResult.)
Public property | TotalIncomeSum | Total income sum.
Top
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.BillNumber Property

CashRegisterResultBillNumber Property

Bill number.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? BillNumber { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.CashSum Property

CashRegisterResultCashSum Property

Cash sum.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? CashSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.ChequeVatTotalizers Property

CashRegisterResultChequeVatTotalizers Property

VAT totalizers for the last cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<CashRegisterVatData> ChequeVatTotalizers { get; set; }

Property Value

Type: List CashRegisterVatData
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.DailyVatTotalizers Property

CashRegisterResultDailyVatTotalizers Property

Daily VAT totalizers.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<CashRegisterVatData> DailyVatTotalizers { get; set; }

Property Value

Type: List CashRegisterVatData
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.DocumentNumber Property

CashRegisterResultDocumentNumber Property

Document number.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? DocumentNumber { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.RtcDateTime Property

CashRegisterResultRtcDateTime Property

Rtc date time.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string RtcDateTime { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.SaleNumber Property

CashRegisterResultSaleNumber Property

Sale number.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? SaleNumber { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.SerialNumber Property

CashRegisterResultSerialNumber Property

Serial number.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string SerialNumber { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.Session Property

CashRegisterResultSession Property

Session.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? Session { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult.TotalIncomeSum Property

CashRegisterResultTotalIncomeSum Property

Total income sum.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? TotalIncomeSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterResult Methods

The CashRegisterResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterResult Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus Class

Cash register status.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsCashRegisterStatus

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterStatus

The CashRegisterStatus type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterStatus | Main constructor
Top
Properties
 | Name | Description
Public property | ErrorCode | Error code.
Public property | ExtendedStatus | Extended status.
Public property | FiscalStorage | Fiscal storage.
Public property | FnResponseCode | Fiscal storage response code.
Public property | HaveRegisterDateTime | Date and time in yyyy-MM-dd HH:mm:ss format.
Public property | IsOfdConnected | Ofd connection status.
Public property | OfdBufferedDocuments | Number of documents in buffer.
Public property | OfdChequeDateTime | Date and time of the last cheque.
Public property | OfdChequeSum | Cheque sum.
Public property | OfdDocumentNumber | Document number.
Public property | OfdKkmRegistrationNumber | Kkm registration number of the last cheque.
Public property | OfdOrgName | The name of the organization in the last cheque.
Public property | OfdResponseCode | Ofd response code.
Public property | OfdSalesAddress | Sale address of the last cheque.
Public property | OfdTaxpayerIdNumber | Id number of Ofd taxpayer.
Public property | OfdUrl | Internet address for receiving a copy of the latest electronic cheque.
Public property | OfflineMode | Offline mode.
Public property | RegisterDateTime | Register date time.
Public property | RestaurantMode | Restaurant mode.
Public property | SessionStatus | Cafe session status: 0 - closed, 1 - open, 2 - expired.
Public property | StatusBarInfo | Info to be shown in the iikoFront status bar.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterStatus()
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus Properties

The CashRegisterStatus type exposes the following members.

Properties
 | Name | Description
Public property | ErrorCode | Error code.
Public property | ExtendedStatus | Extended status.
Public property | FiscalStorage | Fiscal storage.
Public property | FnResponseCode | Fiscal storage response code.
Public property | HaveRegisterDateTime | Date and time in yyyy-MM-dd HH:mm:ss format.
Public property | IsOfdConnected | Ofd connection status.
Public property | OfdBufferedDocuments | Number of documents in buffer.
Public property | OfdChequeDateTime | Date and time of the last cheque.
Public property | OfdChequeSum | Cheque sum.
Public property | OfdDocumentNumber | Document number.
Public property | OfdKkmRegistrationNumber | Kkm registration number of the last cheque.
Public property | OfdOrgName | The name of the organization in the last cheque.
Public property | OfdResponseCode | Ofd response code.
Public property | OfdSalesAddress | Sale address of the last cheque.
Public property | OfdTaxpayerIdNumber | Id number of Ofd taxpayer.
Public property | OfdUrl | Internet address for receiving a copy of the latest electronic cheque.
Public property | OfflineMode | Offline mode.
Public property | RegisterDateTime | Register date time.
Public property | RestaurantMode | Restaurant mode.
Public property | SessionStatus | Cafe session status: 0 - closed, 1 - open, 2 - expired.
Public property | StatusBarInfo | Info to be shown in the iikoFront status bar.
Top
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.ErrorCode Property

CashRegisterStatusErrorCode Property

Error code.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? ErrorCode { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.ExtendedStatus Property

CashRegisterStatusExtendedStatus Property

Extended status.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ExtendedStatus { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.FiscalStorage Property

CashRegisterStatusFiscalStorage Property

Fiscal storage.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool? FiscalStorage { get; set; }

Property Value

Type: Nullable Boolean
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.FnResponseCode Property

CashRegisterStatusFnResponseCode Property

Fiscal storage response code.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? FnResponseCode { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.HaveRegisterDateTime Property

CashRegisterStatusHaveRegisterDateTime Property

Date and time in yyyy-MM-dd HH:mm:ss format.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool HaveRegisterDateTime { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.IsOfdConnected Property

CashRegisterStatusIsOfdConnected Property

Ofd connection status.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool? IsOfdConnected { get; set; }

Property Value

Type: Nullable Boolean
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdBufferedDocuments Property

CashRegisterStatusOfdBufferedDocuments Property

Number of documents in buffer.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? OfdBufferedDocuments { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdChequeDateTime Property

CashRegisterStatusOfdChequeDateTime Property

Date and time of the last cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdChequeDateTime { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdChequeSum Property

CashRegisterStatusOfdChequeSum Property

Cheque sum.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public double? OfdChequeSum { get; set; }

Property Value

Type: Nullable Double
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdDocumentNumber Property

CashRegisterStatusOfdDocumentNumber Property

Document number.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdDocumentNumber { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdKkmRegistrationNumber Property

CashRegisterStatusOfdKkmRegistrationNumber Property

Kkm registration number of the last cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdKkmRegistrationNumber { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdOrgName Property

CashRegisterStatusOfdOrgName Property

The name of the organization in the last cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdOrgName { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdResponseCode Property

CashRegisterStatusOfdResponseCode Property

Ofd response code.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? OfdResponseCode { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdSalesAddress Property

CashRegisterStatusOfdSalesAddress Property

Sale address of the last cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdSalesAddress { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdTaxpayerIdNumber Property

CashRegisterStatusOfdTaxpayerIdNumber Property

Id number of Ofd taxpayer.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdTaxpayerIdNumber { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfdUrl Property

CashRegisterStatusOfdUrl Property

Internet address for receiving a copy of the latest electronic cheque.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdUrl { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.OfflineMode Property

CashRegisterStatusOfflineMode Property

Offline mode.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool? OfflineMode { get; set; }

Property Value

Type: Nullable Boolean
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.RegisterDateTime Property

CashRegisterStatusRegisterDateTime Property

Register date time.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DateTime? RegisterDateTime { get; set; }

Property Value

Type: Nullable DateTime
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.RestaurantMode Property

CashRegisterStatusRestaurantMode Property

Restaurant mode.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool? RestaurantMode { get; set; }

Property Value

Type: Nullable Boolean
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.SessionStatus Property

CashRegisterStatusSessionStatus Property

Cafe session status: 0 - closed, 1 - open, 2 - expired.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? SessionStatus { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus.StatusBarInfo Property

CashRegisterStatusStatusBarInfo Property

Info to be shown in the iikoFront status bar.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string StatusBarInfo { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterStatus Methods

The CashRegisterStatus type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterStatus Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData Class

Cash register VAT data.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsFiscalRegisterTaxItem
Resto.Front.Api.Data.Device.ResultsCashRegisterVatData

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterVatData : FiscalRegisterTaxItem

The CashRegisterVatData type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterVatData | Main constructor
Top
Properties
 | Name | Description
Public property | HaveTaxableSum | True if TaxableSum is valid
Public property | HaveTaxAmount | True if TaxAmount is valid
Public property | IsCalculated | Is calculated VAT rate? (Inherited from FiscalRegisterTaxItem.)
Public property | IsTaxable | True if not extempted VAT rate (Inherited from FiscalRegisterTaxItem.)
Public property | TaxableSum | Taxable sum.
Public property | TaxAmount | Tax amount.
Public property | TaxId | Tax id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..). (Inherited from FiscalRegisterTaxItem.)
Public property | TaxName | Tax name to display. (Inherited from FiscalRegisterTaxItem.)
Public property | TaxPercent | Tax item in percent. (Inherited from FiscalRegisterTaxItem.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterVatData(
    string taxId,
    bool isTaxable,
    bool isCalculated,
    decimal taxPercent,
    string taxName
)

Parameters

taxId
Type: SystemString
isTaxable
Type: SystemBoolean
isCalculated
Type: SystemBoolean
taxPercent
Type: SystemDecimal
taxName
Type: SystemString
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData Properties

The CashRegisterVatData type exposes the following members.

Properties
 | Name | Description
Public property | HaveTaxableSum | True if TaxableSum is valid
Public property | HaveTaxAmount | True if TaxAmount is valid
Public property | IsCalculated | Is calculated VAT rate? (Inherited from FiscalRegisterTaxItem.)
Public property | IsTaxable | True if not extempted VAT rate (Inherited from FiscalRegisterTaxItem.)
Public property | TaxableSum | Taxable sum.
Public property | TaxAmount | Tax amount.
Public property | TaxId | Tax id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..). (Inherited from FiscalRegisterTaxItem.)
Public property | TaxName | Tax name to display. (Inherited from FiscalRegisterTaxItem.)
Public property | TaxPercent | Tax item in percent. (Inherited from FiscalRegisterTaxItem.)
Top
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData.HaveTaxableSum Property

CashRegisterVatDataHaveTaxableSum Property

True if TaxableSum is valid

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool HaveTaxableSum { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData.HaveTaxAmount Property

CashRegisterVatDataHaveTaxAmount Property

True if TaxAmount is valid

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool HaveTaxAmount { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData.TaxableSum Property

CashRegisterVatDataTaxableSum Property

Taxable sum.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal TaxableSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData.TaxAmount Property

CashRegisterVatDataTaxAmount Property

Tax amount.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal TaxAmount { get; set; }

Property Value

Type: Decimal
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


CashRegisterVatData Methods

The CashRegisterVatData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterVatData Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Class

Device status information.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsDeviceInfo

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceInfo

The DeviceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceInfo | Default constructor
Public method | DeviceInfo(State, String, DeviceSettings) | Main constructor
Top
Properties
 | Name | Description
Public property | Comment | Device status: why doesnt work, etc.
Public property | Settings | Current device settings.
Public property | State | Device state: strarted, starting, stopped, etc.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Constructor

Overload List
 | Name | Description
Public method | DeviceInfo | Default constructor
Public method | DeviceInfo(State, String, DeviceSettings) | Main constructor
Top
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceInfo()
See Also

Reference

DeviceInfo Class
DeviceInfo Overload
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Constructor (State, String, DeviceSettings)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceInfo(
    State state,
    string comment,
    DeviceSettings settings
)

Parameters

state
Type: Resto.Front.Api.Data.DeviceState
comment
Type: SystemString
settings
Type: Resto.Front.Api.Data.Device.SettingsDeviceSettings
See Also

Reference

DeviceInfo Class
DeviceInfo Overload
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Properties

The DeviceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Device status: why doesnt work, etc.
Public property | Settings | Current device settings.
Public property | State | Device state: strarted, starting, stopped, etc.
Top
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo.Comment Property

DeviceInfoComment Property

Device status: why doesnt work, etc.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

Type: String
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo.Settings Property

DeviceInfoSettings Property

Current device settings.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceSettings Settings { get; set; }

Property Value

Type: DeviceSettings
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo.State Property

DeviceInfoState Property

Device state: strarted, starting, stopped, etc.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public State State { get; set; }

Property Value

Type: State
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DeviceInfo Methods

The DeviceInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceInfo Class
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Class

The result of the operation.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsDirectIoResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DirectIoResult

The DirectIoResult type exposes the following members.

Constructors
 | Name | Description
Public method | DirectIoResult | Default constructor
Public method | DirectIoResult(Document, String) | Main constructor
Top
Properties
 | Name | Description
Public property | Document | Document for printing.
Public property | Message | The message about the performed operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Constructor

Overload List
 | Name | Description
Public method | DirectIoResult | Default constructor
Public method | DirectIoResult(Document, String) | Main constructor
Top
See Also

Reference

DirectIoResult Class
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DirectIoResult()
See Also

Reference

DirectIoResult Class
DirectIoResult Overload
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Constructor (Document, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DirectIoResult(
    Document document,
    string message
)

Parameters

document
Type: Resto.Front.Api.Data.Device.ResultsDocument
message
Type: SystemString
See Also

Reference

DirectIoResult Class
DirectIoResult Overload
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Properties

The DirectIoResult type exposes the following members.

Properties
 | Name | Description
Public property | Document | Document for printing.
Public property | Message | The message about the performed operation.
Top
See Also

Reference

DirectIoResult Class
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult.Document Property

DirectIoResultDocument Property

Document for printing.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Document Document { get; set; }

Property Value

Type: Document
See Also

Reference

DirectIoResult Class
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult.Message Property

DirectIoResultMessage Property

The message about the performed operation.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Message { get; set; }

Property Value

Type: String
See Also

Reference

DirectIoResult Class
Resto.Front.Api.Data.Device.Results Namespace


DirectIoResult Methods

The DirectIoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectIoResult Class
Resto.Front.Api.Data.Device.Results Namespace


Document Class

Document for printing.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsDocument

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class Document

The Document type exposes the following members.

Constructors
 | Name | Description
Public method | Document | Default constructor
Public method | Document(ListString) | Main constructor
Top
Properties
 | Name | Description
Public property | Lines | Text lines to display.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


Document Constructor

Overload List
 | Name | Description
Public method | Document | Default constructor
Public method | Document(ListString) | Main constructor
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Device.Results Namespace


Document Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Document()
See Also

Reference

Document Class
Document Overload
Resto.Front.Api.Data.Device.Results Namespace


Document Constructor (List(String))

Document Constructor (ListString)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Document(
    List<string> lines
)

Parameters

lines
Type: System.Collections.GenericList String
See Also

Reference

Document Class
Document Overload
Resto.Front.Api.Data.Device.Results Namespace


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | Lines | Text lines to display.
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Device.Results Namespace


Document.Lines Property

DocumentLines Property

Text lines to display.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<string> Lines { get; set; }

Property Value

Type: List String
See Also

Reference

Document Class
Resto.Front.Api.Data.Device.Results Namespace


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Device.Results Namespace


ErrorResult Class

The successful result of the executed command.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsPostResult
Resto.Front.Api.Data.Device.ResultsErrorResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ErrorResult : PostResult

The ErrorResult type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorResult | Main constructor
Top
Properties
 | Name | Description
Public property | Details | Details about the performed operation.
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | Success | Is it successful? (Inherited from PostResult.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


ErrorResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ErrorResult(
    string details
)

Parameters

details
Type: SystemString
See Also

Reference

ErrorResult Class
Resto.Front.Api.Data.Device.Results Namespace


ErrorResult Properties

The ErrorResult type exposes the following members.

Properties
 | Name | Description
Public property | Details | Details about the performed operation.
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | Success | Is it successful? (Inherited from PostResult.)
Top
See Also

Reference

ErrorResult Class
Resto.Front.Api.Data.Device.Results Namespace


ErrorResult.Details Property

ErrorResultDetails Property

Details about the performed operation.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Details { get; set; }

Property Value

Type: String
See Also

Reference

ErrorResult Class
Resto.Front.Api.Data.Device.Results Namespace


ErrorResult Methods

The ErrorResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorResult Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem Class

Fiscal register tax item
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsFiscalRegisterTaxItem
Resto.Front.Api.Data.Device.ResultsCashRegisterVatData

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class FiscalRegisterTaxItem

The FiscalRegisterTaxItem type exposes the following members.

Constructors
 | Name | Description
Public method | FiscalRegisterTaxItem | Main constructor
Top
Properties
 | Name | Description
Public property | IsCalculated | Is calculated VAT rate?
Public property | IsTaxable | True if not extempted VAT rate
Public property | TaxId | Tax id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).
Public property | TaxName | Tax name to display.
Public property | TaxPercent | Tax item in percent.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public FiscalRegisterTaxItem(
    string taxId,
    bool isTaxable,
    bool isCalculated,
    decimal taxPercent,
    string taxName
)

Parameters

taxId
Type: SystemString
isTaxable
Type: SystemBoolean
isCalculated
Type: SystemBoolean
taxPercent
Type: SystemDecimal
taxName
Type: SystemString
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem Properties

The FiscalRegisterTaxItem type exposes the following members.

Properties
 | Name | Description
Public property | IsCalculated | Is calculated VAT rate?
Public property | IsTaxable | True if not extempted VAT rate
Public property | TaxId | Tax id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).
Public property | TaxName | Tax name to display.
Public property | TaxPercent | Tax item in percent.
Top
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem.IsCalculated Property

FiscalRegisterTaxItemIsCalculated Property

Is calculated VAT rate?

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsCalculated { get; set; }

Property Value

Type: Boolean
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem.IsTaxable Property

FiscalRegisterTaxItemIsTaxable Property

True if not extempted VAT rate

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsTaxable { get; set; }

Property Value

Type: Boolean
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem.TaxId Property

FiscalRegisterTaxItemTaxId Property

Tax id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TaxId { get; set; }

Property Value

Type: String
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem.TaxName Property

FiscalRegisterTaxItemTaxName Property

Tax name to display.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TaxName { get; set; }

Property Value

Type: String
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem.TaxPercent Property

FiscalRegisterTaxItemTaxPercent Property

Tax item in percent.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal TaxPercent { get; set; }

Property Value

Type: Decimal
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


FiscalRegisterTaxItem Methods

The FiscalRegisterTaxItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FiscalRegisterTaxItem Class
Resto.Front.Api.Data.Device.Results Namespace


OkResult Class

The successful result of the executed command.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsPostResult
Resto.Front.Api.Data.Device.ResultsOkResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class OkResult : PostResult

The OkResult type exposes the following members.

Constructors
 | Name | Description
Public method | OkResult | Main constructor
Top
Properties
 | Name | Description
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | Success | Is it successful? (Inherited from PostResult.)
Public property | Warnings | Are there any warnings?
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


OkResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public OkResult(
    bool warnings
)

Parameters

warnings
Type: SystemBoolean
See Also

Reference

OkResult Class
Resto.Front.Api.Data.Device.Results Namespace


OkResult Properties

The OkResult type exposes the following members.

Properties
 | Name | Description
Public property | Message | Message about the performed operation. (Inherited from PostResult.)
Public property | Success | Is it successful? (Inherited from PostResult.)
Public property | Warnings | Are there any warnings?
Top
See Also

Reference

OkResult Class
Resto.Front.Api.Data.Device.Results Namespace


OkResult.Warnings Property

OkResultWarnings Property

Are there any warnings?

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Warnings { get; set; }

Property Value

Type: Boolean
See Also

Reference

OkResult Class
Resto.Front.Api.Data.Device.Results Namespace


OkResult Methods

The OkResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OkResult Class
Resto.Front.Api.Data.Device.Results Namespace


PostResult Class

Device post result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsPostResult
Resto.Front.Api.Data.Device.ResultsCashRegisterResult
Resto.Front.Api.Data.Device.ResultsErrorResult
Resto.Front.Api.Data.Device.ResultsOkResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PostResult

The PostResult type exposes the following members.

Constructors
 | Name | Description
Public method | PostResult | Main constructor
Top
Properties
 | Name | Description
Public property | Message | Message about the performed operation.
Public property | Success | Is it successful?
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


PostResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PostResult()
See Also

Reference

PostResult Class
Resto.Front.Api.Data.Device.Results Namespace


PostResult Properties

The PostResult type exposes the following members.

Properties
 | Name | Description
Public property | Message | Message about the performed operation.
Public property | Success | Is it successful?
Top
See Also

Reference

PostResult Class
Resto.Front.Api.Data.Device.Results Namespace


PostResult.Message Property

PostResultMessage Property

Message about the performed operation.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Message { get; set; }

Property Value

Type: String
See Also

Reference

PostResult Class
Resto.Front.Api.Data.Device.Results Namespace


PostResult.Success Property

PostResultSuccess Property

Is it successful?

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Success { get; set; }

Property Value

Type: Boolean
See Also

Reference

PostResult Class
Resto.Front.Api.Data.Device.Results Namespace


PostResult Methods

The PostResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PostResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Class

Class that contains list of additional supported commands.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsQueryInfoResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class QueryInfoResult

The QueryInfoResult type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInfoResult | Default constructor
Public method | QueryInfoResult(ListSupportedCommand, Boolean) | Main constructor
Top
Properties
 | Name | Description
Public property | CapQueryElectronicJournalByLastSession | Indicates whether printing of electronic journal's buffer is supported by cash register.
Public property | PaymentTypesInfo | List of payment items.
Public property | SupportedCommands | List of additional supported commands.
Public property | TaxesInfo | List of tax items.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Constructor

Overload List
 | Name | Description
Public method | QueryInfoResult | Default constructor
Public method | QueryInfoResult(ListSupportedCommand, Boolean) | Main constructor
Top
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public QueryInfoResult()
See Also

Reference

QueryInfoResult Class
QueryInfoResult Overload
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Constructor (List(SupportedCommand), Boolean)

QueryInfoResult Constructor (ListSupportedCommand, Boolean)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public QueryInfoResult(
    List<SupportedCommand> supportedCommands,
    bool capQueryElectronicJournalByLastSession
)

Parameters

supportedCommands
Type: System.Collections.GenericList SupportedCommand
capQueryElectronicJournalByLastSession
Type: SystemBoolean
See Also

Reference

QueryInfoResult Class
QueryInfoResult Overload
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Properties

The QueryInfoResult type exposes the following members.

Properties
 | Name | Description
Public property | CapQueryElectronicJournalByLastSession | Indicates whether printing of electronic journal's buffer is supported by cash register.
Public property | PaymentTypesInfo | List of payment items.
Public property | SupportedCommands | List of additional supported commands.
Public property | TaxesInfo | List of tax items.
Top
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult.CapQueryElectronicJournalByLastSession Property

QueryInfoResultCapQueryElectronicJournalByLastSession Property

Indicates whether printing of electronic journal's buffer is supported by cash register.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CapQueryElectronicJournalByLastSession { get; set; }

Property Value

Type: Boolean
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult.PaymentTypesInfo Property

QueryInfoResultPaymentTypesInfo Property

List of payment items.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<FiscalRegisterPaymentType> PaymentTypesInfo { get; set; }

Property Value

Type: List FiscalRegisterPaymentType
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult.SupportedCommands Property

QueryInfoResultSupportedCommands Property

List of additional supported commands.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<SupportedCommand> SupportedCommands { get; set; }

Property Value

Type: List SupportedCommand
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult.TaxesInfo Property

QueryInfoResultTaxesInfo Property

List of tax items.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<FiscalRegisterTaxItem> TaxesInfo { get; set; }

Property Value

Type: List FiscalRegisterTaxItem
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


QueryInfoResult Methods

The QueryInfoResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryInfoResult Class
Resto.Front.Api.Data.Device.Results Namespace


ScaleWeightResult Class

Scale weight result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.ResultsScaleWeightResult

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ScaleWeightResult

The ScaleWeightResult type exposes the following members.

Constructors
 | Name | Description
Public method | ScaleWeightResult | Main constructor
Top
Properties
 | Name | Description
Public property | Weight | Weight in kilograms.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Results Namespace


ScaleWeightResult Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ScaleWeightResult(
    decimal? weight
)

Parameters

weight
Type: SystemNullable Decimal
See Also

Reference

ScaleWeightResult Class
Resto.Front.Api.Data.Device.Results Namespace


ScaleWeightResult Properties

The ScaleWeightResult type exposes the following members.

Properties
 | Name | Description
Public property | Weight | Weight in kilograms.
Top
See Also

Reference

ScaleWeightResult Class
Resto.Front.Api.Data.Device.Results Namespace


ScaleWeightResult.Weight Property

ScaleWeightResultWeight Property

Weight in kilograms.

Namespace: Resto.Front.Api.Data.Device.Results
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Weight { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ScaleWeightResult Class
Resto.Front.Api.Data.Device.Results Namespace


ScaleWeightResult Methods

The ScaleWeightResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScaleWeightResult Class
Resto.Front.Api.Data.Device.Results Namespace


Resto.Front.Api.Data.Device.Settings Namespace

Classes
 | Class | Description
Public class | CashRegisterDriverParameters | Cash register driver parameters.
Public class | CashRegisterSettings | Cash register settings.
Public class | DeviceBooleanSetting | Device boolean setting.
Public class | DeviceCustomEnumSetting | Device enum setting.
Public class | DeviceCustomEnumSettingValue | Device enum setting value.
Public class | DeviceNumberSetting | Device number setting.
Public class | DeviceSetting | Device custom setting.
Public class | DeviceSettings | Settings for device. It's universal for any device model.
Public class | DeviceStringSetting | Device string setting.
Public class | FiscalRegisterPaymentType | Fiscal register payment item
Public class | InternalCustomerDisplaySettings |
Enumerations
 | Enumeration | Description
Public enumeration | DeviceNumberSettingKind | Device number setting kind.


CashRegisterDriverParameters Class

Cash register driver parameters.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsCashRegisterDriverParameters

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterDriverParameters

The CashRegisterDriverParameters type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterDriverParameters | Main constructor
Top
Properties
 | Name | Description
Public property | CanPrintBarcode | Can print barcode.
Public property | CanPrintLogo | Can print logo.
Public property | CanPrintQRCode | Can print QR code.
Public property | CanPrintText | Can print text.
Public property | CanUseFontSizes | Can use font sizes.
Public property | Font0Width | How many characters can contain one line of cheque tape with font0.
Public property | Font1Width | How many characters can contain one line of cheque tape with font1.
Public property | Font2Width | How many characters can contain one line of cheque tape with font2.
Public property | IsBillTaskSupported | Is bill (precheque) printing supported?
Public property | IsCancellationSupported | Is cancellation supported?
Public property | IsRegisterStatusSupported | Whether the result of the execution GetCashRegisterStatus(IReadOnlyCollectionCashRegisterStatusField) is shown in the iikoFront tray
Public property | NeedToCheckBillNumber | Is need to check the bill (precheque) number before paying for an order?
Public property | PrintNonFiscalPrepayCheque | Whether to print a non-fiscal prepay / prepay return receipt.
Public property | SupportsPayInAfterSessionClose | Can pay in after close.
Public property | ZeroCashOnClose | Zero cash on close.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterDriverParameters()
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters Properties

The CashRegisterDriverParameters type exposes the following members.

Properties
 | Name | Description
Public property | CanPrintBarcode | Can print barcode.
Public property | CanPrintLogo | Can print logo.
Public property | CanPrintQRCode | Can print QR code.
Public property | CanPrintText | Can print text.
Public property | CanUseFontSizes | Can use font sizes.
Public property | Font0Width | How many characters can contain one line of cheque tape with font0.
Public property | Font1Width | How many characters can contain one line of cheque tape with font1.
Public property | Font2Width | How many characters can contain one line of cheque tape with font2.
Public property | IsBillTaskSupported | Is bill (precheque) printing supported?
Public property | IsCancellationSupported | Is cancellation supported?
Public property | IsRegisterStatusSupported | Whether the result of the execution GetCashRegisterStatus(IReadOnlyCollectionCashRegisterStatusField) is shown in the iikoFront tray
Public property | NeedToCheckBillNumber | Is need to check the bill (precheque) number before paying for an order?
Public property | PrintNonFiscalPrepayCheque | Whether to print a non-fiscal prepay / prepay return receipt.
Public property | SupportsPayInAfterSessionClose | Can pay in after close.
Public property | ZeroCashOnClose | Zero cash on close.
Top
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.CanPrintBarcode Property

CashRegisterDriverParametersCanPrintBarcode Property

Can print barcode.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CanPrintBarcode { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.CanPrintLogo Property

CashRegisterDriverParametersCanPrintLogo Property

Can print logo.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CanPrintLogo { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.CanPrintQRCode Property

CashRegisterDriverParametersCanPrintQRCode Property

Can print QR code.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CanPrintQRCode { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.CanPrintText Property

CashRegisterDriverParametersCanPrintText Property

Can print text.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CanPrintText { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.CanUseFontSizes Property

CashRegisterDriverParametersCanUseFontSizes Property

Can use font sizes.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool CanUseFontSizes { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.Font0Width Property

CashRegisterDriverParametersFont0Width Property

How many characters can contain one line of cheque tape with font0.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Font0Width { get; set; }

Property Value

Type: Int32
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.Font1Width Property

CashRegisterDriverParametersFont1Width Property

How many characters can contain one line of cheque tape with font1.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Font1Width { get; set; }

Property Value

Type: Int32
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.Font2Width Property

CashRegisterDriverParametersFont2Width Property

How many characters can contain one line of cheque tape with font2.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Font2Width { get; set; }

Property Value

Type: Int32
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.IsBillTaskSupported Property

CashRegisterDriverParametersIsBillTaskSupported Property

Is bill (precheque) printing supported?

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsBillTaskSupported { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.IsCancellationSupported Property

CashRegisterDriverParametersIsCancellationSupported Property

Is cancellation supported?

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsCancellationSupported { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.IsRegisterStatusSupported Property

CashRegisterDriverParametersIsRegisterStatusSupported Property

Whether the result of the execution GetCashRegisterStatus(IReadOnlyCollectionCashRegisterStatusField) is shown in the iikoFront tray

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsRegisterStatusSupported { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.NeedToCheckBillNumber Property

CashRegisterDriverParametersNeedToCheckBillNumber Property

Is need to check the bill (precheque) number before paying for an order?

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool NeedToCheckBillNumber { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.PrintNonFiscalPrepayCheque Property

CashRegisterDriverParametersPrintNonFiscalPrepayCheque Property

Whether to print a non-fiscal prepay / prepay return receipt.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool PrintNonFiscalPrepayCheque { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.SupportsPayInAfterSessionClose Property

CashRegisterDriverParametersSupportsPayInAfterSessionClose Property

Can pay in after close.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool SupportsPayInAfterSessionClose { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters.ZeroCashOnClose Property

CashRegisterDriverParametersZeroCashOnClose Property

Zero cash on close.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool ZeroCashOnClose { get; set; }

Property Value

Type: Boolean
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterDriverParameters Methods

The CashRegisterDriverParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterDriverParameters Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings Class

Cash register settings.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSettings
Resto.Front.Api.Data.Device.SettingsCashRegisterSettings

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterSettings : DeviceSettings

The CashRegisterSettings type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterSettings | Main constructor
Top
Properties
 | Name | Description
Public property | Autorun | Autorun device. (Inherited from DeviceSettings.)
Public property | Code | Code. (Inherited from DeviceSettings.)
Public property | CustomerDisplaySettings | (Inherited from DeviceSettings.)
Public property | DeviceId | Device id. (Inherited from DeviceSettings.)
Public property | FiscalRegisterPaymentTypes | List of payment items.
Public property | FiscalRegisterTaxItems | List of tax items.
Public property | Font0Width | Count of char in a check line with the main font f0.
Public property | FriendlyName | Friendly name for UI. (Inherited from DeviceSettings.)
Public property | OfdProtocolVersion | Version of fiscal data format.
Public property | Settings | Device settings list. The device has the ability to define the set and behavior of its settings. Setting uniquely identified by name. (Inherited from DeviceSettings.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterSettings()
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings Properties

The CashRegisterSettings type exposes the following members.

Properties
 | Name | Description
Public property | Autorun | Autorun device. (Inherited from DeviceSettings.)
Public property | Code | Code. (Inherited from DeviceSettings.)
Public property | CustomerDisplaySettings | (Inherited from DeviceSettings.)
Public property | DeviceId | Device id. (Inherited from DeviceSettings.)
Public property | FiscalRegisterPaymentTypes | List of payment items.
Public property | FiscalRegisterTaxItems | List of tax items.
Public property | Font0Width | Count of char in a check line with the main font f0.
Public property | FriendlyName | Friendly name for UI. (Inherited from DeviceSettings.)
Public property | OfdProtocolVersion | Version of fiscal data format.
Public property | Settings | Device settings list. The device has the ability to define the set and behavior of its settings. Setting uniquely identified by name. (Inherited from DeviceSettings.)
Top
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings.FiscalRegisterPaymentTypes Property

CashRegisterSettingsFiscalRegisterPaymentTypes Property

List of payment items.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<FiscalRegisterPaymentType> FiscalRegisterPaymentTypes { get; set; }

Property Value

Type: List FiscalRegisterPaymentType
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings.FiscalRegisterTaxItems Property

CashRegisterSettingsFiscalRegisterTaxItems Property

List of tax items.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<FiscalRegisterTaxItem> FiscalRegisterTaxItems { get; set; }

Property Value

Type: List FiscalRegisterTaxItem
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings.Font0Width Property

CashRegisterSettingsFont0Width Property

Count of char in a check line with the main font f0.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNumberSetting Font0Width { get; set; }

Property Value

Type: DeviceNumberSetting
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings.OfdProtocolVersion Property

CashRegisterSettingsOfdProtocolVersion Property

Version of fiscal data format.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceCustomEnumSetting OfdProtocolVersion { get; set; }

Property Value

Type: DeviceCustomEnumSetting
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


CashRegisterSettings Methods

The CashRegisterSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Class

Device boolean setting.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSetting
Resto.Front.Api.Data.Device.SettingsDeviceBooleanSetting

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceBooleanSetting : DeviceSetting

The DeviceBooleanSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceBooleanSetting | Default constructor
Public method | DeviceBooleanSetting(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Value | Boolean setting value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Constructor

Overload List
 | Name | Description
Public method | DeviceBooleanSetting | Default constructor
Public method | DeviceBooleanSetting(String, String) | Main constructor
Top
See Also

Reference

DeviceBooleanSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceBooleanSetting()
See Also

Reference

DeviceBooleanSetting Class
DeviceBooleanSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceBooleanSetting(
    string name,
    string label
)

Parameters

name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceBooleanSetting Class
DeviceBooleanSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Properties

The DeviceBooleanSetting type exposes the following members.

Properties
 | Name | Description
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Value | Boolean setting value.
Top
See Also

Reference

DeviceBooleanSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting.Value Property

DeviceBooleanSettingValue Property

Boolean setting value.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Value { get; set; }

Property Value

Type: Boolean
See Also

Reference

DeviceBooleanSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceBooleanSetting Methods

The DeviceBooleanSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceBooleanSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Class

Device enum setting.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSetting
Resto.Front.Api.Data.Device.SettingsDeviceCustomEnumSetting

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceCustomEnumSetting : DeviceSetting

The DeviceCustomEnumSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceCustomEnumSetting | Default constructor
Public method | DeviceCustomEnumSetting(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | IsList | If true then values will be represented in BackOffice as ComboBox, otherwise as RadioButton group.
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Values | Enum values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Constructor

Overload List
 | Name | Description
Public method | DeviceCustomEnumSetting | Default constructor
Public method | DeviceCustomEnumSetting(String, String) | Main constructor
Top
See Also

Reference

DeviceCustomEnumSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceCustomEnumSetting()
See Also

Reference

DeviceCustomEnumSetting Class
DeviceCustomEnumSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceCustomEnumSetting(
    string name,
    string label
)

Parameters

name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceCustomEnumSetting Class
DeviceCustomEnumSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Properties

The DeviceCustomEnumSetting type exposes the following members.

Properties
 | Name | Description
Public property | IsList | If true then values will be represented in BackOffice as ComboBox, otherwise as RadioButton group.
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Values | Enum values.
Top
See Also

Reference

DeviceCustomEnumSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting.IsList Property

DeviceCustomEnumSettingIsList Property

If true then values will be represented in BackOffice as ComboBox, otherwise as RadioButton group.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsList { get; set; }

Property Value

Type: Boolean
See Also

Reference

DeviceCustomEnumSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting.Values Property

DeviceCustomEnumSettingValues Property

Enum values.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<DeviceCustomEnumSettingValue> Values { get; set; }

Property Value

Type: List DeviceCustomEnumSettingValue
See Also

Reference

DeviceCustomEnumSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSetting Methods

The DeviceCustomEnumSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceCustomEnumSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Class

Device enum setting value.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceCustomEnumSettingValue

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceCustomEnumSettingValue

The DeviceCustomEnumSettingValue type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceCustomEnumSettingValue | Default constructor
Public method | DeviceCustomEnumSettingValue(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | IsDefault | Is default value?
Public property | Label | Label to display.
Public property | Name | Name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Constructor

Overload List
 | Name | Description
Public method | DeviceCustomEnumSettingValue | Default constructor
Public method | DeviceCustomEnumSettingValue(String, String) | Main constructor
Top
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceCustomEnumSettingValue()
See Also

Reference

DeviceCustomEnumSettingValue Class
DeviceCustomEnumSettingValue Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceCustomEnumSettingValue(
    string name,
    string label
)

Parameters

name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceCustomEnumSettingValue Class
DeviceCustomEnumSettingValue Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Properties

The DeviceCustomEnumSettingValue type exposes the following members.

Properties
 | Name | Description
Public property | IsDefault | Is default value?
Public property | Label | Label to display.
Public property | Name | Name.
Top
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue.IsDefault Property

DeviceCustomEnumSettingValueIsDefault Property

Is default value?

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsDefault { get; set; }

Property Value

Type: Boolean
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue.Label Property

DeviceCustomEnumSettingValueLabel Property

Label to display.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Label { get; set; }

Property Value

Type: String
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue.Name Property

DeviceCustomEnumSettingValueName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceCustomEnumSettingValue Methods

The DeviceCustomEnumSettingValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceCustomEnumSettingValue Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Class

Device number setting.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSetting
Resto.Front.Api.Data.Device.SettingsDeviceNumberSetting

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceNumberSetting : DeviceSetting

The DeviceNumberSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceNumberSetting | Default constructor
Public method | DeviceNumberSetting(NullableDecimal, NullableDecimal, NullableDecimal, DeviceNumberSettingKind, String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | MaxValue | Maximum number value.
Public property | MinValue | Minimal number value.
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | SettingKind | Type of setting.
Public property | Value | Number value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Constructor

Overload List
 | Name | Description
Public method | DeviceNumberSetting | Default constructor
Public method | DeviceNumberSetting(NullableDecimal, NullableDecimal, NullableDecimal, DeviceNumberSettingKind, String, String) | Main constructor
Top
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNumberSetting()
See Also

Reference

DeviceNumberSetting Class
DeviceNumberSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Constructor (Nullable(Decimal), Nullable(Decimal), Nullable(Decimal), DeviceNumberSettingKind, String, String)

DeviceNumberSetting Constructor (NullableDecimal, NullableDecimal, NullableDecimal, DeviceNumberSettingKind, String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNumberSetting(
    decimal? minValue,
    decimal? maxValue,
    decimal? value,
    DeviceNumberSettingKind settingKind,
    string name,
    string label
)

Parameters

minValue
Type: SystemNullable Decimal
maxValue
Type: SystemNullable Decimal
value
Type: SystemNullable Decimal
settingKind
Type: Resto.Front.Api.Data.Device.SettingsDeviceNumberSettingKind
name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceNumberSetting Class
DeviceNumberSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Properties

The DeviceNumberSetting type exposes the following members.

Properties
 | Name | Description
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | MaxValue | Maximum number value.
Public property | MinValue | Minimal number value.
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | SettingKind | Type of setting.
Public property | Value | Number value.
Top
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting.MaxValue Property

DeviceNumberSettingMaxValue Property

Maximum number value.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? MaxValue { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting.MinValue Property

DeviceNumberSettingMinValue Property

Minimal number value.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? MinValue { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting.SettingKind Property

DeviceNumberSettingSettingKind Property

Type of setting.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNumberSettingKind SettingKind { get; set; }

Property Value

Type: DeviceNumberSettingKind
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting.Value Property

DeviceNumberSettingValue Property

Number value.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Value { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSetting Methods

The DeviceNumberSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceNumberSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceNumberSettingKind Enumeration

Device number setting kind.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum DeviceNumberSettingKind
Members
Member name | Value | Description
Integer | 0 | Integer number.
Decimal | 1 | Decimal floating point number.
Amount | 2 | Amount of something (generates control with up/down arrows).
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Class

Device custom setting.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSetting
Resto.Front.Api.Data.Device.SettingsDeviceBooleanSetting
Resto.Front.Api.Data.Device.SettingsDeviceCustomEnumSetting
Resto.Front.Api.Data.Device.SettingsDeviceNumberSetting
Resto.Front.Api.Data.Device.SettingsDeviceStringSetting

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public abstract class DeviceSetting

The DeviceSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceSetting | Default constructor
Public method | DeviceSetting(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | Label | Label to display in UI.
Public property | Name | Name should be unique.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Constructor

Overload List
 | Name | Description
Public method | DeviceSetting | Default constructor
Public method | DeviceSetting(String, String) | Main constructor
Top
See Also

Reference

DeviceSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceSetting()
See Also

Reference

DeviceSetting Class
DeviceSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceSetting(
    string name,
    string label
)

Parameters

name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceSetting Class
DeviceSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Properties

The DeviceSetting type exposes the following members.

Properties
 | Name | Description
Public property | Label | Label to display in UI.
Public property | Name | Name should be unique.
Top
See Also

Reference

DeviceSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting.Label Property

DeviceSettingLabel Property

Label to display in UI.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Label { get; set; }

Property Value

Type: String
See Also

Reference

DeviceSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting.Name Property

DeviceSettingName Property

Name should be unique.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

DeviceSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSetting Methods

The DeviceSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings Class

Settings for device. It's universal for any device model.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSettings
Resto.Front.Api.Data.Device.SettingsCashRegisterSettings

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceSettings

The DeviceSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceSettings | Main constructor
Top
Properties
 | Name | Description
Public property | Autorun | Autorun device.
Public property | Code | Code.
Public property | CustomerDisplaySettings |
Public property | DeviceId | Device id.
Public property | FriendlyName | Friendly name for UI.
Public property | Settings | Device settings list. The device has the ability to define the set and behavior of its settings. Setting uniquely identified by name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceSettings()
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings Properties

The DeviceSettings type exposes the following members.

Properties
 | Name | Description
Public property | Autorun | Autorun device.
Public property | Code | Code.
Public property | CustomerDisplaySettings |
Public property | DeviceId | Device id.
Public property | FriendlyName | Friendly name for UI.
Public property | Settings | Device settings list. The device has the ability to define the set and behavior of its settings. Setting uniquely identified by name.
Top
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.Autorun Property

DeviceSettingsAutorun Property

Autorun device.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Autorun { get; set; }

Property Value

Type: Boolean
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.Code Property

DeviceSettingsCode Property

Code.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Code { get; set; }

Property Value

Type: String
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.CustomerDisplaySettings Property

DeviceSettingsCustomerDisplaySettings Property

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InternalCustomerDisplaySettings CustomerDisplaySettings { get; set; }

Property Value

Type: InternalCustomerDisplaySettings
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.DeviceId Property

DeviceSettingsDeviceId Property

Device id.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? DeviceId { get; set; }

Property Value

Type: Nullable Guid
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.FriendlyName Property

DeviceSettingsFriendlyName Property

Friendly name for UI.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string FriendlyName { get; set; }

Property Value

Type: String
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings.Settings Property

DeviceSettingsSettings Property

Device settings list. The device has the ability to define the set and behavior of its settings. Setting uniquely identified by name.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<DeviceSetting> Settings { get; set; }

Property Value

Type: List DeviceSetting
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceSettings Methods

The DeviceSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceSettings Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Class

Device string setting.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsDeviceSetting
Resto.Front.Api.Data.Device.SettingsDeviceStringSetting

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceStringSetting : DeviceSetting

The DeviceStringSetting type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceStringSetting | Default constructor
Public method | DeviceStringSetting(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | AllowedValues | Alowed string values.
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | MaxLength | Maximum string length.
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Value | String value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Constructor

Overload List
 | Name | Description
Public method | DeviceStringSetting | Default constructor
Public method | DeviceStringSetting(String, String) | Main constructor
Top
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceStringSetting()
See Also

Reference

DeviceStringSetting Class
DeviceStringSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceStringSetting(
    string name,
    string label
)

Parameters

name
Type: SystemString
label
Type: SystemString
See Also

Reference

DeviceStringSetting Class
DeviceStringSetting Overload
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Properties

The DeviceStringSetting type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValues | Alowed string values.
Public property | Label | Label to display in UI. (Inherited from DeviceSetting.)
Public property | MaxLength | Maximum string length.
Public property | Name | Name should be unique. (Inherited from DeviceSetting.)
Public property | Value | String value.
Top
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting.AllowedValues Property

DeviceStringSettingAllowedValues Property

Alowed string values.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<string> AllowedValues { get; set; }

Property Value

Type: List String
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting.MaxLength Property

DeviceStringSettingMaxLength Property

Maximum string length.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int MaxLength { get; set; }

Property Value

Type: Int32
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting.Value Property

DeviceStringSettingValue Property

String value.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Value { get; set; }

Property Value

Type: String
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


DeviceStringSetting Methods

The DeviceStringSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeviceStringSetting Class
Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType Class

Fiscal register payment item
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsFiscalRegisterPaymentType

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class FiscalRegisterPaymentType

The FiscalRegisterPaymentType type exposes the following members.

Constructors
 | Name | Description
Public method | FiscalRegisterPaymentType | Main constructor
Top
Properties
 | Name | Description
Public property | Id | Payment type id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).
Public property | Name | Payment type name to display.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public FiscalRegisterPaymentType()
See Also

Reference

FiscalRegisterPaymentType Class
Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType Properties

The FiscalRegisterPaymentType type exposes the following members.

Properties
 | Name | Description
Public property | Id | Payment type id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).
Public property | Name | Payment type name to display.
Top
See Also

Reference

FiscalRegisterPaymentType Class
Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType.Id Property

FiscalRegisterPaymentTypeId Property

Payment type id in fiscal register (for ex. 0, 1, 2, A, B, C, etc..).

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Id { get; set; }

Property Value

Type: String
See Also

Reference

FiscalRegisterPaymentType Class
Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType.Name Property

FiscalRegisterPaymentTypeName Property

Payment type name to display.

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

FiscalRegisterPaymentType Class
Resto.Front.Api.Data.Device.Settings Namespace


FiscalRegisterPaymentType Methods

The FiscalRegisterPaymentType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FiscalRegisterPaymentType Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.SettingsInternalCustomerDisplaySettings

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class InternalCustomerDisplaySettings

The InternalCustomerDisplaySettings type exposes the following members.

Constructors
 | Name | Description
Public method | InternalCustomerDisplaySettings | Default constructor
Public method | InternalCustomerDisplaySettings(Boolean, String, Int32, Int32) | Main constructor
Top
Properties
 | Name | Description
Public property | Chars |
Public property | IdleText |
Public property | IsEnabled |
Public property | Rows |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Constructor

Overload List
 | Name | Description
Public method | InternalCustomerDisplaySettings | Default constructor
Public method | InternalCustomerDisplaySettings(Boolean, String, Int32, Int32) | Main constructor
Top
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InternalCustomerDisplaySettings()
See Also

Reference

InternalCustomerDisplaySettings Class
InternalCustomerDisplaySettings Overload
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Constructor (Boolean, String, Int32, Int32)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InternalCustomerDisplaySettings(
    bool isEnabled,
    string idleText,
    int chars,
    int rows
)

Parameters

isEnabled
Type: SystemBoolean
idleText
Type: SystemString
chars
Type: SystemInt32
rows
Type: SystemInt32
See Also

Reference

InternalCustomerDisplaySettings Class
InternalCustomerDisplaySettings Overload
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Properties

The InternalCustomerDisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | Chars |
Public property | IdleText |
Public property | IsEnabled |
Public property | Rows |
Top
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings.Chars Property

InternalCustomerDisplaySettingsChars Property

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Chars { get; set; }

Property Value

Type: Int32
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings.IdleText Property

InternalCustomerDisplaySettingsIdleText Property

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string IdleText { get; set; }

Property Value

Type: String
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings.IsEnabled Property

InternalCustomerDisplaySettingsIsEnabled Property

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsEnabled { get; set; }

Property Value

Type: Boolean
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings.Rows Property

InternalCustomerDisplaySettingsRows Property

Namespace: Resto.Front.Api.Data.Device.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Rows { get; set; }

Property Value

Type: Int32
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


InternalCustomerDisplaySettings Methods

The InternalCustomerDisplaySettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InternalCustomerDisplaySettings Class
Resto.Front.Api.Data.Device.Settings Namespace


Resto.Front.Api.Data.Device.Tasks Namespace

Classes
 | Class | Description
Public class | BillTask | Bill task.
Public class | CashRegisterTask | Cash register task.
Public class | ChequePayment | Cheque payment.
Public class | ChequeSale | Cheque sale
Public class | ChequeTask | Task to perform sale or refund operations.
Public class | ChequeTaskDiscountIncreaseItem | Cheque task discount increase item.
Public class | CommandExecute | Command execute.
Public class | Contractor | Contractor.
Public class | CorrectionTask | Correction task.
Public class | CustomerDisplayTextTask | Task to display custom text to customer.
Public class | ParameterExecute | Parameter execute.
Public class | RequiredParameter | Arbitrary operation parameter.
Public class | SupportedCommand | Supported command.
Enumerations
 | Enumeration | Description
Public enumeration | CashRegisterStatusField | Cash register status field.
Public enumeration | ChequeTransferType | Item category attribute.
Public enumeration | CorrectionDocumentType | Correction document type.
Public enumeration | CorrectionReasonEnum | Correction reason.
Public enumeration | TaxationSystem | Taxation system.


BillTask Class

Bill task.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCashRegisterTask
Resto.Front.Api.Data.Device.TasksBillTask
Resto.Front.Api.Data.Device.TasksChequeTask

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class BillTask : CashRegisterTask

The BillTask type exposes the following members.

Constructors
 | Name | Description
Public method | BillTask | Main constructor
Top
Properties
 | Name | Description
Public property | CancellingSaleNumber | The order number that will be canceled if cheque is refund.
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | DiscountPercent | Discount for subtotal in percent.
Public property | DiscountSum | Discount for subtotal.
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | IncreasePercent | Increase for subtotal in percent.
Public property | IncreaseSum | Increase for subtotal.
Public property | IsCancellation | Belarus/Latvia localization specific option. The cashier can choose either cancellation or refund depending on the actual situation. Only the entire check can be cancelled.
Public property | IsRefund | Indicates whether the cheque is refund (Storno in Resto).
Public property | OrderId | Order id for bill/payment/return operations.
Public property | OrderNumber | Order number.
Public property | PrintArticle | Print product article.
Public property | PrintVat | Print VAT.
Public property | ResultSum | The resulting sum.
Public property | Sales | Sales.
Public property | TableNumber | Table number.
Public property | TableNumberLocalized | Order number and table number localized string.
Public property | TextAfterCheque | Text to print at the beginning of a document.
Public property | TextBeforeCheque | Text to print at the end of a document.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


BillTask Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public BillTask(
    bool isRefund,
    bool isCancellation,
    List<ChequeSale> sales,
    int cancellingSaleNumber,
    decimal? discountPercent,
    decimal? increasePercent,
    decimal resultSum,
    decimal? discountSum,
    decimal? increaseSum,
    string tableNumberLocalized,
    Guid orderId,
    int orderNumber,
    int tableNumber,
    bool printVat,
    bool printArticle,
    string textAfterCheque,
    string textBeforeCheque,
    Guid? id,
    string cashierName,
    Guid cashierId,
    string cashierTaxpayerId
)

Parameters

isRefund
Type: SystemBoolean
isCancellation
Type: SystemBoolean
sales
Type: System.Collections.GenericList ChequeSale
cancellingSaleNumber
Type: SystemInt32
discountPercent
Type: SystemNullable Decimal
increasePercent
Type: SystemNullable Decimal
resultSum
Type: SystemDecimal
discountSum
Type: SystemNullable Decimal
increaseSum
Type: SystemNullable Decimal
tableNumberLocalized
Type: SystemString
orderId
Type: SystemGuid
orderNumber
Type: SystemInt32
tableNumber
Type: SystemInt32
printVat
Type: SystemBoolean
printArticle
Type: SystemBoolean
textAfterCheque
Type: SystemString
textBeforeCheque
Type: SystemString
id
Type: SystemNullable Guid
cashierName
Type: SystemString
cashierId
Type: SystemGuid
cashierTaxpayerId
Type: SystemString
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask Properties

The BillTask type exposes the following members.

Properties
 | Name | Description
Public property | CancellingSaleNumber | The order number that will be canceled if cheque is refund.
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | DiscountPercent | Discount for subtotal in percent.
Public property | DiscountSum | Discount for subtotal.
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | IncreasePercent | Increase for subtotal in percent.
Public property | IncreaseSum | Increase for subtotal.
Public property | IsCancellation | Belarus/Latvia localization specific option. The cashier can choose either cancellation or refund depending on the actual situation. Only the entire check can be cancelled.
Public property | IsRefund | Indicates whether the cheque is refund (Storno in Resto).
Public property | OrderId | Order id for bill/payment/return operations.
Public property | OrderNumber | Order number.
Public property | PrintArticle | Print product article.
Public property | PrintVat | Print VAT.
Public property | ResultSum | The resulting sum.
Public property | Sales | Sales.
Public property | TableNumber | Table number.
Public property | TableNumberLocalized | Order number and table number localized string.
Public property | TextAfterCheque | Text to print at the beginning of a document.
Public property | TextBeforeCheque | Text to print at the end of a document.
Top
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.CancellingSaleNumber Property

BillTaskCancellingSaleNumber Property

The order number that will be canceled if cheque is refund.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int CancellingSaleNumber { get; set; }

Property Value

Type: Int32
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.DiscountPercent Property

BillTaskDiscountPercent Property

Discount for subtotal in percent.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? DiscountPercent { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.DiscountSum Property

BillTaskDiscountSum Property

Discount for subtotal.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? DiscountSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.IncreasePercent Property

BillTaskIncreasePercent Property

Increase for subtotal in percent.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? IncreasePercent { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.IncreaseSum Property

BillTaskIncreaseSum Property

Increase for subtotal.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? IncreaseSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.IsCancellation Property

BillTaskIsCancellation Property

Belarus/Latvia localization specific option. The cashier can choose either cancellation or refund depending on the actual situation. Only the entire check can be cancelled.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsCancellation { get; set; }

Property Value

Type: Boolean
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.IsRefund Property

BillTaskIsRefund Property

Indicates whether the cheque is refund (Storno in Resto).

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsRefund { get; set; }

Property Value

Type: Boolean
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.OrderId Property

BillTaskOrderId Property

Order id for bill/payment/return operations.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid OrderId { get; set; }

Property Value

Type: Guid
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.OrderNumber Property

BillTaskOrderNumber Property

Order number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int OrderNumber { get; set; }

Property Value

Type: Int32
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.PrintArticle Property

BillTaskPrintArticle Property

Print product article.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool PrintArticle { get; set; }

Property Value

Type: Boolean
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.PrintVat Property

BillTaskPrintVat Property

Print VAT.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool PrintVat { get; set; }

Property Value

Type: Boolean
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.ResultSum Property

BillTaskResultSum Property

The resulting sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal ResultSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.Sales Property

BillTaskSales Property

Sales.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<ChequeSale> Sales { get; set; }

Property Value

Type: List ChequeSale
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.TableNumber Property

BillTaskTableNumber Property

Table number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int TableNumber { get; set; }

Property Value

Type: Int32
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.TableNumberLocalized Property

BillTaskTableNumberLocalized Property

Order number and table number localized string.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TableNumberLocalized { get; set; }

Property Value

Type: String
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.TextAfterCheque Property

BillTaskTextAfterCheque Property

Text to print at the beginning of a document.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TextAfterCheque { get; set; }

Property Value

Type: String
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask.TextBeforeCheque Property

BillTaskTextBeforeCheque Property

Text to print at the end of a document.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TextBeforeCheque { get; set; }

Property Value

Type: String
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


BillTask Methods

The BillTask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BillTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterStatusField Enumeration

Cash register status field.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum CashRegisterStatusField
Members
Member name | Value | Description
ErrorCode | 0 | Error code.
RegisterDateTime | 1 | Register date and time.
IsOfdConnected | 2 | Is Ofd connected?
SessionStatus | 3 | Session status.
RestaurantMode | 4 | Restaurant mode.
OfflineMode | 5 | Offline mode.
FiscalStorage | 6 | Fiscal storage.
ExtendedStatus | 7 | Extended status.
OfdResponseCode | 8 | Ofd response code.
FnResponseCode | 9 | Fiscal storage response code.
OfdBufferedDocuments | 10 | Ofd buffered documents.
OfdDocumentNumber | 11 | Number of the Ofd document.
OfdUrl | 12 | Url of Ofd site.
OfdOrgName | 13 | Name of Ofd organization.
OfdSalesAddress | 14 | Sales address of the Ofd.
OfdKkmRegistrationNumber | 15 | Number of ofd Kkm registration.
OfdChequeDateTime | 16 | Datetime of Ofd cheque.
OfdChequeSum | 17 | Sum of Ofd cheque.
OfdTaxpayerIdNumber | 18 | Id number of Ofd taxpayer.
StatusBarInfo | 19 | Info to be shown in the iikoFront status bar.
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask Class

Cash register task.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCashRegisterTask
Resto.Front.Api.Data.Device.TasksBillTask
Resto.Front.Api.Data.Device.TasksCorrectionTask

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CashRegisterTask

The CashRegisterTask type exposes the following members.

Constructors
 | Name | Description
Public method | CashRegisterTask | Main constructor
Top
Properties
 | Name | Description
Public property | CashierId | Cashier Id.
Public property | CashierName | Cashier name.
Public property | CashierTaxpayerId | Taxpayer Id of the cashier.
Public property | Id | The task id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CashRegisterTask(
    Guid? id,
    string cashierName,
    Guid cashierId,
    string cashierTaxpayerId
)

Parameters

id
Type: SystemNullable Guid
cashierName
Type: SystemString
cashierId
Type: SystemGuid
cashierTaxpayerId
Type: SystemString
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask Properties

The CashRegisterTask type exposes the following members.

Properties
 | Name | Description
Public property | CashierId | Cashier Id.
Public property | CashierName | Cashier name.
Public property | CashierTaxpayerId | Taxpayer Id of the cashier.
Public property | Id | The task id.
Top
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask.CashierId Property

CashRegisterTaskCashierId Property

Cashier Id.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CashierId { get; set; }

Property Value

Type: Guid
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask.CashierName Property

CashRegisterTaskCashierName Property

Cashier name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CashierName { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask.CashierTaxpayerId Property

CashRegisterTaskCashierTaxpayerId Property

Taxpayer Id of the cashier.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CashierTaxpayerId { get; set; }

Property Value

Type: String
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask.Id Property

CashRegisterTaskId Property

The task id.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? Id { get; set; }

Property Value

Type: Nullable Guid
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CashRegisterTask Methods

The CashRegisterTask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CashRegisterTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment Class

Cheque payment.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksChequePayment

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ChequePayment

The ChequePayment type exposes the following members.

Constructors
 | Name | Description
Public method | ChequePayment | Main constructor
Top
Properties
 | Name | Description
Public property | Comment | Comment.
Public property | IsDefaultNonCash | It is true, if the register 'PaymentRegisterId' is the default register.
Public property | Name | Name.
Public property | PaymentRegisterId | Register identifier of cash register.
Public property | Sum | Sum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequePayment(
    string name,
    decimal sum,
    string paymentRegisterId,
    bool isDefaultNonCash,
    string comment
)

Parameters

name
Type: SystemString
sum
Type: SystemDecimal
paymentRegisterId
Type: SystemString
isDefaultNonCash
Type: SystemBoolean
comment
Type: SystemString
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment Properties

The ChequePayment type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Comment.
Public property | IsDefaultNonCash | It is true, if the register 'PaymentRegisterId' is the default register.
Public property | Name | Name.
Public property | PaymentRegisterId | Register identifier of cash register.
Public property | Sum | Sum.
Top
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment.Comment Property

ChequePaymentComment Property

Comment.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

Type: String
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment.IsDefaultNonCash Property

ChequePaymentIsDefaultNonCash Property

It is true, if the register 'PaymentRegisterId' is the default register.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsDefaultNonCash { get; set; }

Property Value

Type: Boolean
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment.Name Property

ChequePaymentName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment.PaymentRegisterId Property

ChequePaymentPaymentRegisterId Property

Register identifier of cash register.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PaymentRegisterId { get; set; }

Property Value

Type: String
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment.Sum Property

ChequePaymentSum Property

Sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Sum { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequePayment Methods

The ChequePayment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChequePayment Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale Class

Cheque sale
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksChequeSale

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ChequeSale

The ChequeSale type exposes the following members.

Constructors
 | Name | Description
Public method | ChequeSale | Main constructor
Top
Properties
 | Name | Description
Public property | Amount | Amount.
Public property | Code | Nomenclature article of product.
Public property | Comment | Cheque sale items comment string.
Public property | CommodityCode | Commodity code.
Public property | CommodityMark | Commodity mark.
Public property | Contractor | Contractor (user).
Public property | Discount | Discount.
Public property | DiscountSum | Discount sum.
Public property | GtinCode | 14-digit Global Trade Item Number.
Public property | GuestName | The name of the guest.
Public property | Increase | Increase.
Public property | IncreaseSum | Increase sum.
Public property | IsTaxable | Is taxable?
Public property | ItemCategory | Item category code attribute.
Public property | Name | Product name.
Public property | Price | Price.
Public property | ProductId |
Public property | Section | Product section.
Public property | Sum | Position cost, including all discounts and increases.
Public property | TaricCode | TARIC code - Integrated Tariff of the European Communities.
Public property | TaxId | Tax identifier.
Public property | TransferType | Transfer type attribute.
Public property | Vat | Tax rate in percent. Only if IsTaxable is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequeSale(
    string name,
    string code,
    decimal? price,
    decimal? amount,
    string guestName,
    int section,
    decimal? vat,
    decimal? discountSum,
    decimal? increaseSum,
    decimal? sum,
    string taxId
)

Parameters

name
Type: SystemString
code
Type: SystemString
price
Type: SystemNullable Decimal
amount
Type: SystemNullable Decimal
guestName
Type: SystemString
section
Type: SystemInt32
vat
Type: SystemNullable Decimal
discountSum
Type: SystemNullable Decimal
increaseSum
Type: SystemNullable Decimal
sum
Type: SystemNullable Decimal
taxId
Type: SystemString
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale Properties

The ChequeSale type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Amount.
Public property | Code | Nomenclature article of product.
Public property | Comment | Cheque sale items comment string.
Public property | CommodityCode | Commodity code.
Public property | CommodityMark | Commodity mark.
Public property | Contractor | Contractor (user).
Public property | Discount | Discount.
Public property | DiscountSum | Discount sum.
Public property | GtinCode | 14-digit Global Trade Item Number.
Public property | GuestName | The name of the guest.
Public property | Increase | Increase.
Public property | IncreaseSum | Increase sum.
Public property | IsTaxable | Is taxable?
Public property | ItemCategory | Item category code attribute.
Public property | Name | Product name.
Public property | Price | Price.
Public property | ProductId |
Public property | Section | Product section.
Public property | Sum | Position cost, including all discounts and increases.
Public property | TaricCode | TARIC code - Integrated Tariff of the European Communities.
Public property | TaxId | Tax identifier.
Public property | TransferType | Transfer type attribute.
Public property | Vat | Tax rate in percent. Only if IsTaxable is true.
Top
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Amount Property

ChequeSaleAmount Property

Amount.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Amount { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Code Property

ChequeSaleCode Property

Nomenclature article of product.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Code { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Comment Property

ChequeSaleComment Property

Cheque sale items comment string.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.CommodityCode Property

ChequeSaleCommodityCode Property

Commodity code.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CommodityCode { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.CommodityMark Property

ChequeSaleCommodityMark Property

Commodity mark.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CommodityMark { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Contractor Property

ChequeSaleContractor Property

Contractor (user).

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Contractor Contractor { get; set; }

Property Value

Type: Contractor
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Discount Property

ChequeSaleDiscount Property

Discount.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Discount { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.DiscountSum Property

ChequeSaleDiscountSum Property

Discount sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? DiscountSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.GtinCode Property

ChequeSaleGtinCode Property

14-digit Global Trade Item Number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string GtinCode { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.GuestName Property

ChequeSaleGuestName Property

The name of the guest.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string GuestName { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Increase Property

ChequeSaleIncrease Property

Increase.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Increase { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.IncreaseSum Property

ChequeSaleIncreaseSum Property

Increase sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? IncreaseSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.IsTaxable Property

ChequeSaleIsTaxable Property

Is taxable?

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsTaxable { get; set; }

Property Value

Type: Boolean
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.ItemCategory Property

ChequeSaleItemCategory Property

Item category code attribute.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ItemCategory { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Name Property

ChequeSaleName Property

Product name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Price Property

ChequeSalePrice Property

Price.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Price { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.ProductId Property

ChequeSaleProductId Property

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ProductId { get; set; }

Property Value

Type: Guid
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Section Property

ChequeSaleSection Property

Product section.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Section { get; set; }

Property Value

Type: Int32
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Sum Property

ChequeSaleSum Property

Position cost, including all discounts and increases.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Sum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.TaricCode Property

ChequeSaleTaricCode Property

TARIC code - Integrated Tariff of the European Communities.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TaricCode { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.TaxId Property

ChequeSaleTaxId Property

Tax identifier.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TaxId { get; set; }

Property Value

Type: String
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.TransferType Property

ChequeSaleTransferType Property

Transfer type attribute.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequeTransferType TransferType { get; set; }

Property Value

Type: ChequeTransferType
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale.Vat Property

ChequeSaleVat Property

Tax rate in percent. Only if IsTaxable is true.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? Vat { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeSale Methods

The ChequeSale type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChequeSale Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask Class

Task to perform sale or refund operations.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCashRegisterTask
Resto.Front.Api.Data.Device.TasksBillTask
Resto.Front.Api.Data.Device.TasksChequeTask

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ChequeTask : BillTask

The ChequeTask type exposes the following members.

Constructors
 | Name | Description
Public method | ChequeTask | Main constructor
Top
Properties
 | Name | Description
Public property | BillNumber | Bill (precheque) number.
Public property | CancellingSaleNumber | The order number that will be canceled if cheque is refund. (Inherited from BillTask.)
Public property | CardPayments | Card payments.
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | CashPayment | Cash payment sum.
Public property | CashPayments | Cash payments.
Public property | ConsiderationSum | Consideration sum.
Public property | CreditSum | Credit sum.
Public property | CustomerName | Name of customer (person or organization).
Public property | CustomerTin | Taxpayer Identification Number of customer (person or organization).
Public property | DiscountPercent | Discount for subtotal in percent. (Inherited from BillTask.)
Public property | DiscountSum | Discount for subtotal. (Inherited from BillTask.)
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | IncreasePercent | Increase for subtotal in percent. (Inherited from BillTask.)
Public property | IncreaseSum | Increase for subtotal. (Inherited from BillTask.)
Public property | IsCancellation | Belarus/Latvia localization specific option. The cashier can choose either cancellation or refund depending on the actual situation. Only the entire check can be cancelled. (Inherited from BillTask.)
Public property | IsOfdElectronicChequeOnly | Form electronic cheque only.
Public property | IsRefund | Indicates whether the cheque is refund (Storno in Resto). (Inherited from BillTask.)
Public property | OfdEmail | Email for receipt copy of cheque.
Public property | OfdPhoneNumber | Phone number for receipt copy of cheque.
Public property | OperationTime | Operation time.
Public property | OrderId | Order id for bill/payment/return operations. (Inherited from BillTask.)
Public property | OrderNumber | Order number. (Inherited from BillTask.)
Public property | PrepaymentId | Unique prepayment identification number to return prepayment, for non prepayment is null
Public property | PrepaymentSum | Advance payment sum.
Public property | PrintArticle | Print product article. (Inherited from BillTask.)
Public property | PrintVat | Print VAT. (Inherited from BillTask.)
Public property | ResultSum | The resulting sum. (Inherited from BillTask.)
Public property | RoundSum | Rounded sum in favor of the client.
Public property | Sales | Sales. (Inherited from BillTask.)
Public property | SettlementAddress | Address of settlement.
Public property | SettlementPlace | Place of settlement.
Public property | TableNumber | Table number. (Inherited from BillTask.)
Public property | TableNumberLocalized | Order number and table number localized string. (Inherited from BillTask.)
Public property | TaxationSystem | Taxation system.
Public property | TextAfterCheque | Text to print at the beginning of a document. (Inherited from BillTask.)
Public property | TextBeforeCheque | Text to print at the end of a document. (Inherited from BillTask.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequeTask(
    decimal cashPayment,
    string settlementAddress,
    string settlementPlace,
    string customerName,
    string customerTin,
    bool isRefund,
    bool isCancellation,
    List<ChequeSale> sales,
    int cancellingSaleNumber,
    decimal? discountPercent,
    decimal? increasePercent,
    decimal resultSum,
    decimal? discountSum,
    decimal? increaseSum,
    string tableNumberLocalized,
    Guid orderId,
    int orderNumber,
    int tableNumber,
    bool printVat,
    bool printArticle,
    string textAfterCheque,
    string textBeforeCheque,
    Guid? id,
    string cashierName,
    Guid cashierId,
    string cashierTaxpayerId
)

Parameters

cashPayment
Type: SystemDecimal
settlementAddress
Type: SystemString
settlementPlace
Type: SystemString
customerName
Type: SystemString
customerTin
Type: SystemString
isRefund
Type: SystemBoolean
isCancellation
Type: SystemBoolean
sales
Type: System.Collections.GenericList ChequeSale
cancellingSaleNumber
Type: SystemInt32
discountPercent
Type: SystemNullable Decimal
increasePercent
Type: SystemNullable Decimal
resultSum
Type: SystemDecimal
discountSum
Type: SystemNullable Decimal
increaseSum
Type: SystemNullable Decimal
tableNumberLocalized
Type: SystemString
orderId
Type: SystemGuid
orderNumber
Type: SystemInt32
tableNumber
Type: SystemInt32
printVat
Type: SystemBoolean
printArticle
Type: SystemBoolean
textAfterCheque
Type: SystemString
textBeforeCheque
Type: SystemString
id
Type: SystemNullable Guid
cashierName
Type: SystemString
cashierId
Type: SystemGuid
cashierTaxpayerId
Type: SystemString
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask Properties

The ChequeTask type exposes the following members.

Properties
 | Name | Description
Public property | BillNumber | Bill (precheque) number.
Public property | CancellingSaleNumber | The order number that will be canceled if cheque is refund. (Inherited from BillTask.)
Public property | CardPayments | Card payments.
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | CashPayment | Cash payment sum.
Public property | CashPayments | Cash payments.
Public property | ConsiderationSum | Consideration sum.
Public property | CreditSum | Credit sum.
Public property | CustomerName | Name of customer (person or organization).
Public property | CustomerTin | Taxpayer Identification Number of customer (person or organization).
Public property | DiscountPercent | Discount for subtotal in percent. (Inherited from BillTask.)
Public property | DiscountSum | Discount for subtotal. (Inherited from BillTask.)
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | IncreasePercent | Increase for subtotal in percent. (Inherited from BillTask.)
Public property | IncreaseSum | Increase for subtotal. (Inherited from BillTask.)
Public property | IsCancellation | Belarus/Latvia localization specific option. The cashier can choose either cancellation or refund depending on the actual situation. Only the entire check can be cancelled. (Inherited from BillTask.)
Public property | IsOfdElectronicChequeOnly | Form electronic cheque only.
Public property | IsRefund | Indicates whether the cheque is refund (Storno in Resto). (Inherited from BillTask.)
Public property | OfdEmail | Email for receipt copy of cheque.
Public property | OfdPhoneNumber | Phone number for receipt copy of cheque.
Public property | OperationTime | Operation time.
Public property | OrderId | Order id for bill/payment/return operations. (Inherited from BillTask.)
Public property | OrderNumber | Order number. (Inherited from BillTask.)
Public property | PrepaymentId | Unique prepayment identification number to return prepayment, for non prepayment is null
Public property | PrepaymentSum | Advance payment sum.
Public property | PrintArticle | Print product article. (Inherited from BillTask.)
Public property | PrintVat | Print VAT. (Inherited from BillTask.)
Public property | ResultSum | The resulting sum. (Inherited from BillTask.)
Public property | RoundSum | Rounded sum in favor of the client.
Public property | Sales | Sales. (Inherited from BillTask.)
Public property | SettlementAddress | Address of settlement.
Public property | SettlementPlace | Place of settlement.
Public property | TableNumber | Table number. (Inherited from BillTask.)
Public property | TableNumberLocalized | Order number and table number localized string. (Inherited from BillTask.)
Public property | TaxationSystem | Taxation system.
Public property | TextAfterCheque | Text to print at the beginning of a document. (Inherited from BillTask.)
Public property | TextBeforeCheque | Text to print at the end of a document. (Inherited from BillTask.)
Top
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.BillNumber Property

ChequeTaskBillNumber Property

Bill (precheque) number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int BillNumber { get; set; }

Property Value

Type: Int32
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CardPayments Property

ChequeTaskCardPayments Property

Card payments.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<ChequePayment> CardPayments { get; set; }

Property Value

Type: List ChequePayment
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CashPayment Property

ChequeTaskCashPayment Property

Cash payment sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal CashPayment { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CashPayments Property

ChequeTaskCashPayments Property

Cash payments.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<ChequePayment> CashPayments { get; set; }

Property Value

Type: List ChequePayment
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.ConsiderationSum Property

ChequeTaskConsiderationSum Property

Consideration sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal ConsiderationSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CreditSum Property

ChequeTaskCreditSum Property

Credit sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal CreditSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CustomerName Property

ChequeTaskCustomerName Property

Name of customer (person or organization).

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CustomerName { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.CustomerTin Property

ChequeTaskCustomerTin Property

Taxpayer Identification Number of customer (person or organization).

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CustomerTin { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.IsOfdElectronicChequeOnly Property

ChequeTaskIsOfdElectronicChequeOnly Property

Form electronic cheque only.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsOfdElectronicChequeOnly { get; set; }

Property Value

Type: Boolean
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.OfdEmail Property

ChequeTaskOfdEmail Property

Email for receipt copy of cheque.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdEmail { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.OfdPhoneNumber Property

ChequeTaskOfdPhoneNumber Property

Phone number for receipt copy of cheque.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string OfdPhoneNumber { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.OperationTime Property

ChequeTaskOperationTime Property

Operation time.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DateTime OperationTime { get; set; }

Property Value

Type: DateTime
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.PrepaymentId Property

ChequeTaskPrepaymentId Property

Unique prepayment identification number to return prepayment, for non prepayment is null

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? PrepaymentId { get; set; }

Property Value

Type: Nullable Guid
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.PrepaymentSum Property

ChequeTaskPrepaymentSum Property

Advance payment sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal PrepaymentSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.RoundSum Property

ChequeTaskRoundSum Property

Rounded sum in favor of the client.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal? RoundSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.SettlementAddress Property

ChequeTaskSettlementAddress Property

Address of settlement.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string SettlementAddress { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.SettlementPlace Property

ChequeTaskSettlementPlace Property

Place of settlement.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string SettlementPlace { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask.TaxationSystem Property

ChequeTaskTaxationSystem Property

Taxation system.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TaxationSystem? TaxationSystem { get; set; }

Property Value

Type: Nullable TaxationSystem
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTask Methods

The ChequeTask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChequeTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem Class

Cheque task discount increase item.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksChequeTaskDiscountIncreaseItem

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ChequeTaskDiscountIncreaseItem

The ChequeTaskDiscountIncreaseItem type exposes the following members.

Constructors
 | Name | Description
Public method | ChequeTaskDiscountIncreaseItem | Main constructor
Top
Properties
 | Name | Description
Public property | CardNumber | Card number.
Public property | Name | Name.
Public property | Percent | Percent.
Public property | Sum | Sum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequeTaskDiscountIncreaseItem(
    string name,
    decimal percent,
    decimal sum,
    string cardNumber
)

Parameters

name
Type: SystemString
percent
Type: SystemDecimal
sum
Type: SystemDecimal
cardNumber
Type: SystemString
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem Properties

The ChequeTaskDiscountIncreaseItem type exposes the following members.

Properties
 | Name | Description
Public property | CardNumber | Card number.
Public property | Name | Name.
Public property | Percent | Percent.
Public property | Sum | Sum.
Top
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem.CardNumber Property

ChequeTaskDiscountIncreaseItemCardNumber Property

Card number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CardNumber { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem.Name Property

ChequeTaskDiscountIncreaseItemName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem.Percent Property

ChequeTaskDiscountIncreaseItemPercent Property

Percent.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Percent { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem.Sum Property

ChequeTaskDiscountIncreaseItemSum Property

Sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Sum { get; set; }

Property Value

Type: Decimal
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTaskDiscountIncreaseItem Methods

The ChequeTaskDiscountIncreaseItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChequeTaskDiscountIncreaseItem Class
Resto.Front.Api.Data.Device.Tasks Namespace


ChequeTransferType Enumeration

Item category attribute.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum ChequeTransferType
Members
Member name | Value | Description
FullPrepayment | 0 | Goods.
PartialPrepayment | 1 | Goods.
Advance | 2 | Goods.
FullPayment | 3 | Goods.
PartialCredit | 4 | Goods.
Credit | 5 | Goods.
RepaymentOfCredit | 6 | Goods.
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Class

Command execute.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCommandExecute

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CommandExecute

The CommandExecute type exposes the following members.

Constructors
 | Name | Description
Public method | CommandExecute | Default constructor
Public method | CommandExecute(String) | Main constructor
Top
Properties
 | Name | Description
Public property | Name | Name.
Public property | Parameters | List of parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Constructor

Overload List
 | Name | Description
Public method | CommandExecute | Default constructor
Public method | CommandExecute(String) | Main constructor
Top
See Also

Reference

CommandExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CommandExecute()
See Also

Reference

CommandExecute Class
CommandExecute Overload
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Constructor (String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CommandExecute(
    string name
)

Parameters

name
Type: SystemString
See Also

Reference

CommandExecute Class
CommandExecute Overload
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Properties

The CommandExecute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name.
Public property | Parameters | List of parameters.
Top
See Also

Reference

CommandExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute.Name Property

CommandExecuteName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

CommandExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute.Parameters Property

CommandExecuteParameters Property

List of parameters.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<ParameterExecute> Parameters { get; set; }

Property Value

Type: List ParameterExecute
See Also

Reference

CommandExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


CommandExecute Methods

The CommandExecute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommandExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor Class

Contractor.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksContractor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class Contractor

The Contractor type exposes the following members.

Constructors
 | Name | Description
Public method | Contractor | Main constructor
Top
Properties
 | Name | Description
Public property | Name | Name.
Public property | PhoneNumber | Phone number.
Public property | TaxpayerId | Taxpayer id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


Contractor Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Contractor(
    string name,
    string taxpayerId,
    string phoneNumber
)

Parameters

name
Type: SystemString
taxpayerId
Type: SystemString
phoneNumber
Type: SystemString
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor Properties

The Contractor type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name.
Public property | PhoneNumber | Phone number.
Public property | TaxpayerId | Taxpayer id.
Top
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor.Name Property

ContractorName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor.PhoneNumber Property

ContractorPhoneNumber Property

Phone number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PhoneNumber { get; set; }

Property Value

Type: String
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor.TaxpayerId Property

ContractorTaxpayerId Property

Taxpayer id.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TaxpayerId { get; set; }

Property Value

Type: String
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


Contractor Methods

The Contractor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Contractor Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionDocumentType Enumeration

Correction document type.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum CorrectionDocumentType
Members
Member name | Value | Description
Sale | 0 | Income correction.
Buy | 1 | Expense correction.
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionReasonEnum Enumeration

Correction reason.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum CorrectionReasonEnum
Members
Member name | Value | Description
OwnInitiative | 0 | Own initiative.
Determination | 1 | Federal Tax Service instruction.
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask Class

Correction task.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCashRegisterTask
Resto.Front.Api.Data.Device.TasksCorrectionTask

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CorrectionTask : CashRegisterTask

The CorrectionTask type exposes the following members.

Constructors
 | Name | Description
Public method | CorrectionTask | Main constructor
Top
Properties
 | Name | Description
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | CashSum | Cash sum.
Public property | ConsiderationSum | Consideration sum.
Public property | CorrectionReason | Correction reason.
Public property | CreditSum | Credit sum.
Public property | DocumentDateTime | Document date time.
Public property | DocumentName | Document name.
Public property | DocumentNumber | Document number.
Public property | DocumentType | Document type.
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | NonCashSum | Electronic payment sum.
Public property | PrepaymentSum | Prepayment sum.
Public property | TaxationSystem | Taxation system.
Public property | VatSum | VAT sum.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CorrectionTask(
    Guid? id,
    string cashierName,
    Guid cashierId,
    string cashierTaxpayerId
)

Parameters

id
Type: SystemNullable Guid
cashierName
Type: SystemString
cashierId
Type: SystemGuid
cashierTaxpayerId
Type: SystemString
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask Properties

The CorrectionTask type exposes the following members.

Properties
 | Name | Description
Public property | CashierId | Cashier Id. (Inherited from CashRegisterTask.)
Public property | CashierName | Cashier name. (Inherited from CashRegisterTask.)
Public property | CashierTaxpayerId | Taxpayer Id of the cashier. (Inherited from CashRegisterTask.)
Public property | CashSum | Cash sum.
Public property | ConsiderationSum | Consideration sum.
Public property | CorrectionReason | Correction reason.
Public property | CreditSum | Credit sum.
Public property | DocumentDateTime | Document date time.
Public property | DocumentName | Document name.
Public property | DocumentNumber | Document number.
Public property | DocumentType | Document type.
Public property | Id | The task id. (Inherited from CashRegisterTask.)
Public property | NonCashSum | Electronic payment sum.
Public property | PrepaymentSum | Prepayment sum.
Public property | TaxationSystem | Taxation system.
Public property | VatSum | VAT sum.
Top
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.CashSum Property

CorrectionTaskCashSum Property

Cash sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal CashSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.ConsiderationSum Property

CorrectionTaskConsiderationSum Property

Consideration sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal ConsiderationSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.CorrectionReason Property

CorrectionTaskCorrectionReason Property

Correction reason.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CorrectionReasonEnum CorrectionReason { get; set; }

Property Value

Type: CorrectionReasonEnum
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.CreditSum Property

CorrectionTaskCreditSum Property

Credit sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal CreditSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.DocumentDateTime Property

CorrectionTaskDocumentDateTime Property

Document date time.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string DocumentDateTime { get; set; }

Property Value

Type: String
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.DocumentName Property

CorrectionTaskDocumentName Property

Document name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string DocumentName { get; set; }

Property Value

Type: String
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.DocumentNumber Property

CorrectionTaskDocumentNumber Property

Document number.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string DocumentNumber { get; set; }

Property Value

Type: String
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.DocumentType Property

CorrectionTaskDocumentType Property

Document type.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CorrectionDocumentType DocumentType { get; set; }

Property Value

Type: CorrectionDocumentType
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.NonCashSum Property

CorrectionTaskNonCashSum Property

Electronic payment sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal NonCashSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.PrepaymentSum Property

CorrectionTaskPrepaymentSum Property

Prepayment sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal PrepaymentSum { get; set; }

Property Value

Type: Decimal
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.TaxationSystem Property

CorrectionTaskTaxationSystem Property

Taxation system.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TaxationSystem? TaxationSystem { get; set; }

Property Value

Type: Nullable TaxationSystem
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask.VatSum Property

CorrectionTaskVatSum Property

VAT sum.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<CashRegisterVatData> VatSum { get; set; }

Property Value

Type: List CashRegisterVatData
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CorrectionTask Methods

The CorrectionTask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CorrectionTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask Class

Task to display custom text to customer.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksCustomerDisplayTextTask

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CustomerDisplayTextTask

The CustomerDisplayTextTask type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerDisplayTextTask | Main constructor
Top
Properties
 | Name | Description
Public property | BottomLeft | Text at bottom left corner.
Public property | BottomRight | Text at bottom right corner.
Public property | MaxShowTimeMillis | Maximum display text time. After timeout waiting text will be displayed.
Public property | TopLeft | Text at top left corner.
Public property | TopRight | Text at top right corner.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CustomerDisplayTextTask(
    int maxShowTimeMillis,
    string topLeft,
    string topRight,
    string bottomLeft,
    string bottomRight
)

Parameters

maxShowTimeMillis
Type: SystemInt32
topLeft
Type: SystemString
topRight
Type: SystemString
bottomLeft
Type: SystemString
bottomRight
Type: SystemString
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask Properties

The CustomerDisplayTextTask type exposes the following members.

Properties
 | Name | Description
Public property | BottomLeft | Text at bottom left corner.
Public property | BottomRight | Text at bottom right corner.
Public property | MaxShowTimeMillis | Maximum display text time. After timeout waiting text will be displayed.
Public property | TopLeft | Text at top left corner.
Public property | TopRight | Text at top right corner.
Top
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask.BottomLeft Property

CustomerDisplayTextTaskBottomLeft Property

Text at bottom left corner.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string BottomLeft { get; set; }

Property Value

Type: String
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask.BottomRight Property

CustomerDisplayTextTaskBottomRight Property

Text at bottom right corner.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string BottomRight { get; set; }

Property Value

Type: String
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask.MaxShowTimeMillis Property

CustomerDisplayTextTaskMaxShowTimeMillis Property

Maximum display text time. After timeout waiting text will be displayed.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int MaxShowTimeMillis { get; set; }

Property Value

Type: Int32
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask.TopLeft Property

CustomerDisplayTextTaskTopLeft Property

Text at top left corner.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TopLeft { get; set; }

Property Value

Type: String
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask.TopRight Property

CustomerDisplayTextTaskTopRight Property

Text at top right corner.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TopRight { get; set; }

Property Value

Type: String
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


CustomerDisplayTextTask Methods

The CustomerDisplayTextTask type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomerDisplayTextTask Class
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Class

Parameter execute.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksParameterExecute

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ParameterExecute

The ParameterExecute type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterExecute | Default constructor
Public method | ParameterExecute(String, String) | Main constructor
Top
Properties
 | Name | Description
Public property | Name | Name.
Public property | Value | Value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Constructor

Overload List
 | Name | Description
Public method | ParameterExecute | Default constructor
Public method | ParameterExecute(String, String) | Main constructor
Top
See Also

Reference

ParameterExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Constructor

Default constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ParameterExecute()
See Also

Reference

ParameterExecute Class
ParameterExecute Overload
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Constructor (String, String)

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ParameterExecute(
    string name,
    string value
)

Parameters

name
Type: SystemString
value
Type: SystemString
See Also

Reference

ParameterExecute Class
ParameterExecute Overload
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Properties

The ParameterExecute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name.
Public property | Value | Value.
Top
See Also

Reference

ParameterExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute.Name Property

ParameterExecuteName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

ParameterExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute.Value Property

ParameterExecuteValue Property

Value.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Value { get; set; }

Property Value

Type: String
See Also

Reference

ParameterExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


ParameterExecute Methods

The ParameterExecute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ParameterExecute Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter Class

Arbitrary operation parameter.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksRequiredParameter

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class RequiredParameter

The RequiredParameter type exposes the following members.

Constructors
 | Name | Description
Public method | RequiredParameter | Main constructor
Top
Properties
 | Name | Description
Public property | Name | Name.
Public property | ResourceName | Resource id with parameter name.
Public property | ResourceTip | Resource id with parameter tooltip.
Public property | Type | Type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RequiredParameter(
    string name,
    string resourceName,
    string resourceTip,
    string type
)

Parameters

name
Type: SystemString
resourceName
Type: SystemString
resourceTip
Type: SystemString
type
Type: SystemString
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter Properties

The RequiredParameter type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name.
Public property | ResourceName | Resource id with parameter name.
Public property | ResourceTip | Resource id with parameter tooltip.
Public property | Type | Type.
Top
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter.Name Property

RequiredParameterName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter.ResourceName Property

RequiredParameterResourceName Property

Resource id with parameter name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ResourceName { get; set; }

Property Value

Type: String
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter.ResourceTip Property

RequiredParameterResourceTip Property

Resource id with parameter tooltip.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ResourceTip { get; set; }

Property Value

Type: String
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter.Type Property

RequiredParameterType Property

Type.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Type { get; set; }

Property Value

Type: String
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


RequiredParameter Methods

The RequiredParameter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RequiredParameter Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand Class

Supported command.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Device.TasksSupportedCommand

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class SupportedCommand

The SupportedCommand type exposes the following members.

Constructors
 | Name | Description
Public method | SupportedCommand | Main constructor
Top
Properties
 | Name | Description
Public property | Name | Name.
Public property | Parameters | Parameters.
Public property | ResourceName | Resource id with parameter name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public SupportedCommand(
    string name,
    string resourceName
)

Parameters

name
Type: SystemString
resourceName
Type: SystemString
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand Properties

The SupportedCommand type exposes the following members.

Properties
 | Name | Description
Public property | Name | Name.
Public property | Parameters | Parameters.
Public property | ResourceName | Resource id with parameter name.
Top
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand.Name Property

SupportedCommandName Property

Name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; set; }

Property Value

Type: String
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand.Parameters Property

SupportedCommandParameters Property

Parameters.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public List<RequiredParameter> Parameters { get; set; }

Property Value

Type: List RequiredParameter
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand.ResourceName Property

SupportedCommandResourceName Property

Resource id with parameter name.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string ResourceName { get; set; }

Property Value

Type: String
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


SupportedCommand Methods

The SupportedCommand type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SupportedCommand Class
Resto.Front.Api.Data.Device.Tasks Namespace


TaxationSystem Enumeration

Taxation system.

Namespace: Resto.Front.Api.Data.Device.Tasks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public enum TaxationSystem
Members
Member name | Value | Description
Common | 0 | Common.
SimplifiedIncomeOnly | 1 | Simplified. Income only.
SimplifiedIncomeMinusExpenses | 2 | Simplified. Income minus expenses.
Singletaxonimputedincome | 3 | Single tax on imputed income.
Singleagriculturaltax | 4 | Single agricultural tax.
Patent | 5 | Patent.
See Also

Reference

Resto.Front.Api.Data.Device.Tasks Namespace


Resto.Front.Api.Data.JournalEvents Namespace

Enumerations
 | Enumeration | Description
Public enumeration | Severity | Severity of journal event.


Severity Enumeration

Severity of journal event.

Namespace: Resto.Front.Api.Data.JournalEvents
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum Severity
Members
Member name | Value | Description
Low | 0 | Low severity.
Middle | 1 | Middle severity.
High | 2 | High severity.
See Also

Reference

Resto.Front.Api.Data.JournalEvents Namespace


Resto.Front.Api.Data.Kitchen Namespace

Classes
 | Class | Description
Public class | KitchenOrderCompoundItemComponentDto |
Public class | KitchenOrderCompoundItemDto |
Public class | KitchenOrderDto |
Public class | KitchenOrderItemCommentDto |
Public class | KitchenOrderModifierItemDto |
Public class | KitchenOrderProductItemDto |
Interfaces
 | Interface | Description
Public interface | IKitchenOrder | Order equivalent for kitchen. Kitchen orders created automatically from IOrder and have independent lifetime.
Public interface | IKitchenOrderCompoundItem | Order item compound item equivalent for kitchen.
Public interface | IKitchenOrderCompoundItemComponent | Order item compound item component equivalent for kitchen.
Public interface | IKitchenOrderCookingItem | Order cooking item equivalent for kitchen.
Public interface | IKitchenOrderCookingItemComment | Comment for order item product, kitchen equivalent of IOrderCookingItemComment.
Public interface | IKitchenOrderCookingItemDto |
Public interface | IKitchenOrderModifierItem | Specifies some kind of predefined product cooking customization.
Public interface | IKitchenOrderProductItem | Order item product equivalent for kitchen.
Enumerations
 | Enumeration | Description
Public enumeration | KitchenOrderItemProcessingStatus | Describes order item processing lifecycle from kitchen point of view.


IKitchenOrder Interface

Order equivalent for kitchen. Kitchen orders created automatically from IOrder and have independent lifetime.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrder : ISerializable,
    IEntity

The IKitchenOrder type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderId | Id of the base order (IOrder) this kitchen order was created from.
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.
Public property | Id | (Inherited from IEntity.)
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.
Public property | Items | Source order item products equivalent for kitchen. Only printed order item products are taken into account for kitchen.
Public property | Number | Number of the source order.
Public property | OrderType |
Public property | Table | Table of the source order.
Public property | Waiter | Person who serves the source order.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder Properties

The IKitchenOrder type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderId | Id of the base order (IOrder) this kitchen order was created from.
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.
Public property | Id | (Inherited from IEntity.)
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.
Public property | Items | Source order item products equivalent for kitchen. Only printed order item products are taken into account for kitchen.
Public property | Number | Number of the source order.
Public property | OrderType |
Public property | Table | Table of the source order.
Public property | Waiter | Person who serves the source order.
Top
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.BaseOrderId Property

IKitchenOrderBaseOrderId Property

Id of the base order (IOrder) this kitchen order was created from.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid BaseOrderId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.CookingPriority Property

IKitchenOrderCookingPriority Property

Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int CookingPriority { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.IsTopCookingPriority Property

IKitchenOrderIsTopCookingPriority Property

The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsTopCookingPriority { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.Items Property

IKitchenOrderItems Property

Source order item products equivalent for kitchen. Only printed order item products are taken into account for kitchen.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenOrderCookingItem> Items { get; }

Property Value

Type: IReadOnlyList IKitchenOrderCookingItem
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.Number Property

IKitchenOrderNumber Property

Number of the source order.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.OrderType Property

IKitchenOrderOrderType Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType OrderType { get; }

Property Value

Type: IOrderType
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.Table Property

IKitchenOrderTable Property

Table of the source order.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITable Table { get; }

Property Value

Type: ITable
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder.Waiter Property

IKitchenOrderWaiter Property

Person who serves the source order.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Waiter { get; }

Property Value

Type: IUser
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrder Methods

The IKitchenOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrder Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem Interface

Order item compound item equivalent for kitchen.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderCompoundItem : IKitchenOrderCookingItem,
    ISerializable, IEntity

The IKitchenOrderCompoundItem type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from. (Inherited from IKitchenOrderCookingItem.)
Public property | Comment | Optional text comment, can be used as a message from waiter to cook. (Inherited from IKitchenOrderCookingItem.)
Public property | CommonModifiers | Common (non-splittable) assigned modifiers. Apply to all components.
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Course | Gets course of this kitchen order item. (Inherited from IKitchenOrderCookingItem.)
Public property | Deleted | Whether printed item has been deleted from source order. (Inherited from IKitchenOrderCookingItem.)
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started. (Inherited from IKitchenOrderCookingItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time). (Inherited from IKitchenOrderCookingItem.)
Public property | Kitchen | Item cooking place. (Inherited from IKitchenOrderCookingItem.)
Public property | PrimaryComponent | Primary part of the kitchen compound item. For the undivided compound item this part is single, for splitted — primary.
Public property | PrintTime | Source order item print time. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingStatus | Gets current position in a item processing lifecycle. (Inherited from IKitchenOrderCookingItem.)
Public property | SecondaryComponent | Secondary part of the splitted kitchen compound item or null for undivided compound item.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together. (Inherited from IKitchenOrderCookingItem.)
Public property | ServeTime | Moment when item last time switched to the Served status. (Inherited from IKitchenOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Template | Template of the current kitchen compound item.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem Properties

The IKitchenOrderCompoundItem type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from. (Inherited from IKitchenOrderCookingItem.)
Public property | Comment | Optional text comment, can be used as a message from waiter to cook. (Inherited from IKitchenOrderCookingItem.)
Public property | CommonModifiers | Common (non-splittable) assigned modifiers. Apply to all components.
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Course | Gets course of this kitchen order item. (Inherited from IKitchenOrderCookingItem.)
Public property | Deleted | Whether printed item has been deleted from source order. (Inherited from IKitchenOrderCookingItem.)
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started. (Inherited from IKitchenOrderCookingItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time). (Inherited from IKitchenOrderCookingItem.)
Public property | Kitchen | Item cooking place. (Inherited from IKitchenOrderCookingItem.)
Public property | PrimaryComponent | Primary part of the kitchen compound item. For the undivided compound item this part is single, for splitted — primary.
Public property | PrintTime | Source order item print time. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingStatus | Gets current position in a item processing lifecycle. (Inherited from IKitchenOrderCookingItem.)
Public property | SecondaryComponent | Secondary part of the splitted kitchen compound item or null for undivided compound item.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together. (Inherited from IKitchenOrderCookingItem.)
Public property | ServeTime | Moment when item last time switched to the Served status. (Inherited from IKitchenOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Template | Template of the current kitchen compound item.
Top
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem.CommonModifiers Property

IKitchenOrderCompoundItemCommonModifiers Property

Common (non-splittable) assigned modifiers. Apply to all components.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenOrderModifierItem> CommonModifiers { get; }

Property Value

Type: IReadOnlyList IKitchenOrderModifierItem
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem.PrimaryComponent Property

IKitchenOrderCompoundItemPrimaryComponent Property

Primary part of the kitchen compound item. For the undivided compound item this part is single, for splitted — primary.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IKitchenOrderCompoundItemComponent PrimaryComponent { get; }

Property Value

Type: IKitchenOrderCompoundItemComponent
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem.SecondaryComponent Property

IKitchenOrderCompoundItemSecondaryComponent Property

Secondary part of the splitted kitchen compound item or null for undivided compound item.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IKitchenOrderCompoundItemComponent SecondaryComponent { get; }

Property Value

Type: IKitchenOrderCompoundItemComponent
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem.Template Property

IKitchenOrderCompoundItemTemplate Property

Template of the current kitchen compound item.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICompoundItemTemplate Template { get; }

Property Value

Type: ICompoundItemTemplate
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItem Methods

The IKitchenOrderCompoundItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderCompoundItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent Interface

Order item compound item component equivalent for kitchen.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderCompoundItemComponent : ISerializable,
    IEntity

The IKitchenOrderCompoundItemComponent type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Compound item component amount to be cooked.
Public property | Id | (Inherited from IEntity.)
Public property | Modifiers | Get compound component's modifiers.
Public property | Product | Compound item component product to be cooked.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent Properties

The IKitchenOrderCompoundItemComponent type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Compound item component amount to be cooked.
Public property | Id | (Inherited from IEntity.)
Public property | Modifiers | Get compound component's modifiers.
Public property | Product | Compound item component product to be cooked.
Top
See Also

Reference

IKitchenOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent.Amount Property

IKitchenOrderCompoundItemComponentAmount Property

Compound item component amount to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IKitchenOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent.Modifiers Property

IKitchenOrderCompoundItemComponentModifiers Property

Get compound component's modifiers.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenOrderModifierItem> Modifiers { get; }

Property Value

Type: IReadOnlyList IKitchenOrderModifierItem
See Also

Reference

IKitchenOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent.Product Property

IKitchenOrderCompoundItemComponentProduct Property

Compound item component product to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IKitchenOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCompoundItemComponent Methods

The IKitchenOrderCompoundItemComponent type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem Interface

Order cooking item equivalent for kitchen.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderCookingItem : ISerializable,
    IEntity

The IKitchenOrderCookingItem type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from.
Public property | Comment | Optional text comment, can be used as a message from waiter to cook.
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null.
Public property | Course | Gets course of this kitchen order item.
Public property | Deleted | Whether printed item has been deleted from source order.
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started.
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time).
Public property | Kitchen | Item cooking place.
Public property | PrintTime | Source order item print time.
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status.
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status.
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status.
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status.
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status.
Public property | ProcessingStatus | Gets current position in a item processing lifecycle.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together.
Public property | ServeTime | Moment when item last time switched to the Served status.
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem Properties

The IKitchenOrderCookingItem type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from.
Public property | Comment | Optional text comment, can be used as a message from waiter to cook.
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null.
Public property | Course | Gets course of this kitchen order item.
Public property | Deleted | Whether printed item has been deleted from source order.
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started.
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time).
Public property | Kitchen | Item cooking place.
Public property | PrintTime | Source order item print time.
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status.
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status.
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status.
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status.
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status.
Public property | ProcessingStatus | Gets current position in a item processing lifecycle.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together.
Public property | ServeTime | Moment when item last time switched to the Served status.
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null.
Top
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.BaseOrderItemId Property

IKitchenOrderCookingItemBaseOrderItemId Property

Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid BaseOrderItemId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Comment Property

IKitchenOrderCookingItemComment Property

Optional text comment, can be used as a message from waiter to cook.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IKitchenOrderCookingItemComment Comment { get; }

Property Value

Type: IKitchenOrderCookingItemComment
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.CookingTime Property

IKitchenOrderCookingItemCookingTime Property

Standard cooking time defined by settings if cooking is started, otherwise null.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? CookingTime { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Course Property

IKitchenOrderCookingItemCourse Property

Gets course of this kitchen order item.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderItemCourse Course { get; }

Property Value

Type: OrderItemCourse
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Deleted Property

IKitchenOrderCookingItemDeleted Property

Whether printed item has been deleted from source order.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.EstimatedCookingBeginTime Property

IKitchenOrderCookingItemEstimatedCookingBeginTime Property

Moment when item cooking should be started. This property is null until cooking should be started.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? EstimatedCookingBeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.IsCookingStarted Property

IKitchenOrderCookingItemIsCookingStarted Property

Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time).

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsCookingStarted { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Kitchen Property

IKitchenOrderCookingItemKitchen Property

Item cooking place.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection Kitchen { get; }

Property Value

Type: IRestaurantSection
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.PrintTime Property

IKitchenOrderCookingItemPrintTime Property

Source order item print time.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime PrintTime { get; }

Property Value

Type: DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Processing1BeginTime Property

IKitchenOrderCookingItemProcessing1BeginTime Property

Moment when item last time switched to the Processing1 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing1BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Processing2BeginTime Property

IKitchenOrderCookingItemProcessing2BeginTime Property

Moment when item last time switched to the Processing2 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing2BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Processing3BeginTime Property

IKitchenOrderCookingItemProcessing3BeginTime Property

Moment when item last time switched to the Processing3 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing3BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Processing4BeginTime Property

IKitchenOrderCookingItemProcessing4BeginTime Property

Moment when item last time switched to the Processing4 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing4BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.ProcessingCompleteTime Property

IKitchenOrderCookingItemProcessingCompleteTime Property

Moment when item last time switched to the Processed or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ProcessingCompleteTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.ProcessingStatus Property

IKitchenOrderCookingItemProcessingStatus Property

Gets current position in a item processing lifecycle.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
KitchenOrderItemProcessingStatus ProcessingStatus { get; }

Property Value

Type: KitchenOrderItemProcessingStatus
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.ServeGroupNumber Property

IKitchenOrderCookingItemServeGroupNumber Property

Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int ServeGroupNumber { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.ServeTime Property

IKitchenOrderCookingItemServeTime Property

Moment when item last time switched to the Served status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ServeTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem.Size Property

IKitchenOrderCookingItemSize Property

Gets size of the order item if it's product or template has scale, otherwise null.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize Size { get; }

Property Value

Type: IProductSize
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItem Methods

The IKitchenOrderCookingItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderCookingItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemComment Interface

Comment for order item product, kitchen equivalent of IOrderCookingItemComment.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderCookingItemComment : ISerializable

The IKitchenOrderCookingItemComment type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Text of the comment.
Public property | Deleted | Whether comment of the printed product was deleted.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemComment Properties

The IKitchenOrderCookingItemComment type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Text of the comment.
Public property | Deleted | Whether comment of the printed product was deleted.
Top
See Also

Reference

IKitchenOrderCookingItemComment Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemComment.Comment Property

IKitchenOrderCookingItemCommentComment Property

Text of the comment.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IKitchenOrderCookingItemComment Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemComment.Deleted Property

IKitchenOrderCookingItemCommentDeleted Property

Whether comment of the printed product was deleted.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderCookingItemComment Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemComment Methods

The IKitchenOrderCookingItemComment type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderCookingItemComment Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto Interface

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderCookingItemDto

The IKitchenOrderCookingItemDto type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | OrderRank |
Public property | PrintTime |
Public property | ProductSizeId |
Public property | ServeGroupNumber |
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto Properties

The IKitchenOrderCookingItemDto type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | OrderRank |
Public property | PrintTime |
Public property | ProductSizeId |
Public property | ServeGroupNumber |
Top
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.BaseOrderItemId Property

IKitchenOrderCookingItemDtoBaseOrderItemId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid BaseOrderItemId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.Comment Property

IKitchenOrderCookingItemDtoComment Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
KitchenOrderItemCommentDto Comment { get; }

Property Value

Type: KitchenOrderItemCommentDto
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.CookingPlaceId Property

IKitchenOrderCookingItemDtoCookingPlaceId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid CookingPlaceId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.CookingPlaceTypeId Property

IKitchenOrderCookingItemDtoCookingPlaceTypeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid CookingPlaceTypeId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.CookingTime Property

IKitchenOrderCookingItemDtoCookingTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? CookingTime { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.GuestName Property

IKitchenOrderCookingItemDtoGuestName Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GuestName { get; }

Property Value

Type: String
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.OrderRank Property

IKitchenOrderCookingItemDtoOrderRank Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int OrderRank { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.PrintTime Property

IKitchenOrderCookingItemDtoPrintTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime PrintTime { get; }

Property Value

Type: DateTime
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.ProductSizeId Property

IKitchenOrderCookingItemDtoProductSizeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? ProductSizeId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderCookingItemDto.ServeGroupNumber Property

IKitchenOrderCookingItemDtoServeGroupNumber Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int ServeGroupNumber { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenOrderCookingItemDto Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem Interface

Specifies some kind of predefined product cooking customization.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderModifierItem : ISerializable,
    IEntity

The IKitchenOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Modifier amount to be cooked.
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | BaseOrderModifierId | Id of the modifier item (IOrderModifierItem) from the base order (IOrder) this item was created from.
Public property | CookingTime | For separate modifiers standard cooking time defined by settings if cooking is started, otherwise null. This property is meaningless for non-separate modifiers.
Public property | Deleted | Whether modifier or the printed product has been deleted from source order.
Public property | EstimatedCookingBeginTime | Moment when modifier cooking should be started. This property is null until cooking should be started.
Public property | Id | (Inherited from IEntity.)
Public property | IsSeparate | Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.
Public property | Kitchen | Modifier cooking place.
Public property | Processing1BeginTime | Moment when product last time switched to the Processing1 or greater status.
Public property | Processing2BeginTime | Moment when product last time switched to the Processing2 or greater status.
Public property | Processing3BeginTime | Moment when product last time switched to the Processing3 or greater status.
Public property | Processing4BeginTime | Moment when product last time switched to the Processing4 or greater status.
Public property | ProcessingCompleteTime | Moment when product last time switched to the Processed or greater status.
Public property | ProcessingStatus | Gets current position in a product processing lifecycle.
Public property | Product | Modifier to be cooked.
Public property | ServeTime | Moment when product last time switched to the Served status.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem Properties

The IKitchenOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Modifier amount to be cooked.
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | BaseOrderModifierId | Id of the modifier item (IOrderModifierItem) from the base order (IOrder) this item was created from.
Public property | CookingTime | For separate modifiers standard cooking time defined by settings if cooking is started, otherwise null. This property is meaningless for non-separate modifiers.
Public property | Deleted | Whether modifier or the printed product has been deleted from source order.
Public property | EstimatedCookingBeginTime | Moment when modifier cooking should be started. This property is null until cooking should be started.
Public property | Id | (Inherited from IEntity.)
Public property | IsSeparate | Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.
Public property | Kitchen | Modifier cooking place.
Public property | Processing1BeginTime | Moment when product last time switched to the Processing1 or greater status.
Public property | Processing2BeginTime | Moment when product last time switched to the Processing2 or greater status.
Public property | Processing3BeginTime | Moment when product last time switched to the Processing3 or greater status.
Public property | Processing4BeginTime | Moment when product last time switched to the Processing4 or greater status.
Public property | ProcessingCompleteTime | Moment when product last time switched to the Processed or greater status.
Public property | ProcessingStatus | Gets current position in a product processing lifecycle.
Public property | Product | Modifier to be cooked.
Public property | ServeTime | Moment when product last time switched to the Served status.
Top
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Amount Property

IKitchenOrderModifierItemAmount Property

Modifier amount to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.AmountIndependentOfParentAmount Property

IKitchenOrderModifierItemAmountIndependentOfParentAmount Property

Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AmountIndependentOfParentAmount { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.BaseOrderModifierId Property

IKitchenOrderModifierItemBaseOrderModifierId Property

Id of the modifier item (IOrderModifierItem) from the base order (IOrder) this item was created from.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid BaseOrderModifierId { get; }

Property Value

Type: Guid
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.CookingTime Property

IKitchenOrderModifierItemCookingTime Property

For separate modifiers standard cooking time defined by settings if cooking is started, otherwise null. This property is meaningless for non-separate modifiers.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? CookingTime { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Deleted Property

IKitchenOrderModifierItemDeleted Property

Whether modifier or the printed product has been deleted from source order.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.EstimatedCookingBeginTime Property

IKitchenOrderModifierItemEstimatedCookingBeginTime Property

Moment when modifier cooking should be started. This property is null until cooking should be started.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? EstimatedCookingBeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.IsSeparate Property

IKitchenOrderModifierItemIsSeparate Property

Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsSeparate { get; }

Property Value

Type: Boolean
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Kitchen Property

IKitchenOrderModifierItemKitchen Property

Modifier cooking place.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection Kitchen { get; }

Property Value

Type: IRestaurantSection
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Processing1BeginTime Property

IKitchenOrderModifierItemProcessing1BeginTime Property

Moment when product last time switched to the Processing1 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing1BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Processing2BeginTime Property

IKitchenOrderModifierItemProcessing2BeginTime Property

Moment when product last time switched to the Processing2 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing2BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Processing3BeginTime Property

IKitchenOrderModifierItemProcessing3BeginTime Property

Moment when product last time switched to the Processing3 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing3BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Processing4BeginTime Property

IKitchenOrderModifierItemProcessing4BeginTime Property

Moment when product last time switched to the Processing4 or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? Processing4BeginTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.ProcessingCompleteTime Property

IKitchenOrderModifierItemProcessingCompleteTime Property

Moment when product last time switched to the Processed or greater status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ProcessingCompleteTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.ProcessingStatus Property

IKitchenOrderModifierItemProcessingStatus Property

Gets current position in a product processing lifecycle.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
KitchenOrderItemProcessingStatus ProcessingStatus { get; }

Property Value

Type: KitchenOrderItemProcessingStatus
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.Product Property

IKitchenOrderModifierItemProduct Property

Modifier to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem.ServeTime Property

IKitchenOrderModifierItemServeTime Property

Moment when product last time switched to the Served status.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ServeTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderModifierItem Methods

The IKitchenOrderModifierItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderModifierItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem Interface

Order item product equivalent for kitchen.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenOrderProductItem : IKitchenOrderCookingItem,
    ISerializable, IEntity

The IKitchenOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Product amount to be cooked.
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from. (Inherited from IKitchenOrderCookingItem.)
Public property | Comment | Optional text comment, can be used as a message from waiter to cook. (Inherited from IKitchenOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Course | Gets course of this kitchen order item. (Inherited from IKitchenOrderCookingItem.)
Public property | Deleted | Whether printed item has been deleted from source order. (Inherited from IKitchenOrderCookingItem.)
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started. (Inherited from IKitchenOrderCookingItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time). (Inherited from IKitchenOrderCookingItem.)
Public property | Kitchen | Item cooking place. (Inherited from IKitchenOrderCookingItem.)
Public property | Modifiers | Gets product modifiers. This collection is kitchen equivalent of simple and group child modifiers of the source product.
Public property | PrintTime | Source order item print time. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingStatus | Gets current position in a item processing lifecycle. (Inherited from IKitchenOrderCookingItem.)
Public property | Product | Product to be cooked.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together. (Inherited from IKitchenOrderCookingItem.)
Public property | ServeTime | Moment when item last time switched to the Served status. (Inherited from IKitchenOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem Properties

The IKitchenOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Product amount to be cooked.
Public property | BaseOrderItemId | Id of the cooking item (IOrderCookingItem) from the base order (IOrder) this item was created from. (Inherited from IKitchenOrderCookingItem.)
Public property | Comment | Optional text comment, can be used as a message from waiter to cook. (Inherited from IKitchenOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Public property | Course | Gets course of this kitchen order item. (Inherited from IKitchenOrderCookingItem.)
Public property | Deleted | Whether printed item has been deleted from source order. (Inherited from IKitchenOrderCookingItem.)
Public property | EstimatedCookingBeginTime | Moment when item cooking should be started. This property is null until cooking should be started. (Inherited from IKitchenOrderCookingItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsCookingStarted | Whether cooking of the item started. Depending on kitchen settings and waiter intentions item cooking can start immediately after printing or with some delay. Item with short cooking time may wait for long-time cooking item from the same serve group (to be served together), item of second or above course may wait for corresponding serve cheque printing. This property is perfect, expected state, do not mess up with processing status, which means actual status (cook can begin processing before or after the appointed time). (Inherited from IKitchenOrderCookingItem.)
Public property | Kitchen | Item cooking place. (Inherited from IKitchenOrderCookingItem.)
Public property | Modifiers | Gets product modifiers. This collection is kitchen equivalent of simple and group child modifiers of the source product.
Public property | PrintTime | Source order item print time. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing1BeginTime | Moment when item last time switched to the Processing1 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing2BeginTime | Moment when item last time switched to the Processing2 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing3BeginTime | Moment when item last time switched to the Processing3 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | Processing4BeginTime | Moment when item last time switched to the Processing4 or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingCompleteTime | Moment when item last time switched to the Processed or greater status. (Inherited from IKitchenOrderCookingItem.)
Public property | ProcessingStatus | Gets current position in a item processing lifecycle. (Inherited from IKitchenOrderCookingItem.)
Public property | Product | Product to be cooked.
Public property | ServeGroupNumber | Identifies order item products group to be served together. Cooking of items from the same order with the same serve group number should be completed at the same time, so that waiter will serve them together. (Inherited from IKitchenOrderCookingItem.)
Public property | ServeTime | Moment when item last time switched to the Served status. (Inherited from IKitchenOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IKitchenOrderCookingItem.)
Top
See Also

Reference

IKitchenOrderProductItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem.Amount Property

IKitchenOrderProductItemAmount Property

Product amount to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IKitchenOrderProductItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem.Modifiers Property

IKitchenOrderProductItemModifiers Property

Gets product modifiers. This collection is kitchen equivalent of simple and group child modifiers of the source product.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenOrderModifierItem> Modifiers { get; }

Property Value

Type: IReadOnlyList IKitchenOrderModifierItem
See Also

Reference

IKitchenOrderProductItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem.Product Property

IKitchenOrderProductItemProduct Property

Product to be cooked.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IKitchenOrderProductItem Interface
Resto.Front.Api.Data.Kitchen Namespace


IKitchenOrderProductItem Methods

The IKitchenOrderProductItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenOrderProductItem Interface
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderCompoundItemComponentDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderCompoundItemComponentDto

The KitchenOrderCompoundItemComponentDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderCompoundItemComponentDto | Initializes a new instance of the KitchenOrderCompoundItemComponentDto class
Public method | KitchenOrderCompoundItemComponentDto(Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto) | Initializes a new instance of the KitchenOrderCompoundItemComponentDto class
Top
Properties
 | Name | Description
Public property | Amount |
Public property | BaseCompoundItemComponentId |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | Modifiers |
Public property | ProductId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Constructor

Overload List
 | Name | Description
Public method | KitchenOrderCompoundItemComponentDto | Initializes a new instance of the KitchenOrderCompoundItemComponentDto class
Public method | KitchenOrderCompoundItemComponentDto(Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto) | Initializes a new instance of the KitchenOrderCompoundItemComponentDto class
Top
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Constructor

Initializes a new instance of the KitchenOrderCompoundItemComponentDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemComponentDto()
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
KitchenOrderCompoundItemComponentDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Constructor (Guid, Guid, Guid, Decimal, IReadOnlyCollection(KitchenOrderModifierItemDto))

KitchenOrderCompoundItemComponentDto Constructor (Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto)

Initializes a new instance of the KitchenOrderCompoundItemComponentDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemComponentDto(
    Guid baseCompoundItemComponentId,
    Guid productId,
    Guid itemSaleEventId,
    decimal amount,
    IReadOnlyCollection<KitchenOrderModifierItemDto> modifiers
)

Parameters

baseCompoundItemComponentId
Type: SystemGuid
productId
Type: SystemGuid
itemSaleEventId
Type: SystemGuid
amount
Type: SystemDecimal
modifiers
Type: System.Collections.GenericIReadOnlyCollection KitchenOrderModifierItemDto
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
KitchenOrderCompoundItemComponentDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Properties

The KitchenOrderCompoundItemComponentDto type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | BaseCompoundItemComponentId |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | Modifiers |
Public property | ProductId |
Top
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.Amount Property

KitchenOrderCompoundItemComponentDtoAmount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Amount { get; set; }

Property Value

Type: Decimal
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.BaseCompoundItemComponentId Property

KitchenOrderCompoundItemComponentDtoBaseCompoundItemComponentId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid BaseCompoundItemComponentId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.ItemCookingEventId Property

KitchenOrderCompoundItemComponentDtoItemCookingEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemCookingEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.ItemSaleEventId Property

KitchenOrderCompoundItemComponentDtoItemSaleEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemSaleEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.Modifiers Property

KitchenOrderCompoundItemComponentDtoModifiers Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<KitchenOrderModifierItemDto> Modifiers { get; set; }

Property Value

Type: IReadOnlyCollection KitchenOrderModifierItemDto
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto.ProductId Property

KitchenOrderCompoundItemComponentDtoProductId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ProductId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemComponentDto Methods

The KitchenOrderCompoundItemComponentDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderCompoundItemComponentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderCompoundItemDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderCompoundItemDto : IKitchenOrderCookingItemDto

The KitchenOrderCompoundItemDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderCompoundItemDto | Initializes a new instance of the KitchenOrderCompoundItemDto class
Public method | KitchenOrderCompoundItemDto(Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, IReadOnlyCollectionKitchenOrderModifierItemDto, KitchenOrderCompoundItemComponentDto, KitchenOrderCompoundItemComponentDto) | Initializes a new instance of the KitchenOrderCompoundItemDto class
Top
Properties
 | Name | Description
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CommonModifiers |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | ModifierSchemaId |
Public property | OrderRank |
Public property | PrimaryComponent |
Public property | PrintTime |
Public property | ProductSizeId |
Public property | SecondaryComponent |
Public property | ServeGroupNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Constructor

Overload List
 | Name | Description
Public method | KitchenOrderCompoundItemDto | Initializes a new instance of the KitchenOrderCompoundItemDto class
Public method | KitchenOrderCompoundItemDto(Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, IReadOnlyCollectionKitchenOrderModifierItemDto, KitchenOrderCompoundItemComponentDto, KitchenOrderCompoundItemComponentDto) | Initializes a new instance of the KitchenOrderCompoundItemDto class
Top
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Constructor

Initializes a new instance of the KitchenOrderCompoundItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemDto()
See Also

Reference

KitchenOrderCompoundItemDto Class
KitchenOrderCompoundItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Constructor (Guid, Guid, Guid, Nullable(TimeSpan), DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, Nullable(Guid), Guid, IReadOnlyCollection(KitchenOrderModifierItemDto), KitchenOrderCompoundItemComponentDto, KitchenOrderCompoundItemComponentDto)

KitchenOrderCompoundItemDto Constructor (Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, IReadOnlyCollectionKitchenOrderModifierItemDto, KitchenOrderCompoundItemComponentDto, KitchenOrderCompoundItemComponentDto)

Initializes a new instance of the KitchenOrderCompoundItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemDto(
    Guid baseOrderItemId,
    Guid cookingPlaceId,
    Guid cookingPlaceTypeId,
    TimeSpan? cookingTime,
    DateTime printTime,
    int serveGroupNumber,
    int orderRank,
    string guestName,
    KitchenOrderItemCommentDto comment,
    Guid? productSizeId,
    Guid modifierSchemaId,
    IReadOnlyCollection<KitchenOrderModifierItemDto> commonModifiers,
    KitchenOrderCompoundItemComponentDto primaryComponent,
    KitchenOrderCompoundItemComponentDto secondaryComponent
)

Parameters

baseOrderItemId
Type: SystemGuid
cookingPlaceId
Type: SystemGuid
cookingPlaceTypeId
Type: SystemGuid
cookingTime
Type: SystemNullable TimeSpan
printTime
Type: SystemDateTime
serveGroupNumber
Type: SystemInt32
orderRank
Type: SystemInt32
guestName
Type: SystemString
comment
Type: Resto.Front.Api.Data.KitchenKitchenOrderItemCommentDto
productSizeId
Type: SystemNullable Guid
modifierSchemaId
Type: SystemGuid
commonModifiers
Type: System.Collections.GenericIReadOnlyCollection KitchenOrderModifierItemDto
primaryComponent
Type: Resto.Front.Api.Data.KitchenKitchenOrderCompoundItemComponentDto
secondaryComponent
Type: Resto.Front.Api.Data.KitchenKitchenOrderCompoundItemComponentDto
See Also

Reference

KitchenOrderCompoundItemDto Class
KitchenOrderCompoundItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Properties

The KitchenOrderCompoundItemDto type exposes the following members.

Properties
 | Name | Description
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CommonModifiers |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | ModifierSchemaId |
Public property | OrderRank |
Public property | PrimaryComponent |
Public property | PrintTime |
Public property | ProductSizeId |
Public property | SecondaryComponent |
Public property | ServeGroupNumber |
Top
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.BaseOrderItemId Property

KitchenOrderCompoundItemDtoBaseOrderItemId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid BaseOrderItemId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoBaseOrderItemId
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.Comment Property

KitchenOrderCompoundItemDtoComment Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderItemCommentDto Comment { get; set; }

Property Value

Type: KitchenOrderItemCommentDto

Implements

IKitchenOrderCookingItemDtoComment
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.CommonModifiers Property

KitchenOrderCompoundItemDtoCommonModifiers Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<KitchenOrderModifierItemDto> CommonModifiers { get; set; }

Property Value

Type: IReadOnlyCollection KitchenOrderModifierItemDto
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.CookingPlaceId Property

KitchenOrderCompoundItemDtoCookingPlaceId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoCookingPlaceId
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.CookingPlaceTypeId Property

KitchenOrderCompoundItemDtoCookingPlaceTypeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceTypeId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoCookingPlaceTypeId
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.CookingTime Property

KitchenOrderCompoundItemDtoCookingTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan? CookingTime { get; set; }

Property Value

Type: Nullable TimeSpan

Implements

IKitchenOrderCookingItemDtoCookingTime
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.GuestName Property

KitchenOrderCompoundItemDtoGuestName Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string GuestName { get; set; }

Property Value

Type: String

Implements

IKitchenOrderCookingItemDtoGuestName
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.ModifierSchemaId Property

KitchenOrderCompoundItemDtoModifierSchemaId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ModifierSchemaId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.OrderRank Property

KitchenOrderCompoundItemDtoOrderRank Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int OrderRank { get; set; }

Property Value

Type: Int32

Implements

IKitchenOrderCookingItemDtoOrderRank
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.PrimaryComponent Property

KitchenOrderCompoundItemDtoPrimaryComponent Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemComponentDto PrimaryComponent { get; set; }

Property Value

Type: KitchenOrderCompoundItemComponentDto
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.PrintTime Property

KitchenOrderCompoundItemDtoPrintTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DateTime PrintTime { get; set; }

Property Value

Type: DateTime

Implements

IKitchenOrderCookingItemDtoPrintTime
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.ProductSizeId Property

KitchenOrderCompoundItemDtoProductSizeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? ProductSizeId { get; set; }

Property Value

Type: Nullable Guid

Implements

IKitchenOrderCookingItemDtoProductSizeId
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.SecondaryComponent Property

KitchenOrderCompoundItemDtoSecondaryComponent Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderCompoundItemComponentDto SecondaryComponent { get; set; }

Property Value

Type: KitchenOrderCompoundItemComponentDto
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto.ServeGroupNumber Property

KitchenOrderCompoundItemDtoServeGroupNumber Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int ServeGroupNumber { get; set; }

Property Value

Type: Int32

Implements

IKitchenOrderCookingItemDtoServeGroupNumber
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderCompoundItemDto Methods

The KitchenOrderCompoundItemDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderCompoundItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderDto

The KitchenOrderDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderDto | Initializes a new instance of the KitchenOrderDto class
Public method | KitchenOrderDto(Guid, Int32, NullableGuid, Guid, NullableGuid, DateTime, Int32, Int32, IReadOnlyCollectionIKitchenOrderCookingItemDto) | Initializes a new instance of the KitchenOrderDto class
Top
Properties
 | Name | Description
Public property | ActualGuestsCount |
Public property | BaseOrderId |
Public property | InitialGuestsCount |
Public property | Items |
Public property | Number |
Public property | OrderOpenTime |
Public property | OrderTypeId |
Public property | TableId |
Public property | WaiterId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Constructor

Overload List
 | Name | Description
Public method | KitchenOrderDto | Initializes a new instance of the KitchenOrderDto class
Public method | KitchenOrderDto(Guid, Int32, NullableGuid, Guid, NullableGuid, DateTime, Int32, Int32, IReadOnlyCollectionIKitchenOrderCookingItemDto) | Initializes a new instance of the KitchenOrderDto class
Top
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Constructor

Initializes a new instance of the KitchenOrderDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderDto()
See Also

Reference

KitchenOrderDto Class
KitchenOrderDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Constructor (Guid, Int32, Nullable(Guid), Guid, Nullable(Guid), DateTime, Int32, Int32, IReadOnlyCollection(IKitchenOrderCookingItemDto))

KitchenOrderDto Constructor (Guid, Int32, NullableGuid, Guid, NullableGuid, DateTime, Int32, Int32, IReadOnlyCollectionIKitchenOrderCookingItemDto)

Initializes a new instance of the KitchenOrderDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderDto(
    Guid baseOrderId,
    int number,
    Guid? orderTypeId,
    Guid tableId,
    Guid? waiterId,
    DateTime orderOpenTime,
    int initialGuestsCount,
    int actualGuestsCount,
    IReadOnlyCollection<IKitchenOrderCookingItemDto> items
)

Parameters

baseOrderId
Type: SystemGuid
number
Type: SystemInt32
orderTypeId
Type: SystemNullable Guid
tableId
Type: SystemGuid
waiterId
Type: SystemNullable Guid
orderOpenTime
Type: SystemDateTime
initialGuestsCount
Type: SystemInt32
actualGuestsCount
Type: SystemInt32
items
Type: System.Collections.GenericIReadOnlyCollection IKitchenOrderCookingItemDto
See Also

Reference

KitchenOrderDto Class
KitchenOrderDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Properties

The KitchenOrderDto type exposes the following members.

Properties
 | Name | Description
Public property | ActualGuestsCount |
Public property | BaseOrderId |
Public property | InitialGuestsCount |
Public property | Items |
Public property | Number |
Public property | OrderOpenTime |
Public property | OrderTypeId |
Public property | TableId |
Public property | WaiterId |
Top
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.ActualGuestsCount Property

KitchenOrderDtoActualGuestsCount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int ActualGuestsCount { get; set; }

Property Value

Type: Int32
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.BaseOrderId Property

KitchenOrderDtoBaseOrderId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid BaseOrderId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.InitialGuestsCount Property

KitchenOrderDtoInitialGuestsCount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int InitialGuestsCount { get; set; }

Property Value

Type: Int32
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.Items Property

KitchenOrderDtoItems Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<IKitchenOrderCookingItemDto> Items { get; set; }

Property Value

Type: IReadOnlyCollection IKitchenOrderCookingItemDto
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.Number Property

KitchenOrderDtoNumber Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Number { get; set; }

Property Value

Type: Int32
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.OrderOpenTime Property

KitchenOrderDtoOrderOpenTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DateTime OrderOpenTime { get; set; }

Property Value

Type: DateTime
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.OrderTypeId Property

KitchenOrderDtoOrderTypeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? OrderTypeId { get; set; }

Property Value

Type: Nullable Guid
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.TableId Property

KitchenOrderDtoTableId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid TableId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto.WaiterId Property

KitchenOrderDtoWaiterId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? WaiterId { get; set; }

Property Value

Type: Nullable Guid
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderDto Methods

The KitchenOrderDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderItemCommentDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderItemCommentDto

The KitchenOrderItemCommentDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderItemCommentDto | Initializes a new instance of the KitchenOrderItemCommentDto class
Top
Properties
 | Name | Description
Public property | Comment |
Public property | Deleted |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto Constructor

Initializes a new instance of the KitchenOrderItemCommentDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderItemCommentDto(
    string comment,
    bool deleted
)

Parameters

comment
Type: SystemString
deleted
Type: SystemBoolean
See Also

Reference

KitchenOrderItemCommentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto Properties

The KitchenOrderItemCommentDto type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Deleted |
Top
See Also

Reference

KitchenOrderItemCommentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto.Comment Property

KitchenOrderItemCommentDtoComment Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Comment { get; }

Property Value

Type: String
See Also

Reference

KitchenOrderItemCommentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto.Deleted Property

KitchenOrderItemCommentDtoDeleted Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

KitchenOrderItemCommentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemCommentDto Methods

The KitchenOrderItemCommentDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderItemCommentDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderItemProcessingStatus Enumeration

Describes order item processing lifecycle from kitchen point of view.

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum KitchenOrderItemProcessingStatus
Members
Member name | Value | Description
Idle | 0 | Order item was printed, but cooking didn't start yet.
Processing1 | 1 | Order item cooking was started, cooking is in first step progress.
Processing2 | 2 | Order item cooking was started, cooking is in second step progress.
Processing3 | 3 | Order item cooking was started, cooking is in third step progress.
Processing4 | 4 | Order item cooking was started, cooking is in fourth step progress.
Processed | 5 | Order item cooking completed, dish is ready to be served.
Served | 6 | Order item was cooked and served.
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderModifierItemDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderModifierItemDto

The KitchenOrderModifierItemDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderModifierItemDto | Initializes a new instance of the KitchenOrderModifierItemDto class
Public method | KitchenOrderModifierItemDto(Guid, Guid, Guid, NullableTimeSpan, Boolean, TupleInt32, Int32, Boolean, Boolean, Guid, Guid, Guid, Decimal) | Initializes a new instance of the KitchenOrderModifierItemDto class
Top
Properties
 | Name | Description
Public property | Amount |
Public property | AmountIndependentOfParentAmount |
Public property | BaseOrderItemId |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | IsHidden |
Public property | IsSeparate |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | OrderRank |
Public property | ProductId |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Constructor

Overload List
 | Name | Description
Public method | KitchenOrderModifierItemDto | Initializes a new instance of the KitchenOrderModifierItemDto class
Public method | KitchenOrderModifierItemDto(Guid, Guid, Guid, NullableTimeSpan, Boolean, TupleInt32, Int32, Boolean, Boolean, Guid, Guid, Guid, Decimal) | Initializes a new instance of the KitchenOrderModifierItemDto class
Top
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Constructor

Initializes a new instance of the KitchenOrderModifierItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderModifierItemDto()
See Also

Reference

KitchenOrderModifierItemDto Class
KitchenOrderModifierItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Constructor (Guid, Guid, Guid, Nullable(TimeSpan), Boolean, Tuple(Int32, Int32), Boolean, Boolean, Guid, Guid, Guid, Decimal)

KitchenOrderModifierItemDto Constructor (Guid, Guid, Guid, NullableTimeSpan, Boolean, TupleInt32, Int32, Boolean, Boolean, Guid, Guid, Guid, Decimal)

Initializes a new instance of the KitchenOrderModifierItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderModifierItemDto(
    Guid baseOrderItemId,
    Guid cookingPlaceId,
    Guid cookingPlaceTypeId,
    TimeSpan? cookingTime,
    bool isSeparate,
    Tuple<int, int> orderRank,
    bool amountIndependentOfParentAmount,
    bool isHidden,
    Guid productId,
    Guid itemSaleEventId,
    Guid itemCookingEventId,
    decimal amount
)

Parameters

baseOrderItemId
Type: SystemGuid
cookingPlaceId
Type: SystemGuid
cookingPlaceTypeId
Type: SystemGuid
cookingTime
Type: SystemNullable TimeSpan
isSeparate
Type: SystemBoolean
orderRank
Type: SystemTuple Int32, Int32
amountIndependentOfParentAmount
Type: SystemBoolean
isHidden
Type: SystemBoolean
productId
Type: SystemGuid
itemSaleEventId
Type: SystemGuid
itemCookingEventId
Type: SystemGuid
amount
Type: SystemDecimal
See Also

Reference

KitchenOrderModifierItemDto Class
KitchenOrderModifierItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Properties

The KitchenOrderModifierItemDto type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | AmountIndependentOfParentAmount |
Public property | BaseOrderItemId |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | IsHidden |
Public property | IsSeparate |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | OrderRank |
Public property | ProductId |
Top
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.Amount Property

KitchenOrderModifierItemDtoAmount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Amount { get; set; }

Property Value

Type: Decimal
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.AmountIndependentOfParentAmount Property

KitchenOrderModifierItemDtoAmountIndependentOfParentAmount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool AmountIndependentOfParentAmount { get; set; }

Property Value

Type: Boolean
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.BaseOrderItemId Property

KitchenOrderModifierItemDtoBaseOrderItemId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid BaseOrderItemId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.CookingPlaceId Property

KitchenOrderModifierItemDtoCookingPlaceId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.CookingPlaceTypeId Property

KitchenOrderModifierItemDtoCookingPlaceTypeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceTypeId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.CookingTime Property

KitchenOrderModifierItemDtoCookingTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan? CookingTime { get; set; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.IsHidden Property

KitchenOrderModifierItemDtoIsHidden Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsHidden { get; set; }

Property Value

Type: Boolean
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.IsSeparate Property

KitchenOrderModifierItemDtoIsSeparate Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsSeparate { get; set; }

Property Value

Type: Boolean
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.ItemCookingEventId Property

KitchenOrderModifierItemDtoItemCookingEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemCookingEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.ItemSaleEventId Property

KitchenOrderModifierItemDtoItemSaleEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemSaleEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.OrderRank Property

KitchenOrderModifierItemDtoOrderRank Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Tuple<int, int> OrderRank { get; set; }

Property Value

Type: Tuple Int32, Int32
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto.ProductId Property

KitchenOrderModifierItemDtoProductId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ProductId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderModifierItemDto Methods

The KitchenOrderModifierItemDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderModifierItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.KitchenKitchenOrderProductItemDto

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class KitchenOrderProductItemDto : IKitchenOrderCookingItemDto

The KitchenOrderProductItemDto type exposes the following members.

Constructors
 | Name | Description
Public method | KitchenOrderProductItemDto | Initializes a new instance of the KitchenOrderProductItemDto class
Public method | KitchenOrderProductItemDto(Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto) | Initializes a new instance of the KitchenOrderProductItemDto class
Top
Properties
 | Name | Description
Public property | Amount |
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | Modifiers |
Public property | OrderRank |
Public property | PrintTime |
Public property | ProductId |
Public property | ProductSizeId |
Public property | ServeGroupNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Constructor

Overload List
 | Name | Description
Public method | KitchenOrderProductItemDto | Initializes a new instance of the KitchenOrderProductItemDto class
Public method | KitchenOrderProductItemDto(Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto) | Initializes a new instance of the KitchenOrderProductItemDto class
Top
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Constructor

Initializes a new instance of the KitchenOrderProductItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderProductItemDto()
See Also

Reference

KitchenOrderProductItemDto Class
KitchenOrderProductItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Constructor (Guid, Guid, Guid, Nullable(TimeSpan), DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, Nullable(Guid), Guid, Guid, Guid, Decimal, IReadOnlyCollection(KitchenOrderModifierItemDto))

KitchenOrderProductItemDto Constructor (Guid, Guid, Guid, NullableTimeSpan, DateTime, Int32, Int32, String, KitchenOrderItemCommentDto, NullableGuid, Guid, Guid, Guid, Decimal, IReadOnlyCollectionKitchenOrderModifierItemDto)

Initializes a new instance of the KitchenOrderProductItemDto class

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderProductItemDto(
    Guid baseOrderItemId,
    Guid cookingPlaceId,
    Guid cookingPlaceTypeId,
    TimeSpan? cookingTime,
    DateTime printTime,
    int serveGroupNumber,
    int orderRank,
    string guestName,
    KitchenOrderItemCommentDto comment,
    Guid? productSizeId,
    Guid productId,
    Guid itemSaleEventId,
    Guid itemCookingEventId,
    decimal amount,
    IReadOnlyCollection<KitchenOrderModifierItemDto> modifiers
)

Parameters

baseOrderItemId
Type: SystemGuid
cookingPlaceId
Type: SystemGuid
cookingPlaceTypeId
Type: SystemGuid
cookingTime
Type: SystemNullable TimeSpan
printTime
Type: SystemDateTime
serveGroupNumber
Type: SystemInt32
orderRank
Type: SystemInt32
guestName
Type: SystemString
comment
Type: Resto.Front.Api.Data.KitchenKitchenOrderItemCommentDto
productSizeId
Type: SystemNullable Guid
productId
Type: SystemGuid
itemSaleEventId
Type: SystemGuid
itemCookingEventId
Type: SystemGuid
amount
Type: SystemDecimal
modifiers
Type: System.Collections.GenericIReadOnlyCollection KitchenOrderModifierItemDto
See Also

Reference

KitchenOrderProductItemDto Class
KitchenOrderProductItemDto Overload
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Properties

The KitchenOrderProductItemDto type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | BaseOrderItemId |
Public property | Comment |
Public property | CookingPlaceId |
Public property | CookingPlaceTypeId |
Public property | CookingTime |
Public property | GuestName |
Public property | ItemCookingEventId |
Public property | ItemSaleEventId |
Public property | Modifiers |
Public property | OrderRank |
Public property | PrintTime |
Public property | ProductId |
Public property | ProductSizeId |
Public property | ServeGroupNumber |
Top
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.Amount Property

KitchenOrderProductItemDtoAmount Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Amount { get; set; }

Property Value

Type: Decimal
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.BaseOrderItemId Property

KitchenOrderProductItemDtoBaseOrderItemId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid BaseOrderItemId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoBaseOrderItemId
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.Comment Property

KitchenOrderProductItemDtoComment Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public KitchenOrderItemCommentDto Comment { get; set; }

Property Value

Type: KitchenOrderItemCommentDto

Implements

IKitchenOrderCookingItemDtoComment
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.CookingPlaceId Property

KitchenOrderProductItemDtoCookingPlaceId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoCookingPlaceId
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.CookingPlaceTypeId Property

KitchenOrderProductItemDtoCookingPlaceTypeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CookingPlaceTypeId { get; set; }

Property Value

Type: Guid

Implements

IKitchenOrderCookingItemDtoCookingPlaceTypeId
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.CookingTime Property

KitchenOrderProductItemDtoCookingTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan? CookingTime { get; set; }

Property Value

Type: Nullable TimeSpan

Implements

IKitchenOrderCookingItemDtoCookingTime
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.GuestName Property

KitchenOrderProductItemDtoGuestName Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string GuestName { get; set; }

Property Value

Type: String

Implements

IKitchenOrderCookingItemDtoGuestName
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.ItemCookingEventId Property

KitchenOrderProductItemDtoItemCookingEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemCookingEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.ItemSaleEventId Property

KitchenOrderProductItemDtoItemSaleEventId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ItemSaleEventId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.Modifiers Property

KitchenOrderProductItemDtoModifiers Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<KitchenOrderModifierItemDto> Modifiers { get; set; }

Property Value

Type: IReadOnlyCollection KitchenOrderModifierItemDto
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.OrderRank Property

KitchenOrderProductItemDtoOrderRank Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int OrderRank { get; set; }

Property Value

Type: Int32

Implements

IKitchenOrderCookingItemDtoOrderRank
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.PrintTime Property

KitchenOrderProductItemDtoPrintTime Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DateTime PrintTime { get; set; }

Property Value

Type: DateTime

Implements

IKitchenOrderCookingItemDtoPrintTime
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.ProductId Property

KitchenOrderProductItemDtoProductId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid ProductId { get; set; }

Property Value

Type: Guid
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.ProductSizeId Property

KitchenOrderProductItemDtoProductSizeId Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? ProductSizeId { get; set; }

Property Value

Type: Nullable Guid

Implements

IKitchenOrderCookingItemDtoProductSizeId
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto.ServeGroupNumber Property

KitchenOrderProductItemDtoServeGroupNumber Property

Namespace: Resto.Front.Api.Data.Kitchen
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int ServeGroupNumber { get; set; }

Property Value

Type: Int32

Implements

IKitchenOrderCookingItemDtoServeGroupNumber
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


KitchenOrderProductItemDto Methods

The KitchenOrderProductItemDto type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

KitchenOrderProductItemDto Class
Resto.Front.Api.Data.Kitchen Namespace


Resto.Front.Api.Data.Orders Namespace

Classes
 | Class | Description
Public class | DiscountForOrderItem | Describes discount for specific order item like IOrderRootItem, modifier IOrderModifierItem or compound product component IOrderCompoundItemComponent.
Public class | IikoCardDiscount | Describes DTO for iikoCard discount using by AddIikoCardDiscounts action AddIikoCardDiscounts(IReadOnlyCollectionIikoCardDiscount, IOrderStub).
Public class | ProductsSellingRestrictions | Check result of CheckProductsSellingRestrictions(ICredentials, DictionaryIProduct, Decimal) method.
Public class | RateSchedule | A schedule of a service rates.
Public class | RateScheduleItem | Item of a RateSchedule describing rate of one or more time intervals (Intervals).
Public class | WriteoffOptions | Options to delete and write-off printed order items.
Structures
 | Structure | Description
Public structure | RateScheduleInterval | Describes a time interval within a week, which is used in RateSchedule.
Interfaces
 | Interface | Description
Public interface | IAllergenGroup |
Public interface | IAppliedDiscountItem | The result of applying discount item, contains discount sums.
Public interface | ICookingPlaceType | Cooking place type.
Public interface | ICourierWorkload |
Public interface | IDeletionMethod |
Public interface | IDeliveryOrder |
Public interface | IDeliveryTerminalWorkload |
Public interface | IDiscountCard | Discount card is a part of loyalty system which allows to provide reduced prices for loyal clients using either a discount or a special price category.
Public interface | IDiscountItem | Discount item is the result of adding discount to an order, contains discount parameters, which will be used to calculate sums. While discount params are persistent, discount sums are calculated on demand, because they are subject to change (they may depend on the time, etc). Call GetOrderAppliedDiscounts(IOrder) to get calculated sums.
Public interface | IDiscountType |
Public interface | IFixedChildModifier |
Public interface | IFixedGroupModifier |
Public interface | IFixedSimpleModifier |
Public interface | IFrontDeliverySettings |
Public interface | IIikoCard51OrderInfo |
Public interface | IKitchenWorkload |
Public interface | IOrder |
Public interface | IOrderCombo |
Public interface | IOrderCompoundItem | Templated order item representing one or two combined products.
Public interface | IOrderCompoundItemComponent | Element of the compound item representing one of its products.
Public interface | IOrderCookingItem | Base type for all foody order items (those which may be cooked in the kitchen).
Public interface | IOrderCookingItemComment |
Public interface | IOrderGuestItem |
Public interface | IOrderModifierItem |
Public interface | IOrderProductItem | Regular order item representing single product.
Public interface | IOrderRootItem | Base type for all order items.
Public interface | IOrderServiceItem | Order item representing time pay service.
Public interface | IOrderServiceItemPeriod | Period of a service item.
Public interface | IPastOrder |
Public interface | IPastOrderHrsTransaction |
Public interface | IPastOrderItem |
Public interface | IPastOrderPayment |
Public interface | IPriceCategory |
Public interface | IRemovalType |
Public interface | ISelectiveDiscountItemSettings | Order items to which the discount item is applied selectively.
Enumerations
 | Enumeration | Description
Public enumeration | CheckSplitRequiredResult | Checking should you call SplitOrderBetweenCashRegisters(ICredentials, IOrder) or not.
Public enumeration | OrderItemCourse | Describes the course (cooking and serving sequence) of an order item.
Public enumeration | OrderItemStatus | Describes the status of an order item.
Public enumeration | OrderStatus | Describes the status of an order.
Public enumeration | PaymentStatus |
Public enumeration | ProductsSellingPossibility | Member of ProductsSellingRestrictions, check result of CheckProductsSellingRestrictions(ICredentials, DictionaryIProduct, Decimal) method.
Public enumeration | ServiceTimingMode | Time rate calculation modes, which specifies how to treat rate schedule interval bounds.
Public enumeration | WriteoffOptionsType | Describes the write-off type, which required to delete printed dishes.
Public enumeration | WriteoffType | Describes available write-off types of removal type.


CheckSplitRequiredResult Enumeration

Checking should you call SplitOrderBetweenCashRegisters(ICredentials, IOrder) or not.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum CheckSplitRequiredResult
Members
Member name | Value | Description
Disabled | 0 | Not necessary to split order by calling SplitOrderBetweenCashRegisters(ICredentials, IOrder) before any payment actions.
Allowed | 1 | You should ask user whether call SplitOrderBetweenCashRegisters(ICredentials, IOrder) or not before calling PayOrderAndPayOutOnUser(ICredentials, IOrder, IPaymentType, Decimal, ChequeAdditionalInfo) and PayOrder(ICredentials, IOrder, ChequeAdditionalInfo).
Required | 2 | Necessary to split order by calling SplitOrderBetweenCashRegisters(ICredentials, IOrder) before any payment actions. If you won't do this, PayOrderAndPayOutOnUser(ICredentials, IOrder, IPaymentType, Decimal, ChequeAdditionalInfo) and PayOrder(ICredentials, IOrder, ChequeAdditionalInfo) will throw exception.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem Class

Describes discount for specific order item like IOrderRootItem, modifier IOrderModifierItem or compound product component IOrderCompoundItemComponent.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersDiscountForOrderItem

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DiscountForOrderItem

The DiscountForOrderItem type exposes the following members.

Constructors
 | Name | Description
Public method | DiscountForOrderItem | Initializes a new instance of the DiscountForOrderItem class.
Top
Properties
 | Name | Description
Public property | Amount | The discount amount is a part of the dish amount that this discount applies to. The discount amount is equal to the dish amount if the discount applies to the whole item, otherwise the discount amount must be between zero and the dish amount.
Public property | OrderItemId | Order item id.
Public property | Sum | Sum of discount.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem Constructor

Initializes a new instance of the DiscountForOrderItem class.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DiscountForOrderItem(
    Guid orderItemId,
    decimal sum,
    decimal amount
)

Parameters

orderItemId
Type: SystemGuid
Order item id
sum
Type: SystemDecimal
Sum of discount
amount
Type: SystemDecimal
The discount amount is a part of the dish amount that this discount applies to. The discount amount is equal to the dish amount if the discount applies to the whole item, otherwise the discount amount must be between zero and the dish amount.
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem Properties

The DiscountForOrderItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | The discount amount is a part of the dish amount that this discount applies to. The discount amount is equal to the dish amount if the discount applies to the whole item, otherwise the discount amount must be between zero and the dish amount.
Public property | OrderItemId | Order item id.
Public property | Sum | Sum of discount.
Top
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem.Amount Property

DiscountForOrderItemAmount Property

The discount amount is a part of the dish amount that this discount applies to. The discount amount is equal to the dish amount if the discount applies to the whole item, otherwise the discount amount must be between zero and the dish amount.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem.OrderItemId Property

DiscountForOrderItemOrderItemId Property

Order item id.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid OrderItemId { get; }

Property Value

Type: Guid
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem.Sum Property

DiscountForOrderItemSum Property

Sum of discount.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public decimal Sum { get; }

Property Value

Type: Decimal
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


DiscountForOrderItem Methods

The DiscountForOrderItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiscountForOrderItem Class
Resto.Front.Api.Data.Orders Namespace


IAllergenGroup Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IAllergenGroup : ISerializable

The IAllergenGroup type exposes the following members.

Properties
 | Name | Description
Public property | Code |
Public property | Name |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IAllergenGroup Properties

The IAllergenGroup type exposes the following members.

Properties
 | Name | Description
Public property | Code |
Public property | Name |
Top
See Also

Reference

IAllergenGroup Interface
Resto.Front.Api.Data.Orders Namespace


IAllergenGroup.Code Property

IAllergenGroupCode Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Code { get; }

Property Value

Type: String
See Also

Reference

IAllergenGroup Interface
Resto.Front.Api.Data.Orders Namespace


IAllergenGroup.Name Property

IAllergenGroupName Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IAllergenGroup Interface
Resto.Front.Api.Data.Orders Namespace


IAllergenGroup Methods

The IAllergenGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IAllergenGroup Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem Interface

The result of applying discount item, contains discount sums.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IAppliedDiscountItem : ISerializable

The IAppliedDiscountItem type exposes the following members.

Properties
 | Name | Description
Public property | Discount | The discount item.
Public property | DiscountSum | Total discount sum given by the discount item for all order items.
Public property | DiscountSumByOrderItemId | Discount sums given by the discount item for each order item (products, compounds, services and modifiers). Absence of some order item's id means zero discount for that item.
Public property | IsRounding | Indicates that the discount was used to round off the order sum. Depending on the settings, rounding can be performed up or down for individual items as well as for the entire order.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem Properties

The IAppliedDiscountItem type exposes the following members.

Properties
 | Name | Description
Public property | Discount | The discount item.
Public property | DiscountSum | Total discount sum given by the discount item for all order items.
Public property | DiscountSumByOrderItemId | Discount sums given by the discount item for each order item (products, compounds, services and modifiers). Absence of some order item's id means zero discount for that item.
Public property | IsRounding | Indicates that the discount was used to round off the order sum. Depending on the settings, rounding can be performed up or down for individual items as well as for the entire order.
Top
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem.Discount Property

IAppliedDiscountItemDiscount Property

The discount item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountItem Discount { get; }

Property Value

Type: IDiscountItem
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem.DiscountSum Property

IAppliedDiscountItemDiscountSum Property

Total discount sum given by the discount item for all order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal DiscountSum { get; }

Property Value

Type: Decimal
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem.DiscountSumByOrderItemId Property

IAppliedDiscountItemDiscountSumByOrderItemId Property

Discount sums given by the discount item for each order item (products, compounds, services and modifiers). Absence of some order item's id means zero discount for that item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyDictionary<Guid, decimal> DiscountSumByOrderItemId { get; }

Property Value

Type: IReadOnlyDictionary Guid, Decimal
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem.IsRounding Property

IAppliedDiscountItemIsRounding Property

Indicates that the discount was used to round off the order sum. Depending on the settings, rounding can be performed up or down for individual items as well as for the entire order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsRounding { get; }

Property Value

Type: Boolean
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IAppliedDiscountItem Methods

The IAppliedDiscountItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IAppliedDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


ICookingPlaceType Interface

Cooking place type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICookingPlaceType : ISerializable

The ICookingPlaceType type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name | Name of cooking place type.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ICookingPlaceType Properties

The ICookingPlaceType type exposes the following members.

Properties
 | Name | Description
Public property | Id |
Public property | Name | Name of cooking place type.
Top
See Also

Reference

ICookingPlaceType Interface
Resto.Front.Api.Data.Orders Namespace


ICookingPlaceType.Id Property

ICookingPlaceTypeId Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid Id { get; }

Property Value

Type: Guid
See Also

Reference

ICookingPlaceType Interface
Resto.Front.Api.Data.Orders Namespace


ICookingPlaceType.Name Property

ICookingPlaceTypeName Property

Name of cooking place type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ICookingPlaceType Interface
Resto.Front.Api.Data.Orders Namespace


ICookingPlaceType Methods

The ICookingPlaceType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICookingPlaceType Interface
Resto.Front.Api.Data.Orders Namespace


ICourierWorkload Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICourierWorkload : ISerializable

The ICourierWorkload type exposes the following members.

Properties
 | Name | Description
Public property | Courier | Courier.
Public property | DeliveriesCount | Count of active (i.e. neither closed nor cancelled) deliveries assigned to courier.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ICourierWorkload Properties

The ICourierWorkload type exposes the following members.

Properties
 | Name | Description
Public property | Courier | Courier.
Public property | DeliveriesCount | Count of active (i.e. neither closed nor cancelled) deliveries assigned to courier.
Top
See Also

Reference

ICourierWorkload Interface
Resto.Front.Api.Data.Orders Namespace


ICourierWorkload.Courier Property

ICourierWorkloadCourier Property

Courier.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Courier { get; }

Property Value

Type: IUser
See Also

Reference

ICourierWorkload Interface
Resto.Front.Api.Data.Orders Namespace


ICourierWorkload.DeliveriesCount Property

ICourierWorkloadDeliveriesCount Property

Count of active (i.e. neither closed nor cancelled) deliveries assigned to courier.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int DeliveriesCount { get; }

Property Value

Type: Int32
See Also

Reference

ICourierWorkload Interface
Resto.Front.Api.Data.Orders Namespace


ICourierWorkload Methods

The ICourierWorkload type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICourierWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDeletionMethod Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeletionMethod : ISerializable

The IDeletionMethod type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Id |
Public property | RemovalType |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDeletionMethod Properties

The IDeletionMethod type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Id |
Public property | RemovalType |
Top
See Also

Reference

IDeletionMethod Interface
Resto.Front.Api.Data.Orders Namespace


IDeletionMethod.Comment Property

IDeletionMethodComment Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IDeletionMethod Interface
Resto.Front.Api.Data.Orders Namespace


IDeletionMethod.Id Property

IDeletionMethodId Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Id { get; }

Property Value

Type: String
See Also

Reference

IDeletionMethod Interface
Resto.Front.Api.Data.Orders Namespace


IDeletionMethod.RemovalType Property

IDeletionMethodRemovalType Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRemovalType RemovalType { get; }

Property Value

Type: IRemovalType
See Also

Reference

IDeletionMethod Interface
Resto.Front.Api.Data.Orders Namespace


IDeletionMethod Methods

The IDeletionMethod type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeletionMethod Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliveryOrder : IOrder,
    ISerializable, IEntity, IVersionedEntity, IOrderStub, IDeliveryOrderStub

The IDeliveryOrder type exposes the following members.

Properties
 | Name | Description
Public property | ActualDeliverTime | Time when order was actually delivered to the client
Public property | Address | Address where the order will be delivered
Public property | BillTime | Gets the bill cheque print time of the current order. (Inherited from IOrder.)
Public property | CafeAddress | Restaurant address
Public property | CancelCause | Cause of cancelling the order
Public property | CancelComment | Comment to the order cancellation
Public property | CancelTime | Time when the order was marked as cancelled
Public property | Cashier | Gets the user closed the current order. (Inherited from IOrder.)
Public property | Client | Client that placed the delivery.
Public property | ClientName | Name of client
Public property | CloseTime | Time when delivery order was marked as closed
Public property | Combos | (Inherited from IOrder.)
Public property | Comment | Client's comment on order
Public property | ConfirmTime | Time when order was confirmed
Public property | CookingFinishTime | Time when order cooking was finished
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic. (Inherited from IOrder.)
Public property | Courier | Courier that delivers the order
Public property | CreateTime | Time when order was created
Public property | CustomApiData | Custom data about delivery from Api
Public property | CustomerIds | (Inherited from IOrder.)
Public property | DeliveryId | Identifier of the delivery, don't confuse it with identifier of the delivery order. This property exists for historical reason, avoid using it when possible.
Public property | DeliveryOperator | User who created the order
Public property | DeliveryStatus | Status of the delivery
Public property | Discounts | (Inherited from IOrder.)
Public property | Donations | (Inherited from IOrder.)
Public property | Duration |
Public property | Email | E-mail of client
Public property | EstimatedGuestsCount | Gets estimated guests count, that is greater than or equal to added guests count. When single order is used to serve many people and handling each of them as a separate guest may be inconvenient, this property will indicate estimated guests count while guests collection will contain as many guests as needed for waiters. (Inherited from IOrder.)
Public property | ExpectedDeliverTime | Time when client wants the order to be delivered
Public property | ExpectedDuration | Duration calculated without overridden value on terminal
Public property | ExternalCourierServiceData | External service courier that delivers the order
Public property | FiscalChequeNumber | Fiscal cheque number. (Inherited from IOrder.)
Public property | FullSum | Subtotal, sum of all not deleted order items with included vat, but without excluded vat and discounts. (Inherited from IOrder.)
Public property | Guests | (Inherited from IOrder.)
Public property | HasProblem | Whether the order is marked as having problem
Public property | Id | (Inherited from IEntity.)
Public property | IikoCard51Info | Specific data for iikoCard51. (Inherited from IOrder.)
Public property | IndexInCourierRoute | Index of the order in courier route (zero-based)
Public property | IsBanquetOrder | Order is banquet. (Inherited from IOrder.)
Public property | IsCourierSelectedManually | Whether courier was selected from UI or automatically
Public property | IsCustomerAuthorizedInIikoBiz | Indicates whether customer is already authorized in iiko.biz, i.e. his credentials are verified
Public property | IsPrintedBillActual | Whether the order bill was already printed and since then it's considered to be actual. Also means whether the bill will be printed automatically according to settings: if it's not already printed, it will.
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false. (Inherited from IOrder.)
Public property | Items | (Inherited from IOrder.)
Public property | LastVerifiedDeliveryRestrictionsHash | Last verified on server delivery restrictions hash
Public property | Latitude | Latitude of geoposition of the delivery address
Public property | Longitude | Longitude of geoposition of the delivery address
Public property | MarketingSource | Advertising Source of the order (for example, some web site, call center)
Public property | MovedDeliveryId | New delivery identifier created for move to a new terminal
Public property | Number | (Inherited from IOrder.)
Public property | OpenTime | (Inherited from IOrder.)
Public property | OrderType | (Inherited from IOrder.)
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. (Inherited from IOrder.)
Public property | Payments | (Inherited from IOrder.)
Public property | Phone | Phone of client
Public property | PredictedCookingCompleteTime | Predicted time when order cooking should be completed
Public property | PredictedDeliveryTime | Predicted time when order should be delivered
Public property | PriceCategory | Price category. (Inherited from IOrder.)
Public property | PricingTime | Time, which determines the price of products. By default time is taken from items print time. (Inherited from IOrder.)
Public property | PrintTime | Time when products were printed
Public property | ProblemComment | Description of the problem. Non-empty ProblemComment doesn't mean delivery is currently has a problem: comment could been filled in earlier, and after that HasProblem flag was unchecked. That means that the order had some problems earlier.
Public property | ProcessedPaymentsSum | Sum of all processed payment items in order. (Inherited from IOrder.)
Public property | RepeatBillNumber | Number of repeated bills. (Inherited from IOrder.)
Public property | ResultSum | Total sum to be paid, sum of all not deleted order items with discounts and both included and excluded vat. (Inherited from IOrder.)
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | SendTime | Time when order was sent to client
Public property | SourceId | Identifier of the delivery that existed before splitting it by multiple cash registers. Depending on settings, a single delivery can be split by multiple cash registers before payment, producing multiple deliveries. At this moment SourceId of all produced deliveries is set to Id of the source delivery. If delivery was not splitted by cash registers, SourceId returns null.
Public property | SplitBetweenPersons | Indicates whether the order should be splitted between persons or not
Public property | Status | (Inherited from IOrder.)
Public property | StornedOrderId | Source order's identifier this order copied from during storno operation. null if the order has never storned. (Inherited from IOrder.)
Public property | Tables | (Inherited from IOrder.)
Public property | TabName | Optional marker used to specify that the order is a tab. This property contains name of the tab if the order is marked as tab, otherwise null. (Inherited from IOrder.)
Public property | Waiter | (Inherited from IOrder.)
Public property | WasPrepaid | Whether order was prepaid. Any processed or deleted prepay. (Inherited from IOrder.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder Properties

The IDeliveryOrder type exposes the following members.

Properties
 | Name | Description
Public property | ActualDeliverTime | Time when order was actually delivered to the client
Public property | Address | Address where the order will be delivered
Public property | BillTime | Gets the bill cheque print time of the current order. (Inherited from IOrder.)
Public property | CafeAddress | Restaurant address
Public property | CancelCause | Cause of cancelling the order
Public property | CancelComment | Comment to the order cancellation
Public property | CancelTime | Time when the order was marked as cancelled
Public property | Cashier | Gets the user closed the current order. (Inherited from IOrder.)
Public property | Client | Client that placed the delivery.
Public property | ClientName | Name of client
Public property | CloseTime | Time when delivery order was marked as closed
Public property | Combos | (Inherited from IOrder.)
Public property | Comment | Client's comment on order
Public property | ConfirmTime | Time when order was confirmed
Public property | CookingFinishTime | Time when order cooking was finished
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic. (Inherited from IOrder.)
Public property | Courier | Courier that delivers the order
Public property | CreateTime | Time when order was created
Public property | CustomApiData | Custom data about delivery from Api
Public property | CustomerIds | (Inherited from IOrder.)
Public property | DeliveryId | Identifier of the delivery, don't confuse it with identifier of the delivery order. This property exists for historical reason, avoid using it when possible.
Public property | DeliveryOperator | User who created the order
Public property | DeliveryStatus | Status of the delivery
Public property | Discounts | (Inherited from IOrder.)
Public property | Donations | (Inherited from IOrder.)
Public property | Duration |
Public property | Email | E-mail of client
Public property | EstimatedGuestsCount | Gets estimated guests count, that is greater than or equal to added guests count. When single order is used to serve many people and handling each of them as a separate guest may be inconvenient, this property will indicate estimated guests count while guests collection will contain as many guests as needed for waiters. (Inherited from IOrder.)
Public property | ExpectedDeliverTime | Time when client wants the order to be delivered
Public property | ExpectedDuration | Duration calculated without overridden value on terminal
Public property | ExternalCourierServiceData | External service courier that delivers the order
Public property | FiscalChequeNumber | Fiscal cheque number. (Inherited from IOrder.)
Public property | FullSum | Subtotal, sum of all not deleted order items with included vat, but without excluded vat and discounts. (Inherited from IOrder.)
Public property | Guests | (Inherited from IOrder.)
Public property | HasProblem | Whether the order is marked as having problem
Public property | Id | (Inherited from IEntity.)
Public property | IikoCard51Info | Specific data for iikoCard51. (Inherited from IOrder.)
Public property | IndexInCourierRoute | Index of the order in courier route (zero-based)
Public property | IsBanquetOrder | Order is banquet. (Inherited from IOrder.)
Public property | IsCourierSelectedManually | Whether courier was selected from UI or automatically
Public property | IsCustomerAuthorizedInIikoBiz | Indicates whether customer is already authorized in iiko.biz, i.e. his credentials are verified
Public property | IsPrintedBillActual | Whether the order bill was already printed and since then it's considered to be actual. Also means whether the bill will be printed automatically according to settings: if it's not already printed, it will.
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false. (Inherited from IOrder.)
Public property | Items | (Inherited from IOrder.)
Public property | LastVerifiedDeliveryRestrictionsHash | Last verified on server delivery restrictions hash
Public property | Latitude | Latitude of geoposition of the delivery address
Public property | Longitude | Longitude of geoposition of the delivery address
Public property | MarketingSource | Advertising Source of the order (for example, some web site, call center)
Public property | MovedDeliveryId | New delivery identifier created for move to a new terminal
Public property | Number | (Inherited from IOrder.)
Public property | OpenTime | (Inherited from IOrder.)
Public property | OrderType | (Inherited from IOrder.)
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. (Inherited from IOrder.)
Public property | Payments | (Inherited from IOrder.)
Public property | Phone | Phone of client
Public property | PredictedCookingCompleteTime | Predicted time when order cooking should be completed
Public property | PredictedDeliveryTime | Predicted time when order should be delivered
Public property | PriceCategory | Price category. (Inherited from IOrder.)
Public property | PricingTime | Time, which determines the price of products. By default time is taken from items print time. (Inherited from IOrder.)
Public property | PrintTime | Time when products were printed
Public property | ProblemComment | Description of the problem. Non-empty ProblemComment doesn't mean delivery is currently has a problem: comment could been filled in earlier, and after that HasProblem flag was unchecked. That means that the order had some problems earlier.
Public property | ProcessedPaymentsSum | Sum of all processed payment items in order. (Inherited from IOrder.)
Public property | RepeatBillNumber | Number of repeated bills. (Inherited from IOrder.)
Public property | ResultSum | Total sum to be paid, sum of all not deleted order items with discounts and both included and excluded vat. (Inherited from IOrder.)
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | SendTime | Time when order was sent to client
Public property | SourceId | Identifier of the delivery that existed before splitting it by multiple cash registers. Depending on settings, a single delivery can be split by multiple cash registers before payment, producing multiple deliveries. At this moment SourceId of all produced deliveries is set to Id of the source delivery. If delivery was not splitted by cash registers, SourceId returns null.
Public property | SplitBetweenPersons | Indicates whether the order should be splitted between persons or not
Public property | Status | (Inherited from IOrder.)
Public property | StornedOrderId | Source order's identifier this order copied from during storno operation. null if the order has never storned. (Inherited from IOrder.)
Public property | Tables | (Inherited from IOrder.)
Public property | TabName | Optional marker used to specify that the order is a tab. This property contains name of the tab if the order is marked as tab, otherwise null. (Inherited from IOrder.)
Public property | Waiter | (Inherited from IOrder.)
Public property | WasPrepaid | Whether order was prepaid. Any processed or deleted prepay. (Inherited from IOrder.)
Top
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ActualDeliverTime Property

IDeliveryOrderActualDeliverTime Property

Time when order was actually delivered to the client

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ActualDeliverTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Address Property

IDeliveryOrderAddress Property

Address where the order will be delivered

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IAddress Address { get; }

Property Value

Type: IAddress
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CafeAddress Property

IDeliveryOrderCafeAddress Property

Restaurant address

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CafeAddress { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CancelCause Property

IDeliveryOrderCancelCause Property

Cause of cancelling the order

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryCancelCause CancelCause { get; }

Property Value

Type: IDeliveryCancelCause
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CancelComment Property

IDeliveryOrderCancelComment Property

Comment to the order cancellation

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CancelComment { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CancelTime Property

IDeliveryOrderCancelTime Property

Time when the order was marked as cancelled

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CancelTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Client Property

IDeliveryOrderClient Property

Client that placed the delivery.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient Client { get; }

Property Value

Type: IClient
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ClientName Property

IDeliveryOrderClientName Property

Name of client

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ClientName { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CloseTime Property

IDeliveryOrderCloseTime Property

Time when delivery order was marked as closed

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CloseTime { get; }

Property Value

Type: Nullable DateTime

Implements

IOrderCloseTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Comment Property

IDeliveryOrderComment Property

Client's comment on order

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ConfirmTime Property

IDeliveryOrderConfirmTime Property

Time when order was confirmed

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ConfirmTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CookingFinishTime Property

IDeliveryOrderCookingFinishTime Property

Time when order cooking was finished

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CookingFinishTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Courier Property

IDeliveryOrderCourier Property

Courier that delivers the order

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Courier { get; }

Property Value

Type: IUser
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CreateTime Property

IDeliveryOrderCreateTime Property

Time when order was created

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime CreateTime { get; }

Property Value

Type: DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.CustomApiData Property

IDeliveryOrderCustomApiData Property

Custom data about delivery from Api

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CustomApiData { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.DeliveryId Property

IDeliveryOrderDeliveryId Property

Identifier of the delivery, don't confuse it with identifier of the delivery order. This property exists for historical reason, avoid using it when possible.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid DeliveryId { get; }

Property Value

Type: Guid
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.DeliveryOperator Property

IDeliveryOrderDeliveryOperator Property

User who created the order

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser DeliveryOperator { get; }

Property Value

Type: IUser
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.DeliveryStatus Property

IDeliveryOrderDeliveryStatus Property

Status of the delivery

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeliveryStatus DeliveryStatus { get; }

Property Value

Type: DeliveryStatus
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Duration Property

IDeliveryOrderDuration Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? Duration { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Email Property

IDeliveryOrderEmail Property

E-mail of client

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Email { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ExpectedDeliverTime Property

IDeliveryOrderExpectedDeliverTime Property

Time when client wants the order to be delivered

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime ExpectedDeliverTime { get; }

Property Value

Type: DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ExpectedDuration Property

IDeliveryOrderExpectedDuration Property

Duration calculated without overridden value on terminal

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? ExpectedDuration { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ExternalCourierServiceData Property

IDeliveryOrderExternalCourierServiceData Property

External service courier that delivers the order

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IExternalCourierServiceData ExternalCourierServiceData { get; }

Property Value

Type: IExternalCourierServiceData
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.HasProblem Property

IDeliveryOrderHasProblem Property

Whether the order is marked as having problem

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasProblem { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.IndexInCourierRoute Property

IDeliveryOrderIndexInCourierRoute Property

Index of the order in courier route (zero-based)

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? IndexInCourierRoute { get; }

Property Value

Type: Nullable Int32
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.IsCourierSelectedManually Property

IDeliveryOrderIsCourierSelectedManually Property

Whether courier was selected from UI or automatically

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsCourierSelectedManually { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.IsCustomerAuthorizedInIikoBiz Property

IDeliveryOrderIsCustomerAuthorizedInIikoBiz Property

Indicates whether customer is already authorized in iiko.biz, i.e. his credentials are verified

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsCustomerAuthorizedInIikoBiz { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.IsPrintedBillActual Property

IDeliveryOrderIsPrintedBillActual Property

Whether the order bill was already printed and since then it's considered to be actual. Also means whether the bill will be printed automatically according to settings: if it's not already printed, it will.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsPrintedBillActual { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.LastVerifiedDeliveryRestrictionsHash Property

IDeliveryOrderLastVerifiedDeliveryRestrictionsHash Property

Last verified on server delivery restrictions hash

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string LastVerifiedDeliveryRestrictionsHash { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Latitude Property

IDeliveryOrderLatitude Property

Latitude of geoposition of the delivery address

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
double? Latitude { get; }

Property Value

Type: Nullable Double
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Longitude Property

IDeliveryOrderLongitude Property

Longitude of geoposition of the delivery address

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
double? Longitude { get; }

Property Value

Type: Nullable Double
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.MarketingSource Property

IDeliveryOrderMarketingSource Property

Advertising Source of the order (for example, some web site, call center)

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IMarketingSource MarketingSource { get; }

Property Value

Type: IMarketingSource
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.MovedDeliveryId Property

IDeliveryOrderMovedDeliveryId Property

New delivery identifier created for move to a new terminal

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? MovedDeliveryId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.Phone Property

IDeliveryOrderPhone Property

Phone of client

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Phone { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.PredictedCookingCompleteTime Property

IDeliveryOrderPredictedCookingCompleteTime Property

Predicted time when order cooking should be completed

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? PredictedCookingCompleteTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.PredictedDeliveryTime Property

IDeliveryOrderPredictedDeliveryTime Property

Predicted time when order should be delivered

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? PredictedDeliveryTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.PrintTime Property

IDeliveryOrderPrintTime Property

Time when products were printed

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? PrintTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.ProblemComment Property

IDeliveryOrderProblemComment Property

Description of the problem. Non-empty ProblemComment doesn't mean delivery is currently has a problem: comment could been filled in earlier, and after that HasProblem flag was unchecked. That means that the order had some problems earlier.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ProblemComment { get; }

Property Value

Type: String
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.SendTime Property

IDeliveryOrderSendTime Property

Time when order was sent to client

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? SendTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.SourceId Property

IDeliveryOrderSourceId Property

Identifier of the delivery that existed before splitting it by multiple cash registers. Depending on settings, a single delivery can be split by multiple cash registers before payment, producing multiple deliveries. At this moment SourceId of all produced deliveries is set to Id of the source delivery. If delivery was not splitted by cash registers, SourceId returns null.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? SourceId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder.SplitBetweenPersons Property

IDeliveryOrderSplitBetweenPersons Property

Indicates whether the order should be splitted between persons or not

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool SplitBetweenPersons { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryOrder Methods

The IDeliveryOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeliveryOrder Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliveryTerminalWorkload : ISerializable

The IDeliveryTerminalWorkload type exposes the following members.

Properties
 | Name | Description
Public property | CourierWorkload | Courier workload.
Public property | IsTimePeak | Set standard cooking time 'Peak hour'
Public property | KitchenWorkload | Kitchen workload.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload Properties

The IDeliveryTerminalWorkload type exposes the following members.

Properties
 | Name | Description
Public property | CourierWorkload | Courier workload.
Public property | IsTimePeak | Set standard cooking time 'Peak hour'
Public property | KitchenWorkload | Kitchen workload.
Top
See Also

Reference

IDeliveryTerminalWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload.CourierWorkload Property

IDeliveryTerminalWorkloadCourierWorkload Property

Courier workload.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ICourierWorkload> CourierWorkload { get; }

Property Value

Type: IReadOnlyList ICourierWorkload
See Also

Reference

IDeliveryTerminalWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload.IsTimePeak Property

IDeliveryTerminalWorkloadIsTimePeak Property

Set standard cooking time 'Peak hour'

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsTimePeak { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliveryTerminalWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload.KitchenWorkload Property

IDeliveryTerminalWorkloadKitchenWorkload Property

Kitchen workload.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IKitchenWorkload> KitchenWorkload { get; }

Property Value

Type: IReadOnlyList IKitchenWorkload
See Also

Reference

IDeliveryTerminalWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDeliveryTerminalWorkload Methods

The IDeliveryTerminalWorkload type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeliveryTerminalWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard Interface

Discount card is a part of loyalty system which allows to provide reduced prices for loyal clients using either a discount or a special price category.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDiscountCard : ISerializable,
    IEntity

The IDiscountCard type exposes the following members.

Properties
 | Name | Description
Public property | CardNumber | Number of the card.
Public property | DiscountType | Discount type bound to the card. null if this card is bound to a price category.
Public property | Id | (Inherited from IEntity.)
Public property | OwnerName | Card owner's name.
Public property | PriceCategory | Price category bound to the card. null if this card is bound to a discount.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDiscountCard Properties

The IDiscountCard type exposes the following members.

Properties
 | Name | Description
Public property | CardNumber | Number of the card.
Public property | DiscountType | Discount type bound to the card. null if this card is bound to a price category.
Public property | Id | (Inherited from IEntity.)
Public property | OwnerName | Card owner's name.
Public property | PriceCategory | Price category bound to the card. null if this card is bound to a discount.
Top
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard.CardNumber Property

IDiscountCardCardNumber Property

Number of the card.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CardNumber { get; }

Property Value

Type: String
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard.DiscountType Property

IDiscountCardDiscountType Property

Discount type bound to the card. null if this card is bound to a price category.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountType DiscountType { get; }

Property Value

Type: IDiscountType
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard.OwnerName Property

IDiscountCardOwnerName Property

Card owner's name.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string OwnerName { get; }

Property Value

Type: String
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard.PriceCategory Property

IDiscountCardPriceCategory Property

Price category bound to the card. null if this card is bound to a discount.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory PriceCategory { get; }

Property Value

Type: IPriceCategory
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountCard Methods

The IDiscountCard type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDiscountCard Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountItem Interface

Discount item is the result of adding discount to an order, contains discount parameters, which will be used to calculate sums. While discount params are persistent, discount sums are calculated on demand, because they are subject to change (they may depend on the time, etc). Call GetOrderAppliedDiscounts(IOrder) to get calculated sums.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDiscountItem : ISerializable

The IDiscountItem type exposes the following members.

Properties
 | Name | Description
Public property | DiscountType | Type of the discount item.
Public property | IsSelectivelyApplied | Whether this discount item is applied selectively to some order items. If true, use TryGetSelectiveDiscountItemSettings(IOrder, IDiscountItem) to get or ChangeSelectiveDiscount(IOrderStub, IDiscountType, IReadOnlyListIOrderProductItemStub, IReadOnlyListIOrderModifierItemStub, IReadOnlyListIOrderCompoundItemComponentStub) to change list of selected order items.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDiscountItem Properties

The IDiscountItem type exposes the following members.

Properties
 | Name | Description
Public property | DiscountType | Type of the discount item.
Public property | IsSelectivelyApplied | Whether this discount item is applied selectively to some order items. If true, use TryGetSelectiveDiscountItemSettings(IOrder, IDiscountItem) to get or ChangeSelectiveDiscount(IOrderStub, IDiscountType, IReadOnlyListIOrderProductItemStub, IReadOnlyListIOrderModifierItemStub, IReadOnlyListIOrderCompoundItemComponentStub) to change list of selected order items.
Top
See Also

Reference

IDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountItem.DiscountType Property

IDiscountItemDiscountType Property

Type of the discount item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountType DiscountType { get; }

Property Value

Type: IDiscountType
See Also

Reference

IDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountItem.IsSelectivelyApplied Property

IDiscountItemIsSelectivelyApplied Property

Whether this discount item is applied selectively to some order items. If true, use TryGetSelectiveDiscountItemSettings(IOrder, IDiscountItem) to get or ChangeSelectiveDiscount(IOrderStub, IDiscountType, IReadOnlyListIOrderProductItemStub, IReadOnlyListIOrderModifierItemStub, IReadOnlyListIOrderCompoundItemComponentStub) to change list of selected order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsSelectivelyApplied { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountItem Methods

The IDiscountItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDiscountItem Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDiscountType : ISerializable,
    IEntity

The IDiscountType type exposes the following members.

Properties
 | Name | Description
Public property | CanApplyByCardNumber | Can discount be applied to order by card number.
Public property | CanApplyByDiscountCard | Can discount be applied to order by discount card.
Public property | CanApplyManually | Can discount be applied to order manually.
Public property | CanApplySelectively | Can discount be applied to order items selectively.
Public property | Deleted | Is this item deleted.
Public property | DiscountByFlexibleSum | Does it need to set discount sum on adding. Flexible sum discount types require user to provide discount sum while adding to order while other discount types automatically calculate discount sum depending on predefined settings.
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Is this item active for current group. Note that this property doesn't associated with Deleted. I.e. discount type can be deleted and active at the same time.
Public property | IsAutomatic | A sign that the discount is added automatically to order.
Public property | Name | Name of discount type
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IDiscountType Properties

The IDiscountType type exposes the following members.

Properties
 | Name | Description
Public property | CanApplyByCardNumber | Can discount be applied to order by card number.
Public property | CanApplyByDiscountCard | Can discount be applied to order by discount card.
Public property | CanApplyManually | Can discount be applied to order manually.
Public property | CanApplySelectively | Can discount be applied to order items selectively.
Public property | Deleted | Is this item deleted.
Public property | DiscountByFlexibleSum | Does it need to set discount sum on adding. Flexible sum discount types require user to provide discount sum while adding to order while other discount types automatically calculate discount sum depending on predefined settings.
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Is this item active for current group. Note that this property doesn't associated with Deleted. I.e. discount type can be deleted and active at the same time.
Public property | IsAutomatic | A sign that the discount is added automatically to order.
Public property | Name | Name of discount type
Top
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.CanApplyByCardNumber Property

IDiscountTypeCanApplyByCardNumber Property

Can discount be applied to order by card number.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanApplyByCardNumber { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.CanApplyByDiscountCard Property

IDiscountTypeCanApplyByDiscountCard Property

Can discount be applied to order by discount card.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanApplyByDiscountCard { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.CanApplyManually Property

IDiscountTypeCanApplyManually Property

Can discount be applied to order manually.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanApplyManually { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.CanApplySelectively Property

IDiscountTypeCanApplySelectively Property

Can discount be applied to order items selectively.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanApplySelectively { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.Deleted Property

IDiscountTypeDeleted Property

Is this item deleted.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.DiscountByFlexibleSum Property

IDiscountTypeDiscountByFlexibleSum Property

Does it need to set discount sum on adding. Flexible sum discount types require user to provide discount sum while adding to order while other discount types automatically calculate discount sum depending on predefined settings.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool DiscountByFlexibleSum { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.IsActive Property

IDiscountTypeIsActive Property

Is this item active for current group. Note that this property doesn't associated with Deleted. I.e. discount type can be deleted and active at the same time.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.IsAutomatic Property

IDiscountTypeIsAutomatic Property

A sign that the discount is added automatically to order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsAutomatic { get; }

Property Value

Type: Boolean
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType.Name Property

IDiscountTypeName Property

Name of discount type

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IDiscountType Methods

The IDiscountType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDiscountType Interface
Resto.Front.Api.Data.Orders Namespace


IFixedChildModifier Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IFixedChildModifier : ISerializable,
    IChildModifierBase

The IFixedChildModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from IChildModifierBase.)
Public property | DefaultAmount | (Inherited from IChildModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from IChildModifierBase.)
Public property | HideIfDefaultAmount | (Inherited from IChildModifierBase.)
Public property | MaximumAmount | (Inherited from IChildModifierBase.)
Public property | MinimumAmount | (Inherited from IChildModifierBase.)
Public property | Product | (Inherited from IChildModifierBase.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IFixedChildModifier Properties

The IFixedChildModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from IChildModifierBase.)
Public property | DefaultAmount | (Inherited from IChildModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from IChildModifierBase.)
Public property | HideIfDefaultAmount | (Inherited from IChildModifierBase.)
Public property | MaximumAmount | (Inherited from IChildModifierBase.)
Public property | MinimumAmount | (Inherited from IChildModifierBase.)
Public property | Product | (Inherited from IChildModifierBase.)
Top
See Also

Reference

IFixedChildModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedChildModifier Methods

The IFixedChildModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IFixedChildModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IFixedGroupModifier : ISerializable

The IFixedGroupModifier type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | ProductGroup |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier Properties

The IFixedGroupModifier type exposes the following members.

Properties
 | Name | Description
Public property | Items |
Public property | MaximumAmount |
Public property | MinimumAmount |
Public property | ProductGroup |
Top
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier.Items Property

IFixedGroupModifierItems Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedChildModifier> Items { get; }

Property Value

Type: IReadOnlyList IFixedChildModifier
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier.MaximumAmount Property

IFixedGroupModifierMaximumAmount Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MaximumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier.MinimumAmount Property

IFixedGroupModifierMinimumAmount Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MinimumAmount { get; }

Property Value

Type: Int32
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier.ProductGroup Property

IFixedGroupModifierProductGroup Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup ProductGroup { get; }

Property Value

Type: IProductGroup
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedGroupModifier Methods

The IFixedGroupModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IFixedGroupModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedSimpleModifier Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IFixedSimpleModifier : ISerializable,
    ISimpleModifierBase

The IFixedSimpleModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from ISimpleModifierBase.)
Public property | DefaultAmount | (Inherited from ISimpleModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from ISimpleModifierBase.)
Public property | MaximumAmount | (Inherited from ISimpleModifierBase.)
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product. (Inherited from ISimpleModifierBase.)
Public property | MinimumAmount | (Inherited from ISimpleModifierBase.)
Public property | Product | (Inherited from ISimpleModifierBase.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IFixedSimpleModifier Properties

The IFixedSimpleModifier type exposes the following members.

Properties
 | Name | Description
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent. (Inherited from ISimpleModifierBase.)
Public property | DefaultAmount | (Inherited from ISimpleModifierBase.)
Public property | FreeOfChargeAmount | Maximum amount that will be free, additional amount will be paid. (Inherited from ISimpleModifierBase.)
Public property | MaximumAmount | (Inherited from ISimpleModifierBase.)
Public property | MenuIndex | Gets an index of simple modifier in hierarchical menu, can be used to sort modifiers of product. (Inherited from ISimpleModifierBase.)
Public property | MinimumAmount | (Inherited from ISimpleModifierBase.)
Public property | Product | (Inherited from ISimpleModifierBase.)
Top
See Also

Reference

IFixedSimpleModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFixedSimpleModifier Methods

The IFixedSimpleModifier type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IFixedSimpleModifier Interface
Resto.Front.Api.Data.Orders Namespace


IFrontDeliverySettings Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IFrontDeliverySettings : ISerializable,
    IEntity

The IFrontDeliverySettings type exposes the following members.

Properties
 | Name | Description
Public property | CourierDeliveryDuration | Courier delivery duration set on a delivery terminal.
Public property | Id | (Inherited from IEntity.)
Public property | SelfServiceDeliveryDuration | SelfService delivery duration set on a delivery terminal.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IFrontDeliverySettings Properties

The IFrontDeliverySettings type exposes the following members.

Properties
 | Name | Description
Public property | CourierDeliveryDuration | Courier delivery duration set on a delivery terminal.
Public property | Id | (Inherited from IEntity.)
Public property | SelfServiceDeliveryDuration | SelfService delivery duration set on a delivery terminal.
Top
See Also

Reference

IFrontDeliverySettings Interface
Resto.Front.Api.Data.Orders Namespace


IFrontDeliverySettings.CourierDeliveryDuration Property

IFrontDeliverySettingsCourierDeliveryDuration Property

Courier delivery duration set on a delivery terminal.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? CourierDeliveryDuration { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IFrontDeliverySettings Interface
Resto.Front.Api.Data.Orders Namespace


IFrontDeliverySettings.SelfServiceDeliveryDuration Property

IFrontDeliverySettingsSelfServiceDeliveryDuration Property

SelfService delivery duration set on a delivery terminal.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? SelfServiceDeliveryDuration { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IFrontDeliverySettings Interface
Resto.Front.Api.Data.Orders Namespace


IFrontDeliverySettings Methods

The IFrontDeliverySettings type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IFrontDeliverySettings Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IIikoCard51OrderInfo : ISerializable

The IIikoCard51OrderInfo type exposes the following members.

Properties
 | Name | Description
Public property | AppliedManualConditions |
Public property | Coupon |
Public property | DynamicDiscounts | Dynamic discount sums for manual condition. It applies optionally with arbitrary discount value.
Public property | HasFixedDiscounts | Order has fixed precalculated iikoCard discounts.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo Properties

The IIikoCard51OrderInfo type exposes the following members.

Properties
 | Name | Description
Public property | AppliedManualConditions |
Public property | Coupon |
Public property | DynamicDiscounts | Dynamic discount sums for manual condition. It applies optionally with arbitrary discount value.
Public property | HasFixedDiscounts | Order has fixed precalculated iikoCard discounts.
Top
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo.AppliedManualConditions Property

IIikoCard51OrderInfoAppliedManualConditions Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<Guid> AppliedManualConditions { get; }

Property Value

Type: IReadOnlyList Guid
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo.Coupon Property

IIikoCard51OrderInfoCoupon Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Coupon { get; }

Property Value

Type: String
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo.DynamicDiscounts Property

IIikoCard51OrderInfoDynamicDiscounts Property

Dynamic discount sums for manual condition. It applies optionally with arbitrary discount value.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Dictionary<Guid, decimal> DynamicDiscounts { get; }

Property Value

Type: Dictionary Guid, Decimal
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo.HasFixedDiscounts Property

IIikoCard51OrderInfoHasFixedDiscounts Property

Order has fixed precalculated iikoCard discounts.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasFixedDiscounts { get; }

Property Value

Type: Boolean
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IIikoCard51OrderInfo Methods

The IIikoCard51OrderInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IIikoCard51OrderInfo Interface
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount Class

Describes DTO for iikoCard discount using by AddIikoCardDiscounts action AddIikoCardDiscounts(IReadOnlyCollectionIikoCardDiscount, IOrderStub).
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersIikoCardDiscount

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class IikoCardDiscount

The IikoCardDiscount type exposes the following members.

Constructors
 | Name | Description
Public method | IikoCardDiscount | Initializes a new instance of the IikoCardDiscount class
Top
Properties
 | Name | Description
Public property | Discounts | Discounts grouped by order item.
Public property | MarketingCampaignId | Marketign campaign id from iikoCard system.
Public property | MarketingCampaignName | Marketign campaign name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount Constructor

Initializes a new instance of the IikoCardDiscount class

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IikoCardDiscount()
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount Properties

The IikoCardDiscount type exposes the following members.

Properties
 | Name | Description
Public property | Discounts | Discounts grouped by order item.
Public property | MarketingCampaignId | Marketign campaign id from iikoCard system.
Public property | MarketingCampaignName | Marketign campaign name.
Top
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount.Discounts Property

IikoCardDiscountDiscounts Property

Discounts grouped by order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyCollection<DiscountForOrderItem> Discounts { get; set; }

Property Value

Type: IReadOnlyCollection DiscountForOrderItem
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount.MarketingCampaignId Property

IikoCardDiscountMarketingCampaignId Property

Marketign campaign id from iikoCard system.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid MarketingCampaignId { get; set; }

Property Value

Type: Guid
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount.MarketingCampaignName Property

IikoCardDiscountMarketingCampaignName Property

Marketign campaign name.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string MarketingCampaignName { get; set; }

Property Value

Type: String
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IikoCardDiscount Methods

The IikoCardDiscount type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IikoCardDiscount Class
Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IKitchenWorkload : ISerializable

The IKitchenWorkload type exposes the following members.

Properties
 | Name | Description
Public property | CookCount | Cooks count.
Public property | CookingPlaceType | Type of cooking place which refers to kitchen workload.
Public property | KitchenWorkloadInMinutes | Kitchen queue in minutes.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload Properties

The IKitchenWorkload type exposes the following members.

Properties
 | Name | Description
Public property | CookCount | Cooks count.
Public property | CookingPlaceType | Type of cooking place which refers to kitchen workload.
Public property | KitchenWorkloadInMinutes | Kitchen queue in minutes.
Top
See Also

Reference

IKitchenWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload.CookCount Property

IKitchenWorkloadCookCount Property

Cooks count.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int CookCount { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload.CookingPlaceType Property

IKitchenWorkloadCookingPlaceType Property

Type of cooking place which refers to kitchen workload.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICookingPlaceType CookingPlaceType { get; }

Property Value

Type: ICookingPlaceType
See Also

Reference

IKitchenWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload.KitchenWorkloadInMinutes Property

IKitchenWorkloadKitchenWorkloadInMinutes Property

Kitchen queue in minutes.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int KitchenWorkloadInMinutes { get; }

Property Value

Type: Int32
See Also

Reference

IKitchenWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IKitchenWorkload Methods

The IKitchenWorkload type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IKitchenWorkload Interface
Resto.Front.Api.Data.Orders Namespace


IOrder Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrder : ISerializable, IEntity,
    IVersionedEntity, IOrderStub

The IOrder type exposes the following members.

Properties
 | Name | Description
Public property | BillTime | Gets the bill cheque print time of the current order.
Public property | Cashier | Gets the user closed the current order.
Public property | CloseTime | Gets the payment time of the current order.
Public property | Combos |
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.
Public property | CustomerIds |
Public property | Discounts |
Public property | Donations |
Public property | EstimatedGuestsCount | Gets estimated guests count, that is greater than or equal to added guests count. When single order is used to serve many people and handling each of them as a separate guest may be inconvenient, this property will indicate estimated guests count while guests collection will contain as many guests as needed for waiters.
Public property | FiscalChequeNumber | Fiscal cheque number.
Public property | FullSum | Subtotal, sum of all not deleted order items with included vat, but without excluded vat and discounts.
Public property | Guests |
Public property | Id | (Inherited from IEntity.)
Public property | IikoCard51Info | Specific data for iikoCard51.
Public property | IsBanquetOrder | Order is banquet.
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.
Public property | Items |
Public property | Number |
Public property | OpenTime |
Public property | OrderType |
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.
Public property | Payments |
Public property | PriceCategory | Price category.
Public property | PricingTime | Time, which determines the price of products. By default time is taken from items print time.
Public property | ProcessedPaymentsSum | Sum of all processed payment items in order.
Public property | RepeatBillNumber | Number of repeated bills.
Public property | ResultSum | Total sum to be paid, sum of all not deleted order items with discounts and both included and excluded vat.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | Status |
Public property | StornedOrderId | Source order's identifier this order copied from during storno operation. null if the order has never storned.
Public property | Tables |
Public property | TabName | Optional marker used to specify that the order is a tab. This property contains name of the tab if the order is marked as tab, otherwise null.
Public property | Waiter |
Public property | WasPrepaid | Whether order was prepaid. Any processed or deleted prepay.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrder Properties

The IOrder type exposes the following members.

Properties
 | Name | Description
Public property | BillTime | Gets the bill cheque print time of the current order.
Public property | Cashier | Gets the user closed the current order.
Public property | CloseTime | Gets the payment time of the current order.
Public property | Combos |
Public property | CookingPriority | Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.
Public property | CustomerIds |
Public property | Discounts |
Public property | Donations |
Public property | EstimatedGuestsCount | Gets estimated guests count, that is greater than or equal to added guests count. When single order is used to serve many people and handling each of them as a separate guest may be inconvenient, this property will indicate estimated guests count while guests collection will contain as many guests as needed for waiters.
Public property | FiscalChequeNumber | Fiscal cheque number.
Public property | FullSum | Subtotal, sum of all not deleted order items with included vat, but without excluded vat and discounts.
Public property | Guests |
Public property | Id | (Inherited from IEntity.)
Public property | IikoCard51Info | Specific data for iikoCard51.
Public property | IsBanquetOrder | Order is banquet.
Public property | IsTopCookingPriority | The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.
Public property | Items |
Public property | Number |
Public property | OpenTime |
Public property | OrderType |
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.
Public property | Payments |
Public property | PriceCategory | Price category.
Public property | PricingTime | Time, which determines the price of products. By default time is taken from items print time.
Public property | ProcessedPaymentsSum | Sum of all processed payment items in order.
Public property | RepeatBillNumber | Number of repeated bills.
Public property | ResultSum | Total sum to be paid, sum of all not deleted order items with discounts and both included and excluded vat.
Public property | Revision | Incremental version of the entity. (Inherited from IVersionedEntity.)
Public property | Status |
Public property | StornedOrderId | Source order's identifier this order copied from during storno operation. null if the order has never storned.
Public property | Tables |
Public property | TabName | Optional marker used to specify that the order is a tab. This property contains name of the tab if the order is marked as tab, otherwise null.
Public property | Waiter |
Public property | WasPrepaid | Whether order was prepaid. Any processed or deleted prepay.
Top
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.BillTime Property

IOrderBillTime Property

Gets the bill cheque print time of the current order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? BillTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Cashier Property

IOrderCashier Property

Gets the user closed the current order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Cashier { get; }

Property Value

Type: IUser
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.CloseTime Property

IOrderCloseTime Property

Gets the payment time of the current order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CloseTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Combos Property

IOrderCombos Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderCombo> Combos { get; }

Property Value

Type: IReadOnlyList IOrderCombo
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.CookingPriority Property

IOrderCookingPriority Property

Specifies a custom cooking priority. While the application provides built-in prioritization logic for orders based on timing, dish courses, etc., you can override it and enforce custom cooking order based on your external logic. Ideally, all dishes should be cooked timely, but in case of concurrency when kitchen is high-loaded, you have to decide which orders are more important and should be cooked in the first place and which orders are allowed to be delayed. Higher priority values mean that the order, its serve groups and dishes will appear at the kitchen display earlier. Default value is zero. Both positive and negative values are allowed for raising and lowering the priority correspondingly. Orders with the same cooking priority will be sorted using default built-in logic.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int CookingPriority { get; }

Property Value

Type: Int32
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.CustomerIds Property

IOrderCustomerIds Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<Guid> CustomerIds { get; }

Property Value

Type: IReadOnlyList Guid
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Discounts Property

IOrderDiscounts Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IDiscountItem> Discounts { get; }

Property Value

Type: IReadOnlyList IDiscountItem
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Donations Property

IOrderDonations Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentItem> Donations { get; }

Property Value

Type: IReadOnlyList IPaymentItem
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.EstimatedGuestsCount Property

IOrderEstimatedGuestsCount Property

Gets estimated guests count, that is greater than or equal to added guests count. When single order is used to serve many people and handling each of them as a separate guest may be inconvenient, this property will indicate estimated guests count while guests collection will contain as many guests as needed for waiters.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int EstimatedGuestsCount { get; }

Property Value

Type: Int32
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.FiscalChequeNumber Property

IOrderFiscalChequeNumber Property

Fiscal cheque number.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? FiscalChequeNumber { get; }

Property Value

Type: Nullable Int32
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.FullSum Property

IOrderFullSum Property

Subtotal, sum of all not deleted order items with included vat, but without excluded vat and discounts.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal FullSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Guests Property

IOrderGuests Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderGuestItem> Guests { get; }

Property Value

Type: IReadOnlyList IOrderGuestItem
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.IikoCard51Info Property

IOrderIikoCard51Info Property

Specific data for iikoCard51.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IIikoCard51OrderInfo IikoCard51Info { get; }

Property Value

Type: IIikoCard51OrderInfo
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.IsBanquetOrder Property

IOrderIsBanquetOrder Property

Order is banquet.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsBanquetOrder { get; }

Property Value

Type: Boolean
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.IsTopCookingPriority Property

IOrderIsTopCookingPriority Property

The flag specifies that this order should be cooked out-of-order at kitchen. All orders which have this flag set on will appear above other orders at the kitchen display. Both groups (top priority and non-top priority) will be sorted separately using usual sorting logic (custom cooking priority, then default built-in criterions. Default value is false.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsTopCookingPriority { get; }

Property Value

Type: Boolean
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Items Property

IOrderItems Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderRootItem> Items { get; }

Property Value

Type: IReadOnlyList IOrderRootItem
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Number Property

IOrderNumber Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.OpenTime Property

IOrderOpenTime Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime OpenTime { get; }

Property Value

Type: DateTime
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.OrderType Property

IOrderOrderType Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType OrderType { get; }

Property Value

Type: IOrderType
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.OriginName Property

IOrderOriginName Property

Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string OriginName { get; }

Property Value

Type: String
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Payments Property

IOrderPayments Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentItem> Payments { get; }

Property Value

Type: IReadOnlyList IPaymentItem
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.PriceCategory Property

IOrderPriceCategory Property

Price category.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory PriceCategory { get; }

Property Value

Type: IPriceCategory
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.PricingTime Property

IOrderPricingTime Property

Time, which determines the price of products. By default time is taken from items print time.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? PricingTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.ProcessedPaymentsSum Property

IOrderProcessedPaymentsSum Property

Sum of all processed payment items in order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ProcessedPaymentsSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.RepeatBillNumber Property

IOrderRepeatBillNumber Property

Number of repeated bills.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int RepeatBillNumber { get; }

Property Value

Type: Int32
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.ResultSum Property

IOrderResultSum Property

Total sum to be paid, sum of all not deleted order items with discounts and both included and excluded vat.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ResultSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Status Property

IOrderStatus Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderStatus Status { get; }

Property Value

Type: OrderStatus
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.StornedOrderId Property

IOrderStornedOrderId Property

Source order's identifier this order copied from during storno operation. null if the order has never storned.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? StornedOrderId { get; }

Property Value

Type: Nullable Guid
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Tables Property

IOrderTables Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITable> Tables { get; }

Property Value

Type: IReadOnlyList ITable
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.TabName Property

IOrderTabName Property

Optional marker used to specify that the order is a tab. This property contains name of the tab if the order is marked as tab, otherwise null.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string TabName { get; }

Property Value

Type: String
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.Waiter Property

IOrderWaiter Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Waiter { get; }

Property Value

Type: IUser
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder.WasPrepaid Property

IOrderWasPrepaid Property

Whether order was prepaid. Any processed or deleted prepay.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool WasPrepaid { get; }

Property Value

Type: Boolean
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrder Methods

The IOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrder Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCombo : ISerializable,
    IEntity, IOrderComboStub

The IOrderCombo type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | GuestId |
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Public property | OrderRootItemsByGroups |
Public property | Price |
Public property | ProgramId | Identifier of the loyalty program.
Public property | SourceActionId |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderCombo Properties

The IOrderCombo type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | GuestId |
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Public property | OrderRootItemsByGroups |
Public property | Price |
Public property | ProgramId | Identifier of the loyalty program.
Public property | SourceActionId |
Top
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.Amount Property

IOrderComboAmount Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Amount { get; }

Property Value

Type: Int32
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.GuestId Property

IOrderComboGuestId Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid GuestId { get; }

Property Value

Type: Guid
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.Name Property

IOrderComboName Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.OrderRootItemsByGroups Property

IOrderComboOrderRootItemsByGroups Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Dictionary<Guid, Guid> OrderRootItemsByGroups { get; }

Property Value

Type: Dictionary Guid, Guid
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.Price Property

IOrderComboPrice Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.ProgramId Property

IOrderComboProgramId Property

Identifier of the loyalty program.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid ProgramId { get; }

Property Value

Type: Guid
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo.SourceActionId Property

IOrderComboSourceActionId Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid SourceActionId { get; }

Property Value

Type: Guid
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCombo Methods

The IOrderCombo type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderCombo Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem Interface

Templated order item representing one or two combined products.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCompoundItem : IOrderCookingItem,
    IOrderRootItem, ISerializable, IEntity, IOrderRootItemStub, IOrderCookingItemStub,
    IOrderCompoundItemStub

The IOrderCompoundItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | (Inherited from IOrderCookingItem.)
Public property | AvailableCommonGroupModifiers | Group modifiers that are available for the whole compound item.
Public property | AvailableCommonSimpleModifiers | Simple modifiers that are available for the whole compound item.
Public property | AvailableComponentGroupModifiers | Group modifiers that are available for compound item component.
Public property | AvailableComponentSimpleModifiers | Simple modifiers that are available for compound item component.
Public property | Comment | (Inherited from IOrderCookingItem.)
Public property | CommonModifiers | Common (non-splittable) assigned modifiers. Apply to all components.
Public property | CookingFinishTime | (Inherited from IOrderCookingItem.)
Public property | CookingStartTime | (Inherited from IOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Course | Gets the course of the current order item. (Inherited from IOrderCookingItem.)
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place. (Inherited from IOrderCookingItem.)
Public property | PrimaryComponent | Primary part of the compound item. For the undivided compound item this part is single, for splitted — primary.
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | SecondaryComponent | Secondary part of the splitted compound item or null for undivided compound item.
Public property | ServeTime | (Inherited from IOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | Template | Template of the current compound item.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem Properties

The IOrderCompoundItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | (Inherited from IOrderCookingItem.)
Public property | AvailableCommonGroupModifiers | Group modifiers that are available for the whole compound item.
Public property | AvailableCommonSimpleModifiers | Simple modifiers that are available for the whole compound item.
Public property | AvailableComponentGroupModifiers | Group modifiers that are available for compound item component.
Public property | AvailableComponentSimpleModifiers | Simple modifiers that are available for compound item component.
Public property | Comment | (Inherited from IOrderCookingItem.)
Public property | CommonModifiers | Common (non-splittable) assigned modifiers. Apply to all components.
Public property | CookingFinishTime | (Inherited from IOrderCookingItem.)
Public property | CookingStartTime | (Inherited from IOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Course | Gets the course of the current order item. (Inherited from IOrderCookingItem.)
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place. (Inherited from IOrderCookingItem.)
Public property | PrimaryComponent | Primary part of the compound item. For the undivided compound item this part is single, for splitted — primary.
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | SecondaryComponent | Secondary part of the splitted compound item or null for undivided compound item.
Public property | ServeTime | (Inherited from IOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | Template | Template of the current compound item.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.AvailableCommonGroupModifiers Property

IOrderCompoundItemAvailableCommonGroupModifiers Property

Group modifiers that are available for the whole compound item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedGroupModifier> AvailableCommonGroupModifiers { get; }

Property Value

Type: IReadOnlyList IFixedGroupModifier
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.AvailableCommonSimpleModifiers Property

IOrderCompoundItemAvailableCommonSimpleModifiers Property

Simple modifiers that are available for the whole compound item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedSimpleModifier> AvailableCommonSimpleModifiers { get; }

Property Value

Type: IReadOnlyList IFixedSimpleModifier
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.AvailableComponentGroupModifiers Property

IOrderCompoundItemAvailableComponentGroupModifiers Property

Group modifiers that are available for compound item component.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedGroupModifier> AvailableComponentGroupModifiers { get; }

Property Value

Type: IReadOnlyList IFixedGroupModifier
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.AvailableComponentSimpleModifiers Property

IOrderCompoundItemAvailableComponentSimpleModifiers Property

Simple modifiers that are available for compound item component.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedSimpleModifier> AvailableComponentSimpleModifiers { get; }

Property Value

Type: IReadOnlyList IFixedSimpleModifier
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.CommonModifiers Property

IOrderCompoundItemCommonModifiers Property

Common (non-splittable) assigned modifiers. Apply to all components.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderModifierItem> CommonModifiers { get; }

Property Value

Type: IReadOnlyList IOrderModifierItem
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.PrimaryComponent Property

IOrderCompoundItemPrimaryComponent Property

Primary part of the compound item. For the undivided compound item this part is single, for splitted — primary.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCompoundItemComponent PrimaryComponent { get; }

Property Value

Type: IOrderCompoundItemComponent
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.SecondaryComponent Property

IOrderCompoundItemSecondaryComponent Property

Secondary part of the splitted compound item or null for undivided compound item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCompoundItemComponent SecondaryComponent { get; }

Property Value

Type: IOrderCompoundItemComponent
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem.Template Property

IOrderCompoundItemTemplate Property

Template of the current compound item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICompoundItemTemplate Template { get; }

Property Value

Type: ICompoundItemTemplate
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItem Methods

The IOrderCompoundItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderCompoundItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent Interface

Element of the compound item representing one of its products.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCompoundItemComponent : ISerializable,
    IEntity, IOrderCompoundItemComponentStub

The IOrderCompoundItemComponent type exposes the following members.

Properties
 | Name | Description
Public property | Cost |
Public property | Id | (Inherited from IEntity.)
Public property | Modifiers | Assigned modifiers of the current component.
Public property | Price |
Public property | PricePredefined |
Public property | Product | Product of the current component.
Public property | ProductCustomName | Optional marker used to specify custom name of the current component.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | TaxPercent | Tax percent or null for not taxed order items.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent Properties

The IOrderCompoundItemComponent type exposes the following members.

Properties
 | Name | Description
Public property | Cost |
Public property | Id | (Inherited from IEntity.)
Public property | Modifiers | Assigned modifiers of the current component.
Public property | Price |
Public property | PricePredefined |
Public property | Product | Product of the current component.
Public property | ProductCustomName | Optional marker used to specify custom name of the current component.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | TaxPercent | Tax percent or null for not taxed order items.
Top
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.Cost Property

IOrderCompoundItemComponentCost Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Cost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.Modifiers Property

IOrderCompoundItemComponentModifiers Property

Assigned modifiers of the current component.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderModifierItem> Modifiers { get; }

Property Value

Type: IReadOnlyList IOrderModifierItem
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.Price Property

IOrderCompoundItemComponentPrice Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.PricePredefined Property

IOrderCompoundItemComponentPricePredefined Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PricePredefined { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.Product Property

IOrderCompoundItemComponentProduct Property

Product of the current component.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.ProductCustomName Property

IOrderCompoundItemComponentProductCustomName Property

Optional marker used to specify custom name of the current component.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ProductCustomName { get; }

Property Value

Type: String
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.ResultSum Property

IOrderCompoundItemComponentResultSum Property

Total sum to be paid, sum with discounts and both included and excluded vat.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ResultSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent.TaxPercent Property

IOrderCompoundItemComponentTaxPercent Property

Tax percent or null for not taxed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? TaxPercent { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCompoundItemComponent Methods

The IOrderCompoundItemComponent type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderCompoundItemComponent Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem Interface

Base type for all foody order items (those which may be cooked in the kitchen).

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCookingItem : IOrderRootItem,
    ISerializable, IEntity, IOrderRootItemStub, IOrderCookingItemStub

The IOrderCookingItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | Comment |
Public property | CookingFinishTime |
Public property | CookingStartTime |
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null.
Public property | Course | Gets the course of the current order item.
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place.
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | ServeTime |
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null.
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem Properties

The IOrderCookingItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | Comment |
Public property | CookingFinishTime |
Public property | CookingStartTime |
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null.
Public property | Course | Gets the course of the current order item.
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place.
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | ServeTime |
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null.
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.Amount Property

IOrderCookingItemAmount Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.Comment Property

IOrderCookingItemComment Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCookingItemComment Comment { get; }

Property Value

Type: IOrderCookingItemComment
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.CookingFinishTime Property

IOrderCookingItemCookingFinishTime Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CookingFinishTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.CookingStartTime Property

IOrderCookingItemCookingStartTime Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CookingStartTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.CookingTime Property

IOrderCookingItemCookingTime Property

Standard cooking time defined by settings if cooking is started, otherwise null.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? CookingTime { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.Course Property

IOrderCookingItemCourse Property

Gets the course of the current order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderItemCourse Course { get; }

Property Value

Type: OrderItemCourse
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.Kitchen Property

IOrderCookingItemKitchen Property

Product cooking place.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection Kitchen { get; }

Property Value

Type: IRestaurantSection
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.ServeTime Property

IOrderCookingItemServeTime Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? ServeTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem.Size Property

IOrderCookingItemSize Property

Gets size of the order item if it's product or template has scale, otherwise null.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize Size { get; }

Property Value

Type: IProductSize
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItem Methods

The IOrderCookingItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderCookingItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItemComment Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCookingItemComment : ISerializable

The IOrderCookingItemComment type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Deleted |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderCookingItemComment Properties

The IOrderCookingItemComment type exposes the following members.

Properties
 | Name | Description
Public property | Comment |
Public property | Deleted |
Top
See Also

Reference

IOrderCookingItemComment Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItemComment.Comment Property

IOrderCookingItemCommentComment Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Comment { get; }

Property Value

Type: String
See Also

Reference

IOrderCookingItemComment Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItemComment.Deleted Property

IOrderCookingItemCommentDeleted Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderCookingItemComment Interface
Resto.Front.Api.Data.Orders Namespace


IOrderCookingItemComment Methods

The IOrderCookingItemComment type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderCookingItemComment Interface
Resto.Front.Api.Data.Orders Namespace


IOrderGuestItem Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderGuestItem : ISerializable,
    IEntity, IOrderGuestItemStub

The IOrderGuestItem type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Public property | Rank | Guest's rank in order.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderGuestItem Properties

The IOrderGuestItem type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name |
Public property | Rank | Guest's rank in order.
Top
See Also

Reference

IOrderGuestItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderGuestItem.Name Property

IOrderGuestItemName Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IOrderGuestItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderGuestItem.Rank Property

IOrderGuestItemRank Property

Guest's rank in order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Rank { get; }

Property Value

Type: Int32
See Also

Reference

IOrderGuestItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderGuestItem Methods

The IOrderGuestItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderGuestItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderModifierItem : ISerializable,
    IEntity, IOrderModifierItemStub

The IOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | Cost |
Public property | Deleted |
Public property | DeletionMethod |
Public property | Id | (Inherited from IEntity.)
Public property | IsSeparate | Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.
Public property | Kitchen | Modifier cooking place.
Public property | PayableAmount | Payable part of the total Amount, the remaining amount is free of charge.
Public property | Price |
Public property | PricePredefined |
Public property | Product |
Public property | ProductCustomName | Optional marker used to specify custom name of the modifier.
Public property | ProductGroup |
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | TaxPercent | Tax percent or null for not taxed order items.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem Properties

The IOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount |
Public property | AmountIndependentOfParentAmount | Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.
Public property | Cost |
Public property | Deleted |
Public property | DeletionMethod |
Public property | Id | (Inherited from IEntity.)
Public property | IsSeparate | Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.
Public property | Kitchen | Modifier cooking place.
Public property | PayableAmount | Payable part of the total Amount, the remaining amount is free of charge.
Public property | Price |
Public property | PricePredefined |
Public property | Product |
Public property | ProductCustomName | Optional marker used to specify custom name of the modifier.
Public property | ProductGroup |
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | TaxPercent | Tax percent or null for not taxed order items.
Top
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Amount Property

IOrderModifierItemAmount Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.AmountIndependentOfParentAmount Property

IOrderModifierItemAmountIndependentOfParentAmount Property

Whether amount of the modifier is absolute or relative to parent amount. When modifier amount depends on parent, it means multiplication — specified amount of modifier should be cooked per each parent unit, otherwise it means addition — specified amount of modifier should be cooked for whole parent.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AmountIndependentOfParentAmount { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Cost Property

IOrderModifierItemCost Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Cost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Deleted Property

IOrderModifierItemDeleted Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.DeletionMethod Property

IOrderModifierItemDeletionMethod Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeletionMethod DeletionMethod { get; }

Property Value

Type: IDeletionMethod
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.IsSeparate Property

IOrderModifierItemIsSeparate Property

Whether modifier should be cooked separately from its product. In general this property exposes modifier semantics: while some modifiers specify how to cook their product, another modifiers are additional dish parts or even separate dishes. First type completely depends on product and has the same cooking property values, second type is separate and has own kitchen, status etc.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsSeparate { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Kitchen Property

IOrderModifierItemKitchen Property

Modifier cooking place.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection Kitchen { get; }

Property Value

Type: IRestaurantSection
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.PayableAmount Property

IOrderModifierItemPayableAmount Property

Payable part of the total Amount, the remaining amount is free of charge.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal PayableAmount { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Price Property

IOrderModifierItemPrice Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.PricePredefined Property

IOrderModifierItemPricePredefined Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PricePredefined { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.Product Property

IOrderModifierItemProduct Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.ProductCustomName Property

IOrderModifierItemProductCustomName Property

Optional marker used to specify custom name of the modifier.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ProductCustomName { get; }

Property Value

Type: String
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.ProductGroup Property

IOrderModifierItemProductGroup Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductGroup ProductGroup { get; }

Property Value

Type: IProductGroup
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.ResultSum Property

IOrderModifierItemResultSum Property

Total sum to be paid, sum with discounts and both included and excluded vat.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ResultSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem.TaxPercent Property

IOrderModifierItemTaxPercent Property

Tax percent or null for not taxed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? TaxPercent { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderModifierItem Methods

The IOrderModifierItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderModifierItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem Interface

Regular order item representing single product.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderProductItem : IOrderCookingItem,
    IOrderRootItem, ISerializable, IEntity, IOrderRootItemStub, IOrderCookingItemStub,
    IOrderProductItemStub

The IOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | (Inherited from IOrderCookingItem.)
Public property | AssignedModifiers | Modifiers assigned to order item.
Public property | AvailableGroupModifiers | Group modifiers that are available for order item.
Public property | AvailableSimpleModifiers | Simple modifiers that are available for order item.
Public property | Comment | (Inherited from IOrderCookingItem.)
Public property | CookingFinishTime | (Inherited from IOrderCookingItem.)
Public property | CookingStartTime | (Inherited from IOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Cost |
Public property | Course | Gets the course of the current order item. (Inherited from IOrderCookingItem.)
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place. (Inherited from IOrderCookingItem.)
Public property | OpenPrice | Manually set price of the product.
Public property | Price |
Public property | PricePredefined |
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | Product |
Public property | ProductCustomName | Optional marker used to specify custom name of the product item.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | ServeTime | (Inherited from IOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | TaxPercent | Tax percent or null for not taxed order items.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderProductItem Properties

The IOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | (Inherited from IOrderCookingItem.)
Public property | AssignedModifiers | Modifiers assigned to order item.
Public property | AvailableGroupModifiers | Group modifiers that are available for order item.
Public property | AvailableSimpleModifiers | Simple modifiers that are available for order item.
Public property | Comment | (Inherited from IOrderCookingItem.)
Public property | CookingFinishTime | (Inherited from IOrderCookingItem.)
Public property | CookingStartTime | (Inherited from IOrderCookingItem.)
Public property | CookingTime | Standard cooking time defined by settings if cooking is started, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Cost |
Public property | Course | Gets the course of the current order item. (Inherited from IOrderCookingItem.)
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | Kitchen | Product cooking place. (Inherited from IOrderCookingItem.)
Public property | OpenPrice | Manually set price of the product.
Public property | Price |
Public property | PricePredefined |
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | Product |
Public property | ProductCustomName | Optional marker used to specify custom name of the product item.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | ServeTime | (Inherited from IOrderCookingItem.)
Public property | Size | Gets size of the order item if it's product or template has scale, otherwise null. (Inherited from IOrderCookingItem.)
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | TaxPercent | Tax percent or null for not taxed order items.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.AssignedModifiers Property

IOrderProductItemAssignedModifiers Property

Modifiers assigned to order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderModifierItem> AssignedModifiers { get; }

Property Value

Type: IReadOnlyList IOrderModifierItem
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.AvailableGroupModifiers Property

IOrderProductItemAvailableGroupModifiers Property

Group modifiers that are available for order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedGroupModifier> AvailableGroupModifiers { get; }

Property Value

Type: IReadOnlyList IFixedGroupModifier
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.AvailableSimpleModifiers Property

IOrderProductItemAvailableSimpleModifiers Property

Simple modifiers that are available for order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IFixedSimpleModifier> AvailableSimpleModifiers { get; }

Property Value

Type: IReadOnlyList IFixedSimpleModifier
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.Cost Property

IOrderProductItemCost Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Cost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.OpenPrice Property

IOrderProductItemOpenPrice Property

Manually set price of the product.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? OpenPrice { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.Price Property

IOrderProductItemPrice Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.PricePredefined Property

IOrderProductItemPricePredefined Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool PricePredefined { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.Product Property

IOrderProductItemProduct Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.ProductCustomName Property

IOrderProductItemProductCustomName Property

Optional marker used to specify custom name of the product item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ProductCustomName { get; }

Property Value

Type: String
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.ResultSum Property

IOrderProductItemResultSum Property

Total sum to be paid, sum with discounts and both included and excluded vat.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ResultSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem.TaxPercent Property

IOrderProductItemTaxPercent Property

Tax percent or null for not taxed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? TaxPercent { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderProductItem Methods

The IOrderProductItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderProductItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem Interface

Base type for all order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderRootItem : ISerializable,
    IEntity, IOrderRootItemStub

The IOrderRootItem type exposes the following members.

Properties
 | Name | Description
Public property | Deleted |
Public property | DeletionMethod |
Public property | Guest |
Public property | Id | (Inherited from IEntity.)
Public property | PrintTime |
Public property | Status | Gets the status of the current order item.
Public property | Waiter | Waiter who made latest changes to the order item.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderRootItem Properties

The IOrderRootItem type exposes the following members.

Properties
 | Name | Description
Public property | Deleted |
Public property | DeletionMethod |
Public property | Guest |
Public property | Id | (Inherited from IEntity.)
Public property | PrintTime |
Public property | Status | Gets the status of the current order item.
Public property | Waiter | Waiter who made latest changes to the order item.
Top
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.Deleted Property

IOrderRootItemDeleted Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.DeletionMethod Property

IOrderRootItemDeletionMethod Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeletionMethod DeletionMethod { get; }

Property Value

Type: IDeletionMethod
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.Guest Property

IOrderRootItemGuest Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderGuestItem Guest { get; }

Property Value

Type: IOrderGuestItem
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.PrintTime Property

IOrderRootItemPrintTime Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? PrintTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.Status Property

IOrderRootItemStatus Property

Gets the status of the current order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderItemStatus Status { get; }

Property Value

Type: OrderItemStatus
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem.Waiter Property

IOrderRootItemWaiter Property

Waiter who made latest changes to the order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Waiter { get; }

Property Value

Type: IUser
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderRootItem Methods

The IOrderRootItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderRootItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem Interface

Order item representing time pay service.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderServiceItem : IOrderRootItem,
    ISerializable, IEntity, IOrderRootItemStub, IOrderServiceItemStub

The IOrderServiceItem type exposes the following members.

Properties
 | Name | Description
Public property | Cost | Total cost of the service item, sum of costs of the Periods plus RemainingLimitCost.
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsStarted | Whether the service is running now.
Public property | Periods | Service periods, each period represents some rate. For example, if the schedule has different rates for times before and after 10 o'clock, the service was started at 09:30 and now is 11:00, there will be one period with 30 mins length and another period with 60 mins length, both periods may have different prices and therefore different costs.
Public property | Price | Default price of the service. Some periods may have own prices, see Price. All prices are per timing step (TimingStep).
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | RateSchedule | Schedule of the service rates.
Public property | RemainingLimitCost | Predicted cost of the remaining time limit. Zero, if the TimeLimit is not set. If the time limit is set, but it's less than total time of the Periods, remaining time limit is zero and therefore it's cost is also zero. For example, if timing step is one minute, the time limit was set to 1 hour and 20 minutes already passed, there will be one or more periods with total time of 20 minutes and their respective costs, then the cost of remaining 40 minutes will be predicted using schedule. This cost will go down with the lapse of time, because while time of some period increases, the remaining time limit decreases. After 15 minutes total periods time will be 35 mins (20+15) and RemainingLimitCost will represent cost of the remaining 25 mins.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | Service | The service menu item. Expected to be of type Service.
Public property | ServiceCustomName | Optional marker used to specify custom name of the service item.
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | TaxPercent | Tax percent or null for not taxed order items.
Public property | TimeLimit | Total amount of time after which the service will be stopped or null for default limit (12 hours). Includes all periods.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem Properties

The IOrderServiceItem type exposes the following members.

Properties
 | Name | Description
Public property | Cost | Total cost of the service item, sum of costs of the Periods plus RemainingLimitCost.
Public property | Deleted | (Inherited from IOrderRootItem.)
Public property | DeletionMethod | (Inherited from IOrderRootItem.)
Public property | Guest | (Inherited from IOrderRootItem.)
Public property | Id | (Inherited from IEntity.)
Public property | IsStarted | Whether the service is running now.
Public property | Periods | Service periods, each period represents some rate. For example, if the schedule has different rates for times before and after 10 o'clock, the service was started at 09:30 and now is 11:00, there will be one period with 30 mins length and another period with 60 mins length, both periods may have different prices and therefore different costs.
Public property | Price | Default price of the service. Some periods may have own prices, see Price. All prices are per timing step (TimingStep).
Public property | PrintTime | (Inherited from IOrderRootItem.)
Public property | RateSchedule | Schedule of the service rates.
Public property | RemainingLimitCost | Predicted cost of the remaining time limit. Zero, if the TimeLimit is not set. If the time limit is set, but it's less than total time of the Periods, remaining time limit is zero and therefore it's cost is also zero. For example, if timing step is one minute, the time limit was set to 1 hour and 20 minutes already passed, there will be one or more periods with total time of 20 minutes and their respective costs, then the cost of remaining 40 minutes will be predicted using schedule. This cost will go down with the lapse of time, because while time of some period increases, the remaining time limit decreases. After 15 minutes total periods time will be 35 mins (20+15) and RemainingLimitCost will represent cost of the remaining 25 mins.
Public property | ResultSum | Total sum to be paid, sum with discounts and both included and excluded vat.
Public property | Service | The service menu item. Expected to be of type Service.
Public property | ServiceCustomName | Optional marker used to specify custom name of the service item.
Public property | Status | Gets the status of the current order item. (Inherited from IOrderRootItem.)
Public property | TaxPercent | Tax percent or null for not taxed order items.
Public property | TimeLimit | Total amount of time after which the service will be stopped or null for default limit (12 hours). Includes all periods.
Public property | Waiter | Waiter who made latest changes to the order item. (Inherited from IOrderRootItem.)
Top
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.Cost Property

IOrderServiceItemCost Property

Total cost of the service item, sum of costs of the Periods plus RemainingLimitCost.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Cost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.IsStarted Property

IOrderServiceItemIsStarted Property

Whether the service is running now.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsStarted { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.Periods Property

IOrderServiceItemPeriods Property

Service periods, each period represents some rate. For example, if the schedule has different rates for times before and after 10 o'clock, the service was started at 09:30 and now is 11:00, there will be one period with 30 mins length and another period with 60 mins length, both periods may have different prices and therefore different costs.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IOrderServiceItemPeriod> Periods { get; }

Property Value

Type: IReadOnlyList IOrderServiceItemPeriod
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.Price Property

IOrderServiceItemPrice Property

Default price of the service. Some periods may have own prices, see Price. All prices are per timing step (TimingStep).

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.RateSchedule Property

IOrderServiceItemRateSchedule Property

Schedule of the service rates.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
RateSchedule RateSchedule { get; }

Property Value

Type: RateSchedule
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.RemainingLimitCost Property

IOrderServiceItemRemainingLimitCost Property

Predicted cost of the remaining time limit. Zero, if the TimeLimit is not set. If the time limit is set, but it's less than total time of the Periods, remaining time limit is zero and therefore it's cost is also zero. For example, if timing step is one minute, the time limit was set to 1 hour and 20 minutes already passed, there will be one or more periods with total time of 20 minutes and their respective costs, then the cost of remaining 40 minutes will be predicted using schedule. This cost will go down with the lapse of time, because while time of some period increases, the remaining time limit decreases. After 15 minutes total periods time will be 35 mins (20+15) and RemainingLimitCost will represent cost of the remaining 25 mins.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal RemainingLimitCost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.ResultSum Property

IOrderServiceItemResultSum Property

Total sum to be paid, sum with discounts and both included and excluded vat.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal ResultSum { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.Service Property

IOrderServiceItemService Property

The service menu item. Expected to be of type Service.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Service { get; }

Property Value

Type: IProduct
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.ServiceCustomName Property

IOrderServiceItemServiceCustomName Property

Optional marker used to specify custom name of the service item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ServiceCustomName { get; }

Property Value

Type: String
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.TaxPercent Property

IOrderServiceItemTaxPercent Property

Tax percent or null for not taxed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? TaxPercent { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem.TimeLimit Property

IOrderServiceItemTimeLimit Property

Total amount of time after which the service will be stopped or null for default limit (12 hours). Includes all periods.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan? TimeLimit { get; }

Property Value

Type: Nullable TimeSpan
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItem Methods

The IOrderServiceItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderServiceItem Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod Interface

Period of a service item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderServiceItemPeriod : ISerializable,
    IEntity, IOrderServiceItemPeriodStub

The IOrderServiceItemPeriod type exposes the following members.

Properties
 | Name | Description
Public property | Cost | Cost of the service period.
Public property | ElapsedTime | Exact total elapsed time of the period, includes all runs of the period. Service may be started, then stopped, then started again, or the schedule may switch the service to another rate and then switch back, so this property will accumulate total active time of the period. This is exact unrounded value. For example, if timing step is 10 mins and this period was active only for 2 mins and 42 seconds, the Cost will be calculated for 10 mins anyway, while this property will have an exact value 00:02:42.
Public property | Id | (Inherited from IEntity.)
Public property | Price | Price of the service period per timing step (TimingStep).
Public property | Service | Product that specifies price of the period. Expected to be of types Service or Rate.
Public property | ServiceCustomName | Optional marker used to specify custom name of the service period.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod Properties

The IOrderServiceItemPeriod type exposes the following members.

Properties
 | Name | Description
Public property | Cost | Cost of the service period.
Public property | ElapsedTime | Exact total elapsed time of the period, includes all runs of the period. Service may be started, then stopped, then started again, or the schedule may switch the service to another rate and then switch back, so this property will accumulate total active time of the period. This is exact unrounded value. For example, if timing step is 10 mins and this period was active only for 2 mins and 42 seconds, the Cost will be calculated for 10 mins anyway, while this property will have an exact value 00:02:42.
Public property | Id | (Inherited from IEntity.)
Public property | Price | Price of the service period per timing step (TimingStep).
Public property | Service | Product that specifies price of the period. Expected to be of types Service or Rate.
Public property | ServiceCustomName | Optional marker used to specify custom name of the service period.
Top
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod.Cost Property

IOrderServiceItemPeriodCost Property

Cost of the service period.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Cost { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod.ElapsedTime Property

IOrderServiceItemPeriodElapsedTime Property

Exact total elapsed time of the period, includes all runs of the period. Service may be started, then stopped, then started again, or the schedule may switch the service to another rate and then switch back, so this property will accumulate total active time of the period. This is exact unrounded value. For example, if timing step is 10 mins and this period was active only for 2 mins and 42 seconds, the Cost will be calculated for 10 mins anyway, while this property will have an exact value 00:02:42.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan ElapsedTime { get; }

Property Value

Type: TimeSpan
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod.Price Property

IOrderServiceItemPeriodPrice Property

Price of the service period per timing step (TimingStep).

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod.Service Property

IOrderServiceItemPeriodService Property

Product that specifies price of the period. Expected to be of types Service or Rate.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Service { get; }

Property Value

Type: IProduct
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod.ServiceCustomName Property

IOrderServiceItemPeriodServiceCustomName Property

Optional marker used to specify custom name of the service period.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ServiceCustomName { get; }

Property Value

Type: String
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IOrderServiceItemPeriod Methods

The IOrderServiceItemPeriod type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderServiceItemPeriod Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPastOrder : ISerializable,
    IEntity

The IPastOrder type exposes the following members.

Properties
 | Name | Description
Public property | CafeSessionNumber | Orders session number
Public property | CafeSessionOpenTime | Orders session open time
Public property | CardTransactions |
Public property | Cashier | Gets the user closed the current order.
Public property | CashRegister | CashRegister of current point of sale
Public property | CloseTime | Order close time.
Public property | FiscalChequeNumber | Orders fiscal receipt number
Public property | Id | (Inherited from IEntity.)
Public property | Items |
Public property | Number | Order number
Public property | OpenTime | Order open time
Public property | OrderType | Order type
Public property | Payments |
Public property | RestaurantSection | Item cooking place.
Public property | TableNumber | Orders table number
Public property | Waiter | Person who serves the source order.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IPastOrder Properties

The IPastOrder type exposes the following members.

Properties
 | Name | Description
Public property | CafeSessionNumber | Orders session number
Public property | CafeSessionOpenTime | Orders session open time
Public property | CardTransactions |
Public property | Cashier | Gets the user closed the current order.
Public property | CashRegister | CashRegister of current point of sale
Public property | CloseTime | Order close time.
Public property | FiscalChequeNumber | Orders fiscal receipt number
Public property | Id | (Inherited from IEntity.)
Public property | Items |
Public property | Number | Order number
Public property | OpenTime | Order open time
Public property | OrderType | Order type
Public property | Payments |
Public property | RestaurantSection | Item cooking place.
Public property | TableNumber | Orders table number
Public property | Waiter | Person who serves the source order.
Top
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.CafeSessionNumber Property

IPastOrderCafeSessionNumber Property

Orders session number

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int CafeSessionNumber { get; }

Property Value

Type: Int32
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.CafeSessionOpenTime Property

IPastOrderCafeSessionOpenTime Property

Orders session open time

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime CafeSessionOpenTime { get; }

Property Value

Type: DateTime
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.CardTransactions Property

IPastOrderCardTransactions Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPastOrderHrsTransaction> CardTransactions { get; }

Property Value

Type: IReadOnlyList IPastOrderHrsTransaction
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.Cashier Property

IPastOrderCashier Property

Gets the user closed the current order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Cashier { get; }

Property Value

Type: IUser
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.CashRegister Property

IPastOrderCashRegister Property

CashRegister of current point of sale

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo CashRegister { get; }

Property Value

Type: ICashRegisterInfo
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.CloseTime Property

IPastOrderCloseTime Property

Order close time.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime? CloseTime { get; }

Property Value

Type: Nullable DateTime
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.FiscalChequeNumber Property

IPastOrderFiscalChequeNumber Property

Orders fiscal receipt number

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? FiscalChequeNumber { get; }

Property Value

Type: Nullable Int32
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.Items Property

IPastOrderItems Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPastOrderItem> Items { get; }

Property Value

Type: IReadOnlyList IPastOrderItem
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.Number Property

IPastOrderNumber Property

Order number

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.OpenTime Property

IPastOrderOpenTime Property

Order open time

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime OpenTime { get; }

Property Value

Type: DateTime
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.OrderType Property

IPastOrderOrderType Property

Order type

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType OrderType { get; }

Property Value

Type: IOrderType
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.Payments Property

IPastOrderPayments Property

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPastOrderPayment> Payments { get; }

Property Value

Type: IReadOnlyList IPastOrderPayment
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.RestaurantSection Property

IPastOrderRestaurantSection Property

Item cooking place.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IRestaurantSection RestaurantSection { get; }

Property Value

Type: IRestaurantSection
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.TableNumber Property

IPastOrderTableNumber Property

Orders table number

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int TableNumber { get; }

Property Value

Type: Int32
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder.Waiter Property

IPastOrderWaiter Property

Person who serves the source order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IUser Waiter { get; }

Property Value

Type: IUser
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrder Methods

The IPastOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPastOrder Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPastOrderHrsTransaction : ISerializable,
    IEntity

The IPastOrderHrsTransaction type exposes the following members.

Properties
 | Name | Description
Public property | GuestHrsIdentifier | Guest HRS identifier.
Public property | GuestName | Guest name.
Public property | Id | (Inherited from IEntity.)
Public property | RoomNumber | Room number.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction Properties

The IPastOrderHrsTransaction type exposes the following members.

Properties
 | Name | Description
Public property | GuestHrsIdentifier | Guest HRS identifier.
Public property | GuestName | Guest name.
Public property | Id | (Inherited from IEntity.)
Public property | RoomNumber | Room number.
Top
See Also

Reference

IPastOrderHrsTransaction Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction.GuestHrsIdentifier Property

IPastOrderHrsTransactionGuestHrsIdentifier Property

Guest HRS identifier.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GuestHrsIdentifier { get; }

Property Value

Type: String
See Also

Reference

IPastOrderHrsTransaction Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction.GuestName Property

IPastOrderHrsTransactionGuestName Property

Guest name.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string GuestName { get; }

Property Value

Type: String
See Also

Reference

IPastOrderHrsTransaction Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction.RoomNumber Property

IPastOrderHrsTransactionRoomNumber Property

Room number.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string RoomNumber { get; }

Property Value

Type: String
See Also

Reference

IPastOrderHrsTransaction Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderHrsTransaction Methods

The IPastOrderHrsTransaction type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPastOrderHrsTransaction Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPastOrderItem : ISerializable,
    IEntity

The IPastOrderItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Item amount.
Public property | Id | (Inherited from IEntity.)
Public property | IsMainDish | Item price.
Public property | Price | Item price.
Public property | Product | Product to be cooked.
Public property | ProductSize | Gets size of the order item if it's product.
Public property | SumWithDiscounts | Item sum with all discounts included.
Public property | SumWithoutDiscounts | Item sum without any discounts.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IPastOrderItem Properties

The IPastOrderItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Item amount.
Public property | Id | (Inherited from IEntity.)
Public property | IsMainDish | Item price.
Public property | Price | Item price.
Public property | Product | Product to be cooked.
Public property | ProductSize | Gets size of the order item if it's product.
Public property | SumWithDiscounts | Item sum with all discounts included.
Public property | SumWithoutDiscounts | Item sum without any discounts.
Top
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.Amount Property

IPastOrderItemAmount Property

Item amount.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.IsMainDish Property

IPastOrderItemIsMainDish Property

Item price.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsMainDish { get; }

Property Value

Type: Boolean
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.Price Property

IPastOrderItemPrice Property

Item price.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Price { get; }

Property Value

Type: Decimal
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.Product Property

IPastOrderItemProduct Property

Product to be cooked.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.ProductSize Property

IPastOrderItemProductSize Property

Gets size of the order item if it's product.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize ProductSize { get; }

Property Value

Type: IProductSize
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.SumWithDiscounts Property

IPastOrderItemSumWithDiscounts Property

Item sum with all discounts included.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal SumWithDiscounts { get; }

Property Value

Type: Decimal
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem.SumWithoutDiscounts Property

IPastOrderItemSumWithoutDiscounts Property

Item sum without any discounts.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal SumWithoutDiscounts { get; }

Property Value

Type: Decimal
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderItem Methods

The IPastOrderItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPastOrderItem Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPastOrderPayment : ISerializable,
    IEntity

The IPastOrderPayment type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsPrepay | Payment operation is prepayment.
Public property | PaymentType | Payment type.
Public property | Sum | Payment amount.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment Properties

The IPastOrderPayment type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsPrepay | Payment operation is prepayment.
Public property | PaymentType | Payment type.
Public property | Sum | Payment amount.
Top
See Also

Reference

IPastOrderPayment Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment.IsPrepay Property

IPastOrderPaymentIsPrepay Property

Payment operation is prepayment.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsPrepay { get; }

Property Value

Type: Boolean
See Also

Reference

IPastOrderPayment Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment.PaymentType Property

IPastOrderPaymentPaymentType Property

Payment type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentType PaymentType { get; }

Property Value

Type: IPaymentType
See Also

Reference

IPastOrderPayment Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment.Sum Property

IPastOrderPaymentSum Property

Payment amount.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Sum { get; }

Property Value

Type: Decimal
See Also

Reference

IPastOrderPayment Interface
Resto.Front.Api.Data.Orders Namespace


IPastOrderPayment Methods

The IPastOrderPayment type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPastOrderPayment Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPriceCategory : ISerializable,
    IEntity

The IPriceCategory type exposes the following members.

Properties
 | Name | Description
Public property | CanApplyManually | Can price category be applied to order manually.
Public property | Code | Unique price category code.
Public property | Deleted | Is this item deleted.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of price category.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IPriceCategory Properties

The IPriceCategory type exposes the following members.

Properties
 | Name | Description
Public property | CanApplyManually | Can price category be applied to order manually.
Public property | Code | Unique price category code.
Public property | Deleted | Is this item deleted.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of price category.
Top
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory.CanApplyManually Property

IPriceCategoryCanApplyManually Property

Can price category be applied to order manually.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanApplyManually { get; }

Property Value

Type: Boolean
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory.Code Property

IPriceCategoryCode Property

Unique price category code.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Code { get; }

Property Value

Type: String
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory.Deleted Property

IPriceCategoryDeleted Property

Is this item deleted.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool Deleted { get; }

Property Value

Type: Boolean
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory.Name Property

IPriceCategoryName Property

Name of price category.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IPriceCategory Methods

The IPriceCategory type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPriceCategory Interface
Resto.Front.Api.Data.Orders Namespace


IRemovalType Interface

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IRemovalType : ISerializable,
    IEntity

The IRemovalType type exposes the following members.

Properties
 | Name | Description
Public property | CommentRequired | If true, printed order item deletion comment is mandatory, otherwise comment is optional.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of removal type
Public property | WriteoffType | Write-off types of removal type.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


IRemovalType Properties

The IRemovalType type exposes the following members.

Properties
 | Name | Description
Public property | CommentRequired | If true, printed order item deletion comment is mandatory, otherwise comment is optional.
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of removal type
Public property | WriteoffType | Write-off types of removal type.
Top
See Also

Reference

IRemovalType Interface
Resto.Front.Api.Data.Orders Namespace


IRemovalType.CommentRequired Property

IRemovalTypeCommentRequired Property

If true, printed order item deletion comment is mandatory, otherwise comment is optional.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CommentRequired { get; }

Property Value

Type: Boolean
See Also

Reference

IRemovalType Interface
Resto.Front.Api.Data.Orders Namespace


IRemovalType.Name Property

IRemovalTypeName Property

Name of removal type

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IRemovalType Interface
Resto.Front.Api.Data.Orders Namespace


IRemovalType.WriteoffType Property

IRemovalTypeWriteoffType Property

Write-off types of removal type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
WriteoffType WriteoffType { get; }

Property Value

Type: WriteoffType
See Also

Reference

IRemovalType Interface
Resto.Front.Api.Data.Orders Namespace


IRemovalType Methods

The IRemovalType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IRemovalType Interface
Resto.Front.Api.Data.Orders Namespace


ISelectiveDiscountItemSettings Interface

Order items to which the discount item is applied selectively.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISelectiveDiscountItemSettings

The ISelectiveDiscountItemSettings type exposes the following members.

Properties
 | Name | Description
Public property | CompoundItemComponents | Compound item components to which the discount item is applied selectively.
Public property | Modifiers | Order item modifiers to which the discount item is applied selectively.
Public property | Products | Order item products to which the discount item is applied selectively.
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ISelectiveDiscountItemSettings Properties

The ISelectiveDiscountItemSettings type exposes the following members.

Properties
 | Name | Description
Public property | CompoundItemComponents | Compound item components to which the discount item is applied selectively.
Public property | Modifiers | Order item modifiers to which the discount item is applied selectively.
Public property | Products | Order item products to which the discount item is applied selectively.
Top
See Also

Reference

ISelectiveDiscountItemSettings Interface
Resto.Front.Api.Data.Orders Namespace


ISelectiveDiscountItemSettings.CompoundItemComponents Property

ISelectiveDiscountItemSettingsCompoundItemComponents Property

Compound item components to which the discount item is applied selectively.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyCollection<IOrderCompoundItemComponent> CompoundItemComponents { get; }

Property Value

Type: IReadOnlyCollection IOrderCompoundItemComponent
See Also

Reference

ISelectiveDiscountItemSettings Interface
Resto.Front.Api.Data.Orders Namespace


ISelectiveDiscountItemSettings.Modifiers Property

ISelectiveDiscountItemSettingsModifiers Property

Order item modifiers to which the discount item is applied selectively.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyCollection<IOrderModifierItem> Modifiers { get; }

Property Value

Type: IReadOnlyCollection IOrderModifierItem
See Also

Reference

ISelectiveDiscountItemSettings Interface
Resto.Front.Api.Data.Orders Namespace


ISelectiveDiscountItemSettings.Products Property

ISelectiveDiscountItemSettingsProducts Property

Order item products to which the discount item is applied selectively.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyCollection<IOrderProductItem> Products { get; }

Property Value

Type: IReadOnlyCollection IOrderProductItem
See Also

Reference

ISelectiveDiscountItemSettings Interface
Resto.Front.Api.Data.Orders Namespace


OrderItemCourse Enumeration

Describes the course (cooking and serving sequence) of an order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum OrderItemCourse
Members
Member name | Value | Description
Default | -1 | Order item should be cooked and served with default priority.
Vip | 0 | Order item should be cooked and served as soon as possible, this is highest priority.
First | 1 | Order item cooking should start immediately after service cheque printing.
Second | 2 | Order item cooking should start after second course serve cheque printing, items of this priority should be served after First.
Third | 3 | Order item cooking should start after third course serve cheque printing, items of this priority should be served after Second.
Fourth | 4 | Order item cooking should start after fourth course serve cheque printing, items of this priority should be served after Third.
Fifth | 5 | Order item cooking should start after fifth course serve cheque printing, items of this priority should be served after Fourth. This course usage possibility depends on MaxCourseNumber setting.
Sixth | 6 | Order item cooking should start after sixth course serve cheque printing, items of this priority should be served after Fifth. This course usage possibility depends on MaxCourseNumber setting.
Seventh | 7 | Order item cooking should start after seventh course serve cheque printing, items of this priority should be served after Sixth. This course usage possibility depends on MaxCourseNumber setting.
Eighth | 8 | Order item cooking should start after eighth course serve cheque printing, items of this priority should be served after Seventh. This course usage possibility depends on MaxCourseNumber setting.
Ninth | 9 | Order item cooking should start after ninth course serve cheque printing, items of this priority should be served after Eighth. This course usage possibility depends on MaxCourseNumber setting.
Tenth | 10 | Order item cooking should start after tenth course serve cheque printing, items of this priority should be served after Ninth. This course usage possibility depends on MaxCourseNumber setting.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


OrderItemStatus Enumeration

Describes the status of an order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum OrderItemStatus
Members
Member name | Value | Description
Added | 0 | Newly added item.
PrintedNotCooking | 1 | Item was printed with low priority (Second, Third, Fourth) and corresponding course serve cheque wasn't printed yet.
CookingStarted | 2 | Order item was printed with high or normal priority (Vip, First) or was printed with low priority and it's corresponding course serve cheque was also printed.
CookingCompleted | 3 | Order item cooking completed, so it's ready to serve.
Served | 4 | Order item is served.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


OrderStatus Enumeration

Describes the status of an order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum OrderStatus
Members
Member name | Value | Description
New | 0 | Newly created order. This status corresponds to lifetime from creation to ready-to-pay state.
Bill | 1 | Bill cheque printed order. This status corresponds to lifetime between billing and payment.
Closed | 2 | Paid order.
Deleted | 3 | Deleted order.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


PaymentStatus Enumeration

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum PaymentStatus
Members
Member name | Value | Description
New | 0 |
Processed | 1 |
Storned | 2 |
Cancelled | 3 |
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ProductsSellingPossibility Enumeration

Member of ProductsSellingRestrictions, check result of CheckProductsSellingRestrictions(ICredentials, DictionaryIProduct, Decimal) method.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ProductsSellingPossibility
Members
Member name | Value | Description
Allowed | 0 | Current user can sell specified amount of products without restriction.
AllowedForced | 1 | Selling of specified amount of products is restricted, but current user can sell them forcibly. Consider asking user for confirmation to sell products with negative remaining amount. Products with insufficient amount can be retrieved from ProductsExceedRemainingAmounts.
Restricted | 2 | Selling of specified amount of products is restricted and current user hasn't permisstion to sell them forcibly. Products with insufficient amount can be retrieved from ProductsExceedRemainingAmounts.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions Class

Check result of CheckProductsSellingRestrictions(ICredentials, DictionaryIProduct, Decimal) method.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersProductsSellingRestrictions

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ProductsSellingRestrictions

The ProductsSellingRestrictions type exposes the following members.

Constructors
 | Name | Description
Public method | ProductsSellingRestrictions | Initializes a new instance of the ProductsSellingRestrictions class
Top
Properties
 | Name | Description
Public property | CheckResult | If current user can add these products with such amounts.
Public property | ProductsExceedRemainingAmounts | Products and amounts of products that can not be added to order.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
MaximumItemAmount | Maximum possible amount of the order item.
MinimumItemAmount | Minimum possible amount of the order item.
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions Constructor

Initializes a new instance of the ProductsSellingRestrictions class

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ProductsSellingRestrictions(
    ProductsSellingPossibility checkResult,
    Dictionary<IProduct, decimal> productsExceedRemainingAmounts
)

Parameters

checkResult
Type: Resto.Front.Api.Data.OrdersProductsSellingPossibility
productsExceedRemainingAmounts
Type: System.Collections.GenericDictionary IProduct, Decimal
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions Properties

The ProductsSellingRestrictions type exposes the following members.

Properties
 | Name | Description
Public property | CheckResult | If current user can add these products with such amounts.
Public property | ProductsExceedRemainingAmounts | Products and amounts of products that can not be added to order.
Top
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions.CheckResult Property

ProductsSellingRestrictionsCheckResult Property

If current user can add these products with such amounts.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ProductsSellingPossibility CheckResult { get; }

Property Value

Type: ProductsSellingPossibility
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions.ProductsExceedRemainingAmounts Property

ProductsSellingRestrictionsProductsExceedRemainingAmounts Property

Products and amounts of products that can not be added to order.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Dictionary<IProduct, decimal> ProductsExceedRemainingAmounts { get; }

Property Value

Type: Dictionary IProduct, Decimal
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions Methods

The ProductsSellingRestrictions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions Fields

The ProductsSellingRestrictions type exposes the following members.

Fields
Name | Description
MaximumItemAmount | Maximum possible amount of the order item.
MinimumItemAmount | Minimum possible amount of the order item.
Top
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions.MaximumItemAmount Field

ProductsSellingRestrictionsMaximumItemAmount Field

Maximum possible amount of the order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static readonly decimal MaximumItemAmount

Field Value

Type: Decimal
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


ProductsSellingRestrictions.MinimumItemAmount Field

ProductsSellingRestrictionsMinimumItemAmount Field

Minimum possible amount of the order item.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static readonly decimal MinimumItemAmount

Field Value

Type: Decimal
See Also

Reference

ProductsSellingRestrictions Class
Resto.Front.Api.Data.Orders Namespace


RateSchedule Class

A schedule of a service rates.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersRateSchedule

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RateSchedule

The RateSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | RateSchedule | Initializes a new instance of the RateSchedule.
Top
Properties
 | Name | Description
Public property | Items | List of non-default rates. Each item is a set of non-intersecting time intervals having own price. All time intervals that are not covered by any of the schedule items have a default price.
 | MinimumDuration | Minumum duration of a service or null if there is no lower limit. If the lower limit is set and the actual duration is below of limit, it will be rounded up.
Public property | TimingMode | Time rate calculation mode, which specifies how to treat rate schedule interval bounds.
 | TimingStep | Length of the service duration increment steps. Actual service duration is always rounded up to a multiple of this value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


RateSchedule Constructor

Initializes a new instance of the RateSchedule.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RateSchedule(
    ServiceTimingMode timingMode,
    TimeSpan? minimumDuration,
    TimeSpan timingStep,
    IReadOnlyList<RateScheduleItem> items
)

Parameters

timingMode
Type: Resto.Front.Api.Data.OrdersServiceTimingMode
minimumDuration
Type: SystemNullable TimeSpan
timingStep
Type: SystemTimeSpan
items
Type: System.Collections.GenericIReadOnlyList RateScheduleItem
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace


RateSchedule Properties

The RateSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Items | List of non-default rates. Each item is a set of non-intersecting time intervals having own price. All time intervals that are not covered by any of the schedule items have a default price.
 | MinimumDuration | Minumum duration of a service or null if there is no lower limit. If the lower limit is set and the actual duration is below of limit, it will be rounded up.
Public property | TimingMode | Time rate calculation mode, which specifies how to treat rate schedule interval bounds.
 | TimingStep | Length of the service duration increment steps. Actual service duration is always rounded up to a multiple of this value.
Top
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace


RateSchedule.Items Property

RateScheduleItems Property

List of non-default rates. Each item is a set of non-intersecting time intervals having own price. All time intervals that are not covered by any of the schedule items have a default price.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyList<RateScheduleItem> Items { get; }

Property Value

Type: IReadOnlyList RateScheduleItem
Remarks
Time intervals pricing difference is implemented via binding to different products (IProduct). Order item of a service type (IOrderServiceItem) has a primary service product (Service) and additional rate products ( Service), which are specified by the rates schedule (RateSchedule).
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace


RateSchedule.MinimumDuration Property

RateScheduleMinimumDuration Property

Minumum duration of a service or null if there is no lower limit. If the lower limit is set and the actual duration is below of limit, it will be rounded up.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan? MinimumDuration { get; }

Property Value

Type: Nullable TimeSpan
Examples
  • Actual service duration is 15 minutes, TimingStep is 10 minutes and MinimumDuration is not set: service duration will just be rounded up to a multiple of TimingStep, the result is 20 minutes.
  • Actual service duration is 15 minutes, TimingStep is 10 minutes and MinimumDuration is 1 hour: at first service duration will be rounded up to 1 hour to meet the MinimumDuration and then will be rounded up to a multiple of TimingStep, the result is 1 hour.
  • Actual service duration is 75 minutes, TimingStep is 10 minutes and MinimumDuration is 1 hour: 75 mins already meets the MinimumDuration, so it will only be rounded up to a multiple of TimingStep, the result is 1 hour 20 mins.
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace
RateScheduleTimingStep


RateSchedule.TimingMode Property

RateScheduleTimingMode Property

Time rate calculation mode, which specifies how to treat rate schedule interval bounds.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ServiceTimingMode TimingMode { get; }

Property Value

Type: ServiceTimingMode
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace


RateSchedule.TimingStep Property

RateScheduleTimingStep Property

Length of the service duration increment steps. Actual service duration is always rounded up to a multiple of this value.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan TimingStep { get; }

Property Value

Type: TimeSpan
Examples
  • Actual service duration is 15 minutes, TimingStep is 10 minutes and MinimumDuration is not set: service duration will just be rounded up to a multiple of TimingStep, the result is 20 minutes.
  • Actual service duration is 15 minutes, TimingStep is 10 minutes and MinimumDuration is 1 hour: at first service duration will be rounded up to 1 hour to meet the MinimumDuration and then will be rounded up to a multiple of TimingStep, the result is 1 hour.
  • Actual service duration is 75 minutes, TimingStep is 10 minutes and MinimumDuration is 1 hour: 75 mins already meets the MinimumDuration, so it will only be rounded up to a multiple of TimingStep, the result is 1 hour 20 mins.
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace
RateScheduleTimingStep


RateSchedule Methods

The RateSchedule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RateSchedule Class
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval Structure

Describes a time interval within a week, which is used in RateSchedule.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public struct RateScheduleInterval

The RateScheduleInterval type exposes the following members.

Constructors
 | Name | Description
Public method | RateScheduleInterval | Initializes a new instance of the RateScheduleInterval.
Top
Properties
 | Name | Description
Public property | Day | Day of week of the interval.
Public property | End | Interval's end point offset relative to start of a day or a service depending on TimingMode.
Public property | Start | Interval's start point offset relative to start of a day or a service depending on TimingMode.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval Constructor

Initializes a new instance of the RateScheduleInterval.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RateScheduleInterval(
    DayOfWeek day,
    TimeSpan begin,
    TimeSpan end
)

Parameters

day
Type: SystemDayOfWeek
begin
Type: SystemTimeSpan
end
Type: SystemTimeSpan
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval Properties

The RateScheduleInterval type exposes the following members.

Properties
 | Name | Description
Public property | Day | Day of week of the interval.
Public property | End | Interval's end point offset relative to start of a day or a service depending on TimingMode.
Public property | Start | Interval's start point offset relative to start of a day or a service depending on TimingMode.
Top
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval.Day Property

RateScheduleIntervalDay Property

Day of week of the interval.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DayOfWeek Day { get; }

Property Value

Type: DayOfWeek
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval.End Property

RateScheduleIntervalEnd Property

Interval's end point offset relative to start of a day or a service depending on TimingMode.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan End { get; }

Property Value

Type: TimeSpan
Remarks
For DayTime valid values range is (0h; 24h], which means all the day (Day) exluding it's left bound. For ServiceTime valid values range is (0h; 12h], because max service duration is 12h. Anyway, End is greater than Start, so that interval has positive length.
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval.Start Property

RateScheduleIntervalStart Property

Interval's start point offset relative to start of a day or a service depending on TimingMode.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TimeSpan Start { get; }

Property Value

Type: TimeSpan
Remarks
For DayTime valid values range is [0h; 24h), which means all the day (Day) excluding it's right bound. For ServiceTime valid values range is [0h; 12h), because max service duration is 12h.
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleInterval Methods

The RateScheduleInterval type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

RateScheduleInterval Structure
Resto.Front.Api.Data.Orders Namespace


RateScheduleItem Class

Item of a RateSchedule describing rate of one or more time intervals (Intervals).
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersRateScheduleItem

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RateScheduleItem

The RateScheduleItem type exposes the following members.

Constructors
 | Name | Description
Public method | RateScheduleItem | Initializes a new instance of the RateScheduleItem.
Top
Properties
 | Name | Description
Public property | Intervals | One or more intervals
Public property | Service | Product that represents the rate. Expected to be of type Rate.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


RateScheduleItem Constructor

Initializes a new instance of the RateScheduleItem.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RateScheduleItem(
    IProduct service,
    IReadOnlyList<RateScheduleInterval> intervals
)

Parameters

service
Type: Resto.Front.Api.Data.AssortmentIProduct
intervals
Type: System.Collections.GenericIReadOnlyList RateScheduleInterval
See Also

Reference

RateScheduleItem Class
Resto.Front.Api.Data.Orders Namespace


RateScheduleItem Properties

The RateScheduleItem type exposes the following members.

Properties
 | Name | Description
Public property | Intervals | One or more intervals
Public property | Service | Product that represents the rate. Expected to be of type Rate.
Top
See Also

Reference

RateScheduleItem Class
Resto.Front.Api.Data.Orders Namespace


RateScheduleItem.Intervals Property

RateScheduleItemIntervals Property

One or more intervals

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IReadOnlyList<RateScheduleInterval> Intervals { get; }

Property Value

Type: IReadOnlyList RateScheduleInterval
See Also

Reference

RateScheduleItem Class
Resto.Front.Api.Data.Orders Namespace


RateScheduleItem.Service Property

RateScheduleItemService Property

Product that represents the rate. Expected to be of type Rate.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IProduct Service { get; }

Property Value

Type: IProduct
See Also

Reference

RateScheduleItem Class
Resto.Front.Api.Data.Orders Namespace


RateScheduleItem Methods

The RateScheduleItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RateScheduleItem Class
Resto.Front.Api.Data.Orders Namespace


ServiceTimingMode Enumeration

Time rate calculation modes, which specifies how to treat rate schedule interval bounds.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ServiceTimingMode
Members
Member name | Value | Description
DayTime | 0 | Rate schedule interval bounds are relative to a day start. Allows to have different rates for different times of a day, e.g. reduced price for morning hours and advanced price for evening hours, which helps to keep balance between prime time and unpopular periods of a day.
ServiceTime | 1 | Rate schedule interval bounds are relative to a service start. It allows to have different rates for different service hours, e.g. full price for the first hour of the service, 90% price for the second hour and so on, which motivates to increase service duration.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace
Resto.Front.Api.Data.OrdersRateSchedule
Resto.Front.Api.Data.OrdersRateScheduleInterval


WriteoffOptions Class

Options to delete and write-off printed order items.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.OrdersWriteoffOptions

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class WriteoffOptions

The WriteoffOptions type exposes the following members.

Properties
 | Name | Description
Public property | RemovalType | Used removal type to delete printed order items.
Public property | User | Selected user, which required to WriteoffToUser write-off type.
Public property | WriteoffType | Used write-off type to delete printed order items.
Top
Methods
 | Name | Description
 | Auto | Returns the write-off options which use the first available write-off type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WithoutWriteoff | Returns the write-off options which delete printed order item without write-off.
 | WriteoffToCafe | Returns the write-off options which delete printed order item to the cafe.
 | WriteoffToUser | Returns the write-off options which delete printed order item to the user with open personal session.
 | WriteoffToWaiter | Returns the write-off options which delete printed order item to the order's waiter or current user.
Top
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


WriteoffOptions Properties

The WriteoffOptions type exposes the following members.

Properties
 | Name | Description
Public property | RemovalType | Used removal type to delete printed order items.
Public property | User | Selected user, which required to WriteoffToUser write-off type.
Public property | WriteoffType | Used write-off type to delete printed order items.
Top
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.RemovalType Property

WriteoffOptionsRemovalType Property

Used removal type to delete printed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IRemovalType RemovalType { get; }

Property Value

Type: IRemovalType
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.User Property

WriteoffOptionsUser Property

Selected user, which required to WriteoffToUser write-off type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IUser User { get; }

Property Value

Type: IUser
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.WriteoffType Property

WriteoffOptionsWriteoffType Property

Used write-off type to delete printed order items.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public WriteoffOptionsType WriteoffType { get; }

Property Value

Type: WriteoffOptionsType
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions Methods

The WriteoffOptions type exposes the following members.

Methods
 | Name | Description
 | Auto | Returns the write-off options which use the first available write-off type.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WithoutWriteoff | Returns the write-off options which delete printed order item without write-off.
 | WriteoffToCafe | Returns the write-off options which delete printed order item to the cafe.
 | WriteoffToUser | Returns the write-off options which delete printed order item to the user with open personal session.
 | WriteoffToWaiter | Returns the write-off options which delete printed order item to the order's waiter or current user.
Top
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.Auto Method

WriteoffOptionsAuto Method

Returns the write-off options which use the first available write-off type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static WriteoffOptions Auto(
    IRemovalType removalType,
    IUser defaultWriteoffUser = null
)

Parameters

removalType
Type: Resto.Front.Api.Data.OrdersIRemovalType
defaultWriteoffUser (Optional)
Type: Resto.Front.Api.Data.SecurityIUser

Return Value

Type: WriteoffOptions
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.WithoutWriteoff Method

WriteoffOptionsWithoutWriteoff Method

Returns the write-off options which delete printed order item without write-off.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static WriteoffOptions WithoutWriteoff(
    IRemovalType removalType
)

Parameters

removalType
Type: Resto.Front.Api.Data.OrdersIRemovalType

Return Value

Type: WriteoffOptions
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.WriteoffToCafe Method

WriteoffOptionsWriteoffToCafe Method

Returns the write-off options which delete printed order item to the cafe.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static WriteoffOptions WriteoffToCafe(
    IRemovalType removalType
)

Parameters

removalType
Type: Resto.Front.Api.Data.OrdersIRemovalType

Return Value

Type: WriteoffOptions
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.WriteoffToUser Method

WriteoffOptionsWriteoffToUser Method

Returns the write-off options which delete printed order item to the user with open personal session.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static WriteoffOptions WriteoffToUser(
    IRemovalType removalType,
    IUser writeoffUser
)

Parameters

removalType
Type: Resto.Front.Api.Data.OrdersIRemovalType
writeoffUser
Type: Resto.Front.Api.Data.SecurityIUser

Return Value

Type: WriteoffOptions
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.WriteoffToWaiter Method

WriteoffOptionsWriteoffToWaiter Method

Returns the write-off options which delete printed order item to the order's waiter or current user.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static WriteoffOptions WriteoffToWaiter(
    IRemovalType removalType
)

Parameters

removalType
Type: Resto.Front.Api.Data.OrdersIRemovalType

Return Value

Type: WriteoffOptions
See Also

Reference

WriteoffOptions Class
Resto.Front.Api.Data.Orders Namespace


WriteoffOptions.Type Enumeration

WriteoffOptionsType Enumeration

Describes the write-off type, which required to delete printed dishes.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum Type
Members
Member name | Value | Description
Auto | 0 | Uses the first available write-off type.
WithoutWriteoff | 1 | Uses removing without write-off.
WriteoffToCafe | 2 | Uses removing to the cafe.
WriteoffToWaiter | 3 | Uses removing to the order's waiter or current user.
WriteoffToUser | 4 | Uses removing to the user with open personal session.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


WriteoffType Enumeration

Describes available write-off types of removal type.

Namespace: Resto.Front.Api.Data.Orders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum WriteoffType
Members
Member name | Value | Description
None | 0 | Removing without write-off.
Cafe | 1 | Removing to the cafe is available.
Waiter | 2 | Removing to the order's waiter or current user is available.
User | 4 | Removing to the user with open personal session is available.
See Also

Reference

Resto.Front.Api.Data.Orders Namespace


Resto.Front.Api.Data.Organization Namespace

Interfaces
 | Interface | Description
Public interface | IConception | Conception of point of sale.
Public interface | ICurrencySettings | Currency settings
Public interface | IDeliverySettings |
Public interface | IHostTerminalSettings | Settings of the local terminal.
Public interface | IOrderType | Order type
Public interface | IPointOfSale | Point of sale
Public interface | IRestaurant |
Public interface | ITerminal | The device on which the iikoFront application is installed.
Public interface | ITerminalsGroup |
Public interface | ITransportSettings | iikoTransport settings.
Enumerations
 | Enumeration | Description
Public enumeration | CanDeleteOrdersOutOfCafeSession | Setting "Is it possible to delete orders with closed cafe session".
Public enumeration | DeliverySettingsServiceType | Available service types for delivery settings.
Public enumeration | OrderServiceTypes | Describes different servicing types.
Public enumeration | OrderTypeFillRequirements | Order type filling requirements


CanDeleteOrdersOutOfCafeSession Enumeration

Setting "Is it possible to delete orders with closed cafe session".

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum CanDeleteOrdersOutOfCafeSession
Members
Member name | Value | Description
NotAllowed | 0 | Not allowed.
OnlyWithoutWriteoff | 1 | Only orders without writeoff and payment.
All | 2 | Any orders without payment.
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


DeliverySettingsServiceType Enumeration

Available service types for delivery settings.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum DeliverySettingsServiceType
Members
Member name | Value | Description
CourierOnly | 0 | Delivered only with courier.
SelfServiceOnly | 1 | Taken away only by customer.
CourierAndSelfService | 2 | Both.
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IConception Interface

Conception of point of sale.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IConception : ISerializable,
    IEntity

The IConception type exposes the following members.

Properties
 | Name | Description
Public property | Code | Code of conception
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of conception
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IConception Properties

The IConception type exposes the following members.

Properties
 | Name | Description
Public property | Code | Code of conception
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of conception
Top
See Also

Reference

IConception Interface
Resto.Front.Api.Data.Organization Namespace


IConception.Code Property

IConceptionCode Property

Code of conception

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Code { get; }

Property Value

Type: String
See Also

Reference

IConception Interface
Resto.Front.Api.Data.Organization Namespace


IConception.Name Property

IConceptionName Property

Name of conception

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IConception Interface
Resto.Front.Api.Data.Organization Namespace


IConception Methods

The IConception type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IConception Interface
Resto.Front.Api.Data.Organization Namespace


ICurrencySettings Interface

Currency settings

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICurrencySettings : ISerializable

The ICurrencySettings type exposes the following members.

Properties
 | Name | Description
Public property | FormatInfo | Provides culture-specific information for formatting and parsing numeric values
Public property | MinimumDenomination | Minimum denomination
Public property | ShowFractionalPart | Should show the fractional part
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


ICurrencySettings Properties

The ICurrencySettings type exposes the following members.

Properties
 | Name | Description
Public property | FormatInfo | Provides culture-specific information for formatting and parsing numeric values
Public property | MinimumDenomination | Minimum denomination
Public property | ShowFractionalPart | Should show the fractional part
Top
See Also

Reference

ICurrencySettings Interface
Resto.Front.Api.Data.Organization Namespace


ICurrencySettings.FormatInfo Property

ICurrencySettingsFormatInfo Property

Provides culture-specific information for formatting and parsing numeric values

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
NumberFormatInfo FormatInfo { get; }

Property Value

Type: NumberFormatInfo
See Also

Reference

ICurrencySettings Interface
Resto.Front.Api.Data.Organization Namespace


ICurrencySettings.MinimumDenomination Property

ICurrencySettingsMinimumDenomination Property

Minimum denomination

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal MinimumDenomination { get; }

Property Value

Type: Decimal
See Also

Reference

ICurrencySettings Interface
Resto.Front.Api.Data.Organization Namespace


ICurrencySettings.ShowFractionalPart Property

ICurrencySettingsShowFractionalPart Property

Should show the fractional part

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ShowFractionalPart { get; }

Property Value

Type: Boolean
See Also

Reference

ICurrencySettings Interface
Resto.Front.Api.Data.Organization Namespace


ICurrencySettings Methods

The ICurrencySettings type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICurrencySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings Interface

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliverySettings : ISerializable

The IDeliverySettings type exposes the following members.

Properties
 | Name | Description
Public property | BeepOnDeliveriesUpdate | Should operator be informed with system sound "beep" when delivery order is created/updated.
Public property | DefaultDeliveryDuration | If the time of delivery of the order at its creation was not explicitly specified, it is considered that the order should be delivered in exactly DefaultDeliveryDuration from the moment of creation. Estimated time = the current time + DefaultDeliveryDuration.
Public property | DefaultSelfServiceDeliveryDuration | Average time of delivery at restaurant for self-service.
Public property | DeliveryBillPrintTimeOption | Delivery bill may be printed either automatically or manually. This option specifies how and when to print delivery bill.
Public property | DeliveryPaymentTimeOption | Order may be paid either before sending a courier to way or after successful delivery before closing. This option specifies when to pay courier deliveries and doesn't affect pick up deliveries.
Public property | MarketingSourceRequired | Check whether input or marketing source(advertising) is required.
Public property | ProcessExternalPrepayOnAddition | Whether external processed payments should be processed as prepays immediately after addition.
Public property | ServiceType | Delivery service type: courier, self-service or both of them.
Public property | SmsNotificationTemplates | Sms notification templates for delivery.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IDeliverySettings Properties

The IDeliverySettings type exposes the following members.

Properties
 | Name | Description
Public property | BeepOnDeliveriesUpdate | Should operator be informed with system sound "beep" when delivery order is created/updated.
Public property | DefaultDeliveryDuration | If the time of delivery of the order at its creation was not explicitly specified, it is considered that the order should be delivered in exactly DefaultDeliveryDuration from the moment of creation. Estimated time = the current time + DefaultDeliveryDuration.
Public property | DefaultSelfServiceDeliveryDuration | Average time of delivery at restaurant for self-service.
Public property | DeliveryBillPrintTimeOption | Delivery bill may be printed either automatically or manually. This option specifies how and when to print delivery bill.
Public property | DeliveryPaymentTimeOption | Order may be paid either before sending a courier to way or after successful delivery before closing. This option specifies when to pay courier deliveries and doesn't affect pick up deliveries.
Public property | MarketingSourceRequired | Check whether input or marketing source(advertising) is required.
Public property | ProcessExternalPrepayOnAddition | Whether external processed payments should be processed as prepays immediately after addition.
Public property | ServiceType | Delivery service type: courier, self-service or both of them.
Public property | SmsNotificationTemplates | Sms notification templates for delivery.
Top
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.BeepOnDeliveriesUpdate Property

IDeliverySettingsBeepOnDeliveriesUpdate Property

Should operator be informed with system sound "beep" when delivery order is created/updated.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool BeepOnDeliveriesUpdate { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.DefaultDeliveryDuration Property

IDeliverySettingsDefaultDeliveryDuration Property

If the time of delivery of the order at its creation was not explicitly specified, it is considered that the order should be delivered in exactly DefaultDeliveryDuration from the moment of creation. Estimated time = the current time + DefaultDeliveryDuration.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan DefaultDeliveryDuration { get; }

Property Value

Type: TimeSpan
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.DefaultSelfServiceDeliveryDuration Property

IDeliverySettingsDefaultSelfServiceDeliveryDuration Property

Average time of delivery at restaurant for self-service.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TimeSpan DefaultSelfServiceDeliveryDuration { get; }

Property Value

Type: TimeSpan
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.DeliveryBillPrintTimeOption Property

IDeliverySettingsDeliveryBillPrintTimeOption Property

Delivery bill may be printed either automatically or manually. This option specifies how and when to print delivery bill.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeliveryBillPrintTimeOption DeliveryBillPrintTimeOption { get; }

Property Value

Type: DeliveryBillPrintTimeOption
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.DeliveryPaymentTimeOption Property

IDeliverySettingsDeliveryPaymentTimeOption Property

Order may be paid either before sending a courier to way or after successful delivery before closing. This option specifies when to pay courier deliveries and doesn't affect pick up deliveries.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeliveryPaymentTimeOption DeliveryPaymentTimeOption { get; }

Property Value

Type: DeliveryPaymentTimeOption
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.MarketingSourceRequired Property

IDeliverySettingsMarketingSourceRequired Property

Check whether input or marketing source(advertising) is required.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool MarketingSourceRequired { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.ProcessExternalPrepayOnAddition Property

IDeliverySettingsProcessExternalPrepayOnAddition Property

Whether external processed payments should be processed as prepays immediately after addition.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ProcessExternalPrepayOnAddition { get; }

Property Value

Type: Boolean
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.ServiceType Property

IDeliverySettingsServiceType Property

Delivery service type: courier, self-service or both of them.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeliverySettingsServiceType ServiceType { get; }

Property Value

Type: DeliverySettingsServiceType
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings.SmsNotificationTemplates Property

IDeliverySettingsSmsNotificationTemplates Property

Sms notification templates for delivery.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeliverySmsNotificationTemplates SmsNotificationTemplates { get; }

Property Value

Type: DeliverySmsNotificationTemplates
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IDeliverySettings Methods

The IDeliverySettings type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeliverySettings Interface
Resto.Front.Api.Data.Organization Namespace


IHostTerminalSettings Interface

Settings of the local terminal.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IHostTerminalSettings : ISerializable,
    IEntity

The IHostTerminalSettings type exposes the following members.

Properties
 | Name | Description
Public property | Culture | UI culture info of the iikoFront app.
Public property | Id | (Inherited from IEntity.)
Public property | IsMainTerminal | Whether host terminal is the main terminal of group. Plugin with IsSingleInstance in its manifest will be loaded on main terminal.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IHostTerminalSettings Properties

The IHostTerminalSettings type exposes the following members.

Properties
 | Name | Description
Public property | Culture | UI culture info of the iikoFront app.
Public property | Id | (Inherited from IEntity.)
Public property | IsMainTerminal | Whether host terminal is the main terminal of group. Plugin with IsSingleInstance in its manifest will be loaded on main terminal.
Top
See Also

Reference

IHostTerminalSettings Interface
Resto.Front.Api.Data.Organization Namespace


IHostTerminalSettings.Culture Property

IHostTerminalSettingsCulture Property

UI culture info of the iikoFront app.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CultureInfo Culture { get; }

Property Value

Type: CultureInfo
See Also

Reference

IHostTerminalSettings Interface
Resto.Front.Api.Data.Organization Namespace


IHostTerminalSettings.IsMainTerminal Property

IHostTerminalSettingsIsMainTerminal Property

Whether host terminal is the main terminal of group. Plugin with IsSingleInstance in its manifest will be loaded on main terminal.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsMainTerminal { get; }

Property Value

Type: Boolean
See Also

Reference

IHostTerminalSettings Interface
Resto.Front.Api.Data.Organization Namespace


IHostTerminalSettings Methods

The IHostTerminalSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IHostTerminalSettings Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType Interface

Order type

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderType : ISerializable,
    IEntity

The IOrderType type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Gets a value that indicates whether this order type can be set to orders. Order type can be activated or deactivated via iikoOffice.
Public property | IsDefaultForServiceType | Gets a value that indicates whether this order type set by default to orders with corresponding service type.
Public property | Name | Order type name.
Public property | OrderServiceType | Orders of which service type this order type is applicable for. There is only one service type, single enum value, despite of the flags attribute.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IOrderType Properties

The IOrderType type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Gets a value that indicates whether this order type can be set to orders. Order type can be activated or deactivated via iikoOffice.
Public property | IsDefaultForServiceType | Gets a value that indicates whether this order type set by default to orders with corresponding service type.
Public property | Name | Order type name.
Public property | OrderServiceType | Orders of which service type this order type is applicable for. There is only one service type, single enum value, despite of the flags attribute.
Top
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType.IsActive Property

IOrderTypeIsActive Property

Gets a value that indicates whether this order type can be set to orders. Order type can be activated or deactivated via iikoOffice.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType.IsDefaultForServiceType Property

IOrderTypeIsDefaultForServiceType Property

Gets a value that indicates whether this order type set by default to orders with corresponding service type.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsDefaultForServiceType { get; }

Property Value

Type: Boolean
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType.Name Property

IOrderTypeName Property

Order type name.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType.OrderServiceType Property

IOrderTypeOrderServiceType Property

Orders of which service type this order type is applicable for. There is only one service type, single enum value, despite of the flags attribute.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderServiceTypes OrderServiceType { get; }

Property Value

Type: OrderServiceTypes
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IOrderType Methods

The IOrderType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderType Interface
Resto.Front.Api.Data.Organization Namespace


IPointOfSale Interface

Point of sale

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPointOfSale : ISerializable,
    IEntity

The IPointOfSale type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | CashRegister of current point of sale
Public property | Conception | Conception of current point of sale
Public property | Id | (Inherited from IEntity.)
Public property | Name | Point of sale name.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IPointOfSale Properties

The IPointOfSale type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | CashRegister of current point of sale
Public property | Conception | Conception of current point of sale
Public property | Id | (Inherited from IEntity.)
Public property | Name | Point of sale name.
Top
See Also

Reference

IPointOfSale Interface
Resto.Front.Api.Data.Organization Namespace


IPointOfSale.CashRegister Property

IPointOfSaleCashRegister Property

CashRegister of current point of sale

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo CashRegister { get; }

Property Value

Type: ICashRegisterInfo
See Also

Reference

IPointOfSale Interface
Resto.Front.Api.Data.Organization Namespace


IPointOfSale.Conception Property

IPointOfSaleConception Property

Conception of current point of sale

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IConception Conception { get; }

Property Value

Type: IConception
See Also

Reference

IPointOfSale Interface
Resto.Front.Api.Data.Organization Namespace


IPointOfSale.Name Property

IPointOfSaleName Property

Point of sale name.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IPointOfSale Interface
Resto.Front.Api.Data.Organization Namespace


IPointOfSale Methods

The IPointOfSale type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPointOfSale Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant Interface

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IRestaurant : ISerializable

The IRestaurant type exposes the following members.

Properties
 | Name | Description
Public property | AccountingReasonCode |
Public property | Address | Restaurant address.
Public property | CanDeleteOrdersOutOfCafeSession | Is it possible to delete orders with closed cafe session.
Public property | CompanyName | Name of the company from the iikoRms license.
Public property | CrmId | Unique identifier of the organization (installation of iikoRms).
Public property | Currency |
Public property | DepartmentCode |
Public property | DepartmentId |
Public property | IikoUid | Serial number of the iikoRms license (temporary).
Public property | IsRoundingDownOrderSum |
Public property | IsRoundingPricePerUnit |
Public property | LegalAddress | Company legal address.
Public property | LegalAddressDetailed | Company legal address detailed.
Public property | LegalName | Company legal name.
Public property | Name | Restaurant name.
Public property | OrderTypeFillRequirements | Order type filling requirements.
Public property | RegistrationNumber |
Public property | TaxId | Company Tax Identification Number (TIN).
Public property | UsePersonalRoles | Whether the restaurant uses roles (IRole) for personal sessions.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


IRestaurant Properties

The IRestaurant type exposes the following members.

Properties
 | Name | Description
Public property | AccountingReasonCode |
Public property | Address | Restaurant address.
Public property | CanDeleteOrdersOutOfCafeSession | Is it possible to delete orders with closed cafe session.
Public property | CompanyName | Name of the company from the iikoRms license.
Public property | CrmId | Unique identifier of the organization (installation of iikoRms).
Public property | Currency |
Public property | DepartmentCode |
Public property | DepartmentId |
Public property | IikoUid | Serial number of the iikoRms license (temporary).
Public property | IsRoundingDownOrderSum |
Public property | IsRoundingPricePerUnit |
Public property | LegalAddress | Company legal address.
Public property | LegalAddressDetailed | Company legal address detailed.
Public property | LegalName | Company legal name.
Public property | Name | Restaurant name.
Public property | OrderTypeFillRequirements | Order type filling requirements.
Public property | RegistrationNumber |
Public property | TaxId | Company Tax Identification Number (TIN).
Public property | UsePersonalRoles | Whether the restaurant uses roles (IRole) for personal sessions.
Top
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.AccountingReasonCode Property

IRestaurantAccountingReasonCode Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string AccountingReasonCode { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.Address Property

IRestaurantAddress Property

Restaurant address.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Address { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.CanDeleteOrdersOutOfCafeSession Property

IRestaurantCanDeleteOrdersOutOfCafeSession Property

Is it possible to delete orders with closed cafe session.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CanDeleteOrdersOutOfCafeSession CanDeleteOrdersOutOfCafeSession { get; }

Property Value

Type: CanDeleteOrdersOutOfCafeSession
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.CompanyName Property

IRestaurantCompanyName Property

Name of the company from the iikoRms license.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CompanyName { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.CrmId Property

IRestaurantCrmId Property

Unique identifier of the organization (installation of iikoRms).

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int? CrmId { get; }

Property Value

Type: Nullable Int32
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.Currency Property

IRestaurantCurrency Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICurrencySettings Currency { get; }

Property Value

Type: ICurrencySettings
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.DepartmentCode Property

IRestaurantDepartmentCode Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string DepartmentCode { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.DepartmentId Property

IRestaurantDepartmentId Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid DepartmentId { get; }

Property Value

Type: Guid
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.IikoUid Property

IRestaurantIikoUid Property

Serial number of the iikoRms license (temporary).

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string IikoUid { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.IsRoundingDownOrderSum Property

IRestaurantIsRoundingDownOrderSum Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsRoundingDownOrderSum { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.IsRoundingPricePerUnit Property

IRestaurantIsRoundingPricePerUnit Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsRoundingPricePerUnit { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.LegalAddress Property

IRestaurantLegalAddress Property

Company legal address.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string LegalAddress { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.LegalAddressDetailed Property

IRestaurantLegalAddressDetailed Property

Company legal address detailed.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
LegalAddress LegalAddressDetailed { get; }

Property Value

Type: LegalAddress
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.LegalName Property

IRestaurantLegalName Property

Company legal name.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string LegalName { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.Name Property

IRestaurantName Property

Restaurant name.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.OrderTypeFillRequirements Property

IRestaurantOrderTypeFillRequirements Property

Order type filling requirements.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderTypeFillRequirements OrderTypeFillRequirements { get; }

Property Value

Type: OrderTypeFillRequirements
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.RegistrationNumber Property

IRestaurantRegistrationNumber Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string RegistrationNumber { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.TaxId Property

IRestaurantTaxId Property

Company Tax Identification Number (TIN).

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string TaxId { get; }

Property Value

Type: String
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant.UsePersonalRoles Property

IRestaurantUsePersonalRoles Property

Whether the restaurant uses roles (IRole) for personal sessions.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool UsePersonalRoles { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


IRestaurant Methods

The IRestaurant type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IRestaurant Interface
Resto.Front.Api.Data.Organization Namespace


ITerminal Interface

The device on which the iikoFront application is installed.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITerminal : ISerializable,
    IEntity

The ITerminal type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Friendly name of the terminal.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


ITerminal Properties

The ITerminal type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Friendly name of the terminal.
Top
See Also

Reference

ITerminal Interface
Resto.Front.Api.Data.Organization Namespace


ITerminal.Name Property

ITerminalName Property

Friendly name of the terminal.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ITerminal Interface
Resto.Front.Api.Data.Organization Namespace


ITerminal Methods

The ITerminal type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITerminal Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup Interface

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITerminalsGroup : ISerializable,
    IEntity

The ITerminalsGroup type exposes the following members.

Properties
 | Name | Description
Public property | AskCashierForMultiCashRegisterPayment | Whether cashier will be asked for multiple cash register payment.
Public property | DefaultTable | The default table of a group.
Public property | Id | (Inherited from IEntity.)
Public property | IsTabMode | Tab mode specified.
Public property | MainTerminal | The main terminal of group. Returns null if the main terminal is not specified.
Public property | MaxCourseNumber | The maximum number of course.
Public property | Name |
Public property | PriceCategory |
Public property | ServicePrintOnOrderExit |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup Properties

The ITerminalsGroup type exposes the following members.

Properties
 | Name | Description
Public property | AskCashierForMultiCashRegisterPayment | Whether cashier will be asked for multiple cash register payment.
Public property | DefaultTable | The default table of a group.
Public property | Id | (Inherited from IEntity.)
Public property | IsTabMode | Tab mode specified.
Public property | MainTerminal | The main terminal of group. Returns null if the main terminal is not specified.
Public property | MaxCourseNumber | The maximum number of course.
Public property | Name |
Public property | PriceCategory |
Public property | ServicePrintOnOrderExit |
Top
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.AskCashierForMultiCashRegisterPayment Property

ITerminalsGroupAskCashierForMultiCashRegisterPayment Property

Whether cashier will be asked for multiple cash register payment.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool AskCashierForMultiCashRegisterPayment { get; }

Property Value

Type: Boolean
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.DefaultTable Property

ITerminalsGroupDefaultTable Property

The default table of a group.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITable DefaultTable { get; }

Property Value

Type: ITable
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.IsTabMode Property

ITerminalsGroupIsTabMode Property

Tab mode specified.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsTabMode { get; }

Property Value

Type: Boolean
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.MainTerminal Property

ITerminalsGroupMainTerminal Property

The main terminal of group. Returns null if the main terminal is not specified.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminal MainTerminal { get; }

Property Value

Type: ITerminal
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.MaxCourseNumber Property

ITerminalsGroupMaxCourseNumber Property

The maximum number of course.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int MaxCourseNumber { get; }

Property Value

Type: Int32
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.Name Property

ITerminalsGroupName Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.PriceCategory Property

ITerminalsGroupPriceCategory Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory PriceCategory { get; }

Property Value

Type: IPriceCategory
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup.ServicePrintOnOrderExit Property

ITerminalsGroupServicePrintOnOrderExit Property

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ServicePrintOnOrderExit { get; }

Property Value

Type: Boolean
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITerminalsGroup Methods

The ITerminalsGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITerminalsGroup Interface
Resto.Front.Api.Data.Organization Namespace


ITransportSettings Interface

iikoTransport settings.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITransportSettings : ISerializable

The ITransportSettings type exposes the following members.

Properties
 | Name | Description
Public property | ServerUri | iikoTransport server URI (TransportService).
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


ITransportSettings Properties

The ITransportSettings type exposes the following members.

Properties
 | Name | Description
Public property | ServerUri | iikoTransport server URI (TransportService).
Top
See Also

Reference

ITransportSettings Interface
Resto.Front.Api.Data.Organization Namespace


ITransportSettings.ServerUri Property

ITransportSettingsServerUri Property

iikoTransport server URI (TransportService).

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ServerUri { get; }

Property Value

Type: String
See Also

Reference

ITransportSettings Interface
Resto.Front.Api.Data.Organization Namespace


ITransportSettings Methods

The ITransportSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITransportSettings Interface
Resto.Front.Api.Data.Organization Namespace


OrderServiceTypes Enumeration

Describes different servicing types.

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum OrderServiceTypes
Members
Member name | Value | Description
Common | 1 | Regular order to be served on table or sold as a fastfood.
DeliveryByCourier | 2 | Delivery order to be delivered by courier.
DeliveryByClient | 4 | Delivery order to be picked up by client himself.
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


OrderTypeFillRequirements Enumeration

Order type filling requirements

Namespace: Resto.Front.Api.Data.Organization
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum OrderTypeFillRequirements
Members
Member name | Value | Description
NotRequired | 0 | Filling the order type don't required
FillOnOrderCreate | 1 | Filling the order type on order creating
FillOnServicePrint | 2 | Filling the order type on service printing
FillOnOrderBill | 3 | Filling the order type on order billing
See Also

Reference

Resto.Front.Api.Data.Organization Namespace


Resto.Front.Api.Data.Organization.Sections Namespace

Classes
 | Class | Description
Public class | RestaurantSectionExtensions | Provides a set of static methods to access referenced entities.
Interfaces
 | Interface | Description
Public interface | IRestaurantSection |
Public interface | ISectionSchema | Represents a graphical schema of a IRestaurantSection. Use TryGetSectionSchemaByRestaurantSection(IRestaurantSection) or TryGetSectionSchema(IRestaurantSection) to get schema for a specific section.
Public interface | ITable |


IRestaurantSection Interface

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IRestaurantSection : ISerializable,
    IEntity

The IRestaurantSection type exposes the following members.

Properties
 | Name | Description
Public property | DefaultOrderType | Default order type for section.
Public property | DefaultPriceCategory | Default price category for section.
Public property | Id | (Inherited from IEntity.)
Public property | KitchenCoursesEnabled | Whether courses are enabled at section.
Public property | Name |
Public property | OrderItemCommentsEnabled | Whether comments to cooking items are enabled at section.
Public property | OrderItemsGroupingEnabled | Whether combining cooking items into groups is enabled at the section.
Public property | Tables |
Public property | TerminalsGroup | Terminals group to which this section belongs.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | TryGetSectionSchema | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist. (Defined by RestaurantSectionExtensions.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection Properties

The IRestaurantSection type exposes the following members.

Properties
 | Name | Description
Public property | DefaultOrderType | Default order type for section.
Public property | DefaultPriceCategory | Default price category for section.
Public property | Id | (Inherited from IEntity.)
Public property | KitchenCoursesEnabled | Whether courses are enabled at section.
Public property | Name |
Public property | OrderItemCommentsEnabled | Whether comments to cooking items are enabled at section.
Public property | OrderItemsGroupingEnabled | Whether combining cooking items into groups is enabled at the section.
Public property | Tables |
Public property | TerminalsGroup | Terminals group to which this section belongs.
Top
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.DefaultOrderType Property

IRestaurantSectionDefaultOrderType Property

Default order type for section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderType DefaultOrderType { get; }

Property Value

Type: IOrderType
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.DefaultPriceCategory Property

IRestaurantSectionDefaultPriceCategory Property

Default price category for section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPriceCategory DefaultPriceCategory { get; }

Property Value

Type: IPriceCategory
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.KitchenCoursesEnabled Property

IRestaurantSectionKitchenCoursesEnabled Property

Whether courses are enabled at section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool KitchenCoursesEnabled { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.Name Property

IRestaurantSectionName Property

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.OrderItemCommentsEnabled Property

IRestaurantSectionOrderItemCommentsEnabled Property

Whether comments to cooking items are enabled at section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool OrderItemCommentsEnabled { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.OrderItemsGroupingEnabled Property

IRestaurantSectionOrderItemsGroupingEnabled Property

Whether combining cooking items into groups is enabled at the section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool OrderItemsGroupingEnabled { get; }

Property Value

Type: Boolean
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.Tables Property

IRestaurantSectionTables Property

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<ITable> Tables { get; }

Property Value

Type: IReadOnlyList ITable
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection.TerminalsGroup Property

IRestaurantSectionTerminalsGroup Property

Terminals group to which this section belongs.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ITerminalsGroup TerminalsGroup { get; }

Property Value

Type: ITerminalsGroup
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


IRestaurantSection Methods

The IRestaurantSection type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | TryGetSectionSchema | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist. (Defined by RestaurantSectionExtensions.)
Top
See Also

Reference

IRestaurantSection Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema Interface

Represents a graphical schema of a IRestaurantSection. Use TryGetSectionSchemaByRestaurantSection(IRestaurantSection) or TryGetSectionSchema(IRestaurantSection) to get schema for a specific section.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISectionSchema : ISerializable

The ISectionSchema type exposes the following members.

Properties
 | Name | Description
Public property | EllipseElements | Collection of restaurant section ellipses.
Public property | Height | Section schema height in px
Public property | ImageElements | Collection of restaurant section images.
Public property | MarkElements | Collection of restaurant section marks.
Public property | RectangleElements | Collection of restaurant section rectangles.
Public property | TableElements | Collection of restaurant section tables.
Public property | Version | Version of the schema, which can be used to track schema changes.
Public property | Width | Section schema width in px
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema Properties

The ISectionSchema type exposes the following members.

Properties
 | Name | Description
Public property | EllipseElements | Collection of restaurant section ellipses.
Public property | Height | Section schema height in px
Public property | ImageElements | Collection of restaurant section images.
Public property | MarkElements | Collection of restaurant section marks.
Public property | RectangleElements | Collection of restaurant section rectangles.
Public property | TableElements | Collection of restaurant section tables.
Public property | Version | Version of the schema, which can be used to track schema changes.
Public property | Width | Section schema width in px
Top
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.EllipseElements Property

ISectionSchemaEllipseElements Property

Collection of restaurant section ellipses.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<RestaurantSectionEllipse> EllipseElements { get; }

Property Value

Type: IReadOnlyList RestaurantSectionEllipse
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.Height Property

ISectionSchemaHeight Property

Section schema height in px

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Height { get; }

Property Value

Type: Int32
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.ImageElements Property

ISectionSchemaImageElements Property

Collection of restaurant section images.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<RestaurantSectionImage> ImageElements { get; }

Property Value

Type: IReadOnlyList RestaurantSectionImage
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.MarkElements Property

ISectionSchemaMarkElements Property

Collection of restaurant section marks.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<RestaurantSectionMark> MarkElements { get; }

Property Value

Type: IReadOnlyList RestaurantSectionMark
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.RectangleElements Property

ISectionSchemaRectangleElements Property

Collection of restaurant section rectangles.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<RestaurantSectionRectangle> RectangleElements { get; }

Property Value

Type: IReadOnlyList RestaurantSectionRectangle
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.TableElements Property

ISectionSchemaTableElements Property

Collection of restaurant section tables.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<RestaurantSectionTable> TableElements { get; }

Property Value

Type: IReadOnlyList RestaurantSectionTable
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.Version Property

ISectionSchemaVersion Property

Version of the schema, which can be used to track schema changes.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Version { get; }

Property Value

Type: Int32
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema.Width Property

ISectionSchemaWidth Property

Section schema width in px

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Width { get; }

Property Value

Type: Int32
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ISectionSchema Methods

The ISectionSchema type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ISectionSchema Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable Interface

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITable : ISerializable, IEntity

The ITable type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Gets a value that indicates whether new orders can be created on this table. The table can be activated or deactivated via iikoOffice.
Public property | Name | Table name specified in the organization settings.
Public property | Number | Number of the table.
Public property | SeatingCapacity | Seating capacity of the table.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Organization.Sections Namespace


ITable Properties

The ITable type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | IsActive | Gets a value that indicates whether new orders can be created on this table. The table can be activated or deactivated via iikoOffice.
Public property | Name | Table name specified in the organization settings.
Public property | Number | Number of the table.
Public property | SeatingCapacity | Seating capacity of the table.
Top
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable.IsActive Property

ITableIsActive Property

Gets a value that indicates whether new orders can be created on this table. The table can be activated or deactivated via iikoOffice.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsActive { get; }

Property Value

Type: Boolean
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable.Name Property

ITableName Property

Table name specified in the organization settings.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable.Number Property

ITableNumber Property

Number of the table.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Number { get; }

Property Value

Type: Int32
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable.SeatingCapacity Property

ITableSeatingCapacity Property

Seating capacity of the table.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int SeatingCapacity { get; }

Property Value

Type: Int32
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


ITable Methods

The ITable type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITable Interface
Resto.Front.Api.Data.Organization.Sections Namespace


RestaurantSectionExtensions Class

Provides a set of static methods to access referenced entities.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.Organization.SectionsRestaurantSectionExtensions

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class RestaurantSectionExtensions

The RestaurantSectionExtensions type exposes the following members.

Methods
Name | Description
TryGetSectionSchema | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.
Top
See Also

Reference

Resto.Front.Api.Data.Organization.Sections Namespace


RestaurantSectionExtensions Methods

The RestaurantSectionExtensions type exposes the following members.

Methods
Name | Description
TryGetSectionSchema | Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.
Top
See Also

Reference

RestaurantSectionExtensions Class
Resto.Front.Api.Data.Organization.Sections Namespace


RestaurantSectionExtensions.TryGetSectionSchema Method

RestaurantSectionExtensionsTryGetSectionSchema Method

Returns sectionSchema of the specified restaurantSection or null if restaurantSection doesn't exist.

Namespace: Resto.Front.Api.Data.Organization.Sections
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static ISectionSchema TryGetSectionSchema(
    this IRestaurantSection restaurantSection
)

Parameters

restaurantSection
Type: Resto.Front.Api.Data.Organization.SectionsIRestaurantSection

Return Value

Type: ISectionSchema

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IRestaurantSection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

RestaurantSectionExtensions Class
Resto.Front.Api.Data.Organization.Sections Namespace


Resto.Front.Api.Data.Payments Namespace

Classes
 | Class | Description
Public class | CardPaymentItemAdditionalData | Additional information for card payment types.
Public class | ChequeAdditionalInfo | Cheque additional information according to russian federal law #54.
Public class | CreditPaymentItemAdditionalData | Additional information for credit payment types.
Public class | ExternalPaymentItemAdditionalData | Additional data for external payment item.
Public class | IikoCard51PaymentItemAdditionalData | Additional data for iikoCard51 payment item.
Public class | OrganizationDetailsInfo | Organization details information.
Public class | PlastekPaymentItemAdditionalData |
Public class | PlaziusPaymentItemAdditionalData |
Public class | VoucherPaymentItemAdditionalData | Additional information for voucher payment types.
Public class | WriteoffPaymentItemAdditionalData | Additional information for writeoff payment types.
Interfaces
 | Interface | Description
Public interface | IDonationType |
Public interface | IPaymentItem |
Public interface | IPaymentItemAdditionalData | Common base interface for payment type specific DTOs carrying properties with additional data.
Public interface | IPaymentType |
Enumerations
 | Enumeration | Description
Public enumeration | IikoCard51SearchScope |
Public enumeration | IikoNetCardExternalIdType |
Public enumeration | PaymentTypeKind | Kind of a payment type.


CardPaymentItemAdditionalData Class

Additional information for card payment types.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsCardPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CardPaymentItemAdditionalData : IEquatable<CardPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The CardPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | CardPaymentItemAdditionalData | Initializes a new instance of the CardPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | CardNumber | Card number.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CardPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData Constructor

Initializes a new instance of the CardPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CardPaymentItemAdditionalData()
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData Properties

The CardPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | CardNumber | Card number.
Top
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData.CardNumber Property

CardPaymentItemAdditionalDataCardNumber Property

Card number.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CardNumber { get; set; }

Property Value

Type: String
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData Methods

The CardPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CardPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData.Equals Method

CardPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CardPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData.Equals Method (Object)

CardPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

CardPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData.Equals Method (CardPaymentItemAdditionalData)

CardPaymentItemAdditionalDataEquals Method (CardPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    CardPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsCardPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

CardPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


CardPaymentItemAdditionalData.GetHashCode Method

CardPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

CardPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo Class

Cheque additional information according to russian federal law #54.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsChequeAdditionalInfo

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ChequeAdditionalInfo

The ChequeAdditionalInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ChequeAdditionalInfo | Initializes a new instance of the ChequeAdditionalInfo class.
Top
Properties
 | Name | Description
Public property | Email | Email to send cheque information.
Public property | NeedReceipt | Whether paper cheque should be printed.
Public property | Phone | Phone to send cheque information (by sms).
Public property | SettlementPlace | Settlement place.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
For Russia only. For other countries use null instead of this class.
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo Constructor

Initializes a new instance of the ChequeAdditionalInfo class.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ChequeAdditionalInfo(
    bool needReceipt,
    string phone,
    string email,
    string settlementPlace
)

Parameters

needReceipt
Type: SystemBoolean
Whether a paper receipt should be printed. Must be true if e-receipt (sms, email) will not be sent.
phone
Type: SystemString
Phone number to send e-receipt as sms.
email
Type: SystemString
Email address to send e-receipt as email.
settlementPlace
Type: SystemString
Settlement place.
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo Properties

The ChequeAdditionalInfo type exposes the following members.

Properties
 | Name | Description
Public property | Email | Email to send cheque information.
Public property | NeedReceipt | Whether paper cheque should be printed.
Public property | Phone | Phone to send cheque information (by sms).
Public property | SettlementPlace | Settlement place.
Top
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo.Email Property

ChequeAdditionalInfoEmail Property

Email to send cheque information.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Email { get; }

Property Value

Type: String
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo.NeedReceipt Property

ChequeAdditionalInfoNeedReceipt Property

Whether paper cheque should be printed.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool NeedReceipt { get; }

Property Value

Type: Boolean
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo.Phone Property

ChequeAdditionalInfoPhone Property

Phone to send cheque information (by sms).

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Phone { get; }

Property Value

Type: String
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo.SettlementPlace Property

ChequeAdditionalInfoSettlementPlace Property

Settlement place.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string SettlementPlace { get; }

Property Value

Type: String
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


ChequeAdditionalInfo Methods

The ChequeAdditionalInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChequeAdditionalInfo Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData Class

Additional information for credit payment types.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsCreditPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CreditPaymentItemAdditionalData : IEquatable<CreditPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The CreditPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | CreditPaymentItemAdditionalData | Initializes a new instance of the CreditPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | CounteragentUserId |
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CreditPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData Constructor

Initializes a new instance of the CreditPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CreditPaymentItemAdditionalData()
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData Properties

The CreditPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | CounteragentUserId |
Top
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData.CounteragentUserId Property

CreditPaymentItemAdditionalDataCounteragentUserId Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CounteragentUserId { get; set; }

Property Value

Type: Guid
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData Methods

The CreditPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CreditPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData.Equals Method

CreditPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(CreditPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData.Equals Method (Object)

CreditPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

CreditPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData.Equals Method (CreditPaymentItemAdditionalData)

CreditPaymentItemAdditionalDataEquals Method (CreditPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    CreditPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsCreditPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

CreditPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


CreditPaymentItemAdditionalData.GetHashCode Method

CreditPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

CreditPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData Class

Additional data for external payment item.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsExternalPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ExternalPaymentItemAdditionalData : IEquatable<ExternalPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The ExternalPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalPaymentItemAdditionalData | Initializes a new instance of the ExternalPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | CustomData | Custom data.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(ExternalPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData Constructor

Initializes a new instance of the ExternalPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalPaymentItemAdditionalData()
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData Properties

The ExternalPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | CustomData | Custom data.
Top
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData.CustomData Property

ExternalPaymentItemAdditionalDataCustomData Property

Custom data.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CustomData { get; set; }

Property Value

Type: String
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData Methods

The ExternalPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(ExternalPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData.Equals Method

ExternalPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(ExternalPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData.Equals Method (Object)

ExternalPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

ExternalPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData.Equals Method (ExternalPaymentItemAdditionalData)

ExternalPaymentItemAdditionalDataEquals Method (ExternalPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    ExternalPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsExternalPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

ExternalPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


ExternalPaymentItemAdditionalData.GetHashCode Method

ExternalPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

ExternalPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IDonationType Interface

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDonationType : ISerializable,
    IEntity

The IDonationType type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of donation type.
Public property | OrderServiceTypes | Orders of which service type this donation type is applicable for.
Public property | PaymentTypes | Assigned payment types of the current donation type.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IDonationType Properties

The IDonationType type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of donation type.
Public property | OrderServiceTypes | Orders of which service type this donation type is applicable for.
Public property | PaymentTypes | Assigned payment types of the current donation type.
Top
See Also

Reference

IDonationType Interface
Resto.Front.Api.Data.Payments Namespace


IDonationType.Name Property

IDonationTypeName Property

Name of donation type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IDonationType Interface
Resto.Front.Api.Data.Payments Namespace


IDonationType.OrderServiceTypes Property

IDonationTypeOrderServiceTypes Property

Orders of which service type this donation type is applicable for.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrderServiceTypes OrderServiceTypes { get; }

Property Value

Type: OrderServiceTypes
See Also

Reference

IDonationType Interface
Resto.Front.Api.Data.Payments Namespace


IDonationType.PaymentTypes Property

IDonationTypePaymentTypes Property

Assigned payment types of the current donation type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPaymentType> PaymentTypes { get; }

Property Value

Type: IReadOnlyList IPaymentType
See Also

Reference

IDonationType Interface
Resto.Front.Api.Data.Payments Namespace


IDonationType Methods

The IDonationType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDonationType Interface
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData Class

Additional data for iikoCard51 payment item.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsIikoCard51PaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class IikoCard51PaymentItemAdditionalData : IEquatable<IikoCard51PaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The IikoCard51PaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | IikoCard51PaymentItemAdditionalData | Initializes a new instance of the IikoCard51PaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | Credential | Guest credential, authorizing payment.
Public property | SearchScope | Guest credential search scope.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(IikoCard51PaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData Constructor

Initializes a new instance of the IikoCard51PaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IikoCard51PaymentItemAdditionalData()
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData Properties

The IikoCard51PaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | Credential | Guest credential, authorizing payment.
Public property | SearchScope | Guest credential search scope.
Top
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.Credential Property

IikoCard51PaymentItemAdditionalDataCredential Property

Guest credential, authorizing payment.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Credential { get; set; }

Property Value

Type: String
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.SearchScope Property

IikoCard51PaymentItemAdditionalDataSearchScope Property

Guest credential search scope.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IikoCard51SearchScope SearchScope { get; set; }

Property Value

Type: IikoCard51SearchScope
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData Methods

The IikoCard51PaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(IikoCard51PaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.Equals Method

IikoCard51PaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(IikoCard51PaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.Equals Method (Object)

IikoCard51PaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.Equals Method (IikoCard51PaymentItemAdditionalData)

IikoCard51PaymentItemAdditionalDataEquals Method (IikoCard51PaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    IikoCard51PaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsIikoCard51PaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


IikoCard51PaymentItemAdditionalData.GetHashCode Method

IikoCard51PaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

IikoCard51PaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


IikoCard51SearchScope Enumeration

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum IikoCard51SearchScope
Members
Member name | Value | Description
Reserved | 0 |
Phone | 1 |
CardNumber | 2 |
CardTrack | 4 |
PaymentToken | 16 |
FindFaceId | 32 |
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IikoNetCardExternalIdType Enumeration

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum IikoNetCardExternalIdType
Members
Member name | Value | Description
Phone | 0 |
MagnetCard | 1 |
Id | 2 |
Barcode | 3 |
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IPaymentItem Interface

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentItem : ISerializable,
    IEntity, IPaymentItemStub

The IPaymentItem type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData |
Public property | DonationType |
Public property | Id | (Inherited from IEntity.)
Public property | IsExternal |
Public property | IsFiscalizedExternally |
Public property | IsPreliminary |
Public property | IsPrepay | Whether payment item is prepay.
Public property | IsProcessedExternally |
Public property | MaxSum | Maximum allowed payment sum, upper bound for the payment. null means default limit value.
Public property | MinSum | Minimum allowed payment sum, lower bound for the payment. null means default limit value.
Public property | OrganizationDetailsInfo | Organization details informations.
Public property | PointOfSale | Point of sale where payment was processed or null if it's not processed.
Public property | Status |
Public property | Sum |
Public property | Type |
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IPaymentItem Properties

The IPaymentItem type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData |
Public property | DonationType |
Public property | Id | (Inherited from IEntity.)
Public property | IsExternal |
Public property | IsFiscalizedExternally |
Public property | IsPreliminary |
Public property | IsPrepay | Whether payment item is prepay.
Public property | IsProcessedExternally |
Public property | MaxSum | Maximum allowed payment sum, upper bound for the payment. null means default limit value.
Public property | MinSum | Minimum allowed payment sum, lower bound for the payment. null means default limit value.
Public property | OrganizationDetailsInfo | Organization details informations.
Public property | PointOfSale | Point of sale where payment was processed or null if it's not processed.
Public property | Status |
Public property | Sum |
Public property | Type |
Top
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.AdditionalData Property

IPaymentItemAdditionalData Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Object AdditionalData { get; }

Property Value

Type: Object
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.DonationType Property

IPaymentItemDonationType Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDonationType DonationType { get; }

Property Value

Type: IDonationType
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.IsExternal Property

IPaymentItemIsExternal Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsExternal { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.IsFiscalizedExternally Property

IPaymentItemIsFiscalizedExternally Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsFiscalizedExternally { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.IsPreliminary Property

IPaymentItemIsPreliminary Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsPreliminary { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.IsPrepay Property

IPaymentItemIsPrepay Property

Whether payment item is prepay.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsPrepay { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.IsProcessedExternally Property

IPaymentItemIsProcessedExternally Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsProcessedExternally { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.MaxSum Property

IPaymentItemMaxSum Property

Maximum allowed payment sum, upper bound for the payment. null means default limit value.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? MaxSum { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.MinSum Property

IPaymentItemMinSum Property

Minimum allowed payment sum, lower bound for the payment. null means default limit value.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal? MinSum { get; }

Property Value

Type: Nullable Decimal
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.OrganizationDetailsInfo Property

IPaymentItemOrganizationDetailsInfo Property

Organization details informations.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
OrganizationDetailsInfo OrganizationDetailsInfo { get; }

Property Value

Type: OrganizationDetailsInfo
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.PointOfSale Property

IPaymentItemPointOfSale Property

Point of sale where payment was processed or null if it's not processed.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPointOfSale PointOfSale { get; }

Property Value

Type: IPointOfSale
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.Status Property

IPaymentItemStatus Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
PaymentStatus Status { get; }

Property Value

Type: PaymentStatus
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.Sum Property

IPaymentItemSum Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Sum { get; }

Property Value

Type: Decimal
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem.Type Property

IPaymentItemType Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentType Type { get; }

Property Value

Type: IPaymentType
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItem Methods

The IPaymentItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPaymentItem Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentItemAdditionalData Interface

Common base interface for payment type specific DTOs carrying properties with additional data.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentItemAdditionalData
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IPaymentType Interface

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentType : ISerializable,
    IEntity

The IPaymentType type exposes the following members.

Properties
 | Name | Description
Public property | CanBeExternalProcessed | Can be added as processed external by AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub).
Public property | CanDisplayChange | If change can be displayed for payment type.
Public property | DiscountType | Recommended IDiscountType to apply with this payment type. You should delete discount item of this discount type if you are deleting payment item of this payment type.
Public property | Id | (Inherited from IEntity.)
Public property | IsCombinable | Is payment type combinable with other payment types.
Public property | IsEnabled | Is payment type enabled for some kind of usage. Specific purposes may have additional constraints.
Public property | IsHidden | Is payment type hidden from payment type selector UI.
Public property | Kind | Kind of the payment type.
Public property | Name | Name of payment type.
Public property | OpenCashDrawerOnPay | Indicates if BaseType needs to open cash drawer.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


IPaymentType Properties

The IPaymentType type exposes the following members.

Properties
 | Name | Description
Public property | CanBeExternalProcessed | Can be added as processed external by AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub).
Public property | CanDisplayChange | If change can be displayed for payment type.
Public property | DiscountType | Recommended IDiscountType to apply with this payment type. You should delete discount item of this discount type if you are deleting payment item of this payment type.
Public property | Id | (Inherited from IEntity.)
Public property | IsCombinable | Is payment type combinable with other payment types.
Public property | IsEnabled | Is payment type enabled for some kind of usage. Specific purposes may have additional constraints.
Public property | IsHidden | Is payment type hidden from payment type selector UI.
Public property | Kind | Kind of the payment type.
Public property | Name | Name of payment type.
Public property | OpenCashDrawerOnPay | Indicates if BaseType needs to open cash drawer.
Top
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.CanBeExternalProcessed Property

IPaymentTypeCanBeExternalProcessed Property

Can be added as processed external by AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub).

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanBeExternalProcessed { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.CanDisplayChange Property

IPaymentTypeCanDisplayChange Property

If change can be displayed for payment type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CanDisplayChange { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.DiscountType Property

IPaymentTypeDiscountType Property

Recommended IDiscountType to apply with this payment type. You should delete discount item of this discount type if you are deleting payment item of this payment type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDiscountType DiscountType { get; }

Property Value

Type: IDiscountType
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.IsCombinable Property

IPaymentTypeIsCombinable Property

Is payment type combinable with other payment types.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsCombinable { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.IsEnabled Property

IPaymentTypeIsEnabled Property

Is payment type enabled for some kind of usage. Specific purposes may have additional constraints.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsEnabled { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.IsHidden Property

IPaymentTypeIsHidden Property

Is payment type hidden from payment type selector UI.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsHidden { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.Kind Property

IPaymentTypeKind Property

Kind of the payment type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
PaymentTypeKind Kind { get; }

Property Value

Type: PaymentTypeKind
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.Name Property

IPaymentTypeName Property

Name of payment type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType.OpenCashDrawerOnPay Property

IPaymentTypeOpenCashDrawerOnPay Property

Indicates if BaseType needs to open cash drawer.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool OpenCashDrawerOnPay { get; }

Property Value

Type: Boolean
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


IPaymentType Methods

The IPaymentType type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPaymentType Interface
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo Class

Organization details information.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class OrganizationDetailsInfo

The OrganizationDetailsInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OrganizationDetailsInfo | Initializes a new instance of the OrganizationDetailsInfo class.
Top
Properties
 | Name | Description
Public property | AccountingReasonCode | Tax Registration Reason Code, KPP of organization.
Public property | Address | Legal address of organization.
Public property | Code | Taxpayer Identification Number, INN of organization.
Public property | CustomerId | Identifier of linked customer.
Public property | Name | Name of organization.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo Constructor

Initializes a new instance of the OrganizationDetailsInfo class.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public OrganizationDetailsInfo(
    Guid customerId,
    string name,
    string code,
    string accountingReasonCode,
    string address
)

Parameters

customerId
Type: SystemGuid
Identifier of linked customer
name
Type: SystemString
Name of organization.
code
Type: SystemString
Taxpayer Identification Number, INN of organization.
accountingReasonCode
Type: SystemString
Tax Registration Reason Code, KPP of organization.
address
Type: SystemString
Legal address of organization.
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo Properties

The OrganizationDetailsInfo type exposes the following members.

Properties
 | Name | Description
Public property | AccountingReasonCode | Tax Registration Reason Code, KPP of organization.
Public property | Address | Legal address of organization.
Public property | Code | Taxpayer Identification Number, INN of organization.
Public property | CustomerId | Identifier of linked customer.
Public property | Name | Name of organization.
Top
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo.AccountingReasonCode Property

OrganizationDetailsInfoAccountingReasonCode Property

Tax Registration Reason Code, KPP of organization.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string AccountingReasonCode { get; }

Property Value

Type: String
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo.Address Property

OrganizationDetailsInfoAddress Property

Legal address of organization.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Address { get; }

Property Value

Type: String
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo.Code Property

OrganizationDetailsInfoCode Property

Taxpayer Identification Number, INN of organization.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Code { get; }

Property Value

Type: String
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo.CustomerId Property

OrganizationDetailsInfoCustomerId Property

Identifier of linked customer.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid CustomerId { get; }

Property Value

Type: Guid
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo.Name Property

OrganizationDetailsInfoName Property

Name of organization.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Name { get; }

Property Value

Type: String
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


OrganizationDetailsInfo Methods

The OrganizationDetailsInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrganizationDetailsInfo Class
Resto.Front.Api.Data.Payments Namespace


PaymentTypeKind Enumeration

Kind of a payment type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum PaymentTypeKind
Members
Member name | Value | Description
Unknown | 0 | None of kinds listed below.
Cash | 1 | Cash.
Card | 2 | Card.
Credit | 3 | Credit.
Writeoff | 4 | Writeoff.
Voucher | 5 | Voucher.
External | 6 | External api payment type of payment system registered with RegisterPaymentSystem(IPaymentProcessor, Boolean).
SmartSale | 7 | Smart sale.
Sberbank | 8 | Sberbank.
Trpos | 9 | Trpos.
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsPlastekPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PlastekPaymentItemAdditionalData : IEquatable<PlastekPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The PlastekPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | PlastekPaymentItemAdditionalData | Initializes a new instance of the PlastekPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | PlastekCardNumber | Card number.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlastekPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData Constructor

Initializes a new instance of the PlastekPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PlastekPaymentItemAdditionalData()
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData Properties

The PlastekPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | PlastekCardNumber | Card number.
Top
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData.PlastekCardNumber Property

PlastekPaymentItemAdditionalDataPlastekCardNumber Property

Card number.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PlastekCardNumber { get; set; }

Property Value

Type: String
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData Methods

The PlastekPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlastekPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData.Equals Method

PlastekPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlastekPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData.Equals Method (Object)

PlastekPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

PlastekPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData.Equals Method (PlastekPaymentItemAdditionalData)

PlastekPaymentItemAdditionalDataEquals Method (PlastekPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    PlastekPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsPlastekPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

PlastekPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


PlastekPaymentItemAdditionalData.GetHashCode Method

PlastekPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

PlastekPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsPlaziusPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PlaziusPaymentItemAdditionalData : IEquatable<PlaziusPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The PlaziusPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | PlaziusPaymentItemAdditionalData | Initializes a new instance of the PlaziusPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | CardExternalId |
Public property | CardExternalIdType |
Public property | CardNumberOrBarcode |
Public property | DiscountSum | Obsolete. Total sum that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.
Public property | DiscountSums | Sums that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlaziusPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData Constructor

Initializes a new instance of the PlaziusPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PlaziusPaymentItemAdditionalData()
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData Properties

The PlaziusPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | CardExternalId |
Public property | CardExternalIdType |
Public property | CardNumberOrBarcode |
Public property | DiscountSum | Obsolete. Total sum that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.
Public property | DiscountSums | Sums that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.
Top
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.CardExternalId Property

PlaziusPaymentItemAdditionalDataCardExternalId Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CardExternalId { get; set; }

Property Value

Type: String
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.CardExternalIdType Property

PlaziusPaymentItemAdditionalDataCardExternalIdType Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IikoNetCardExternalIdType CardExternalIdType { get; set; }

Property Value

Type: IikoNetCardExternalIdType
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.CardNumberOrBarcode Property

PlaziusPaymentItemAdditionalDataCardNumberOrBarcode Property

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string CardNumberOrBarcode { get; set; }

Property Value

Type: String
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.DiscountSum Property

PlaziusPaymentItemAdditionalDataDiscountSum Property

Note: This API is now obsolete.

Total sum that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[ObsoleteAttribute("Use DiscountSums property to set individual discount sum for each order item")]
public decimal? DiscountSum { get; set; }

Property Value

Type: Nullable Decimal
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.DiscountSums Property

PlaziusPaymentItemAdditionalDataDiscountSums Property

Sums that Plazius will process as discount from all discount marketing campaigns. It is calculated by Plazius, so setting it to another value can be harmful.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Dictionary<Guid, (decimal discountSum, decimal discountAmount)> DiscountSums { get; set; }

Property Value

Type: Dictionary Guid, ValueTuple Decimal, Decimal
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData Methods

The PlaziusPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlaziusPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.Equals Method

PlaziusPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(PlaziusPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.Equals Method (Object)

PlaziusPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.Equals Method (PlaziusPaymentItemAdditionalData)

PlaziusPaymentItemAdditionalDataEquals Method (PlaziusPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    PlaziusPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsPlaziusPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


PlaziusPaymentItemAdditionalData.GetHashCode Method

PlaziusPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

PlaziusPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData Class

Additional information for voucher payment types.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsVoucherPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class VoucherPaymentItemAdditionalData : IEquatable<VoucherPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The VoucherPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | VoucherPaymentItemAdditionalData | Initializes a new instance of the VoucherPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | Count | Vouchers' count.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(VoucherPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData Constructor

Initializes a new instance of the VoucherPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public VoucherPaymentItemAdditionalData()
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData Properties

The VoucherPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | Count | Vouchers' count.
Top
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData.Count Property

VoucherPaymentItemAdditionalDataCount Property

Vouchers' count.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Count { get; set; }

Property Value

Type: Int32
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData Methods

The VoucherPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(VoucherPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData.Equals Method

VoucherPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(VoucherPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData.Equals Method (Object)

VoucherPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

VoucherPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData.Equals Method (VoucherPaymentItemAdditionalData)

VoucherPaymentItemAdditionalDataEquals Method (VoucherPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    VoucherPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsVoucherPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

VoucherPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


VoucherPaymentItemAdditionalData.GetHashCode Method

VoucherPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

VoucherPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData Class

Additional information for writeoff payment types.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PaymentsWriteoffPaymentItemAdditionalData

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class WriteoffPaymentItemAdditionalData : IEquatable<WriteoffPaymentItemAdditionalData>,
    IPaymentItemAdditionalData

The WriteoffPaymentItemAdditionalData type exposes the following members.

Constructors
 | Name | Description
Public method | WriteoffPaymentItemAdditionalData | Initializes a new instance of the WriteoffPaymentItemAdditionalData class
Top
Properties
 | Name | Description
Public property | Ratio | Coefficient of writeoff (1 or -1). Can be null where the field was not filled explicit.
Public property | Reason | Reason of writeoff.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(WriteoffPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData Constructor

Initializes a new instance of the WriteoffPaymentItemAdditionalData class

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public WriteoffPaymentItemAdditionalData()
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData Properties

The WriteoffPaymentItemAdditionalData type exposes the following members.

Properties
 | Name | Description
Public property | Ratio | Coefficient of writeoff (1 or -1). Can be null where the field was not filled explicit.
Public property | Reason | Reason of writeoff.
Top
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.Ratio Property

WriteoffPaymentItemAdditionalDataRatio Property

Coefficient of writeoff (1 or -1). Can be null where the field was not filled explicit.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int? Ratio { get; set; }

Property Value

Type: Nullable Int32
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.Reason Property

WriteoffPaymentItemAdditionalDataReason Property

Reason of writeoff.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Reason { get; set; }

Property Value

Type: String
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData Methods

The WriteoffPaymentItemAdditionalData type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(WriteoffPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Serves as the default hash function. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.Equals Method

WriteoffPaymentItemAdditionalDataEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Overrides ObjectEquals(Object).)
Public method | Equals(WriteoffPaymentItemAdditionalData) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.Equals Method (Object)

WriteoffPaymentItemAdditionalDataEquals Method (Object)

Determines whether the specified object is equal to the current object.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override bool Equals(
    Object obj
)

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
if the specified object is equal to the current object; otherwise, .
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.Equals Method (WriteoffPaymentItemAdditionalData)

WriteoffPaymentItemAdditionalDataEquals Method (WriteoffPaymentItemAdditionalData)

Indicates whether the current object is equal to another object of the same type.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool Equals(
    WriteoffPaymentItemAdditionalData other
)

Parameters

other
Type: Resto.Front.Api.Data.PaymentsWriteoffPaymentItemAdditionalData
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .

Implements

IEquatableTEquals(T)
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Equals Overload
Resto.Front.Api.Data.Payments Namespace


WriteoffPaymentItemAdditionalData.GetHashCode Method

WriteoffPaymentItemAdditionalDataGetHashCode Method

Serves as the default hash function.

Namespace: Resto.Front.Api.Data.Payments
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override int GetHashCode()

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

WriteoffPaymentItemAdditionalData Class
Resto.Front.Api.Data.Payments Namespace


Resto.Front.Api.Data.PreliminaryOrders Namespace

Interfaces
 | Interface | Description
Public interface | IPreliminaryOrder |
Public interface | IPreliminaryOrderModifierItem |
Public interface | IPreliminaryOrderProductItem |


IPreliminaryOrder Interface

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPreliminaryOrder : ISerializable,
    IEntity

The IPreliminaryOrder type exposes the following members.

Properties
 | Name | Description
Public property | CreateTime | Time of creation
Public property | Id | (Inherited from IEntity.)
Public property | Number | Arbitrary non-unique identifier (tag)
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.
Public property | Products | Order products
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder Properties

The IPreliminaryOrder type exposes the following members.

Properties
 | Name | Description
Public property | CreateTime | Time of creation
Public property | Id | (Inherited from IEntity.)
Public property | Number | Arbitrary non-unique identifier (tag)
Public property | OriginName | Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.
Public property | Products | Order products
Top
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder.CreateTime Property

IPreliminaryOrderCreateTime Property

Time of creation

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime CreateTime { get; }

Property Value

Type: DateTime
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder.Number Property

IPreliminaryOrderNumber Property

Arbitrary non-unique identifier (tag)

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Number { get; }

Property Value

Type: String
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder.OriginName Property

IPreliminaryOrderOriginName Property

Optional marker used to specify order origin. This property contains either null or name of the source order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on.

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string OriginName { get; }

Property Value

Type: String
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder.Products Property

IPreliminaryOrderProducts Property

Order products

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPreliminaryOrderProductItem> Products { get; }

Property Value

Type: IReadOnlyList IPreliminaryOrderProductItem
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrder Methods

The IPreliminaryOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPreliminaryOrder Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem Interface

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPreliminaryOrderModifierItem : ISerializable

The IPreliminaryOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Modifier amount
Public property | Dish | Modifier product
Public property | IsChildModifier | Is modifier child of group modifier
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem Properties

The IPreliminaryOrderModifierItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Modifier amount
Public property | Dish | Modifier product
Public property | IsChildModifier | Is modifier child of group modifier
Top
See Also

Reference

IPreliminaryOrderModifierItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem.Amount Property

IPreliminaryOrderModifierItemAmount Property

Modifier amount

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Amount { get; }

Property Value

Type: Int32
See Also

Reference

IPreliminaryOrderModifierItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem.Dish Property

IPreliminaryOrderModifierItemDish Property

Modifier product

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Dish { get; }

Property Value

Type: IProduct
See Also

Reference

IPreliminaryOrderModifierItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem.IsChildModifier Property

IPreliminaryOrderModifierItemIsChildModifier Property

Is modifier child of group modifier

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsChildModifier { get; }

Property Value

Type: Boolean
See Also

Reference

IPreliminaryOrderModifierItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderModifierItem Methods

The IPreliminaryOrderModifierItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPreliminaryOrderModifierItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem Interface

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPreliminaryOrderProductItem : ISerializable

The IPreliminaryOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Product amount
Public property | Dish | Product product
Public property | Modifiers | Product modifiers
Public property | ProductSize | Size of the product if it has scale, otherwise null.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem Properties

The IPreliminaryOrderProductItem type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Product amount
Public property | Dish | Product product
Public property | Modifiers | Product modifiers
Public property | ProductSize | Size of the product if it has scale, otherwise null.
Top
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem.Amount Property

IPreliminaryOrderProductItemAmount Property

Product amount

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem.Dish Property

IPreliminaryOrderProductItemDish Property

Product product

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Dish { get; }

Property Value

Type: IProduct
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem.Modifiers Property

IPreliminaryOrderProductItemModifiers Property

Product modifiers

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IPreliminaryOrderModifierItem> Modifiers { get; }

Property Value

Type: IReadOnlyList IPreliminaryOrderModifierItem
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem.ProductSize Property

IPreliminaryOrderProductItemProductSize Property

Size of the product if it has scale, otherwise null.

Namespace: Resto.Front.Api.Data.PreliminaryOrders
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProductSize ProductSize { get; }

Property Value

Type: IProductSize
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


IPreliminaryOrderProductItem Methods

The IPreliminaryOrderProductItem type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPreliminaryOrderProductItem Interface
Resto.Front.Api.Data.PreliminaryOrders Namespace


Resto.Front.Api.Data.Print Namespace

Classes
 | Class | Description
Public class | Document | Serializable wrapper for markup XElement.
Interfaces
 | Interface | Description
Public interface | IPrinterRef | Reference to a printer which can be used to print documents using Print(IPrinterRef, Document, Boolean).
Enumerations
 | Enumeration | Description
Public enumeration | PrinterSelectionMode | Specifies how to select printer to print a section-related document on a specific terminal.


Document Class

Serializable wrapper for markup XElement.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.PrintDocument

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class Document : ISerializable

The Document type exposes the following members.

Constructors
 | Name | Description
Public method | Document | Initializes a new instance of the Document class
Protected method | Document(SerializationInfo, StreamingContext) | Initializes a new instance of the Document class
Top
Properties
 | Name | Description
Public property | Markup | Document markup
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
(XElement to Document) | Cast the value of [T:T:System.XElement] to the Document.
(Document to XElement) | Cast the value of this Document to a XElement.
Top
See Also

Reference

Resto.Front.Api.Data.Print Namespace


Document Constructor

Overload List
 | Name | Description
Public method | Document | Initializes a new instance of the Document class
Protected method | Document(SerializationInfo, StreamingContext) | Initializes a new instance of the Document class
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document Constructor

Initializes a new instance of the Document class

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Document()
See Also

Reference

Document Class
Document Overload
Resto.Front.Api.Data.Print Namespace


Document Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the Document class

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected Document(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

Document Class
Document Overload
Resto.Front.Api.Data.Print Namespace


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | Markup | Document markup
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document.Markup Property

DocumentMarkup Property

Document markup

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public XElement Markup { get; set; }

Property Value

Type: XElement
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document.GetObjectData Method

DocumentGetObjectData Method

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document Type Conversions

Operators
Name | Description
(XElement to Document) | Cast the value of [T:T:System.XElement] to the Document.
(Document to XElement) | Cast the value of this Document to a XElement.
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document Implicit Conversion Operators

Document Conversion Operators

Overload List
Name | Description
(XElement to Document) | Cast the value of [T:T:System.XElement] to the Document.
(Document to XElement) | Cast the value of this Document to a XElement.
Top
See Also

Reference

Document Class
Resto.Front.Api.Data.Print Namespace


Document Implicit Conversion (XElement to Document)

Document Conversion (XElement to Document)

Cast the value of [T:T:System.XElement] to the Document.

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static implicit operator Document (
    XElement markup
)

Parameters

markup
Type: System.Xml.LinqXElement

Return Value

Type: Document
See Also

Reference

Document Class
Overload
Resto.Front.Api.Data.Print Namespace


Document Implicit Conversion (Document to XElement)

Document Conversion (Document to XElement)

Cast the value of this Document to a XElement.

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static implicit operator XElement (
    Document document
)

Parameters

document
Type: Resto.Front.Api.Data.PrintDocument

Return Value

Type: XElement
See Also

Reference

Document Class
Overload
Resto.Front.Api.Data.Print Namespace


IPrinterRef Interface

Reference to a printer which can be used to print documents using Print(IPrinterRef, Document, Boolean).

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPrinterRef : ISerializable,
    IEntity

The IPrinterRef type exposes the following members.

Properties
 | Name | Description
Public property | CheckIsConfigured | Check for printer configured.
Public property | Id | (Inherited from IEntity.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Print Namespace


IPrinterRef Properties

The IPrinterRef type exposes the following members.

Properties
 | Name | Description
Public property | CheckIsConfigured | Check for printer configured.
Public property | Id | (Inherited from IEntity.)
Top
See Also

Reference

IPrinterRef Interface
Resto.Front.Api.Data.Print Namespace


IPrinterRef.CheckIsConfigured Property

IPrinterRefCheckIsConfigured Property

Check for printer configured.

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool CheckIsConfigured { get; }

Property Value

Type: Boolean
See Also

Reference

IPrinterRef Interface
Resto.Front.Api.Data.Print Namespace


IPrinterRef Methods

The IPrinterRef type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IPrinterRef Interface
Resto.Front.Api.Data.Print Namespace


PrinterSelectionMode Enumeration

Specifies how to select printer to print a section-related document on a specific terminal.

Namespace: Resto.Front.Api.Data.Print
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum PrinterSelectionMode
Members
Member name | Value | Description
Default | 0 | Treat section settings as a base level and terminal settings as an override. Printer will be selected by terminal settings if they specify some printer for a document, otherwise printer will be selected using section settings.
BySection | 1 | Select printer using section settings. Terminal settings will be ignored.
ByTerminal | 2 | Select printer using terminal settings. Currently, section settings will be used as a fallback if printer cannot be selected by terminal, so this option coincides with Default, but it's just an implementation detail, which may be changed at any time.
Remarks
Each IRestaurantSection has printer settings and each terminal (iikoFront application instance) also may have it's own printer settings, so it's necessary to specify, which settings to use to select a printer.
See Also

Reference

Resto.Front.Api.Data.Print Namespace


Resto.Front.Api.Data.ProductStocks Namespace

Interfaces
 | Interface | Description
Public interface | IProductBatch | Cooked product batch
Public interface | IProductStock | Stock of cooked product batches
Public interface | IProductStocksList | List of all stocks of cooked product batches


IProductBatch Interface

Cooked product batch

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductBatch : ISerializable

The IProductBatch type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Batch rest amount
Public property | CookingTime | Batch cooking time
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.ProductStocks Namespace


IProductBatch Properties

The IProductBatch type exposes the following members.

Properties
 | Name | Description
Public property | Amount | Batch rest amount
Public property | CookingTime | Batch cooking time
Top
See Also

Reference

IProductBatch Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductBatch.Amount Property

IProductBatchAmount Property

Batch rest amount

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal Amount { get; }

Property Value

Type: Decimal
See Also

Reference

IProductBatch Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductBatch.CookingTime Property

IProductBatchCookingTime Property

Batch cooking time

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DateTime CookingTime { get; }

Property Value

Type: DateTime
See Also

Reference

IProductBatch Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductBatch Methods

The IProductBatch type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductBatch Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStock Interface

Stock of cooked product batches

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductStock : ISerializable

The IProductStock type exposes the following members.

Properties
 | Name | Description
Public property | Batches | Cooked product batches
Public property | CookDebt | Amount of product waiting for cook
Public property | Product | Stock product
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.ProductStocks Namespace


IProductStock Properties

The IProductStock type exposes the following members.

Properties
 | Name | Description
Public property | Batches | Cooked product batches
Public property | CookDebt | Amount of product waiting for cook
Public property | Product | Stock product
Top
See Also

Reference

IProductStock Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStock.Batches Property

IProductStockBatches Property

Cooked product batches

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductBatch> Batches { get; }

Property Value

Type: IReadOnlyList IProductBatch
See Also

Reference

IProductStock Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStock.CookDebt Property

IProductStockCookDebt Property

Amount of product waiting for cook

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal CookDebt { get; }

Property Value

Type: Decimal
See Also

Reference

IProductStock Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStock.Product Property

IProductStockProduct Property

Stock product

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

IProductStock Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStock Methods

The IProductStock type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductStock Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStocksList Interface

List of all stocks of cooked product batches

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IProductStocksList : ISerializable,
    IEntity

The IProductStocksList type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Stocks | Stocks of cooked product batches
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.ProductStocks Namespace


IProductStocksList Properties

The IProductStocksList type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Stocks | Stocks of cooked product batches
Top
See Also

Reference

IProductStocksList Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStocksList.Stocks Property

IProductStocksListStocks Property

Stocks of cooked product batches

Namespace: Resto.Front.Api.Data.ProductStocks
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyList<IProductStock> Stocks { get; }

Property Value

Type: IReadOnlyList IProductStock
See Also

Reference

IProductStocksList Interface
Resto.Front.Api.Data.ProductStocks Namespace


IProductStocksList Methods

The IProductStocksList type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IProductStocksList Interface
Resto.Front.Api.Data.ProductStocks Namespace


Resto.Front.Api.Data.Screens Namespace

Interfaces
 | Interface | Description
Public interface | IAdditionalOperationsScreen | Screen with additional operations buttons, such as opening/closing personal and cafe sessions, viewing reports, navigating to opened/closed order, deliveries, documents and so on.
Public interface | ICloseCafeSessionScreen | Cafe session closing wizard.
Public interface | IClosedOrderScreen | Closed order viewing screen.
Public interface | IDeliveryOrderEditScreen | Modifiable delivery order viewing/editing screen.
Public interface | ILockScreen | Common base interface for station lock screen.
Public interface | IOpenCafeSessionScreen | Cafe session opening wizard.
Public interface | IOrderEditScreen | Open order viewing/editing screen.
Public interface | IOrderPayScreen | Order payment screen.
Public interface | IReserveEditScreen | Reserve or banquet viewing/editing screen.
Public interface | IScreen | Common base interface for all screens.
Public interface | IScreenWithDelivery | Common base interface for screens having a delivery order.
Public interface | IScreenWithOrder | Common base interface for screens having an order.
Public interface | IUnknownScreen | Common interface for all screens which don't have a specific interface.
Public interface | IUnmodifiableDeliveryOrderScreen | Unmodifiable delivery order viewing screen.


IAdditionalOperationsScreen Interface

Screen with additional operations buttons, such as opening/closing personal and cafe sessions, viewing reports, navigating to opened/closed order, deliveries, documents and so on.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IAdditionalOperationsScreen : ISerializable,
    IScreen

The IAdditionalOperationsScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IAdditionalOperationsScreen Methods

The IAdditionalOperationsScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IAdditionalOperationsScreen Interface
Resto.Front.Api.Data.Screens Namespace


ICloseCafeSessionScreen Interface

Cafe session closing wizard.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICloseCafeSessionScreen : ISerializable,
    IScreen

The ICloseCafeSessionScreen type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | Cash register that the wizard is associated to.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


ICloseCafeSessionScreen Properties

The ICloseCafeSessionScreen type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | Cash register that the wizard is associated to.
Top
See Also

Reference

ICloseCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


ICloseCafeSessionScreen.CashRegister Property

ICloseCafeSessionScreenCashRegister Property

Cash register that the wizard is associated to.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo CashRegister { get; }

Property Value

Type: ICashRegisterInfo
See Also

Reference

ICloseCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


ICloseCafeSessionScreen Methods

The ICloseCafeSessionScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICloseCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


IClosedOrderScreen Interface

Closed order viewing screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IClosedOrderScreen : ISerializable,
    IScreen, IScreenWithOrder

The IClosedOrderScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IClosedOrderScreen Properties

The IClosedOrderScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
See Also

Reference

IClosedOrderScreen Interface
Resto.Front.Api.Data.Screens Namespace


IClosedOrderScreen Methods

The IClosedOrderScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IClosedOrderScreen Interface
Resto.Front.Api.Data.Screens Namespace


IDeliveryOrderEditScreen Interface

Modifiable delivery order viewing/editing screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliveryOrderEditScreen : ISerializable,
    IScreen, IScreenWithDelivery

The IDeliveryOrderEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to. (Inherited from IScreenWithDelivery.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IDeliveryOrderEditScreen Properties

The IDeliveryOrderEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to. (Inherited from IScreenWithDelivery.)
Top
See Also

Reference

IDeliveryOrderEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IDeliveryOrderEditScreen Methods

The IDeliveryOrderEditScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IDeliveryOrderEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


ILockScreen Interface

Common base interface for station lock screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ILockScreen : ISerializable,
    IScreen

The ILockScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


ILockScreen Methods

The ILockScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ILockScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOpenCafeSessionScreen Interface

Cafe session opening wizard.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOpenCafeSessionScreen : ISerializable,
    IScreen

The IOpenCafeSessionScreen type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | Cash register that the wizard is associated to.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IOpenCafeSessionScreen Properties

The IOpenCafeSessionScreen type exposes the following members.

Properties
 | Name | Description
Public property | CashRegister | Cash register that the wizard is associated to.
Top
See Also

Reference

IOpenCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOpenCafeSessionScreen.CashRegister Property

IOpenCafeSessionScreenCashRegister Property

Cash register that the wizard is associated to.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegisterInfo CashRegister { get; }

Property Value

Type: ICashRegisterInfo
See Also

Reference

IOpenCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOpenCafeSessionScreen Methods

The IOpenCafeSessionScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOpenCafeSessionScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOrderEditScreen Interface

Open order viewing/editing screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderEditScreen : ISerializable,
    IScreen, IScreenWithOrder

The IOrderEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IOrderEditScreen Properties

The IOrderEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
See Also

Reference

IOrderEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOrderEditScreen Methods

The IOrderEditScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOrderPayScreen Interface

Order payment screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderPayScreen : ISerializable,
    IScreen, IScreenWithOrder

The IOrderPayScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IOrderPayScreen Properties

The IOrderPayScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to. (Inherited from IScreenWithOrder.)
Top
See Also

Reference

IOrderPayScreen Interface
Resto.Front.Api.Data.Screens Namespace


IOrderPayScreen Methods

The IOrderPayScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IOrderPayScreen Interface
Resto.Front.Api.Data.Screens Namespace


IReserveEditScreen Interface

Reserve or banquet viewing/editing screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IReserveEditScreen : ISerializable,
    IScreen

The IReserveEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Reserve | Reserve or banquet that the screen is associated to.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IReserveEditScreen Properties

The IReserveEditScreen type exposes the following members.

Properties
 | Name | Description
Public property | Reserve | Reserve or banquet that the screen is associated to.
Top
See Also

Reference

IReserveEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IReserveEditScreen.Reserve Property

IReserveEditScreenReserve Property

Reserve or banquet that the screen is associated to.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReserve Reserve { get; }

Property Value

Type: IReserve
See Also

Reference

IReserveEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IReserveEditScreen Methods

The IReserveEditScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IReserveEditScreen Interface
Resto.Front.Api.Data.Screens Namespace


IScreen Interface

Common base interface for all screens.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IScreen : ISerializable

The IScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IScreen Methods

The IScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IScreen Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithDelivery Interface

Common base interface for screens having a delivery order.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IScreenWithDelivery : ISerializable

The IScreenWithDelivery type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IScreenWithDelivery Properties

The IScreenWithDelivery type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to.
Top
See Also

Reference

IScreenWithDelivery Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithDelivery.Order Property

IScreenWithDeliveryOrder Property

Delivery order that the screen is associated to.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryOrder Order { get; }

Property Value

Type: IDeliveryOrder
See Also

Reference

IScreenWithDelivery Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithDelivery Methods

The IScreenWithDelivery type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IScreenWithDelivery Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithOrder Interface

Common base interface for screens having an order.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IScreenWithOrder : ISerializable

The IScreenWithOrder type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IScreenWithOrder Properties

The IScreenWithOrder type exposes the following members.

Properties
 | Name | Description
Public property | Order | Order that the screen is associated to.
Top
See Also

Reference

IScreenWithOrder Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithOrder.Order Property

IScreenWithOrderOrder Property

Order that the screen is associated to.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrder Order { get; }

Property Value

Type: IOrder
See Also

Reference

IScreenWithOrder Interface
Resto.Front.Api.Data.Screens Namespace


IScreenWithOrder Methods

The IScreenWithOrder type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IScreenWithOrder Interface
Resto.Front.Api.Data.Screens Namespace


IUnknownScreen Interface

Common interface for all screens which don't have a specific interface.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IUnknownScreen : ISerializable,
    IScreen

The IUnknownScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IUnknownScreen Methods

The IUnknownScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IUnknownScreen Interface
Resto.Front.Api.Data.Screens Namespace


IUnmodifiableDeliveryOrderScreen Interface

Unmodifiable delivery order viewing screen.

Namespace: Resto.Front.Api.Data.Screens
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IUnmodifiableDeliveryOrderScreen : ISerializable,
    IScreen, IScreenWithDelivery

The IUnmodifiableDeliveryOrderScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to. (Inherited from IScreenWithDelivery.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Screens Namespace


IUnmodifiableDeliveryOrderScreen Properties

The IUnmodifiableDeliveryOrderScreen type exposes the following members.

Properties
 | Name | Description
Public property | Order | Delivery order that the screen is associated to. (Inherited from IScreenWithDelivery.)
Top
See Also

Reference

IUnmodifiableDeliveryOrderScreen Interface
Resto.Front.Api.Data.Screens Namespace


IUnmodifiableDeliveryOrderScreen Methods

The IUnmodifiableDeliveryOrderScreen type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IUnmodifiableDeliveryOrderScreen Interface
Resto.Front.Api.Data.Screens Namespace


Resto.Front.Api.Data.Search Namespace

Enumerations
 | Enumeration | Description
Public enumeration | ClientFields | Client's fields for search.
Public enumeration | SearchType | Type of search
Public enumeration | StreetFields | Street's fields for search.


ClientFields Enumeration

Client's fields for search.

Namespace: Resto.Front.Api.Data.Search
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum ClientFields
Members
Member name | Value | Description
Name | 1 | Name.
CardNumber | 2 | Card number.
Address | 4 | Address.
Phone | 8 | Phone number.
Comment | 16 | Comment.
All | 31 | All fields.
See Also

Reference

Resto.Front.Api.Data.Search Namespace
IOperationServiceSearchClients(ICredentials, String, SearchType, ClientFields)


SearchType Enumeration

Type of search

Namespace: Resto.Front.Api.Data.Search
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum SearchType
Members
Member name | Value | Description
Prefix | 0 | Prefix.
Equals | 1 | Equals.
See Also

Reference

Resto.Front.Api.Data.Search Namespace


StreetFields Enumeration

Street's fields for search.

Namespace: Resto.Front.Api.Data.Search
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum StreetFields
Members
Member name | Value | Description
Name | 1 | Street name.
ExternalId | 2 | External id of a street.
All | 3 | All fields.
See Also

Reference

Resto.Front.Api.Data.Search Namespace
IOperationServiceSearchStreets(String, SearchType, StreetFields, IReadOnlyListICity)


Resto.Front.Api.Data.Security Namespace

Interfaces
 | Interface | Description
Public interface | ICredentials | Credentials to authenticate operations, which require a user with specific permissions.
Public interface | IRole | User role such as cashier, waiter, headwaiter, cook, etc. Users can work as one of the roles.
Public interface | IUser |
Enumerations
 | Enumeration | Description
Public enumeration | UserType | Describes contractor types of IUser.


ICredentials Interface

Credentials to authenticate operations, which require a user with specific permissions.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICredentials : IEntity,
    ISerializable

The ICredentials type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Security Namespace
IOperationServiceAuthenticateByPin(String)


ICredentials Properties

The ICredentials type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Top
See Also

Reference

ICredentials Interface
Resto.Front.Api.Data.Security Namespace


ICredentials Methods

The ICredentials type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ICredentials Interface
Resto.Front.Api.Data.Security Namespace


IRole Interface

User role such as cashier, waiter, headwaiter, cook, etc. Users can work as one of the roles.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IRole : ISerializable, IEntity

The IRole type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of the role.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Security Namespace


IRole Properties

The IRole type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Name of the role.
Top
See Also

Reference

IRole Interface
Resto.Front.Api.Data.Security Namespace


IRole.Name Property

IRoleName Property

Name of the role.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IRole Interface
Resto.Front.Api.Data.Security Namespace


IRole Methods

The IRole type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IRole Interface
Resto.Front.Api.Data.Security Namespace


IUser Interface

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IUser : ISerializable, IEntity

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Card | User original personal card number.
Public property | CellPhone |
Public property | Code | User personal number.
Public property | Id | (Inherited from IEntity.)
Public property | InsuranceNumber | User insurance number.
Public property | IsSessionOpen |
Public property | Name |
Public property | TaxpayerId | User taxpayer identification number.
Public property | Type | Contractor types assigned to the user.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUserRoles | Returns roles available for the user. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

Resto.Front.Api.Data.Security Namespace


IUser Properties

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Card | User original personal card number.
Public property | CellPhone |
Public property | Code | User personal number.
Public property | Id | (Inherited from IEntity.)
Public property | InsuranceNumber | User insurance number.
Public property | IsSessionOpen |
Public property | Name |
Public property | TaxpayerId | User taxpayer identification number.
Public property | Type | Contractor types assigned to the user.
Top
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.Card Property

IUserCard Property

User original personal card number.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Card { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.CellPhone Property

IUserCellPhone Property

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CellPhone { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.Code Property

IUserCode Property

User personal number.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Code { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.InsuranceNumber Property

IUserInsuranceNumber Property

User insurance number.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string InsuranceNumber { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.IsSessionOpen Property

IUserIsSessionOpen Property

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsSessionOpen { get; }

Property Value

Type: Boolean
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.Name Property

IUserName Property

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.TaxpayerId Property

IUserTaxpayerId Property

User taxpayer identification number.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string TaxpayerId { get; }

Property Value

Type: String
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser.Type Property

IUserType Property

Contractor types assigned to the user.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
UserType Type { get; }

Property Value

Type: UserType
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


IUser Methods

The IUser type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetUserRoles | Returns roles available for the user. (Defined by OperationArgumentExtensions.)
Top
See Also

Reference

IUser Interface
Resto.Front.Api.Data.Security Namespace


UserType Enumeration

Describes contractor types of IUser.

Namespace: Resto.Front.Api.Data.Security
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum UserType
Members
Member name | Value | Description
None | 0 | User's contractor type is not defined.
Employee | 1 | User's contractor type is an employee.
Guest | 2 | User's contractor type is a special guest.
Supplier | 4 | User's contractor type is a supplier.
See Also

Reference

Resto.Front.Api.Data.Security Namespace


Resto.Front.Api.Data.Settings Namespace

Classes
 | Class | Description
Public class | BaseSettingT | Base class for plugin settings elements.
Public class | CheckBox | Check box.
Public class | PluginSettings | Plugin settings.
Public class | TextBox | Text box.
Public class | ToggleButtonState | Toggle button state.
Interfaces
 | Interface | Description
Public interface | IPluginSettings | Interface of plugin settings.
Public interface | ISetting | Base interface for plugin settings.


BaseSetting(T) Class

BaseSettingT Class

Base class for plugin settings elements.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.SettingsBaseSettingT
Resto.Front.Api.Data.SettingsCheckBox
Resto.Front.Api.Data.SettingsTextBox

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public abstract class BaseSetting<T> : ISetting

Type Parameters

T

The BaseSettingT type exposes the following members.

Constructors
 | Name | Description
Protected method | BaseSettingT | Ctor.
Top
Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing.
Public property | Key |
Public property | LabelText | Text on label next to the element.
Public property | Value | Value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


BaseSetting(T) Constructor

BaseSettingT Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected BaseSetting(
    string key,
    T value,
    string labelText,
    bool isReadonly
)

Parameters

key
Type: SystemString
value
Type: T
labelText
Type: SystemString
isReadonly
Type: SystemBoolean
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T) Properties

BaseSettingT Properties

The BaseSettingT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing.
Public property | Key |
Public property | LabelText | Text on label next to the element.
Public property | Value | Value.
Top
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T).IsReadonly Property

BaseSettingTIsReadonly Property

Is element readonly or available for editing.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsReadonly { get; set; }

Property Value

Type: Boolean
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T).Key Property

BaseSettingTKey Property

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Key { get; set; }

Property Value

Type: String

Implements

ISettingKey
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T).LabelText Property

BaseSettingTLabelText Property

Text on label next to the element.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string LabelText { get; set; }

Property Value

Type: String
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T).Value Property

BaseSettingTValue Property

Value.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public T Value { get; set; }

Property Value

Type: T
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


BaseSetting(T) Methods

BaseSettingT Methods

The BaseSettingT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseSettingT Class
Resto.Front.Api.Data.Settings Namespace


CheckBox Class

Check box.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.SettingsBaseSetting Boolean
Resto.Front.Api.Data.SettingsCheckBox

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CheckBox : BaseSetting<bool>

The CheckBox type exposes the following members.

Constructors
 | Name | Description
Public method | CheckBox | Ctor.
Top
Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing. (Inherited from BaseSettingT.)
Public property | Key | (Inherited from BaseSettingT.)
Public property | LabelText | Text on label next to the element. (Inherited from BaseSettingT.)
Public property | Value | Value. (Inherited from BaseSettingT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


CheckBox Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CheckBox(
    string key,
    bool value,
    string labelText,
    bool isReadonly
)

Parameters

key
Type: SystemString
value
Type: SystemBoolean
labelText
Type: SystemString
isReadonly
Type: SystemBoolean
See Also

Reference

CheckBox Class
Resto.Front.Api.Data.Settings Namespace


CheckBox Properties

The CheckBox type exposes the following members.

Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing. (Inherited from BaseSettingT.)
Public property | Key | (Inherited from BaseSettingT.)
Public property | LabelText | Text on label next to the element. (Inherited from BaseSettingT.)
Public property | Value | Value. (Inherited from BaseSettingT.)
Top
See Also

Reference

CheckBox Class
Resto.Front.Api.Data.Settings Namespace


CheckBox Methods

The CheckBox type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CheckBox Class
Resto.Front.Api.Data.Settings Namespace


IPluginSettings Interface

Interface of plugin settings.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPluginSettings

The IPluginSettings type exposes the following members.

Properties
 | Name | Description
Public property | BoundEntityId | Identifier of bound entity.
Public property | DisplayName | Name that describes settings to iikoOffice user.
Public property | PluginKey | Plugin's key for signing settings.
Public property | Version | Version of settings scheme. Meant to be monotonically increasing.
Top
Methods
 | Name | Description
Public method | GetSettings | Get all settings within current plugin settings.
Public method | TryGetSettingTSetting | Get setting by its key.
Public method | TryGetValueTValue(String) | Get value by its key.
Public method | TryGetValueTSetting, TValue(String) | Get value specified for TSettings<TValue> by its key.
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


IPluginSettings Properties

The IPluginSettings type exposes the following members.

Properties
 | Name | Description
Public property | BoundEntityId | Identifier of bound entity.
Public property | DisplayName | Name that describes settings to iikoOffice user.
Public property | PluginKey | Plugin's key for signing settings.
Public property | Version | Version of settings scheme. Meant to be monotonically increasing.
Top
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.BoundEntityId Property

IPluginSettingsBoundEntityId Property

Identifier of bound entity.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid? BoundEntityId { get; set; }

Property Value

Type: Nullable Guid
Remarks
If settings are bound to some iikoRMS entity (i.e. plugin payment type, plugin payment processor, etc.), set this identifier equal to entity id. This makes iikoRMS know that entity and settings are bound, and settings will be available in entity editor in iikoOffice. Otherwise set this identidier to null.
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.DisplayName Property

IPluginSettingsDisplayName Property

Name that describes settings to iikoOffice user.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string DisplayName { get; set; }

Property Value

Type: String
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.PluginKey Property

IPluginSettingsPluginKey Property

Plugin's key for signing settings.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid PluginKey { get; set; }

Property Value

Type: Guid
Remarks
Identifies plugin which owns these settings. Make some constant guid describing a plugin and use here for settings signing and for getting settings.
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.Version Property

IPluginSettingsVersion Property

Version of settings scheme. Meant to be monotonically increasing.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int Version { get; set; }

Property Value

Type: Int32
Remarks
Increase as scheme of settings changes. Do not increase when settings values are updated without changing their scheme.
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings Methods

The IPluginSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetSettings | Get all settings within current plugin settings.
Public method | TryGetSettingTSetting | Get setting by its key.
Public method | TryGetValueTValue(String) | Get value by its key.
Public method | TryGetValueTSetting, TValue(String) | Get value specified for TSettings<TValue> by its key.
Top
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.GetSettings Method

IPluginSettingsGetSettings Method

Get all settings within current plugin settings.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IList<ISetting> GetSettings()

Return Value

Type: IList ISetting
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.TryGetSetting(TSetting) Method

IPluginSettingsTryGetSettingTSetting Method

Get setting by its key.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TSetting TryGetSetting<TSetting>(
    string key
)
where TSetting : class, ISetting

Parameters

key
Type: SystemString
Key of setting.

Type Parameters

TSetting
Type of setting.

Return Value

Type: TSetting
Setting or null if none specified.
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.TryGetValue Method

IPluginSettingsTryGetValue Method

Overload List
 | Name | Description
Public method | TryGetValueTSetting, TValue(String) | Get value specified for TSettings<TValue> by its key.
Public method | TryGetValueTValue(String) | Get value by its key.
Top
See Also

Reference

IPluginSettings Interface
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.TryGetValue(TSetting, TValue) Method (String)

IPluginSettingsTryGetValueTSetting, TValue Method (String)

Get value specified for TSettings<TValue> by its key.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TValue TryGetValue<TSetting, TValue>(
    string key
)
where TSetting : BaseSetting<TValue>

Parameters

key
Type: SystemString
Key of setting.

Type Parameters

TSetting
Type of setting.
TValue
Return type of value.

Return Value

Type: TValue
Value of setting or default(TValue) if none specified.
See Also

Reference

IPluginSettings Interface
TryGetValue Overload
Resto.Front.Api.Data.Settings Namespace


IPluginSettings.TryGetValue(TValue) Method (String)

IPluginSettingsTryGetValueTValue Method (String)

Get value by its key.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
TValue TryGetValue<TValue>(
    string key
)

Parameters

key
Type: SystemString
Key of setting.

Type Parameters

TValue
Return type of value.

Return Value

Type: TValue
Value of setting or null if none specified.
See Also

Reference

IPluginSettings Interface
TryGetValue Overload
Resto.Front.Api.Data.Settings Namespace


ISetting Interface

Base interface for plugin settings.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISetting

The ISetting type exposes the following members.

Properties
 | Name | Description
Public property | Key | Key of element.
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


ISetting Properties

The ISetting type exposes the following members.

Properties
 | Name | Description
Public property | Key | Key of element.
Top
See Also

Reference

ISetting Interface
Resto.Front.Api.Data.Settings Namespace


ISetting.Key Property

ISettingKey Property

Key of element.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Key { get; }

Property Value

Type: String
See Also

Reference

ISetting Interface
Resto.Front.Api.Data.Settings Namespace


PluginSettings Class

Plugin settings.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.SettingsPluginSettings

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PluginSettings : IPluginSettings

The PluginSettings type exposes the following members.

Constructors
 | Name | Description
Public method | PluginSettings | Ctor.
Top
Properties
 | Name | Description
Public property | BoundEntityId |
Public property | DisplayName |
Public property | PluginKey |
Public property | Version |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetSettingTSetting |
Public method | TryGetValueTValue(String) |
Public method | TryGetValueTSetting, TValue(String) |
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


PluginSettings Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PluginSettings(
    Guid pluginKey,
    Guid? boundEntityId,
    int version,
    List<ISetting> settings
)

Parameters

pluginKey
Type: SystemGuid
boundEntityId
Type: SystemNullable Guid
version
Type: SystemInt32
settings
Type: System.Collections.GenericList ISetting
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings Properties

The PluginSettings type exposes the following members.

Properties
 | Name | Description
Public property | BoundEntityId |
Public property | DisplayName |
Public property | PluginKey |
Public property | Version |
Top
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.BoundEntityId Property

PluginSettingsBoundEntityId Property

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid? BoundEntityId { get; set; }

Property Value

Type: Nullable Guid

Implements

IPluginSettingsBoundEntityId
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.DisplayName Property

PluginSettingsDisplayName Property

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string DisplayName { get; set; }

Property Value

Type: String

Implements

IPluginSettingsDisplayName
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.PluginKey Property

PluginSettingsPluginKey Property

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid PluginKey { get; set; }

Property Value

Type: Guid

Implements

IPluginSettingsPluginKey
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.Version Property

PluginSettingsVersion Property

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Version { get; set; }

Property Value

Type: Int32

Implements

IPluginSettingsVersion
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings Methods

The PluginSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSettings |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetSettingTSetting |
Public method | TryGetValueTValue(String) |
Public method | TryGetValueTSetting, TValue(String) |
Top
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.GetSettings Method

PluginSettingsGetSettings Method

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IList<ISetting> GetSettings()

Return Value

Type: IList ISetting

Implements

IPluginSettingsGetSettings
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.TryGetSetting(TSetting) Method

PluginSettingsTryGetSettingTSetting Method

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TSetting TryGetSetting<TSetting>(
    string key
)
where TSetting : class, ISetting

Parameters

key
Type: SystemString

Type Parameters

TSetting

Return Value

Type: TSetting

Implements

IPluginSettingsTryGetSettingTSetting(String)
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.TryGetValue Method

PluginSettingsTryGetValue Method

Overload List
 | Name | Description
Public method | TryGetValueTSetting, TValue(String) |
Public method | TryGetValueTValue(String) |
Top
See Also

Reference

PluginSettings Class
Resto.Front.Api.Data.Settings Namespace


PluginSettings.TryGetValue(TSetting, TValue) Method (String)

PluginSettingsTryGetValueTSetting, TValue Method (String)

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TValue TryGetValue<TSetting, TValue>(
    string key
)
where TSetting : BaseSetting<TValue>

Parameters

key
Type: SystemString

Type Parameters

TSetting
TValue

Return Value

Type: TValue

Implements

IPluginSettingsTryGetValueTSetting, TValue(String)
See Also

Reference

PluginSettings Class
TryGetValue Overload
Resto.Front.Api.Data.Settings Namespace


PluginSettings.TryGetValue(TValue) Method (String)

PluginSettingsTryGetValueTValue Method (String)

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TValue TryGetValue<TValue>(
    string key
)

Parameters

key
Type: SystemString

Type Parameters

TValue

Return Value

Type: TValue

Implements

IPluginSettingsTryGetValueTValue(String)
See Also

Reference

PluginSettings Class
TryGetValue Overload
Resto.Front.Api.Data.Settings Namespace


TextBox Class

Text box.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.SettingsBaseSetting String
Resto.Front.Api.Data.SettingsTextBox

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class TextBox : BaseSetting<string>

The TextBox type exposes the following members.

Constructors
 | Name | Description
Public method | TextBox | Ctor.
Top
Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing. (Inherited from BaseSettingT.)
Public property | Key | (Inherited from BaseSettingT.)
Public property | LabelText | Text on label next to the element. (Inherited from BaseSettingT.)
Public property | MaxLength | Max length of text.
Public property | Value | Value. (Inherited from BaseSettingT.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


TextBox Constructor

Ctor.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public TextBox(
    string key,
    string value,
    string labelText,
    bool isReadonly,
    int maxLength
)

Parameters

key
Type: SystemString
value
Type: SystemString
labelText
Type: SystemString
isReadonly
Type: SystemBoolean
maxLength
Type: SystemInt32
See Also

Reference

TextBox Class
Resto.Front.Api.Data.Settings Namespace


TextBox Properties

The TextBox type exposes the following members.

Properties
 | Name | Description
Public property | IsReadonly | Is element readonly or available for editing. (Inherited from BaseSettingT.)
Public property | Key | (Inherited from BaseSettingT.)
Public property | LabelText | Text on label next to the element. (Inherited from BaseSettingT.)
Public property | MaxLength | Max length of text.
Public property | Value | Value. (Inherited from BaseSettingT.)
Top
See Also

Reference

TextBox Class
Resto.Front.Api.Data.Settings Namespace


TextBox.MaxLength Property

TextBoxMaxLength Property

Max length of text.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int MaxLength { get; set; }

Property Value

Type: Int32
See Also

Reference

TextBox Class
Resto.Front.Api.Data.Settings Namespace


TextBox Methods

The TextBox type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TextBox Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState Class

Toggle button state.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.SettingsToggleButtonState

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ToggleButtonState

The ToggleButtonState type exposes the following members.

Constructors
 | Name | Description
Public method | ToggleButtonState | Main constructor
Top
Properties
 | Name | Description
Public property | Caption | Toggle button caption.
Public property | Icon | Toggle button icon.
Public property | IsChecked | Toggle button state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.Settings Namespace


ToggleButtonState Constructor

Main constructor

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ToggleButtonState()
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState Properties

The ToggleButtonState type exposes the following members.

Properties
 | Name | Description
Public property | Caption | Toggle button caption.
Public property | Icon | Toggle button icon.
Public property | IsChecked | Toggle button state.
Top
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState.Caption Property

ToggleButtonStateCaption Property

Toggle button caption.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Caption { get; set; }

Property Value

Type: String
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState.Icon Property

ToggleButtonStateIcon Property

Toggle button icon.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Icon { get; set; }

Property Value

Type: String
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState.IsChecked Property

ToggleButtonStateIsChecked Property

Toggle button state.

Namespace: Resto.Front.Api.Data.Settings
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool IsChecked { get; set; }

Property Value

Type: Boolean
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


ToggleButtonState Methods

The ToggleButtonState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ToggleButtonState Class
Resto.Front.Api.Data.Settings Namespace


Resto.Front.Api.Data.Taxes Namespace

Interfaces
 | Interface | Description
Public interface | ITaxCategory |


ITaxCategory Interface

Namespace: Resto.Front.Api.Data.Taxes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ITaxCategory : ISerializable,
    IEntity

The ITaxCategory type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Vat name.
Public property | VatPercent | Vat percent.
Top
Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

Resto.Front.Api.Data.Taxes Namespace


ITaxCategory Properties

The ITaxCategory type exposes the following members.

Properties
 | Name | Description
Public property | Id | (Inherited from IEntity.)
Public property | Name | Vat name.
Public property | VatPercent | Vat percent.
Top
See Also

Reference

ITaxCategory Interface
Resto.Front.Api.Data.Taxes Namespace


ITaxCategory.Name Property

ITaxCategoryName Property

Vat name.

Namespace: Resto.Front.Api.Data.Taxes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string Name { get; }

Property Value

Type: String
See Also

Reference

ITaxCategory Interface
Resto.Front.Api.Data.Taxes Namespace


ITaxCategory.VatPercent Property

ITaxCategoryVatPercent Property

Vat percent.

Namespace: Resto.Front.Api.Data.Taxes
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
decimal VatPercent { get; }

Property Value

Type: Decimal
See Also

Reference

ITaxCategory Interface
Resto.Front.Api.Data.Taxes Namespace


ITaxCategory Methods

The ITaxCategory type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

ITaxCategory Interface
Resto.Front.Api.Data.Taxes Namespace


Resto.Front.Api.Data.View Namespace

Classes
 | Class | Description
Public class | BarcodeInputDialogResult | Barcode type input dialog result.
Public class | CardInputDialogResult | Magnetic stripe card type input dialog result.
Public class | NumberInputDialogResult | Number type input dialog result.
Public class | PhoneInputDialogResult | Phone number type input dialog result.
Public class | RestaurantSectionEllipse | Restaurant section ellipse.
Public class | RestaurantSectionImage | Restaurant section image.
Public class | RestaurantSectionMark | Restaurant section mark.
Public class | RestaurantSectionObject | Restaurant section object.
Public class | RestaurantSectionRectangle | Restaurant section rectangle.
Public class | RestaurantSectionTable | Restaurant section table.
Public class | StringInputDialogResult | String type input dialog result.
Structures
 | Structure | Description
Public structure | Font | Font.
Interfaces
 | Interface | Description
Public interface | IInputDialogResult | Common base interface for different input dialog result types. Match and cast it to one of it's inheritors to get specific dialog result properties.
Enumerations
 | Enumeration | Description
Public enumeration | FontStyle | Font style.
Public enumeration | InputDialogTypes | Input types for the input dialog. Use any input type or combination to specify, which input types do you expect.


BarcodeInputDialogResult Class

Barcode type input dialog result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewBarcodeInputDialogResult

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class BarcodeInputDialogResult : IInputDialogResult

The BarcodeInputDialogResult type exposes the following members.

Constructors
 | Name | Description
Public method | BarcodeInputDialogResult | Initializes a new instance of the BarcodeInputDialogResult class
Top
Properties
 | Name | Description
Public property | Barcode | Scanned barcode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


BarcodeInputDialogResult Constructor

Initializes a new instance of the BarcodeInputDialogResult class

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public BarcodeInputDialogResult(
    string barcode
)

Parameters

barcode
Type: SystemString
See Also

Reference

BarcodeInputDialogResult Class
Resto.Front.Api.Data.View Namespace


BarcodeInputDialogResult Properties

The BarcodeInputDialogResult type exposes the following members.

Properties
 | Name | Description
Public property | Barcode | Scanned barcode.
Top
See Also

Reference

BarcodeInputDialogResult Class
Resto.Front.Api.Data.View Namespace


BarcodeInputDialogResult.Barcode Property

BarcodeInputDialogResultBarcode Property

Scanned barcode.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Barcode { get; }

Property Value

Type: String
See Also

Reference

BarcodeInputDialogResult Class
Resto.Front.Api.Data.View Namespace


BarcodeInputDialogResult Methods

The BarcodeInputDialogResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BarcodeInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult Class

Magnetic stripe card type input dialog result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewCardInputDialogResult

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CardInputDialogResult : IInputDialogResult

The CardInputDialogResult type exposes the following members.

Constructors
 | Name | Description
Public method | CardInputDialogResult | Initializes a new instance of the CardInputDialogResult class
Top
Properties
 | Name | Description
Public property | FullCardTrack | Raw track, which includes all tracks altogether.
Public property | Track1 | First track of the card.
Public property | Track2 | Second track of the card.
Public property | Track3 | Third track of the card.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


CardInputDialogResult Constructor

Initializes a new instance of the CardInputDialogResult class

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CardInputDialogResult(
    string track1,
    string track2,
    string track3,
    string fullCardTrack
)

Parameters

track1
Type: SystemString
track2
Type: SystemString
track3
Type: SystemString
fullCardTrack
Type: SystemString
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult Properties

The CardInputDialogResult type exposes the following members.

Properties
 | Name | Description
Public property | FullCardTrack | Raw track, which includes all tracks altogether.
Public property | Track1 | First track of the card.
Public property | Track2 | Second track of the card.
Public property | Track3 | Third track of the card.
Top
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult.FullCardTrack Property

CardInputDialogResultFullCardTrack Property

Raw track, which includes all tracks altogether.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string FullCardTrack { get; }

Property Value

Type: String
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult.Track1 Property

CardInputDialogResultTrack1 Property

First track of the card.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Track1 { get; }

Property Value

Type: String
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult.Track2 Property

CardInputDialogResultTrack2 Property

Second track of the card.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Track2 { get; }

Property Value

Type: String
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult.Track3 Property

CardInputDialogResultTrack3 Property

Third track of the card.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Track3 { get; }

Property Value

Type: String
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


CardInputDialogResult Methods

The CardInputDialogResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CardInputDialogResult Class
Resto.Front.Api.Data.View Namespace


Font Structure

Font.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public struct Font

The Font type exposes the following members.

Constructors
 | Name | Description
Public method | Font | Ctor.
Top
Properties
 | Name | Description
Public property | FontFamily | Font family.
Public property | FontStyle | Font style.
Public property | Size | Font size.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


Font Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Font(
    string fontFamily,
    float size,
    FontStyle fontStyle
)

Parameters

fontFamily
Type: SystemString
size
Type: SystemSingle
fontStyle
Type: Resto.Front.Api.Data.ViewFontStyle
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


Font Properties

The Font type exposes the following members.

Properties
 | Name | Description
Public property | FontFamily | Font family.
Public property | FontStyle | Font style.
Public property | Size | Font size.
Top
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


Font.FontFamily Property

FontFontFamily Property

Font family.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string FontFamily { get; }

Property Value

Type: String
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


Font.FontStyle Property

FontFontStyle Property

Font style.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public FontStyle FontStyle { get; }

Property Value

Type: FontStyle
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


Font.Size Property

FontSize Property

Font size.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public float Size { get; }

Property Value

Type: Single
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


Font Methods

The Font type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

Font Structure
Resto.Front.Api.Data.View Namespace


FontStyle Enumeration

Font style.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum FontStyle
Members
Member name | Value | Description
Regular | 0 | Regular.
Bold | 1 | Bold.
Italic | 2 | Italic.
Underline | 4 | Underline.
Strikeout | 8 | Strikeout.
See Also

Reference

Resto.Front.Api.Data.View Namespace


IInputDialogResult Interface

Common base interface for different input dialog result types. Match and cast it to one of it's inheritors to get specific dialog result properties.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IInputDialogResult
See Also

Reference

Resto.Front.Api.Data.View Namespace
Resto.Front.Api.Data.ViewBarcodeInputDialogResult
Resto.Front.Api.Data.ViewCardInputDialogResult
Resto.Front.Api.Data.ViewNumberInputDialogResult
Resto.Front.Api.Data.ViewStringInputDialogResult
Resto.Front.Api.Data.ViewPhoneInputDialogResult
IViewManagerShowInputDialog(String, InputDialogTypes, NullableInt32)
IViewManagerShowExtendedInputDialog(String, String, ExtendedInputDialogSettings)
IViewManagerShowExtendedKeyboardDialog(String, String, Boolean, Int32, Boolean, Boolean, Boolean, Boolean)


InputDialogTypes Enumeration

Input types for the input dialog. Use any input type or combination to specify, which input types do you expect.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[FlagsAttribute]
public enum InputDialogTypes
Members
Member name | Value | Description
Card | 1 | To get card track. Window with card slide listener will be shown.
Number | 2 | To get number. Numpad window will be shown.
See Also

Reference

Resto.Front.Api.Data.View Namespace


NumberInputDialogResult Class

Number type input dialog result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewNumberInputDialogResult

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NumberInputDialogResult : IInputDialogResult

The NumberInputDialogResult type exposes the following members.

Constructors
 | Name | Description
Public method | NumberInputDialogResult | Initializes a new instance of the NumberInputDialogResult class
Top
Properties
 | Name | Description
Public property | Number | Number, which was entered by user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


NumberInputDialogResult Constructor

Initializes a new instance of the NumberInputDialogResult class

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NumberInputDialogResult(
    int number
)

Parameters

number
Type: SystemInt32
See Also

Reference

NumberInputDialogResult Class
Resto.Front.Api.Data.View Namespace


NumberInputDialogResult Properties

The NumberInputDialogResult type exposes the following members.

Properties
 | Name | Description
Public property | Number | Number, which was entered by user.
Top
See Also

Reference

NumberInputDialogResult Class
Resto.Front.Api.Data.View Namespace


NumberInputDialogResult.Number Property

NumberInputDialogResultNumber Property

Number, which was entered by user.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Number { get; }

Property Value

Type: Int32
See Also

Reference

NumberInputDialogResult Class
Resto.Front.Api.Data.View Namespace


NumberInputDialogResult Methods

The NumberInputDialogResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NumberInputDialogResult Class
Resto.Front.Api.Data.View Namespace


PhoneInputDialogResult Class

Phone number type input dialog result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewPhoneInputDialogResult

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PhoneInputDialogResult : IInputDialogResult

The PhoneInputDialogResult type exposes the following members.

Constructors
 | Name | Description
Public method | PhoneInputDialogResult | Initializes a new instance of the PhoneInputDialogResult class
Top
Properties
 | Name | Description
Public property | PhoneNumber | Phone number, which was entered by user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


PhoneInputDialogResult Constructor

Initializes a new instance of the PhoneInputDialogResult class

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PhoneInputDialogResult(
    string phoneNumber
)

Parameters

phoneNumber
Type: SystemString
See Also

Reference

PhoneInputDialogResult Class
Resto.Front.Api.Data.View Namespace


PhoneInputDialogResult Properties

The PhoneInputDialogResult type exposes the following members.

Properties
 | Name | Description
Public property | PhoneNumber | Phone number, which was entered by user.
Top
See Also

Reference

PhoneInputDialogResult Class
Resto.Front.Api.Data.View Namespace


PhoneInputDialogResult.PhoneNumber Property

PhoneInputDialogResultPhoneNumber Property

Phone number, which was entered by user.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string PhoneNumber { get; }

Property Value

Type: String
See Also

Reference

PhoneInputDialogResult Class
Resto.Front.Api.Data.View Namespace


PhoneInputDialogResult Methods

The PhoneInputDialogResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhoneInputDialogResult Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionEllipse Class

Restaurant section ellipse.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionEllipse

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RestaurantSectionEllipse : RestaurantSectionObject

The RestaurantSectionEllipse type exposes the following members.

Constructors
 | Name | Description
Public method | RestaurantSectionEllipse | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionEllipse Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RestaurantSectionEllipse(
    Color color,
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

color
Type: System.DrawingColor
x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionEllipse Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionEllipse Properties

The RestaurantSectionEllipse type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
See Also

Reference

RestaurantSectionEllipse Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionEllipse.Color Property

RestaurantSectionEllipseColor Property

Color.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Color Color { get; }

Property Value

Type: Color
See Also

Reference

RestaurantSectionEllipse Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionEllipse Methods

The RestaurantSectionEllipse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionEllipse Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionImage Class

Restaurant section image.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionImage

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RestaurantSectionImage : RestaurantSectionObject

The RestaurantSectionImage type exposes the following members.

Constructors
 | Name | Description
Public method | RestaurantSectionImage | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Image | Image Base64 string.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionImage Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RestaurantSectionImage(
    IReadOnlyList<byte> image,
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

image
Type: System.Collections.GenericIReadOnlyList Byte
x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionImage Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionImage Properties

The RestaurantSectionImage type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Image | Image Base64 string.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
See Also

Reference

RestaurantSectionImage Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionImage.Image Property

RestaurantSectionImageImage Property

Image Base64 string.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public byte[] Image { get; }

Property Value

Type: Byte
See Also

Reference

RestaurantSectionImage Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionImage Methods

The RestaurantSectionImage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionImage Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark Class

Restaurant section mark.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionMark

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RestaurantSectionMark : RestaurantSectionObject

The RestaurantSectionMark type exposes the following members.

Constructors
 | Name | Description
Public method | RestaurantSectionMark | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Font | Font.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Text | Text.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionMark Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RestaurantSectionMark(
    string text,
    Font font,
    Color color,
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

text
Type: SystemString
font
Type: Resto.Front.Api.Data.ViewFont
color
Type: System.DrawingColor
x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark Properties

The RestaurantSectionMark type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Font | Font.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Text | Text.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark.Color Property

RestaurantSectionMarkColor Property

Color.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Color Color { get; }

Property Value

Type: Color
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark.Font Property

RestaurantSectionMarkFont Property

Font.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Font Font { get; }

Property Value

Type: Font
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark.Text Property

RestaurantSectionMarkText Property

Text.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Text { get; }

Property Value

Type: String
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionMark Methods

The RestaurantSectionMark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionMark Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject Class

Restaurant section object.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionEllipse
Resto.Front.Api.Data.ViewRestaurantSectionImage
Resto.Front.Api.Data.ViewRestaurantSectionMark
Resto.Front.Api.Data.ViewRestaurantSectionRectangle
Resto.Front.Api.Data.ViewRestaurantSectionTable

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public abstract class RestaurantSectionObject

The RestaurantSectionObject type exposes the following members.

Constructors
 | Name | Description
Protected method | RestaurantSectionObject | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope.
Public property | Height | Item's height in px.
Public property | Width | Item's width in px.
Public property | X | X cordinate of left point of item.
Public property | Y | Y coordinate of top point of item.
Public property | Z | Z-index of item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionObject Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected RestaurantSectionObject(
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject Properties

The RestaurantSectionObject type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope.
Public property | Height | Item's height in px.
Public property | Width | Item's width in px.
Public property | X | X cordinate of left point of item.
Public property | Y | Y coordinate of top point of item.
Public property | Z | Z-index of item.
Top
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.Angle Property

RestaurantSectionObjectAngle Property

Item's angle of slope.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public double Angle { get; }

Property Value

Type: Double
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.Height Property

RestaurantSectionObjectHeight Property

Item's height in px.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Height { get; }

Property Value

Type: Int32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.Width Property

RestaurantSectionObjectWidth Property

Item's width in px.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Width { get; }

Property Value

Type: Int32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.X Property

RestaurantSectionObjectX Property

X cordinate of left point of item.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int X { get; }

Property Value

Type: Int32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.Y Property

RestaurantSectionObjectY Property

Y coordinate of top point of item.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Y { get; }

Property Value

Type: Int32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject.Z Property

RestaurantSectionObjectZ Property

Z-index of item.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int Z { get; }

Property Value

Type: Int32
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionObject Methods

The RestaurantSectionObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionObject Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionRectangle Class

Restaurant section rectangle.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionRectangle

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RestaurantSectionRectangle : RestaurantSectionObject

The RestaurantSectionRectangle type exposes the following members.

Constructors
 | Name | Description
Public method | RestaurantSectionRectangle | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionRectangle Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RestaurantSectionRectangle(
    Color color,
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

color
Type: System.DrawingColor
x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionRectangle Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionRectangle Properties

The RestaurantSectionRectangle type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Color | Color.
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
See Also

Reference

RestaurantSectionRectangle Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionRectangle.Color Property

RestaurantSectionRectangleColor Property

Color.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Color Color { get; }

Property Value

Type: Color
See Also

Reference

RestaurantSectionRectangle Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionRectangle Methods

The RestaurantSectionRectangle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionRectangle Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionTable Class

Restaurant section table.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewRestaurantSectionObject
Resto.Front.Api.Data.ViewRestaurantSectionTable

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class RestaurantSectionTable : RestaurantSectionObject

The RestaurantSectionTable type exposes the following members.

Constructors
 | Name | Description
Public method | RestaurantSectionTable | Ctor.
Top
Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Table | Table.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


RestaurantSectionTable Constructor

Ctor.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public RestaurantSectionTable(
    ITable table,
    int x,
    int y,
    int z,
    double angle,
    int width,
    int height
)

Parameters

table
Type: Resto.Front.Api.Data.Organization.SectionsITable
x
Type: SystemInt32
y
Type: SystemInt32
z
Type: SystemInt32
angle
Type: SystemDouble
width
Type: SystemInt32
height
Type: SystemInt32
See Also

Reference

RestaurantSectionTable Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionTable Properties

The RestaurantSectionTable type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Item's angle of slope. (Inherited from RestaurantSectionObject.)
Public property | Height | Item's height in px. (Inherited from RestaurantSectionObject.)
Public property | Table | Table.
Public property | Width | Item's width in px. (Inherited from RestaurantSectionObject.)
Public property | X | X cordinate of left point of item. (Inherited from RestaurantSectionObject.)
Public property | Y | Y coordinate of top point of item. (Inherited from RestaurantSectionObject.)
Public property | Z | Z-index of item. (Inherited from RestaurantSectionObject.)
Top
See Also

Reference

RestaurantSectionTable Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionTable.Table Property

RestaurantSectionTableTable Property

Table.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ITable Table { get; }

Property Value

Type: ITable
See Also

Reference

RestaurantSectionTable Class
Resto.Front.Api.Data.View Namespace


RestaurantSectionTable Methods

The RestaurantSectionTable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestaurantSectionTable Class
Resto.Front.Api.Data.View Namespace


StringInputDialogResult Class

String type input dialog result.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Data.ViewStringInputDialogResult

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class StringInputDialogResult : IInputDialogResult

The StringInputDialogResult type exposes the following members.

Constructors
 | Name | Description
Public method | StringInputDialogResult | Initializes a new instance of the StringInputDialogResult class
Top
Properties
 | Name | Description
Public property | Result | String, which was entered by user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Data.View Namespace


StringInputDialogResult Constructor

Initializes a new instance of the StringInputDialogResult class

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public StringInputDialogResult(
    string result
)

Parameters

result
Type: SystemString
See Also

Reference

StringInputDialogResult Class
Resto.Front.Api.Data.View Namespace


StringInputDialogResult Properties

The StringInputDialogResult type exposes the following members.

Properties
 | Name | Description
Public property | Result | String, which was entered by user.
Top
See Also

Reference

StringInputDialogResult Class
Resto.Front.Api.Data.View Namespace


StringInputDialogResult.Result Property

StringInputDialogResultResult Property

String, which was entered by user.

Namespace: Resto.Front.Api.Data.View
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string Result { get; }

Property Value

Type: String
See Also

Reference

StringInputDialogResult Class
Resto.Front.Api.Data.View Namespace


StringInputDialogResult Methods

The StringInputDialogResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringInputDialogResult Class
Resto.Front.Api.Data.View Namespace


Resto.Front.Api.Devices Namespace

Interfaces
 | Interface | Description
Public interface | ICashRegister | Plugin-based cash register device.
Public interface | ICashRegisterFactory | Plugin-based cash register device factory.
Public interface | IChequeTaskProcessor | Common interface for extending the functionality of fiscal operations.
Public interface | IDevice | Common interface for plugin-based devices.
Public interface | IDeviceFactory | Common interface for plugin-based device factories.
Public interface | IScale | Plugin-based scale device.
Public interface | IScaleFactory | Plugin-based scale device factory.


ICashRegister Interface

Plugin-based cash register device.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICashRegister : IDevice

The ICashRegister type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id. (Inherited from IDevice.)
Public property | DeviceName | Device title that will be displayed in BackOffice. (Inherited from IDevice.)
Top
Methods
 | Name | Description
Public method | CustomerDisplayIdle | Put a customer display into idle mode.
Public method | CustomerDisplayText | Display a text on the customer display.
Public method | DirectIo | Perform additional specific operation.
Public method | DoBillCheque | Perform a cheque printing operation on a cash register without payments.
Public method | DoCheque | Perform a cheque printing operation on a cash register.
Public method | DoCorrection | Perform a cheque correction.
Public method | DoOpenSession | Perform open cafe session operation.
Public method | DoPayIn | Perform pay in cash operation.
Public method | DoPayOut | Perform pay out cash operation.
Public method | DoXReport | Perform X-report printing operation at the cafe session opening.
Public method | DoZReport | Perform Z-report printing operation at the cafe session closing.
Public method | GetCashRegisterData | Get the current state of the cash register.
Public method | GetCashRegisterDriverParameters | Get the cash register driver parameters.
Public method | GetCashRegisterStatus | Get the current status of the cash register.
Public method | GetDeviceInfo | Device status. (Inherited from IDevice.)
Public method | GetQueryInfo | Returns supported additional operations.
Public method | IsDrawerOpened | Checks a cash drawer status.
Public method | OpenDrawer | Perform open drawer operation.
Public method | PrintText | Perform the operation of printing non-fiscal cheque (information, advertising or other).
Public method | RemoveDevice | Perform remove device operation. (Inherited from IDevice.)
Public method | Setup | Perform setup new configuration operation. (Inherited from IDevice.)
Public method | Start | Perform start device operation. (Inherited from IDevice.)
Public method | Stop | Perform stop device operation. (Inherited from IDevice.)
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
Resto.Front.Api.DevicesICashRegisterFactory


ICashRegister Properties

The ICashRegister type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id. (Inherited from IDevice.)
Public property | DeviceName | Device title that will be displayed in BackOffice. (Inherited from IDevice.)
Top
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister Methods

The ICashRegister type exposes the following members.

Methods
 | Name | Description
Public method | CustomerDisplayIdle | Put a customer display into idle mode.
Public method | CustomerDisplayText | Display a text on the customer display.
Public method | DirectIo | Perform additional specific operation.
Public method | DoBillCheque | Perform a cheque printing operation on a cash register without payments.
Public method | DoCheque | Perform a cheque printing operation on a cash register.
Public method | DoCorrection | Perform a cheque correction.
Public method | DoOpenSession | Perform open cafe session operation.
Public method | DoPayIn | Perform pay in cash operation.
Public method | DoPayOut | Perform pay out cash operation.
Public method | DoXReport | Perform X-report printing operation at the cafe session opening.
Public method | DoZReport | Perform Z-report printing operation at the cafe session closing.
Public method | GetCashRegisterData | Get the current state of the cash register.
Public method | GetCashRegisterDriverParameters | Get the cash register driver parameters.
Public method | GetCashRegisterStatus | Get the current status of the cash register.
Public method | GetDeviceInfo | Device status. (Inherited from IDevice.)
Public method | GetQueryInfo | Returns supported additional operations.
Public method | IsDrawerOpened | Checks a cash drawer status.
Public method | OpenDrawer | Perform open drawer operation.
Public method | PrintText | Perform the operation of printing non-fiscal cheque (information, advertising or other).
Public method | RemoveDevice | Perform remove device operation. (Inherited from IDevice.)
Public method | Setup | Perform setup new configuration operation. (Inherited from IDevice.)
Public method | Start | Perform start device operation. (Inherited from IDevice.)
Public method | Stop | Perform stop device operation. (Inherited from IDevice.)
Top
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.CustomerDisplayIdle Method

ICashRegisterCustomerDisplayIdle Method

Put a customer display into idle mode.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CustomerDisplayIdle(
    TimeSpan timeToIdle
)

Parameters

timeToIdle
Type: SystemTimeSpan
Time to turn off the display.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.CustomerDisplayText Method

ICashRegisterCustomerDisplayText Method

Display a text on the customer display.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void CustomerDisplayText(
    CustomerDisplayTextTask task
)

Parameters

task
Type: Resto.Front.Api.Data.Device.TasksCustomerDisplayTextTask
CustomerDisplayTextTask Text with markup for display.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DirectIo Method

ICashRegisterDirectIo Method

Perform additional specific operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DirectIoResult DirectIo(
    CommandExecute execute
)

Parameters

execute
Type: Resto.Front.Api.Data.Device.TasksCommandExecute
Specific command to execute.

Return Value

Type: DirectIoResult
A document with the text of the command execution result. For example, a cash register's control tape.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace
ICashRegisterGetQueryInfo


ICashRegister.DoBillCheque Method

ICashRegisterDoBillCheque Method

Perform a cheque printing operation on a cash register without payments.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoBillCheque(
    BillTask billTask,
    IViewManager viewManager
)

Parameters

billTask
Type: Resto.Front.Api.Data.Device.TasksBillTask
BillTask Information about the order items, discounts, cashier and other.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
State of the cash register: sums, vat, bill number and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoCheque Method

ICashRegisterDoCheque Method

Perform a cheque printing operation on a cash register.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoCheque(
    ChequeTask chequeTask,
    IViewManager viewManager
)

Parameters

chequeTask
Type: Resto.Front.Api.Data.Device.TasksChequeTask
ChequeTask Information about the order items, payments, discounts, cashier and other.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
State of the cash register: sums, vat, sale number and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
Remarks
Called when the order is closed or storned on the plug-in cash register.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoCorrection Method

ICashRegisterDoCorrection Method

Perform a cheque correction.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DoCorrection(
    CorrectionTask task,
    IViewManager viewManager
)

Parameters

task
Type: Resto.Front.Api.Data.Device.TasksCorrectionTask
CorrectionTask Contains information about sums that need to correct.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoOpenSession Method

ICashRegisterDoOpenSession Method

Perform open cafe session operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DoOpenSession(
    IUser cashier,
    IViewManager viewManager
)

Parameters

cashier
Type: Resto.Front.Api.Data.SecurityIUser
The cashier performing the operation.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoPayIn Method

ICashRegisterDoPayIn Method

Perform pay in cash operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoPayIn(
    decimal sum,
    IUser cashier,
    IViewManager viewManager
)

Parameters

sum
Type: SystemDecimal
Cash sum.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
Cashier.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoPayOut Method

ICashRegisterDoPayOut Method

Perform pay out cash operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoPayOut(
    decimal sum,
    IUser cashier,
    IViewManager viewManager
)

Parameters

sum
Type: SystemDecimal
Cash sum.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
Cashier.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoXReport Method

ICashRegisterDoXReport Method

Perform X-report printing operation at the cafe session opening.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoXReport(
    IUser cashier,
    IViewManager viewManager
)

Parameters

cashier
Type: Resto.Front.Api.Data.SecurityIUser
The cashier performing the operation.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
State of the cash register: sums, vat, sale number and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
Remarks
Called at the opening cafe session.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.DoZReport Method

ICashRegisterDoZReport Method

Perform Z-report printing operation at the cafe session closing.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult DoZReport(
    ICafeSession cafeSession,
    IUser cashier,
    bool printEklzReport,
    IViewManager viewManager
)

Parameters

cafeSession
Type: Resto.Front.Api.Data.DeviceICafeSession
The cafe session to be closed.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
The cashier performing the operation.
printEklzReport
Type: SystemBoolean
True, if need to print a cafe session settlement status report.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: CashRegisterResult
State of the cash register: sums, vat, sale number and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
Remarks
Called at the cafe session closing.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.GetCashRegisterData Method

ICashRegisterGetCashRegisterData Method

Get the current state of the cash register.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterResult GetCashRegisterData()

Return Value

Type: CashRegisterResult
State of the cash register: sums, vat, sale number and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
Remarks
It is called to compare the sums for each cheque printing, opening and closing a cafe session on a cash register.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.GetCashRegisterDriverParameters Method

ICashRegisterGetCashRegisterDriverParameters Method

Get the cash register driver parameters.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterDriverParameters GetCashRegisterDriverParameters()

Return Value

Type: CashRegisterDriverParameters
State of the cash register driver: can it print text, print barcode, QR code and other.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.GetCashRegisterStatus Method

ICashRegisterGetCashRegisterStatus Method

Get the current status of the cash register.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
CashRegisterStatus GetCashRegisterStatus(
    IReadOnlyCollection<CashRegisterStatusField> statusFields
)

Parameters

statusFields
Type: System.Collections.GenericIReadOnlyCollection CashRegisterStatusField
List of the fields.

Return Value

Type: CashRegisterStatus
Status of the cash register with completed requested fields.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.GetQueryInfo Method

ICashRegisterGetQueryInfo Method

Returns supported additional operations.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
QueryInfoResult GetQueryInfo()

Return Value

Type: QueryInfoResult
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
Remarks
These operations are specific. For each device, these operations can be different.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.IsDrawerOpened Method

ICashRegisterIsDrawerOpened Method

Checks a cash drawer status.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsDrawerOpened()

Return Value

Type: Boolean
true if the cash drawer is open, otherwise false.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.OpenDrawer Method

ICashRegisterOpenDrawer Method

Perform open drawer operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void OpenDrawer(
    IUser cashier,
    IViewManager viewManager
)

Parameters

cashier
Type: Resto.Front.Api.Data.SecurityIUser
The cashier performing the operation.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegister.PrintText Method

ICashRegisterPrintText Method

Perform the operation of printing non-fiscal cheque (information, advertising or other).

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void PrintText(
    string text
)

Parameters

text
Type: SystemString
Text for printing.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

ICashRegister Interface
Resto.Front.Api.Devices Namespace


ICashRegisterFactory Interface

Plugin-based cash register device factory.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ICashRegisterFactory : IDeviceFactory

The ICashRegisterFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice. (Inherited from IDeviceFactory.)
Public property | DefaultDeviceSettings | Get the initial configuration of the device. (Inherited from IDeviceFactory.)
Top
Methods
 | Name | Description
Public method | Create | Create cash register.
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
IOperationServiceRegisterCashRegisterFactory(ICashRegisterFactory)


ICashRegisterFactory Properties

The ICashRegisterFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice. (Inherited from IDeviceFactory.)
Public property | DefaultDeviceSettings | Get the initial configuration of the device. (Inherited from IDeviceFactory.)
Top
See Also

Reference

ICashRegisterFactory Interface
Resto.Front.Api.Devices Namespace


ICashRegisterFactory Methods

The ICashRegisterFactory type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create cash register.
Top
See Also

Reference

ICashRegisterFactory Interface
Resto.Front.Api.Devices Namespace


ICashRegisterFactory.Create Method

ICashRegisterFactoryCreate Method

Create cash register.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ICashRegister Create(
    Guid deviceId,
    CashRegisterSettings settings
)

Parameters

deviceId
Type: SystemGuid
Cash register id.
settings
Type: Resto.Front.Api.Data.Device.SettingsCashRegisterSettings
Cash register settings.

Return Value

Type: ICashRegister
Cash register device.
See Also

Reference

ICashRegisterFactory Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor Interface

Common interface for extending the functionality of fiscal operations.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IChequeTaskProcessor

The IChequeTaskProcessor type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | Whether this cheque task processor is going to change operation sums. When multiple cheque task processors have been registered, primary processors are called first, because they can change sums, so that remaining processors will see final sums.
Top
Methods
 | Name | Description
Public method | AfterDoCheckAction | Perform the action after do cheque.
Public method | AfterPayIn | Perform the action after pay in.
Public method | AfterPayOut | Perform the action after pay out.
Public method | AfterXReport | Perform the action after printing the X-report.
Public method | AfterZReport | Perform the action after printing the Z-report.
Public method | BeforeDoCheckAction | Perform the action before do cheque.
Public method | BeforePayIn | Perform the action before pay in.
Public method | BeforePayOut | Perform the action before pay out.
Public method | BeforeXReport | Perform the action before printing the X-report.
Public method | BeforeZReport | Perform the action before printing the Z-report.
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
IOperationServiceRegisterChequeTaskProcessor(IChequeTaskProcessor)


IChequeTaskProcessor Properties

The IChequeTaskProcessor type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | Whether this cheque task processor is going to change operation sums. When multiple cheque task processors have been registered, primary processors are called first, because they can change sums, so that remaining processors will see final sums.
Top
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.IsPrimary Property

IChequeTaskProcessorIsPrimary Property

Whether this cheque task processor is going to change operation sums. When multiple cheque task processors have been registered, primary processors are called first, because they can change sums, so that remaining processors will see final sums.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool IsPrimary { get; }

Property Value

Type: Boolean
Remarks
Currently this property affects only BeforePayOut(ICashRegisterInfo, Decimal, Decimal, Boolean, IUser, IViewManager) method. This property must return the same value each time. Return true if this processor is going to change sumToPayOut ref-argument or return false to indicate that this processor is readonly.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor Methods

The IChequeTaskProcessor type exposes the following members.

Methods
 | Name | Description
Public method | AfterDoCheckAction | Perform the action after do cheque.
Public method | AfterPayIn | Perform the action after pay in.
Public method | AfterPayOut | Perform the action after pay out.
Public method | AfterXReport | Perform the action after printing the X-report.
Public method | AfterZReport | Perform the action after printing the Z-report.
Public method | BeforeDoCheckAction | Perform the action before do cheque.
Public method | BeforePayIn | Perform the action before pay in.
Public method | BeforePayOut | Perform the action before pay out.
Public method | BeforeXReport | Perform the action before printing the X-report.
Public method | BeforeZReport | Perform the action before printing the Z-report.
Top
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.AfterDoCheckAction Method

IChequeTaskProcessorAfterDoCheckAction Method

Perform the action after do cheque.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AfterDoCheckAction(
    ChequeTask chequeTask,
    PostResult result,
    ICashRegisterInfo device,
    IViewManager viewManager
)

Parameters

chequeTask
Type: Resto.Front.Api.Data.Device.TasksChequeTask
Cheque task.
result
Type: Resto.Front.Api.Data.Device.ResultsPostResult
The result of the operation do check.
device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.AfterPayIn Method

IChequeTaskProcessorAfterPayIn Method

Perform the action after pay in.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AfterPayIn(
    ICashRegisterInfo device,
    decimal sum,
    PostResult result,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
sum
Type: SystemDecimal
Sum to pay in.
result
Type: Resto.Front.Api.Data.Device.ResultsPostResult
The result of the operation pay in.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.AfterPayOut Method

IChequeTaskProcessorAfterPayOut Method

Perform the action after pay out.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AfterPayOut(
    ICashRegisterInfo device,
    decimal sum,
    PostResult result,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
sum
Type: SystemDecimal
Sum to pay out.
result
Type: Resto.Front.Api.Data.Device.ResultsPostResult
The result of the operation pay out.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.AfterXReport Method

IChequeTaskProcessorAfterXReport Method

Perform the action after printing the X-report.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AfterXReport(
    ICashRegisterInfo device,
    PostResult result,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
result
Type: Resto.Front.Api.Data.Device.ResultsPostResult
The result of the operation print X-report.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.AfterZReport Method

IChequeTaskProcessorAfterZReport Method

Perform the action after printing the Z-report.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AfterZReport(
    ICashRegisterInfo device,
    PostResult result,
    IUser authUser,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
result
Type: Resto.Front.Api.Data.Device.ResultsPostResult
The result of the operation print Z-report.
authUser
Type: Resto.Front.Api.Data.SecurityIUser
User.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.BeforeDoCheckAction Method

IChequeTaskProcessorBeforeDoCheckAction Method

Perform the action before do cheque.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
BeforeDoCheckActionResult BeforeDoCheckAction(
    ChequeTask chequeTask,
    ICashRegisterInfo device,
    CashRegisterChequeExtensions chequeExtensions,
    IViewManager viewManager
)

Parameters

chequeTask
Type: Resto.Front.Api.Data.Device.TasksChequeTask
Cheque task.
device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
chequeExtensions
Type: Resto.Front.Api.Data.DeviceCashRegisterChequeExtensions
Additional data to the operation.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.

Return Value

Type: BeforeDoCheckActionResult
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.BeforePayIn Method

IChequeTaskProcessorBeforePayIn Method

Perform the action before pay in.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void BeforePayIn(
    ICashRegisterInfo device,
    decimal sumToPayIn,
    bool isCloseSession,
    IUser cashier,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
sumToPayIn
Type: SystemDecimal
Sum to pay in.
isCloseSession
Type: SystemBoolean
Whether the method is called during cafe session closing.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
Cashier.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.BeforePayOut Method

IChequeTaskProcessorBeforePayOut Method

Perform the action before pay out.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void BeforePayOut(
    ICashRegisterInfo device,
    decimal availableSum,
    ref decimal sumToPayOut,
    bool isCloseSession,
    IUser cashier,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
availableSum
Type: SystemDecimal
Original sum to pay out.
sumToPayOut
Type: SystemDecimal
Sum to pay out.
isCloseSession
Type: SystemBoolean
Whether the method is called during cafe session closing.
cashier
Type: Resto.Front.Api.Data.SecurityIUser
Cashier.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.BeforeXReport Method

IChequeTaskProcessorBeforeXReport Method

Perform the action before printing the X-report.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void BeforeXReport(
    ICashRegisterInfo device,
    IUser authUser,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
authUser
Type: Resto.Front.Api.Data.SecurityIUser
User.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IChequeTaskProcessor.BeforeZReport Method

IChequeTaskProcessorBeforeZReport Method

Perform the action before printing the Z-report.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void BeforeZReport(
    ICashRegisterInfo device,
    decimal cashRest,
    IUser authUser,
    IViewManager viewManager
)

Parameters

device
Type: Resto.Front.Api.Data.DeviceICashRegisterInfo
Cash register.
cashRest
Type: SystemDecimal
Cash rest.
authUser
Type: Resto.Front.Api.Data.SecurityIUser
User.
viewManager
Type: Resto.Front.Api.UIIViewManager
IViewManager object to show dialogs. Should not be used after method returns.
See Also

Reference

IChequeTaskProcessor Interface
Resto.Front.Api.Devices Namespace


IDevice Interface

Common interface for plugin-based devices.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDevice

The IDevice type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id.
Public property | DeviceName | Device title that will be displayed in BackOffice.
Top
Methods
 | Name | Description
Public method | GetDeviceInfo | Device status.
Public method | RemoveDevice | Perform remove device operation.
Public method | Setup | Perform setup new configuration operation.
Public method | Start | Perform start device operation.
Public method | Stop | Perform stop device operation.
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
Resto.Front.Api.DevicesIDeviceFactory


IDevice Properties

The IDevice type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id.
Public property | DeviceName | Device title that will be displayed in BackOffice.
Top
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.DeviceId Property

IDeviceDeviceId Property

Device id.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
Guid DeviceId { get; }

Property Value

Type: Guid
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.DeviceName Property

IDeviceDeviceName Property

Device title that will be displayed in BackOffice.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string DeviceName { get; }

Property Value

Type: String
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice Methods

The IDevice type exposes the following members.

Methods
 | Name | Description
Public method | GetDeviceInfo | Device status.
Public method | RemoveDevice | Perform remove device operation.
Public method | Setup | Perform setup new configuration operation.
Public method | Start | Perform start device operation.
Public method | Stop | Perform stop device operation.
Top
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.GetDeviceInfo Method

IDeviceGetDeviceInfo Method

Device status.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeviceInfo GetDeviceInfo()

Return Value

Type: DeviceInfo
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace
Resto.Front.Api.Data.DeviceState


IDevice.RemoveDevice Method

IDeviceRemoveDevice Method

Perform remove device operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void RemoveDevice()
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.Setup Method

IDeviceSetup Method

Perform setup new configuration operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Setup(
    DeviceSettings settings
)

Parameters

settings
Type: Resto.Front.Api.Data.Device.SettingsDeviceSettings
DeviceSettings New device configuration.
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.Start Method

IDeviceStart Method

Perform start device operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Start()
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDevice.Stop Method

IDeviceStop Method

Perform stop device operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void Stop()
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

IDevice Interface
Resto.Front.Api.Devices Namespace


IDeviceFactory Interface

Common interface for plugin-based device factories.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeviceFactory

The IDeviceFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice.
Public property | DefaultDeviceSettings | Get the initial configuration of the device.
Top
See Also

Reference

Resto.Front.Api.Devices Namespace


IDeviceFactory Properties

The IDeviceFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice.
Public property | DefaultDeviceSettings | Get the initial configuration of the device.
Top
See Also

Reference

IDeviceFactory Interface
Resto.Front.Api.Devices Namespace


IDeviceFactory.CodeName Property

IDeviceFactoryCodeName Property

Device title that will be displayed in BackOffice.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string CodeName { get; }

Property Value

Type: String
See Also

Reference

IDeviceFactory Interface
Resto.Front.Api.Devices Namespace


IDeviceFactory.DefaultDeviceSettings Property

IDeviceFactoryDefaultDeviceSettings Property

Get the initial configuration of the device.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
DeviceSettings DefaultDeviceSettings { get; }

Property Value

Type: DeviceSettings
Exceptions
Exception | Condition
DeviceException | Exception to notify that device actions was not successful.
See Also

Reference

IDeviceFactory Interface
Resto.Front.Api.Devices Namespace


IScale Interface

Plugin-based scale device.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IScale : IDevice

The IScale type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id. (Inherited from IDevice.)
Public property | DeviceName | Device title that will be displayed in BackOffice. (Inherited from IDevice.)
Top
Methods
 | Name | Description
Public method | GetDeviceInfo | Device status. (Inherited from IDevice.)
Public method | MeasureWeight | Perform measure of weight operation.
Public method | RemoveDevice | Perform remove device operation. (Inherited from IDevice.)
Public method | Setup | Perform setup new configuration operation. (Inherited from IDevice.)
Public method | Start | Perform start device operation. (Inherited from IDevice.)
Public method | Stop | Perform stop device operation. (Inherited from IDevice.)
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
Resto.Front.Api.DevicesIScaleFactory


IScale Properties

The IScale type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | Device id. (Inherited from IDevice.)
Public property | DeviceName | Device title that will be displayed in BackOffice. (Inherited from IDevice.)
Top
See Also

Reference

IScale Interface
Resto.Front.Api.Devices Namespace


IScale Methods

The IScale type exposes the following members.

Methods
 | Name | Description
Public method | GetDeviceInfo | Device status. (Inherited from IDevice.)
Public method | MeasureWeight | Perform measure of weight operation.
Public method | RemoveDevice | Perform remove device operation. (Inherited from IDevice.)
Public method | Setup | Perform setup new configuration operation. (Inherited from IDevice.)
Public method | Start | Perform start device operation. (Inherited from IDevice.)
Public method | Stop | Perform stop device operation. (Inherited from IDevice.)
Top
See Also

Reference

IScale Interface
Resto.Front.Api.Devices Namespace


IScale.MeasureWeight Method

IScaleMeasureWeight Method

Perform measure of weight operation.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ScaleWeightResult MeasureWeight()

Return Value

Type: ScaleWeightResult
Product weight in kilograms.
See Also

Reference

IScale Interface
Resto.Front.Api.Devices Namespace


IScaleFactory Interface

Plugin-based scale device factory.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IScaleFactory : IDeviceFactory

The IScaleFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice. (Inherited from IDeviceFactory.)
Public property | DefaultDeviceSettings | Get the initial configuration of the device. (Inherited from IDeviceFactory.)
Top
Methods
 | Name | Description
Public method | Create | Create Scale.
Top
See Also

Reference

Resto.Front.Api.Devices Namespace
IOperationServiceRegisterScaleFactory(IScaleFactory)


IScaleFactory Properties

The IScaleFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeName | Device title that will be displayed in BackOffice. (Inherited from IDeviceFactory.)
Public property | DefaultDeviceSettings | Get the initial configuration of the device. (Inherited from IDeviceFactory.)
Top
See Also

Reference

IScaleFactory Interface
Resto.Front.Api.Devices Namespace


IScaleFactory Methods

The IScaleFactory type exposes the following members.

Methods
 | Name | Description
Public method | Create | Create Scale.
Top
See Also

Reference

IScaleFactory Interface
Resto.Front.Api.Devices Namespace


IScaleFactory.Create Method

IScaleFactoryCreate Method

Create Scale.

Namespace: Resto.Front.Api.Devices
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IScale Create(
    Guid deviceId,
    DeviceSettings settings
)

Parameters

deviceId
Type: SystemGuid
Scale id.
settings
Type: Resto.Front.Api.Data.Device.SettingsDeviceSettings
Scale settings.

Return Value

Type: IScale
Scale device.
See Also

Reference

IScaleFactory Interface
Resto.Front.Api.Devices Namespace


Resto.Front.Api.Editors Namespace

Interfaces
 | Interface | Description
Public interface | IEditSession | Accumulates a sequence of entity changes that can be applied atomically at the end.
Public interface | ISubmittedEntities |


IEditSession Interface

Accumulates a sequence of entity changes that can be applied atomically at the end.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IEditSession

The IEditSession type exposes the following members.

Properties
 | Name | Description
Public property | HasChanges | Determines whether an edit session has changes.
Top
Methods
 | Name | Description
Public method | ActivateReserve | Closes reserve and creates order on reserved table.
Public method | AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
Public method | AddDiscountByCardNumber | Add discount by card number.
Public method | AddExternalFiscalizedPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new externally fiscalized payment item to order.
Public method | AddExternalFiscalizedPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new external fiscalized payment item to order.
Public method | AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Public method | AddExternalPaymentItem(Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Public method | AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
Public method | AddFlexibleSumDiscountByCardNumber | Add discount by card number.
Public method | AddIikoCardDiscounts | Adds discounts grouped by order items.
Public method | AddOrderCombo | Create order combo item. Order must contain new combo items.
Public method | AddOrderCompoundItem(IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Public method | AddOrderCompoundItem(Guid, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Public method | AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(String, IOrderStub) to delete the data when it's no longer needed.
Public method | AddOrderGuest(String, IOrderStub) | Adds new guest to existing order. User must have rights to edit orders.
Public method | AddOrderGuest(Guid, String, IOrderStub) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Public method | AddOrderProductItem(Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Public method | AddOrderProductItem(Guid, Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Public method | AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders.
Public method | AddPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Public method | AddPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Public method | AddPreliminaryPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Public method | AddPreliminaryPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Public method | AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Public method | AddPrimaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Public method | AddSecondaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Public method | AddSecondaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Public method | AttachToJournalEvent | Sets default attributes of order for journal event.
Public method | BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order.
Public method | ChangeClientAddresses | Changes client addresses.
Public method | ChangeClientBirthDate | Changes client's birth date.
Public method | ChangeClientBlacklistInfo | Changes client blacklist info.
Public method | ChangeClientCardNumber | Changes client card number.
Public method | ChangeClientComment | Changes client comment.
Public method | ChangeClientConsentDates | Changes client's dates of consent.
Public method | ChangeClientEmails | Changes client emails list.
Public method | ChangeClientGender | Change client's gender.
Public method | ChangeClientIikoBizId | Changes client's account in iiko.biz.
Public method | ChangeClientLastOrderDate | Changes client's last order date.
Public method | ChangeClientLinkedCounteragent | Changes client linked counter agent.
Public method | ChangeClientMainAddressIndex | Changes client main address index.
Public method | ChangeClientMarketingSource | Changes client marketing source.
Public method | ChangeClientName | Changes client name.
Public method | ChangeClientNick | Changes client nickname.
Public method | ChangeClientOrganizationDetailsInfo | Changes organization details information of client.
Public method | ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data.
Public method | ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent.
Public method | ChangeClientPhones | Changes client phones list.
Public method | ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages.
Public method | ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages.
Public method | ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages.
Public method | ChangeClientSurname | Changes client surname.
Public method | ChangeComboAmount | Change combo amount.
Public method | ChangeComboPrice | Change combo price.
Public method | ChangeCookingPriority | Changes custom cooking priority and top priority flag.
Public method | ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered.
Public method | ChangeDeliveryAddress | Changes address of delivery
Public method | ChangeDeliveryClientName | Change name of delivery client.
Public method | ChangeDeliveryComment | Change the order comment.
Public method | ChangeDeliveryConfirmTime | Changes delivery confirmation state and time.
Public method | ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered.
Public method | ChangeDeliveryCustomApiData | Change the delivery custom data from api.
Public method | ChangeDeliveryDuration | Change duration of delivery processing.
Public method | ChangeDeliveryEmail | Change the order e-mail.
Public method | ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered.
Public method | ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal.
Public method | ChangeDeliveryExternalCourier | Changes external courier for delivery.
Public method | ChangeDeliveryExternalCourierService | Changes external courier service for delivery.
Public method | ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server.
Public method | ChangeDeliveryLocation | Changes delivery address location.
Public method | ChangeDeliveryMarketingSource | Assign/change order marketing source.
Public method | ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal.
Public method | ChangeDeliveryOperator | Assign/change the order operator.
Public method | ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.
Public method | ChangeDeliveryPhone | Changes the order phone.
Public method | ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.
Public method | ChangeDeliveryProblemComment | Change the order problem comment.
Public method | ChangeDeliveryProblemStatus | Change the order problem status.
Public method | ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons.
Public method | ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.
Public method | ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item.
Public method | ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order.
Public method | ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders.
Public method | ChangeOrderCookingItemCourse | Changes the course of the order item.
Public method | ChangeOrderCookingItemSize | Changes the product size of the order item.
Public method | ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system.
Public method | ChangeOrderItemComment | Changes product order item's comment.
Public method | ChangeOrderItemWaiter | Changes product order item's waiter.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
Public method | ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.
Public method | ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time.
Public method | ChangeOrderTables | Changes tables of the order.
Public method | ChangeOrderWaiter | Changes order's waiter.
Public method | ChangePaymentItemCustomData | Changes custom data of existing payment item.
Public method | ChangePaymentItemSum | Changes sum of existing payment item.
Public method | ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item.
Public method | ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item.
Public method | ChangePriceCategory | Changes price category of the order.
Public method | ChangeReserveComment | Changes reserve comment. Use empty string to clear comment.
Public method | ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.
Public method | ChangeReserveEstimatedStartTime | Changes estimated reserve start time.
Public method | ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2.
Public method | ChangeReserveReminder | Changes reserve reminder flag.
Public method | ChangeReserveTables | Changes reserving tables.
Public method | ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.
Public method | ChangeStreetName | Changes street's name.
Public method | CreateBanquet(DateTime, IClientStub, IOrderStub, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
Public method | CreateBanquet(DateTime, IClientStub, IReadOnlyListITable, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
Public method | CreateClient | Creates new client. The client must have a card number or at least one phone number.
Public method | CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info.
Public method | CreateDeliveryOrder(NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Public method | CreateDeliveryOrder(Guid, Guid, NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Public method | CreateJournalEvent | Creates new journal event.
Public method | CreateOrder | Creates new order on specified table. User must have rights to create orders.
Public method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
Public method | CreateStreet(String) | Creates new street.
Public method | CreateStreet(Guid, String, ICity) | Creates new street.
Public method | DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts.
Public method | DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order.
Public method | DeleteExternalPaymentItem | Delete existing external payment item from order.
Public method | DeleteOrderCombo | Delete order combo item.
Public method | DeleteOrderExternalData | Deletes external data from the order.
Public method | DeleteOrderGuest | Deletes guest without any products from order.
Public method | DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderItemComment | Deletes product order item's comment.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderProductItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrRestoreStreet | Deletes street.
Public method | DeletePaymentItem | Delete existing payment item from order.
Public method | DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order.
Public method | DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders.
Public method | DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders.
Public method | GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.
Public method | MarkOrderAsTab | Marks the order as tab and assignes tab name.
Public method | MoveOrderItemToAnotherGuest | Moves product item between guests of the same order.
Public method | MoveOrderItemToAnotherOrder | Moves product item between orders.
Public method | OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order.
Public method | RecoverCorruptedReserve | Recovers banquet which is bound to non-existent order. Normally such cases should never occur, but due to entities storage implementation details sometimes banquet may loose its order. Note that new empty order will be created from scratch.
Public method | RenameOrderGuest | Renames order's guest.
Public method | ReopenReserve | Reopens previously closed or canceled reserve.
Public method | ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.
Public method | ResetPriceCategory | Resets price category of the order.
Public method | ServeOrderCookingItem | Mark order item product as served.
Public method | SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders.
Public method | SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.
Public method | SetDeliveryDelivered | Change delivery status to delivered.
Public method | SetDeliveryUndelivered | Change delivery status to OnWay from status delivered.
Public method | SetJournalEventAttribute | Sets attribute for journal event.
Public method | SetOpenPrice | Changes order item open price.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub) | Sets the custom name of the product item modifier. User must have rights to edit orders.
Public method | SetOrderType | Sets order type for order.
Public method | SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders.
Public method | SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders.
Public method | SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders.
Public method | SplitOrderCookingItem | Cut off specified amount from product to new one.
Public method | StartBanquet | Transits banquet to the started status.
Public method | UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently.
Public method | UnserveOrderCookingItem | Mark order item product as unserved.
Public method | UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items.
Top
Extension Methods
 | Name | Description
Public Extension Method | ChangeReserveTable | Changes reserving table. (Defined by EditSessionExtensions.)
Public Extension Method | CreateBanquet | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time. (Defined by EditSessionExtensions.)
Public Extension Method | CreateOrder | Creates new order on specified table. User must have rights to create orders. (Defined by EditSessionExtensions.)
Public Extension Method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time. (Defined by EditSessionExtensions.)
Top
See Also

Reference

Resto.Front.Api.Editors Namespace
IOperationServiceCreateEditSession
IOperationServiceSubmitChanges(ICredentials, IEditSession)


IEditSession Properties

The IEditSession type exposes the following members.

Properties
 | Name | Description
Public property | HasChanges | Determines whether an edit session has changes.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.HasChanges Property

IEditSessionHasChanges Property

Determines whether an edit session has changes.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool HasChanges { get; }

Property Value

Type: Boolean
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession Methods

The IEditSession type exposes the following members.

Methods
 | Name | Description
Public method | ActivateReserve | Closes reserve and creates order on reserved table.
Public method | AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
Public method | AddDiscountByCardNumber | Add discount by card number.
Public method | AddExternalFiscalizedPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new externally fiscalized payment item to order.
Public method | AddExternalFiscalizedPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new external fiscalized payment item to order.
Public method | AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Public method | AddExternalPaymentItem(Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Public method | AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
Public method | AddFlexibleSumDiscountByCardNumber | Add discount by card number.
Public method | AddIikoCardDiscounts | Adds discounts grouped by order items.
Public method | AddOrderCombo | Create order combo item. Order must contain new combo items.
Public method | AddOrderCompoundItem(IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Public method | AddOrderCompoundItem(Guid, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Public method | AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(String, IOrderStub) to delete the data when it's no longer needed.
Public method | AddOrderGuest(String, IOrderStub) | Adds new guest to existing order. User must have rights to edit orders.
Public method | AddOrderGuest(Guid, String, IOrderStub) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Public method | AddOrderProductItem(Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Public method | AddOrderProductItem(Guid, Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Public method | AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders.
Public method | AddPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Public method | AddPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Public method | AddPreliminaryPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Public method | AddPreliminaryPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Public method | AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Public method | AddPrimaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Public method | AddSecondaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Public method | AddSecondaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Public method | AttachToJournalEvent | Sets default attributes of order for journal event.
Public method | BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order.
Public method | ChangeClientAddresses | Changes client addresses.
Public method | ChangeClientBirthDate | Changes client's birth date.
Public method | ChangeClientBlacklistInfo | Changes client blacklist info.
Public method | ChangeClientCardNumber | Changes client card number.
Public method | ChangeClientComment | Changes client comment.
Public method | ChangeClientConsentDates | Changes client's dates of consent.
Public method | ChangeClientEmails | Changes client emails list.
Public method | ChangeClientGender | Change client's gender.
Public method | ChangeClientIikoBizId | Changes client's account in iiko.biz.
Public method | ChangeClientLastOrderDate | Changes client's last order date.
Public method | ChangeClientLinkedCounteragent | Changes client linked counter agent.
Public method | ChangeClientMainAddressIndex | Changes client main address index.
Public method | ChangeClientMarketingSource | Changes client marketing source.
Public method | ChangeClientName | Changes client name.
Public method | ChangeClientNick | Changes client nickname.
Public method | ChangeClientOrganizationDetailsInfo | Changes organization details information of client.
Public method | ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data.
Public method | ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent.
Public method | ChangeClientPhones | Changes client phones list.
Public method | ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages.
Public method | ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages.
Public method | ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages.
Public method | ChangeClientSurname | Changes client surname.
Public method | ChangeComboAmount | Change combo amount.
Public method | ChangeComboPrice | Change combo price.
Public method | ChangeCookingPriority | Changes custom cooking priority and top priority flag.
Public method | ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered.
Public method | ChangeDeliveryAddress | Changes address of delivery
Public method | ChangeDeliveryClientName | Change name of delivery client.
Public method | ChangeDeliveryComment | Change the order comment.
Public method | ChangeDeliveryConfirmTime | Changes delivery confirmation state and time.
Public method | ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered.
Public method | ChangeDeliveryCustomApiData | Change the delivery custom data from api.
Public method | ChangeDeliveryDuration | Change duration of delivery processing.
Public method | ChangeDeliveryEmail | Change the order e-mail.
Public method | ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered.
Public method | ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal.
Public method | ChangeDeliveryExternalCourier | Changes external courier for delivery.
Public method | ChangeDeliveryExternalCourierService | Changes external courier service for delivery.
Public method | ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server.
Public method | ChangeDeliveryLocation | Changes delivery address location.
Public method | ChangeDeliveryMarketingSource | Assign/change order marketing source.
Public method | ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal.
Public method | ChangeDeliveryOperator | Assign/change the order operator.
Public method | ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.
Public method | ChangeDeliveryPhone | Changes the order phone.
Public method | ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.
Public method | ChangeDeliveryProblemComment | Change the order problem comment.
Public method | ChangeDeliveryProblemStatus | Change the order problem status.
Public method | ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons.
Public method | ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.
Public method | ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item.
Public method | ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order.
Public method | ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders.
Public method | ChangeOrderCookingItemCourse | Changes the course of the order item.
Public method | ChangeOrderCookingItemSize | Changes the product size of the order item.
Public method | ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system.
Public method | ChangeOrderItemComment | Changes product order item's comment.
Public method | ChangeOrderItemWaiter | Changes product order item's waiter.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
Public method | ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.
Public method | ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time.
Public method | ChangeOrderTables | Changes tables of the order.
Public method | ChangeOrderWaiter | Changes order's waiter.
Public method | ChangePaymentItemCustomData | Changes custom data of existing payment item.
Public method | ChangePaymentItemSum | Changes sum of existing payment item.
Public method | ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item.
Public method | ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item.
Public method | ChangePriceCategory | Changes price category of the order.
Public method | ChangeReserveComment | Changes reserve comment. Use empty string to clear comment.
Public method | ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.
Public method | ChangeReserveEstimatedStartTime | Changes estimated reserve start time.
Public method | ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2.
Public method | ChangeReserveReminder | Changes reserve reminder flag.
Public method | ChangeReserveTables | Changes reserving tables.
Public method | ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.
Public method | ChangeStreetName | Changes street's name.
Public method | CreateBanquet(DateTime, IClientStub, IOrderStub, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
Public method | CreateBanquet(DateTime, IClientStub, IReadOnlyListITable, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
Public method | CreateClient | Creates new client. The client must have a card number or at least one phone number.
Public method | CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info.
Public method | CreateDeliveryOrder(NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Public method | CreateDeliveryOrder(Guid, Guid, NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Public method | CreateJournalEvent | Creates new journal event.
Public method | CreateOrder | Creates new order on specified table. User must have rights to create orders.
Public method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
Public method | CreateStreet(String) | Creates new street.
Public method | CreateStreet(Guid, String, ICity) | Creates new street.
Public method | DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts.
Public method | DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order.
Public method | DeleteExternalPaymentItem | Delete existing external payment item from order.
Public method | DeleteOrderCombo | Delete order combo item.
Public method | DeleteOrderExternalData | Deletes external data from the order.
Public method | DeleteOrderGuest | Deletes guest without any products from order.
Public method | DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderItemComment | Deletes product order item's comment.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderProductItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrRestoreStreet | Deletes street.
Public method | DeletePaymentItem | Delete existing payment item from order.
Public method | DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order.
Public method | DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders.
Public method | DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders.
Public method | GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.
Public method | MarkOrderAsTab | Marks the order as tab and assignes tab name.
Public method | MoveOrderItemToAnotherGuest | Moves product item between guests of the same order.
Public method | MoveOrderItemToAnotherOrder | Moves product item between orders.
Public method | OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order.
Public method | RecoverCorruptedReserve | Recovers banquet which is bound to non-existent order. Normally such cases should never occur, but due to entities storage implementation details sometimes banquet may loose its order. Note that new empty order will be created from scratch.
Public method | RenameOrderGuest | Renames order's guest.
Public method | ReopenReserve | Reopens previously closed or canceled reserve.
Public method | ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.
Public method | ResetPriceCategory | Resets price category of the order.
Public method | ServeOrderCookingItem | Mark order item product as served.
Public method | SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders.
Public method | SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.
Public method | SetDeliveryDelivered | Change delivery status to delivered.
Public method | SetDeliveryUndelivered | Change delivery status to OnWay from status delivered.
Public method | SetJournalEventAttribute | Sets attribute for journal event.
Public method | SetOpenPrice | Changes order item open price.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub) | Sets the custom name of the product item modifier. User must have rights to edit orders.
Public method | SetOrderType | Sets order type for order.
Public method | SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders.
Public method | SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders.
Public method | SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders.
Public method | SplitOrderCookingItem | Cut off specified amount from product to new one.
Public method | StartBanquet | Transits banquet to the started status.
Public method | UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently.
Public method | UnserveOrderCookingItem | Mark order item product as unserved.
Public method | UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items.
Top
Extension Methods
 | Name | Description
Public Extension Method | ChangeReserveTable | Changes reserving table. (Defined by EditSessionExtensions.)
Public Extension Method | CreateBanquet | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time. (Defined by EditSessionExtensions.)
Public Extension Method | CreateOrder | Creates new order on specified table. User must have rights to create orders. (Defined by EditSessionExtensions.)
Public Extension Method | CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time. (Defined by EditSessionExtensions.)
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ActivateReserve Method

IEditSessionActivateReserve Method

Closes reserve and creates order on reserved table.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderStub ActivateReserve(
    IReserveStub reserve
)

Parameters

reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to activate.

Return Value

Type: INewOrderStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddDiscount Method

IEditSessionAddDiscount Method

Adds simple discount of known type to existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddDiscount(
    IDiscountType discount,
    IOrderStub order
)

Parameters

discount
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of the discount
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order where discount will be applied.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddDiscountByCardNumber Method

IEditSessionAddDiscountByCardNumber Method

Add discount by card number.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddDiscountByCardNumber(
    string cardNumber,
    IOrderStub order,
    IDiscountCard discountCard
)

Parameters

cardNumber
Type: SystemString
Number of iiko discount card.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order where discount will be applied.
discountCard
Type: Resto.Front.Api.Data.OrdersIDiscountCard
Iiko discount card data.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalFiscalizedPaymentItem Method

IEditSessionAddExternalFiscalizedPaymentItem Method

Overload List
 | Name | Description
Public method | AddExternalFiscalizedPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new externally fiscalized payment item to order.
Public method | AddExternalFiscalizedPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new external fiscalized payment item to order.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalFiscalizedPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

IEditSessionAddExternalFiscalizedPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

Add new externally fiscalized payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddExternalFiscalizedPaymentItem(
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddExternalFiscalizedPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalFiscalizedPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

IEditSessionAddExternalFiscalizedPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

Add new external fiscalized payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddExternalFiscalizedPaymentItem(
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddExternalFiscalizedPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalPaymentItem Method

IEditSessionAddExternalPaymentItem Method

Overload List
 | Name | Description
Public method | AddExternalPaymentItem(Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Public method | AddExternalPaymentItem(Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub) | Add new external payment item to order.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalPaymentItem Method (Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub)

IEditSessionAddExternalPaymentItem Method (Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub)

Add new external payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddExternalPaymentItem(
    decimal paymentSum,
    bool isProcessed,
    IPaymentItemAdditionalData additionalData,
    OrganizationDetailsInfo organizationDetailsInfo,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
isProcessed
Type: SystemBoolean
Whether payment item was already processed by some external system.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
organizationDetailsInfo
Type: Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo
Organization details informations.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddExternalPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddExternalPaymentItem Method (Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub)

IEditSessionAddExternalPaymentItem Method (Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrderStub)

Add new external payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddExternalPaymentItem(
    Guid id,
    decimal paymentSum,
    bool isProcessed,
    IPaymentItemAdditionalData additionalData,
    OrganizationDetailsInfo organizationDetailsInfo,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
isProcessed
Type: SystemBoolean
Whether payment item was already processed by some external system.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
organizationDetailsInfo
Type: Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo
Organization details informations.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddExternalPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddFlexibleSumDiscount Method

IEditSessionAddFlexibleSumDiscount Method

Adds simple discount of known type to existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddFlexibleSumDiscount(
    decimal sum,
    IDiscountType discount,
    IOrderStub order
)

Parameters

sum
Type: SystemDecimal
Discount sum.
discount
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of the discount
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order where discount will be applied.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddFlexibleSumDiscountByCardNumber Method

IEditSessionAddFlexibleSumDiscountByCardNumber Method

Add discount by card number.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddFlexibleSumDiscountByCardNumber(
    string cardNumber,
    decimal sum,
    IOrderStub order,
    IDiscountCard discountCard
)

Parameters

cardNumber
Type: SystemString
Number of iiko discount card.
sum
Type: SystemDecimal
Discount sum.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order where discount will be applied.
discountCard
Type: Resto.Front.Api.Data.OrdersIDiscountCard
Iiko discount card data.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddIikoCardDiscounts Method

IEditSessionAddIikoCardDiscounts Method

Adds discounts grouped by order items.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddIikoCardDiscounts(
    IReadOnlyCollection<IikoCardDiscount> discounts,
    IOrderStub order
)

Parameters

discounts
Type: System.Collections.GenericIReadOnlyCollection IikoCardDiscount
iikoCard discount data.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order where discounts will be applied.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderCombo Method

IEditSessionAddOrderCombo Method

Create order combo item. Order must contain new combo items.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderComboStub AddOrderCombo(
    Guid id,
    string name,
    int amount,
    decimal price,
    Guid sourceActionId,
    Guid programId,
    IReadOnlyDictionary<Guid, IOrderCookingItemStub> comboItems,
    IOrderStub order,
    IOrderGuestItemStub guest
)

Parameters

id
Type: SystemGuid
Unique identifier of the new combo.
name
Type: SystemString
Name of combo.
amount
Type: SystemInt32
Amount of combo.
price
Type: SystemDecimal
Price of combo.
sourceActionId
Type: SystemGuid
Unique identifier of source combo (template identifier).
programId
Type: SystemGuid
Identifier of the loyalty program.
comboItems
Type: System.Collections.GenericIReadOnlyDictionary Guid, IOrderCookingItemStub
Combo items dictionary. Key - combo group identifier, Value - item id (must be contained in order).
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which combo will be added.
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which combo will be added.

Return Value

Type: INewOrderComboStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderCompoundItem Method

IEditSessionAddOrderCompoundItem Method

Overload List
 | Name | Description
Public method | AddOrderCompoundItem(IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Public method | AddOrderCompoundItem(Guid, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse) | Adds compound item to the guest in existing order. User must have permission to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderCompoundItem Method (IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse)

IEditSessionAddOrderCompoundItem Method (IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse)

Adds compound item to the guest in existing order. User must have permission to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemStub AddOrderCompoundItem(
    IProduct product,
    IOrderStub order,
    IOrderGuestItemStub guest,
    IProductSize size,
    OrderItemCourse course = OrderItemCourse.Default
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position used to fix modifiers. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which position will be added.
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's template has scale, otherwise null.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.

Return Value

Type: INewOrderCompoundItemStub
Remarks
Compound item should have at least one component, so AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) should be called after adding a compound item.
See Also

Reference

IEditSession Interface
AddOrderCompoundItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderCompoundItem Method (Guid, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse)

IEditSessionAddOrderCompoundItem Method (Guid, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse)

Adds compound item to the guest in existing order. User must have permission to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemStub AddOrderCompoundItem(
    Guid id,
    IProduct product,
    IOrderStub order,
    IOrderGuestItemStub guest,
    IProductSize size,
    OrderItemCourse course = OrderItemCourse.Default
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position used to fix modifiers. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which position will be added.
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's template has scale, otherwise null.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.

Return Value

Type: INewOrderCompoundItemStub
Remarks
Compound item should have at least one component, so AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) should be called after adding a compound item.
See Also

Reference

IEditSession Interface
AddOrderCompoundItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderExternalData Method

IEditSessionAddOrderExternalData Method

Adds external data to the order. Use DeleteOrderExternalData(String, IOrderStub) to delete the data when it's no longer needed.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AddOrderExternalData(
    string key,
    string value,
    IOrderStub order
)

Parameters

key
Type: SystemString
External data key. Max length - 256 chars.
value
Type: SystemString
External data value. Max length - 32000 chars.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which external data will be added.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderGuest Method

IEditSessionAddOrderGuest Method

Overload List
 | Name | Description
Public method | AddOrderGuest(String, IOrderStub) | Adds new guest to existing order. User must have rights to edit orders.
Public method | AddOrderGuest(Guid, String, IOrderStub) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderGuest Method (String, IOrderStub)

IEditSessionAddOrderGuest Method (String, IOrderStub)

Adds new guest to existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderGuestItemStub AddOrderGuest(
    string name,
    IOrderStub order
)

Parameters

name
Type: SystemString
Name of the new guest. If name is null, then it will be generated automatically.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Existing order

Return Value

Type: INewOrderGuestItemStub
See Also

Reference

IEditSession Interface
AddOrderGuest Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderGuest Method (Guid, String, IOrderStub)

IEditSessionAddOrderGuest Method (Guid, String, IOrderStub)

Adds new guest with the given ID to existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderGuestItemStub AddOrderGuest(
    Guid id,
    string name,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the new guest in the order. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
name
Type: SystemString
Name of the new guest. If name is null, then it will be generated automatically.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Existing order

Return Value

Type: INewOrderGuestItemStub
See Also

Reference

IEditSession Interface
AddOrderGuest Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method

IEditSessionAddOrderModifierItem Method

Overload List
 | Name | Description
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
Public method | AddOrderModifierItem(Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderCompoundItemComponentStub component,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
component
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
Remarks
Compound item should have at least one component, so AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) should be called before adding modifiers.
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal)

Adds order item modifier to the order item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderProductItemStub productItem,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
productItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemComponentStub, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderCompoundItemComponentStub component,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
component
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderCompoundItemStub, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
Remarks
Compound item should have at least one component, so AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) should be called before adding modifiers.
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, Nullable(Int32), Nullable(Decimal))

IEditSessionAddOrderModifierItem Method (Guid, Int32, IProduct, IProductGroup, IOrderStub, IOrderProductItemStub, NullableInt32, NullableDecimal)

Adds order item modifier to the order item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderModifierItemStub AddOrderModifierItem(
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrderStub order,
    IOrderProductItemStub productItem,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which modifier will be added
productItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item to which modifier will be added.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderModifierItemStub
See Also

Reference

IEditSession Interface
AddOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderProductItem Method

IEditSessionAddOrderProductItem Method

Overload List
 | Name | Description
Public method | AddOrderProductItem(Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Public method | AddOrderProductItem(Guid, Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderProductItem Method (Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, Nullable(Decimal))

IEditSessionAddOrderProductItem Method (Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal)

Adds assortment position to the guest in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderProductItemStub AddOrderProductItem(
    decimal amount,
    IProduct product,
    IOrderStub order,
    IOrderGuestItemStub guest,
    IProductSize size,
    OrderItemCourse course = OrderItemCourse.Default,
    decimal? predefinedPrice = null
)

Parameters

amount
Type: SystemDecimal
For positions with weight: weight in defined measure unit. For positions without weight: amount of the position. Can be from 0.001 to 999.999
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which position will be added
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's product has scale, otherwise null.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the order item, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderProductItemStub
See Also

Reference

IEditSession Interface
AddOrderProductItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderProductItem Method (Guid, Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, Nullable(Decimal))

IEditSessionAddOrderProductItem Method (Guid, Decimal, IProduct, IOrderStub, IOrderGuestItemStub, IProductSize, OrderItemCourse, NullableDecimal)

Adds assortment position to the guest in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderProductItemStub AddOrderProductItem(
    Guid id,
    decimal amount,
    IProduct product,
    IOrderStub order,
    IOrderGuestItemStub guest,
    IProductSize size,
    OrderItemCourse course = OrderItemCourse.Default,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new item in the order. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemDecimal
For positions with weight: weight in defined measure unit. For positions without weight: amount of the position. Can be from 0.001 to 999.999
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which position will be added
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's product has scale, otherwise null.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the order item, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderProductItemStub
See Also

Reference

IEditSession Interface
AddOrderProductItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddOrderServiceItem Method

IEditSessionAddOrderServiceItem Method

Adds time pay service item to the guest in existing order. User must have permission to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderServiceItemStub AddOrderServiceItem(
    IProduct service,
    IOrderStub order,
    IOrderGuestItemStub guest,
    TimeSpan? timeLimit = null
)

Parameters

service
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added
guest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest to which position will be added
timeLimit (Optional)
Type: SystemNullable TimeSpan
Total amount of time after which the service will be stopped or null for default limit (12 hours). Includes all periods.

Return Value

Type: INewOrderServiceItemStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddPaymentItem Method

IEditSessionAddPaymentItem Method

Overload List
 | Name | Description
Public method | AddPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Public method | AddPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub) | Add new payment item to order.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

IEditSessionAddPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

Add new payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddPaymentItem(
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

IEditSessionAddPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrderStub)

Add new payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddPaymentItem(
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddPreliminaryPaymentItem Method

IEditSessionAddPreliminaryPaymentItem Method

Overload List
 | Name | Description
Public method | AddPreliminaryPaymentItem(Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Public method | AddPreliminaryPaymentItem(Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub) | Add new preliminary payment item to order.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddPreliminaryPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub)

IEditSessionAddPreliminaryPaymentItem Method (Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub)

Add new preliminary payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddPreliminaryPaymentItem(
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IDeliveryOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Delivery order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddPreliminaryPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddPreliminaryPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub)

IEditSessionAddPreliminaryPaymentItem Method (Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrderStub)

Add new preliminary payment item to order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewPaymentItemStub AddPreliminaryPaymentItem(
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IDeliveryOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Delivery order to which payment item will be added.

Return Value

Type: INewPaymentItemStub
See Also

Reference

IEditSession Interface
AddPreliminaryPaymentItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddPrimaryComponent Method

IEditSessionAddPrimaryComponent Method

Overload List
 | Name | Description
Public method | AddPrimaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Public method | AddPrimaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a primary component to the compound item.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddPrimaryComponent Method (IProduct, IOrderStub, IOrderCompoundItemStub, Nullable(Decimal))

IEditSessionAddPrimaryComponent Method (IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal)

Adds a primary component to the compound item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemComponentStub AddPrimaryComponent(
    IProduct product,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    decimal? predefinedPrice = null
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Compound item to which new component will be added.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the component, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderCompoundItemComponentStub
See Also

Reference

IEditSession Interface
AddPrimaryComponent Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddPrimaryComponent Method (Guid, IProduct, IOrderStub, IOrderCompoundItemStub, Nullable(Decimal))

IEditSessionAddPrimaryComponent Method (Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal)

Adds a primary component to the compound item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemComponentStub AddPrimaryComponent(
    Guid id,
    IProduct product,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Compound item to which new component will be added.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the component, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderCompoundItemComponentStub
See Also

Reference

IEditSession Interface
AddPrimaryComponent Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddSecondaryComponent Method

IEditSessionAddSecondaryComponent Method

Overload List
 | Name | Description
Public method | AddSecondaryComponent(IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Public method | AddSecondaryComponent(Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal) | Adds a secondary component to the compound item.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.AddSecondaryComponent Method (IProduct, IOrderStub, IOrderCompoundItemStub, Nullable(Decimal))

IEditSessionAddSecondaryComponent Method (IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal)

Adds a secondary component to the compound item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemComponentStub AddSecondaryComponent(
    IProduct product,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    decimal? predefinedPrice = null
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Compound item to which new component will be added.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the component, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderCompoundItemComponentStub
See Also

Reference

IEditSession Interface
AddSecondaryComponent Overload
Resto.Front.Api.Editors Namespace


IEditSession.AddSecondaryComponent Method (Guid, IProduct, IOrderStub, IOrderCompoundItemStub, Nullable(Decimal))

IEditSessionAddSecondaryComponent Method (Guid, IProduct, IOrderStub, IOrderCompoundItemStub, NullableDecimal)

Adds a secondary component to the compound item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCompoundItemComponentStub AddSecondaryComponent(
    Guid id,
    IProduct product,
    IOrderStub order,
    IOrderCompoundItemStub compoundItem,
    decimal? predefinedPrice = null
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which position will be added.
compoundItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Compound item to which new component will be added.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the component, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: INewOrderCompoundItemComponentStub
See Also

Reference

IEditSession Interface
AddSecondaryComponent Overload
Resto.Front.Api.Editors Namespace


IEditSession.AttachToJournalEvent Method

IEditSessionAttachToJournalEvent Method

Sets default attributes of order for journal event.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void AttachToJournalEvent(
    IOrderStub order,
    INewJournalEventStub journalEvent
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order.
journalEvent
Type: Resto.Front.Api.Editors.StubsINewJournalEventStub
Journal event.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.BindReserveToOrder Method

IEditSessionBindReserveToOrder Method

Converts exising reserve or banquet without order to banquet with order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void BindReserveToOrder(
    IReserveStub reserve,
    IOrderStub order
)

Parameters

reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to bind.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order used to bind reserve to.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientAddresses Method

IEditSessionChangeClientAddresses Method

Changes client addresses.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientAddresses(
    List<AddressDto> addresses,
    int? mainAddressIndex,
    IClientStub client
)

Parameters

addresses
Type: System.Collections.GenericList AddressDto
new addresses list of client
mainAddressIndex
Type: SystemNullable Int32
index of client main address
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientBirthDate Method

IEditSessionChangeClientBirthDate Method

Changes client's birth date.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientBirthDate(
    DateTime? birthDate,
    IClientStub client
)

Parameters

birthDate
Type: SystemNullable DateTime
New birth date
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientBlacklistInfo Method

IEditSessionChangeClientBlacklistInfo Method

Changes client blacklist info.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientBlacklistInfo(
    bool isInBlacklist,
    string reason,
    IClientStub client
)

Parameters

isInBlacklist
Type: SystemBoolean
Is changing client in blacklist.
reason
Type: SystemString
The reason of adding client to blacklist.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientCardNumber Method

IEditSessionChangeClientCardNumber Method

Changes client card number.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientCardNumber(
    string cardNumber,
    IClientStub client
)

Parameters

cardNumber
Type: SystemString
New card number of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientComment Method

IEditSessionChangeClientComment Method

Changes client comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientComment(
    string comment,
    IClientStub client
)

Parameters

comment
Type: SystemString
new name of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientConsentDates Method

IEditSessionChangeClientConsentDates Method

Changes client's dates of consent.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientConsentDates(
    DateTime? consentFrom,
    DateTime? consentTo,
    IClientStub client
)

Parameters

consentFrom
Type: SystemNullable DateTime
The date and time of explicit consent by the client.
consentTo
Type: SystemNullable DateTime
The date and time when client's consent expires.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientEmails Method

IEditSessionChangeClientEmails Method

Changes client emails list.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientEmails(
    List<EmailDto> emails,
    IClientStub client
)

Parameters

emails
Type: System.Collections.GenericList EmailDto
new emails list of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientGender Method

IEditSessionChangeClientGender Method

Change client's gender.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientGender(
    Gender gender,
    IClientStub client
)

Parameters

gender
Type: Resto.Front.Api.Data.BrdGender
New gender.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientIikoBizId Method

IEditSessionChangeClientIikoBizId Method

Changes client's account in iiko.biz.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientIikoBizId(
    Guid iikoBizId,
    IClientStub client
)

Parameters

iikoBizId
Type: SystemGuid
New account in iiko.biz
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientLastOrderDate Method

IEditSessionChangeClientLastOrderDate Method

Changes client's last order date.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientLastOrderDate(
    DateTime lastOrderDate,
    IClientStub client
)

Parameters

lastOrderDate
Type: SystemDateTime
New last order date
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientLinkedCounteragent Method

IEditSessionChangeClientLinkedCounteragent Method

Changes client linked counter agent.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientLinkedCounteragent(
    IClientStub client,
    IUser linkedCounteragent
)

Parameters

client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client.
linkedCounteragent
Type: Resto.Front.Api.Data.SecurityIUser
New linked counteragent.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientMainAddressIndex Method

IEditSessionChangeClientMainAddressIndex Method

Changes client main address index.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientMainAddressIndex(
    int mainAddressIndex,
    IClientStub client
)

Parameters

mainAddressIndex
Type: SystemInt32
index of client main address
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientMarketingSource Method

IEditSessionChangeClientMarketingSource Method

Changes client marketing source.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientMarketingSource(
    IMarketingSource marketingSource,
    IClientStub client
)

Parameters

marketingSource
Type: Resto.Front.Api.Data.BrdIMarketingSource
New marketing source of the client.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientName Method

IEditSessionChangeClientName Method

Changes client name.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientName(
    string name,
    IClientStub client
)

Parameters

name
Type: SystemString
new name of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientNick Method

IEditSessionChangeClientNick Method

Changes client nickname.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientNick(
    string nick,
    IClientStub client
)

Parameters

nick
Type: SystemString
new nick of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientOrganizationDetailsInfo Method

IEditSessionChangeClientOrganizationDetailsInfo Method

Changes organization details information of client.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientOrganizationDetailsInfo(
    string name,
    string code,
    string accountingReasonCode,
    string address,
    string counteragentRecipientCode,
    string fullAddressPostCode,
    string fullAddressCountry,
    string fullAddressRegion,
    string fullAddressCity,
    string fullAddressStreet,
    string fullAddressHouse,
    IClientStub client
)

Parameters

name
Type: SystemString
Client's organization name
code
Type: SystemString
Client's organization code
accountingReasonCode
Type: SystemString
Client's organization accounting reason code
address
Type: SystemString
Client's organization address
counteragentRecipientCode
Type: SystemString
Client's organization recipient code
fullAddressPostCode
Type: SystemString
Client's organization full address post code
fullAddressCountry
Type: SystemString
Client's organization full address country
fullAddressRegion
Type: SystemString
Client's organization full address region
fullAddressCity
Type: SystemString
Client's organization full address city
fullAddressStreet
Type: SystemString
Client's organization full address street
fullAddressHouse
Type: SystemString
Client's organization full address house
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientPersonalDataConsent Method

IEditSessionChangeClientPersonalDataConsent Method

Changes whether client consented processing their personal data.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientPersonalDataConsent(
    bool? consent,
    IClientStub client
)

Parameters

consent
Type: SystemNullable Boolean
Client's consent status to the processing of the personal data
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientPersonalDataProcessingDates Method

IEditSessionChangeClientPersonalDataProcessingDates Method

Changes dates of the time interval which allows client's legal personal data processing without thier consent.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientPersonalDataProcessingDates(
    DateTime? processingFrom,
    DateTime? processingTo,
    IClientStub client
)

Parameters

processingFrom
Type: SystemNullable DateTime
The date and time of the beginning of legal personal data processing.
processingTo
Type: SystemNullable DateTime
The date and time of the end of the legal personal data processing.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientPhones Method

IEditSessionChangeClientPhones Method

Changes client phones list.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientPhones(
    List<PhoneDto> phones,
    IClientStub client
)

Parameters

phones
Type: System.Collections.GenericList PhoneDto
new phones list of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientReceivesLoyaltySystemNotifications Method

IEditSessionChangeClientReceivesLoyaltySystemNotifications Method

Changes whether client receives loyalty system notification messages.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientReceivesLoyaltySystemNotifications(
    bool receivesLoyaltySystemNotifications,
    IClientStub client
)

Parameters

receivesLoyaltySystemNotifications
Type: SystemBoolean
Whether client receives loyalty system notification messages
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientReceivesOrderStatusNotifications Method

IEditSessionChangeClientReceivesOrderStatusNotifications Method

Changes whether client receives order status notification messages.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientReceivesOrderStatusNotifications(
    bool receivesOrderStatusNotifications,
    IClientStub client
)

Parameters

receivesOrderStatusNotifications
Type: SystemBoolean
Whether client receives order status notification messages
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientReceivesPromotionalNotifications Method

IEditSessionChangeClientReceivesPromotionalNotifications Method

Changes whether client receives promotional notification messages.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientReceivesPromotionalNotifications(
    bool receivesPromotionalNotifications,
    IClientStub client
)

Parameters

receivesPromotionalNotifications
Type: SystemBoolean
Whether client receives promotional notification messages
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeClientSurname Method

IEditSessionChangeClientSurname Method

Changes client surname.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeClientSurname(
    string surname,
    IClientStub client
)

Parameters

surname
Type: SystemString
new surname of client
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Changing client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeComboAmount Method

IEditSessionChangeComboAmount Method

Change combo amount.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeComboAmount(
    int amount,
    IOrderComboStub combo,
    IOrderStub order
)

Parameters

amount
Type: SystemInt32
New combo amount.
combo
Type: Resto.Front.Api.Editors.StubsIOrderComboStub
Combo which amount will be changed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which combo amount will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeComboPrice Method

IEditSessionChangeComboPrice Method

Change combo price.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeComboPrice(
    decimal price,
    IOrderComboStub combo,
    IOrderStub order
)

Parameters

price
Type: SystemDecimal
New combo price.
combo
Type: Resto.Front.Api.Editors.StubsIOrderComboStub
Combo which price will be changed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which combo price will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeCookingPriority Method

IEditSessionChangeCookingPriority Method

Changes custom cooking priority and top priority flag.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeCookingPriority(
    int customPriority,
    bool isTopPriority,
    IOrderStub order
)

Parameters

customPriority
Type: SystemInt32
Specifies a custom cooking priority.
isTopPriority
Type: SystemBoolean
Sets a top priority flag.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to apply custom priority
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryActualDeliverTime Method

IEditSessionChangeDeliveryActualDeliverTime Method

Change time when the order was actually delivered.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryActualDeliverTime(
    DateTime? actualDeliverTime,
    IDeliveryOrderStub order
)

Parameters

actualDeliverTime
Type: SystemNullable DateTime
Actual deliver time
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change status.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryAddress Method

IEditSessionChangeDeliveryAddress Method

Changes address of delivery

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryAddress(
    AddressDto address,
    IDeliveryOrderStub order
)

Parameters

address
Type: Resto.Front.Api.Data.BrdAddressDto
New address of delivery
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change address
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryClientName Method

IEditSessionChangeDeliveryClientName Method

Change name of delivery client.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryClientName(
    string clientName,
    IDeliveryOrderStub order
)

Parameters

clientName
Type: SystemString
Name of client
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Change name of delivery client
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryComment Method

IEditSessionChangeDeliveryComment Method

Change the order comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryComment(
    string comment,
    IDeliveryOrderStub order
)

Parameters

comment
Type: SystemString
Comment
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryConfirmTime Method

IEditSessionChangeDeliveryConfirmTime Method

Changes delivery confirmation state and time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryConfirmTime(
    DateTime? confirmTime,
    IDeliveryOrderStub order
)

Parameters

confirmTime
Type: SystemNullable DateTime
Confirmation time or null if delivery is unconfirmed.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change time.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryCourier Method

IEditSessionChangeDeliveryCourier Method

Assign/Change the order courier. Can use this action only before the order is to be delivered.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryCourier(
    bool isCourierSelectedManually,
    IDeliveryOrderStub order,
    IUser courier
)

Parameters

isCourierSelectedManually
Type: SystemBoolean
Is courier selected manually and can't be replaced with automatic logistic system
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to assign courier.
courier
Type: Resto.Front.Api.Data.SecurityIUser
Courier to assign to delivery.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryCustomApiData Method

IEditSessionChangeDeliveryCustomApiData Method

Change the delivery custom data from api.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryCustomApiData(
    string customApiData,
    IDeliveryOrderStub order
)

Parameters

customApiData
Type: SystemString
Custom data from api
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryDuration Method

IEditSessionChangeDeliveryDuration Method

Change duration of delivery processing.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryDuration(
    TimeSpan duration,
    IDeliveryOrderStub order
)

Parameters

duration
Type: SystemTimeSpan
Calculated delivery duration (accurate within minutes).
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Change precalculated delivery duration.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryEmail Method

IEditSessionChangeDeliveryEmail Method

Change the order e-mail.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryEmail(
    string email,
    IDeliveryOrderStub order
)

Parameters

email
Type: SystemString
E-mail
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryExpectedDeliverTime Method

IEditSessionChangeDeliveryExpectedDeliverTime Method

Change time when client wants the order to be delivered.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryExpectedDeliverTime(
    DateTime expectedDeliverTime,
    IDeliveryOrderStub order
)

Parameters

expectedDeliverTime
Type: SystemDateTime
Expected deliver time
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryExpectedDuration Method

IEditSessionChangeDeliveryExpectedDuration Method

Set calculated delivery duration without overrided value on terminal.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryExpectedDuration(
    TimeSpan? expectedDeliveryDuration,
    IDeliveryOrderStub order
)

Parameters

expectedDeliveryDuration
Type: SystemNullable TimeSpan
delivery duration without overriden value on terminal
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryExternalCourier Method

IEditSessionChangeDeliveryExternalCourier Method

Changes external courier for delivery.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryExternalCourier(
    string courierName,
    string courierPhone,
    string courierComment,
    IDeliveryOrderStub order
)

Parameters

courierName
Type: SystemString
External courier service id.
courierPhone
Type: SystemString
External courier service name.
courierComment
Type: SystemString
External courier service name.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to assign external courier service holder.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryExternalCourierService Method

IEditSessionChangeDeliveryExternalCourierService Method

Changes external courier service for delivery.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryExternalCourierService(
    Guid serviceId,
    string serviceName,
    IDeliveryOrderStub order
)

Parameters

serviceId
Type: SystemGuid
External courier service id.
serviceName
Type: SystemString
External courier service name.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to assign external courier service holder.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryLastVerifiedRestrictionsHash Method

IEditSessionChangeDeliveryLastVerifiedRestrictionsHash Method

Set last verified restirictions hash from server.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryLastVerifiedRestrictionsHash(
    string lastVerifiedDeliveryRestrictionsHash,
    IDeliveryOrderStub order
)

Parameters

lastVerifiedDeliveryRestrictionsHash
Type: SystemString
last verified restirictions hash from server
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryLocation Method

IEditSessionChangeDeliveryLocation Method

Changes delivery address location.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryLocation(
    double? latitude,
    double? longitude,
    IDeliveryOrderStub order
)

Parameters

latitude
Type: SystemNullable Double
Latitude of geolocation of delivery address.
longitude
Type: SystemNullable Double
Longitude of geolocation of delivery address.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change marketing source.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryMarketingSource Method

IEditSessionChangeDeliveryMarketingSource Method

Assign/change order marketing source.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryMarketingSource(
    IDeliveryOrderStub order,
    IMarketingSource marketingSource
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to assign marketing source.
marketingSource
Type: Resto.Front.Api.Data.BrdIMarketingSource
Source of the order.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryMovedId Method

IEditSessionChangeDeliveryMovedId Method

Change new delivery identifier created for move to a new terminal.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryMovedId(
    Guid movedDeliveryId,
    IDeliveryOrderStub order
)

Parameters

movedDeliveryId
Type: SystemGuid
New delivery identifier created for move to a new terminal.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryOperator Method

IEditSessionChangeDeliveryOperator Method

Assign/change the order operator.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryOperator(
    IDeliveryOrderStub order,
    IUser deliveryOperator
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to assign operator.
deliveryOperator
Type: Resto.Front.Api.Data.SecurityIUser
Operator to assign the order to.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryOrderPredictedCookingCompleteTime Method

IEditSessionChangeDeliveryOrderPredictedCookingCompleteTime Method

Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryOrderPredictedCookingCompleteTime(
    DateTime? predictedCookingCompleteTime,
    IDeliveryOrderStub order
)

Parameters

predictedCookingCompleteTime
Type: SystemNullable DateTime
Predicted time
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryPhone Method

IEditSessionChangeDeliveryPhone Method

Changes the order phone.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryPhone(
    string phone,
    IDeliveryOrderStub order
)

Parameters

phone
Type: SystemString
New phone value of the order
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change phone
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryPredictedDeliveryTime Method

IEditSessionChangeDeliveryPredictedDeliveryTime Method

Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryPredictedDeliveryTime(
    DateTime? predictedDeliveryTime,
    IDeliveryOrderStub order
)

Parameters

predictedDeliveryTime
Type: SystemNullable DateTime
Predicted time
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryProblemComment Method

IEditSessionChangeDeliveryProblemComment Method

Change the order problem comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryProblemComment(
    string comment,
    IDeliveryOrderStub order
)

Parameters

comment
Type: SystemString
Problem comment. MaxLength = 1000 symbols. If HasProblem = false it does not mean that ProblemComment = null, because comment isn't erased automatically after set HasProblem to false.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliveryProblemStatus Method

IEditSessionChangeDeliveryProblemStatus Method

Change the order problem status.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliveryProblemStatus(
    bool hasProblem,
    IDeliveryOrderStub order
)

Parameters

hasProblem
Type: SystemBoolean
Problem flag
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeDeliverySplitBetweenPersons Method

IEditSessionChangeDeliverySplitBetweenPersons Method

Changes the order property if it should be splitted between persons.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeDeliverySplitBetweenPersons(
    bool splitBetweenPersons,
    IDeliveryOrderStub order
)

Parameters

splitBetweenPersons
Type: SystemBoolean
Whether the order should be splitted between persons
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeEstimatedOrderGuestsCount Method

IEditSessionChangeEstimatedOrderGuestsCount Method

Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeEstimatedOrderGuestsCount(
    int estimatedGuestsCount,
    IOrderStub order
)

Parameters

estimatedGuestsCount
Type: SystemInt32
How many people will be served using this order, in spite of how many guests this order will be splitted by.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to change estimated guests count.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeExternalPaymentItemCustomData Method

IEditSessionChangeExternalPaymentItemCustomData Method

Changes custom data of existing external payment item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeExternalPaymentItemCustomData(
    string customData,
    IPaymentItemStub paymentItem,
    IOrderStub order
)

Parameters

customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Editors.StubsIPaymentItemStub
External payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order of which payment item will be edited.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderAppliedIikoCard5ManualConditions Method

IEditSessionChangeOrderAppliedIikoCard5ManualConditions Method

Change iikoCard5 manual conditions applied for order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderAppliedIikoCard5ManualConditions(
    List<Guid> appliedManualConditions,
    IOrderStub order
)

Parameters

appliedManualConditions
Type: System.Collections.GenericList Guid
List of iikoCard5 manual condition identifiers applied to order.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to apply iikoCard5 manual conditions.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderCookingItemAmount Method

IEditSessionChangeOrderCookingItemAmount Method

Changes the amount of the assortment position in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderCookingItemAmount(
    decimal amount,
    IOrderCookingItemStub cookingItem,
    IOrderStub order
)

Parameters

amount
Type: SystemDecimal
For positions with weight: new weight in defined measure unit. For positions without weight: new amount of the position. Can be from 0.001 to 999.999
cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Order item that represents the assortment position and which amount will be changed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which contains the product.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderCookingItemCourse Method

IEditSessionChangeOrderCookingItemCourse Method

Changes the course of the order item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderCookingItemCourse(
    OrderItemCourse course,
    IOrderCookingItem cookingItem,
    IOrderStub order
)

Parameters

course
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
New course for order item.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item which course will be changed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which contains the product.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderCookingItemSize Method

IEditSessionChangeOrderCookingItemSize Method

Changes the product size of the order item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderCookingItemSize(
    IProductSize size,
    IOrderCookingItem cookingItem,
    IOrderStub order
)

Parameters

size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item which course will be changed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which contains the product.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderIikoCard5Coupon Method

IEditSessionChangeOrderIikoCard5Coupon Method

Change order iikoCard5 coupon, used in iikoCard5 system.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderIikoCard5Coupon(
    string iikoCard5Coupon,
    IOrderStub order
)

Parameters

iikoCard5Coupon
Type: SystemString
New iikoCard5 coupon
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Existing order
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderItemComment Method

IEditSessionChangeOrderItemComment Method

Changes product order item's comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderItemComment(
    string comment,
    IOrderStub order,
    IOrderCookingItemStub cookingItem
)

Parameters

comment
Type: SystemString
New comment for product order item.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains product order item which comment will be changed.
cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Product order item which comment will be changed. Product order item should not been printed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderItemWaiter Method

IEditSessionChangeOrderItemWaiter Method

Changes product order item's waiter.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderItemWaiter(
    IOrderStub order,
    IOrderRootItemStub orderItem,
    IUser waiter
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains product order item which waiter will be changed.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderRootItemStub
Product order item which waiterId will be changed. Product order item should not been printed.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
Waiter.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderModifierItemAmount Method

IEditSessionChangeOrderModifierItemAmount Method

Overload List
 | Name | Description
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
Public method | ChangeOrderModifierItemAmount(Int32, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub, Nullable(Int32))

IEditSessionChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub, NullableInt32)

Changes the amount of the compound component modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderModifierItemAmount(
    int amount,
    IOrderStub order,
    IOrderCompoundItemComponentStub compoundComponent,
    IOrderModifierItemStub modifier,
    int? payableAmount = null
)

Parameters

amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
compoundComponent
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which amount will be changed.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
See Also

Reference

IEditSession Interface
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub, Nullable(Int32))

IEditSessionChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub, NullableInt32)

Changes the amount of the compound item common modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderModifierItemAmount(
    int amount,
    IOrderStub order,
    IOrderCompoundItemStub orderItem,
    IOrderModifierItemStub modifier,
    int? payableAmount = null
)

Parameters

amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which amount will be changed.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
See Also

Reference

IEditSession Interface
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub, Nullable(Int32))

IEditSessionChangeOrderModifierItemAmount Method (Int32, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub, NullableInt32)

Changes the amount of the product item modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderModifierItemAmount(
    int amount,
    IOrderStub order,
    IOrderProductItemStub orderItem,
    IOrderModifierItemStub modifier,
    int? payableAmount = null
)

Parameters

amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which amount will be changed.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
See Also

Reference

IEditSession Interface
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderOriginName Method

IEditSessionChangeOrderOriginName Method

Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderOriginName(
    string originName,
    IOrderStub order
)

Parameters

originName
Type: SystemString
Non-empty string of the new origin name. Maximum length is 20 chars.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to specify origin.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderPricingTime Method

IEditSessionChangeOrderPricingTime Method

Change order pricing time, which determines the price of products. By default time taken from items print time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderPricingTime(
    DateTime? pricingTime,
    IOrderStub order
)

Parameters

pricingTime
Type: SystemNullable DateTime
New order pricing time
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Existing order
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderTables Method

IEditSessionChangeOrderTables Method

Changes tables of the order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderTables(
    IOrderStub order,
    IReadOnlyList<ITable> tables
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to change tables.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Tables to be assigned to the order.
Remarks
If specified tables belongs to another restaurant section then section property, price category and products cooking palces will also be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeOrderWaiter Method

IEditSessionChangeOrderWaiter Method

Changes order's waiter.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeOrderWaiter(
    IOrderStub order,
    IUser waiter
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which waiter will be changed.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
New waiter.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangePaymentItemCustomData Method

IEditSessionChangePaymentItemCustomData Method

Changes custom data of existing payment item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePaymentItemCustomData(
    string customData,
    IPaymentItemStub paymentItem,
    IOrderStub order
)

Parameters

customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Editors.StubsIPaymentItemStub
Payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order of which payment item will be edited.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangePaymentItemSum Method

IEditSessionChangePaymentItemSum Method

Changes sum of existing payment item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePaymentItemSum(
    decimal paymentSum,
    decimal? minPaymentSum,
    decimal? maxPaymentSum,
    IPaymentItemStub paymentItem,
    IOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
New sum of payment item.
minPaymentSum
Type: SystemNullable Decimal
Minimum allowed payment sum, lower bound for the payment. null means default limit value.
maxPaymentSum
Type: SystemNullable Decimal
Maximum allowed payment sum, upper bound for the payment. null means default limit value.
paymentItem
Type: Resto.Front.Api.Editors.StubsIPaymentItemStub
Payment item to be edited.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order of which payment item will be edited.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangePreliminaryPaymentItemCustomData Method

IEditSessionChangePreliminaryPaymentItemCustomData Method

Changes custom data of existing preliminary payment item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePreliminaryPaymentItemCustomData(
    string customData,
    IPaymentItemStub paymentItem,
    IOrderStub order
)

Parameters

customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Editors.StubsIPaymentItemStub
Preliminary payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order of which payment item will be edited.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangePreliminaryPaymentItemSum Method

IEditSessionChangePreliminaryPaymentItemSum Method

Changes sum of existing preliminary payment item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePreliminaryPaymentItemSum(
    decimal paymentSum,
    IPaymentItemStub paymentItem,
    IOrderStub order
)

Parameters

paymentSum
Type: SystemDecimal
New sum of payment item.
paymentItem
Type: Resto.Front.Api.Editors.StubsIPaymentItemStub
Preliminary payment item to be edited.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order of which payment item will be edited.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangePriceCategory Method

IEditSessionChangePriceCategory Method

Changes price category of the order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangePriceCategory(
    IPriceCategory priceCategory,
    IOrderStub order
)

Parameters

priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
New price category.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to change price category.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveComment Method

IEditSessionChangeReserveComment Method

Changes reserve comment. Use empty string to clear comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveComment(
    string comment,
    IReserveStub reserve
)

Parameters

comment
Type: SystemString
Arbitrary string comment for the reserve, maximum length is 250 chars.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveDuration Method

IEditSessionChangeReserveDuration Method

Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveDuration(
    TimeSpan duration,
    IReserveStub reserve
)

Parameters

duration
Type: SystemTimeSpan
Reserve duration, minimum value is 15 minutes, maximum value is 23 hours and 59 minutes, maximum precision is 1 minute (so 1h 25m 42s is invalid as too precise value).
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveEstimatedStartTime Method

IEditSessionChangeReserveEstimatedStartTime Method

Changes estimated reserve start time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveEstimatedStartTime(
    DateTime estimatedStartTime,
    IReserveStub reserve
)

Parameters

estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned visit, used to divide different visits and remind staff to prepare table.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveGuestsCount Method

IEditSessionChangeReserveGuestsCount Method

Changes estimated guests count for reserve. Default value is 2.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveGuestsCount(
    int guestsCount,
    IReserveStub reserve
)

Parameters

guestsCount
Type: SystemInt32
Estimated guests count, minimum value is 1, maximum value is 1000.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveReminder Method

IEditSessionChangeReserveReminder Method

Changes reserve reminder flag.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveReminder(
    bool shouldRemind,
    IReserveStub reserve
)

Parameters

shouldRemind
Type: SystemBoolean
Whether to remind staff to prepare table beforehand.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeReserveTables Method

IEditSessionChangeReserveTables Method

Changes reserving tables.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeReserveTables(
    IReadOnlyList<ITable> tables,
    IReserveStub reserve
)

Parameters

tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeSelectiveDiscount Method

IEditSessionChangeSelectiveDiscount Method

Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeSelectiveDiscount(
    IOrderStub order,
    IDiscountType discountType,
    IReadOnlyList<IOrderProductItemStub> products,
    IReadOnlyList<IOrderModifierItemStub> modifiers,
    IReadOnlyList<IOrderCompoundItemComponentStub> components
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order containing the discount item.
discountType
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of discount item to change.
products
Type: System.Collections.GenericIReadOnlyList IOrderProductItemStub
Order item products to which the discount item can be applied to.
modifiers
Type: System.Collections.GenericIReadOnlyList IOrderModifierItemStub
Order item modifiers to which the discount item can be applied to.
components
Type: System.Collections.GenericIReadOnlyList IOrderCompoundItemComponentStub
Compound item components to which the discount item can be applied to.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ChangeStreetName Method

IEditSessionChangeStreetName Method

Changes street's name.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeStreetName(
    string name,
    IStreetStub street
)

Parameters

name
Type: SystemString
Name of street
street
Type: Resto.Front.Api.Editors.StubsIStreetStub
Changing street
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateBanquet Method

IEditSessionCreateBanquet Method

Overload List
 | Name | Description
Public method | CreateBanquet(DateTime, IClientStub, IOrderStub, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
Public method | CreateBanquet(DateTime, IClientStub, IReadOnlyListITable, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateBanquet Method (DateTime, IClientStub, IOrderStub, Guid)

IEditSessionCreateBanquet Method (DateTime, IClientStub, IOrderStub, Guid)

Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewReserveStub CreateBanquet(
    DateTime estimatedStartTime,
    IClientStub client,
    IOrderStub order,
    Guid externalId = default
)

Parameters

estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned event, used to divide different events and remind staff to prepare table and ingredients.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who asked to reserve table for his event.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order used to form menu for coming event, specify serve sequence (via courses), prepay.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: INewReserveStub
See Also

Reference

IEditSession Interface
CreateBanquet Overload
Resto.Front.Api.Editors Namespace


IEditSession.CreateBanquet Method (DateTime, IClientStub, IReadOnlyList(ITable), Guid)

IEditSessionCreateBanquet Method (DateTime, IClientStub, IReadOnlyListITable, Guid)

Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewReserveStub CreateBanquet(
    DateTime estimatedStartTime,
    IClientStub client,
    IReadOnlyList<ITable> tables,
    Guid externalId = default
)

Parameters

estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned event, used to divide different events and remind staff to prepare table and ingredients.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who asked to reserve table for his event.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: INewReserveStub
See Also

Reference

IEditSession Interface
CreateBanquet Overload
Resto.Front.Api.Editors Namespace


IEditSession.CreateClient Method

IEditSessionCreateClient Method

Creates new client. The client must have a card number or at least one phone number.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewClientStub CreateClient(
    Guid id,
    string name,
    List<PhoneDto> phones,
    string cardNumber,
    DateTime? dateCreated
)

Parameters

id
Type: SystemGuid
Id of creating client
name
Type: SystemString
Name of client
phones
Type: System.Collections.GenericList PhoneDto
List of client phones. Cannot contain null values and more than one main phone (i.e. with property IsMain = true)
cardNumber
Type: SystemString
Discount card number or null if the client doesn't have discount card. If the discount card doesn't exist, consider creating one using CreateDiscountCard(String, String, IPriceCategory, IDiscountType).
dateCreated
Type: SystemNullable DateTime
Date when client was created. Must be not null, for actual reports by date created of clients.

Return Value

Type: INewClientStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateClientWithOrganizationDetails Method

IEditSessionCreateClientWithOrganizationDetails Method

Creates new client. The client must have orgatizations details info.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewClientStub CreateClientWithOrganizationDetails(
    Guid id,
    string name,
    string counteragentName,
    string counteragentCode,
    string counteragentAccountingReasonCode,
    string counteragentAddress,
    string counteragentRecipientCode,
    string fullAddressPostCode,
    string fullAddressCountry,
    string fullAddressRegion,
    string fullAddressCity,
    string fullAddressStreet,
    string fullAddressHouse,
    DateTime? dateCreated
)

Parameters

id
Type: SystemGuid
Id of creating client
name
Type: SystemString
Name of client
counteragentName
Type: SystemString
Client's organization name
counteragentCode
Type: SystemString
Client's organization code
counteragentAccountingReasonCode
Type: SystemString
Client's organization accounting reason code
counteragentAddress
Type: SystemString
Client's organization address
counteragentRecipientCode
Type: SystemString
Client's organization recipient code
fullAddressPostCode
Type: SystemString
Client's organization full address post code
fullAddressCountry
Type: SystemString
Client's organization full address country
fullAddressRegion
Type: SystemString
Client's organization full address region
fullAddressCity
Type: SystemString
Client's organization full address city
fullAddressStreet
Type: SystemString
Client's organization full address street
fullAddressHouse
Type: SystemString
Client's organization full address house
dateCreated
Type: SystemNullable DateTime
Date when client was created. Must be not null, for actual reports by date created of clients.

Return Value

Type: INewClientStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateDeliveryOrder Method

IEditSessionCreateDeliveryOrder Method

Overload List
 | Name | Description
Public method | CreateDeliveryOrder(NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Public method | CreateDeliveryOrder(Guid, Guid, NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean) | Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateDeliveryOrder Method (Nullable(Int32), DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, Nullable(TimeSpan), Boolean)

IEditSessionCreateDeliveryOrder Method (NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean)

Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewDeliveryOrderStub CreateDeliveryOrder(
    int? number,
    DateTime creationTime,
    string phone,
    AddressDto address,
    DateTime expectedDeliverTime,
    IOrderType type,
    IClientStub client,
    IUser deliveryOperator,
    TimeSpan? duration = null,
    bool hasIikoCardDiscounts = false
)

Parameters

number
Type: SystemNullable Int32
Delivery number
creationTime
Type: SystemDateTime
Creation time of the delivery. Cannot be greater than current time at the moment of processing action at front.
phone
Type: SystemString
Contact phone of the client.
address
Type: Resto.Front.Api.Data.BrdAddressDto
Address where order should be delivered for courier-service or null for self-service.
expectedDeliverTime
Type: SystemDateTime
Time when client wants the order to be delivered.
type
Type: Resto.Front.Api.Data.OrganizationIOrderType
Order type. Order service type should be DeliveryByCourier or DeliveryByClient.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who ordered the delivery
deliveryOperator
Type: Resto.Front.Api.Data.SecurityIUser
User who creates the order.
duration (Optional)
Type: SystemNullable TimeSpan
Calculated delivery duration (accurate within minutes) or null to use default predefined duration.
hasIikoCardDiscounts (Optional)
Type: SystemBoolean
Order has fixed iikoCard discounts.

Return Value

Type: INewDeliveryOrderStub
See Also

Reference

IEditSession Interface
CreateDeliveryOrder Overload
Resto.Front.Api.Editors Namespace


IEditSession.CreateDeliveryOrder Method (Guid, Guid, Nullable(Int32), DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, Nullable(TimeSpan), Boolean)

IEditSessionCreateDeliveryOrder Method (Guid, Guid, NullableInt32, DateTime, String, AddressDto, DateTime, IOrderType, IClientStub, IUser, NullableTimeSpan, Boolean)

Creates new delivery order. User must have rights to edit delivery orders. Specify address for courier-service; leave it null for self-service.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewDeliveryOrderStub CreateDeliveryOrder(
    Guid id,
    Guid deliveryId,
    int? number,
    DateTime creationTime,
    string phone,
    AddressDto address,
    DateTime expectedDeliverTime,
    IOrderType type,
    IClientStub client,
    IUser deliveryOperator,
    TimeSpan? duration = null,
    bool hasIikoCardDiscounts = false
)

Parameters

id
Type: SystemGuid
Unique identifier of the new order. MUST be unique for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid().
deliveryId
Type: SystemGuid
Id of the new delivery
number
Type: SystemNullable Int32
Delivery number
creationTime
Type: SystemDateTime
Creation time of delivery. Cannot be greater than current time at the moment of processing action at front.
phone
Type: SystemString
Contact phone of the client.
address
Type: Resto.Front.Api.Data.BrdAddressDto
Address where order should be delivered for courier-service or null for self-service.
expectedDeliverTime
Type: SystemDateTime
Time when client wants the order to be delivered.
type
Type: Resto.Front.Api.Data.OrganizationIOrderType
Order type. Order service type should be DeliveryByCourier or DeliveryByClient.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Delivery client
deliveryOperator
Type: Resto.Front.Api.Data.SecurityIUser
User who creates the order.
duration (Optional)
Type: SystemNullable TimeSpan
Calculated delivery duration (accurate within minutes) or null to use default predefined duration.
hasIikoCardDiscounts (Optional)
Type: SystemBoolean
Order has fixed iikoCard discounts.

Return Value

Type: INewDeliveryOrderStub
See Also

Reference

IEditSession Interface
CreateDeliveryOrder Overload
Resto.Front.Api.Editors Namespace


IEditSession.CreateJournalEvent Method

IEditSessionCreateJournalEvent Method

Creates new journal event.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewJournalEventStub CreateJournalEvent(
    string sender,
    Severity severity,
    string eventType,
    DateTime? dateTime = null
)

Parameters

sender
Type: SystemString
Sender of new journal event. Max length - 255 chars.
severity
Type: Resto.Front.Api.Data.JournalEventsSeverity
Severity of new journal event.
eventType
Type: SystemString
Event type of new journal event. Max length - 255 chars.
dateTime (Optional)
Type: SystemNullable DateTime
Date and time of new journal event. You can leave it unspecified to use current date and time.

Return Value

Type: INewJournalEventStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateOrder Method

IEditSessionCreateOrder Method

Creates new order on specified table. User must have rights to create orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderStub CreateOrder(
    IReadOnlyList<ITable> tables,
    IUser waiter = null
)

Parameters

tables
Type: System.Collections.GenericIReadOnlyList ITable
Tables on which order will be created. If tables is null or empty, then order will be created on the default table (depending on select iikoFront mode).
waiter (Optional)
Type: Resto.Front.Api.Data.SecurityIUser
Waiter for new order. If null, user from credentials will be used.

Return Value

Type: INewOrderStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateReserve Method

IEditSessionCreateReserve Method

Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewReserveStub CreateReserve(
    DateTime estimatedStartTime,
    IClientStub client,
    IReadOnlyList<ITable> tables,
    Guid externalId = default
)

Parameters

estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned visit, used to divide different visits and remind staff to prepare table.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who asked to reserve table for him.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: INewReserveStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateStreet Method

IEditSessionCreateStreet Method

Overload List
 | Name | Description
Public method | CreateStreet(String) | Creates new street.
Public method | CreateStreet(Guid, String, ICity) | Creates new street.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.CreateStreet Method (String)

IEditSessionCreateStreet Method (String)

Creates new street.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewStreetStub CreateStreet(
    string name
)

Parameters

name
Type: SystemString
Name of creating street

Return Value

Type: INewStreetStub
See Also

Reference

IEditSession Interface
CreateStreet Overload
Resto.Front.Api.Editors Namespace


IEditSession.CreateStreet Method (Guid, String, ICity)

IEditSessionCreateStreet Method (Guid, String, ICity)

Creates new street.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewStreetStub CreateStreet(
    Guid id,
    string name,
    ICity city
)

Parameters

id
Type: SystemGuid
Id of creating street
name
Type: SystemString
Name of creating street
city
Type: Resto.Front.Api.Data.BrdICity
City of creating street

Return Value

Type: INewStreetStub
See Also

Reference

IEditSession Interface
CreateStreet Overload
Resto.Front.Api.Editors Namespace


IEditSession.DeleteDiscount Method

IEditSessionDeleteDiscount Method

Removes discount of known type from existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteDiscount(
    IDiscountItem discountItem,
    IOrderStub order
)

Parameters

discountItem
Type: Resto.Front.Api.Data.OrdersIDiscountItem
Discount to be removed.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to delete discount from.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteExternalFiscalizedPaymentItem Method

IEditSessionDeleteExternalFiscalizedPaymentItem Method

Delete existing externally fiscalized payment item from order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteExternalFiscalizedPaymentItem(
    IPaymentItem paymentItem,
    IOrderStub order
)

Parameters

paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Externally fiscalized payment item to be deleted.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order from which payment item will be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteExternalPaymentItem Method

IEditSessionDeleteExternalPaymentItem Method

Delete existing external payment item from order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteExternalPaymentItem(
    IPaymentItem paymentItem,
    IOrderStub order
)

Parameters

paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
External payment item to be deleted.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order from which payment item will be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderCombo Method

IEditSessionDeleteOrderCombo Method

Delete order combo item.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderCombo(
    IOrderComboStub combo,
    IOrderStub order
)

Parameters

combo
Type: Resto.Front.Api.Editors.StubsIOrderComboStub
Combo which will be deleted.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order from which combo will be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderExternalData Method

IEditSessionDeleteOrderExternalData Method

Deletes external data from the order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderExternalData(
    string key,
    IOrderStub order
)

Parameters

key
Type: SystemString
External data key. Should be the same as it was used with AddOrderExternalData(String, String, IOrderStub)
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to delete external data from.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderGuest Method

IEditSessionDeleteOrderGuest Method

Deletes guest without any products from order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderGuest(
    IOrderStub order,
    IOrderGuestItem guest
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to delete guest from.
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderItem Method

IEditSessionDeleteOrderItem Method

Deletes order item from order that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderItem(
    IOrderStub order,
    IOrderRootItem orderItem
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the item to be deleted.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Order item to be deleted. Item must not be printed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderItemComment Method

IEditSessionDeleteOrderItemComment Method

Deletes product order item's comment.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderItemComment(
    IOrderStub order,
    IOrderCookingItemStub cookingItem
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains product order item which comment will be changed.
cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Product order item which comment will be changed. Product order item should not been printed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderModifierItem Method

IEditSessionDeleteOrderModifierItem Method

Overload List
 | Name | Description
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderCompoundItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Public method | DeleteOrderModifierItem(IOrderStub, IOrderProductItemStub, IOrderModifierItem) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderModifierItem Method (IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItem)

IEditSessionDeleteOrderModifierItem Method (IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItem)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderModifierItem(
    IOrderStub order,
    IOrderCompoundItemComponentStub orderItem,
    IOrderModifierItem modifier
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
See Also

Reference

IEditSession Interface
DeleteOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderModifierItem Method (IOrderStub, IOrderCompoundItemStub, IOrderModifierItem)

IEditSessionDeleteOrderModifierItem Method (IOrderStub, IOrderCompoundItemStub, IOrderModifierItem)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderModifierItem(
    IOrderStub order,
    IOrderCompoundItemStub orderItem,
    IOrderModifierItem modifier
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
See Also

Reference

IEditSession Interface
DeleteOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrderModifierItem Method (IOrderStub, IOrderProductItemStub, IOrderModifierItem)

IEditSessionDeleteOrderModifierItem Method (IOrderStub, IOrderProductItemStub, IOrderModifierItem)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrderModifierItem(
    IOrderStub order,
    IOrderProductItemStub orderItem,
    IOrderModifierItem modifier
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
See Also

Reference

IEditSession Interface
DeleteOrderModifierItem Overload
Resto.Front.Api.Editors Namespace


IEditSession.DeleteOrRestoreStreet Method

IEditSessionDeleteOrRestoreStreet Method

Deletes street.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeleteOrRestoreStreet(
    bool delete,
    IStreetStub street
)

Parameters

delete
Type: SystemBoolean
Delete or restore street flag. true - to delete, false - to restore.
street
Type: Resto.Front.Api.Editors.StubsIStreetStub
Changing street
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeletePaymentItem Method

IEditSessionDeletePaymentItem Method

Delete existing payment item from order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeletePaymentItem(
    IPaymentItem paymentItem,
    IOrderStub order
)

Parameters

paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be deleted.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order from which payment item will be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeletePreliminaryPaymentItem Method

IEditSessionDeletePreliminaryPaymentItem Method

Delete existing preliminary payment item from order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeletePreliminaryPaymentItem(
    IPaymentItem paymentItem,
    IDeliveryOrderStub order
)

Parameters

paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be deleted.
order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Delivery order from which payment item will be deleted.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeletePrintedOrderItems Method

IEditSessionDeletePrintedOrderItems Method

Deletes order items that is already printed. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeletePrintedOrderItems(
    string comment,
    WriteoffOptions writeoffOptions,
    IOrderStub order,
    IReadOnlyList<IOrderRootItemStub> orderItems
)

Parameters

comment
Type: SystemString
Comment to the charge-off. Max length - 255 chars.
writeoffOptions
Type: Resto.Front.Api.Data.OrdersWriteoffOptions
Object that describes how item should be removed and charged-off.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the items to be removed.
orderItems
Type: System.Collections.GenericIReadOnlyList IOrderRootItemStub
Order items to be removed. Items must be printed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.DeletePrintedOrderModifierItem Method

IEditSessionDeletePrintedOrderModifierItem Method

Deletes order item modifier that is already printed. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void DeletePrintedOrderModifierItem(
    string comment,
    WriteoffOptions writeoffOptions,
    IOrderStub order,
    IOrderProductItemStub orderItemProduct,
    IOrderModifierItemStub orderModifierItem
)

Parameters

comment
Type: SystemString
Comment to the charge-off. Max length - 255 chars.
writeoffOptions
Type: Resto.Front.Api.Data.OrdersWriteoffOptions
Object that describes how item should be removed and charged-off.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains the item to be removed. Item must not be printed.
orderItemProduct
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item that contains the modifier to be removed.Item must be prin /ted.
orderModifierItem
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Order item modifier to be removed. Modifier must be printed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.GroupOrderCookingItems Method

IEditSessionGroupOrderCookingItems Method

Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void GroupOrderCookingItems(
    IReadOnlyList<IOrderCookingItemStub> cookingItems,
    IOrderStub order
)

Parameters

cookingItems
Type: System.Collections.GenericIReadOnlyList IOrderCookingItemStub
Order item products to be cooked together.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which products will be combined into mix group.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.MarkOrderAsTab Method

IEditSessionMarkOrderAsTab Method

Marks the order as tab and assignes tab name.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void MarkOrderAsTab(
    string tabName,
    IOrderStub order
)

Parameters

tabName
Type: SystemString
Tab name to be assigned to the order.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to be marked as tab.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.MoveOrderItemToAnotherGuest Method

IEditSessionMoveOrderItemToAnotherGuest Method

Moves product item between guests of the same order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void MoveOrderItemToAnotherGuest(
    IOrderRootItemStub product,
    IOrderGuestItemStub destinationGuest,
    IOrderStub order
)

Parameters

product
Type: Resto.Front.Api.Editors.StubsIOrderRootItemStub
Product item to be moved.
destinationGuest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest the product item will be assigned to.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which contains the product.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.MoveOrderItemToAnotherOrder Method

IEditSessionMoveOrderItemToAnotherOrder Method

Moves product item between orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void MoveOrderItemToAnotherOrder(
    IOrderRootItemStub orderItem,
    IOrderStub sourceOrder,
    IOrderGuestItemStub destinationGuest,
    IOrderStub destinationOrder
)

Parameters

orderItem
Type: Resto.Front.Api.Editors.StubsIOrderRootItemStub
Product item to be moved.
sourceOrder
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which currently contains the product.
destinationGuest
Type: Resto.Front.Api.Editors.StubsIOrderGuestItemStub
Guest the product item will be assigned to.
destinationOrder
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to move to.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.OverrideVatInclusionForOrder Method

IEditSessionOverrideVatInclusionForOrder Method

Overrides default VAT inclusion settings for items of the specified order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void OverrideVatInclusionForOrder(
    IOrderStub order,
    bool? isVatIncluded = null
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains items to override vat inclusion.
isVatIncluded (Optional)
Type: SystemNullable Boolean
Allows to override default VAT inclusion setting. Set true if VAT is included into prices or false if VAT should be added on top of the prices. Set null to use default VAT settings.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.RecoverCorruptedReserve Method

IEditSessionRecoverCorruptedReserve Method

Recovers banquet which is bound to non-existent order. Normally such cases should never occur, but due to entities storage implementation details sometimes banquet may loose its order. Note that new empty order will be created from scratch.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderStub RecoverCorruptedReserve(
    IReserveStub reserve
)

Parameters

reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Banquet to recover.

Return Value

Type: INewOrderStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.RenameOrderGuest Method

IEditSessionRenameOrderGuest Method

Renames order's guest.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void RenameOrderGuest(
    Guid id,
    string newName,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the guest to be renamed.
newName
Type: SystemString
New name of the guest.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to rename guest in.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ReopenReserve Method

IEditSessionReopenReserve Method

Reopens previously closed or canceled reserve.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ReopenReserve(
    IReserveStub reserve
)

Parameters

reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to reopen.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ResetIsPrintedDeliveryBillActual Method

IEditSessionResetIsPrintedDeliveryBillActual Method

Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ResetIsPrintedDeliveryBillActual(
    IDeliveryOrderStub order
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to reset whether its bill is considered to be actual.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ResetPriceCategory Method

IEditSessionResetPriceCategory Method

Resets price category of the order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ResetPriceCategory(
    IOrderStub order
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to reset price category.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.ServeOrderCookingItem Method

IEditSessionServeOrderCookingItem Method

Mark order item product as served.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ServeOrderCookingItem(
    IOrderCookingItemStub cookingItem,
    IOrderStub order
)

Parameters

cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Order item product to mark as served. This item should be printed, but not served yet.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which product will be served.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetCompoundItemComponentCustomName Method

IEditSessionSetCompoundItemComponentCustomName Method

Sets the custom name of the compound component. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetCompoundItemComponentCustomName(
    string customName,
    IOrderStub order,
    IOrderCompoundItemComponentStub compoundComponent
)

Parameters

customName
Type: SystemString
New custom name of the compound component or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing compound component.
compoundComponent
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Compound component which custom name will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetDeliveryCustomerAuthorizedInIikoBiz Method

IEditSessionSetDeliveryCustomerAuthorizedInIikoBiz Method

Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetDeliveryCustomerAuthorizedInIikoBiz(
    IDeliveryOrderStub order
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetDeliveryDelivered Method

IEditSessionSetDeliveryDelivered Method

Change delivery status to delivered.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetDeliveryDelivered(
    IDeliveryOrderStub order
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change status.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetDeliveryUndelivered Method

IEditSessionSetDeliveryUndelivered Method

Change delivery status to OnWay from status delivered.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetDeliveryUndelivered(
    IDeliveryOrderStub order
)

Parameters

order
Type: Resto.Front.Api.Editors.StubsIDeliveryOrderStub
Order to change status.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetJournalEventAttribute Method

IEditSessionSetJournalEventAttribute Method

Sets attribute for journal event.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetJournalEventAttribute(
    string attributeName,
    string value,
    INewJournalEventStub journalEvent
)

Parameters

attributeName
Type: SystemString
Attribute name. Max length - 255 chars.
value
Type: SystemString
Attribute value. Max length - 1000 chars.
journalEvent
Type: Resto.Front.Api.Editors.StubsINewJournalEventStub
Journal event.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetOpenPrice Method

IEditSessionSetOpenPrice Method

Changes order item open price.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetOpenPrice(
    decimal openPrice,
    IOrderProductItemStub productOrderItem,
    IOrderStub sourceOrder
)

Parameters

openPrice
Type: SystemDecimal
New open price value.
productOrderItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item.
sourceOrder
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which currently contains the product.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetOrderModifierItemCustomName Method

IEditSessionSetOrderModifierItemCustomName Method

Overload List
 | Name | Description
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
Public method | SetOrderModifierItemCustomName(String, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub) | Sets the custom name of the product item modifier. User must have rights to edit orders.
Top
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetOrderModifierItemCustomName Method (String, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub)

IEditSessionSetOrderModifierItemCustomName Method (String, IOrderStub, IOrderCompoundItemComponentStub, IOrderModifierItemStub)

Sets the custom name of the compound component modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetOrderModifierItemCustomName(
    string customName,
    IOrderStub order,
    IOrderCompoundItemComponentStub compoundComponent,
    IOrderModifierItemStub modifier
)

Parameters

customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
compoundComponent
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemComponentStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which custom name will be changed.
See Also

Reference

IEditSession Interface
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Editors Namespace


IEditSession.SetOrderModifierItemCustomName Method (String, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub)

IEditSessionSetOrderModifierItemCustomName Method (String, IOrderStub, IOrderCompoundItemStub, IOrderModifierItemStub)

Sets the custom name of the compound item common modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetOrderModifierItemCustomName(
    string customName,
    IOrderStub order,
    IOrderCompoundItemStub orderItem,
    IOrderModifierItemStub modifier
)

Parameters

customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderCompoundItemStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which custom name will be changed.
See Also

Reference

IEditSession Interface
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Editors Namespace


IEditSession.SetOrderModifierItemCustomName Method (String, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub)

IEditSessionSetOrderModifierItemCustomName Method (String, IOrderStub, IOrderProductItemStub, IOrderModifierItemStub)

Sets the custom name of the product item modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetOrderModifierItemCustomName(
    string customName,
    IOrderStub order,
    IOrderProductItemStub orderItem,
    IOrderModifierItemStub modifier
)

Parameters

customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Editors.StubsIOrderModifierItemStub
Modifier which custom name will be changed.
See Also

Reference

IEditSession Interface
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Editors Namespace


IEditSession.SetOrderType Method

IEditSessionSetOrderType Method

Sets order type for order.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetOrderType(
    IOrderType type,
    IOrderStub order
)

Parameters

type
Type: Resto.Front.Api.Data.OrganizationIOrderType
Order type to set
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Existing order
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetProductItemCustomName Method

IEditSessionSetProductItemCustomName Method

Sets the custom name of the product item. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetProductItemCustomName(
    string customName,
    IOrderStub order,
    IOrderProductItemStub orderItem
)

Parameters

customName
Type: SystemString
New custom name of the product item or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing product item.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderProductItemStub
Product item which custom name will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetServiceItemCustomName Method

IEditSessionSetServiceItemCustomName Method

Sets the custom name of the service item. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetServiceItemCustomName(
    string customName,
    IOrderStub order,
    IOrderServiceItemStub orderItem
)

Parameters

customName
Type: SystemString
New custom name of the service item or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing service item.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderServiceItemStub
Service item which custom name will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SetServiceItemPeriodCustomName Method

IEditSessionSetServiceItemPeriodCustomName Method

Sets the custom name of the service period. User must have rights to edit orders.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void SetServiceItemPeriodCustomName(
    string customName,
    IOrderStub order,
    IOrderServiceItemStub orderItem,
    IOrderServiceItemPeriodStub period
)

Parameters

customName
Type: SystemString
New custom name of the service period or null to use default name.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order that contains element with changing service period.
orderItem
Type: Resto.Front.Api.Editors.StubsIOrderServiceItemStub
Service item with changing period.
period
Type: Resto.Front.Api.Editors.StubsIOrderServiceItemPeriodStub
Service period which custom name will be changed.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.SplitOrderCookingItem Method

IEditSessionSplitOrderCookingItem Method

Cut off specified amount from product to new one.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderCookingItemStub SplitOrderCookingItem(
    decimal amount,
    IOrderStub order,
    IOrderCookingItemStub cookingItem
)

Parameters

amount
Type: SystemDecimal
Amount to cut off. Source cooking item's amount will be reduced by this amount, resultant item will get this amount.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which contains the product.
cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Product to split.

Return Value

Type: INewOrderCookingItemStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.StartBanquet Method

IEditSessionStartBanquet Method

Transits banquet to the started status.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void StartBanquet(
    IReserve reserve,
    IUser waiter
)

Parameters

reserve
Type: Resto.Front.Api.Data.BrdIReserve
Banquet to start. Banquet must have an order binding, otherwise call BindReserveToOrder(IReserveStub, IOrderStub) first.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
Waiter who will serve the banquet.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.UngroupOrderCookingItems Method

IEditSessionUngroupOrderCookingItems Method

Separates the order item products from mix group so that they will be cooked independently.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void UngroupOrderCookingItems(
    IReadOnlyList<IOrderCookingItemStub> cookingItems,
    IOrderStub order
)

Parameters

cookingItems
Type: System.Collections.GenericIReadOnlyList IOrderCookingItemStub
Order item products to be separated from mix group.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which products will be separated from mix group.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.UnserveOrderCookingItem Method

IEditSessionUnserveOrderCookingItem Method

Mark order item product as unserved.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void UnserveOrderCookingItem(
    IOrderCookingItemStub cookingItem,
    IOrderStub order
)

Parameters

cookingItem
Type: Resto.Front.Api.Editors.StubsIOrderCookingItemStub
Order item product to mark as unserved. This item should be served.
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order which product will be unserved.
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


IEditSession.UpdateOrderComboItems Method

IEditSessionUpdateOrderComboItems Method

Update existing order combo items. Order must contain new combo items.

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
INewOrderComboStub UpdateOrderComboItems(
    Guid id,
    IReadOnlyDictionary<Guid, IOrderCookingItemStub> comboItems,
    IOrderStub order
)

Parameters

id
Type: SystemGuid
Unique identifier of the existing combo.
comboItems
Type: System.Collections.GenericIReadOnlyDictionary Guid, IOrderCookingItemStub
Combo items dictionary. Key - combo group identifier, Value - item id (must be contained in order).
order
Type: Resto.Front.Api.Editors.StubsIOrderStub
Order to which combo will be added.

Return Value

Type: INewOrderComboStub
See Also

Reference

IEditSession Interface
Resto.Front.Api.Editors Namespace


ISubmittedEntities Interface

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface ISubmittedEntities

The ISubmittedEntities type exposes the following members.

Methods
 | Name | Description
Public method | Get(INewClientStub) |
Public method | Get(INewDeliveryOrderStub) |
Public method | Get(INewOrderComboStub) |
Public method | Get(INewOrderCompoundItemComponentStub) |
Public method | Get(INewOrderCompoundItemStub) |
Public method | Get(INewOrderCookingItemStub) |
Public method | Get(INewOrderGuestItemStub) |
Public method | Get(INewOrderModifierItemStub) |
Public method | Get(INewOrderProductItemStub) |
Public method | Get(INewOrderRootItemStub) |
Public method | Get(INewOrderServiceItemPeriodStub) |
Public method | Get(INewOrderServiceItemStub) |
Public method | Get(INewOrderStub) |
Public method | Get(INewPaymentItemStub) |
Public method | Get(INewReserveStub) |
Public method | Get(INewStreetStub) |
Public method | GetRevisionT |
Top
See Also

Reference

Resto.Front.Api.Editors Namespace


ISubmittedEntities Methods

The ISubmittedEntities type exposes the following members.

Methods
 | Name | Description
Public method | Get(INewClientStub) |
Public method | Get(INewDeliveryOrderStub) |
Public method | Get(INewOrderComboStub) |
Public method | Get(INewOrderCompoundItemComponentStub) |
Public method | Get(INewOrderCompoundItemStub) |
Public method | Get(INewOrderCookingItemStub) |
Public method | Get(INewOrderGuestItemStub) |
Public method | Get(INewOrderModifierItemStub) |
Public method | Get(INewOrderProductItemStub) |
Public method | Get(INewOrderRootItemStub) |
Public method | Get(INewOrderServiceItemPeriodStub) |
Public method | Get(INewOrderServiceItemStub) |
Public method | Get(INewOrderStub) |
Public method | Get(INewPaymentItemStub) |
Public method | Get(INewReserveStub) |
Public method | Get(INewStreetStub) |
Public method | GetRevisionT |
Top
See Also

Reference

ISubmittedEntities Interface
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method

ISubmittedEntitiesGet Method

Overload List
 | Name | Description
Public method | Get(INewClientStub) |
Public method | Get(INewDeliveryOrderStub) |
Public method | Get(INewOrderComboStub) |
Public method | Get(INewOrderCompoundItemComponentStub) |
Public method | Get(INewOrderCompoundItemStub) |
Public method | Get(INewOrderCookingItemStub) |
Public method | Get(INewOrderGuestItemStub) |
Public method | Get(INewOrderModifierItemStub) |
Public method | Get(INewOrderProductItemStub) |
Public method | Get(INewOrderRootItemStub) |
Public method | Get(INewOrderServiceItemPeriodStub) |
Public method | Get(INewOrderServiceItemStub) |
Public method | Get(INewOrderStub) |
Public method | Get(INewPaymentItemStub) |
Public method | Get(INewReserveStub) |
Public method | Get(INewStreetStub) |
Top
See Also

Reference

ISubmittedEntities Interface
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewClientStub)

ISubmittedEntitiesGet Method (INewClientStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IClient Get(
    INewClientStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewClientStub

Return Value

Type: IClient
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewDeliveryOrderStub)

ISubmittedEntitiesGet Method (INewDeliveryOrderStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IDeliveryOrder Get(
    INewDeliveryOrderStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewDeliveryOrderStub

Return Value

Type: IDeliveryOrder
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderComboStub)

ISubmittedEntitiesGet Method (INewOrderComboStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCombo Get(
    INewOrderComboStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderComboStub

Return Value

Type: IOrderCombo
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderCompoundItemComponentStub)

ISubmittedEntitiesGet Method (INewOrderCompoundItemComponentStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCompoundItemComponent Get(
    INewOrderCompoundItemComponentStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderCompoundItemComponentStub

Return Value

Type: IOrderCompoundItemComponent
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderCompoundItemStub)

ISubmittedEntitiesGet Method (INewOrderCompoundItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCompoundItem Get(
    INewOrderCompoundItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderCompoundItemStub

Return Value

Type: IOrderCompoundItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderCookingItemStub)

ISubmittedEntitiesGet Method (INewOrderCookingItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderCookingItem Get(
    INewOrderCookingItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderCookingItemStub

Return Value

Type: IOrderCookingItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderGuestItemStub)

ISubmittedEntitiesGet Method (INewOrderGuestItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderGuestItem Get(
    INewOrderGuestItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderGuestItemStub

Return Value

Type: IOrderGuestItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderModifierItemStub)

ISubmittedEntitiesGet Method (INewOrderModifierItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderModifierItem Get(
    INewOrderModifierItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderModifierItemStub

Return Value

Type: IOrderModifierItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderProductItemStub)

ISubmittedEntitiesGet Method (INewOrderProductItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderProductItem Get(
    INewOrderProductItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderProductItemStub

Return Value

Type: IOrderProductItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderRootItemStub)

ISubmittedEntitiesGet Method (INewOrderRootItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderRootItem Get(
    INewOrderRootItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderRootItemStub

Return Value

Type: IOrderRootItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderServiceItemPeriodStub)

ISubmittedEntitiesGet Method (INewOrderServiceItemPeriodStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderServiceItemPeriod Get(
    INewOrderServiceItemPeriodStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderServiceItemPeriodStub

Return Value

Type: IOrderServiceItemPeriod
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderServiceItemStub)

ISubmittedEntitiesGet Method (INewOrderServiceItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrderServiceItem Get(
    INewOrderServiceItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderServiceItemStub

Return Value

Type: IOrderServiceItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewOrderStub)

ISubmittedEntitiesGet Method (INewOrderStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IOrder Get(
    INewOrderStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewOrderStub

Return Value

Type: IOrder
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewPaymentItemStub)

ISubmittedEntitiesGet Method (INewPaymentItemStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IPaymentItem Get(
    INewPaymentItemStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewPaymentItemStub

Return Value

Type: IPaymentItem
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewReserveStub)

ISubmittedEntitiesGet Method (INewReserveStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReserve Get(
    INewReserveStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewReserveStub

Return Value

Type: IReserve
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.Get Method (INewStreetStub)

ISubmittedEntitiesGet Method (INewStreetStub)

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IStreet Get(
    INewStreetStub entityStub
)

Parameters

entityStub
Type: Resto.Front.Api.Editors.StubsINewStreetStub

Return Value

Type: IStreet
See Also

Reference

ISubmittedEntities Interface
Get Overload
Resto.Front.Api.Editors Namespace


ISubmittedEntities.GetRevision(T) Method

ISubmittedEntitiesGetRevisionT Method

Namespace: Resto.Front.Api.Editors
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int GetRevision<T>(
    Guid id
)
where T : IEntity

Parameters

id
Type: SystemGuid

Type Parameters

T

Return Value

Type: Int32
See Also

Reference

ISubmittedEntities Interface
Resto.Front.Api.Editors Namespace


Resto.Front.Api.Editors.Stubs Namespace

Classes
 | Class | Description
Public class | NewClientStub |
Public class | NewDeliveryOrderStub |
Public class | NewEntityStub |
Public class | NewJournalEventStub |
Public class | NewOrderComboStub |
Public class | NewOrderCompoundItemComponentStub |
Public class | NewOrderCompoundItemStub |
Public class | NewOrderCookingItemStub |
Public class | NewOrderGuestItemStub |
Public class | NewOrderModifierItemStub |
Public class | NewOrderProductItemStub |
Public class | NewOrderRootItemStub |
Public class | NewOrderServiceItemPeriodStub |
Public class | NewOrderServiceItemStub |
Public class | NewOrderStub |
Public class | NewPaymentItemStub |
Public class | NewReserveStub |
Public class | NewStreetStub |
Interfaces
 | Interface | Description
Public interface | IClientStub |
Public interface | IDeliveryOrderStub |
Public interface | INewClientStub |
Public interface | INewDeliveryOrderStub |
Public interface | INewEntityStub |
Public interface | INewJournalEventStub |
Public interface | INewOrderComboStub |
Public interface | INewOrderCompoundItemComponentStub |
Public interface | INewOrderCompoundItemStub |
Public interface | INewOrderCookingItemStub |
Public interface | INewOrderGuestItemStub |
Public interface | INewOrderModifierItemStub |
Public interface | INewOrderProductItemStub |
Public interface | INewOrderRootItemStub |
Public interface | INewOrderServiceItemPeriodStub |
Public interface | INewOrderServiceItemStub |
Public interface | INewOrderStub |
Public interface | INewPaymentItemStub |
Public interface | INewReserveStub |
Public interface | INewStreetStub |
Public interface | IOrderComboStub |
Public interface | IOrderCompoundItemComponentStub |
Public interface | IOrderCompoundItemStub |
Public interface | IOrderCookingItemStub |
Public interface | IOrderGuestItemStub |
Public interface | IOrderModifierItemStub |
Public interface | IOrderProductItemStub |
Public interface | IOrderRootItemStub |
Public interface | IOrderServiceItemPeriodStub |
Public interface | IOrderServiceItemStub |
Public interface | IOrderStub |
Public interface | IPaymentItemStub |
Public interface | IReserveStub |
Public interface | IStreetStub |


IClientStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IClientStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IDeliveryOrderStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IDeliveryOrderStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewClientStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewClientStub : INewEntityStub,
    IClientStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewDeliveryOrderStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewDeliveryOrderStub : INewOrderStub,
    INewEntityStub, IOrderStub, IDeliveryOrderStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewEntityStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewEntityStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewJournalEventStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewJournalEventStub : INewEntityStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderComboStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderComboStub : INewEntityStub,
    IOrderComboStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderCompoundItemComponentStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderCompoundItemComponentStub : INewEntityStub,
    IOrderCompoundItemComponentStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderCompoundItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderCompoundItemStub : INewOrderCookingItemStub,
    INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub, IOrderCookingItemStub, IOrderCompoundItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderCookingItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderCookingItemStub : INewOrderRootItemStub,
    INewEntityStub, IOrderRootItemStub, IOrderCookingItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderGuestItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderGuestItemStub : INewEntityStub,
    IOrderGuestItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderModifierItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderModifierItemStub : INewEntityStub,
    IOrderModifierItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderProductItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderProductItemStub : INewOrderCookingItemStub,
    INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub, IOrderCookingItemStub, IOrderProductItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderRootItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderRootItemStub : INewEntityStub,
    IOrderRootItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderServiceItemPeriodStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderServiceItemPeriodStub : INewEntityStub,
    IOrderServiceItemPeriodStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderServiceItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderServiceItemStub : INewOrderRootItemStub,
    INewEntityStub, IOrderRootItemStub, IOrderServiceItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewOrderStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewOrderStub : INewEntityStub,
    IOrderStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewPaymentItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewPaymentItemStub : INewEntityStub,
    IPaymentItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewReserveStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewReserveStub : INewEntityStub,
    IReserveStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


INewStreetStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INewStreetStub : INewEntityStub,
    IStreetStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderComboStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderComboStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderCompoundItemComponentStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCompoundItemComponentStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderCompoundItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCompoundItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderCookingItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderCookingItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderGuestItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderGuestItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderModifierItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderModifierItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderProductItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderProductItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderRootItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderRootItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderServiceItemPeriodStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderServiceItemPeriodStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderServiceItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderServiceItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IOrderStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IOrderStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IPaymentItemStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IPaymentItemStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IReserveStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IReserveStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


IStreetStub Interface

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IStreetStub
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewClientStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewClientStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewClientStub : NewEntityStub,
    INewClientStub, INewEntityStub, IClientStub

The NewClientStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewClientStub | Initializes a new instance of the NewClientStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewClientStub Constructor

Initializes a new instance of the NewClientStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewClientStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewClientStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewClientStub Properties

The NewClientStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewClientStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewClientStub Methods

The NewClientStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewClientStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewDeliveryOrderStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewDeliveryOrderStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewDeliveryOrderStub : NewEntityStub,
    INewDeliveryOrderStub, INewOrderStub, INewEntityStub, IOrderStub, IDeliveryOrderStub

The NewDeliveryOrderStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewDeliveryOrderStub | Initializes a new instance of the NewDeliveryOrderStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewDeliveryOrderStub Constructor

Initializes a new instance of the NewDeliveryOrderStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewDeliveryOrderStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewDeliveryOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewDeliveryOrderStub Properties

The NewDeliveryOrderStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewDeliveryOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewDeliveryOrderStub Methods

The NewDeliveryOrderStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewDeliveryOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewEntityStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
More...

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public abstract class NewEntityStub : INewEntityStub

The NewEntityStub type exposes the following members.

Constructors
 | Name | Description
Protected method | NewEntityStub | Initializes a new instance of the NewEntityStub class
Top
Properties
 | Name | Description
Public property | ActionNumber |
Public property | SessionNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace
Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewClientStub
Resto.Front.Api.Editors.StubsNewDeliveryOrderStub
Resto.Front.Api.Editors.StubsNewJournalEventStub
Resto.Front.Api.Editors.StubsNewOrderComboStub
Resto.Front.Api.Editors.StubsNewOrderCompoundItemComponentStub
Resto.Front.Api.Editors.StubsNewOrderCompoundItemStub
Resto.Front.Api.Editors.StubsNewOrderCookingItemStub
Resto.Front.Api.Editors.StubsNewOrderGuestItemStub
Resto.Front.Api.Editors.StubsNewOrderModifierItemStub
Resto.Front.Api.Editors.StubsNewOrderProductItemStub
Resto.Front.Api.Editors.StubsNewOrderRootItemStub
Resto.Front.Api.Editors.StubsNewOrderServiceItemPeriodStub
Resto.Front.Api.Editors.StubsNewOrderServiceItemStub
Resto.Front.Api.Editors.StubsNewOrderStub
Resto.Front.Api.Editors.StubsNewPaymentItemStub
Resto.Front.Api.Editors.StubsNewReserveStub
Resto.Front.Api.Editors.StubsNewStreetStub


NewEntityStub Constructor

Initializes a new instance of the NewEntityStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected NewEntityStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewEntityStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewEntityStub Properties

The NewEntityStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber |
Public property | SessionNumber |
Top
See Also

Reference

NewEntityStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewEntityStub.ActionNumber Property

NewEntityStubActionNumber Property

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int ActionNumber { get; }

Property Value

Type: Int32
See Also

Reference

NewEntityStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewEntityStub.SessionNumber Property

NewEntityStubSessionNumber Property

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public int SessionNumber { get; }

Property Value

Type: Int32
See Also

Reference

NewEntityStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewEntityStub Methods

The NewEntityStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewEntityStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewJournalEventStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewJournalEventStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewJournalEventStub : NewEntityStub,
    INewJournalEventStub, INewEntityStub

The NewJournalEventStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewJournalEventStub | Initializes a new instance of the NewJournalEventStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewJournalEventStub Constructor

Initializes a new instance of the NewJournalEventStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewJournalEventStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewJournalEventStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewJournalEventStub Properties

The NewJournalEventStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewJournalEventStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewJournalEventStub Methods

The NewJournalEventStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewJournalEventStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderComboStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderComboStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderComboStub : NewEntityStub,
    INewOrderComboStub, INewEntityStub, IOrderComboStub

The NewOrderComboStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderComboStub | Initializes a new instance of the NewOrderComboStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderComboStub Constructor

Initializes a new instance of the NewOrderComboStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderComboStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderComboStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderComboStub Properties

The NewOrderComboStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderComboStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderComboStub Methods

The NewOrderComboStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderComboStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemComponentStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderCompoundItemComponentStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderCompoundItemComponentStub : NewEntityStub,
    INewOrderCompoundItemComponentStub, INewEntityStub, IOrderCompoundItemComponentStub

The NewOrderCompoundItemComponentStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderCompoundItemComponentStub | Initializes a new instance of the NewOrderCompoundItemComponentStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemComponentStub Constructor

Initializes a new instance of the NewOrderCompoundItemComponentStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderCompoundItemComponentStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderCompoundItemComponentStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemComponentStub Properties

The NewOrderCompoundItemComponentStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderCompoundItemComponentStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemComponentStub Methods

The NewOrderCompoundItemComponentStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderCompoundItemComponentStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderCompoundItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderCompoundItemStub : NewEntityStub,
    INewOrderCompoundItemStub, INewOrderCookingItemStub, INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub,
    IOrderCookingItemStub, IOrderCompoundItemStub

The NewOrderCompoundItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderCompoundItemStub | Initializes a new instance of the NewOrderCompoundItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemStub Constructor

Initializes a new instance of the NewOrderCompoundItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderCompoundItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderCompoundItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemStub Properties

The NewOrderCompoundItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderCompoundItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCompoundItemStub Methods

The NewOrderCompoundItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderCompoundItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCookingItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderCookingItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderCookingItemStub : NewEntityStub,
    INewOrderCookingItemStub, INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub, IOrderCookingItemStub

The NewOrderCookingItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderCookingItemStub | Initializes a new instance of the NewOrderCookingItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderCookingItemStub Constructor

Initializes a new instance of the NewOrderCookingItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderCookingItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderCookingItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCookingItemStub Properties

The NewOrderCookingItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderCookingItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderCookingItemStub Methods

The NewOrderCookingItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderCookingItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderGuestItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderGuestItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderGuestItemStub : NewEntityStub,
    INewOrderGuestItemStub, INewEntityStub, IOrderGuestItemStub

The NewOrderGuestItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderGuestItemStub | Initializes a new instance of the NewOrderGuestItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderGuestItemStub Constructor

Initializes a new instance of the NewOrderGuestItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderGuestItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderGuestItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderGuestItemStub Properties

The NewOrderGuestItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderGuestItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderGuestItemStub Methods

The NewOrderGuestItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderGuestItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderModifierItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderModifierItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderModifierItemStub : NewEntityStub,
    INewOrderModifierItemStub, INewEntityStub, IOrderModifierItemStub

The NewOrderModifierItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderModifierItemStub | Initializes a new instance of the NewOrderModifierItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderModifierItemStub Constructor

Initializes a new instance of the NewOrderModifierItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderModifierItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderModifierItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderModifierItemStub Properties

The NewOrderModifierItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderModifierItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderModifierItemStub Methods

The NewOrderModifierItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderModifierItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderProductItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderProductItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderProductItemStub : NewEntityStub,
    INewOrderProductItemStub, INewOrderCookingItemStub, INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub,
    IOrderCookingItemStub, IOrderProductItemStub

The NewOrderProductItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderProductItemStub | Initializes a new instance of the NewOrderProductItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderProductItemStub Constructor

Initializes a new instance of the NewOrderProductItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderProductItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderProductItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderProductItemStub Properties

The NewOrderProductItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderProductItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderProductItemStub Methods

The NewOrderProductItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderProductItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderRootItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderRootItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderRootItemStub : NewEntityStub,
    INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub

The NewOrderRootItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderRootItemStub | Initializes a new instance of the NewOrderRootItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderRootItemStub Constructor

Initializes a new instance of the NewOrderRootItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderRootItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderRootItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderRootItemStub Properties

The NewOrderRootItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderRootItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderRootItemStub Methods

The NewOrderRootItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderRootItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemPeriodStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderServiceItemPeriodStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderServiceItemPeriodStub : NewEntityStub,
    INewOrderServiceItemPeriodStub, INewEntityStub, IOrderServiceItemPeriodStub

The NewOrderServiceItemPeriodStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderServiceItemPeriodStub | Initializes a new instance of the NewOrderServiceItemPeriodStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemPeriodStub Constructor

Initializes a new instance of the NewOrderServiceItemPeriodStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderServiceItemPeriodStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderServiceItemPeriodStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemPeriodStub Properties

The NewOrderServiceItemPeriodStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderServiceItemPeriodStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemPeriodStub Methods

The NewOrderServiceItemPeriodStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderServiceItemPeriodStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderServiceItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderServiceItemStub : NewEntityStub,
    INewOrderServiceItemStub, INewOrderRootItemStub, INewEntityStub, IOrderRootItemStub, IOrderServiceItemStub

The NewOrderServiceItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderServiceItemStub | Initializes a new instance of the NewOrderServiceItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemStub Constructor

Initializes a new instance of the NewOrderServiceItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderServiceItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderServiceItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemStub Properties

The NewOrderServiceItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderServiceItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderServiceItemStub Methods

The NewOrderServiceItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderServiceItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewOrderStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewOrderStub : NewEntityStub,
    INewOrderStub, INewEntityStub, IOrderStub

The NewOrderStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewOrderStub | Initializes a new instance of the NewOrderStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewOrderStub Constructor

Initializes a new instance of the NewOrderStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewOrderStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderStub Properties

The NewOrderStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewOrderStub Methods

The NewOrderStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewOrderStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewPaymentItemStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewPaymentItemStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewPaymentItemStub : NewEntityStub,
    INewPaymentItemStub, INewEntityStub, IPaymentItemStub

The NewPaymentItemStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewPaymentItemStub | Initializes a new instance of the NewPaymentItemStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewPaymentItemStub Constructor

Initializes a new instance of the NewPaymentItemStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewPaymentItemStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewPaymentItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewPaymentItemStub Properties

The NewPaymentItemStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewPaymentItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewPaymentItemStub Methods

The NewPaymentItemStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewPaymentItemStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewReserveStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewReserveStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewReserveStub : NewEntityStub,
    INewReserveStub, INewEntityStub, IReserveStub

The NewReserveStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewReserveStub | Initializes a new instance of the NewReserveStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewReserveStub Constructor

Initializes a new instance of the NewReserveStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewReserveStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewReserveStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewReserveStub Properties

The NewReserveStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewReserveStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewReserveStub Methods

The NewReserveStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewReserveStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewStreetStub Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.Editors.StubsNewEntityStub
Resto.Front.Api.Editors.StubsNewStreetStub

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class NewStreetStub : NewEntityStub,
    INewStreetStub, INewEntityStub, IStreetStub

The NewStreetStub type exposes the following members.

Constructors
 | Name | Description
Public method | NewStreetStub | Initializes a new instance of the NewStreetStub class
Top
Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.Editors.Stubs Namespace


NewStreetStub Constructor

Initializes a new instance of the NewStreetStub class

Namespace: Resto.Front.Api.Editors.Stubs
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public NewStreetStub(
    int sessionNumber,
    int actionNumber
)

Parameters

sessionNumber
Type: SystemInt32
actionNumber
Type: SystemInt32
See Also

Reference

NewStreetStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewStreetStub Properties

The NewStreetStub type exposes the following members.

Properties
 | Name | Description
Public property | ActionNumber | (Inherited from NewEntityStub.)
Public property | SessionNumber | (Inherited from NewEntityStub.)
Top
See Also

Reference

NewStreetStub Class
Resto.Front.Api.Editors.Stubs Namespace


NewStreetStub Methods

The NewStreetStub type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NewStreetStub Class
Resto.Front.Api.Editors.Stubs Namespace


Resto.Front.Api.Exceptions Namespace

Classes
 | Class | Description
Public class | AuthenticationException | The exception that is thrown when plugin authentication fails.
Public class | CafeSessionException | The exception that is thrown when cafe session opening or closing fails.
Public class | CannotAddInactiveProductException | The exception that is thrown on attempt to use product which isn't included in menu.
Public class | CannotCancelNotNewDeliveryException | The exception that is thrown on attempt to cancel delivery, which status is other than New or Unconfirmed.
Public class | CannotCreateEntityException | The exception that is thrown when entity creation fails. Most likely reason for this exception is network problem.
Public class | CannotUseInactiveEntityException | The exception that is thrown when entity cannot be used in specific context because it is inactive.
Public class | ConstraintViolationException | The exception that is thrown when an operation violates business model constraints.
Public class | DeviceException | The exception that is thrown when a specified device could not execute the command.
Public class | DeviceNotStartedException | The exception that should be thrown when a specified device isn't started.
Public class | DeviceRegistrationException | The exception that is thrown when a specified external device was not registered.
Public class | EntityAlreadyInUseException | The exception that is thrown on attempt to change entity that is already being edited by someone.
Public class | EntityModifiedException | The exception that is thrown when versioned entity was modified by someone between reading an entity and applying changes to it. In general case parallel changes cannot be merged automatically, so optimistic locking prevents overwriting someones changes or getting inconsistent entity state.
Public class | EntityNotFoundException | The exception that is thrown on attempt to use entity that doesn't exist.
Public class | EntityStubUsingException | Entity stub usage outruns its creation or entity stub from one edit session is used in another edit session.
Public class | EntityUsingException | The exception that is thrown when entity cannot be used in specific context.
Public class | ExternalOperationCallingException | The exception that is thrown when an external operation calling or execution fails.
Public class | ExternalOperationFailedException | The exception that is thrown when external operation execution fails. Most likely reason for this exception is network problem.
Public class | FrontApiException | Represents a common base error in either the service or client side of Api.
Public class | InsufficientLicenseException | The exception that is thrown when license slot cannot be acquired.
Public class | LicenseRestrictionException | The exception that is thrown on calling unlicensed operation.
Public class | OrderWithoutTypeException | The exception that is thrown when the operation results in an order which has no mandatory order type.
Public class | PaymentActionCancelledException | Exception to notify that payment action was cancelled.
Public class | PaymentActionFailedException | Exception to notify that payment, cancel payment or return payment actions was not successful.
Public class | PaymentSystemRegistrationException | The exception that is thrown when a specified payment system was not registered.
Public class | PaymentTypeConfigurationException | The exception that is thrown when a specified payment type is not well configured.
Public class | PermissionDeniedException | The exception that is thrown on trying to execute operation without having required permissions.
Public class | PluginSettingsException | The exception that is thrown when plugin settings operation fails.
Public class | PreliminaryOrderEditTemporaryUnavailableException | The exception that is thrown when a preliminary order edit temporarily cannot be executed due to networking issues.
Public class | ReportBuildException | The exception that is thrown when a specified report could not be built.
Public class | ServerConnectionException | The exception that is thrown when message wasn't sent due to connection troubles.
Public class | UnexpectedInternalException | The exception that is sent into OnError(Exception) handler of the notification stream from Notifications when the underlying event source throws unexpected exception.
Public class | UserPersonalSessionNotOpenedException |
Public class | UserSessionInvalidException | The exception that is thrown on trying to use credentials that doesn't correspond to valid user session. Session may become outdated if user is deactivated or his pin is changed since session start.
Enumerations
 | Enumeration | Description
Public enumeration | ExternalOperationCallingExceptionReason | Reason for throwing ExternalOperationCallingException.


AuthenticationException Class

The exception that is thrown when plugin authentication fails.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsAuthenticationException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class AuthenticationException : FrontApiException

The AuthenticationException type exposes the following members.

Constructors
 | Name | Description
Public method | AuthenticationException | Initializes a new instance of the AuthenticationException class.
Public method | AuthenticationException(String) | Initializes a new instance of the AuthenticationException class with a specified error message.
Public method | AuthenticationException(String, Exception) | Initializes a new instance of the AuthenticationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace
IOperationServiceAuthenticateByPin(String)


AuthenticationException Constructor

Overload List
 | Name | Description
Public method | AuthenticationException | Initializes a new instance of the AuthenticationException class.
Public method | AuthenticationException(String) | Initializes a new instance of the AuthenticationException class with a specified error message.
Public method | AuthenticationException(String, Exception) | Initializes a new instance of the AuthenticationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

AuthenticationException Class
Resto.Front.Api.Exceptions Namespace


AuthenticationException Constructor

Initializes a new instance of the AuthenticationException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AuthenticationException()
See Also

Reference

AuthenticationException Class
AuthenticationException Overload
Resto.Front.Api.Exceptions Namespace


AuthenticationException Constructor (String)

Initializes a new instance of the AuthenticationException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AuthenticationException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

AuthenticationException Class
AuthenticationException Overload
Resto.Front.Api.Exceptions Namespace


AuthenticationException Constructor (String, Exception)

Initializes a new instance of the AuthenticationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public AuthenticationException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

AuthenticationException Class
AuthenticationException Overload
Resto.Front.Api.Exceptions Namespace


AuthenticationException Properties

The AuthenticationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

AuthenticationException Class
Resto.Front.Api.Exceptions Namespace


AuthenticationException Methods

The AuthenticationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

AuthenticationException Class
Resto.Front.Api.Exceptions Namespace


CafeSessionException Class

The exception that is thrown when cafe session opening or closing fails.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsCafeSessionException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CafeSessionException : FrontApiException

The CafeSessionException type exposes the following members.

Constructors
 | Name | Description
Public method | CafeSessionException(String) | Initializes a new instance of the CafeSessionException class with a specified error message.
Protected method | CafeSessionException(SerializationInfo, StreamingContext) | Initializes a new instance of the CafeSessionException class with serialized data.
Public method | CafeSessionException(String, Exception) | Initializes a new instance of the CafeSessionException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | CafeSessionException(String, Object) | Initializes a new instance of the CafeSessionException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


CafeSessionException Constructor

Overload List
 | Name | Description
Public method | CafeSessionException(String) | Initializes a new instance of the CafeSessionException class with a specified error message.
Protected method | CafeSessionException(SerializationInfo, StreamingContext) | Initializes a new instance of the CafeSessionException class with serialized data.
Public method | CafeSessionException(String, Exception) | Initializes a new instance of the CafeSessionException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | CafeSessionException(String, Object) | Initializes a new instance of the CafeSessionException class with a specified error message.
Top
See Also

Reference

CafeSessionException Class
Resto.Front.Api.Exceptions Namespace


CafeSessionException Constructor (String)

Initializes a new instance of the CafeSessionException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CafeSessionException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

CafeSessionException Class
CafeSessionException Overload
Resto.Front.Api.Exceptions Namespace


CafeSessionException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the CafeSessionException class with serialized data.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected CafeSessionException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

CafeSessionException Class
CafeSessionException Overload
Resto.Front.Api.Exceptions Namespace


CafeSessionException Constructor (String, Exception)

Initializes a new instance of the CafeSessionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CafeSessionException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

CafeSessionException Class
CafeSessionException Overload
Resto.Front.Api.Exceptions Namespace


CafeSessionException Constructor (String, Object[])

CafeSessionException Constructor (String, Object)

Initializes a new instance of the CafeSessionException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CafeSessionException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

CafeSessionException Class
CafeSessionException Overload
Resto.Front.Api.Exceptions Namespace


CafeSessionException Properties

The CafeSessionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CafeSessionException Class
Resto.Front.Api.Exceptions Namespace


CafeSessionException Methods

The CafeSessionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CafeSessionException Class
Resto.Front.Api.Exceptions Namespace


CafeSessionException Events

The CafeSessionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CafeSessionException Class
Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException Class

The exception that is thrown on attempt to use product which isn't included in menu.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsConstraintViolationException
Resto.Front.Api.ExceptionsCannotAddInactiveProductException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CannotAddInactiveProductException : ConstraintViolationException

The CannotAddInactiveProductException type exposes the following members.

Constructors
 | Name | Description
Public method | CannotAddInactiveProductException | Initializes a new instance of the CannotAddInactiveProductException class with a specified product.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Product | Gets the product that caused this exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException Constructor

Initializes a new instance of the CannotAddInactiveProductException class with a specified product.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotAddInactiveProductException(
    IProduct product
)

Parameters

product
Type: Resto.Front.Api.Data.AssortmentIProduct
See Also

Reference

CannotAddInactiveProductException Class
Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException Properties

The CannotAddInactiveProductException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Product | Gets the product that caused this exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotAddInactiveProductException Class
Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException.Product Property

CannotAddInactiveProductExceptionProduct Property

Gets the product that caused this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IProduct Product { get; }

Property Value

Type: IProduct
See Also

Reference

CannotAddInactiveProductException Class
Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException Methods

The CannotAddInactiveProductException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotAddInactiveProductException Class
Resto.Front.Api.Exceptions Namespace


CannotAddInactiveProductException.GetObjectData Method

CannotAddInactiveProductExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

CannotAddInactiveProductException Class
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Class

The exception that is thrown on attempt to cancel delivery, which status is other than New or Unconfirmed.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsCannotCancelNotNewDeliveryException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CannotCancelNotNewDeliveryException : EntityUsingException

The CannotCancelNotNewDeliveryException type exposes the following members.

Constructors
 | Name | Description
Public method | CannotCancelNotNewDeliveryException(Guid) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id.
Public method | CannotCancelNotNewDeliveryException(Guid, String) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id and error message.
Public method | CannotCancelNotNewDeliveryException(Guid, String, Exception) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id, error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Constructor

Overload List
 | Name | Description
Public method | CannotCancelNotNewDeliveryException(Guid) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id.
Public method | CannotCancelNotNewDeliveryException(Guid, String) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id and error message.
Public method | CannotCancelNotNewDeliveryException(Guid, String, Exception) | Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id, error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

CannotCancelNotNewDeliveryException Class
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Constructor (Guid)

Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCancelNotNewDeliveryException(
    Guid deliveryId
)

Parameters

deliveryId
Type: SystemGuid
See Also

Reference

CannotCancelNotNewDeliveryException Class
CannotCancelNotNewDeliveryException Overload
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Constructor (Guid, String)

Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id and error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCancelNotNewDeliveryException(
    Guid deliveryId,
    string message
)

Parameters

deliveryId
Type: SystemGuid
message
Type: SystemString
See Also

Reference

CannotCancelNotNewDeliveryException Class
CannotCancelNotNewDeliveryException Overload
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Constructor (Guid, String, Exception)

Initializes a new instance of the CannotCancelNotNewDeliveryException class with a specified delivery id, error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCancelNotNewDeliveryException(
    Guid deliveryId,
    string message,
    Exception innerException
)

Parameters

deliveryId
Type: SystemGuid
message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

CannotCancelNotNewDeliveryException Class
CannotCancelNotNewDeliveryException Overload
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Properties

The CannotCancelNotNewDeliveryException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotCancelNotNewDeliveryException Class
Resto.Front.Api.Exceptions Namespace


CannotCancelNotNewDeliveryException Methods

The CannotCancelNotNewDeliveryException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotCancelNotNewDeliveryException Class
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Class

The exception that is thrown when entity creation fails. Most likely reason for this exception is network problem.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsCannotCreateEntityException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class CannotCreateEntityException : FrontApiException

The CannotCreateEntityException type exposes the following members.

Constructors
 | Name | Description
Public method | CannotCreateEntityException | Initializes a new instance of the CannotCreateEntityException class.
Public method | CannotCreateEntityException(String) | Initializes a new instance of the CannotCreateEntityException class with a specified error message.
Public method | CannotCreateEntityException(String, Exception) | Initializes a new instance of the CannotCreateEntityException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Constructor

Overload List
 | Name | Description
Public method | CannotCreateEntityException | Initializes a new instance of the CannotCreateEntityException class.
Public method | CannotCreateEntityException(String) | Initializes a new instance of the CannotCreateEntityException class with a specified error message.
Public method | CannotCreateEntityException(String, Exception) | Initializes a new instance of the CannotCreateEntityException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

CannotCreateEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Constructor

Initializes a new instance of the CannotCreateEntityException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCreateEntityException()
See Also

Reference

CannotCreateEntityException Class
CannotCreateEntityException Overload
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Constructor (String)

Initializes a new instance of the CannotCreateEntityException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCreateEntityException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

CannotCreateEntityException Class
CannotCreateEntityException Overload
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Constructor (String, Exception)

Initializes a new instance of the CannotCreateEntityException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotCreateEntityException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

CannotCreateEntityException Class
CannotCreateEntityException Overload
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Properties

The CannotCreateEntityException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotCreateEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Methods

The CannotCreateEntityException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotCreateEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotCreateEntityException Events

The CannotCreateEntityException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CannotCreateEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotUseInactiveEntityException Class

The exception that is thrown when entity cannot be used in specific context because it is inactive.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsCannotUseInactiveEntityException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class CannotUseInactiveEntityException : EntityUsingException

The CannotUseInactiveEntityException type exposes the following members.

Constructors
 | Name | Description
Public method | CannotUseInactiveEntityException | Initializes a new instance of the CannotUseInactiveEntityException class with specified entity id and error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


CannotUseInactiveEntityException Constructor

Initializes a new instance of the CannotUseInactiveEntityException class with specified entity id and error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public CannotUseInactiveEntityException(
    Guid entityId,
    string message
)

Parameters

entityId
Type: SystemGuid
message
Type: SystemString
See Also

Reference

CannotUseInactiveEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotUseInactiveEntityException Properties

The CannotUseInactiveEntityException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotUseInactiveEntityException Class
Resto.Front.Api.Exceptions Namespace


CannotUseInactiveEntityException Methods

The CannotUseInactiveEntityException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CannotUseInactiveEntityException Class
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Class

The exception that is thrown when an operation violates business model constraints.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsConstraintViolationException
Resto.Front.Api.ExceptionsCannotAddInactiveProductException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ConstraintViolationException : FrontApiException

The ConstraintViolationException type exposes the following members.

Constructors
 | Name | Description
Public method | ConstraintViolationException(String) | Initializes a new instance of the ConstraintViolationException class with a specified error message.
Protected method | ConstraintViolationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConstraintViolationException class with serialized data.
Public method | ConstraintViolationException(String, Exception) | Initializes a new instance of the ConstraintViolationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | ConstraintViolationException(String, Object) | Initializes a new instance of the ConstraintViolationException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Constructor

Overload List
 | Name | Description
Public method | ConstraintViolationException(String) | Initializes a new instance of the ConstraintViolationException class with a specified error message.
Protected method | ConstraintViolationException(SerializationInfo, StreamingContext) | Initializes a new instance of the ConstraintViolationException class with serialized data.
Public method | ConstraintViolationException(String, Exception) | Initializes a new instance of the ConstraintViolationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | ConstraintViolationException(String, Object) | Initializes a new instance of the ConstraintViolationException class with a specified error message.
Top
See Also

Reference

ConstraintViolationException Class
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Constructor (String)

Initializes a new instance of the ConstraintViolationException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ConstraintViolationException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

ConstraintViolationException Class
ConstraintViolationException Overload
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ConstraintViolationException class with serialized data.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected ConstraintViolationException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ConstraintViolationException Class
ConstraintViolationException Overload
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Constructor (String, Exception)

Initializes a new instance of the ConstraintViolationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ConstraintViolationException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

ConstraintViolationException Class
ConstraintViolationException Overload
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Constructor (String, Object[])

ConstraintViolationException Constructor (String, Object)

Initializes a new instance of the ConstraintViolationException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ConstraintViolationException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

ConstraintViolationException Class
ConstraintViolationException Overload
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Properties

The ConstraintViolationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ConstraintViolationException Class
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Methods

The ConstraintViolationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ConstraintViolationException Class
Resto.Front.Api.Exceptions Namespace


ConstraintViolationException Events

The ConstraintViolationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ConstraintViolationException Class
Resto.Front.Api.Exceptions Namespace


DeviceException Class

The exception that is thrown when a specified device could not execute the command.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsDeviceException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceException : FrontApiException

The DeviceException type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceException | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, Exception) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceException(String, Object) | Initializes a new instance of the DeviceException class with a specified error message.
Public method | DeviceException(Int32, String, Exception) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceException(Int32, String, Object) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InternalErrorCode | Internal error number, thrown by external device or adapter.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


DeviceException Constructor

Overload List
 | Name | Description
Public method | DeviceException | Initializes a new instance of the DeviceException class.
Public method | DeviceException(String, Exception) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceException(String, Object) | Initializes a new instance of the DeviceException class with a specified error message.
Public method | DeviceException(Int32, String, Exception) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceException(Int32, String, Object) | Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceException Constructor

Initializes a new instance of the DeviceException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceException()
See Also

Reference

DeviceException Class
DeviceException Overload
Resto.Front.Api.Exceptions Namespace


DeviceException Constructor (String, Exception)

Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

DeviceException Class
DeviceException Overload
Resto.Front.Api.Exceptions Namespace


DeviceException Constructor (String, Object[])

DeviceException Constructor (String, Object)

Initializes a new instance of the DeviceException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

DeviceException Class
DeviceException Overload
Resto.Front.Api.Exceptions Namespace


DeviceException Constructor (Int32, String, Exception)

Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceException(
    int deviceErrorCode,
    string message,
    Exception innerException
)

Parameters

deviceErrorCode
Type: SystemInt32
Internal device error number
message
Type: SystemString
Device error message text
innerException
Type: SystemException
Exception instance that caused the current exception
See Also

Reference

DeviceException Class
DeviceException Overload
Resto.Front.Api.Exceptions Namespace


DeviceException Constructor (Int32, String, Object[])

DeviceException Constructor (Int32, String, Object)

Initializes a new instance of the DeviceException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceException(
    int deviceErrorCode,
    string messageFormat,
    params Object[] args
)

Parameters

deviceErrorCode
Type: SystemInt32
Internal device error number
messageFormat
Type: SystemString
Device error message text format
args
Type: SystemObject
Message args
See Also

Reference

DeviceException Class
DeviceException Overload
Resto.Front.Api.Exceptions Namespace


DeviceException Properties

The DeviceException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InternalErrorCode | Internal error number, thrown by external device or adapter.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceException.InternalErrorCode Property

DeviceExceptionInternalErrorCode Property

Internal error number, thrown by external device or adapter.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public long InternalErrorCode { get; }

Property Value

Type: Int64
Internal device error number.
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceException Methods

The DeviceException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceException.GetObjectData Method

DeviceExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceException Events

The DeviceException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceException Class
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Class

The exception that should be thrown when a specified device isn't started.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsDeviceNotStartedException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class DeviceNotStartedException : FrontApiException

The DeviceNotStartedException type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceNotStartedException | Initializes a new instance of the DeviceNotStartedException class.
Public method | DeviceNotStartedException(String, Exception) | Initializes a new instance of the DeviceNotStartedException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceNotStartedException(String, Object) | Initializes a new instance of the DeviceNotStartedException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Constructor

Overload List
 | Name | Description
Public method | DeviceNotStartedException | Initializes a new instance of the DeviceNotStartedException class.
Public method | DeviceNotStartedException(String, Exception) | Initializes a new instance of the DeviceNotStartedException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceNotStartedException(String, Object) | Initializes a new instance of the DeviceNotStartedException class with a specified error message.
Top
See Also

Reference

DeviceNotStartedException Class
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Constructor

Initializes a new instance of the DeviceNotStartedException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNotStartedException()
See Also

Reference

DeviceNotStartedException Class
DeviceNotStartedException Overload
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Constructor (String, Exception)

Initializes a new instance of the DeviceNotStartedException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNotStartedException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

DeviceNotStartedException Class
DeviceNotStartedException Overload
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Constructor (String, Object[])

DeviceNotStartedException Constructor (String, Object)

Initializes a new instance of the DeviceNotStartedException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceNotStartedException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

DeviceNotStartedException Class
DeviceNotStartedException Overload
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Properties

The DeviceNotStartedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceNotStartedException Class
Resto.Front.Api.Exceptions Namespace


DeviceNotStartedException Methods

The DeviceNotStartedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceNotStartedException Class
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Class

The exception that is thrown when a specified external device was not registered.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsDeviceRegistrationException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class DeviceRegistrationException : FrontApiException

The DeviceRegistrationException type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceRegistrationException | Initializes a new instance of the DeviceRegistrationException class.
Public method | DeviceRegistrationException(String, Exception) | Initializes a new instance of the DeviceRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceRegistrationException(String, Object) | Initializes a new instance of the DeviceRegistrationException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Constructor

Overload List
 | Name | Description
Public method | DeviceRegistrationException | Initializes a new instance of the DeviceRegistrationException class.
Public method | DeviceRegistrationException(String, Exception) | Initializes a new instance of the DeviceRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | DeviceRegistrationException(String, Object) | Initializes a new instance of the DeviceRegistrationException class with a specified error message.
Top
See Also

Reference

DeviceRegistrationException Class
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Constructor

Initializes a new instance of the DeviceRegistrationException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceRegistrationException()
See Also

Reference

DeviceRegistrationException Class
DeviceRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Constructor (String, Exception)

Initializes a new instance of the DeviceRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceRegistrationException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

DeviceRegistrationException Class
DeviceRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Constructor (String, Object[])

DeviceRegistrationException Constructor (String, Object)

Initializes a new instance of the DeviceRegistrationException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public DeviceRegistrationException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

DeviceRegistrationException Class
DeviceRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Properties

The DeviceRegistrationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceRegistrationException Class
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Methods

The DeviceRegistrationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceRegistrationException Class
Resto.Front.Api.Exceptions Namespace


DeviceRegistrationException Events

The DeviceRegistrationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DeviceRegistrationException Class
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Class

The exception that is thrown on attempt to change entity that is already being edited by someone.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityAlreadyInUseException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class EntityAlreadyInUseException : FrontApiException

The EntityAlreadyInUseException type exposes the following members.

Constructors
 | Name | Description
Public method | EntityAlreadyInUseException | Initializes a new instance of the EntityAlreadyInUseException class.
Public method | EntityAlreadyInUseException(String) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.
Public method | EntityAlreadyInUseException(String, Exception) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | EntityAlreadyInUseException(String, String, IUser) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LockedTerminalName | Terminal that locked entity.
Public property | LockedUser | User, who locked entity.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Constructor

Overload List
 | Name | Description
Public method | EntityAlreadyInUseException | Initializes a new instance of the EntityAlreadyInUseException class.
Public method | EntityAlreadyInUseException(String) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.
Public method | EntityAlreadyInUseException(String, Exception) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | EntityAlreadyInUseException(String, String, IUser) | Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.
Top
See Also

Reference

EntityAlreadyInUseException Class
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Constructor

Initializes a new instance of the EntityAlreadyInUseException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityAlreadyInUseException()
See Also

Reference

EntityAlreadyInUseException Class
EntityAlreadyInUseException Overload
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Constructor (String)

Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityAlreadyInUseException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

EntityAlreadyInUseException Class
EntityAlreadyInUseException Overload
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Constructor (String, Exception)

Initializes a new instance of the EntityAlreadyInUseException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityAlreadyInUseException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

EntityAlreadyInUseException Class
EntityAlreadyInUseException Overload
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Constructor (String, String, IUser)

Initializes a new instance of the EntityAlreadyInUseException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityAlreadyInUseException(
    string message,
    string terminal,
    IUser user
)

Parameters

message
Type: SystemString
terminal
Type: SystemString
user
Type: Resto.Front.Api.Data.SecurityIUser
See Also

Reference

EntityAlreadyInUseException Class
EntityAlreadyInUseException Overload
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Properties

The EntityAlreadyInUseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LockedTerminalName | Terminal that locked entity.
Public property | LockedUser | User, who locked entity.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityAlreadyInUseException Class
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException.LockedTerminalName Property

EntityAlreadyInUseExceptionLockedTerminalName Property

Terminal that locked entity.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string LockedTerminalName { get; }

Property Value

Type: String
See Also

Reference

EntityAlreadyInUseException Class
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException.LockedUser Property

EntityAlreadyInUseExceptionLockedUser Property

User, who locked entity.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public IUser LockedUser { get; }

Property Value

Type: IUser
See Also

Reference

EntityAlreadyInUseException Class
Resto.Front.Api.Exceptions Namespace


EntityAlreadyInUseException Methods

The EntityAlreadyInUseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityAlreadyInUseException Class
Resto.Front.Api.Exceptions Namespace


EntityModifiedException Class

The exception that is thrown when versioned entity was modified by someone between reading an entity and applying changes to it. In general case parallel changes cannot be merged automatically, so optimistic locking prevents overwriting someones changes or getting inconsistent entity state.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsEntityModifiedException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class EntityModifiedException : EntityUsingException

The EntityModifiedException type exposes the following members.

Constructors
 | Name | Description
Public method | EntityModifiedException(Guid, String) | Initializes a new instance of the EntityModifiedException class with custom message.
Public method | EntityModifiedException(IVersionedEntity, Int32) | Initializes a new instance of the EntityModifiedException class with specified entity stub and actual version.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Remarks
Plugin should re-read changed entity, ensure that rejected changes are compatible with new entity state and re-apply them.
See Also

Reference

Resto.Front.Api.Exceptions Namespace


EntityModifiedException Constructor

Overload List
 | Name | Description
Public method | EntityModifiedException(Guid, String) | Initializes a new instance of the EntityModifiedException class with custom message.
Public method | EntityModifiedException(IVersionedEntity, Int32) | Initializes a new instance of the EntityModifiedException class with specified entity stub and actual version.
Top
See Also

Reference

EntityModifiedException Class
Resto.Front.Api.Exceptions Namespace


EntityModifiedException Constructor (Guid, String)

Initializes a new instance of the EntityModifiedException class with custom message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityModifiedException(
    Guid entityId,
    string message
)

Parameters

entityId
Type: SystemGuid
message
Type: SystemString
See Also

Reference

EntityModifiedException Class
EntityModifiedException Overload
Resto.Front.Api.Exceptions Namespace


EntityModifiedException Constructor (IVersionedEntity, Int32)

Initializes a new instance of the EntityModifiedException class with specified entity stub and actual version.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityModifiedException(
    IVersionedEntity modifiedEntity,
    int actualVersion
)

Parameters

modifiedEntity
Type: Resto.Front.Api.Data.CommonIVersionedEntity
actualVersion
Type: SystemInt32
See Also

Reference

EntityModifiedException Class
EntityModifiedException Overload
Resto.Front.Api.Exceptions Namespace


EntityModifiedException Properties

The EntityModifiedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityModifiedException Class
Resto.Front.Api.Exceptions Namespace


EntityModifiedException Methods

The EntityModifiedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityModifiedException Class
Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Class

The exception that is thrown on attempt to use entity that doesn't exist.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsEntityNotFoundException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class EntityNotFoundException : EntityUsingException

The EntityNotFoundException type exposes the following members.

Constructors
 | Name | Description
Public method | EntityNotFoundException(Guid, Type) | Initializes a new instance of the EntityNotFoundException class with specified entity id and type.
Public method | EntityNotFoundException(Guid, String, Object) | Initializes a new instance of the EntityNotFoundException class with specified entity id, type and error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Constructor

Overload List
 | Name | Description
Public method | EntityNotFoundException(Guid, Type) | Initializes a new instance of the EntityNotFoundException class with specified entity id and type.
Public method | EntityNotFoundException(Guid, String, Object) | Initializes a new instance of the EntityNotFoundException class with specified entity id, type and error message.
Top
See Also

Reference

EntityNotFoundException Class
Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Constructor (Guid, Type)

Initializes a new instance of the EntityNotFoundException class with specified entity id and type.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityNotFoundException(
    Guid entityId,
    Type entityType
)

Parameters

entityId
Type: SystemGuid
entityType
Type: SystemType
See Also

Reference

EntityNotFoundException Class
EntityNotFoundException Overload
Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Constructor (Guid, String, Object[])

EntityNotFoundException Constructor (Guid, String, Object)

Initializes a new instance of the EntityNotFoundException class with specified entity id, type and error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityNotFoundException(
    Guid entityId,
    string messageFormat,
    params Object[] args
)

Parameters

entityId
Type: SystemGuid
messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

EntityNotFoundException Class
EntityNotFoundException Overload
Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Properties

The EntityNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityNotFoundException Class
Resto.Front.Api.Exceptions Namespace


EntityNotFoundException Methods

The EntityNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityNotFoundException Class
Resto.Front.Api.Exceptions Namespace


EntityStubUsingException Class

Entity stub usage outruns its creation or entity stub from one edit session is used in another edit session.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityStubUsingException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class EntityStubUsingException : FrontApiException

The EntityStubUsingException type exposes the following members.

Constructors
 | Name | Description
Public method | EntityStubUsingException | Initializes a new instance of the EntityStubUsingException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


EntityStubUsingException Constructor

Initializes a new instance of the EntityStubUsingException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityStubUsingException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

EntityStubUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityStubUsingException Properties

The EntityStubUsingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityStubUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityStubUsingException Methods

The EntityStubUsingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityStubUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException Class

The exception that is thrown when entity cannot be used in specific context.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsCannotCancelNotNewDeliveryException
Resto.Front.Api.ExceptionsCannotUseInactiveEntityException
Resto.Front.Api.ExceptionsEntityModifiedException
Resto.Front.Api.ExceptionsEntityNotFoundException
Resto.Front.Api.ExceptionsOrderWithoutTypeException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class EntityUsingException : FrontApiException

The EntityUsingException type exposes the following members.

Constructors
 | Name | Description
Public method | EntityUsingException(Guid) | Initializes a new instance of the EntityUsingException class with specified entity id.
Protected method | EntityUsingException(SerializationInfo, StreamingContext) | Initializes a new instance of the EntityUsingException class with serialized data.
Public method | EntityUsingException(Guid, String, Exception) | Initializes a new instance of the EntityUsingException class with specified entity id, error message and a reference to the inner exception that is the cause of this exception.
Public method | EntityUsingException(Guid, String, Object) | Initializes a new instance of the EntityUsingException class with specified entity id and error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


EntityUsingException Constructor

Overload List
 | Name | Description
Public method | EntityUsingException(Guid) | Initializes a new instance of the EntityUsingException class with specified entity id.
Protected method | EntityUsingException(SerializationInfo, StreamingContext) | Initializes a new instance of the EntityUsingException class with serialized data.
Public method | EntityUsingException(Guid, String, Exception) | Initializes a new instance of the EntityUsingException class with specified entity id, error message and a reference to the inner exception that is the cause of this exception.
Public method | EntityUsingException(Guid, String, Object) | Initializes a new instance of the EntityUsingException class with specified entity id and error message.
Top
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException Constructor (Guid)

Initializes a new instance of the EntityUsingException class with specified entity id.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityUsingException(
    Guid entityId
)

Parameters

entityId
Type: SystemGuid
See Also

Reference

EntityUsingException Class
EntityUsingException Overload
Resto.Front.Api.Exceptions Namespace


EntityUsingException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the EntityUsingException class with serialized data.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected EntityUsingException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

EntityUsingException Class
EntityUsingException Overload
Resto.Front.Api.Exceptions Namespace


EntityUsingException Constructor (Guid, String, Exception)

Initializes a new instance of the EntityUsingException class with specified entity id, error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityUsingException(
    Guid entityId,
    string message,
    Exception innerException
)

Parameters

entityId
Type: SystemGuid
message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

EntityUsingException Class
EntityUsingException Overload
Resto.Front.Api.Exceptions Namespace


EntityUsingException Constructor (Guid, String, Object[])

EntityUsingException Constructor (Guid, String, Object)

Initializes a new instance of the EntityUsingException class with specified entity id and error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public EntityUsingException(
    Guid entityId,
    string messageFormat,
    params Object[] args
)

Parameters

entityId
Type: SystemGuid
messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

EntityUsingException Class
EntityUsingException Overload
Resto.Front.Api.Exceptions Namespace


EntityUsingException Properties

The EntityUsingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException.EntityId Property

EntityUsingExceptionEntityId Property

Identifier of entity which usage caused this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid EntityId { get; }

Property Value

Type: Guid
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException Methods

The EntityUsingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException.GetObjectData Method

EntityUsingExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


EntityUsingException Events

The EntityUsingException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

EntityUsingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException Class

The exception that is thrown when an external operation calling or execution fails.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsExternalOperationFailedException
Resto.Front.Api.ExceptionsExternalOperationCallingException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class ExternalOperationCallingException : ExternalOperationFailedException

The ExternalOperationCallingException type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalOperationCallingException | Initializes a new instance of the ExternalOperationCallingException class with a specified error message and fail reason.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Reason | External operation fail reason.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException Constructor

Initializes a new instance of the ExternalOperationCallingException class with a specified error message and fail reason.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalOperationCallingException(
    ExternalOperationCallingExceptionReason reason,
    string message
)

Parameters

reason
Type: Resto.Front.Api.ExceptionsExternalOperationCallingExceptionReason
message
Type: SystemString
See Also

Reference

ExternalOperationCallingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException Properties

The ExternalOperationCallingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Reason | External operation fail reason.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExternalOperationCallingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException.Reason Property

ExternalOperationCallingExceptionReason Property

External operation fail reason.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalOperationCallingExceptionReason Reason { get; }

Property Value

Type: ExternalOperationCallingExceptionReason
See Also

Reference

ExternalOperationCallingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException Methods

The ExternalOperationCallingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExternalOperationCallingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingException.GetObjectData Method

ExternalOperationCallingExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

ExternalOperationCallingException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationCallingExceptionReason Enumeration

Reason for throwing ExternalOperationCallingException.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ExternalOperationCallingExceptionReason
Members
Member name | Value | Description
NetworkProblem | 0 | Cannot call external operation on another terminal because of network problems.
OperationNotRegistered | 1 | Cannot call external operation on current or another terminal because of operation doesn't exist.
OperationFailed | 2 | External operation execution failed on current or another terminal.
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Class

The exception that is thrown when external operation execution fails. Most likely reason for this exception is network problem.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsExternalOperationFailedException
Resto.Front.Api.ExceptionsExternalOperationCallingException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ExternalOperationFailedException : FrontApiException

The ExternalOperationFailedException type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalOperationFailedException(String) | Initializes a new instance of the FrontApiException class.
Protected method | ExternalOperationFailedException(SerializationInfo, StreamingContext) | Initializes a new instance of the FrontApiException class with serialized data.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Constructor

Overload List
 | Name | Description
Public method | ExternalOperationFailedException(String) | Initializes a new instance of the FrontApiException class.
Protected method | ExternalOperationFailedException(SerializationInfo, StreamingContext) | Initializes a new instance of the FrontApiException class with serialized data.
Top
See Also

Reference

ExternalOperationFailedException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Constructor (String)

Initializes a new instance of the FrontApiException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExternalOperationFailedException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

ExternalOperationFailedException Class
ExternalOperationFailedException Overload
Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FrontApiException class with serialized data.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected ExternalOperationFailedException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ExternalOperationFailedException Class
ExternalOperationFailedException Overload
Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Properties

The ExternalOperationFailedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExternalOperationFailedException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Methods

The ExternalOperationFailedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ExternalOperationFailedException Class
Resto.Front.Api.Exceptions Namespace


ExternalOperationFailedException Events

The ExternalOperationFailedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ExternalOperationFailedException Class
Resto.Front.Api.Exceptions Namespace


FrontApiException Class

Represents a common base error in either the service or client side of Api.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
More...

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public abstract class FrontApiException : Exception

The FrontApiException type exposes the following members.

Constructors
 | Name | Description
Protected method | FrontApiException | Initializes a new instance of the FrontApiException class.
Protected method | FrontApiException(String) | Initializes a new instance of the FrontApiException class with a specified error message.
Protected method | FrontApiException(SerializationInfo, StreamingContext) | Initializes a new instance of the FrontApiException class with serialized data.
Protected method | FrontApiException(String, Exception) | Initializes a new instance of the FrontApiException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Protected method | FrontApiException(String, Object) | Initializes a new instance of the FrontApiException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsAuthenticationException
Resto.Front.Api.ExceptionsCafeSessionException
Resto.Front.Api.ExceptionsCannotCreateEntityException
Resto.Front.Api.ExceptionsConstraintViolationException
Resto.Front.Api.ExceptionsDeviceException
Resto.Front.Api.ExceptionsDeviceNotStartedException
Resto.Front.Api.ExceptionsDeviceRegistrationException
Resto.Front.Api.ExceptionsEntityAlreadyInUseException
Resto.Front.Api.ExceptionsEntityStubUsingException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsExternalOperationFailedException
Resto.Front.Api.ExceptionsInsufficientLicenseException
Resto.Front.Api.ExceptionsLicenseRestrictionException
Resto.Front.Api.ExceptionsPaymentActionCancelledException
Resto.Front.Api.ExceptionsPaymentActionFailedException
Resto.Front.Api.ExceptionsPaymentSystemRegistrationException
Resto.Front.Api.ExceptionsPaymentTypeConfigurationException
Resto.Front.Api.ExceptionsPermissionDeniedException
Resto.Front.Api.ExceptionsPluginSettingsException
Resto.Front.Api.ExceptionsPreliminaryOrderEditTemporaryUnavailableException
Resto.Front.Api.ExceptionsReportBuildException
Resto.Front.Api.ExceptionsServerConnectionException
Resto.Front.Api.ExceptionsUnexpectedInternalException
Resto.Front.Api.ExceptionsUserSessionInvalidException


FrontApiException Constructor

Overload List
 | Name | Description
Protected method | FrontApiException | Initializes a new instance of the FrontApiException class.
Protected method | FrontApiException(String) | Initializes a new instance of the FrontApiException class with a specified error message.
Protected method | FrontApiException(SerializationInfo, StreamingContext) | Initializes a new instance of the FrontApiException class with serialized data.
Protected method | FrontApiException(String, Exception) | Initializes a new instance of the FrontApiException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Protected method | FrontApiException(String, Object) | Initializes a new instance of the FrontApiException class with a specified error message.
Top
See Also

Reference

FrontApiException Class
Resto.Front.Api.Exceptions Namespace


FrontApiException Constructor

Initializes a new instance of the FrontApiException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected FrontApiException()
See Also

Reference

FrontApiException Class
FrontApiException Overload
Resto.Front.Api.Exceptions Namespace


FrontApiException Constructor (String)

Initializes a new instance of the FrontApiException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected FrontApiException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

FrontApiException Class
FrontApiException Overload
Resto.Front.Api.Exceptions Namespace


FrontApiException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FrontApiException class with serialized data.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected FrontApiException(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

FrontApiException Class
FrontApiException Overload
Resto.Front.Api.Exceptions Namespace


FrontApiException Constructor (String, Exception)

Initializes a new instance of the FrontApiException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected FrontApiException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

FrontApiException Class
FrontApiException Overload
Resto.Front.Api.Exceptions Namespace


FrontApiException Constructor (String, Object[])

FrontApiException Constructor (String, Object)

Initializes a new instance of the FrontApiException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected FrontApiException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

FrontApiException Class
FrontApiException Overload
Resto.Front.Api.Exceptions Namespace


FrontApiException Properties

The FrontApiException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FrontApiException Class
Resto.Front.Api.Exceptions Namespace


FrontApiException Methods

The FrontApiException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

FrontApiException Class
Resto.Front.Api.Exceptions Namespace


FrontApiException Events

The FrontApiException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FrontApiException Class
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Class

The exception that is thrown when license slot cannot be acquired.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsInsufficientLicenseException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class InsufficientLicenseException : FrontApiException

The InsufficientLicenseException type exposes the following members.

Constructors
 | Name | Description
Public method | InsufficientLicenseException | Initializes a new instance of the InsufficientLicenseException class.
Public method | InsufficientLicenseException(String) | Initializes a new instance of the InsufficientLicenseException class with a specified error message.
Public method | InsufficientLicenseException(String, Object) | Initializes a new instance of the InsufficientLicenseException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Constructor

Overload List
 | Name | Description
Public method | InsufficientLicenseException | Initializes a new instance of the InsufficientLicenseException class.
Public method | InsufficientLicenseException(String) | Initializes a new instance of the InsufficientLicenseException class with a specified error message.
Public method | InsufficientLicenseException(String, Object) | Initializes a new instance of the InsufficientLicenseException class with a specified error message.
Top
See Also

Reference

InsufficientLicenseException Class
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Constructor

Initializes a new instance of the InsufficientLicenseException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InsufficientLicenseException()
See Also

Reference

InsufficientLicenseException Class
InsufficientLicenseException Overload
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Constructor (String)

Initializes a new instance of the InsufficientLicenseException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InsufficientLicenseException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

InsufficientLicenseException Class
InsufficientLicenseException Overload
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Constructor (String, Object[])

InsufficientLicenseException Constructor (String, Object)

Initializes a new instance of the InsufficientLicenseException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public InsufficientLicenseException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

InsufficientLicenseException Class
InsufficientLicenseException Overload
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Properties

The InsufficientLicenseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InsufficientLicenseException Class
Resto.Front.Api.Exceptions Namespace


InsufficientLicenseException Methods

The InsufficientLicenseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InsufficientLicenseException Class
Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Class

The exception that is thrown on calling unlicensed operation.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsLicenseRestrictionException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class LicenseRestrictionException : FrontApiException

The LicenseRestrictionException type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseRestrictionException | Initializes a new instance of the LicenseRestrictionException class.
Public method | LicenseRestrictionException(String) | Initializes a new instance of the LicenseRestrictionException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Constructor

Overload List
 | Name | Description
Public method | LicenseRestrictionException | Initializes a new instance of the LicenseRestrictionException class.
Public method | LicenseRestrictionException(String) | Initializes a new instance of the LicenseRestrictionException class with a specified error message.
Top
See Also

Reference

LicenseRestrictionException Class
Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Constructor

Initializes a new instance of the LicenseRestrictionException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LicenseRestrictionException()
See Also

Reference

LicenseRestrictionException Class
LicenseRestrictionException Overload
Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Constructor (String)

Initializes a new instance of the LicenseRestrictionException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public LicenseRestrictionException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

LicenseRestrictionException Class
LicenseRestrictionException Overload
Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Properties

The LicenseRestrictionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

LicenseRestrictionException Class
Resto.Front.Api.Exceptions Namespace


LicenseRestrictionException Methods

The LicenseRestrictionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

LicenseRestrictionException Class
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Class

The exception that is thrown when the operation results in an order which has no mandatory order type.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsEntityUsingException
Resto.Front.Api.ExceptionsOrderWithoutTypeException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class OrderWithoutTypeException : EntityUsingException

The OrderWithoutTypeException type exposes the following members.

Constructors
 | Name | Description
Public method | OrderWithoutTypeException(Guid) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id.
Public method | OrderWithoutTypeException(Guid, String, Exception) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id, error message and a reference to the inner exception that is the cause of this exception.
Public method | OrderWithoutTypeException(Guid, String, Object) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id and error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Constructor

Overload List
 | Name | Description
Public method | OrderWithoutTypeException(Guid) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id.
Public method | OrderWithoutTypeException(Guid, String, Exception) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id, error message and a reference to the inner exception that is the cause of this exception.
Public method | OrderWithoutTypeException(Guid, String, Object) | Initializes a new instance of the OrderWithoutTypeException class with a specified order id and error message.
Top
See Also

Reference

OrderWithoutTypeException Class
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Constructor (Guid)

Initializes a new instance of the OrderWithoutTypeException class with a specified order id.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public OrderWithoutTypeException(
    Guid entityId
)

Parameters

entityId
Type: SystemGuid
See Also

Reference

OrderWithoutTypeException Class
OrderWithoutTypeException Overload
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Constructor (Guid, String, Exception)

Initializes a new instance of the OrderWithoutTypeException class with a specified order id, error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public OrderWithoutTypeException(
    Guid entityId,
    string message,
    Exception innerException
)

Parameters

entityId
Type: SystemGuid
message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

OrderWithoutTypeException Class
OrderWithoutTypeException Overload
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Constructor (Guid, String, Object[])

OrderWithoutTypeException Constructor (Guid, String, Object)

Initializes a new instance of the OrderWithoutTypeException class with a specified order id and error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public OrderWithoutTypeException(
    Guid entityId,
    string messageFormat,
    params Object[] args
)

Parameters

entityId
Type: SystemGuid
messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

OrderWithoutTypeException Class
OrderWithoutTypeException Overload
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Properties

The OrderWithoutTypeException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | EntityId | Identifier of entity which usage caused this exception. (Inherited from EntityUsingException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OrderWithoutTypeException Class
Resto.Front.Api.Exceptions Namespace


OrderWithoutTypeException Methods

The OrderWithoutTypeException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from EntityUsingException.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OrderWithoutTypeException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionCancelledException Class

Exception to notify that payment action was cancelled.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPaymentActionCancelledException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PaymentActionCancelledException : FrontApiException

The PaymentActionCancelledException type exposes the following members.

Constructors
 | Name | Description
Public method | PaymentActionCancelledException | Initializes a new instance of the PaymentActionCancelledException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Remarks
Used for cancellation of operation when the reason of cancellation is obvious.
For example, user pressed "Cancel" button during collecting of required data - it's clear that operation will not be resumed.
No message box will be shown.
If the reason is not obvious, use PaymentActionFailedException that will show message box for user.
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PaymentActionCancelledException Constructor

Initializes a new instance of the PaymentActionCancelledException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentActionCancelledException()
See Also

Reference

PaymentActionCancelledException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionCancelledException Properties

The PaymentActionCancelledException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentActionCancelledException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionCancelledException Methods

The PaymentActionCancelledException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentActionCancelledException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Class

Exception to notify that payment, cancel payment or return payment actions was not successful.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPaymentActionFailedException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PaymentActionFailedException : FrontApiException

The PaymentActionFailedException type exposes the following members.

Constructors
 | Name | Description
Public method | PaymentActionFailedException | Initializes a new instance of the PaymentActionFailedException class.
Public method | PaymentActionFailedException(String) | Initializes a new instance of the PaymentActionFailedException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Constructor

Overload List
 | Name | Description
Public method | PaymentActionFailedException | Initializes a new instance of the PaymentActionFailedException class.
Public method | PaymentActionFailedException(String) | Initializes a new instance of the PaymentActionFailedException class with a specified error message.
Top
See Also

Reference

PaymentActionFailedException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Constructor

Initializes a new instance of the PaymentActionFailedException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentActionFailedException()
See Also

Reference

PaymentActionFailedException Class
PaymentActionFailedException Overload
Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Constructor (String)

Initializes a new instance of the PaymentActionFailedException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentActionFailedException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

PaymentActionFailedException Class
PaymentActionFailedException Overload
Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Properties

The PaymentActionFailedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentActionFailedException Class
Resto.Front.Api.Exceptions Namespace


PaymentActionFailedException Methods

The PaymentActionFailedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentActionFailedException Class
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Class

The exception that is thrown when a specified payment system was not registered.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPaymentSystemRegistrationException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PaymentSystemRegistrationException : FrontApiException

The PaymentSystemRegistrationException type exposes the following members.

Constructors
 | Name | Description
Public method | PaymentSystemRegistrationException | Initializes a new instance of the PaymentSystemRegistrationException class.
Public method | PaymentSystemRegistrationException(String, Exception) | Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PaymentSystemRegistrationException(String, Object) | Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Constructor

Overload List
 | Name | Description
Public method | PaymentSystemRegistrationException | Initializes a new instance of the PaymentSystemRegistrationException class.
Public method | PaymentSystemRegistrationException(String, Exception) | Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PaymentSystemRegistrationException(String, Object) | Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message.
Top
See Also

Reference

PaymentSystemRegistrationException Class
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Constructor

Initializes a new instance of the PaymentSystemRegistrationException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentSystemRegistrationException()
See Also

Reference

PaymentSystemRegistrationException Class
PaymentSystemRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Constructor (String, Exception)

Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentSystemRegistrationException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

PaymentSystemRegistrationException Class
PaymentSystemRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Constructor (String, Object[])

PaymentSystemRegistrationException Constructor (String, Object)

Initializes a new instance of the PaymentSystemRegistrationException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentSystemRegistrationException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

PaymentSystemRegistrationException Class
PaymentSystemRegistrationException Overload
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Properties

The PaymentSystemRegistrationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentSystemRegistrationException Class
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Methods

The PaymentSystemRegistrationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentSystemRegistrationException Class
Resto.Front.Api.Exceptions Namespace


PaymentSystemRegistrationException Events

The PaymentSystemRegistrationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentSystemRegistrationException Class
Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException Class

The exception that is thrown when a specified payment type is not well configured.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPaymentTypeConfigurationException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PaymentTypeConfigurationException : FrontApiException

The PaymentTypeConfigurationException type exposes the following members.

Constructors
 | Name | Description
Public method | PaymentTypeConfigurationException | Initializes a new instance of the PaymentTypeConfigurationException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | PaymentTypeId | Gets the misconfigured payment type id.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException Constructor

Initializes a new instance of the PaymentTypeConfigurationException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PaymentTypeConfigurationException(
    Guid paymentTypeId,
    string message
)

Parameters

paymentTypeId
Type: SystemGuid
The payment type id.
message
Type: SystemString
The error message (optional).
See Also

Reference

PaymentTypeConfigurationException Class
Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException Properties

The PaymentTypeConfigurationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | PaymentTypeId | Gets the misconfigured payment type id.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentTypeConfigurationException Class
Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException.PaymentTypeId Property

PaymentTypeConfigurationExceptionPaymentTypeId Property

Gets the misconfigured payment type id.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public Guid PaymentTypeId { get; }

Property Value

Type: Guid
The payment type id.
See Also

Reference

PaymentTypeConfigurationException Class
Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException Methods

The PaymentTypeConfigurationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PaymentTypeConfigurationException Class
Resto.Front.Api.Exceptions Namespace


PaymentTypeConfigurationException.GetObjectData Method

PaymentTypeConfigurationExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

PaymentTypeConfigurationException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Class

The exception that is thrown on trying to execute operation without having required permissions.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPermissionDeniedException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PermissionDeniedException : FrontApiException

The PermissionDeniedException type exposes the following members.

Constructors
 | Name | Description
Public method | PermissionDeniedException | Initializes a new instance of the PermissionDeniedException class.
Public method | PermissionDeniedException(String, Exception) | Initializes a new instance of the PermissionDeniedException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PermissionDeniedException(String, String, String) | Initializes a new instance of the PermissionDeniedException class with a specified error message. The error message (optional).Codes of permissions.Localized names of permissions.
Top
Properties
 | Name | Description
Public property | Codes | Gets codes of permissions.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LocalNames | Gets localized names of permissions.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Constructor

Overload List
 | Name | Description
Public method | PermissionDeniedException | Initializes a new instance of the PermissionDeniedException class.
Public method | PermissionDeniedException(String, Exception) | Initializes a new instance of the PermissionDeniedException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PermissionDeniedException(String, String, String) | Initializes a new instance of the PermissionDeniedException class with a specified error message. The error message (optional).Codes of permissions.Localized names of permissions.
Top
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Constructor

Initializes a new instance of the PermissionDeniedException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PermissionDeniedException()
See Also

Reference

PermissionDeniedException Class
PermissionDeniedException Overload
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Constructor (String, Exception)

Initializes a new instance of the PermissionDeniedException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PermissionDeniedException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

PermissionDeniedException Class
PermissionDeniedException Overload
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Constructor (String, String[], String[])

PermissionDeniedException Constructor (String, String, String)

Initializes a new instance of the PermissionDeniedException class with a specified error message. The error message (optional).Codes of permissions.Localized names of permissions.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PermissionDeniedException(
    string message,
    string[] codes = null,
    string[] localNames = null
)

Parameters

message
Type: SystemString
codes (Optional)
Type: SystemString
localNames (Optional)
Type: SystemString
See Also

Reference

PermissionDeniedException Class
PermissionDeniedException Overload
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Properties

The PermissionDeniedException type exposes the following members.

Properties
 | Name | Description
Public property | Codes | Gets codes of permissions.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LocalNames | Gets localized names of permissions.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException.Codes Property

PermissionDeniedExceptionCodes Property

Gets codes of permissions.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string[] Codes { get; }

Property Value

Type: String
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException.LocalNames Property

PermissionDeniedExceptionLocalNames Property

Gets localized names of permissions.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string[] LocalNames { get; }

Property Value

Type: String
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException Methods

The PermissionDeniedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PermissionDeniedException.GetObjectData Method

PermissionDeniedExceptionGetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | The info parameter is a null reference ( in Visual Basic).
SecurityException | The caller does not have the required permission.
See Also

Reference

PermissionDeniedException Class
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Class

The exception that is thrown when plugin settings operation fails.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPluginSettingsException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class PluginSettingsException : FrontApiException

The PluginSettingsException type exposes the following members.

Constructors
 | Name | Description
Public method | PluginSettingsException | Initializes a new instance of the PluginSettingsException class.
Public method | PluginSettingsException(String, Exception) | Initializes a new instance of the PluginSettingsException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PluginSettingsException(String, Object) | Initializes a new instance of the PluginSettingsException class with a specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PluginSettingsException Constructor

Overload List
 | Name | Description
Public method | PluginSettingsException | Initializes a new instance of the PluginSettingsException class.
Public method | PluginSettingsException(String, Exception) | Initializes a new instance of the PluginSettingsException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Public method | PluginSettingsException(String, Object) | Initializes a new instance of the PluginSettingsException class with a specified error message.
Top
See Also

Reference

PluginSettingsException Class
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Constructor

Initializes a new instance of the PluginSettingsException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PluginSettingsException()
See Also

Reference

PluginSettingsException Class
PluginSettingsException Overload
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Constructor (String, Exception)

Initializes a new instance of the PluginSettingsException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PluginSettingsException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

PluginSettingsException Class
PluginSettingsException Overload
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Constructor (String, Object[])

PluginSettingsException Constructor (String, Object)

Initializes a new instance of the PluginSettingsException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PluginSettingsException(
    string messageFormat,
    params Object[] args
)

Parameters

messageFormat
Type: SystemString
args
Type: SystemObject
See Also

Reference

PluginSettingsException Class
PluginSettingsException Overload
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Properties

The PluginSettingsException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PluginSettingsException Class
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Methods

The PluginSettingsException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PluginSettingsException Class
Resto.Front.Api.Exceptions Namespace


PluginSettingsException Events

The PluginSettingsException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

PluginSettingsException Class
Resto.Front.Api.Exceptions Namespace


PreliminaryOrderEditTemporaryUnavailableException Class

The exception that is thrown when a preliminary order edit temporarily cannot be executed due to networking issues.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsPreliminaryOrderEditTemporaryUnavailableException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class PreliminaryOrderEditTemporaryUnavailableException : FrontApiException

The PreliminaryOrderEditTemporaryUnavailableException type exposes the following members.

Constructors
 | Name | Description
Public method | PreliminaryOrderEditTemporaryUnavailableException | Initializes a new instance of the PreliminaryOrderEditTemporaryUnavailableException class with specified error message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


PreliminaryOrderEditTemporaryUnavailableException Constructor

Initializes a new instance of the PreliminaryOrderEditTemporaryUnavailableException class with specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public PreliminaryOrderEditTemporaryUnavailableException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

PreliminaryOrderEditTemporaryUnavailableException Class
Resto.Front.Api.Exceptions Namespace


PreliminaryOrderEditTemporaryUnavailableException Properties

The PreliminaryOrderEditTemporaryUnavailableException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

PreliminaryOrderEditTemporaryUnavailableException Class
Resto.Front.Api.Exceptions Namespace


PreliminaryOrderEditTemporaryUnavailableException Methods

The PreliminaryOrderEditTemporaryUnavailableException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

PreliminaryOrderEditTemporaryUnavailableException Class
Resto.Front.Api.Exceptions Namespace


ReportBuildException Class

The exception that is thrown when a specified report could not be built.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsReportBuildException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ReportBuildException : FrontApiException

The ReportBuildException type exposes the following members.

Constructors
 | Name | Description
Public method | ReportBuildException | Initializes a new instance of the ReportBuildException class.
Public method | ReportBuildException(String) | Initializes a new instance of the ReportBuildException class with a specified error message.
Public method | ReportBuildException(String, Exception) | Initializes a new instance of the ReportBuildException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ReportBuildException Constructor

Overload List
 | Name | Description
Public method | ReportBuildException | Initializes a new instance of the ReportBuildException class.
Public method | ReportBuildException(String) | Initializes a new instance of the ReportBuildException class with a specified error message.
Public method | ReportBuildException(String, Exception) | Initializes a new instance of the ReportBuildException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ReportBuildException Class
Resto.Front.Api.Exceptions Namespace


ReportBuildException Constructor

Initializes a new instance of the ReportBuildException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ReportBuildException()
See Also

Reference

ReportBuildException Class
ReportBuildException Overload
Resto.Front.Api.Exceptions Namespace


ReportBuildException Constructor (String)

Initializes a new instance of the ReportBuildException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ReportBuildException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

ReportBuildException Class
ReportBuildException Overload
Resto.Front.Api.Exceptions Namespace


ReportBuildException Constructor (String, Exception)

Initializes a new instance of the ReportBuildException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ReportBuildException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

ReportBuildException Class
ReportBuildException Overload
Resto.Front.Api.Exceptions Namespace


ReportBuildException Properties

The ReportBuildException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ReportBuildException Class
Resto.Front.Api.Exceptions Namespace


ReportBuildException Methods

The ReportBuildException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ReportBuildException Class
Resto.Front.Api.Exceptions Namespace


ReportBuildException Events

The ReportBuildException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ReportBuildException Class
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Class

The exception that is thrown when message wasn't sent due to connection troubles.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsServerConnectionException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ServerConnectionException : FrontApiException

The ServerConnectionException type exposes the following members.

Constructors
 | Name | Description
Public method | ServerConnectionException | Initializes a new instance of the ServerConnectionException class.
Public method | ServerConnectionException(String) | Initializes a new instance of the ServerConnectionException class with a specified error message.
Public method | ServerConnectionException(String, Exception) | Initializes a new instance of the ServerConnectionException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


ServerConnectionException Constructor

Overload List
 | Name | Description
Public method | ServerConnectionException | Initializes a new instance of the ServerConnectionException class.
Public method | ServerConnectionException(String) | Initializes a new instance of the ServerConnectionException class with a specified error message.
Public method | ServerConnectionException(String, Exception) | Initializes a new instance of the ServerConnectionException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

ServerConnectionException Class
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Constructor

Initializes a new instance of the ServerConnectionException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ServerConnectionException()
See Also

Reference

ServerConnectionException Class
ServerConnectionException Overload
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Constructor (String)

Initializes a new instance of the ServerConnectionException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ServerConnectionException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

ServerConnectionException Class
ServerConnectionException Overload
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Constructor (String, Exception)

Initializes a new instance of the ServerConnectionException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ServerConnectionException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

ServerConnectionException Class
ServerConnectionException Overload
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Properties

The ServerConnectionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ServerConnectionException Class
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Methods

The ServerConnectionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

ServerConnectionException Class
Resto.Front.Api.Exceptions Namespace


ServerConnectionException Events

The ServerConnectionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ServerConnectionException Class
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Class

The exception that is sent into OnError(Exception) handler of the notification stream from Notifications when the underlying event source throws unexpected exception.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsUnexpectedInternalException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public sealed class UnexpectedInternalException : FrontApiException

The UnexpectedInternalException type exposes the following members.

Constructors
 | Name | Description
Public method | UnexpectedInternalException | Initializes a new instance of the UnexpectedInternalException class.
Public method | UnexpectedInternalException(String) | Initializes a new instance of the UnexpectedInternalException class with a specified error message.
Public method | UnexpectedInternalException(String, Exception) | Initializes a new instance of the UnexpectedInternalException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Remarks
The original exception generally cannot be rethrown as-is because of inter-process serialization issues. See the cash-server.log file for original exception details.
See Also

Reference

Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Constructor

Overload List
 | Name | Description
Public method | UnexpectedInternalException | Initializes a new instance of the UnexpectedInternalException class.
Public method | UnexpectedInternalException(String) | Initializes a new instance of the UnexpectedInternalException class with a specified error message.
Public method | UnexpectedInternalException(String, Exception) | Initializes a new instance of the UnexpectedInternalException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

UnexpectedInternalException Class
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Constructor

Initializes a new instance of the UnexpectedInternalException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UnexpectedInternalException()
See Also

Reference

UnexpectedInternalException Class
UnexpectedInternalException Overload
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Constructor (String)

Initializes a new instance of the UnexpectedInternalException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UnexpectedInternalException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

UnexpectedInternalException Class
UnexpectedInternalException Overload
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Constructor (String, Exception)

Initializes a new instance of the UnexpectedInternalException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UnexpectedInternalException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

UnexpectedInternalException Class
UnexpectedInternalException Overload
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Properties

The UnexpectedInternalException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnexpectedInternalException Class
Resto.Front.Api.Exceptions Namespace


UnexpectedInternalException Methods

The UnexpectedInternalException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnexpectedInternalException Class
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Class

Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsUserPersonalSessionNotOpenedException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class UserPersonalSessionNotOpenedException : Exception

The UserPersonalSessionNotOpenedException type exposes the following members.

Constructors
 | Name | Description
Public method | UserPersonalSessionNotOpenedException | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Public method | UserPersonalSessionNotOpenedException(String) | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Public method | UserPersonalSessionNotOpenedException(String, Exception) | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Constructor

Overload List
 | Name | Description
Public method | UserPersonalSessionNotOpenedException | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Public method | UserPersonalSessionNotOpenedException(String) | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Public method | UserPersonalSessionNotOpenedException(String, Exception) | Initializes a new instance of the UserPersonalSessionNotOpenedException class
Top
See Also

Reference

UserPersonalSessionNotOpenedException Class
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Constructor

Initializes a new instance of the UserPersonalSessionNotOpenedException class

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserPersonalSessionNotOpenedException()
See Also

Reference

UserPersonalSessionNotOpenedException Class
UserPersonalSessionNotOpenedException Overload
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Constructor (String)

Initializes a new instance of the UserPersonalSessionNotOpenedException class

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserPersonalSessionNotOpenedException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

UserPersonalSessionNotOpenedException Class
UserPersonalSessionNotOpenedException Overload
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Constructor (String, Exception)

Initializes a new instance of the UserPersonalSessionNotOpenedException class

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserPersonalSessionNotOpenedException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

UserPersonalSessionNotOpenedException Class
UserPersonalSessionNotOpenedException Overload
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Properties

The UserPersonalSessionNotOpenedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UserPersonalSessionNotOpenedException Class
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Methods

The UserPersonalSessionNotOpenedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UserPersonalSessionNotOpenedException Class
Resto.Front.Api.Exceptions Namespace


UserPersonalSessionNotOpenedException Events

The UserPersonalSessionNotOpenedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

UserPersonalSessionNotOpenedException Class
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Class

The exception that is thrown on trying to use credentials that doesn't correspond to valid user session. Session may become outdated if user is deactivated or his pin is changed since session start.
Inheritance Hierarchy
SystemObject
SystemException
Resto.Front.Api.ExceptionsFrontApiException
Resto.Front.Api.ExceptionsUserSessionInvalidException

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class UserSessionInvalidException : FrontApiException

The UserSessionInvalidException type exposes the following members.

Constructors
 | Name | Description
Public method | UserSessionInvalidException | Initializes a new instance of the UserSessionInvalidException class.
Public method | UserSessionInvalidException(String) | Initializes a new instance of the UserSessionInvalidException class with a specified error message.
Public method | UserSessionInvalidException(String, Exception) | Initializes a new instance of the UserSessionInvalidException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Resto.Front.Api.Exceptions Namespace
IOperationServiceAuthenticateByPin(String)


UserSessionInvalidException Constructor

Overload List
 | Name | Description
Public method | UserSessionInvalidException | Initializes a new instance of the UserSessionInvalidException class.
Public method | UserSessionInvalidException(String) | Initializes a new instance of the UserSessionInvalidException class with a specified error message.
Public method | UserSessionInvalidException(String, Exception) | Initializes a new instance of the UserSessionInvalidException class with a specified error message and a reference to the inner exception that is the cause of this exception.
Top
See Also

Reference

UserSessionInvalidException Class
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Constructor

Initializes a new instance of the UserSessionInvalidException class.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserSessionInvalidException()
See Also

Reference

UserSessionInvalidException Class
UserSessionInvalidException Overload
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Constructor (String)

Initializes a new instance of the UserSessionInvalidException class with a specified error message.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserSessionInvalidException(
    string message
)

Parameters

message
Type: SystemString
See Also

Reference

UserSessionInvalidException Class
UserSessionInvalidException Overload
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Constructor (String, Exception)

Initializes a new instance of the UserSessionInvalidException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Resto.Front.Api.Exceptions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public UserSessionInvalidException(
    string message,
    Exception innerException
)

Parameters

message
Type: SystemString
innerException
Type: SystemException
See Also

Reference

UserSessionInvalidException Class
UserSessionInvalidException Overload
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Properties

The UserSessionInvalidException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UserSessionInvalidException Class
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Methods

The UserSessionInvalidException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UserSessionInvalidException Class
Resto.Front.Api.Exceptions Namespace


UserSessionInvalidException Events

The UserSessionInvalidException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

UserSessionInvalidException Class
Resto.Front.Api.Exceptions Namespace


Resto.Front.Api.Extensions Namespace

Classes
 | Class | Description
Public class | EditSessionExtensions | A set of helper methods for IEditSession.
Public class | OperationServiceExtensions | Provides a set of static methods for executing operations.
Public class | PaymentDataContextExtensions |
Public class | ServiceProviderExtensions | Extension methods for IServiceProvider.
Public class | ViewManagerExtensions | Provides a set of static methods for executing view manager.


EditSessionExtensions Class

A set of helper methods for IEditSession.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.ExtensionsEditSessionExtensions

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class EditSessionExtensions

The EditSessionExtensions type exposes the following members.

Methods
Name | Description
ChangeReserveTable | Changes reserving table.
CreateBanquet | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
CreateOrder | Creates new order on specified table. User must have rights to create orders.
CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
Top
See Also

Reference

Resto.Front.Api.Extensions Namespace


EditSessionExtensions Methods

The EditSessionExtensions type exposes the following members.

Methods
Name | Description
ChangeReserveTable | Changes reserving table.
CreateBanquet | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
CreateOrder | Creates new order on specified table. User must have rights to create orders.
CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
Top
See Also

Reference

EditSessionExtensions Class
Resto.Front.Api.Extensions Namespace


EditSessionExtensions.ChangeReserveTable Method

EditSessionExtensionsChangeReserveTable Method

Changes reserving table.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveTable(
    this IEditSession editSession,
    ITable table,
    IReserveStub reserve
)

Parameters

editSession
Type: Resto.Front.Api.EditorsIEditSession
Order will be created within the specified session.
table
Type: Resto.Front.Api.Data.Organization.SectionsITable
Specifies table to be reserved at some moment in future.
reserve
Type: Resto.Front.Api.Editors.StubsIReserveStub
Reserve to edit.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEditSession. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EditSessionExtensions Class
Resto.Front.Api.Extensions Namespace


EditSessionExtensions.CreateBanquet Method

EditSessionExtensionsCreateBanquet Method

Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static INewReserveStub CreateBanquet(
    this IEditSession editSession,
    DateTime estimatedStartTime,
    IClientStub client,
    ITable table,
    Guid externalId = default
)

Parameters

editSession
Type: Resto.Front.Api.EditorsIEditSession
Order will be created within the specified session.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned event, used to divide different events and remind staff to prepare table and ingredients.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who asked to reserve table for his event.
table
Type: Resto.Front.Api.Data.Organization.SectionsITable
Specifies table to be reserved at some moment in future.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: INewReserveStub

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEditSession. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EditSessionExtensions Class
Resto.Front.Api.Extensions Namespace


EditSessionExtensions.CreateOrder Method

EditSessionExtensionsCreateOrder Method

Creates new order on specified table. User must have rights to create orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static INewOrderStub CreateOrder(
    this IEditSession editSession,
    ITable table
)

Parameters

editSession
Type: Resto.Front.Api.EditorsIEditSession
Order will be created within the specified session.
table
Type: Resto.Front.Api.Data.Organization.SectionsITable
Table on which order will be created. If table is null, then order will be created on the default table (depending on select iikoFront mode).

Return Value

Type: INewOrderStub

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEditSession. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EditSessionExtensions Class
Resto.Front.Api.Extensions Namespace


EditSessionExtensions.CreateReserve Method

EditSessionExtensionsCreateReserve Method

Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static INewReserveStub CreateReserve(
    this IEditSession editSession,
    DateTime estimatedStartTime,
    IClientStub client,
    ITable table,
    Guid externalId = default
)

Parameters

editSession
Type: Resto.Front.Api.EditorsIEditSession
Order will be created within the specified session.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned visit, used to divide different visits and remind staff to prepare table.
client
Type: Resto.Front.Api.Editors.StubsIClientStub
Client who asked to reserve table for him.
table
Type: Resto.Front.Api.Data.Organization.SectionsITable
Specifies table to be reserved at some moment in future.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: INewReserveStub

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEditSession. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EditSessionExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions Class

Provides a set of static methods for executing operations.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.ExtensionsOperationServiceExtensions

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class OperationServiceExtensions

The OperationServiceExtensions type exposes the following members.

Methods
Name | Description
AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
AddDiscountByCardNumber | Add discount by card number.
AddExternalFiscalizedPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new externally fiscalized payment item to order.
AddExternalFiscalizedPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new external fiscalized payment item to order.
AddExternalPaymentItem(IOperationService, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
AddExternalPaymentItem(IOperationService, Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
AddFlexibleSumDiscountByCardNumber | Add discount by card number.
AddIikoCardDiscounts | Adds discounts grouped by order items.
AddOrderCombo | Create order combo item. Order must contain new combo items.
AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(IOperationService, String, IOrder, ICredentials) to delete the data when it's no longer needed.
AddOrderGuest(IOperationService, String, IOrder, ICredentials) | Adds new guest to existing order. User must have rights to edit orders.
AddOrderGuest(IOperationService, Guid, String, IOrder, ICredentials) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
AddOrderProductItem(IOperationService, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
AddOrderProductItem(IOperationService, Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders.
AddPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
AddPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
AddPreliminaryPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
AddPreliminaryPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order.
ChangeClientAddresses | Changes client addresses.
ChangeClientBirthDate | Changes client's birth date.
ChangeClientBlacklistInfo | Changes client blacklist info.
ChangeClientCardNumber | Changes client card number.
ChangeClientComment | Changes client comment.
ChangeClientConsentDates | Changes client's dates of consent.
ChangeClientEmails | Changes client emails list.
ChangeClientGender | Change client's gender.
ChangeClientIikoBizId | Changes client's account in iiko.biz.
ChangeClientLastOrderDate | Changes client's last order date.
ChangeClientLinkedCounteragent | Changes client linked counter agent.
ChangeClientMainAddressIndex | Changes client main address index.
ChangeClientMarketingSource | Changes client marketing source.
ChangeClientName | Changes client name.
ChangeClientNick | Changes client nickname.
ChangeClientOrganizationDetailsInfo | Changes organization details information of client.
ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data.
ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent.
ChangeClientPhones | Changes client phones list.
ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages.
ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages.
ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages.
ChangeClientSurname | Changes client surname.
ChangeComboAmount | Change combo amount.
ChangeComboPrice | Change combo price.
ChangeCookingPriority | Changes custom cooking priority and top priority flag.
ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered.
ChangeDeliveryAddress | Changes address of delivery
ChangeDeliveryClientName | Change name of delivery client.
ChangeDeliveryComment | Change the order comment.
ChangeDeliveryConfirmTime | Changes delivery confirmation state and time.
ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered.
ChangeDeliveryCustomApiData | Change the delivery custom data from api.
ChangeDeliveryDuration | Change duration of delivery processing.
ChangeDeliveryEmail | Change the order e-mail.
ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered.
ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal.
ChangeDeliveryExternalCourier | Changes external courier for delivery.
ChangeDeliveryExternalCourierService | Changes external courier service for delivery.
ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server.
ChangeDeliveryLocation | Changes delivery address location.
ChangeDeliveryMarketingSource | Assign/change order marketing source.
ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal.
ChangeDeliveryOperator | Assign/change the order operator.
ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.
ChangeDeliveryPhone | Changes the order phone.
ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.
ChangeDeliveryProblemComment | Change the order problem comment.
ChangeDeliveryProblemStatus | Change the order problem status.
ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons.
ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.
ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item.
ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order.
ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders.
ChangeOrderCookingItemCourse | Changes the course of the order item.
ChangeOrderCookingItemSize | Changes the product size of the order item.
ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system.
ChangeOrderItemComment | Changes product order item's comment.
ChangeOrderItemWaiter | Changes product order item's waiter.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.
ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time.
ChangeOrderTables | Changes tables of the order.
ChangeOrderWaiter | Changes order's waiter.
ChangePaymentItemCustomData | Changes custom data of existing payment item.
ChangePaymentItemSum | Changes sum of existing payment item.
ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item.
ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item.
ChangePriceCategory | Changes price category of the order.
ChangeReserveComment | Changes reserve comment. Use empty string to clear comment.
ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.
ChangeReserveEstimatedStartTime | Changes estimated reserve start time.
ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2.
ChangeReserveReminder | Changes reserve reminder flag.
ChangeReserveTables | Changes reserving tables.
ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.
ChangeStreetName | Changes street's name.
CreateBanquet(IOperationService, DateTime, IClient, IOrder, ICredentials, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
CreateBanquet(IOperationService, DateTime, IClient, IReadOnlyListITable, ICredentials, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
CreateClient | Creates new client. The client must have a card number or at least one phone number.
CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info.
CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
CreateStreet(IOperationService, String, ICredentials) | Creates new street.
CreateStreet(IOperationService, Guid, String, ICity, ICredentials) | Creates new street.
DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts.
DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order.
DeleteExternalPaymentItem | Delete existing external payment item from order.
DeleteOrderCombo | Delete order combo item.
DeleteOrderExternalData | Deletes external data from the order.
DeleteOrderGuest | Deletes guest without any products from order.
DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders.
DeleteOrderItemComment | Deletes product order item's comment.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrRestoreStreet | Deletes street.
DeletePaymentItem | Delete existing payment item from order.
DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order.
DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders.
DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders.
GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.
MarkOrderAsTab | Marks the order as tab and assignes tab name.
MoveOrderItemToAnotherGuest | Moves product item between guests of the same order.
MoveOrderItemToAnotherOrder | Moves product item between orders.
OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order.
RenameOrderGuest | Renames order's guest.
ReopenReserve | Reopens previously closed or canceled reserve.
ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.
ResetPriceCategory | Resets price category of the order.
ServeOrderCookingItem | Mark order item product as served.
SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders.
SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.
SetDeliveryDelivered | Change delivery status to delivered.
SetDeliveryUndelivered | Change delivery status to OnWay from status delivered.
SetOpenPrice | Changes order item open price.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Sets the custom name of the product item modifier. User must have rights to edit orders.
SetOrderType | Sets order type for order.
SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders.
SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders.
SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders.
SplitOrderCookingItem | Cut off specified amount from product to new one.
StartBanquet | Transits banquet to the started status.
UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently.
UnserveOrderCookingItem | Mark order item product as unserved.
UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items.
Top
See Also

Reference

Resto.Front.Api.Extensions Namespace


OperationServiceExtensions Methods

The OperationServiceExtensions type exposes the following members.

Methods
Name | Description
AddDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
AddDiscountByCardNumber | Add discount by card number.
AddExternalFiscalizedPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new externally fiscalized payment item to order.
AddExternalFiscalizedPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new external fiscalized payment item to order.
AddExternalPaymentItem(IOperationService, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
AddExternalPaymentItem(IOperationService, Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
AddFlexibleSumDiscount | Adds simple discount of known type to existing order. User must have rights to work with discounts.
AddFlexibleSumDiscountByCardNumber | Add discount by card number.
AddIikoCardDiscounts | Adds discounts grouped by order items.
AddOrderCombo | Create order combo item. Order must contain new combo items.
AddOrderExternalData | Adds external data to the order. Use DeleteOrderExternalData(IOperationService, String, IOrder, ICredentials) to delete the data when it's no longer needed.
AddOrderGuest(IOperationService, String, IOrder, ICredentials) | Adds new guest to existing order. User must have rights to edit orders.
AddOrderGuest(IOperationService, Guid, String, IOrder, ICredentials) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
AddOrderProductItem(IOperationService, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
AddOrderProductItem(IOperationService, Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
AddOrderServiceItem | Adds time pay service item to the guest in existing order. User must have permission to edit orders.
AddPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
AddPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
AddPreliminaryPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
AddPreliminaryPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
BindReserveToOrder | Converts exising reserve or banquet without order to banquet with order.
ChangeClientAddresses | Changes client addresses.
ChangeClientBirthDate | Changes client's birth date.
ChangeClientBlacklistInfo | Changes client blacklist info.
ChangeClientCardNumber | Changes client card number.
ChangeClientComment | Changes client comment.
ChangeClientConsentDates | Changes client's dates of consent.
ChangeClientEmails | Changes client emails list.
ChangeClientGender | Change client's gender.
ChangeClientIikoBizId | Changes client's account in iiko.biz.
ChangeClientLastOrderDate | Changes client's last order date.
ChangeClientLinkedCounteragent | Changes client linked counter agent.
ChangeClientMainAddressIndex | Changes client main address index.
ChangeClientMarketingSource | Changes client marketing source.
ChangeClientName | Changes client name.
ChangeClientNick | Changes client nickname.
ChangeClientOrganizationDetailsInfo | Changes organization details information of client.
ChangeClientPersonalDataConsent | Changes whether client consented processing their personal data.
ChangeClientPersonalDataProcessingDates | Changes dates of the time interval which allows client's legal personal data processing without thier consent.
ChangeClientPhones | Changes client phones list.
ChangeClientReceivesLoyaltySystemNotifications | Changes whether client receives loyalty system notification messages.
ChangeClientReceivesOrderStatusNotifications | Changes whether client receives order status notification messages.
ChangeClientReceivesPromotionalNotifications | Changes whether client receives promotional notification messages.
ChangeClientSurname | Changes client surname.
ChangeComboAmount | Change combo amount.
ChangeComboPrice | Change combo price.
ChangeCookingPriority | Changes custom cooking priority and top priority flag.
ChangeDeliveryActualDeliverTime | Change time when the order was actually delivered.
ChangeDeliveryAddress | Changes address of delivery
ChangeDeliveryClientName | Change name of delivery client.
ChangeDeliveryComment | Change the order comment.
ChangeDeliveryConfirmTime | Changes delivery confirmation state and time.
ChangeDeliveryCourier | Assign/Change the order courier. Can use this action only before the order is to be delivered.
ChangeDeliveryCustomApiData | Change the delivery custom data from api.
ChangeDeliveryDuration | Change duration of delivery processing.
ChangeDeliveryEmail | Change the order e-mail.
ChangeDeliveryExpectedDeliverTime | Change time when client wants the order to be delivered.
ChangeDeliveryExpectedDuration | Set calculated delivery duration without overrided value on terminal.
ChangeDeliveryExternalCourier | Changes external courier for delivery.
ChangeDeliveryExternalCourierService | Changes external courier service for delivery.
ChangeDeliveryLastVerifiedRestrictionsHash | Set last verified restirictions hash from server.
ChangeDeliveryLocation | Changes delivery address location.
ChangeDeliveryMarketingSource | Assign/change order marketing source.
ChangeDeliveryMovedId | Change new delivery identifier created for move to a new terminal.
ChangeDeliveryOperator | Assign/change the order operator.
ChangeDeliveryOrderPredictedCookingCompleteTime | Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.
ChangeDeliveryPhone | Changes the order phone.
ChangeDeliveryPredictedDeliveryTime | Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.
ChangeDeliveryProblemComment | Change the order problem comment.
ChangeDeliveryProblemStatus | Change the order problem status.
ChangeDeliverySplitBetweenPersons | Changes the order property if it should be splitted between persons.
ChangeEstimatedOrderGuestsCount | Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.
ChangeExternalPaymentItemCustomData | Changes custom data of existing external payment item.
ChangeOrderAppliedIikoCard5ManualConditions | Change iikoCard5 manual conditions applied for order.
ChangeOrderCookingItemAmount | Changes the amount of the assortment position in existing order. User must have rights to edit orders.
ChangeOrderCookingItemCourse | Changes the course of the order item.
ChangeOrderCookingItemSize | Changes the product size of the order item.
ChangeOrderIikoCard5Coupon | Change order iikoCard5 coupon, used in iikoCard5 system.
ChangeOrderItemComment | Changes product order item's comment.
ChangeOrderItemWaiter | Changes product order item's waiter.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
ChangeOrderOriginName | Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.
ChangeOrderPricingTime | Change order pricing time, which determines the price of products. By default time taken from items print time.
ChangeOrderTables | Changes tables of the order.
ChangeOrderWaiter | Changes order's waiter.
ChangePaymentItemCustomData | Changes custom data of existing payment item.
ChangePaymentItemSum | Changes sum of existing payment item.
ChangePreliminaryPaymentItemCustomData | Changes custom data of existing preliminary payment item.
ChangePreliminaryPaymentItemSum | Changes sum of existing preliminary payment item.
ChangePriceCategory | Changes price category of the order.
ChangeReserveComment | Changes reserve comment. Use empty string to clear comment.
ChangeReserveDuration | Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.
ChangeReserveEstimatedStartTime | Changes estimated reserve start time.
ChangeReserveGuestsCount | Changes estimated guests count for reserve. Default value is 2.
ChangeReserveReminder | Changes reserve reminder flag.
ChangeReserveTables | Changes reserving tables.
ChangeSelectiveDiscount | Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.
ChangeStreetName | Changes street's name.
CreateBanquet(IOperationService, DateTime, IClient, IOrder, ICredentials, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
CreateBanquet(IOperationService, DateTime, IClient, IReadOnlyListITable, ICredentials, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
CreateClient | Creates new client. The client must have a card number or at least one phone number.
CreateClientWithOrganizationDetails | Creates new client. The client must have orgatizations details info.
CreateReserve | Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.
CreateStreet(IOperationService, String, ICredentials) | Creates new street.
CreateStreet(IOperationService, Guid, String, ICity, ICredentials) | Creates new street.
DeleteDiscount | Removes discount of known type from existing order. User must have rights to work with discounts.
DeleteExternalFiscalizedPaymentItem | Delete existing externally fiscalized payment item from order.
DeleteExternalPaymentItem | Delete existing external payment item from order.
DeleteOrderCombo | Delete order combo item.
DeleteOrderExternalData | Deletes external data from the order.
DeleteOrderGuest | Deletes guest without any products from order.
DeleteOrderItem | Deletes order item from order that represents the assortment position. User must have rights to edit orders.
DeleteOrderItemComment | Deletes product order item's comment.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrRestoreStreet | Deletes street.
DeletePaymentItem | Delete existing payment item from order.
DeletePreliminaryPaymentItem | Delete existing preliminary payment item from order.
DeletePrintedOrderItems | Deletes order items that is already printed. User must have rights to edit orders.
DeletePrintedOrderModifierItem | Deletes order item modifier that is already printed. User must have rights to edit orders.
GroupOrderCookingItems | Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.
MarkOrderAsTab | Marks the order as tab and assignes tab name.
MoveOrderItemToAnotherGuest | Moves product item between guests of the same order.
MoveOrderItemToAnotherOrder | Moves product item between orders.
OverrideVatInclusionForOrder | Overrides default VAT inclusion settings for items of the specified order.
RenameOrderGuest | Renames order's guest.
ReopenReserve | Reopens previously closed or canceled reserve.
ResetIsPrintedDeliveryBillActual | Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.
ResetPriceCategory | Resets price category of the order.
ServeOrderCookingItem | Mark order item product as served.
SetCompoundItemComponentCustomName | Sets the custom name of the compound component. User must have rights to edit orders.
SetDeliveryCustomerAuthorizedInIikoBiz | Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.
SetDeliveryDelivered | Change delivery status to delivered.
SetDeliveryUndelivered | Change delivery status to OnWay from status delivered.
SetOpenPrice | Changes order item open price.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Sets the custom name of the product item modifier. User must have rights to edit orders.
SetOrderType | Sets order type for order.
SetProductItemCustomName | Sets the custom name of the product item. User must have rights to edit orders.
SetServiceItemCustomName | Sets the custom name of the service item. User must have rights to edit orders.
SetServiceItemPeriodCustomName | Sets the custom name of the service period. User must have rights to edit orders.
SplitOrderCookingItem | Cut off specified amount from product to new one.
StartBanquet | Transits banquet to the started status.
UngroupOrderCookingItems | Separates the order item products from mix group so that they will be cooked independently.
UnserveOrderCookingItem | Mark order item product as unserved.
UpdateOrderComboItems | Update existing order combo items. Order must contain new combo items.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddDiscount Method

OperationServiceExtensionsAddDiscount Method

Adds simple discount of known type to existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddDiscount(
    this IOperationService operationService,
    IDiscountType discount,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
discount
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of the discount
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order where discount will be applied.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddDiscountByCardNumber Method

OperationServiceExtensionsAddDiscountByCardNumber Method

Add discount by card number.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddDiscountByCardNumber(
    this IOperationService operationService,
    string cardNumber,
    IOrder order,
    IDiscountCard discountCard,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cardNumber
Type: SystemString
Number of iiko discount card.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order where discount will be applied.
discountCard
Type: Resto.Front.Api.Data.OrdersIDiscountCard
Iiko discount card data.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalFiscalizedPaymentItem Method

OperationServiceExtensionsAddExternalFiscalizedPaymentItem Method

Overload List
Name | Description
AddExternalFiscalizedPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new externally fiscalized payment item to order.
AddExternalFiscalizedPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new external fiscalized payment item to order.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalFiscalizedPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddExternalFiscalizedPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

Add new externally fiscalized payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddExternalFiscalizedPaymentItem(
    this IOperationService operationService,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddExternalFiscalizedPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalFiscalizedPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddExternalFiscalizedPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

Add new external fiscalized payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddExternalFiscalizedPaymentItem(
    this IOperationService operationService,
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddExternalFiscalizedPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalPaymentItem Method

OperationServiceExtensionsAddExternalPaymentItem Method

Overload List
Name | Description
AddExternalPaymentItem(IOperationService, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
AddExternalPaymentItem(IOperationService, Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials) | Add new external payment item to order.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalPaymentItem Method (IOperationService, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddExternalPaymentItem Method (IOperationService, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials)

Add new external payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddExternalPaymentItem(
    this IOperationService operationService,
    decimal paymentSum,
    bool isProcessed,
    IPaymentItemAdditionalData additionalData,
    OrganizationDetailsInfo organizationDetailsInfo,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
isProcessed
Type: SystemBoolean
Whether payment item was already processed by some external system.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
organizationDetailsInfo
Type: Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo
Organization details informations.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddExternalPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddExternalPaymentItem Method (IOperationService, Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddExternalPaymentItem Method (IOperationService, Guid, Decimal, Boolean, IPaymentItemAdditionalData, OrganizationDetailsInfo, IPaymentType, IOrder, ICredentials)

Add new external payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddExternalPaymentItem(
    this IOperationService operationService,
    Guid id,
    decimal paymentSum,
    bool isProcessed,
    IPaymentItemAdditionalData additionalData,
    OrganizationDetailsInfo organizationDetailsInfo,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
isProcessed
Type: SystemBoolean
Whether payment item was already processed by some external system.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
organizationDetailsInfo
Type: Resto.Front.Api.Data.PaymentsOrganizationDetailsInfo
Organization details informations.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added. It should be allowed to create external payment items of this type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddExternalPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddFlexibleSumDiscount Method

OperationServiceExtensionsAddFlexibleSumDiscount Method

Adds simple discount of known type to existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddFlexibleSumDiscount(
    this IOperationService operationService,
    decimal sum,
    IDiscountType discount,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
sum
Type: SystemDecimal
Discount sum.
discount
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of the discount
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order where discount will be applied.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddFlexibleSumDiscountByCardNumber Method

OperationServiceExtensionsAddFlexibleSumDiscountByCardNumber Method

Add discount by card number.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddFlexibleSumDiscountByCardNumber(
    this IOperationService operationService,
    string cardNumber,
    decimal sum,
    IOrder order,
    IDiscountCard discountCard,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cardNumber
Type: SystemString
Number of iiko discount card.
sum
Type: SystemDecimal
Discount sum.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order where discount will be applied.
discountCard
Type: Resto.Front.Api.Data.OrdersIDiscountCard
Iiko discount card data.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddIikoCardDiscounts Method

OperationServiceExtensionsAddIikoCardDiscounts Method

Adds discounts grouped by order items.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddIikoCardDiscounts(
    this IOperationService operationService,
    IReadOnlyCollection<IikoCardDiscount> discounts,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
discounts
Type: System.Collections.GenericIReadOnlyCollection IikoCardDiscount
iikoCard discount data.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order where discounts will be applied.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderCombo Method

OperationServiceExtensionsAddOrderCombo Method

Create order combo item. Order must contain new combo items.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderCombo AddOrderCombo(
    this IOperationService operationService,
    Guid id,
    string name,
    int amount,
    decimal price,
    Guid sourceActionId,
    Guid programId,
    IReadOnlyDictionary<Guid, IOrderCookingItem> comboItems,
    IOrder order,
    IOrderGuestItem guest,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new combo.
name
Type: SystemString
Name of combo.
amount
Type: SystemInt32
Amount of combo.
price
Type: SystemDecimal
Price of combo.
sourceActionId
Type: SystemGuid
Unique identifier of source combo (template identifier).
programId
Type: SystemGuid
Identifier of the loyalty program.
comboItems
Type: System.Collections.GenericIReadOnlyDictionary Guid, IOrderCookingItem
Combo items dictionary. Key - combo group identifier, Value - item id (must be contained in order).
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which combo will be added.
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to which combo will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IOrderCombo

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderExternalData Method

OperationServiceExtensionsAddOrderExternalData Method

Adds external data to the order. Use DeleteOrderExternalData(IOperationService, String, IOrder, ICredentials) to delete the data when it's no longer needed.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void AddOrderExternalData(
    this IOperationService operationService,
    string key,
    string value,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
key
Type: SystemString
External data key. Max length - 256 chars.
value
Type: SystemString
External data value. Max length - 32000 chars.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which external data will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderGuest Method

OperationServiceExtensionsAddOrderGuest Method

Overload List
Name | Description
AddOrderGuest(IOperationService, String, IOrder, ICredentials) | Adds new guest to existing order. User must have rights to edit orders.
AddOrderGuest(IOperationService, Guid, String, IOrder, ICredentials) | Adds new guest with the given ID to existing order. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderGuest Method (IOperationService, String, IOrder, ICredentials)

OperationServiceExtensionsAddOrderGuest Method (IOperationService, String, IOrder, ICredentials)

Adds new guest to existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderGuestItem AddOrderGuest(
    this IOperationService operationService,
    string name,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
name
Type: SystemString
Name of the new guest. If name is null, then it will be generated automatically.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Existing order
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IOrderGuestItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderGuest Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderGuest Method (IOperationService, Guid, String, IOrder, ICredentials)

OperationServiceExtensionsAddOrderGuest Method (IOperationService, Guid, String, IOrder, ICredentials)

Adds new guest with the given ID to existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderGuestItem AddOrderGuest(
    this IOperationService operationService,
    Guid id,
    string name,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new guest in the order. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
name
Type: SystemString
Name of the new guest. If name is null, then it will be generated automatically.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Existing order
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IOrderGuestItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderGuest Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method

OperationServiceExtensionsAddOrderModifierItem Method

Overload List
Name | Description
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.
AddOrderModifierItem(IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal) | Adds order item modifier to the order item in existing order. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderCompoundItem compoundItem,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
compoundItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItem
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Compound item should have at least one component, so [!:AddPrimaryComponent(Resto.Front.Api.Data.Assortment.IProduct,Resto.Front.Api.Editors.Stubs.IOrderStub,Resto.Front.Api.Editors.Stubs.IOrderCompoundItemStub,System.Nullable<decimal>)] should be called before adding modifiers.
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderCompoundItemComponent component,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
component
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the order item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderProductItem productItem,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
productItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItem, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderCompoundItem compoundItem,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
compoundItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItem
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Compound item should have at least one component, so [!:AddPrimaryComponent(Resto.Front.Api.Data.Assortment.IProduct,Resto.Front.Api.Editors.Stubs.IOrderStub,Resto.Front.Api.Editors.Stubs.IOrderCompoundItemStub,System.Nullable<decimal>)] should be called before adding modifiers.
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderCompoundItemComponent, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the compound item component in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderCompoundItemComponent component,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
component
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, Nullable(Int32), Nullable(Decimal))

OperationServiceExtensionsAddOrderModifierItem Method (IOperationService, Guid, Int32, IProduct, IProductGroup, IOrder, IOrderProductItem, ICredentials, NullableInt32, NullableDecimal)

Adds order item modifier to the order item in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderModifierItem AddOrderModifierItem(
    this IOperationService operationService,
    Guid id,
    int amount,
    IProduct modifier,
    IProductGroup parentGroup,
    IOrder order,
    IOrderProductItem productItem,
    ICredentials credentials,
    int? payableAmount = null,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new order item modifier. MUST be unique not only for the order item or order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemInt32
Amount of the modifier. Can be from 1 to 999.
modifier
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position for modifier. Must be accessible through IOrderProductItem.AvailableSimpleModifiers collection or one of the IOrderProductItem.AvailableGroupModifiers child collections.
parentGroup
Type: Resto.Front.Api.Data.AssortmentIProductGroup
Assortment position group for modifier. Must be specified if new modifier will be part of the group modifier. Otherwise null. Group modifier must be chosen from IOrderProductItem.AvailableGroupModifiers
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which modifier will be added
productItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item to which modifier will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the modifier, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderModifierItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderProductItem Method

OperationServiceExtensionsAddOrderProductItem Method

Overload List
Name | Description
AddOrderProductItem(IOperationService, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
AddOrderProductItem(IOperationService, Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal) | Adds assortment position to the guest in existing order. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderProductItem Method (IOperationService, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, Nullable(Decimal))

OperationServiceExtensionsAddOrderProductItem Method (IOperationService, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal)

Adds assortment position to the guest in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderProductItem AddOrderProductItem(
    this IOperationService operationService,
    decimal amount,
    IProduct product,
    IOrder order,
    IOrderGuestItem guest,
    IProductSize size,
    ICredentials credentials,
    OrderItemCourse course = OrderItemCourse.Default,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemDecimal
For positions with weight: weight in defined measure unit. For positions without weight: amount of the position. Can be from 0.001 to 999.999
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which position will be added
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to which position will be added
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's product has scale, otherwise null.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the order item, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderProductItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderProductItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderProductItem Method (IOperationService, Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, Nullable(Decimal))

OperationServiceExtensionsAddOrderProductItem Method (IOperationService, Guid, Decimal, IProduct, IOrder, IOrderGuestItem, IProductSize, ICredentials, OrderItemCourse, NullableDecimal)

Adds assortment position to the guest in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderProductItem AddOrderProductItem(
    this IOperationService operationService,
    Guid id,
    decimal amount,
    IProduct product,
    IOrder order,
    IOrderGuestItem guest,
    IProductSize size,
    ICredentials credentials,
    OrderItemCourse course = OrderItemCourse.Default,
    decimal? predefinedPrice = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new item in the order. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
amount
Type: SystemDecimal
For positions with weight: weight in defined measure unit. For positions without weight: amount of the position. Can be from 0.001 to 999.999
product
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which position will be added
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to which position will be added
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item if it's product has scale, otherwise null.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
course (Optional)
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
Cooking and serving priority of the order item.
predefinedPrice (Optional)
Type: SystemNullable Decimal
Predefined fixed price of the order item, allows to use external quotation instead of default price list. null means default price.

Return Value

Type: IOrderProductItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddOrderProductItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddOrderServiceItem Method

OperationServiceExtensionsAddOrderServiceItem Method

Adds time pay service item to the guest in existing order. User must have permission to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderServiceItem AddOrderServiceItem(
    this IOperationService operationService,
    IProduct service,
    IOrder order,
    IOrderGuestItem guest,
    ICredentials credentials,
    TimeSpan? timeLimit = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
service
Type: Resto.Front.Api.Data.AssortmentIProduct
Assortment position. Must exist in iikoFront assortment.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which position will be added
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to which position will be added
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
timeLimit (Optional)
Type: SystemNullable TimeSpan
Total amount of time after which the service will be stopped or null for default limit (12 hours). Includes all periods.

Return Value

Type: IOrderServiceItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPaymentItem Method

OperationServiceExtensionsAddPaymentItem Method

Overload List
Name | Description
AddPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
AddPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials) | Add new payment item to order.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

Add new payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddPaymentItem(
    this IOperationService operationService,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

OperationServiceExtensionsAddPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IOrder, ICredentials)

Add new payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddPaymentItem(
    this IOperationService operationService,
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPreliminaryPaymentItem Method

OperationServiceExtensionsAddPreliminaryPaymentItem Method

Overload List
Name | Description
AddPreliminaryPaymentItem(IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
AddPreliminaryPaymentItem(IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials) | Add new preliminary payment item to order.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPreliminaryPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials)

OperationServiceExtensionsAddPreliminaryPaymentItem Method (IOperationService, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials)

Add new preliminary payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddPreliminaryPaymentItem(
    this IOperationService operationService,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddPreliminaryPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.AddPreliminaryPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials)

OperationServiceExtensionsAddPreliminaryPaymentItem Method (IOperationService, Guid, Decimal, IPaymentItemAdditionalData, IPaymentType, IDeliveryOrder, ICredentials)

Add new preliminary payment item to order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IPaymentItem AddPreliminaryPaymentItem(
    this IOperationService operationService,
    Guid id,
    decimal paymentSum,
    IPaymentItemAdditionalData additionalData,
    IPaymentType paymentType,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the new payment item. MUST be unique not only for the order, but for the whole system. Therefore it must be taken from some synchronization operation or generated with Guid.NewGuid()
paymentSum
Type: SystemDecimal
Sum of payment item that will be added.
additionalData
Type: Resto.Front.Api.Data.PaymentsIPaymentItemAdditionalData
Instance of a payment specific type carrying properties, which will be used to initialize a payment item, or null if payment type doesn't require additional data for payment item initialization.
paymentType
Type: Resto.Front.Api.Data.PaymentsIPaymentType
Type of payment item that will be added.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery order to which payment item will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IPaymentItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
AddPreliminaryPaymentItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.BindReserveToOrder Method

OperationServiceExtensionsBindReserveToOrder Method

Converts exising reserve or banquet without order to banquet with order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void BindReserveToOrder(
    this IOperationService operationService,
    IReserve reserve,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to bind.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order used to bind reserve to.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientAddresses Method

OperationServiceExtensionsChangeClientAddresses Method

Changes client addresses.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientAddresses(
    this IOperationService operationService,
    List<AddressDto> addresses,
    int? mainAddressIndex,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
addresses
Type: System.Collections.GenericList AddressDto
new addresses list of client
mainAddressIndex
Type: SystemNullable Int32
index of client main address
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientBirthDate Method

OperationServiceExtensionsChangeClientBirthDate Method

Changes client's birth date.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientBirthDate(
    this IOperationService operationService,
    DateTime? birthDate,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
birthDate
Type: SystemNullable DateTime
New birth date
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientBlacklistInfo Method

OperationServiceExtensionsChangeClientBlacklistInfo Method

Changes client blacklist info.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientBlacklistInfo(
    this IOperationService operationService,
    bool isInBlacklist,
    string reason,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
isInBlacklist
Type: SystemBoolean
Is changing client in blacklist.
reason
Type: SystemString
The reason of adding client to blacklist.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientCardNumber Method

OperationServiceExtensionsChangeClientCardNumber Method

Changes client card number.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientCardNumber(
    this IOperationService operationService,
    string cardNumber,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cardNumber
Type: SystemString
New card number of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientComment Method

OperationServiceExtensionsChangeClientComment Method

Changes client comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientComment(
    this IOperationService operationService,
    string comment,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
new name of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientConsentDates Method

OperationServiceExtensionsChangeClientConsentDates Method

Changes client's dates of consent.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientConsentDates(
    this IOperationService operationService,
    DateTime? consentFrom,
    DateTime? consentTo,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
consentFrom
Type: SystemNullable DateTime
The date and time of explicit consent by the client.
consentTo
Type: SystemNullable DateTime
The date and time when client's consent expires.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientEmails Method

OperationServiceExtensionsChangeClientEmails Method

Changes client emails list.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientEmails(
    this IOperationService operationService,
    List<EmailDto> emails,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
emails
Type: System.Collections.GenericList EmailDto
new emails list of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientGender Method

OperationServiceExtensionsChangeClientGender Method

Change client's gender.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientGender(
    this IOperationService operationService,
    Gender gender,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
gender
Type: Resto.Front.Api.Data.BrdGender
New gender.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientIikoBizId Method

OperationServiceExtensionsChangeClientIikoBizId Method

Changes client's account in iiko.biz.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientIikoBizId(
    this IOperationService operationService,
    Guid iikoBizId,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
iikoBizId
Type: SystemGuid
New account in iiko.biz
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientLastOrderDate Method

OperationServiceExtensionsChangeClientLastOrderDate Method

Changes client's last order date.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientLastOrderDate(
    this IOperationService operationService,
    DateTime lastOrderDate,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
lastOrderDate
Type: SystemDateTime
New last order date
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientLinkedCounteragent Method

OperationServiceExtensionsChangeClientLinkedCounteragent Method

Changes client linked counter agent.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientLinkedCounteragent(
    this IOperationService operationService,
    IClient client,
    IUser linkedCounteragent,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client.
linkedCounteragent
Type: Resto.Front.Api.Data.SecurityIUser
New linked counteragent.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientMainAddressIndex Method

OperationServiceExtensionsChangeClientMainAddressIndex Method

Changes client main address index.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientMainAddressIndex(
    this IOperationService operationService,
    int mainAddressIndex,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
mainAddressIndex
Type: SystemInt32
index of client main address
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientMarketingSource Method

OperationServiceExtensionsChangeClientMarketingSource Method

Changes client marketing source.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientMarketingSource(
    this IOperationService operationService,
    IMarketingSource marketingSource,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
marketingSource
Type: Resto.Front.Api.Data.BrdIMarketingSource
New marketing source of the client.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientName Method

OperationServiceExtensionsChangeClientName Method

Changes client name.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientName(
    this IOperationService operationService,
    string name,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
name
Type: SystemString
new name of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientNick Method

OperationServiceExtensionsChangeClientNick Method

Changes client nickname.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientNick(
    this IOperationService operationService,
    string nick,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
nick
Type: SystemString
new nick of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientOrganizationDetailsInfo Method

OperationServiceExtensionsChangeClientOrganizationDetailsInfo Method

Changes organization details information of client.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientOrganizationDetailsInfo(
    this IOperationService operationService,
    string name,
    string code,
    string accountingReasonCode,
    string address,
    string counteragentRecipientCode,
    string fullAddressPostCode,
    string fullAddressCountry,
    string fullAddressRegion,
    string fullAddressCity,
    string fullAddressStreet,
    string fullAddressHouse,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
name
Type: SystemString
Client's organization name
code
Type: SystemString
Client's organization code
accountingReasonCode
Type: SystemString
Client's organization accounting reason code
address
Type: SystemString
Client's organization address
counteragentRecipientCode
Type: SystemString
Client's organization recipient code
fullAddressPostCode
Type: SystemString
Client's organization full address post code
fullAddressCountry
Type: SystemString
Client's organization full address country
fullAddressRegion
Type: SystemString
Client's organization full address region
fullAddressCity
Type: SystemString
Client's organization full address city
fullAddressStreet
Type: SystemString
Client's organization full address street
fullAddressHouse
Type: SystemString
Client's organization full address house
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientPersonalDataConsent Method

OperationServiceExtensionsChangeClientPersonalDataConsent Method

Changes whether client consented processing their personal data.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientPersonalDataConsent(
    this IOperationService operationService,
    bool? consent,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
consent
Type: SystemNullable Boolean
Client's consent status to the processing of the personal data
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientPersonalDataProcessingDates Method

OperationServiceExtensionsChangeClientPersonalDataProcessingDates Method

Changes dates of the time interval which allows client's legal personal data processing without thier consent.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientPersonalDataProcessingDates(
    this IOperationService operationService,
    DateTime? processingFrom,
    DateTime? processingTo,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
processingFrom
Type: SystemNullable DateTime
The date and time of the beginning of legal personal data processing.
processingTo
Type: SystemNullable DateTime
The date and time of the end of the legal personal data processing.
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientPhones Method

OperationServiceExtensionsChangeClientPhones Method

Changes client phones list.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientPhones(
    this IOperationService operationService,
    List<PhoneDto> phones,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
phones
Type: System.Collections.GenericList PhoneDto
new phones list of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientReceivesLoyaltySystemNotifications Method

OperationServiceExtensionsChangeClientReceivesLoyaltySystemNotifications Method

Changes whether client receives loyalty system notification messages.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientReceivesLoyaltySystemNotifications(
    this IOperationService operationService,
    bool receivesLoyaltySystemNotifications,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
receivesLoyaltySystemNotifications
Type: SystemBoolean
Whether client receives loyalty system notification messages
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientReceivesOrderStatusNotifications Method

OperationServiceExtensionsChangeClientReceivesOrderStatusNotifications Method

Changes whether client receives order status notification messages.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientReceivesOrderStatusNotifications(
    this IOperationService operationService,
    bool receivesOrderStatusNotifications,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
receivesOrderStatusNotifications
Type: SystemBoolean
Whether client receives order status notification messages
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientReceivesPromotionalNotifications Method

OperationServiceExtensionsChangeClientReceivesPromotionalNotifications Method

Changes whether client receives promotional notification messages.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientReceivesPromotionalNotifications(
    this IOperationService operationService,
    bool receivesPromotionalNotifications,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
receivesPromotionalNotifications
Type: SystemBoolean
Whether client receives promotional notification messages
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeClientSurname Method

OperationServiceExtensionsChangeClientSurname Method

Changes client surname.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeClientSurname(
    this IOperationService operationService,
    string surname,
    IClient client,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
surname
Type: SystemString
new surname of client
client
Type: Resto.Front.Api.Data.BrdIClient
Changing client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeComboAmount Method

OperationServiceExtensionsChangeComboAmount Method

Change combo amount.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeComboAmount(
    this IOperationService operationService,
    int amount,
    IOrderCombo combo,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
New combo amount.
combo
Type: Resto.Front.Api.Data.OrdersIOrderCombo
Combo which amount will be changed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which combo amount will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeComboPrice Method

OperationServiceExtensionsChangeComboPrice Method

Change combo price.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeComboPrice(
    this IOperationService operationService,
    decimal price,
    IOrderCombo combo,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
price
Type: SystemDecimal
New combo price.
combo
Type: Resto.Front.Api.Data.OrdersIOrderCombo
Combo which price will be changed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which combo price will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeCookingPriority Method

OperationServiceExtensionsChangeCookingPriority Method

Changes custom cooking priority and top priority flag.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeCookingPriority(
    this IOperationService operationService,
    int customPriority,
    bool isTopPriority,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customPriority
Type: SystemInt32
Specifies a custom cooking priority.
isTopPriority
Type: SystemBoolean
Sets a top priority flag.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to apply custom priority
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryActualDeliverTime Method

OperationServiceExtensionsChangeDeliveryActualDeliverTime Method

Change time when the order was actually delivered.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryActualDeliverTime(
    this IOperationService operationService,
    DateTime? actualDeliverTime,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
actualDeliverTime
Type: SystemNullable DateTime
Actual deliver time
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change status.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryAddress Method

OperationServiceExtensionsChangeDeliveryAddress Method

Changes address of delivery

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryAddress(
    this IOperationService operationService,
    AddressDto address,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
address
Type: Resto.Front.Api.Data.BrdAddressDto
New address of delivery
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change address
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryClientName Method

OperationServiceExtensionsChangeDeliveryClientName Method

Change name of delivery client.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryClientName(
    this IOperationService operationService,
    string clientName,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
clientName
Type: SystemString
Name of client
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Change name of delivery client
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryComment Method

OperationServiceExtensionsChangeDeliveryComment Method

Change the order comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryComment(
    this IOperationService operationService,
    string comment,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
Comment
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryConfirmTime Method

OperationServiceExtensionsChangeDeliveryConfirmTime Method

Changes delivery confirmation state and time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryConfirmTime(
    this IOperationService operationService,
    DateTime? confirmTime,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
confirmTime
Type: SystemNullable DateTime
Confirmation time or null if delivery is unconfirmed.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change time.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryCourier Method

OperationServiceExtensionsChangeDeliveryCourier Method

Assign/Change the order courier. Can use this action only before the order is to be delivered.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryCourier(
    this IOperationService operationService,
    bool isCourierSelectedManually,
    IDeliveryOrder order,
    IUser courier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
isCourierSelectedManually
Type: SystemBoolean
Is courier selected manually and can't be replaced with automatic logistic system
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to assign courier.
courier
Type: Resto.Front.Api.Data.SecurityIUser
Courier to assign to delivery.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryCustomApiData Method

OperationServiceExtensionsChangeDeliveryCustomApiData Method

Change the delivery custom data from api.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryCustomApiData(
    this IOperationService operationService,
    string customApiData,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customApiData
Type: SystemString
Custom data from api
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryDuration Method

OperationServiceExtensionsChangeDeliveryDuration Method

Change duration of delivery processing.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryDuration(
    this IOperationService operationService,
    TimeSpan duration,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
duration
Type: SystemTimeSpan
Calculated delivery duration (accurate within minutes).
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Change precalculated delivery duration.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryEmail Method

OperationServiceExtensionsChangeDeliveryEmail Method

Change the order e-mail.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryEmail(
    this IOperationService operationService,
    string email,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
email
Type: SystemString
E-mail
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryExpectedDeliverTime Method

OperationServiceExtensionsChangeDeliveryExpectedDeliverTime Method

Change time when client wants the order to be delivered.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryExpectedDeliverTime(
    this IOperationService operationService,
    DateTime expectedDeliverTime,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
expectedDeliverTime
Type: SystemDateTime
Expected deliver time
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryExpectedDuration Method

OperationServiceExtensionsChangeDeliveryExpectedDuration Method

Set calculated delivery duration without overrided value on terminal.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryExpectedDuration(
    this IOperationService operationService,
    TimeSpan? expectedDeliveryDuration,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
expectedDeliveryDuration
Type: SystemNullable TimeSpan
delivery duration without overriden value on terminal
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryExternalCourier Method

OperationServiceExtensionsChangeDeliveryExternalCourier Method

Changes external courier for delivery.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryExternalCourier(
    this IOperationService operationService,
    string courierName,
    string courierPhone,
    string courierComment,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
courierName
Type: SystemString
External courier service id.
courierPhone
Type: SystemString
External courier service name.
courierComment
Type: SystemString
External courier service name.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to assign external courier service holder.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryExternalCourierService Method

OperationServiceExtensionsChangeDeliveryExternalCourierService Method

Changes external courier service for delivery.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryExternalCourierService(
    this IOperationService operationService,
    Guid serviceId,
    string serviceName,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
serviceId
Type: SystemGuid
External courier service id.
serviceName
Type: SystemString
External courier service name.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to assign external courier service holder.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryLastVerifiedRestrictionsHash Method

OperationServiceExtensionsChangeDeliveryLastVerifiedRestrictionsHash Method

Set last verified restirictions hash from server.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryLastVerifiedRestrictionsHash(
    this IOperationService operationService,
    string lastVerifiedDeliveryRestrictionsHash,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
lastVerifiedDeliveryRestrictionsHash
Type: SystemString
last verified restirictions hash from server
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryLocation Method

OperationServiceExtensionsChangeDeliveryLocation Method

Changes delivery address location.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryLocation(
    this IOperationService operationService,
    double? latitude,
    double? longitude,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
latitude
Type: SystemNullable Double
Latitude of geolocation of delivery address.
longitude
Type: SystemNullable Double
Longitude of geolocation of delivery address.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change marketing source.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryMarketingSource Method

OperationServiceExtensionsChangeDeliveryMarketingSource Method

Assign/change order marketing source.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryMarketingSource(
    this IOperationService operationService,
    IDeliveryOrder order,
    IMarketingSource marketingSource,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to assign marketing source.
marketingSource
Type: Resto.Front.Api.Data.BrdIMarketingSource
Source of the order.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryMovedId Method

OperationServiceExtensionsChangeDeliveryMovedId Method

Change new delivery identifier created for move to a new terminal.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryMovedId(
    this IOperationService operationService,
    Guid movedDeliveryId,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
movedDeliveryId
Type: SystemGuid
New delivery identifier created for move to a new terminal.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryOperator Method

OperationServiceExtensionsChangeDeliveryOperator Method

Assign/change the order operator.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryOperator(
    this IOperationService operationService,
    IDeliveryOrder order,
    IUser deliveryOperator,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to assign operator.
deliveryOperator
Type: Resto.Front.Api.Data.SecurityIUser
Operator to assign the order to.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryOrderPredictedCookingCompleteTime Method

OperationServiceExtensionsChangeDeliveryOrderPredictedCookingCompleteTime Method

Change predicted time when the order cooking should be completed. Can change property only for Unconfirmed, New or Waiting delivery.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryOrderPredictedCookingCompleteTime(
    this IOperationService operationService,
    DateTime? predictedCookingCompleteTime,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
predictedCookingCompleteTime
Type: SystemNullable DateTime
Predicted time
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryPhone Method

OperationServiceExtensionsChangeDeliveryPhone Method

Changes the order phone.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryPhone(
    this IOperationService operationService,
    string phone,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
phone
Type: SystemString
New phone value of the order
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change phone
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryPredictedDeliveryTime Method

OperationServiceExtensionsChangeDeliveryPredictedDeliveryTime Method

Change predicted time when the order should be delivered. Can change property only for Unconfirmed, New or Waiting delivery.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryPredictedDeliveryTime(
    this IOperationService operationService,
    DateTime? predictedDeliveryTime,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
predictedDeliveryTime
Type: SystemNullable DateTime
Predicted time
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryProblemComment Method

OperationServiceExtensionsChangeDeliveryProblemComment Method

Change the order problem comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryProblemComment(
    this IOperationService operationService,
    string comment,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
Problem comment. MaxLength = 1000 symbols. If HasProblem = false it does not mean that ProblemComment = null, because comment isn't erased automatically after set HasProblem to false.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliveryProblemStatus Method

OperationServiceExtensionsChangeDeliveryProblemStatus Method

Change the order problem status.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliveryProblemStatus(
    this IOperationService operationService,
    bool hasProblem,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
hasProblem
Type: SystemBoolean
Problem flag
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeDeliverySplitBetweenPersons Method

OperationServiceExtensionsChangeDeliverySplitBetweenPersons Method

Changes the order property if it should be splitted between persons.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeDeliverySplitBetweenPersons(
    this IOperationService operationService,
    bool splitBetweenPersons,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
splitBetweenPersons
Type: SystemBoolean
Whether the order should be splitted between persons
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeEstimatedOrderGuestsCount Method

OperationServiceExtensionsChangeEstimatedOrderGuestsCount Method

Changes estimated order guests count. Use this method to set estimated guests count when guests collection doesn't reflect actual state of affairs.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeEstimatedOrderGuestsCount(
    this IOperationService operationService,
    int estimatedGuestsCount,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
estimatedGuestsCount
Type: SystemInt32
How many people will be served using this order, in spite of how many guests this order will be splitted by.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to change estimated guests count.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeExternalPaymentItemCustomData Method

OperationServiceExtensionsChangeExternalPaymentItemCustomData Method

Changes custom data of existing external payment item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeExternalPaymentItemCustomData(
    this IOperationService operationService,
    string customData,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
External payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order of which payment item will be edited.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderAppliedIikoCard5ManualConditions Method

OperationServiceExtensionsChangeOrderAppliedIikoCard5ManualConditions Method

Change iikoCard5 manual conditions applied for order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderAppliedIikoCard5ManualConditions(
    this IOperationService operationService,
    List<Guid> appliedManualConditions,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
appliedManualConditions
Type: System.Collections.GenericList Guid
List of iikoCard5 manual condition identifiers applied to order.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to apply iikoCard5 manual conditions.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderCookingItemAmount Method

OperationServiceExtensionsChangeOrderCookingItemAmount Method

Changes the amount of the assortment position in existing order. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderCookingItemAmount(
    this IOperationService operationService,
    decimal amount,
    IOrderCookingItem cookingItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemDecimal
For positions with weight: new weight in defined measure unit. For positions without weight: new amount of the position. Can be from 0.001 to 999.999
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item that represents the assortment position and which amount will be changed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which contains the product.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderCookingItemCourse Method

OperationServiceExtensionsChangeOrderCookingItemCourse Method

Changes the course of the order item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderCookingItemCourse(
    this IOperationService operationService,
    OrderItemCourse course,
    IOrderCookingItem cookingItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
course
Type: Resto.Front.Api.Data.OrdersOrderItemCourse
New course for order item.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item which course will be changed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which contains the product.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderCookingItemSize Method

OperationServiceExtensionsChangeOrderCookingItemSize Method

Changes the product size of the order item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderCookingItemSize(
    this IOperationService operationService,
    IProductSize size,
    IOrderCookingItem cookingItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
size
Type: Resto.Front.Api.Data.AssortmentIProductSize
Size of the order item.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item which course will be changed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which contains the product.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderIikoCard5Coupon Method

OperationServiceExtensionsChangeOrderIikoCard5Coupon Method

Change order iikoCard5 coupon, used in iikoCard5 system.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderIikoCard5Coupon(
    this IOperationService operationService,
    string iikoCard5Coupon,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
iikoCard5Coupon
Type: SystemString
New iikoCard5 coupon
order
Type: Resto.Front.Api.Data.OrdersIOrder
Existing order
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderItemComment Method

OperationServiceExtensionsChangeOrderItemComment Method

Changes product order item's comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderItemComment(
    this IOperationService operationService,
    string comment,
    IOrder order,
    IOrderCookingItem cookingItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
New comment for product order item.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains product order item which comment will be changed.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Product order item which comment will be changed. Product order item should not been printed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderItemWaiter Method

OperationServiceExtensionsChangeOrderItemWaiter Method

Changes product order item's waiter.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderItemWaiter(
    this IOperationService operationService,
    IOrder order,
    IOrderRootItem orderItem,
    IUser waiter,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains product order item which waiter will be changed.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Product order item which waiterId will be changed. Product order item should not been printed.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
Waiter.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderModifierItemAmount Method

OperationServiceExtensionsChangeOrderModifierItemAmount Method

Overload List
Name | Description
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound item common modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the compound component modifier. User must have rights to edit orders.
ChangeOrderModifierItemAmount(IOperationService, Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32) | Changes the amount of the product item modifier. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, Nullable(Int32))

OperationServiceExtensionsChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials, NullableInt32)

Changes the amount of the compound item common modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderModifierItemAmount(
    this IOperationService operationService,
    int amount,
    IOrder order,
    IOrderCompoundItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials,
    int? payableAmount = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItem
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which amount will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, Nullable(Int32))

OperationServiceExtensionsChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials, NullableInt32)

Changes the amount of the compound component modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderModifierItemAmount(
    this IOperationService operationService,
    int amount,
    IOrder order,
    IOrderCompoundItemComponent compoundComponent,
    IOrderModifierItem modifier,
    ICredentials credentials,
    int? payableAmount = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
compoundComponent
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which amount will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, Nullable(Int32))

OperationServiceExtensionsChangeOrderModifierItemAmount Method (IOperationService, Int32, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials, NullableInt32)

Changes the amount of the product item modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderModifierItemAmount(
    this IOperationService operationService,
    int amount,
    IOrder order,
    IOrderProductItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials,
    int? payableAmount = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemInt32
New amount of the modifier. Can be from 1 to 999.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which amount will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
payableAmount (Optional)
Type: SystemNullable Int32
Custom payable amount. Leave it null to use default logic or set custom value to override default logic. Payable part of the amount must be between zero (which means that whole modifier is free of charge) and amount (which means that whole modifier is payable).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
ChangeOrderModifierItemAmount Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderOriginName Method

OperationServiceExtensionsChangeOrderOriginName Method

Sets order origin — name of the source this order was received from. Specifying origin allows to analyse efficiency of external order sources such as different web-sites, mobile applications and so on. Origin name can be set only once.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderOriginName(
    this IOperationService operationService,
    string originName,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
originName
Type: SystemString
Non-empty string of the new origin name. Maximum length is 20 chars.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to specify origin.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderPricingTime Method

OperationServiceExtensionsChangeOrderPricingTime Method

Change order pricing time, which determines the price of products. By default time taken from items print time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderPricingTime(
    this IOperationService operationService,
    DateTime? pricingTime,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
pricingTime
Type: SystemNullable DateTime
New order pricing time
order
Type: Resto.Front.Api.Data.OrdersIOrder
Existing order
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderTables Method

OperationServiceExtensionsChangeOrderTables Method

Changes tables of the order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderTables(
    this IOperationService operationService,
    IOrder order,
    IReadOnlyList<ITable> tables,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to change tables.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Tables to be assigned to the order.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If specified tables belongs to another restaurant section then section property, price category and products cooking palces will also be changed.
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeOrderWaiter Method

OperationServiceExtensionsChangeOrderWaiter Method

Changes order's waiter.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeOrderWaiter(
    this IOperationService operationService,
    IOrder order,
    IUser waiter,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which waiter will be changed.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
New waiter.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangePaymentItemCustomData Method

OperationServiceExtensionsChangePaymentItemCustomData Method

Changes custom data of existing payment item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangePaymentItemCustomData(
    this IOperationService operationService,
    string customData,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order of which payment item will be edited.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangePaymentItemSum Method

OperationServiceExtensionsChangePaymentItemSum Method

Changes sum of existing payment item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangePaymentItemSum(
    this IOperationService operationService,
    decimal paymentSum,
    decimal? minPaymentSum,
    decimal? maxPaymentSum,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
New sum of payment item.
minPaymentSum
Type: SystemNullable Decimal
Minimum allowed payment sum, lower bound for the payment. null means default limit value.
maxPaymentSum
Type: SystemNullable Decimal
Maximum allowed payment sum, upper bound for the payment. null means default limit value.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be edited.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order of which payment item will be edited.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangePreliminaryPaymentItemCustomData Method

OperationServiceExtensionsChangePreliminaryPaymentItemCustomData Method

Changes custom data of existing preliminary payment item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangePreliminaryPaymentItemCustomData(
    this IOperationService operationService,
    string customData,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customData
Type: SystemString
New custom data for payment item. Max serialized data length is MaxExternalPaymentItemDataLength.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Preliminary payment item to be edited. Currently should be payment item of plugin payment type.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order of which payment item will be edited.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangePreliminaryPaymentItemSum Method

OperationServiceExtensionsChangePreliminaryPaymentItemSum Method

Changes sum of existing preliminary payment item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangePreliminaryPaymentItemSum(
    this IOperationService operationService,
    decimal paymentSum,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentSum
Type: SystemDecimal
New sum of payment item.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Preliminary payment item to be edited.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order of which payment item will be edited.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangePriceCategory Method

OperationServiceExtensionsChangePriceCategory Method

Changes price category of the order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangePriceCategory(
    this IOperationService operationService,
    IPriceCategory priceCategory,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
priceCategory
Type: Resto.Front.Api.Data.OrdersIPriceCategory
New price category.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to change price category.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveComment Method

OperationServiceExtensionsChangeReserveComment Method

Changes reserve comment. Use empty string to clear comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveComment(
    this IOperationService operationService,
    string comment,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
Arbitrary string comment for the reserve, maximum length is 250 chars.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveDuration Method

OperationServiceExtensionsChangeReserveDuration Method

Changes estimated reserve duration (amount of time betwen visit's start and end). Default reserve duration is 2 hours, banquet duration is 3 hours.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveDuration(
    this IOperationService operationService,
    TimeSpan duration,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
duration
Type: SystemTimeSpan
Reserve duration, minimum value is 15 minutes, maximum value is 23 hours and 59 minutes, maximum precision is 1 minute (so 1h 25m 42s is invalid as too precise value).
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveEstimatedStartTime Method

OperationServiceExtensionsChangeReserveEstimatedStartTime Method

Changes estimated reserve start time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveEstimatedStartTime(
    this IOperationService operationService,
    DateTime estimatedStartTime,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned visit, used to divide different visits and remind staff to prepare table.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveGuestsCount Method

OperationServiceExtensionsChangeReserveGuestsCount Method

Changes estimated guests count for reserve. Default value is 2.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveGuestsCount(
    this IOperationService operationService,
    int guestsCount,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
guestsCount
Type: SystemInt32
Estimated guests count, minimum value is 1, maximum value is 1000.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveReminder Method

OperationServiceExtensionsChangeReserveReminder Method

Changes reserve reminder flag.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveReminder(
    this IOperationService operationService,
    bool shouldRemind,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
shouldRemind
Type: SystemBoolean
Whether to remind staff to prepare table beforehand.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeReserveTables Method

OperationServiceExtensionsChangeReserveTables Method

Changes reserving tables.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeReserveTables(
    this IOperationService operationService,
    IReadOnlyList<ITable> tables,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to edit.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeSelectiveDiscount Method

OperationServiceExtensionsChangeSelectiveDiscount Method

Change discount item selective application settings. Set both products and modifiers to null if you want the discount item to be applied to the whole order (including future order items), otherwise provide order item products and modifiers for selective discount item application.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeSelectiveDiscount(
    this IOperationService operationService,
    IOrder order,
    IDiscountType discountType,
    IReadOnlyList<IOrderProductItem> products,
    IReadOnlyList<IOrderModifierItem> modifiers,
    IReadOnlyList<IOrderCompoundItemComponent> components,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order containing the discount item.
discountType
Type: Resto.Front.Api.Data.OrdersIDiscountType
Type of discount item to change.
products
Type: System.Collections.GenericIReadOnlyList IOrderProductItem
Order item products to which the discount item can be applied to.
modifiers
Type: System.Collections.GenericIReadOnlyList IOrderModifierItem
Order item modifiers to which the discount item can be applied to.
components
Type: System.Collections.GenericIReadOnlyList IOrderCompoundItemComponent
Compound item components to which the discount item can be applied to.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ChangeStreetName Method

OperationServiceExtensionsChangeStreetName Method

Changes street's name.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ChangeStreetName(
    this IOperationService operationService,
    string name,
    IStreet street,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
name
Type: SystemString
Name of street
street
Type: Resto.Front.Api.Data.BrdIStreet
Changing street
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateBanquet Method

OperationServiceExtensionsCreateBanquet Method

Overload List
Name | Description
CreateBanquet(IOperationService, DateTime, IClient, IOrder, ICredentials, Guid) | Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.
CreateBanquet(IOperationService, DateTime, IClient, IReadOnlyListITable, ICredentials, Guid) | Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateBanquet Method (IOperationService, DateTime, IClient, IOrder, ICredentials, Guid)

OperationServiceExtensionsCreateBanquet Method (IOperationService, DateTime, IClient, IOrder, ICredentials, Guid)

Creates reservation for planned event in future. Order's table will be marked as reserved to prevent collision with other events at the same time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReserve CreateBanquet(
    this IOperationService operationService,
    DateTime estimatedStartTime,
    IClient client,
    IOrder order,
    ICredentials credentials,
    Guid externalId = default
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned event, used to divide different events and remind staff to prepare table and ingredients.
client
Type: Resto.Front.Api.Data.BrdIClient
Client who asked to reserve table for his event.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order used to form menu for coming event, specify serve sequence (via courses), prepay.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: IReserve

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
CreateBanquet Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateBanquet Method (IOperationService, DateTime, IClient, IReadOnlyList(ITable), ICredentials, Guid)

OperationServiceExtensionsCreateBanquet Method (IOperationService, DateTime, IClient, IReadOnlyListITable, ICredentials, Guid)

Creates reservation for planned event in future. Table will be marked as reserved to prevent collision with other events at the same time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReserve CreateBanquet(
    this IOperationService operationService,
    DateTime estimatedStartTime,
    IClient client,
    IReadOnlyList<ITable> tables,
    ICredentials credentials,
    Guid externalId = default
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned event, used to divide different events and remind staff to prepare table and ingredients.
client
Type: Resto.Front.Api.Data.BrdIClient
Client who asked to reserve table for his event.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: IReserve

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
CreateBanquet Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateClient Method

OperationServiceExtensionsCreateClient Method

Creates new client. The client must have a card number or at least one phone number.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IClient CreateClient(
    this IOperationService operationService,
    Guid id,
    string name,
    List<PhoneDto> phones,
    string cardNumber,
    DateTime? dateCreated,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Id of creating client
name
Type: SystemString
Name of client
phones
Type: System.Collections.GenericList PhoneDto
List of client phones. Cannot contain null values and more than one main phone (i.e. with property IsMain = true)
cardNumber
Type: SystemString
Discount card number or null if the client doesn't have discount card. If the discount card doesn't exist, consider creating one using CreateDiscountCard(String, String, IPriceCategory, IDiscountType).
dateCreated
Type: SystemNullable DateTime
Date when client was created. Must be not null, for actual reports by date created of clients.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IClient

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateClientWithOrganizationDetails Method

OperationServiceExtensionsCreateClientWithOrganizationDetails Method

Creates new client. The client must have orgatizations details info.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IClient CreateClientWithOrganizationDetails(
    this IOperationService operationService,
    Guid id,
    string name,
    string counteragentName,
    string counteragentCode,
    string counteragentAccountingReasonCode,
    string counteragentAddress,
    string counteragentRecipientCode,
    string fullAddressPostCode,
    string fullAddressCountry,
    string fullAddressRegion,
    string fullAddressCity,
    string fullAddressStreet,
    string fullAddressHouse,
    DateTime? dateCreated,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Id of creating client
name
Type: SystemString
Name of client
counteragentName
Type: SystemString
Client's organization name
counteragentCode
Type: SystemString
Client's organization code
counteragentAccountingReasonCode
Type: SystemString
Client's organization accounting reason code
counteragentAddress
Type: SystemString
Client's organization address
counteragentRecipientCode
Type: SystemString
Client's organization recipient code
fullAddressPostCode
Type: SystemString
Client's organization full address post code
fullAddressCountry
Type: SystemString
Client's organization full address country
fullAddressRegion
Type: SystemString
Client's organization full address region
fullAddressCity
Type: SystemString
Client's organization full address city
fullAddressStreet
Type: SystemString
Client's organization full address street
fullAddressHouse
Type: SystemString
Client's organization full address house
dateCreated
Type: SystemNullable DateTime
Date when client was created. Must be not null, for actual reports by date created of clients.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IClient

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateReserve Method

OperationServiceExtensionsCreateReserve Method

Creates reservation for planned visit in future. Table will be marked as reserved to prevent collision with other guests at the same time.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IReserve CreateReserve(
    this IOperationService operationService,
    DateTime estimatedStartTime,
    IClient client,
    IReadOnlyList<ITable> tables,
    ICredentials credentials,
    Guid externalId = default
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
estimatedStartTime
Type: SystemDateTime
Approximate date and time of planned visit, used to divide different visits and remind staff to prepare table.
client
Type: Resto.Front.Api.Data.BrdIClient
Client who asked to reserve table for him.
tables
Type: System.Collections.GenericIReadOnlyList ITable
Specifies tables to be reserved at some moment in future.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
externalId (Optional)
Type: SystemGuid
Identifier in the external system which can be used to match reserves in the iiko and in the external system.

Return Value

Type: IReserve

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateStreet Method

OperationServiceExtensionsCreateStreet Method

Overload List
Name | Description
CreateStreet(IOperationService, String, ICredentials) | Creates new street.
CreateStreet(IOperationService, Guid, String, ICity, ICredentials) | Creates new street.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateStreet Method (IOperationService, String, ICredentials)

OperationServiceExtensionsCreateStreet Method (IOperationService, String, ICredentials)

Creates new street.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IStreet CreateStreet(
    this IOperationService operationService,
    string name,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
name
Type: SystemString
Name of creating street
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IStreet

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
CreateStreet Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.CreateStreet Method (IOperationService, Guid, String, ICity, ICredentials)

OperationServiceExtensionsCreateStreet Method (IOperationService, Guid, String, ICity, ICredentials)

Creates new street.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IStreet CreateStreet(
    this IOperationService operationService,
    Guid id,
    string name,
    ICity city,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Id of creating street
name
Type: SystemString
Name of creating street
city
Type: Resto.Front.Api.Data.BrdICity
City of creating street
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IStreet

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
CreateStreet Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteDiscount Method

OperationServiceExtensionsDeleteDiscount Method

Removes discount of known type from existing order. User must have rights to work with discounts.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteDiscount(
    this IOperationService operationService,
    IDiscountItem discountItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
discountItem
Type: Resto.Front.Api.Data.OrdersIDiscountItem
Discount to be removed.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to delete discount from.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteExternalFiscalizedPaymentItem Method

OperationServiceExtensionsDeleteExternalFiscalizedPaymentItem Method

Delete existing externally fiscalized payment item from order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteExternalFiscalizedPaymentItem(
    this IOperationService operationService,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Externally fiscalized payment item to be deleted.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order from which payment item will be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteExternalPaymentItem Method

OperationServiceExtensionsDeleteExternalPaymentItem Method

Delete existing external payment item from order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteExternalPaymentItem(
    this IOperationService operationService,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
External payment item to be deleted.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order from which payment item will be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderCombo Method

OperationServiceExtensionsDeleteOrderCombo Method

Delete order combo item.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderCombo(
    this IOperationService operationService,
    IOrderCombo combo,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
combo
Type: Resto.Front.Api.Data.OrdersIOrderCombo
Combo which will be deleted.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order from which combo will be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderExternalData Method

OperationServiceExtensionsDeleteOrderExternalData Method

Deletes external data from the order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderExternalData(
    this IOperationService operationService,
    string key,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
key
Type: SystemString
External data key. Should be the same as it was used with AddOrderExternalData(IOperationService, String, String, IOrder, ICredentials)
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to delete external data from.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderGuest Method

OperationServiceExtensionsDeleteOrderGuest Method

Deletes guest without any products from order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderGuest(
    this IOperationService operationService,
    IOrder order,
    IOrderGuestItem guest,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to delete guest from.
guest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest to be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderItem Method

OperationServiceExtensionsDeleteOrderItem Method

Deletes order item from order that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderItem(
    this IOperationService operationService,
    IOrder order,
    IOrderRootItem orderItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the item to be deleted.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Order item to be deleted. Item must not be printed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderItemComment Method

OperationServiceExtensionsDeleteOrderItemComment Method

Deletes product order item's comment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderItemComment(
    this IOperationService operationService,
    IOrder order,
    IOrderCookingItem cookingItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains product order item which comment will be changed.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Product order item which comment will be changed. Product order item should not been printed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderModifierItem Method

OperationServiceExtensionsDeleteOrderModifierItem Method

Overload List
Name | Description
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
DeleteOrderModifierItem(IOperationService, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderModifierItem Method (IOperationService, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials)

OperationServiceExtensionsDeleteOrderModifierItem Method (IOperationService, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderModifierItem(
    this IOperationService operationService,
    IOrder order,
    IOrderCompoundItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItem
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
DeleteOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderModifierItem Method (IOperationService, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials)

OperationServiceExtensionsDeleteOrderModifierItem Method (IOperationService, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderModifierItem(
    this IOperationService operationService,
    IOrder order,
    IOrderCompoundItemComponent orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
DeleteOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrderModifierItem Method (IOperationService, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials)

OperationServiceExtensionsDeleteOrderModifierItem Method (IOperationService, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials)

Deletes order item modifier from order item that represents the assortment position. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrderModifierItem(
    this IOperationService operationService,
    IOrder order,
    IOrderProductItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the item to be removed. Item must not be printed.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item that contains the modifier to be removed.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier to be removed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
DeleteOrderModifierItem Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeleteOrRestoreStreet Method

OperationServiceExtensionsDeleteOrRestoreStreet Method

Deletes street.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeleteOrRestoreStreet(
    this IOperationService operationService,
    bool delete,
    IStreet street,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
delete
Type: SystemBoolean
Delete or restore street flag. true - to delete, false - to restore.
street
Type: Resto.Front.Api.Data.BrdIStreet
Changing street
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeletePaymentItem Method

OperationServiceExtensionsDeletePaymentItem Method

Delete existing payment item from order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeletePaymentItem(
    this IOperationService operationService,
    IPaymentItem paymentItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be deleted.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order from which payment item will be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeletePreliminaryPaymentItem Method

OperationServiceExtensionsDeletePreliminaryPaymentItem Method

Delete existing preliminary payment item from order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeletePreliminaryPaymentItem(
    this IOperationService operationService,
    IPaymentItem paymentItem,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
paymentItem
Type: Resto.Front.Api.Data.PaymentsIPaymentItem
Payment item to be deleted.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Delivery order from which payment item will be deleted.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeletePrintedOrderItems Method

OperationServiceExtensionsDeletePrintedOrderItems Method

Deletes order items that is already printed. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeletePrintedOrderItems(
    this IOperationService operationService,
    string comment,
    WriteoffOptions writeoffOptions,
    IOrder order,
    IReadOnlyList<IOrderRootItem> orderItems,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
Comment to the charge-off. Max length - 255 chars.
writeoffOptions
Type: Resto.Front.Api.Data.OrdersWriteoffOptions
Object that describes how item should be removed and charged-off.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the items to be removed.
orderItems
Type: System.Collections.GenericIReadOnlyList IOrderRootItem
Order items to be removed. Items must be printed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.DeletePrintedOrderModifierItem Method

OperationServiceExtensionsDeletePrintedOrderModifierItem Method

Deletes order item modifier that is already printed. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void DeletePrintedOrderModifierItem(
    this IOperationService operationService,
    string comment,
    WriteoffOptions writeoffOptions,
    IOrder order,
    IOrderProductItem orderItemProduct,
    IOrderModifierItem orderModifierItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
comment
Type: SystemString
Comment to the charge-off. Max length - 255 chars.
writeoffOptions
Type: Resto.Front.Api.Data.OrdersWriteoffOptions
Object that describes how item should be removed and charged-off.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains the item to be removed. Item must not be printed.
orderItemProduct
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item that contains the modifier to be removed.Item must be prin /ted.
orderModifierItem
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Order item modifier to be removed. Modifier must be printed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.GroupOrderCookingItems Method

OperationServiceExtensionsGroupOrderCookingItems Method

Combines the order item products into mix group so that they will be cooked together. Only consecutive products of the same guest can be combined into mix group.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void GroupOrderCookingItems(
    this IOperationService operationService,
    IReadOnlyList<IOrderCookingItem> cookingItems,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cookingItems
Type: System.Collections.GenericIReadOnlyList IOrderCookingItem
Order item products to be cooked together.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which products will be combined into mix group.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.MarkOrderAsTab Method

OperationServiceExtensionsMarkOrderAsTab Method

Marks the order as tab and assignes tab name.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void MarkOrderAsTab(
    this IOperationService operationService,
    string tabName,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
tabName
Type: SystemString
Tab name to be assigned to the order.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to be marked as tab.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.MoveOrderItemToAnotherGuest Method

OperationServiceExtensionsMoveOrderItemToAnotherGuest Method

Moves product item between guests of the same order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void MoveOrderItemToAnotherGuest(
    this IOperationService operationService,
    IOrderRootItem product,
    IOrderGuestItem destinationGuest,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
product
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Product item to be moved.
destinationGuest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest the product item will be assigned to.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which contains the product.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.MoveOrderItemToAnotherOrder Method

OperationServiceExtensionsMoveOrderItemToAnotherOrder Method

Moves product item between orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void MoveOrderItemToAnotherOrder(
    this IOperationService operationService,
    IOrderRootItem orderItem,
    IOrder sourceOrder,
    IOrderGuestItem destinationGuest,
    IOrder destinationOrder,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderRootItem
Product item to be moved.
sourceOrder
Type: Resto.Front.Api.Data.OrdersIOrder
Order which currently contains the product.
destinationGuest
Type: Resto.Front.Api.Data.OrdersIOrderGuestItem
Guest the product item will be assigned to.
destinationOrder
Type: Resto.Front.Api.Data.OrdersIOrder
Order to move to.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.OverrideVatInclusionForOrder Method

OperationServiceExtensionsOverrideVatInclusionForOrder Method

Overrides default VAT inclusion settings for items of the specified order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void OverrideVatInclusionForOrder(
    this IOperationService operationService,
    IOrder order,
    ICredentials credentials,
    bool? isVatIncluded = null
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains items to override vat inclusion.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.
isVatIncluded (Optional)
Type: SystemNullable Boolean
Allows to override default VAT inclusion setting. Set true if VAT is included into prices or false if VAT should be added on top of the prices. Set null to use default VAT settings.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.RenameOrderGuest Method

OperationServiceExtensionsRenameOrderGuest Method

Renames order's guest.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void RenameOrderGuest(
    this IOperationService operationService,
    Guid id,
    string newName,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the guest to be renamed.
newName
Type: SystemString
New name of the guest.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to rename guest in.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ReopenReserve Method

OperationServiceExtensionsReopenReserve Method

Reopens previously closed or canceled reserve.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ReopenReserve(
    this IOperationService operationService,
    IReserve reserve,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Reserve to reopen.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ResetIsPrintedDeliveryBillActual Method

OperationServiceExtensionsResetIsPrintedDeliveryBillActual Method

Resets whether latest printed bill is actual to 'false' value. Use when you want delivery bill to be print again according to settings. For example, if you changed courier and wish to have actual name on the bill, call this action and delivery will automatically printed according to settings. On the contrary, if you don't want bill to be printed again (for example, courier is written to the bill later by hands), you have no need to call this action.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ResetIsPrintedDeliveryBillActual(
    this IOperationService operationService,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to reset whether its bill is considered to be actual.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ResetPriceCategory Method

OperationServiceExtensionsResetPriceCategory Method

Resets price category of the order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ResetPriceCategory(
    this IOperationService operationService,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to reset price category.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.ServeOrderCookingItem Method

OperationServiceExtensionsServeOrderCookingItem Method

Mark order item product as served.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void ServeOrderCookingItem(
    this IOperationService operationService,
    IOrderCookingItem cookingItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item product to mark as served. This item should be printed, but not served yet.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which product will be served.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetCompoundItemComponentCustomName Method

OperationServiceExtensionsSetCompoundItemComponentCustomName Method

Sets the custom name of the compound component. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetCompoundItemComponentCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderCompoundItemComponent compoundComponent,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the compound component or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing compound component.
compoundComponent
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Compound component which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetDeliveryCustomerAuthorizedInIikoBiz Method

OperationServiceExtensionsSetDeliveryCustomerAuthorizedInIikoBiz Method

Changes whether the client is already authorized in iiko.biz. WARNING: use with caution! Illegal value can lead to unsuccessful iiko.biz operations. Do NOT set this property to 'true' if you are not sure that all authorization properties are correct and customer is registered in iiko.biz; that will cause iiko.biz payment failure.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetDeliveryCustomerAuthorizedInIikoBiz(
    this IOperationService operationService,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetDeliveryDelivered Method

OperationServiceExtensionsSetDeliveryDelivered Method

Change delivery status to delivered.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetDeliveryDelivered(
    this IOperationService operationService,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change status.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetDeliveryUndelivered Method

OperationServiceExtensionsSetDeliveryUndelivered Method

Change delivery status to OnWay from status delivered.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetDeliveryUndelivered(
    this IOperationService operationService,
    IDeliveryOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
order
Type: Resto.Front.Api.Data.OrdersIDeliveryOrder
Order to change status.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOpenPrice Method

OperationServiceExtensionsSetOpenPrice Method

Changes order item open price.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetOpenPrice(
    this IOperationService operationService,
    decimal openPrice,
    IOrderProductItem productOrderItem,
    IOrder sourceOrder,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
openPrice
Type: SystemDecimal
New open price value.
productOrderItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item.
sourceOrder
Type: Resto.Front.Api.Data.OrdersIOrder
Order which currently contains the product.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOrderModifierItemCustomName Method

OperationServiceExtensionsSetOrderModifierItemCustomName Method

Overload List
Name | Description
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials) | Sets the custom name of the compound item common modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials) | Sets the custom name of the compound component modifier. User must have rights to edit orders.
SetOrderModifierItemCustomName(IOperationService, String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials) | Sets the custom name of the product item modifier. User must have rights to edit orders.
Top
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials)

OperationServiceExtensionsSetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderCompoundItem, IOrderModifierItem, ICredentials)

Sets the custom name of the compound item common modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetOrderModifierItemCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderCompoundItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItem
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials)

OperationServiceExtensionsSetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderCompoundItemComponent, IOrderModifierItem, ICredentials)

Sets the custom name of the compound component modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetOrderModifierItemCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderCompoundItemComponent compoundComponent,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
compoundComponent
Type: Resto.Front.Api.Data.OrdersIOrderCompoundItemComponent
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials)

OperationServiceExtensionsSetOrderModifierItemCustomName Method (IOperationService, String, IOrder, IOrderProductItem, IOrderModifierItem, ICredentials)

Sets the custom name of the product item modifier. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetOrderModifierItemCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderProductItem orderItem,
    IOrderModifierItem modifier,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the modifier or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing modifier.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Order item with changing modifier.
modifier
Type: Resto.Front.Api.Data.OrdersIOrderModifierItem
Modifier which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
SetOrderModifierItemCustomName Overload
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetOrderType Method

OperationServiceExtensionsSetOrderType Method

Sets order type for order.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetOrderType(
    this IOperationService operationService,
    IOrderType type,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
type
Type: Resto.Front.Api.Data.OrganizationIOrderType
Order type to set
order
Type: Resto.Front.Api.Data.OrdersIOrder
Existing order
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetProductItemCustomName Method

OperationServiceExtensionsSetProductItemCustomName Method

Sets the custom name of the product item. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetProductItemCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderProductItem orderItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the product item or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing product item.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderProductItem
Product item which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetServiceItemCustomName Method

OperationServiceExtensionsSetServiceItemCustomName Method

Sets the custom name of the service item. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetServiceItemCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderServiceItem orderItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the service item or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing service item.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderServiceItem
Service item which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SetServiceItemPeriodCustomName Method

OperationServiceExtensionsSetServiceItemPeriodCustomName Method

Sets the custom name of the service period. User must have rights to edit orders.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetServiceItemPeriodCustomName(
    this IOperationService operationService,
    string customName,
    IOrder order,
    IOrderServiceItem orderItem,
    IOrderServiceItemPeriod period,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
customName
Type: SystemString
New custom name of the service period or null to use default name.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order that contains element with changing service period.
orderItem
Type: Resto.Front.Api.Data.OrdersIOrderServiceItem
Service item with changing period.
period
Type: Resto.Front.Api.Data.OrdersIOrderServiceItemPeriod
Service period which custom name will be changed.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.SplitOrderCookingItem Method

OperationServiceExtensionsSplitOrderCookingItem Method

Cut off specified amount from product to new one.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderCookingItem SplitOrderCookingItem(
    this IOperationService operationService,
    decimal amount,
    IOrder order,
    IOrderCookingItem cookingItem,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
amount
Type: SystemDecimal
Amount to cut off. Source cooking item's amount will be reduced by this amount, resultant item will get this amount.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which contains the product.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Product to split.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IOrderCookingItem

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.StartBanquet Method

OperationServiceExtensionsStartBanquet Method

Transits banquet to the started status.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void StartBanquet(
    this IOperationService operationService,
    IReserve reserve,
    IUser waiter,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
reserve
Type: Resto.Front.Api.Data.BrdIReserve
Banquet to start. Banquet must have an order binding, otherwise call BindReserveToOrder(IOperationService, IReserve, IOrder, ICredentials) first.
waiter
Type: Resto.Front.Api.Data.SecurityIUser
Waiter who will serve the banquet.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.UngroupOrderCookingItems Method

OperationServiceExtensionsUngroupOrderCookingItems Method

Separates the order item products from mix group so that they will be cooked independently.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void UngroupOrderCookingItems(
    this IOperationService operationService,
    IReadOnlyList<IOrderCookingItem> cookingItems,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cookingItems
Type: System.Collections.GenericIReadOnlyList IOrderCookingItem
Order item products to be separated from mix group.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which products will be separated from mix group.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.UnserveOrderCookingItem Method

OperationServiceExtensionsUnserveOrderCookingItem Method

Mark order item product as unserved.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void UnserveOrderCookingItem(
    this IOperationService operationService,
    IOrderCookingItem cookingItem,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
cookingItem
Type: Resto.Front.Api.Data.OrdersIOrderCookingItem
Order item product to mark as unserved. This item should be served.
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order which product will be unserved.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


OperationServiceExtensions.UpdateOrderComboItems Method

OperationServiceExtensionsUpdateOrderComboItems Method

Update existing order combo items. Order must contain new combo items.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static IOrderCombo UpdateOrderComboItems(
    this IOperationService operationService,
    Guid id,
    IReadOnlyDictionary<Guid, IOrderCookingItem> comboItems,
    IOrder order,
    ICredentials credentials
)

Parameters

operationService
Type: Resto.Front.ApiIOperationService
Operation service.
id
Type: SystemGuid
Unique identifier of the existing combo.
comboItems
Type: System.Collections.GenericIReadOnlyDictionary Guid, IOrderCookingItem
Combo items dictionary. Key - combo group identifier, Value - item id (must be contained in order).
order
Type: Resto.Front.Api.Data.OrdersIOrder
Order to which combo will be added.
credentials
Type: Resto.Front.Api.Data.SecurityICredentials
Credentials of the user. Required to pass permission and some other checks, as well as execute personalized operations.

Return Value

Type: IOrderCombo

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOperationService. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

OperationServiceExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.ExtensionsPaymentDataContextExtensions

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class PaymentDataContextExtensions

The PaymentDataContextExtensions type exposes the following members.

Methods
Name | Description
GetCustomDataT | Method to get your custom data from iiko storage.
GetRollbackDataT | Method to get your rollback data from iiko storage.
SetCustomDataT | Method to set your custom data to store in iiko storage.
SetRollbackDataT | Method to set your rollback data to store in iiko storage. Data will be saved on disk after successful payment.
Top
Fields
Name | Description
MaxExternalPaymentItemDataLength | Max length of the external data to be saved inside an order in the string representation.
Top
See Also

Reference

Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions Methods

The PaymentDataContextExtensions type exposes the following members.

Methods
Name | Description
GetCustomDataT | Method to get your custom data from iiko storage.
GetRollbackDataT | Method to get your rollback data from iiko storage.
SetCustomDataT | Method to set your custom data to store in iiko storage.
SetRollbackDataT | Method to set your rollback data to store in iiko storage. Data will be saved on disk after successful payment.
Top
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions.GetCustomData(T) Method

PaymentDataContextExtensionsGetCustomDataT Method

Method to get your custom data from iiko storage.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static T GetCustomData<T>(
    this IPaymentDataContext context
)
where T : class

Parameters

context
Type: Resto.Front.ApiIPaymentDataContext
Payment data context.

Type Parameters

T
Should be SerializableAttribute public class.

Return Value

Type: T
Data that you previosly stored.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPaymentDataContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions.GetRollbackData(T) Method

PaymentDataContextExtensionsGetRollbackDataT Method

Method to get your rollback data from iiko storage.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static T GetRollbackData<T>(
    this IPaymentDataContext context
)
where T : class

Parameters

context
Type: Resto.Front.ApiIPaymentDataContext
Payment data context.

Type Parameters

T
Should be SerializableAttribute public class.

Return Value

Type: T
Rollback data that you previosly stored.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPaymentDataContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions.SetCustomData(T) Method

PaymentDataContextExtensionsSetCustomDataT Method

Method to set your custom data to store in iiko storage.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetCustomData<T>(
    this IPaymentDataContext context,
    T data
)
where T : class

Parameters

context
Type: Resto.Front.ApiIPaymentDataContext
Payment data context.
data
Type: T
Your custom data. Store any additional data here. Max serialized to string data length is MaxExternalPaymentItemDataLength.

Type Parameters

T
Should be SerializableAttribute public class.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPaymentDataContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions.SetRollbackData(T) Method

PaymentDataContextExtensionsSetRollbackDataT Method

Method to set your rollback data to store in iiko storage. Data will be saved on disk after successful payment.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static void SetRollbackData<T>(
    this IPaymentDataContext context,
    T data
)
where T : class

Parameters

context
Type: Resto.Front.ApiIPaymentDataContext
Payment data context.
data
Type: T
Your rollback data. Please save only data that you may need on operation rollback. Max serialized to string data length is MaxExternalPaymentItemDataLength.

Type Parameters

T
Should be SerializableAttribute public class.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPaymentDataContext. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions Fields

The PaymentDataContextExtensions type exposes the following members.

Fields
Name | Description
MaxExternalPaymentItemDataLength | Max length of the external data to be saved inside an order in the string representation.
Top
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


PaymentDataContextExtensions.MaxExternalPaymentItemDataLength Field

PaymentDataContextExtensionsMaxExternalPaymentItemDataLength Field

Max length of the external data to be saved inside an order in the string representation.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public const int MaxExternalPaymentItemDataLength = 5000

Field Value

Type: Int32
See Also

Reference

PaymentDataContextExtensions Class
Resto.Front.Api.Extensions Namespace


ServiceProviderExtensions Class

Extension methods for IServiceProvider.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.ExtensionsServiceProviderExtensions

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class ServiceProviderExtensions

The ServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetServiceT | Gets the service object of the specified type.
Top
See Also

Reference

Resto.Front.Api.Extensions Namespace


ServiceProviderExtensions Methods

The ServiceProviderExtensions type exposes the following members.

Methods
Name | Description
GetServiceT | Gets the service object of the specified type.
Top
See Also

Reference

ServiceProviderExtensions Class
Resto.Front.Api.Extensions Namespace


ServiceProviderExtensions.GetService(T) Method

ServiceProviderExtensionsGetServiceT Method

Gets the service object of the specified type.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static T GetService<T>(
    this IServiceProvider serviceProvider
)

Parameters

serviceProvider
Type: SystemIServiceProvider

Type Parameters

T

Return Value

Type: T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IServiceProvider. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ServiceProviderExtensions Class
Resto.Front.Api.Extensions Namespace


ViewManagerExtensions Class

Provides a set of static methods for executing view manager.
Inheritance Hierarchy
SystemObject
Resto.Front.Api.ExtensionsViewManagerExtensions

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static class ViewManagerExtensions

The ViewManagerExtensions type exposes the following members.

Methods
Name | Description
ShowChooserPopupT | Shows chooser dialog.
Top
See Also

Reference

Resto.Front.Api.Extensions Namespace


ViewManagerExtensions Methods

The ViewManagerExtensions type exposes the following members.

Methods
Name | Description
ShowChooserPopupT | Shows chooser dialog.
Top
See Also

Reference

ViewManagerExtensions Class
Resto.Front.Api.Extensions Namespace


ViewManagerExtensions.ShowChooserPopup(T) Method

ViewManagerExtensionsShowChooserPopupT Method

Shows chooser dialog.

Namespace: Resto.Front.Api.Extensions
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public static T ShowChooserPopup<T>(
    this IViewManager viewManager,
    string title,
    IList<T> input,
    Func<T, string> namingFunc,
    T selectedItem,
    ButtonWidth buttonWidth = ButtonWidth.Normal
)

Parameters

viewManager
Type: Resto.Front.Api.UIIViewManager
View manager.
title
Type: SystemString
Dialog title.
input
Type: System.Collections.GenericIList T
Items.
namingFunc
Type: SystemFunc T, String
Function to get object's name.
selectedItem
Type: T
Preselected item.
buttonWidth (Optional)
Type: Resto.Front.Api.UIButtonWidth
Button's width in dialog.

Type Parameters

T

Return Value

Type: T
Selected item.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IViewManager. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ViewManagerExtensions Class
Resto.Front.Api.Extensions Namespace


Resto.Front.Api.OperationContexts Namespace

Interfaces
 | Interface | Description
Public interface | INavigatingToPaymentScreenOperationContext | Context of the NavigatingToPaymentScreen notification.


INavigatingToPaymentScreenOperationContext Interface

Context of the NavigatingToPaymentScreen notification.

Namespace: Resto.Front.Api.OperationContexts
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface INavigatingToPaymentScreenOperationContext

The INavigatingToPaymentScreenOperationContext type exposes the following members.

Properties
 | Name | Description
Public property | ChequeAdditionalInfo | You can read or write initial value of the cheque additional info which will be used on the the payment screen.
Top
See Also

Reference

Resto.Front.Api.OperationContexts Namespace


INavigatingToPaymentScreenOperationContext Properties

The INavigatingToPaymentScreenOperationContext type exposes the following members.

Properties
 | Name | Description
Public property | ChequeAdditionalInfo | You can read or write initial value of the cheque additional info which will be used on the the payment screen.
Top
See Also

Reference

INavigatingToPaymentScreenOperationContext Interface
Resto.Front.Api.OperationContexts Namespace


INavigatingToPaymentScreenOperationContext.ChequeAdditionalInfo Property

INavigatingToPaymentScreenOperationContextChequeAdditionalInfo Property

You can read or write initial value of the cheque additional info which will be used on the the payment screen.

Namespace: Resto.Front.Api.OperationContexts
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
ChequeAdditionalInfo ChequeAdditionalInfo { get; set; }

Property Value

Type: ChequeAdditionalInfo
Remarks
In case of multiple plugins/handlers subscribed to the navigating to payment screen event, they will be called sequentially and all of them will have access to the same context, so each will be able to overwrite the value from previous one.
See Also

Reference

INavigatingToPaymentScreenOperationContext Interface
Resto.Front.Api.OperationContexts Namespace


Resto.Front.Api.RemotingHelpers Namespace

Classes
 | Class | Description
Public class | DisconnectableMarshalByRefObject |


DisconnectableMarshalByRefObject Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
Resto.Front.Api.RemotingHelpersDisconnectableMarshalByRefObject

Namespace: Resto.Front.Api.RemotingHelpers
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public abstract class DisconnectableMarshalByRefObject : MarshalByRefObject,
    IDisposable

The DisconnectableMarshalByRefObject type exposes the following members.

Constructors
 | Name | Description
Protected method | DisconnectableMarshalByRefObject | Initializes a new instance of the DisconnectableMarshalByRefObject class
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Overrides MarshalByRefObjectInitializeLifetimeService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.RemotingHelpers Namespace


DisconnectableMarshalByRefObject Constructor

Initializes a new instance of the DisconnectableMarshalByRefObject class

Namespace: Resto.Front.Api.RemotingHelpers
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected DisconnectableMarshalByRefObject()
See Also

Reference

DisconnectableMarshalByRefObject Class
Resto.Front.Api.RemotingHelpers Namespace


DisconnectableMarshalByRefObject Methods

The DisconnectableMarshalByRefObject type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Overrides MarshalByRefObjectInitializeLifetimeService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DisconnectableMarshalByRefObject Class
Resto.Front.Api.RemotingHelpers Namespace


DisconnectableMarshalByRefObject.Dispose Method

DisconnectableMarshalByRefObjectDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Resto.Front.Api.RemotingHelpers
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public void Dispose()

Implements

IDisposableDispose
See Also

Reference

DisconnectableMarshalByRefObject Class
Resto.Front.Api.RemotingHelpers Namespace


DisconnectableMarshalByRefObject.InitializeLifetimeService Method

DisconnectableMarshalByRefObjectInitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Namespace: Resto.Front.Api.RemotingHelpers
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public override Object InitializeLifetimeService()

Return Value

Type: Object
An object of type ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the LeaseManagerPollTime property.
Exceptions
Exception | Condition
SecurityException | The immediate caller does not have infrastructure permission.
See Also

Reference

DisconnectableMarshalByRefObject Class
Resto.Front.Api.RemotingHelpers Namespace


Resto.Front.Api.UI Namespace

Classes
 | Class | Description
Public class | ExtendedInputDialogSettings |
Interfaces
 | Interface | Description
Public interface | IViewManager | Interface for displaying data input dialog. Can be null in a background context, where is no UI.
Enumerations
 | Enumeration | Description
Public enumeration | ButtonWidth | Button width in ShowChooserPopup(String, IListString, Int32, ButtonWidth).


ButtonWidth Enumeration

Button width in ShowChooserPopup(String, IListString, Int32, ButtonWidth).

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public enum ButtonWidth
Members
Member name | Value | Description
Wider | 1 | Dialog will fit up to 1 column.
Wide | 2 | Dialog will fit up to 2 columns.
Normal | 3 | Dialog will fit up to 3 columns.
Narrow | 4 | Dialog will fit up to 4 columns.
Narrower | 5 | Dialog will fit up to 5 columns.
Supernarrow | 6 | Dialog will fit up to 6 columns.
Default | 3 | Dialog fits up to 3 columns is default.
See Also

Reference

Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Class

Inheritance Hierarchy
SystemObject
Resto.Front.Api.UIExtendedInputDialogSettings

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
[SerializableAttribute]
public class ExtendedInputDialogSettings : ISerializable

The ExtendedInputDialogSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedInputDialogSettings | Initializes a new instance of the ExtendedInputDialogSettings class
Protected method | ExtendedInputDialogSettings(SerializationInfo, StreamingContext) | Initializes a new instance of the ExtendedInputDialogSettings class
Top
Properties
 | Name | Description
Public property | EnableBarcode | To get barcode. Numpad with barcode window will be shown.
Public property | EnableCardSlider | To get card track. Enable card slide listener.
Public property | EnableNumericString | To get numeric string. Numpad with numeric string window will be shown.
Public property | EnablePhone | To get phone number. Numpad window with phone formatter will be shown.
Public property | TabTitleBarcode | Hint to barcode.
Public property | TabTitleNumericString | Hint to numeric string.
Public property | TabTitlePhone | Hint to phone number.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Constructor

Overload List
 | Name | Description
Public method | ExtendedInputDialogSettings | Initializes a new instance of the ExtendedInputDialogSettings class
Protected method | ExtendedInputDialogSettings(SerializationInfo, StreamingContext) | Initializes a new instance of the ExtendedInputDialogSettings class
Top
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Constructor

Initializes a new instance of the ExtendedInputDialogSettings class

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public ExtendedInputDialogSettings()
See Also

Reference

ExtendedInputDialogSettings Class
ExtendedInputDialogSettings Overload
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ExtendedInputDialogSettings class

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
protected ExtendedInputDialogSettings(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

ExtendedInputDialogSettings Class
ExtendedInputDialogSettings Overload
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Properties

The ExtendedInputDialogSettings type exposes the following members.

Properties
 | Name | Description
Public property | EnableBarcode | To get barcode. Numpad with barcode window will be shown.
Public property | EnableCardSlider | To get card track. Enable card slide listener.
Public property | EnableNumericString | To get numeric string. Numpad with numeric string window will be shown.
Public property | EnablePhone | To get phone number. Numpad window with phone formatter will be shown.
Public property | TabTitleBarcode | Hint to barcode.
Public property | TabTitleNumericString | Hint to numeric string.
Public property | TabTitlePhone | Hint to phone number.
Top
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.EnableBarcode Property

ExtendedInputDialogSettingsEnableBarcode Property

To get barcode. Numpad with barcode window will be shown.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool EnableBarcode { get; set; }

Property Value

Type: Boolean
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.EnableCardSlider Property

ExtendedInputDialogSettingsEnableCardSlider Property

To get card track. Enable card slide listener.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool EnableCardSlider { get; set; }

Property Value

Type: Boolean
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.EnableNumericString Property

ExtendedInputDialogSettingsEnableNumericString Property

To get numeric string. Numpad with numeric string window will be shown.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool EnableNumericString { get; set; }

Property Value

Type: Boolean
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.EnablePhone Property

ExtendedInputDialogSettingsEnablePhone Property

To get phone number. Numpad window with phone formatter will be shown.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public bool EnablePhone { get; set; }

Property Value

Type: Boolean
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.TabTitleBarcode Property

ExtendedInputDialogSettingsTabTitleBarcode Property

Hint to barcode.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TabTitleBarcode { get; set; }

Property Value

Type: String
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.TabTitleNumericString Property

ExtendedInputDialogSettingsTabTitleNumericString Property

Hint to numeric string.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TabTitleNumericString { get; set; }

Property Value

Type: String
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.TabTitlePhone Property

ExtendedInputDialogSettingsTabTitlePhone Property

Hint to phone number.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public string TabTitlePhone { get; set; }

Property Value

Type: String
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings Methods

The ExtendedInputDialogSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


ExtendedInputDialogSettings.GetObjectData Method

ExtendedInputDialogSettingsGetObjectData Method

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ExtendedInputDialogSettings Class
Resto.Front.Api.UI Namespace


IViewManager Interface

Interface for displaying data input dialog. Can be null in a background context, where is no UI.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
public interface IViewManager

The IViewManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeProgressBarMessage | Changes the message of progress bar.
Public method | ShowChooserPopup | Shows chooser dialog.
Public method | ShowClosePopup | Shows dialog with single "Close" button.
Public method | ShowErrorPopup | Shows dialog with single "Close" button.
Public method | ShowExtendedInputDialog | Shows extended input dialog.
Public method | ShowExtendedKeyboardDialog | Shows "Keyboard" dialog.
Public method | ShowInputDialog | Shows input dialog.
Public method | ShowKeyboard | Shows "Keyboard" dialog.
Public method | ShowOkCancelPopup | Shows "OK"/"Cancel" dialog.
Public method | ShowOkPopup | Shows dialog with single "OK" button.
Public method | ShowQuantityChangerPopup | Shows quantity changer dialog.
Public method | ShowRetryCancelPopup | Shows "Retry"/"Cancel" dialog.
Public method | ShowRetryIgnoreCancelPopup | Shows "Retry"/"Ignore"/"Cancel" dialog.
Public method | ShowYesNoCancelPopup | Shows "Yes"/"No"/"Cancel" dialog.
Public method | ShowYesNoPopup | Shows "Yes"/"No" dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | ShowChooserPopupT | Shows chooser dialog. (Defined by ViewManagerExtensions.)
Top
Exceptions
Exception | Condition
NullReferenceException |
See Also

Reference

Resto.Front.Api.UI Namespace


IViewManager Methods

The IViewManager type exposes the following members.

Methods
 | Name | Description
Public method | ChangeProgressBarMessage | Changes the message of progress bar.
Public method | ShowChooserPopup | Shows chooser dialog.
Public method | ShowClosePopup | Shows dialog with single "Close" button.
Public method | ShowErrorPopup | Shows dialog with single "Close" button.
Public method | ShowExtendedInputDialog | Shows extended input dialog.
Public method | ShowExtendedKeyboardDialog | Shows "Keyboard" dialog.
Public method | ShowInputDialog | Shows input dialog.
Public method | ShowKeyboard | Shows "Keyboard" dialog.
Public method | ShowOkCancelPopup | Shows "OK"/"Cancel" dialog.
Public method | ShowOkPopup | Shows dialog with single "OK" button.
Public method | ShowQuantityChangerPopup | Shows quantity changer dialog.
Public method | ShowRetryCancelPopup | Shows "Retry"/"Cancel" dialog.
Public method | ShowRetryIgnoreCancelPopup | Shows "Retry"/"Ignore"/"Cancel" dialog.
Public method | ShowYesNoCancelPopup | Shows "Yes"/"No"/"Cancel" dialog.
Public method | ShowYesNoPopup | Shows "Yes"/"No" dialog.
Top
Extension Methods
 | Name | Description
Public Extension Method | ShowChooserPopupT | Shows chooser dialog. (Defined by ViewManagerExtensions.)
Top
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ChangeProgressBarMessage Method

IViewManagerChangeProgressBarMessage Method

Changes the message of progress bar.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ChangeProgressBarMessage(
    string message
)

Parameters

message
Type: SystemString
New message.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowChooserPopup Method

IViewManagerShowChooserPopup Method

Shows chooser dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
int ShowChooserPopup(
    string title,
    IList<string> input,
    int selectedItemIndex = -1,
    ButtonWidth buttonWidth = ButtonWidth.Normal
)

Parameters

title
Type: SystemString
Dialog title.
input
Type: System.Collections.GenericIList String
Items.
selectedItemIndex (Optional)
Type: SystemInt32
Preselected item index.
buttonWidth (Optional)
Type: Resto.Front.Api.UIButtonWidth
Button's width in dialog.

Return Value

Type: Int32
Selected item index.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowClosePopup Method

IViewManagerShowClosePopup Method

Shows dialog with single "Close" button.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ShowClosePopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowErrorPopup Method

IViewManagerShowErrorPopup Method

Shows dialog with single "Close" button.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ShowErrorPopup(
    string message
)

Parameters

message
Type: SystemString
Message text.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowExtendedInputDialog Method

IViewManagerShowExtendedInputDialog Method

Shows extended input dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IInputDialogResult ShowExtendedInputDialog(
    string title,
    string hint,
    ExtendedInputDialogSettings settings
)

Parameters

title
Type: SystemString
Dialog title.
hint
Type: SystemString
Hint to show to the user.
settings
Type: Resto.Front.Api.UIExtendedInputDialogSettings
Expected input types settings. Dialog will contain separate tab for each enabled input type, so you should provide tab titles for enabled input types.

Return Value

Type: IInputDialogResult
Dialog result. Depending on settings and user input it could be one of IInputDialogResult inheritors. Use pattern matching to find out specific result type.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace
IViewManagerShowInputDialog(String, InputDialogTypes, NullableInt32)


IViewManager.ShowExtendedKeyboardDialog Method

IViewManagerShowExtendedKeyboardDialog Method

Shows "Keyboard" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IInputDialogResult ShowExtendedKeyboardDialog(
    string title,
    string initialText = "",
    bool isMultiline = true,
    int maxLength = 2147483647,
    bool capitalize = false,
    bool isPassword = false,
    bool enableCardSlider = false,
    bool enableBarcode = false
)

Parameters

title
Type: SystemString
Dialog title.
initialText (Optional)
Type: SystemString
Initial text.
isMultiline (Optional)
Type: SystemBoolean
Is multiline input supported.
maxLength (Optional)
Type: SystemInt32
Max input length.
capitalize (Optional)
Type: SystemBoolean
Automatic words capitalization.
isPassword (Optional)
Type: SystemBoolean
Input is password.
enableCardSlider (Optional)
Type: SystemBoolean
Enable Card slider input.
enableBarcode (Optional)
Type: SystemBoolean
Enable Barcode input.

Return Value

Type: IInputDialogResult
Dialog result. Depending on arguments and user input it could be CardInputDialogResult, StringInputDialogResult or BarcodeInputDialogResult.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowInputDialog Method

IViewManagerShowInputDialog Method

Shows input dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IInputDialogResult ShowInputDialog(
    string title,
    InputDialogTypes type,
    int? initialValue = null
)

Parameters

title
Type: SystemString
Dialog title.
type
Type: Resto.Front.Api.Data.ViewInputDialogTypes
Input types. Can be used as flags.
initialValue (Optional)
Type: SystemNullable Int32
Initial value. Used if type contains Number flag.

Return Value

Type: IInputDialogResult
Dialog result. Depending on type argument and user input it could be CardInputDialogResult or NumberInputDialogResult.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace
IViewManagerShowExtendedInputDialog(String, String, ExtendedInputDialogSettings)


IViewManager.ShowKeyboard Method

IViewManagerShowKeyboard Method

Shows "Keyboard" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
string ShowKeyboard(
    string title,
    string initialText = "",
    bool isMultiline = true,
    int maxLength = 2147483647,
    bool capitalize = false,
    bool isPassword = false
)

Parameters

title
Type: SystemString
Dialog title.
initialText (Optional)
Type: SystemString
Initial text.
isMultiline (Optional)
Type: SystemBoolean
Is multiline input supported.
maxLength (Optional)
Type: SystemInt32
Max input length.
capitalize (Optional)
Type: SystemBoolean
Automatic words capitalization.
isPassword (Optional)
Type: SystemBoolean
Input is password.

Return Value

Type: String
Entered string or null if cancelled.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowOkCancelPopup Method

IViewManagerShowOkCancelPopup Method

Shows "OK"/"Cancel" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ShowOkCancelPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.

Return Value

Type: Boolean
true if "OK".
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowOkPopup Method

IViewManagerShowOkPopup Method

Shows dialog with single "OK" button.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
void ShowOkPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowQuantityChangerPopup Method

IViewManagerShowQuantityChangerPopup Method

Shows quantity changer dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
IReadOnlyCollection<int> ShowQuantityChangerPopup(
    string title,
    string text,
    int minimalQuantity,
    int maximalQuantity,
    IReadOnlyCollection<(string name, int quantity, int minimalQuantity, int maximalQuantity)> items
)

Parameters

title
Type: SystemString
Dialog title.
text
Type: SystemString
Dialog hint text.
minimalQuantity
Type: SystemInt32
Minimal quantity for all items.
maximalQuantity
Type: SystemInt32
Maximal quantity for all items.
items
Type: System.Collections.GenericIReadOnlyCollection ValueTuple String, Int32, Int32, Int32
Items which quantity needs to be changed.

Return Value

Type: IReadOnlyCollection Int32
Actual quantities.
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowRetryCancelPopup Method

IViewManagerShowRetryCancelPopup Method

Shows "Retry"/"Cancel" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ShowRetryCancelPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.

Return Value

Type: Boolean
true if "Retry".
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowRetryIgnoreCancelPopup Method

IViewManagerShowRetryIgnoreCancelPopup Method

Shows "Retry"/"Ignore"/"Cancel" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool? ShowRetryIgnoreCancelPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.

Return Value

Type: Nullable Boolean
true if "Retry", false if "Ignore", null if "Cancel".
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowYesNoCancelPopup Method

IViewManagerShowYesNoCancelPopup Method

Shows "Yes"/"No"/"Cancel" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool? ShowYesNoCancelPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.

Return Value

Type: Nullable Boolean
true if "Yes", false if "No", null if "Cancel".
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace


IViewManager.ShowYesNoPopup Method

IViewManagerShowYesNoPopup Method

Shows "Yes"/"No" dialog.

Namespace: Resto.Front.Api.UI
Assembly: Resto.Front.Api.V7Preview7 (in Resto.Front.Api.V7Preview7.dll) Version: 1ca4876affdd3bc5359a98b321fc115a647d2251
Syntax
C#
Copy
bool ShowYesNoPopup(
    string title,
    string message
)

Parameters

title
Type: SystemString
Dialog title.
message
Type: SystemString
Message text.

Return Value

Type: Boolean
true if "Yes".
See Also

Reference

IViewManager Interface
Resto.Front.Api.UI Namespace